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Introduction

To all residents of the European Union Important environmental information about this product This symbol on the
device or the package indicates that disposal of the device after its lifecycle could harm the environment. Do not
dispose of the unit (or batteries) as unsorted municipal waste; it should be taken to a specialized company for
recycling. This device should be returned to your distributor or to a local recycling service. Respect the local
environmental rules. If in doubt, contact your local waste disposal authorities. Thank you for choosing Whadda!
Please read the manual thoroughly before bringing this device into service. If the device was damaged in transit,
do not install or use it and contact your dealer.

Safety Instructions

« Read and understand this manual and all safety signs before using this appliance.

« Forindoor use only.

« This device can be used by children aged from 8 years and above, and persons with reduced physical, sensory
or mental capabilities or lack of experience and knowledge if they have been given supervision or instruction
concerning the use of the device in a safe way and understand the hazards involved. Children shall not play

with the device. Cleaning and user maintenance shall not be made by children without supervision.
General Guidelines

« Refer to the Velleman® Service and Quality Warranty on the last pages of this manual.

« All modifications of the device are forbidden for safety reasons. Damage caused by user modifications to the
device is not covered by the warranty.

« Only use the device for its intended purpose. Using the device in an unauthorised way will void the warranty.

« Damage caused by disregard of certain guidelines in this manual is not covered by the warranty and the dealer
will not accept responsibility for any ensuing defects or problems.

« Nor Velleman nv nor its dealers can be held responsible for any damage (extraordinary, incidental or indirect) —
of any nature (financial, physical...) arising from the possession, use or failure of this product.

« Keep this manual for future reference.

What is Arduino®



Arduino® is an open-source prototyping platform based on easy-to-use hardware and software. Arduino® boards
are able to read inputs — light-on sensor, a finger on a button or a Twitter message —and turn it into an output —
activating of a motor, turning on an LED, publishing something online. You can tell your board what to do by
sending a set of instructions to the microcontroller on the board. To do so, you use the Arduino programming
language (based on Wiring) and the Arduino® software IDE (based on Processing). Additional
shields/modules/components are required for reading a twitter message or publishing online. Surf to
www.arduino.cc for more information

Product overview

The Whadda WPB109 ESP32 development board is a comprehensive development platform for Espressif's
ESP32, the upgraded cousin of the popular ESP8266. Like the ESP8266, the ESP32 is a WiFi-enabled
microcontroller, but to that it adds support for Bluetooth low-energy (i.e BLE, BT4.0, Bluetooth Smart), and 28 I/O
pins. The ESP32’s power and versatility makes it the ideal candidate to serve as the brains of your next loT
project.

Specifications

Chipset: ESPRESSIF ESP-WROOM-32 CPU: Xtensa dual-core (or single-core) 32-bit LX6 microprocessor
Co-CPU: ultra low power (ULP) co-processor GPIO Pins 28

Memory:

o RAM: 520 KB of SRAM ROM: 448 KB
Wireless connectivity:

o WIiFi: 802.11 b/g/n

o Bluetooth®: v4.2 BR/EDR and BLE

Power management:

o max. current consumption: 300 mA

o Deep sleep power consumption: 10 pA

o max. battery input voltage: 6 V

o max. battery charge current: 450 mA

o Dimensions (W x L x H): 27.9 x 54.4.9 x 19mm

Functional overview

3.3 V Regulator

EN Button

Micro USB Port ———@ &' sl T AR ESP32-WROOM-32

USB-to-UART Bridge


http://www.arduino.cc

Key Component

Description

ESP32-WROOM-32

A module with ESP32 at its core.

EN Button

Reset button

Boot Button

Download button.

Holding down Boot and then pressing EN initiates Firm
ware Download mode for downloading firmware throu
gh the serial port.

USB-to-UART Bridge

Converts USB into UART serial in order to facilitate th
e communication between the ESP32

and pc

Micro USB Port

USB interface. Power supply for the board as well as t
he communication interface between a

computer and the ESP32 module.

3.3 V Regulator

Converts 5 V from USB to 3.3 V needed to supply

the ESP32 module
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Getting started

Installing the required software
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1. First, make sure you have the latest version of the Arduino IDE installed on your computer. You can download

the latest version by going to www.arduino.cc/en/software.

2. Open the Arduino IDE, and open the preferences menu by going to File > Preferences. Enter the following URL
into the “Additional Boards Manager URLs” field:

https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package esp32_index.json , and

Preferences X
Settings = Network

Sketchbook location:

C: \Lisersﬁdas‘buments\,ﬂ.rduinol Browse
Editor language: System Default ~ | (requires restart of Arduing)
Editor font size: 14
Interface scale: [~] Automatic = 100 7 % (requires restart of Arduino)
Thame: Default theme - | (requires restart of Arduing)
Show verbose output during; ] compilation upload
Compiler warnings: MNone .

Display line numbers [[] Enable Code Folding

Verify code after upload [[] Use external editor

[+] Check for updates on startup [+ Save when verifying or uploading

[ ] Use accesshility features

Additional Boards Manager URLs: son,https:/fraw.githubusercontent. comfespressif farduino-esp32/gh-pagespackage_esp32_index.json ﬁ
More preferences can be edited directly in the file
C:\Users\midas \AppData'Local \rduino 15\preferances, bt

T B m .
edit only VEM ArgLEng Ot running

hit “OK”.
3. Open the Boards Manager from Tools > Board menu and install the esp32 platform by putting ESP32 into the

search field, selecting the most recent version of the esp32 core (by Espressif Systems), and clicking “Install”.

@ Boards Manager X
Type Al « | [ESP32
esp32 2

by Espressif Systems
Boards included in this package:
ESP32 Dev Module, WEMOS LoLin32, WEMOS D1 MINI ESP32.

More Info

Close

Uploading the first sketch to the board


http://www.arduino.cc/en/software
https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json

4. Once the ESP32 core has been installed, open the tools menu and select the ESP32 Dev module board by
going to: Tools > Board:”...” > ESP32 Arduino > ESP32 Dev Module

@ SimpleWiFiServer | Arduine 1.8.13
File Edit Sketch Tools Help

Auto Format
Archive Sketch
Fix Encoding & Reload

SimpleWiFiSel

Manage Libraries...
Serial Manitor
Serial Plotter

WiFi101 / WiFiNINA Firrware Updater

ESP32 Sketch Data Upload
ESP8266 LittleFS Data Upload

------ Board: "Arduino Uno®
Port: "COM14"

Get Board Info

Ser] Programmer: "USBasp”

pint Burn Bootloader

ielay (10);

Ctrl+T

Ctrl+Shift+|
Ctrl+5Shift+ M
Ctrl+Shift+L

Boards Manager...

Arduino ARM (32-bits) Boards
Arduino AVR Boards

Arduino megaAVR Boards
ESP32 Arduino

ESPA266 Boards (2.7.4)

STM32F1 Boards (STM32duine.com)

>

A

ESP32 Dev Module

ESP32 Wrover Module

ESP32 Pico Kit

TinyPICO

MagicBit

Turta loT Node

TTGO LoRa32-0OLED V1
TGO

XinaBox CW02

SparkFun ESP32 Thing
u-blox NINA-W10 series (ESP32)
Widera AIR

Electronic SweetPeas - ESP320
Nano32

LOLIN D32

LOLIN D32 PRO

WEMOS LOLIN32

Dongsen Tech Pocket 32
WeMos WiFi&Bluetooth Battery
ESPea32

Noduine Quantum

Node3dZs

Hombill ESP32 Dev

Hombill ESP32 Minima
FireBeetle-ESP32

IntoRaobot Fig

Onehorse ESP32 Dev Module
Adafruit ESP32 Feather
NodeMCL-325

MH ET LIVE ESP32DevKIT
MH ET LIVE ESP32Minikit
ESP32vn loT Uno

DOIT ESP32 DEVKIT V1
OLIMEX ESP32-EVB

5. Connect the Whadda ESP32 module to your pc using a micro USB cable. Open the tools menu again and

check if a new serial port has been added to the port list and select it (Tools > Port:”...” > ). If this is not the

case, you may need to install a new driver to enable the ESP32 to properly connect to your computer.

Go to https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers to download and install the
driver. Reconnect the ESP32 and restart the Arduino IDE once he process has finished.


https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers

@ SimpleWiFiServer | Arduino 1.8.13 - =] X

File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
SimpleWiFiSel  Fix Encoding & Reload
25 Manage Libraries... Ctrl+Shift+1
26 Serial Monitor Ctrl+Shift+M
27 Serial Plotter Ctrl+Shift+L

28 #includdq
29 WiFi101 / WiFiNINA Firmware Updater
onst cl

ESP32 Sketch Data Upload
onst cli

ESP8266 LittleFS Data Upload

33 WiFisSery Board: "ESP32 Dev Module"

34 Upload Speed: "256000"

% CPU Frequency: “240MHz (WiFi/BT)"
Flash Frequency: "80MHz"

Flash Mode: "QI0"

Flash Size: "4MB (32Mb)"

Partition Scheme: “Default 4MB with spiffs (1.2MB APP/1.5MB SPIFFS)"
Core Debug Level "None"

PSRAM: "Disabled”

Port: "COM14"

Get Board Info

BCePOLNOOPOE 6

RO COS 205 TH00OND ZI0n w108 £201 9201 S201 coon 20l

Serial ports

]
:

v v v v v v v v v v

Programmer

Burn Bootloader

Boot button

6. Check that the following settings have been selected in the tools board menu:

Auto Format Ctrl+T
Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+1
Senal Monitor Ctrl+Shift+M
Senal Plotter Ctrl+ Shift+L

WiFi101 / WiFiNINA Firmware Updater

ESP32 Sketch Data Upload

ESPB266 LittleFS Data Upload

Board: "ESP32 Dev Module” >
Upleoad 5peed: "256000" >
CPU Frequency: "240MHz (WiFi/BT)" b
Flash Frequency: “80MHz" »
Flash Mode: "QI0" »
Flash Size: "4MB (32Mb)” >
Partition Scheme: "Default 4MB with spiffs (1.2MB APP/1.5MB SPIFF5)" »
Core Debug Level: “None” »
PSRAM: "Disabled” -
Port: "COM14" )

Get Board Info

Programmer »

Burn Bootloader

7. Select an example sketch from the “Examples for ESP32 Dev Module” in File > Examples. We recommend to
run the example called “GetChiplD” as a starting point, which can be found under File > Examples > ESP32 >
ChiplD.



& GetChiplD | Arduino 1.8.13 - O x
File Edit Sketch Tools Help _
New Ctrl+N A

Open... Ctrl+0 Temboo

Open Recent ; WiFi101

Sketchbook ; RETIRED

mmples | Examples for ESP32 Dev Module

Close Ctrl+W ArduinoOTA s

save culs BluetoothSerial >

Save As... Ctrl+Shift+S DNSServer .

Page Setup  Ctrl+5Shift+P EEPROM > |

Print Ctrl+P ESP32 ) AnalogOut > ad
ESP32 Async UDP 3 Camera >/ /p

Preferences Ctrl+Comma : | 2 5
ESP32 Azure loT Arduino 1 ChiplD . GetChiplD

Quit Ctrl+Q ESP32 BLE Arduino 1 DeepSleep  » .
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|

-

8. Click the Upload button (
“Connecting...” appears, press and hold the Boot button on the ESP32 until the uploading process has

finished.

), and monitor the info messages at the bottom. Once the message

ESP32 Dev Module on COM14

Press and hold Boot button

ESP32 Dev Module on COM14

Release Boot button

9. Open the serial monitor ( @) and check that the baudrate is set to 115200 baud:



[ Autoscroll [ Show timestamp Newine vfl'ﬁsimbaud v!'_t:lwwtput |

10. Press the Reset/EN button, debug messages should start appearing on the serial monitor, together with the

Chip ID (If the GetChipID example was uploaded).
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EN button



-c= COM14 O

ets Jun 8 2016 00:22:57 4]

rst:0xl (POWERON_RESET),boot:0x13 (SPI_FAST FLASH BOOT)

configsip: 0, SPIWP:Oxee

clk drv:0x00,q drv:0x00,d dev:0x00,ca0 drv:0x00,hd drv:0x00,wp drv:0x00
mode:DIO, clock diw:l

load:;0x3£££0018, 1en: 4

load: 0x3£££001c, len:1216

ho 0 tail 12 room 4

load: 0x40078000, len: 9720

hoe 0 tail 12 room 4

load:0x40080400, len: 6352

entry 0x40080&b8

ESP32 Chip ID = e0E71312CFA4

ESP32 Chip ID = 60E71312CFA4

ESP32 Cchip ID — 60E71312CFR4 W

[] Autoscroll [] Show tmestamp Newline v | [115200baud + | Clear output

3.3 V Regulator

Micro USB Port ———® &% sl itee - IER RAES 4 ESP32-WROOM-32

Boot Button

USB-to-UART Bridge

Having trouble?

Restart the Arduino IDE and reconnect the ESP32 board. You can check if the driver has been properly installed
by checking Device manager on Windows under COM Ports to see if a Silicon Labs CP210x device is recognized.
Under Mac OS you can run the command Is /dev/{tty,cu}.* in the terminal to check this.

WiFi connection example

The ESP32 really shines in applications where WiFi connectivity is required. The following example will harness
this extra functionality by having the ESP module function as a basic webserver.

1. Open the Arduino IDE, and open the AdvancedWebServer example by going to File > Examples > WebServer
> AdvancedWebServer



& sdvancedWebServer | Arduing 1.8.13

Mew

I:}PIEI'I...
Open Recent
Sketchbook
Examples
Close

Save

Save As..

Page Setup

Print

Preferences

Cuit

File Edt Sketch Tools Help

Ctri+ M
Ctrl+ 0

Ctrl=W
Ctrl+5
Ctrl+ Shift+5

Ctrl« Shift+P
Ctrl+P

Ctr+ Comma

Ctri+

1ilfs @ 2B APPI SME SPIFFSL. 240MF

s

Adafruit Circurt Playground

Brdge
Ethernet
Firmata
LiguidCrystal
MTPClient

sD

Stepper
Temboo
Wikl
RETIRED

Exarmples for ESP32 Dev Module

Arduino0TA
BluetoothSerial
DrSServer
EEPROM

E5P32

ESP32 Async UDP
ESP32 Azure loT Arduing
ESP32 BLE Arduino
ESPmDME

FFat

HTTPClient
HTTPUpdate
MetBIOS
Preferences
SD{esp3d)
S0_MMC
SirmpleBLE

|

SPIFFS

Ticker

Update
WebServer

Wik

AdvancediWebhServer
FSBrowses

HellaSener
HitpAdvancedAuth
HitpBasicAuth
PathArgServer
SDWebServer
Simplefuthentification
Webllpdate

2. Replace YourSSIDHere with your own WiFi network name, and replace YourPSKHere with your WiFi network

password.



L8]

Ad

L

Lad

3. Connect your ESP32 to your pc (if you haven’t already), and make sure that the correct board settings in the

Tools menu are set and that the proper serial communication port has been selected.

4. Click the Upload button (.), and monitor the info messages at the bottom. Once the message
“Connecting...” appears, press and hold the Boot button on the ESP32 until the uploading process has
finished.

Tw

wn

o

(-

$#include
$include
$include

$#include

<WiFi.h>
<WiFiClient.h>
<WebServer.h>
<ESPmDNS . h>

const char *ssid = "YourSSIDHere";

const char *password = "YourPSKHere";

Auto Format

Archive Sketch

Fix Encoding & Reload
Manage Libranes..,
Serial Monitor

Serial Plotter

WiFiI101 £ WAFiNINA Firmware Updater

E5P32 Sketch Data Upload
E5SP8266 LittleF5 Data Upload

Board: "ESP32 Dev Module"

Upload Speed: "256000"

CPU Frequency: “240MHz (WiFi/BT)"

Flash Frequency: "B0MHz"

Flash Mode: "QIO"

Flash Size: "4MB (32Mb)"

Partition Scheme: "Default AMB with spiffs (1.2MB APP/1.5MB SPIFFS)”
Core Debug Level: "None”™

PSRAM: "Disabled"

Port: "COM14"
Get Board Info

Programmer
Burmn Bootloader

4
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ESP32 Dev Module on COM14

TOHEOmE

Press and hold Boot button
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Release Boot button
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Boot button

5. Open the serial monitor ( - ), and check that the baudrate is set to 115200 baud:
6. Press the Reset/EN button, debug messages should start appearing on the serial monitor, together with status

info about the network connection and the IP-address. Take a note of the IP address:

Is the ESP32 having trouble to connect to your WiFi network?
Check that the WiFi network name and password have been set up correctly, and that the ESP32 is in range of
your WiFi access point. The ESP32 has a relatively small antenna so it might have more difficulties to pick up
the WiFi signal at a certain location than your PC.

7. Open our web browser and try to connect to the ESP32 by entering it’s ip addresses in the address bar. You
should get a webpage that shows a randomly generated graph from the ESP32



@ ESP32 Demo X +

< C {0 A Notsecure | 192.168. 58

Hello from ESP32!

Uptime: 00:30:01

What to do next with my Whadda ESP32 board?

Check out some of the other ESP32 examples that come preloaded in the Arduino IDE. You could try out the
Bluetooth functionality by trying the example sketches in the ESP32 BLE Arduino folder, or try out the internal
magnetic (hall) sensor test sketch (ESP32 > HallSensor). Once you tried out a few different examples you can try
to edit the code to your liking, and combine the various examples to come up with your own unique projects! Also
check out these tutorials made by our friends at last minute engineers:
lastminuteengineers.com/electronics/esp32-projects/

Modifications and typographical errors reserved —© Velleman Group nv, Legen Heirweg 33 — 9890 Gavere
WPB109-26082021.

Documents / Resources

[ WHADDA

WHADDA WPB109 ESP32 Development Board [pdf] User Manual
= WPB109 ESP32 Development Board, WPB109, ESP32 Development Board, Development Boa
' | 1d, Board

References

« “7 ESP32 Projects - Last Minute Engineers

- Ll Whadda - Exciting Electronics

« “7 ESP32 Projects - Last Minute Engineers

» &) raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json



http://lastminuteengineers.com/electronics/esp32-projects/
https://manuals.plus/m/dc64f94637b07ad101e87e1497ef8aafee413d9e5d9e232ad0d58a16424a150c
https://manuals.plus/m/dc64f94637b07ad101e87e1497ef8aafee413d9e5d9e232ad0d58a16424a150c_optim.pdf
http://lastminuteengineers.com/electronics/esp32-projects/
http://whadda.com
https://lastminuteengineers.com/electronics/esp32-projects/
https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json

Manuals+,


https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers
https://manuals.plus/

	WHADDA WPB109 ESP32 Development Board User Manual
	WHADDA WPB109 ESP32 Development Board
	Introduction
	Safety Instructions
	General Guidelines
	What is Arduino®
	Product overview
	Specifications
	Functional overview
	Getting started
	WiFi connection example
	Documents / Resources
	References



