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Product Information

Product Name: STM32F429
Discovery Model Number: 32F429IDISCOVERY
Manufacturer: STMicroelectronics (ST)
Release Date: October 2013
User Manual: UM1680

Description
The STM32F429 Discovery is a software development tool designed for building applications around the
STM32F429 Discovery board. This tool provides a software environment and development  recommendations for
novice users to build and run sample applications, as well as create and build their own applications. The
STM32F429 Discovery board is equipped with the necessary hardware components to execute and debug
firmware applications. System Requirements: Before running any application on the STM32F429 Discovery
board, the following system requirements must be fulfilled:

1. Integrated Development Environment (IDE): Install your preferred IDE that supports the STM32 family.

2. ST-LINK V2 Driver: Install the ST-LINK V2 driver from the ST website.

3. Firmware Package: Download the STM32F429I-Discovery firmware from the ST website.

4. Hardware Connection: Establish a connection with the STM32F429 Discovery board according to the

instructions provided in Figure 1 of the user manual.

Usage Instructions:
Install IDE:

1.  Choose your preferred IDE that supports the STM32 family.

2. Follow the installation instructions provided by the IDE manufacturer.

Install ST-LINK V2 Driver:



1.  Visit the ST website and download the ST-LINK V2 driver.

2. Follow the installation instructions provided by ST to install the driver.

Download Firmware Package:

1. Visit the ST website and locate the STM32F429I-Discovery firmware package.

2. Download the firmware package to your computer.

Hardware Connection:

1. Refer to Figure 1 in the user manual for the hardware connection setup.

2. Connect the STM32F429 Discovery board to your computer using the appropriate cables and connectors.

Once you have fulfilled the system requirements and established the hardware connection, you  are ready to

build and run firmware applications on the STM32F429 Discovery board. The user manual provides further

instructions and guidelines for executing/debugging firmware using different software toolchains and advanced

debugging techniques.

Introduction

This document describes the software environment and development recommendations required to build an
application around the STM32F429 Discovery (32F429IDISCOVERY).
It provides guidelines to novice users on how to build and run a sample application and to create and build their
own application.
This document is structured as follows:

Chapter 1 describes where to find the ST-LINK/V2 driver that should be installed before starting coding on any

Integrated Development Environment

Chapter 2 describes step by step how to execute and debug an existing project with one of the following

toolchains:

IAR Embedded Workbench® for ARM (EWARM) by IAR Systems

Microcontroller Development Kit for ARM (MDK-ARM) by Keil™

TrueSTUDIO® by Atollic

Chapter 3 describes advanced debugging features

Chapter 4 provides links to detailed information on the previously mentioned toolchains

Although this manual cannot cover all the topics relevant to software development environments; it demonstrates
the first basic steps necessary to get started with the compilers/debuggers and provides links to the documents
needed to fully understand every single step.

System requirements

Before running your application, you should:

1. Install your preferred Integrated Development Environment (IDE).

2. Install the ST-LINK V2 driver from the ST web site.

3. Download the STM32F429I-Discovery firmware from the ST web site.



4. Establish the connection with the STM32F429 Discovery board as shown in Figure 1.

To run and develop any firmware applications on your STM32F429 Discovery board, the minimum requirements
are as follows:

Windows PC (2000, XP, Vista, 7)

USB type A to Mini-B’ cable, to power the board (through USB connector CN1) from the host PC and connect

to the embedded ST-LINK/V2 for debugging and programming.

IDEs supporting STM32 family
STMicroelectronics’ STM32 family of 32-bit ARM Cortex-M core-based microcontrollers are supported by a
complete range of software tools, encompassing traditional IDEs with C/C++ compilers and debuggers from major
3rd-parties (free versions up to 64KB of code, depending on partner), and completed with innovative tools from
STMicroelectronics. Table 1 regroups general information about some IDE versions that officially support the
STM32F429I product.

Table 1. Supported Toolchain versions



Toolchain Company Compiler Version Download link (*)

 

 

EWARM

 

 

IAR Systems
®

 

 

IAR C/C+
+

 

6.60

and late
r

www.iar.com/en/Products/IAR-Embedded-
Workbench/ARM

30-day evaluation edition

KickStart edition(32 KB Limitation for Cortex M3/M4)

KickStart edition(16 KB Limitation for Cortex M0)

MDK-ARM Keil™ ARMCC

4.72

and late
r

www.keil.com/demo/eval/arm.htm MDK-Lite (32 KB Co
de size limitation)

 

TrueSTUDI
O

 

© Atollic

 

GNUC

 

4.1

and late
r

www.atollic.com/index.php/request-eval-license(1)

32 KB Limitation (8 KB on Cortex-M0 and Cortex-M1)

30 day Professional version (Trial)

Registration is required before download

ST-LINK/V2 installation and development
The STM32F429 Discovery board includes an ST-LINK/V2 embedded debug tool interface which requires a
dedicated USB driver. This driver is available on the www.st.com ST-LINK V2 page and is supported by these
common software toolchains, and others:

IAR™ Embedded Workbench for ARM (EWARM)

The toolchain is installed by default on the PC’s local hard disk in the C:\Program Files\IAR

Systems\Embedded Workbench x.x directory.

After installing EWARM, install the ST-LINK/V2 driver by running ST-Link_V2_USB.exe from

[IAR_install_directory]\embedded Workbench x.x \arm\drivers\ST-Link\ST-Link_V2_USBdriver.exe

RealView Microcontroller Development Kit (MDK-ARM) toolchain

The toolchain is installed by default on the PC’s local hard disk in the C:\Keil directory; the installer

creates a start menu shortcut for µVision4.

When connecting the ST-LINK/V2 tool, the PC detects new hardware and asks to install the ST-

LINK_V2_USB driver. The “Found New Hardware wizard” guides you through the steps needed to install

the driver from the recommended location.

Atollic TrueSTUDIO® STM32

The toolchain is installed by default on the PC’s local hard disk in the C:\Program Files\Atollic directory.

The ST-Link_V2_USB.exe is installed automatically with the software toolchain.

Complementary information on the firmware package and the STM32F429 Discovery requirements are available
from the Getting started with STM32 Firmware document.

Note: The embedded ST-LINK/V2 supports only SWD interface for STM32 devices.

http://www.iar.com/en/Products/IAR-Embedded-Workbench/ARM
http://www.keil.com/demo/eval/arm.htm
http://www.atollic.com/index.php/request-eval-license(1)
http://www.st.com


Firmware package
The STM32F429I-Discovery firmware applications, demonstration and IP examples are provided in one package
in one zip file. Extracting the zip file generates one folder, STM32F429I-Discovery_FW_VX.Y.Z, which contains
the following subfolders:

Figure 2. Package contents

Template project: Pre-configured project with empty main function to be customized by you. This is helpful to start
creating your own application based on the peripherals drivers.
Master workspace: Assembly of all projects available within this firmware package. Peripheral examples: Set of
examples for each peripheral ready to be run.

Executing / debugging firmware using software toolchains

EWARM toolchain
The following procedure compiles, links and executes an existing EWARM project.
The steps below can be applied to an existing example, demonstration or template project for STM32F429I-
Discovery_FW_VX.Y.Z firmware available at www.st.com.

1. Read the firmware readme.txt file which contains the firmware description and hardware/software

requirements, then start the EWARM toolchain. Figure 3 shows the basic names of the windows referred to in

this document.

Figure 3. IAR Embedded Workbench IDE

http://www.st.com


2. Select File > Open > Workspace. Browse to select either an example, demonstration or template workspace

file and click Open to launch it in the Project window.

3. Select Project > Rebuild All to compile your project. If your project is successfully compiled, the following

window is displayed.

If you need to change project settings (Include and preprocessor defines), just go through project options:

1. For Include directories: Project>Options…>C/C++ compiler>

2. For pre-processor defines: Project>Options…C/C++ compiler>pre-processor>

4. Select Project > Download and Debug or, alternatively, click the Download and Debug button the in toolbar, to

program the Flash memory and begin debugging.

Figure 5. Download and Debug button

5. The debugger in the IAR Embedded Workbench can debug source code at C and assembly levels, set

breakpoints, monitor individual variables and watch events during code execution.

Figure 6. IAR Embedded Workbench debugger screen



6. Select Debug > Go to run your application, or click the Go button in the toolbar.

Figure 7. Go button

MDK-ARM toolchain
The following procedure compiles, links and executes an existing MDK-ARM project. The steps below can be
applied to an existing example, demonstration or template project for STM32F429I-Discovery_FW_VX.Y.Z
firmware available at www.st.com.

1.  Open Keil MDK-ARM Microcontroller Kit. Figure 8 shows the basic names of the “Keil uVision4″windows

referred to in this document.

2. Figure 8. uVision4 IDE

http://www.st.com


3. Select Project > Open Project… Browse to select either an example, demonstration or template project file and

click Open to launch it in the Project window.

4. Select Project > Rebuild All target files to compile your project. If your project is successfully compiled, the

following window is displayed.

Figure 9. MDK-ARM project successfully compiled

You can change your project settings (Include and preprocessor defines), through the project options:

1. For Include directories: Project>Options for Target > C/C++ > Include Paths

2. For pre-processor defines: Project>Options for Target > C/C++ > Preprocessor symbols > Define

5. Select Debug > Start/Stop Debug Session or, click the Start/Stop Debug Session button in the toolbar, to

program the Flash memory and begin debugging.

Figure 10. Start/Stop Debug Session button

6. The MDK-ARM debugger can debug source code at C and assembly levels, set breakpoints, monitor individual

variables and watch events during code execution.

Figure 11. MDK-ARM debugger screen



7.  Select Debug > Run to run your application, or click the Run button in the toolbar.

Figure 12. Run button

TrueSTUDIO toolchain
The following procedure compiles, links and executes an existing TrueSTUDIO project. The steps below can be
applied to an existing example, demonstration or template project for STM32F429I-Discovery_FW_VX.Y.Z
firmware available at www.st.com.

1. Open Atollic TrueSTUDIO for ARM. The program launches and asks for a Workspace location.

Figure 13. TrueSTUDIO workspace launcher dialog box

2. Browse to select a TrueSTUDIO workspace of either an example, demonstration or template workspace file

http://www.st.com


and click OK to load it.

3. To load an existing project in the selected workspace, select File > Import, then General > Existing Projects into

Workspace and click Next.

Figure 14. Atollic TrueSTUDIO® import source select dialog box

4. Click Select root directory and browse to TrueSTUDIO workspace folder.

Figure 15. Atollic TrueSTUDIO® import projects dialog box

5. In the Projects panel, select the project and click Finish.

6. In the Project Explorer, select the project, open Project menu, and click Build Project.

7. If your project is successfully compiled, the following messages will be displayed on the Console window.



Figure 16. TrueSTUDIO® project successfully compiled

To change the project settings (Include directories and preprocessor defines), just go through

Project>Properties, select C/C++ Build>Settings from the left panel:

1. For Include directories: C Compiler>Directories>Include path

2. For pre-processor defines: C Compiler>Symbols> Defined symbols

8. To debug and run the application, select the project in the Project Explorer and press F11 to start a debug

session (see Figure 17).

Figure 17. TrueSTUDIO debug window

9. The debugger in the Atollic TrueSTUDIO can debug source code at C and assembly levels, set breakpoints,

monitor individual variables and watch events during code execution.

10. Select Run > Resume to run your application, or alternatively click the Resume button in the toolbar.

STM32F429 advanced debugging

The STM32 family using the Cortex-M4 processor has many interrupts and it can be difficult to determine when
they are being activated and how often.



Serial Wire Viewer (SWV) on the STM32F429 family makes this task easy. In fact, SWV displays PC Samples,
Exceptions (including interrupts), data reads and writes, ITM (printf), CPU counters and a timestamp. This
information comes from the ARM CoreSight™ debug module integrated into STM32F429 CPU.
SWV does not steal any CPU cycles and is non-intrusive (except for ITM Debug printf Viewer).
You have already configured Serial Wire Viewer (SWV) on the template project. This allows:

1. Retargeting printf to ITM stimulus port(0). This allows debug messages to display easily. How to use it:

EWARM : View > terminal IO

MDK-ARM : View > Serial Windows Debug (printf) Viewer

TrueSTUDIO: View > SWV Console

2. Exception trace:

Entry: when the exception enters.

Exit: When it exits or returns.

Return: When all the exceptions have returned to the main

EWARM : ST-LINK > Interrupt log

MDK-ARM : View > Trace > Exceptions

TrueSTUDIO: View > SWV Exception Trace Log

3. Function profiler: Shows timing information for the functions in an application

EWARM : ST-LINK > Function Profiler

MDK-ARM : View > Analysis Window > Code Coverage

TrueSTUDIO: View > SWV Statistical Profiling

4. Data Trace Timeline: Shows a graphical representation of the data

EWARM : ST-LINK > Timeline (Data log)

MDK-ARM : View > Analysis Window > Logic Analyzer

TrueSTUDIO: View > SWV Data Trace Timeline

SW Toolchains helpful references and links
The following table regroups useful references about the integrated development environments described in this
document:

Table 2. IDE references

Toolchain Download link

EWARM www.iar.com/en/Products/IAR-Embedded-Workbench/ARM/ EWARM_UserG
uide

MDK-ARM www.keil.com/demo/eval/arm.htm www.keil.com/arm/mdk.asp

TrueSTUDIO www.atollic.com/index.php/request-eval-license

Revision history

Table 3. Document revision history

Date Revision Changes

26-Oct-2013 1 Initial release.

http://www.iar.com/en/Products/IAR-Embedded-Workbench/ARM/
http://www.keil.com/demo/eval/arm.htm
http://www.keil.com/arm/mdk.asp
http://www.atollic.com/index.php/request-eval-license


Please Read Carefully:
Information in this document is provided solely in connection with ST products. STMicroelectronics NV and its
subsidiaries (“ST”) reserve the right to make changes, corrections, modifications or improvements, to this
document, and the products and services described herein at any time, without notice.
All ST products are sold pursuant to ST’s terms and conditions of sale.
Purchasers are solely responsible for the choice, selection and use of the ST products and services described
herein, and ST assumes no liability whatsoever relating to the choice, selection or use of the ST products and
services described herein.
No license, express or implied, by estoppel or otherwise, to any intellectual property rights is granted under this
document. If any part of this document refers to any third party products or services it shall not be deemed a
license grant by ST for the use of such third party products or services, or any intellectual property contained
therein or considered as a warranty covering the use in any manner whatsoever of such third party products or
services or any intellectual property contained therein.
UNLESS OTHERWISE SET FORTH IN ST’S TERMS AND CONDITIONS OF SALE ST DISCLAIMS ANY
EXPRESS OR IMPLIED WARRANTY WITH RESPECT TO THE USE AND/OR SALE OF ST PRODUCTS
INCLUDING WITHOUT LIMITATION IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE (AND THEIR EQUIVALENTS UNDER THE LAWS OF ANY JURISDICTION), OR
INFRINGEMENT OF ANY PATENT, COPYRIGHT OR OTHER INTELLECTUAL PROPERTY RIGHT.
ST PRODUCTS ARE NOT DESIGNED OR AUTHORIZED FOR USE IN: (A) SAFETY CRITICAL APPLICATIONS
SUCH AS LIFE SUPPORTING, ACTIVE IMPLANTED DEVICES OR SYSTEMS WITH PRODUCT FUNCTIONAL
SAFETY REQUIREMENTS; (B) AERONAUTIC APPLICATIONS; (C) AUTOMOTIVE APPLICATIONS OR
ENVIRONMENTS, AND/OR (D) AEROSPACE APPLICATIONS OR ENVIRONMENTS. WHERE ST PRODUCTS
ARE NOT DESIGNED FOR SUCH USE, THE PURCHASER SHALL USE PRODUCTS AT PURCHASER’S SOLE
RISK, EVEN IF ST HAS BEEN INFORMED IN WRITING OF SUCH USAGE, UNLESS A PRODUCT IS
EXPRESSLY DESIGNATED BY ST AS BEING INTENDED FOR “AUTOMOTIVE, AUTOMOTIVE SAFETY OR
MEDICAL” INDUSTRY DOMAINS ACCORDING TO ST PRODUCT DESIGN SPECIFICATIONS. PRODUCTS
FORMALLY ESCC, QML OR JAN QUALIFIED ARE DEEMED SUITABLE FOR USE IN AEROSPACE BY THE
CORRESPONDING GOVERNMENTAL AGENCY.
Resale of ST products with provisions different from the statements and/or technical features set forth in this
document shall immediately void any warranty granted by ST for the ST product or service described herein and
shall not create or extend in any manner whatsoever, any liability of ST.
ST and the ST logo are trademarks or registered trademarks of ST in various countries.
Information in this document supersedes and replaces all information previously supplied.
The ST logo is a registered trademark of STMicroelectronics. All other names are the property of their respective
owners.
© 2013 STMicroelectronics – All rights reserved
STMicroelectronics group of companies
Australia – Belgium – Brazil – Canada – China – Czech Republic – Finland – France – Germany – Hong Kong –
India – Israel – Italy – Japan – Malaysia – Malta – Morocco – Philippines – Singapore – Spain – Sweden –
Switzerland – United Kingdom – United States of America
www.st.com
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