Manuals+ — User Manuals Simplified.

SOURCE ELEMENTS Source-Talkback Plug in Pair Designed
User Guide

Home » SOURCE ELEMENTS » SOURCE ELEMENTS Source-Talkback Plug in Pair Designed User Guide -

SOURCE ELEMENTS Source-Talkback Plug in Pair Designed User Guide

<

PRO TOOLS



https://manuals.plus/#content
https://manuals.plus/
https://manuals.plus/
https://manuals.plus/category/source-elements
https://manuals.plus/source-elements/source-talkback-plug-in-pair-designed-manual.pdf

Contents

1 Introducing Source-Talkback

2 New Technology Now Available

3 What’s new with Source-Talkback 1.3?
4 Why do | need Source-Talkback?

5 Source-Talkback Compatibility

6 Installing Source-Talback

7 Uninstalling Source-Talkback

8 Getting Started with Source-Talkback
9 Initial Settings for Source-Talkback

10 iOS Setup and User Guide

11 How to use Source-Talkback with SourceNexus Mute-On

12 Connecting the Source-Talkback iOS application with your host
computer

13 Configuring the iOS Source-Talkback application
14 Setup for OSX 10.9 and higher
15 Using Source-Talkback
16 Source-Talkback Troubleshooting
17 Contacting Support
18 Documents / Resources
18.1 References
19 Related Posts

Introducing Source-Talkback

Written by Source Elements | Last published at: October 30, 2023

This article is part of the Source-Talkback User Guide

Source-Talkback is a plug-in pair designed to enable talkback functionality without requiring external hardware,
using a single keyboard stroke for toggle and latch. Simply place the Talkback plug-ins on your Aux track before
your talkback input, and on your Master fader. Hold down the ‘\" key for toggle, or shift+\ for latch, and enable Auto-
On to open and close automatically during transport start and stop. Talkback allows for an engineer to talk to talent
either over Source-Connect and/or in a local booth while not getting feedback through the monitoring speakers.
Source-Talkback is also compatible with any remote connection method, for example ISDN, regardless of where
you get your signal from.
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Learn MIDI

Forget MIDI CC B0
Learn key

Forget key |

Learn MIDI {latching)

Forget MIDI CC 81 (latching)
Learn key (latching)

Forget key <\ (latching)

Learn MIDI (toggle auto enabla)

Forget MIDI CC B2 (toggle auto enable)
Learn key (toggle auto enable)

Forget key 3\ (toggle auto enable)

Toggle mode
+ Onjoff mode

Source-Talkback features system-wide recognition, so you don’t need to have either of the plug-in windows open,
or even to have Pro Tools be the front-most application. Read on for details usage instructions, and how to place
Source- Talkback into your Pro Tools session.

New Technology Now Available

« Source-Talkback WITH 2Q REMOTES

Check out the new 2Q remote system:

« USB remotes for Source-Talkback

Technique: Remote-buddy with Source-Talkback
As used by Robert Winder

With Source Element’s Source-Talkback plug-in, you can use your Apple Remote or any other supported Remote
hardware with your Mac to open and close your Talkback switch. To help free you from the keyboard, we're
providing you this tutorial courtesy Robert Winder at ADR Anywhere. He’s using the great software ‘Remote
Buddy’ from IOSPIRIT.

Important: Source Elements does not officially support Remote Buddy, as third party software. For questions
regarding this product please visit the Remote Buddy website.

Remote Buddy from IOSPIRIT

Apple remote setup for Source-Talkback:



You need to purchase and download a $30 application called Remote Buddy: www.iospirit.com/remotebuddy

1. Launch Remote-Buddy
Once you launch the program, go to Remote-Buddy -> Preferences.

1. Uncheck application behaviours
Uncheck all applications in the Behavior window except Default Behaviour.

1. Create custom action
Click on Default Behaviour, and then click on “Perform action” on the Play/Pause line. Click on “Custom actions”.

This will open a window to allow you to define a custom action. The top area asks for a name of the action (I called
it “Talkback”). The next area down called “Actors to run within action” is a summary of the selections made in the
“Actor settings” area below. Simply enter a \ in the Keystr make sure that the Operation window reads “Single key
press between button press & release with autorepeats”. Click on “Use”

“Talkback” should now be in the “Perform action” section of Play/Pause. Change whatever buttons you want to
“Talkback”, it should be available as a choice as soon as you click “Perform action” for that button. | originally had
selected all buttons as active for “Talkback” but discovered that double button pushes cancels the action (if for
instance you hit “Play/Pause” and “+” simultaneously), so I've only programmed “Play/Pause” and “Menu” to be
active. Deactivate any unused buttons by picking the top selection in “Perform Action” (-).

Remote-Buddy Tips

Be sure to launch the Remote-Buddy program before use. There are only two downsides I've found in using the
remote:

You need to be in line of sight from the Apple remote IR transmitter to the Mac IR port. It works a little off-axis, but
if the remote user has the IR transmitter pointed at their body rather than at the Mac, it probably won’t work.

« If you're typing something at the keyboard (For example, labelling something during a session) while someone
is using the remote for talkback you will find that your tex\\\\\t look\\\\\\\s like this\\\!

Recommended Tools

« Hardware
« Apple Remote (comes with any new Apple Mac) or any Remote Buddy supported hardware (For example,

Keyspan RF remote or Express, Griffen AirClick USB).

What’s new with Source-Talkback 1.3?

Source-Talkback 1.3 a Native AAX plug-in built for Pro Tools with 64-bit support (10 and higher). Now featuring the
ability to define any key as the talkback, latch, and auto enable function keys and also use MIDI to control these
functions. The Talkback and Volume Control iOS app is designed as a companion app to wirelessly control these
functions, available on the App Store.

Why do | need Source-Talkback?

When working with talent at your studio or remotely via Source-Connect (or any other method of connecting to
another studio) whether it is across the hallway or across the world — you probably want to listen to the connection
over your speakers rather than over headphones. This means that your connected partners will hear themselves


http://www.iospirit.com/remotebuddy

back in your microphone, making it difficult for them to speak. If you are in your studio, you may have hardware at
your disposal that provides talkback functionality: some analog mixers or control surfaces such as the D-Control
come with built-in talkback functions.

However if you are on the road or using a smaller set-up like a Pro Tools Native, you may not have built-in
talkback. The Source-Talkback plug-ins solves this problem for you, more efficiently and more conveniently than
spending more money on an additional hardware piece to lug around just for a single, simple feature.

Source-Talkback Compatibility

Source-Talkback 1.3 for Mac

o AAX 64-bit

« Mac OSX only

« Supported configurations
o OSX 10.9t0 10.15
o Pro Tools 10 and up

Source-Talkback 1.2 for Mac

« AAX 64-bit

« Mac OSX only

« Supported configurations
o OSX 10.9t0 10.11
o Pro Tools 10 and up

Source-Talkback 1.0 for Mac

« RTAS 32-bit

« Mac OSX only

« Supported configurations
o OSX10.5t010.7
o Pro Tools 7t0 9

Source-Talkback 1.0 for Windows
Plug-in Type:

« 32-bit RTAS only

Windows XP
Supported configurations

« Windows XP / Vista / Windows 7

« Any 32-bit Pro Tools version from 6.4 and up, until Pro Tools 10

Installing Source-Talback



Go to your account dashboard, and access the Downloads section. Then, select “Source-Talkback 1.3”.
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Once ready, select the Mac version and download the product.

After downloading the application, double-click the DMG executable file. Then, click on the .pkg file and follow the
installation instructions.

SOURCE-TALKE

Connecting Source-Talkback and Pro Tools

To use Source-Talkback, you will typically place the Source-Talkback plugin on the Aux or Master channel where
your mix or any program material is feeding out to your speakers. Source-Talkback has multi-channel support for
any channel count from mono to 7.1.

Uninstalling Source-Talkback

To uninstall Source-Talkback on Mac, open the installer package and double click on the “Source Talkback
Uninstaller. pkg” file.


https://dashboard.source-elements.com/products
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Follow the instructions on the uninstaller.

Getting Started with Source-Talkback

1. If you haven't already, buy a full license or request a full-featured demonstration license, from http://source-
elements.com. You will be asked to create an account if you do not have

2. Login to your account and download Source-Talkback from the Downloads section and run the Launch Pro
Tools.

3. You'll need to create a separate Auxiliary track for your talkback, if you don’t already do this in your session
template.

4. Insert the ‘Source-Talkback-Aux’ plug-in on your Aux track from the Native > Other menu. Select your mic input
for the Aux track and make sure the volume is up.

5. Create a new Master Fader Insert the ‘ Source-Talkback-Master plug-in here.

6. If you wish, enable Auto mode and change the Talkback Dim level on the Master fader plug-in via the Options

menu. The settings will be remembered according to your Pro Tools plug-in settings preferences

Source-Talkback at a first glance

Source-Talkback provides the following configuration settings in both open and closed modes.


http://source-elements.com/
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Learn MIDI
Forget MIDI CC 80
Learn key
Forget key |

Learn MIDI (latching)
Forget MIDI CC 81 (latching)
Learn key (latehing)
Forget key O (laiching)

Learn MIDI {togghe auto enable)
Forget MIDI CC B2 {togghe auto enable)
Learn key (toggle auto enabie)

Forget key 3\ (toggle auto enable)

Toggle mode
« Onjoff mode

1. Push-to-talk mode options: push-to-talk, or talkback mode, can be enabled by holding down the

\ key. This will allow your connection partner to hear you.
e Learn MIDI
« Forget MIDI CC 80 Learn key
« Forget key \

2. ON/OFF mode options: on/off mode can be enabled by pressing the Shift+\ (1 key on most
Macs) key. Doing this will latch the talkback, which means you will only need to press Shift+\ once,
and the talkback will remain open until you close it.

« Learn MIDI (latching)
» Forget MIDI CC 81 (latching) Learn key (latching)
» Forget key 1\ (latching)

3. Auto enable options: in auto mode, your talkback will automatically close when your transport is in playback or
record. Your talkback will automatically open when you stop playing or recording.

« Learn MIDI (toggle auto enable)

« Forget MIDI CC 82 (toggle auto enable) Learn key (toggle auto enable)

» Forget key 36\ (toggle auto enable)

« Mode selection options: this will be useful for some MIDI controllers and instruments. They do not,
however, affect the general use of Source-Talkback with a keyboard or the iOS application.

« Toggle mode: Source-Talkback will enable the functionality every time you press the key and
stop it when you press it again.

« On/off mode: each time you press the assigned key, Source-Talkback will alternate the state on/off. It is
enabled by default.
For more information on any of the options in the Source-Talkback plugin, continue on to the Using

Source-Talkback topic.

Initial Settings for Source-Talkback


https://professionalcomposers.com/midi-cc-list/
https://professionalcomposers.com/midi-cc-list/
https://professionalcomposers.com/midi-cc-list/
https://support.source-elements.com/source-nexus-mute-on-user-guide

Source-Talkback listens to your keyboard and defaults to the slash “\” key. When using the keyboard, you may get
a system beep if you have another application front-most. To avoid this beep, disable System Alert sounds in your
System Sound preferences.

To define any key you choose, control click on the talkback button to show the menu options to define different
keys for the plugins functions:

Learn MIDI

Learn key
Forget key |

Learn MIDI (latching)

Learn key (latching)
Forget key O\ (latching)

Learn MIDI (toggle auto enable)
Learn key (toggle auto enable)
Forget key ¥\ (toggle auto enable)

Toggle mode
+ Onfoff mode

When building your Pro Tools session, you may want your Aux track with the Source-Talkback-Aux plug-in to be
“solo isolated”. Do this by command-clicking on its solo button.
iOS Setup and User Guide

Download and install the Source-Talkback app on your iOS device:

wnload and install the Source-Talkback app on your iOS device:
itunes://itunes.apple.com/us/app/source-talkback-remote-control/id1046595331?mt=8

Setting up your iOS Talkback app is a little different. Follow these steps:

1. Open Finder and go to Applications -> Utilities and open Audio MIDI Setup
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2. On the Menu bar, go to Window -> Show MIDI Studio (or hit $82)
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3. Double click the Network icon (or click the “Configure Network Driver” button in the top right-hand
corner)

Alternatively, in Pro Tools on the Menu bar, go to Setup -> MIDI -> MIDI Studio
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4. Under My Sessions click the + icon to add a new MIDI Network Session.
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5. Under Session, make sure Enabled is checked. You can change the Local Name of the session

and the Bonjour Name of your computer here if you wish. Set Who may connect to me: to Anyone.
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6. Now that your MIDI Network Session is active, you just need to connect your iOS device to the session.
First, be sure your device is connected to the same network as your host computer. Next, click the connect
button in the app to connect to the session. The status bar along the top will show Connected once a

connection is established.
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7. Make sure your device is listed under Participants. If it is not, then select the device from the Directory and
hit the Connect button. The device is not actually connected unless it shows under Participants even if the



status bar on the app says Connected.
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8. The default MIDI mappings on the Source-Talkback plugin match those on the app so now it is ready to
use.
If the MIDI values have been changed either in the plugin or in the app, Learn MIDI will need to be used on the

plugin to learn the new values.

How to use Source-Talkback with SourceNexus Mute-On

Following is a description of a new workflow for using Source-Nexus Mute-On by pairing the plugin with our
Talkback and Volume Control iOS app to provide remote MIDI control to the plugin.

What you will need

First, if you have not already, please download and install the latest version of Source-Nexus Suite which includes
the Source-Nexus Mute-On plugin.

« Download Source-Nexus Suite for macOS

« Download Source-Nexus Suite for Windows

Next, please download the Talkback and Volumen Control iOS app from the Apple AppStore on your iOS device.
This app is only available for iOS.


https://dashboard.source-elements.com/products
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+« Download Talkback and Volume Control for iOS

Connecting the Source-Talkback iOS application with your host computer

To connect the app to your host computer, first make sure the iOS device is connected to the same network as
your host computer, then you will need to set up a MIDI Network Session. You can follow the in-app instructions in
the Talkback and Volume Control app, or please see the following link for macOS set up instructions (Share MIDI

information over a network in Audio MIDI Setup on Mac).

For Windows, please download and install rtpMIDI to create a MIDI Network Session. There is a set up tutorial
available as well, however the set up is the same procedure as on macOS once rtpMIDlI is installed and running.

« Download rtpMIDI rtpMIDI Set Up Tutorial

Configuring the iOS Source-Talkback application

1. Once the iOS app is connected to your MIDI Network Session, open up an instance of Mute-On in your
preferred DAW.

2. Open the dropdown menu for “On Midi” in the Mute-On plugin and set your MIDI device to the name of your
MIDI Network Session (by default this will be “Session 17).

3. Open the dropdown menu for “On Midi” and select “Midi key: _(click to set new key)”.

4. Now press the large talkback button in the Talkback and Volume Control iOS app, which will send the MIDI
message to the plugin and allow it to learn the MIDI CC value from the If it worked correctly, the MIDI key
should show CC80.

5. If it does not, please verify that the iOS app is properly connected to the MIDI Network Session, and that the
name of the session is selected as the MIDI device in the Mute-On

6. Now the large talkback button in the iOS app should be working to trigger the MIDI action in the Mute-On

plugin.
Setup for OSX 10.9 and higher

OSX since 10.9 (Mavericks) will ask you when you first activate Source-Talkback to allow Pro Tools to access the
Accessibility privacy settings. To verify that Pro Tools has access, open System Preferences->Security and
Privacy and check that Pro Tools is on the list of applications under the Privacy tab. You won’t see Pro Tools in
this list until an application, such as Source-Talkback, requests it.


https://apps.apple.com/us/app/talkback-and-volume-control/id1046595331
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https://www.tobias-erichsen.de/software/rtpmidi/rtpmidi-tutorial.html
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As of macOS Catalina (10.15) Pro Tools also needs to be given Input Monitoring access in the Security and
Privacy settings. This is also under System Preferences->Security and Privacy under the Privacy tab.
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Using Source-Talkback
Auto Usage

The most common method will be to enable Auto-On. You can do this in two ways:

1. Select Auto:on from the Options menu

2. Use the key combination command + \" (apple + backslash

Once Auto is enabled, Talkback will close when the transport is in playback or record. You can override the Auto
functionality at any time with shiff + ‘|’ or toggle Auto with command + \’

Manual Usage



Source-Talkback takes two key commands and has one menu. It also accepts a mouse click on the
‘Talkback’ button in the plug-in window to toggle the ‘latch’ state.

Default Key command: *V

The “forward slash’ key, usually found above the right-hand shift or return key on a standard keyboard.

Holding down this key enables the talkback volume, so your connected partner can hear you, and your master
fader level is dimmed so they get as little feedback as possible from your speakers.

Default Key command: shift+’\’ :

The shift key plus the forward slash key.

Hitting this key command once toggles and ‘latches’ the talkback — this means that you only need to hit the key
command once, and Talkback will stay open until closed.

Talkback Dim: options menu

Depending on your needs, you may wish to modify the dim menu from the default —15db. The recommended
values are -10db, -15db and -20db.

Once one of the Source-Talkback plug-ins is visible in Pro Tools click on the red target in the upper right corner of
the plug-in to deselect it from target mode. This will allow the plug-in to remain on the screen even when another
plug-in is brought forward.

Listen Back

Sometimes the musician in a local booth doesn’t have a microphone nearby or at all. In this situation you can also
set up one more aux input fed by a microphone in the musician’s room. Place SourceTalkback-a on this track. This
aux is output to the engineer’s monitor speakers and is switched on and off by toggling or latching Source-
Talkback. This way you don’t have a continuous feed from the microphone in the musician’s room.

You can use as many Source-Talkback plug-ins as you need at the same time. Thus Talkback and ListenBack
functionality can be simultaneous.

System-wide recognition

Source-Talkback will listen for the key commands regardless of whether you have either plug-in visible, and even if
Pro Tools is a background application.

We recommend leaving at least one Talkback plug-in visible so you can see your status. It doesn’t matter which,
and we have designed them in two different sizes so you can choose which fits best on your screen.

Remote Control for iOS Devices

You can use the Talkback and Volume Control app for iOS devices to control the talkback switch, latch, and auto
enable controls on the Source-Talkback plugin. Download the app from the App Store. To connect the app to the
Source-Talkback plugin, setup a MIDI Network Session and connect your iOS device to it. Setup tutorials are also
available directly in the app.

To setup a MIDI Network Session, open Finder and go to Applications->Ultilities and open Audio MIDI Setup.



On the Menu bar, go to Window->Show MIDI Studio (or hit 32). Double click the Network icon. Alternatively, in
Pro Tools on the Menu bar, go to Setup->MIDI->MIDI Studio...

Under My Sessions click the + icon to add a new MIDI Network Session. Under Session, make sure Enabled is
checked. You can change the Local Name of the session and the Bonjour Name of your computer here if you
wish. Set Who may connect to me: to Anyone. Then, make sure your device is listed under Participants. If it is
not, then select the device from the Directory and hit the Connect button. The device is not actually connected
unless it shows under Participants even if the status bar on the app says Connected.
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The default MIDI mappings on the Source-Talkback plugin match those on the app so now it is ready to use. If the
MIDI values have been changed either in the plugin or in the app, Learn MIDI will need to be used on the plugin to
learn the new values by right clicking on it, selecting Learn MIDI for the control you wish it to learn, then tapping the
corresponding control on the app. The MIDI mode should be set to On/off mode.

Source-Talkback Troubleshooting
Known Issues
Source-Talkback plugin does not respond to its key assignment, or it is not possible to learn a new key

Make sure Pro Tools is given Accessibility and Input Monitoring access in the Privacy settings located in
System Preferences -> Security and Privacy -> Privacy. See the following article for details: Source-Talkback
Privacy Settings

If you continue to have issues with key assignments, try the steps detailed below in the “latches cannot be
changed” section.

Source-Talkback latches and cannot be changed

If Source-Talkback latches automatically when using the iOS application, switch to use the Master version of the
plugin. Then:

1. Right click the plugin for the
2. Forget the existing
3. Relearn the


https://support.source-elements.com/show/setup-for-osx-109-and-higher

Cursors issues when selecting a text field

If your cursor has selected a text field anywhere within Pro Tools, you will see a series of '\’ whenever you use
Source-Talkback. To avoid this, press the ‘ESC’ key. It will return your cursor focus back to Pro Tools, which
doesn’t recognize the forward slash key.

IAC Driver and Source-Talkback

In order to work with Source-Talkback, the IAC Driver needs to be OFF. In some cases, Source- Talkback might be
stuck open when the driver is on. In order to turn off the IAC driver:

1. Go to Audio MIDI

2. Go to Window > Show MIDI

3. Double click the “IAC Driver” icon, if it
4. Uncheck the “Device is online”

Pro Tools crash with MIDI devices

When a MIDI device is being used (as an input, a controller, etc.) in Pro Tools and users add SourceTalkback into
a track, Pro Tools crashes. In order to fix the issue, try disabling the MIDI devices and reload Source-Talkback onto
the track.

Contacting Support

Comprehensive documentation is available on our website. If your question is not answered please contact us via
telephone, email or we can arrange communication over other methods such as Skype on request.

Comprehensive documentation is available on our website. If your question is not answered please contact us via
telephone, email or we can arrange communication over other methods such as Skype on request.

Online support and user guides

https://support.source-elements.com/pages/software-user-guides-and-manuals

Email

Support: support@source-elements.com Sales: sales@source- elements.com

When emailing Support, please provide us with the information required to resolve the issue: for example, your
Source-Connect login, computer type, host version, and as much detail about the problem you are having as
possible. This will assist us in responding to you with relevant assistance more rapidly.

ST URCE
ELEMENTS

Documents / Resources


https://support.source-elements.com/source-elements/software-user-guides-and-manuals
mailto:support@source-elements.com
mailto:sales@source-elements.com

Source-Talkback SOURCE ELEMENTS Source-Talkback Plug in Pair Designed [pdf] User Guide

User guide

Source-Talkback Plug in Pair Designed, Source-Talkback, Plug in Pair Designed, Pair
Designed, Designed

References

« M ELEMENTS Fitness und Wellness in Miinchen, Frankfurt und Stuttgart

« ® Talkback and Volume Control on the App Store
. Remote Audio & Remote Video Collaboration Software - Source Elements

« B Remote Buddy - control your Mac with remotes, iPhone, iPad, Siri Remote and Apple TV

. Source Elements Account

N MIDI CC List (Quick Guide) — Professional Composers

« % _Share MIDI information over a network in Audio MIDI Setup on Mac - Apple Support
. Source-Nexus Mute-On User Guide - Source Elements

. Source-Nexus Mute-On User Guide - Source Elements

« @ rtpMIDI Tutorial | Tobias Erichsen

» User Manual

Manuals+, Privacy Policy

This website is an independent publication and is neither affiliated with nor endorsed by any of the trademark owners. The "Bluetooth®" word mark and logos are registered trademarks owned by Bluetooth
SIG, Inc. The "Wi-Fi®" word mark and logos are registered trademarks owned by the Wi-Fi Alliance. Any use of these marks on this website does not imply any affiliation with or endorsement.


https://manuals.plus/m/18ab9b65cdece19c858901001d1b268a2dd62f6f073f551631b20903d576a3c7
https://manuals.plus/m/18ab9b65cdece19c858901001d1b268a2dd62f6f073f551631b20903d576a3c7_optim.pdf
http://elements.com
http://itunes.apple.com/us/app/source-talkback-remote-control/id1046595331?mt=8
http://source-elements.com
http://www.iospirit.com/remotebuddy
https://dashboard.source-elements.com/products
https://professionalcomposers.com/midi-cc-list/
https://support.apple.com/guide/audio-midi-setup/share-midi-information-over-a-network-ams1012/mac
https://support.source-elements.com/show/setup-for-osx-109-and-higher
https://support.source-elements.com/show/talkback-usage
https://www.tobias-erichsen.de/software/rtpmidi/rtpmidi-tutorial.html
https://manual.tools/?p=14675261#MTA0LjI4LjIzNC4xNzk7Ozs7
https://manuals.plus/
https://manuals.plus/privacy-policy

	SOURCE ELEMENTS Source-Talkback Plug in Pair Designed User Guide
	Introducing Source-Talkback
	New Technology Now Available
	What’s new with Source-Talkback 1.3?
	Why do I need Source-Talkback?
	Source-Talkback Compatibility
	Installing Source-Talback
	Uninstalling Source-Talkback
	Getting Started with Source-Talkback
	Initial Settings for Source-Talkback
	iOS Setup and User Guide
	How to use Source-Talkback with SourceNexus Mute-On
	Connecting the Source-Talkback iOS application with your host computer
	Configuring the iOS Source-Talkback application
	Setup for OSX 10.9 and higher
	Using Source-Talkback
	Source-Talkback Troubleshooting
	Contacting Support
	Documents / Resources
	References



