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Kit Contents

The C8051F34x Development Kit contains the following items:

C8051F340 Target Board

C8051Fxxx Development Kit Quick-Start Guide

AC to DC Power Adapter

USB Debug Adapter (USB to Debug Interface)

USB Cable

CD-ROM

Hardware Setup Using a USB Debug Adapter

The target board is connected to a PC running the Silicon Laboratories IDE via the USB Debug Adapter as shown
in Figure 1.

1. Connect the USB Debug Adapter to the DEBUG connector on the target board with the 10-pin ribbon cable.

2. Connect one end of the USB cable to the USB connector on the USB Debug Adapter.

3. Connect the other end of the USB cable to a USB Port on the PC.

4. Connect the ac/dc power adapter to power jack P1 on the target board.

Notes:

Use the Reset button in the IDE to reset the target when connected using a USB Debug Adapter.

Remove power from the target board before removing the ribbon cable from the target board. Connecting or

disconnecting the cable when the devices have power can damage the device and/or the USB Debug Adapter.
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Figure 1. Hardware Setup Using a USB Debug Adapter
Notes:The C8051F340 target board has the ability to be powered through the USB cable. To enable the USB-
powered mode,
short the pins labeled VBUS and VREGIN on the J8 header. Do not short all 3 pins on the J8 header.

Software Setup

Simplicity Studio greatly reduces development time and complexity with Silicon Labs EFM32 and 8051 MCU
products by providing a high-powered IDE, tools for hardware configuration, and links to helpful resources, all in
one place.

Once Simplicity Studio is installed, the application itself can be used to install additional software and
documentation components to aid in the development and evaluation process.

Figure 2. Simplicity Studio

The following Simplicity Studio components are required for the C8051F340 Development Kit:

8051 Products Part Support

Simplicity Developer Platform

Download and install Simplicity Studio from www.silabs.com/8bit-software or www.silabs.com/simplicity-
studio.
Once installed, run Simplicity Studio by selecting Start>Silicon Labs>Simplicity Studio>Simplicity Studio
from the start menu or clicking the Simplicity Studio shortcut on the desktop. Follow the instructions to install the
software and click Simplicity IDE to launch the IDE.
The first time the project creation wizard runs, the Setup Environment wizard will guide the user through the
process of configuring the build tools and SDK selection.
In the Part Selection step of the wizard, select from the list of installed parts only the parts to use during
development. Choosing parts and families in this step affects the displayed or filtered parts in the later device
selection menus. Choose the C8051F34x family by checking the C8051F34x check box. Modify the part
selection
at any time by accessing the Part Management dialog from the Window>Preferences>Simplicity
Studio >Part Management menu item.
Simplicity Studio can detect if certain toolchains are not activated. If the Licensing Helper is displayed after
completing the Setup Environment wizard, follow the instructions to activate the toolchain.

Running Blinky
Each project has its own source files, target configuration, SDK configuration, and build configurations such as the
Debug and Release build configurations. The IDE can be used to manage multiple projects in a collection called a
workspace. Workspace settings are applied globally to all projects within the workspace. This can include settings
such as key bindings, window preferences, and code style and formatting options. Project actions, such as build
and debug are context sensitive. For example, the user must select a project in the Project Explorer view in order
to build that project.
To create a project based on the Blinky example:

1. Click the Simplicity IDE tile from the Simplicity Studio home screen.

2. Click the Create new project link from the welcome screen or go to File�New�Silicon Labs MCU Project.

3. In the Kit drop-down, select C8051F340 Development Kit, in the Part drop-down, select C8051F340, and in the

SDK drop-down, select the desired SDK. Click Next.

4. Select Example and click Next.

http://www.silabs.com/8bit-software
http://www.silabs.com/simplicity-studio


5. Under C8051F340 Development Kit in the Blinky folder, select F34x Blinky and click Finish.

6. Click on the project in the Project Explorer and click Build, the hammer icon in the top bar. Alternatively, go to

Project�Build Project.

7. Click Debug to download the project to the hardware and start a debug session.

8. Press the Resume button to start the code running. The LED should blink.

9. Press the Suspend button to stop the code.

10. Press the Reset the device button to reset the target MCU.

11. Press the Disconnect button to return to the development perspective.

Simplicity Studio Help
Simplicity Studio includes detailed help information and device documentation within the tool. The help contains
descriptions for each dialog window. To view the documentation for a dialog, click the question mark icon in the
window:
This will open a pane specific to the dialog with additional details.
The documentation within the tool can also be viewed by going to Help>Help Contents or Help>Search.

Legacy 8-bit IDE
Note: Using the Simplicity Studio tools with the C8051F340 Development Kit is recommended. See section 3.
“Software
Setup‚” on page 2 for more information.
Download the 8-bit software from the website (www.silabs.com/8bit-software) or use the provided installer on the
CD-ROM to install the software tools for the C8051F34x devices. After installation, examples can be found in …
\Examples\C8051F34x in the installation directory. At a minimum, the C8051F340 DK requires:

Silicon Labs IDE—Software enabling initial evaluation, development, and debugging.

Configuration Wizard 2—Initialization code generation software for the C8051F34x devices.

Keil C51 Tools—Keil 8051 Compiler/Assembler/Linker toolchain.

Other software available includes:

Keil µVision Driver—Driver for the Keil µVision IDE that enables development and debugging on C8051Fxxx

MCUs.

Flash Programming Utilities and MCU Production Programmer—Programming utilities for the production

line. More information on the available programming options can be found on the website:

http://www.silabs.com/products/mcu/Pages/ProgrammingOptions.aspx.

ToolStick Development Tools—Software and examples for the ToolStick development platform. More

information on this platform can be found at www.silabs.com/toolstick.

The development kit includes the latest version of the C51 Keil 8051 toolset. This toolset is initially limited to a

code

size of 2 kB and programs start at code address 0x0800. After registration, the code size limit is removed

entirely

and programs will start at code address 0x0000.

To register the Keil toolset:

1. Find the Product Serial Number printed on the CD-ROM. If you no longer have this serial number,

register on the Silicon Labs website (www.silabs.com/8bit-software) to obtain the serial number.

2. Open the Keil µVision4 IDE from the installation directory with administrative privileges.

3. Select File>License Management to open the License Management window.
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Swiss Diamond XD Sauteerpan Non Stick Frying Pan User Guide

USE & CARE INSTRUCTIONS

Classic XD is constructed of multiple layers of specially developed and carefully selected materials. Our XD
series cookware begins with a cast aluminum alloy foundation. Liquid metal is cast into molds under high pressure
so it will never warp. This produces a perfectly flat base resulting in even heat distribution. The foundation is then
sand-blasted to prepare it for a layer of plasma coating. Plasma coating eliminates oxidation and forms an
extremely strong bond with our proprietary nonstick coating. Finally, each piece is finished with three layers of our
latest, diamond reinforced, PFOA free, patented, XD nonstick coating.



Swiss Diamond pioneered award winning, PFOA free, diamond reinforced, nonstick cookware nearly two decades
ago. Diamonds are durable, a superior heat conductor, and naturally nonstick. Our next generation, XD nonstick
diamond reinforced coating has been developed after many years of research. The enhanced formula results in
significantly improved durability and cooking performance for perfect food release every time.

XD Series cookware is available in both a Classic and a Classic Induction series to accommodate all cooktops
and can easily be transferred to the oven, with our lids being oven safe up to 500°F (260°C). The handles are
ergonomically designed to stay cool. Key pieces feature a helper handle for additional ease.

The Swiss Diamond brand is 100% Swiss owned. Our Classic XD cookware is made and designed in
Switzerland.

General Use

Use the right cookware for your cooktop.

For best results and to maximize energy efficiency, match the base diameter of your cookware to the

correct size burner or hot plate.

For gas cooktops, ensure the flame is centered beneath the pan. DO NOT allow the flame to extend up

the sides of the pan.

For electric cooktops, always make sure the base of your cookware and your cooktop are clean prior to

use. Never drag or push your cookware asthis may scratch your cooking surface.

For Induction cooktops, always make sure the base of your cookware and your cooktop are clean prior to

use. Permanent marks may occur if this is not done. The “boost” function should not be used for searing

or frying, as its purpose is to bring large quantities of liquid to a boil. While cooking with Classic Induction

XD, you may detect a low vibration noise.

This is normal and will not affect the cooking performance.

Use low to medium heat. High heat is never required due to the excellent thermal conductivity of Swiss

Diamond cookware. Start with low heat and adjust gently upward as needed. Always place your pan on the

center of the heating surface. Do not overheat as this will damage the cooking surface. Overheating is a

common occurrence and is easily recognizable as the exterior will change color. Damage from overheating is

not covered under warranty.

NOTE: Swiss Diamond cookware is oven safe up to 500°F (260°C), including lids and ergonomic handles. Never
put Swiss Diamond in a microwave oven.

Preheating. For optimal performance, place the pan on low and gently increase to medium heat and preheat

for 3 minutes, after this time you can add your food, you can turn down the heat during the cooking process.

Note that the cookware has been specially design to spread the heat evenly across the base and up the sides

of the pans, so there is no need for high heat.

Use proper utensils. Silicone and wooden tools are highly recommended. Any tool with a sharp point or edge

should not be used. Do not chop or cut in the pan. Small scratches do not decrease the performance of the

cookware and are not covered under warranty. Do not leave utensils in cookware while cooking. Use a spoon

rest.

If you must use cooking oil, use it properly. Swiss Diamond is designed for cooking with little or no oil. If

you choose to use oil, heating it above its smoke point, or to the point at which the oil will burn, will gradually



lead to a thin layer of oil residue build-up on the surface of your cookware which may become carbonized over

time. Carbonization can be difficult to remove and interfere with your cookware’s nonstick properties. Refer to

the chart below for smoke points for commonly used oils as well as the section entitled Removing Stubborn

Food & Oil Build-Up from the Nonstick Surface. Avoid using cooking sprays which may cause carbonization at

even relatively low temperatures.

Oil Smoke Point

Avocado Oil (Virgin) 375-400°F 190-205°C

Butter 350°F 175°C

Butter (Clarified) 450°F 230°C

Canola Oil 400°F 205°C

Coconut Oil 350°F 175°C

Corn Oil 450°F 230°C

Grapeseed Oil 390°F 195°C

Lard 370°F 185°C

Olive Oil (Extra-Virgin) 325-375°F 165-190°C

Olive Oil (Light/Refined) 465°F 240°C

Peanut Oil 450°F 230°C

Safflower Oil 510°F 265°C

Sesame Oil 350-410°F 175-210°C

Soybean Oil 450°F 230°C

Sunflower Oil 440°F 225°C

Vegetable Oil 400-450°F 205-230°C

Vegetable Shortening 360°F 180°C

Use cookware safely. Never leave cookware unattended on a hot cooktop. Never allow cookware to reach

boiling temperature without water. Turn handles away from the edge of the cooktop to prevent accident or

injury. Be sure to use oven mitts/gloves when handling hot cookware.

Food storage. Never store food in your cookware.

Cleaning

Before Using New Cookware

Hand-wash cookware thoroughly with hot, soapy water using a nylon brush, a nylon scourer, or a soft clean

dish cloth or sponge.



Note: Swiss Diamond cookware is considered dishwasher safe, but werecommend avoiding the dishwasher

due to the harsh chemicals in dishwashing detergent.

Never use a metal or abrasive scourer or harsh chemicals.

Hand dry with a soft clean towel and ensure cookware is completely dry prior to storage.

Removing Stubborn Food & Oil Build-Up from the Nonstick Surface

Over time, you may notice a dark build-up on the surface of the pan. A thin layer of food and oil residue may
remain on the surface and may become carbonized when reheated. This can occur gradually when cooking oil is
used above its smoke point. This doesn’t damage the pan but it can be very difficult to remove. We recommend
the following baking soda treatment:

1. Mix a solution of baking soda and water about the consistency of toothpaste.

2. Rub this solution into the pan wherever you see the dark build-up.

3. Scrub vigorously with a nylon brush or scourer, or a soft clean dish cloth or sponge.

4. Rinse clean, wash with hot soapy water and dry thoroughly

5. Never use oven cleaner or other harsh chemicals as these will degrade the nonstick surface.

Cleaning the Exterior and Base

The following homemade solution can be used to remove build up on the exterior and base:

1. Mix a solution of 1 quart (1 liter) water + 3 Tbsp. (45 ml) of a natural acid like lemon juice, cream of tartar or

white vinegar.

2. Bring this solution to a boil and then carefully use it on a nylon brush or scourer to clean the exterior and the

base. Rinse, wash with warm soapy water, rinse again and dry thoroughly.

Everyday Maintenance & Storage

Remove your food, carefully fill your hot cookware with about 2 inches of cold water and place your pan on a

heat resistant surface.

Empty the pan and hand-wash it thoroughly with hot, soapy water using a nylon brush, a nylon scourer, or a



soft clean dish cloth or sponge.

Never use a metal or abrasive scourer or harsh chemicals.

Hand dry with a soft clean towel and ensure cookware is completely dry prior to storage.

If you nest your pans one on top of the other, place a clean paper towel, cloth towel or felt pan protectors

between your cookware pieces prior to storage to preserve the nonstick surface.

If need be, the handles may be tightened with a #2 Phillips head screwdriver.

Limited Lifetime Warranty

SWISS DIAMOND warrants to the original owner of the cookware that it is free of defects in materials and
workmanship for the lifetime of the product. This warranty does not cover glass lids or handles.

This warranty does not apply if the Use and Care instructions published in our literature have not been followed.
This warranty does not cover damage or destruction caused by misuse, abuse, accident, overheating, alterations
or commercial use. This warranty does not cover stains, discoloration, scratch marks or dents. Incidental or
consequential damages are expressly excluded by this warranty.

SWISS DIAMOND will repair or replace, at SWISS DIAMOND’s discretion, any item found to be defective. Should
the defective item no longer be available, for any reason, an item of similar function and value will be substituted.
This warranty is expressly not a money-back guarantee.

In the event the cookware needs to be returned for repair or replacement, it must be mailed back prepaid.

SWISS DIAMOND® is a registered trademark.

DIAMOND CERTIFICATION

SWISS DIAMOND hereby certifies that the nonstick coating used on our products contains diamond crystals.
Additionally, we certify that the diamonds used in our products are purchased from a non-conflict source through a
reputable supplier, subject to all international regulations.

If your SWISS DIAMOND cookware is found to be defective in materials or workmanship, please visit
www.swissdiamond.com or e-mail warranty@swissdiamond.com.

Product Registration
Please take a moment to register your product so that we can best support you. Simply go to:
www.swissdiamond.com/register and fill out the short form to complete your registration.

Documents / Resources
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