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Product Information

The SeeedStudio XIAO series are diminutive development boards that share a similar hardware structure, with a
size that is literally thumb-sized. The codename XIAO here represents its half feature Tiny, and the other half will
be Puissant. SeeedStudio XIAO ESP32S3 Sense integrates camera sensor, digital microphone, and SD card
supporting. Combining embedded ML computing power and photography capability, this development board can
be your great tool to get started with intelligent voice and vision AI.

Product Specification

Powerful MCU Board:  Incorporate the ESP32S3 32-bit, dual-core, Xtensa processor chip operating up to

240MHz, mounted multiple development ports, Arduino/MicroPython supported

Advanced Functionality (for Sense): Detachable OV2640 camera sensor for 1600*1200 resolution,

compatible with OV5640 camera sensor, integrating additional digital microphone

Elaborate Power Design: Lithium battery charge management capability, offer 4 power consumption model

which allows for deep sleep mode with power consumption as low as 14 A

Great Memory for more Possibilities:  Offer 8MB PSRAM and 8MB FLASH, supporting SD card slot for

external 32GB FAT memory

Outstanding RF performance:  Support 2.4GHz Wi-Fi and BLE dual wireless communication, support 100m+

remote communication when connected with U.FL antenna

Thumb-sized Compact Design: 21×17.5mm, adopting the classic form factor of XIAO, suitable for space-

limited projects like wearable devices

Product Hardware Overview

Before everything starts, it is quite essential to have some basic parameters of the product. The following table
provides information about the characteristics of SeeedStudio XIAO ESP32S3.

5V – This is 5v out from the USB port. You can also set this as a voltage input but you must have some sort of

diode (schottky, signal, power) between your external power source and this pin with anode to battery, cathode

to 5V pin.



3V3 – This is the regulated output from the onboard regulator. You can draw 700mA

GND – Power/data/signal ground

Product Usage Instructions

Hardware Preparation
Solder header XIAO-ESP32-S3 is shipped without pin headers by default, you need to prepare your own pin
headers and solder it to the corresponding pins of XIAO so that you can connect to the expansion board or
sensor. Due to the miniature size of XIAO-ESP32-S3, please be careful when soldering headers, do not stick
different pins together, and do not stick solder to the shield or other components. Otherwise, it may cause XIAO to
short circuit or not work properly, and the consequences caused by this will be borne by the user.

Installation of antenna:
On the bottom left of the front of XIAO-ESP32-S3, there is a separate WiFi/BT Antenna Connector. In order to get
better WiFi/Bluetooth signal, you need to take out the antenna inside the package and install it on the connector.
There is a little trick to the installation of the antenna, if you press down hard on it directly, you will find it very
difficult to press and your fingers will hurt! The correct way to install the antenna is to put one side of the antenna
connector into the connector block first, then press down a little on the other side, and the antenna will be
installed. Remove the antenna is also the case, do not use brute force to pull the antenna directly, one side of the
force to lift, the antenna is easy to take off.

Installation of expansion boards (for Sense):
If you are shopping for the XIAO-ESP32-S3-Sense, then you should also include an expansion board. This
expansion board has a 1600*1200 OV2640 camera sensor, Onboard SD Card Slot, and digital microphone. By
installing the expansion board with XIAO-ESP32-S3-Sense, you can use the functions on the expansion board.
Installing the expansion board is very simple, you just need to align the connector on the expansion board with the
B2B connector on the XIAO-ESP32-S3, press it hard and hear a click, the installation is complete.

Introduction

Seeed Studio XIAO Series are diminutive development boards, sharing a similar hardware structure, where the
size is literally thumb-sized. The code name “XIAO” here represents its half feature “Tiny”, and the other half will
be “Puissant”. Seeed Studio XIAO ESP32S3 Sense integrates camera sensor, digital microphone and SD card
supporting. Combining embedded ML computing power and photography capability, this development board can
be your great tool to get started with intelligent voice and vision AI.

Specification





Features

Powerful MCU Board: Incorporate the ESP32S3 32-bit, dual-core, Xtensa processor chip operating up to 240

MHz, mounted multiple development ports, Arduino / MicroPython supported

Advanced Functionality (for Sense): Detachable OV2640 camera sensor for 1600*1200 resolution, compatible

with OV5640 camera sensor, intergating additional digital microphone

Elaborate Power Design: Lithium battery charge management capability, offer 4 power consumption model

which allows for deep sleep mode with power consumption as low as 14μA

Great Memory for more Possibilities: Offer 8MB PSRAM and 8MB FLASH, supporting SD card slot for external

32GB FAT memory

Outstanding RF performance: Support 2.4GHz Wi-Fi and BLE dual wireless communication, support 100m+

remote communication when connected with U.FL antenna

Thumb-sized Compact Design: 21 x 17.5mm, adopting the classic form factor of XIAO, suitable for space

limited projects like wearable devices

Hardware Overview

Before everything starts, it is quite essential to have some basic parameters of the product. The following table
provides information about the characteristics of Seeed Studio XIAO ESP32S3.

5V – This is 5v out from the USB port. You can also use this as a voltage input but you must have some sort of

diode (schottky, signal, power) between your external power source and this pin with anode to battery, cathode

to 5V pin.

3V3 – This is the regulated output from the onboard regulator. You can draw 700mA

GND – Power/data/signal ground

Getting Started

To enable you to get started with the XIAO-ESP32-S3 faster, please read the hardware and software preparation
below to prepare the XIAO.

Hardware Preparation

Solder header
XIAO-ESP32-S3 is shipped without pin headers by default,you need to prepare your own pin headers and solder it
to the corresponding pins of XIAO so that you can connect to the expansion board or sensor.

Due to the miniature size of XIAO-ESP32-S3, please be careful when soldering headers, do not stick different pins
together, and do not stick solder to the shield or other components. Otherwise, it may cause XIAO to short circuit
or not work properly, and the consequences caused by this will be borne by the user.



Installation of antenna
On the bottom left of the front of XIAO-ESP32-S3, there is a separate “WiFi/BT Antenna Connector”. In order to
get better WiFi/Bluetooth signal, you need to take out the antenna inside the package and install it on the
connector.

There is a little trick to the installation of the antenna, if you press down hard on it directly, you will find it very
difficult to press and your fingers will hurt! The correct way to install the antenna is to put one side of the antenna
connector into the connector block first, then press down a little on the other side, and the antenna will be
installed.

Remove the antenna is also the case, do not use brute force to pull the antenna directly, one side of the force to
lift, the antenna is easy to take off.

Installation of expansion boards (for Sense)
If you are shopping for the XIAO-ESP32-S3-Sense, then you should also include an expansion board. This
expansion board has a 1600*1200 OV2640 camera sensor, Onboard SD Card Slot and digital microphone. By
installing the expansion board with XIAO-ESP32-S3-Sense, you can use the functions on the expansion board.
Installing the expansion board is very simple, you just need to align the connector on the expansion board with the
B2B connector on the XIAO-ESP32-S3, press it hard and hear a “click”, the installation is complete.



Software Preparation

The recommended programming tool for the XIAO-ESP32-S3 is the Arduino IDE, so as part of the software
preparation, you will need to complete the Arduino installation.

TIP
If this is your first time using Arduino, we highly recommend you to refer to Getting Started with Arduino.

Step 1. Download and Install the stable version of Arduino IDE according to your operating system.

Step 2. Launch the Arduino application.

Step 3. Add ESP32 board package to your Arduino IDE.

Navigate to File > Preferences, and fill “Additional Boards Manager URLs” with the url below:

https://raw.githubusercontent.com/espressif/arduino-esp32/ghpages/package_esp32_dev_index.json.

Navigate to Tools > Board > Boards Manager…, type the keyword esp32 in the search box, select the latest

version of esp32, and install it.

https://raw.githubusercontent.com/espressif/arduino-esp32/ghpages/package_esp32_dev_index.json


TIP
We have now submitted a merge request to ESP32 and will be able to search and use XIAOESP32-S3 in the
Arduino IDE when ESP32 releases the next version of the on-board package update. Until then, you can manually
add the XIAO-ESP32-S3 on-board package to the Arduino directory to use it. After you have downloaded the
above zip, please unzip it and you will see two files. One is the XIAO_ESP32S3 folder, and the other is boards.txt.

Under Windows PC

The default onboard package storage path for ESP32 in Windows is:

C:\Users\${UserName}\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.7

We need to copy the download boards.txt file to the above path, overwriting the original boards.txt file in this

path.

C:\Users\${UserName}\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.7\variants

Then go to the variants folder and copy the XIAO_ESP32S3 folder to it.



Under MacOS PC

~/Library/Arduino15/packages/esp32/hardware/esp32/2.0.7

We need to copy the download boards.txt file to the above path, overwriting the original boards.txt file in this

path.

~/Library/Arduino15/packages/esp32/hardware/esp32/2.0.7/variants

Then go to the variants folder and copy the XIAO_ESP32S3 folder to it.

Step 4. Close the Arduino IDE and reopen it.

Step 5. Select your board and port

On top of the Arduino IDE, you can select the port directly. This is likely to be COM3 or higher (COM1 and

COM2 are usually reserved for hardware serial ports).

Also, search for xiao in the development board on the left. select XIAO_ESP32S3.



With this preparation, you can start writing programs for XIAO-ESP32-S3 to compile and upload.

BootLoader Mode

There are times when we use the wrong program to make XIAO appear to lose ports or not work properly. The
specific performance is:

Connected to computer, but no port number found for XIAO.

The computer is connected and the port number appears, but the upload program fails.

When you encounter the above two situations, you can try to put XIAO into BootLoader mode, which can solve
most of the problems of unrecognized devices and failed uploads.

The specific method is:

Step 1. Press and hold the BOOT button on the XIAO-ESP32-S3 without releasing it.

Step 2. Keep the BOOT button pressed and then connect to the computer via the data cable. Release the

BOOT button after connecting to the computer.

Step 3. Upload the Blink program to check the operation of the XIAO-ESP32-S3.



Reset
When the program runs abnormally, you can press Reset once during power-up to let XIAO reexecute the
uploaded program. When you press and hold the BOOT key while powering up and then press the Reset key
once, you can also enter BootLoader mode.

Run your first Blink program

Step 1. Launch the Arduino application.

Step 2. Navigate to File > Examples > 01.Basics > Blink, open the program.

Step 3. Select the board model to XIAO-ESP32-S3, and select the correct port number to upload the program.



Once the program is successfully uploaded, you will see the following output message and you can observe that
the orange LED on the right side of the XIAO-ESP32-S3 is blinking. Congratulations, you’ve learned how to write
and upload programs for the XIAO-ESP32-S3!

NOTE
The LED will only turn off when the user LED pin on the XIAO-ESP32-S3 is set to a high level, and it will only turn
on when the pin is set to a low level.

Battery Usage

The XIAO-ESP32-S3 series has a built-in power management chip that allows the XIAO-ESP32-S3 to be powered
independently by using a battery or to charge the battery through the XIAOESP32- S3’s USB port.

If you want to connect the battery for XIAO, we recommend you to purchase qualified rechargeable 3.7V lithium
battery. When soldering the battery, please be careful to distinguish between the positive and negative terminals.
The negative terminal of the power supply should be the side closest to the USB port, and the positive terminal of
the power supply is the side away from the USB port.

NOTE
Since all GPIO pins of the XIAO-ESP32-S3 are assigned their own functions, we do not have a GPIO configured
for the battery pin. this means that we cannot get the battery voltage at the software level by reading the analog
value of one of the GPIOs. If necessary, you can consider connecting the positive and negative terminals of the
battery to two of the pins to measure the battery voltage.

FCC STATEMENT

Changes or modifications not expressly approved by the party responsible for compliance could void the user’s
authority to operate the equipment.



This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions:

1. this device may not cause harmful interference, and

2. this device must accept any interference received, including interference that may cause undesired operation.

This transmitter must not be co-located or operating in conjunction with any other antenna or transmitter.

Note:
This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to Part
15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference in a
residential installation. This equipment generates, uses, and can radiate radio frequency energy, and if not
installed and used in accordance with the instructions, may cause harmful interference to radio communications.
However, there is no guarantee that interference will not occur in a particular installation. If this equipment does
cause harmful interference to radio or television reception, which can be determined by turning the equipment off
and on, the user is encouraged to try to correct the interference by one or more of the following measures:

Reorient or relocate the receiving antenna.

Increase the separation between the equipment and receiver.

Connect the equipment into an outlet on a circuit different from that to which the receiver is connected.

Consult the dealer or an experienced radio/TV technician for help.

This device complies with FCC radiation exposure limits set forth for an uncontrolled environment. This device
should be installed and operated with minimum distance 20cm between the radiator & your body.

The module is limited to OEM installation only

The OEM integrator is responsible for ensuring that the end-user has no manual instructions to remove or install
module The module is limited to installation in mobile or fixed applications, according to Part 2.1091(b) That
separate approval is required for all other operating configurations, including portable configurations with respect
to Part 2.1093 and different antenna configurations.

If the FCC identification number is not visible when the module is installed inside another device, then the outside
of the device into which the module is installed must also display a label referring to the enclosed module. This
exterior label can use wording such as the following: “Contains Transmitter Module FCC ID: Z4T-XIAOESP32S3
Or Contains FCC ID: Z4TXIAOESP32S3”.

Documents / Resources

seeed studio XIAO ESP32S3 Diminutive Development Boards  [pdf] User Guide
Z4T-XIAOESP32S3, Z4TXIAOESP32S3, xiaoesp32s3, XIAO ESP32S3 Diminutive Developmen
t Boards, XIAO ESP32S3, XIAO ESP32S3 Development Boards, Diminutive Development Boar
ds, Development Boards, Diminutive Boards, Boards

Manuals+,

https://manuals.plus/m/440aee92796bc58891ba8dd568268c2627d5bdbb85a6405bd4c2d98033bcfd96
https://manuals.plus/m/440aee92796bc58891ba8dd568268c2627d5bdbb85a6405bd4c2d98033bcfd96_optim.pdf
https://manuals.plus/

	seeed studio XIAO ESP32S3 Diminutive Development Boards User Guide
	seeed studio XIAO ESP32S3 Diminutive Development Boards
	Product Information
	Product Specification
	Product Hardware Overview
	Product Usage Instructions
	Introduction
	Specification
	Features
	Hardware Overview
	Getting Started
	Hardware Preparation

	Software Preparation
	BootLoader Mode
	Run your first Blink program
	Battery Usage
	FCC STATEMENT
	Documents / Resources


