
Home » Redtiger » Redtiger T27 Front and Rearview Mirror Dash Cam User Manual  

T27 USER MANUAL

Redtiger T27 Front and Rearview Mirror Dash Cam User
Manual

Manuals+ —  User Manuals Simplified.

https://manuals.plus/
https://manuals.plus/
https://manuals.plus/category/redtiger
https://manuals.plus/redtiger/t27-front-and-rearview-mirror-dash-cam-manual.pdf


Contents
1  T27 Front and Rearview Mirror Dash
Cam
2 Meeting Your T27
3  T27 Power Tools
4  Setting Up Your Camera
5  Mounting the rear camera
6  Mounting the GPS
7  Mounting the Mirror
8  Playback Your T27
9  Customizing Your T27
10  Parking Mode ( Optional )
11  GPS Player (PC)
12  Trouble Shooting
13  Product Information
14  Documents / Resources

14.1  References
15  Related Posts

T27 Front and Rearview Mirror Dash Cam

 WARNING: Be careful when using your camera and its accessories. Always be caution of your
surroundings to avoid injuring yourself and others.
Make sure to follow all local laws including all privacy laws which may restrict recording in certain areas.

IC warning:

This device contains licence-exempt transmitter(s)/receiver(s)/ that comply with Innovation Science and Economic
Development Canada’s licence-exempt RSS(s). Operation is subject to the following two conditions:

1. this device may not cause interference and

2. this device must accept any interference, including interference that may cause undesired operation of the

device.

Radiation Exposure: This equipment complies with Canada radiation exposure limits set forth for an uncontrolled
environment; To maintain compliance with IC’s RF  Exposure guidelines, This equipment should be. installed and
operated with minimum distance of 20cm the radiator your body. This device and its antenna(s) must not  be
colocated or operation in conjunction with any other antenna or transmitter.

NOTES Before Installation
Do not directly plug and unplug the cable or SD card, please perform related operations after camera off.
Do not expose to the sun for a long time is the best, camera will heat on during its working, any damaged by high
temperature will be added to 1 year free replacement  warranty.
Please use the cables and accessories provided in the package.
Please plug in all accessories and power the dash cam to confirm whether it can work well before installation.
If you encounter any problems, please feel free to contact our customer service.

Meeting Your T27





NO. Name Description

1 Front Camera Record the front view of the vehicle.

2 GPS Port Connect the GPS receiver.

3 Micro SD Card Slot Insert a Micro SD card (maximum support 128G).

4 Rear Camera Port Connect the rear view camera.

5 Power Supply Port Connect the car charger.

6 Fasteners Please use the included silicone straps.

7 Screen 11.26 inch IPS touch screen.

8 Power Button Short press to turn off the screen, long press to turn off the 
power.



Speed & Driving Direction: Once GPS is connected, the information will show

Settings: Touch to enter the menu setting

File Playback: Playback the video & Photo

Start/ Stop Recording

Snapshot: Take a Snapshot

Date & Time

Recording Status: Yellow flashing means Lock Recording

Audio Record is on

Button’s beep sound status

GPS Status: Once the GPS signal is successfully received, the icon will turn GREEN. Otherwise, it 
turns WHITE.

T27 Power Tools

1. Cig Charger  (No Battery Protection) SEE PAGE 5



2. Hardwire Kit (Parking Mode Needed) (Extra charge)

Setting Up Your Camera

SD CARD
With your camera off, insert the SD card into the card slot with the label facing the back of your camera.
You can eject the card by pressing it into the slot with your fingernail.
You’ll need a micro SD card (sold separately) to save your videos and photos. Use a U3 Class 10 SD ™Card
dedicated or your camera may malfunction.
SD cards can degrade over time and affect your camera’s ability to save your media. Try swapping out an older
card for a new one if you’re having any problems.

WIRING SET UP
Connect your camera to a Cig charger using the included cig charge cable.
UPDATING YOUR CAMERA’S SOFTWARE
To get the latest features and best performance from your camera, make sure it’s using the most current software.
Visit – https://www.redtigercam.com/pages/firmware-1

On the LEFT side of the screen: Slide up and down to adjust the angle of view.

https://www.redtigercam.com/pages/%25EF%25AC%2581rmware-1


On the RIGHT side of the screen: Slide up and down to adjust the brightness.

Anywhere on the screen: Swipe the screen left or right to switch between front view, rear view, or split-screen
view.

Mounting the rear camera

How to install the rear camera
We recommend installing the rear camera outside the car (above the license plate). The effect of the rear camera
inside the car may be affected by the windshield.

1. Tear off the 3M tape on the rear lens and paste it above the license plate.

2. Remove the Panel Remove the inner panel of the trunk to expose the rear wiring compartment of the car.

Open the trunk and look for a sturdy inner panel covering the other side of the license plate installation area.

Then, insert a decorative removal tool or another thin device behind the panel and pry it apart.

3. Snake the cable

Use a trim removal tool to pop out tailgate trim, then run the cable from outside of the car into the trunk of your

car.

4. Connect the rear cameras power cable to the extension cable. After snaking your rear camera’s extension

cable, connect the power cable to your rear camera’s  xtensioncord.If you need to install a trigger cable to

activate the reversing guidelines, please find the positive cable of the reversing lamp or ask a professional for

help.



5. After testing, our 3M glue is sufficient to support the weight of our rear camera.

6. We suggest to install outside the car, the effect inside the car is far worse than outside the car.

7. If your car is a RV or a pickup truck, you can install the rear camera forward (the bracket is below), and turn on

the “Upside down of rear camera” and turn off the “Rear  Cam” Mirror Image” to adjust the image.If you need a

license plate bracket, we also provide this accessory, feel free to CONTACT US.

PLACEMENT OF REAR LENS INSIDE CAR

Step 1: Confirm the accessories
1 pc mount bracket (2 pcs black iron sheets)
4 pcs screws (2 pcs small screws, 2 pcs large screws)

Step 2: Place a iron sheet over the rear camera, aim it at the hole, and screw it on.

Step 3: Join the two iron sheets together and turn on the screws.



Step 4:Stick the bracket to the rear windshield with 3M glue

Mounting the GPS

Installation location

Considering the use effect and installation convenience, we usually recommended customers to install it at the
position specified in the picture. Of course, you can also try to  install it in other locations for testing, and choose
the location you think is most suitable.

Mounting the Mirror

Step 1: Pull out the ont lens of the T27 dash cam to match the rearview mirror of the vehicle.



Step 2: Extend the straps around the back of the rear-view mirror and attach them to the bottom retaining hooks.

Step 3: Route your rear camera’s power cable to the front of the car. If you’d like,use a trim removal tool to pop
out the headlining panel directly above your windshield.Then,run you cable through the exposed chamber.

Q: Why is my GPS not working? /How to use GPS ?
A: If you cannot receive the signal after inserting the GPS, please follow the steps below.

1. The vehicle must be within a large area.

2. Insert the GPS plug again.

3. Place the GPS plug upward.

4. Restart

5. It will be recognized after about 40 seconds.

If still cannot receive the signal, it may be a GPS problem. Please CONTACT US and we will help you solve this
problem.

Playback Your T27

Playback Mode



1. Normal Recording

2. Emergency Recording

When you turn on the power, the dash cam will start recording automatically. Click  to enter the
playback mode.

Playback menu

1. Front Normal Album
2. Front Urgent Album
3. Front Photo

4. Back Normal Album
5. Back Urgent Album
6. Back Photo

Customizing Your T27

When T27 Hardwire Kit is not connected



Resolution > 4K+2.5K/2.5K+2.5K

Spilt Time > Looping recording duration 1/3/5 min

Video Encode > H.264/H.265

Sound Record > ON/OFF

G-sensor Sensitivity > OFF/LOW (Recommend) / Middle/ High

Flicker > 50HZ/60HZ

Screensaver Mode
> OFF-Screen always on
Turn off screen-Screen off after 15s/1min/3min
Time screensaver-Screen off after 15s/1min/3min&Time on

Click Tone > ON/OFF

Volume > Adjust the camera volume

Screen Brightness > Slide the screen to adjust

Display Mode > Front/Rear/Preview Right/Preview Left

Rear image Adjustment > Rear Flip/Rear Mirror

24-Hour > Time format-12H/24H

Reverse Mode
Full screen Display



Daylight Saving Time > ON/OFF

Time Format > YY-MM-DD/DD-MM-YY/MM-DD-YY

Fatigue Reminder > Remind after long time driving

Speed Unit > KM/H, MPH

Timezone > Select Corresponding Timezone

GPS Information > Check GPS details

Language > Select correct language

Format SD > Delete all DATA in SD card

Reset Factory > Reset to initial settings

About > Check model & Version number

 After T27 dedicated hardware kit is connected, the icon “enter time lapse” will occur on the screen.

Collision Boot Recording



When a car is hit or rubbed, the G sensor detects the impact and saves the next 20 seconds of video (Urgent
Album)
Working Process:G sensor detects vehicle impact Power on Emergency video recording Power off

When you clik into there will be the following options:
Entering time-lapse… : OFF/Low/Middle/High ( the Sensitivity of G-sensor).
Lapse Record: OFF /12H / 24H /48H (Set the continuous shootingduration of the time-lapse video *Up to 48



hours*)
Lapse Interval: 1S/2S/3S. (Set the frame rate of shootingper second)

Parking Mode ( Optional )

INSTALL YOU HARDWIRE KIT

Red wire >> ACC >>> power off along the car

Yellow wire >> B+ >>> never power off

Black wire >> Ground >>> e.g. screw

POP-UP: You could usually find your fuse box under the trunk or steering device.
You could cut the head of wires and connect it to your fuse directly if your fuses is small.

SELECT PARKING MODE
Enter Parking Mode In Settings
Setting >> Parking Mode>> off/ G-sensor/ TimeLapse12h/ Time-Lapse 24h Time-Lapse 48h
G-SENSOR
> Car off
> ” ACC disconnected ” pop-up
> Collision or vibration be detected
> An Unerasable record will be created in Lock space

TIME-LAPSE
> Select 12h / 24h/ 48h
> A Record will be created in 1 fps during your parking time
> 1 min = actual 12 mins
> Collision or vibration be detected
> An Unerasable record will be created in Lock space
POP-UP: 1 fps = 1 image during 1 second.G-sensor could be activated by a deceleration zone.

GPS Player (PC)



DOWNLOAD GPS PLAYER
Download our GPS Player from website: https://www.redtigercam.com/pages/gps-player

https://www.redtigercam.com/pages/gps-player

Transfer your record to computer

USE YOUR GPS PLAYER

https://www.redtigercam.com/pages/gps-player
https://www.redtigercam.com/pages/gps-player


USE YOUR GPS PLAYER

Trouble Shooting

ULTIMATE SOLUTION
> Use a pin or needle to press the reset button on the back of the mirror.
> Unplug all the accessories of camera and charge to see if it works.
> Check your SD card is U3 Class10, if not,please change or leave message to us to get it.
> Try different charging ways to see if the camera works.
> Update the latest firmware: https://www.redtigercam.com/pages/firmware-1

 Update steps

Check your current version number.
Format your SD card and Insert the SD card into your computer with a car reader.

https://www.redtigercam.com/pages/%25EF%25AC%2581rmware-1


Download the firmware to the computer and Unzip the folder.
Transfer the files to SD card.
Insert the SD card into the dash cam and power it.
Check the version number to confirm whether the update is successful.
> If the method above didn’t solve your problem, feel free to contact us and please leave current address which is
needed if the camera needs to be replaced later.
> This solution could be dealing with multiple problems > Won’t turn on > Restart it self > SD card error
> Can’t auto recover > Can’t playback

Customer Service

WORDS FROM HEART

Since our products are related to the safety of customers, we are committed to product quality and highquality
after-sales, we want to achieve the best product quality. And there will inevitably be defective products showing up
which we feel deeply sorry for those customers.
Thank you for making me a better seller.
We are willing to provide 1 month free return for your product. 1 year limited warranty, and lifetime technical
support. Your product is guaranteed to be free of defects in  materials and products from the date of purchase. In
addition, you can also exchange your 1 year old product for a discounted price by contacting us online.
Please feel free to let me know if there is any further problem with the product, it’s such a pleasure to listen to
your advice, and we will figure it out.
Wish you all the best, sincerely
Redtiger Customer Service Team”.

Email
Mirror Dash Cam
Email: support@redtigercam.com
Mini Dash Cam
Email: help@redtigercam.com
Business Cooperation or Others Email: contact@redtigercam.com

Customer Phone Service:
+1 888 966 8028
Business Day, Mon-Fri
6 AM-12 AM, 1 PM-8 PM
EST (GMT-4)

mailto:support@redtigercam.com
mailto:help@redtigercam.com
mailto:contact@redtigercam.com


redtiger.cam@gmail.com
https://wa.me/qr/RK3
PFZ
6R2FQGD1

https://sourl.cn/8dE8P
M

https://line.me/ti/p/9-K
aptiksc

Product Information

Product Specifications

Item Name > 11.26″ Stream Media Dash Camera

Model > REDTIGER T27

NAND Flash > SPI NOR FLASH 16Mbit

Display/Touch Screen > 11.26 Inch

Display Resolution > 440*1920

The Speaker > 1W 8R

MIC > 4015

Software Support

Language Support > Multilingual Translation

G-Sensor > Yes

Loop Video > Yes

Recording Function > Yes

Front Camera Video Quality > 3840×2160/ 2560×1440

Rear Camera Video Quality > 2560×1440

Photo Resolution > 8M (Max)

Working Voltage > 5 (V)

The Minimum Power Consumption > 200uA

Features

https://manuals.plus/redtiger/redtiger.cam@gmail.com
https://wa.me/qr/RK3PFZ6R2FQGD1
https://sourl.cn/8dE8PM
https://line.me/ti/p/9-Kaptiksc


Rearview camera > WDR AHD

Full Screen Touch > Yes

GPS Trajectory > Yes

Taking Pictures > Yes

Camera Rotation > Yes

Automatic Astern View > Yes

Video Format > MP4

Image Format > JPG

Storage Compression Mode > H.265

The Battery Type > Farad Capacitance 5.5V 4.5F

ACC > Support ACC control of Hardwire Kit

Working Temperature > -20°C~ 70°C

Always go-to dash cam
About Us

In an automobile-interconnection era,
everything about charm journey is within the reach of eyes.

Product and service are the foundation of Redtiger. We have an expert research and
development team of “self-driving experts per capita”.

Based on the personal needs of users,
we use technology to drive product innovation.

In the future, we will continue to explore the boundaries of tech to open up
a broader vision for driving.

Email: support@redtigercam.com
Website: http://www.redtigercam.com

Phone: +188 8966 8028
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