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Introduction

Legal notices
All brands and trademarks named in this document and possibly protected by third-party rights are subject without
limitation to the terms of the valid trademark law and intellectual property rights of their respective registered
owner. You can find a list of the free-source and open-source software as well as copyright notes, license texts,
and, if applicable, the relevant source code on our website under the link: Free & Open Source Software Observe
all local and regional laws and provisions as well as the safety instructions contained in this document.

Contact details

Proemion GmbH

Donaustr. 14

36043 Fulda, Germany

Phone: +49 661 9490-0

Fax: +49 661 9490-111  info@proemion.com.

Proemion Corp.

US Subsidiary

241 Taylor St., Suite 301

Dayton, Ohio 45402, USA

mailto:info@proemion.com


Phone: +1 937 558 2211

Fax: +1 937 641 8787  info-dayton@proemion.com.

Proemion Ltd.

373 Gangnam-daero Seocho-gu

Seoul, 06621, South Korea

Phone: +82 2 6080 9490

Fax: +82 504 484 9490  info-seoul@proemion.com.

Website: Proemion

Warranty and liability

Proemion assumes no liability for defects caused by normal wear, external influence, and errors of installation,
operation, or maintenance. This also applies if the customer or third parties modify the devices, any accessories,
or the software without the approval of Proemion.

About this manual

This document is part of the product and provides important information on the intended use, safety,

installation, and operation of the devices described below.

The document is intended for qualified technicians and electricians with advanced knowledge in electrical

engineering and field bus systems, allowing them to estimate the risks and hazards of operating the device and

to integrate it into systems with components of other manufacturers.

About the software

The CANlink wireless Configurator is a software tool that allows the adaption of objects of the CANopen •

Create the configuration for the device.

Create a support archive.

Read out and write configuration files.

Reset the device.

Additional hints for individual configuration options can be found within the tooltips when

hovering a certain field in the GUI.dictionary for both the CANlink wireless 4000 and CANlink wireless 3000 via

the GUI in order to implement these devices in the desired infrastructure, i.e CAN-CAN bridge or CAN-PC

connection, etc.

The CANlink wireless Configurator can perform the following main features:

Service and Support

The latest versions of the drivers, software, firmware, and documentation are available in our Document

Library.

Do you need help or want to report a bug?

Visit our website Proemion for more information, or raise a ticket at Support.

mailto:info-dayton@proemion.com
mailto:info-seoul@proemion.com


Create Support Archive

The CANlink wireless configurator software incorporates the option to create a backup of the installed device

configuration and static device parameters.

This function can be used to save the original configuration and device information such as software version,

WiFi and Bluetooth MAC address, etc.

In the event of a malfunction, the support archive should be attached to the support request.

To keep a backup of the latest configuration status, it is always recommended to create a support archive

before installing a customized configuration.

1. Connect the device to the PC.

See Connecting with a PC in the CANlink wireless 4000 Device Manual.

For the CANlink wireless 3000, read Connection with a PC via RS232.

2. Choose DEVICE → READ DATA FROM THE DEVICE from the menu.

✓ The configuration from the device is loaded.

3. Choose HELP → CREATE SUPPORT ARCHIVE from the menu.

This opens Windows File Explorer.

Enter an explicit file name for the backup file of the original device configuration.

Click the SAVE button.

This saves a backup file of the original device configuration config.clk and also a text file details.txt

with the most important device information into a *.zip archive:

Click to view the sample device information file:

Details
Example of device information file (details.txt):

Date and time: 16.03.2022 07:41:50

APPLICATION

Name: CANlink wireless Configurator

Version: 4.1.0.1

DEVICE ID string: CANlink wireless 4xxx 1.x.x 2.0 01004001 <RS>

Serial number: 2148007

Product code: 1004001



Vendor ID: 524D

Product group: 120

UNIX time of manufacture: 06.12.2021 06:53:19 UTC

WLAN FW version: 1610.2.4.0.0.36

WLAN MAC address: 80:C9:55:A1:FA:2C

Bluetooth MAC address: 80:C9:55:D3:29:35

Getting Started
This chapter describes the first steps in order to install the CANlink wireless Configurator, to connect the device
with the PC/software and read out and write or adapt the configuration.

Install Software
The CANlink wireless Configurator can be downloaded at Download Center > 03_Proemion Tools Software
>01_Software > 09_PROEMION CANlink wireless Configurator. Password: canbyrm
After the installation of the CANlink wireless Configurator, you can connect your device with the software, see next
section.

Connect Device with CANlink wireless Configurator

Prerequisites

In order to connect the devices with the CANlink wireless Configurator, you must connect them to the PC

beforehand:

To connect the CANlink wireless 4000 with the PC read Connecting with a PC.

To connect the CANlink wireless 3000 with the PC read Connection with a PC via RS232.

After connecting the devices to the PC, you can connect them with the CANlink wireless Configurator:

1. In the menu Options > Communication Settings you can then select the serial port for the Bluetooth

connection.

2. To finally connect, select Device > Connect or .

The device is now connected to the CANlink wireless Configurator.

You can now Read Data from the Device or Create a new Configuration.

In case the device firmware is outdated, a dialog may be displayed upon connecting the device, see

below.

To update the device firmware, read Firmware Update for CANlink wireless 4000 (or Firmware Update for

the CANlink wireless 3000).



To disconnect the device, select Device > Disconnect or select .

Load/Open Configuration

In order to use a local configuration file from your computer in the CANlink wireless Configurator, in the

Menubar, select File > Load Configuration or select.

When selecting Read Data from Device, it overwrites the loaded configuration .

Configure Device

The CANlink wireless Configurator allows configuring the device via different settings.

These settings are sorted in the following tabs.

Possible applications of the CANlink wireless device and their settings are described in Use Cases Overview in

the CANlink wireless 4000 Device Manual.



CAN Baudrate

The CAN baud rate is the speed/rate at which the data is transmitted on the CAN bus.

When integrating the device into the desired CAN network, it must be ensured that the configured CAN baud

rate is matching the CAN baud rate of the local CAN bus, otherwise, the device changes to error mode.

Devices with installed factory configuration have a default CAN baud rate of 250 kbit/s.



After a reset to factory settings (see Reset Device), the CAN baud rate is set back to 250kbit/s.

CANopen

The CANopen node ID (address) of a CANopen device on the local CAN bus must be unique and within the

range from 1 to 127.

With the factory configuration installed as well as after a factory reset, the default CANopen node ID for the

CANlink wireless 4000 is 34 (decimal).

Advanced Settings

Select Options > Advanced Settings to configure the following fields.

Hover over the fields and check marks to find the tooltips.

Timestamp Mode

Feedback Mode

CANopen

Heartbeat time

CANopen communication during active wireless connection:

To enable the CANopen stack and send messages.

The SDO server is displayed as 0x600 with the Node ID as hexadecimal 22.

For more details, read Enabling the CANopen Stack and other sections of the chapter “CANfunctions” in the



CANlink wireless 4000 Device Manual.

Enable boot-up message

CAN Receive

The CAN Receive tab shows the active/inactive receive objects for 11- and 29-bit CAN message identifiers

and allows filtering of selected CAN messages to improve the message throughput.

The default configuration for the CAN Receive settings already include active receive objects with open filter

masks for all 11-bit and 29-bit CAN message identifiers.

With this setting, all CAN messages are transmitted.

If the CANlink wireless device is connected to a CAN bus with a high bus load, filtering of specific messages is

recommended.

For a detailed description and examples, read Filter received CAN messages in the CANlink wireless 4000

Device Manual

Configuration
In the Online CAN Object section, you can configure the following fields:

ID length: is used to select an 11-bit or extended 29-bit CAN message identifier.

Mask: is used to set a filter mask for single messages or specific groups of messages.



This makes it possible to only transfer the application-relevant messages.

CAN identifier: is used to filter by CAN IDs (in the format hex (0x) or decimal – the format can be changed in

the field Display Format)

Downsampling: is used to limit the transmission rate in case of a high message frequency.

Downsampling is only recommended for filtering of single messages.

The CAN messages are transmitted via block transfer. Depending on the message load and the radio

technology used, there are unavoidable latency times. Please test your configuration and application under

real operating conditions.

WLAN
In the WLAN tab, you can configure the WLAN communication settings.

Access Point Settings

You can configure the channel of the access point mode for the CAN-WLAN interface.

For more details, read CAN-WLAN Interface in the CANlink wireless 4000 Device Manual.

The Access Point Settings field can be opened via the Options > Advanced Settings:



Bluetooth

In the tab Bluetooth you have the Device Settings and Security Settings sections in order to:

Change the device name.

Make it discoverable and pairable (a requirement for Bluetooth).

Device Name
The device name may have 4 to 29 characters.

Enforcing PIN Code



When entering a Bluetooth PIN code for the CAN-PC connection, the length may have a maximum size of 15

characters.

When the PIN code has been enforced, the password is required:

For the device.

Here, the PIN must be entered in this PIN code field.

For the device to be paired, e.g. PC.

Here, a window will be displayed for entering the PIN and establishing the connection.

Wireless Peers

The Wireless Peers tab is used to set up a point-to-point (P2P) (bridge) connection, i.e. connecting a device to

another, to enable the manipulation of CAN data or to share CAN data between 2 physically separated

networks.

Therefore, both the server and client must be configured.

For more information, read the Use Cases Overview in the CANlink wireless 4000 Device Manual.

A CANlink wireless 4000 device cannot be a wireless server and a client at the same time.

Add Server/Client

On how to add a CANlink wireless 4000 as a Server or Client (bridge), proceed as follows:

1. In Server Configuration, select the desired Type, e.g. SPP.

2. Make sure the Server Configuration is enabled.



3. In Client Configuration, select the desired Type, e.g. SPP.

4. Make sure the Client Configuration is enabled.

How to…

Read Data from the Device

To read data from the device, select Device > Read Data from the Device or select .

The configuration is then loaded in the CANlink wireless Configurator, i.e. the configuration are filled out

accordingly in the tabs.

By reading the data, it may overwrite the currently loaded configuration.

A warning will be displayed.

Write Configuration to Device

To apply the changes in the configuration to the device, in the menu bar, select Device > Write Data to the

Device or select .

When the write-data was successful, the message “Wrote data to device” is displayed briefly.

Create new Configuration

The CANlink wireless configuration file format is .clk.

To start with a blank configuration file, in the menu bar, select File > New Configuration or select .

To use an existing configuration file, you can Load/Open Configuration.

Reset Device

Go to Device > Reset Device to Factory Settings.

The existing configuration is then overridden with the factory settings of the CANlink wireless Configurator.

Get Device Information

To view information about the CANlink wireless 4000, select Device > Device Information.

A dialog with information about the Device ID, Serial number, and Bluetooth MAC address is displayed.

Read also how to use the device information for Support.
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