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Product Information

The IO-Config configuration software is used to configure Remote IO products. It enables functions such as
parameter uploading and downloading, process data monitoring, data address table view, device search, and
firmware upgrades. When using IO-Config to configure the software, the serial port supports all protocol adapters
for parameter uploading, configuration parameter modification, and online monitoring. The ethernet port only
supports the Modbus TCP adapter (CN-8031) for these functions.

The serial MicroUSB cable is required for data transmission and power supply. Some mobile USB cables only
have the power supply function and cannot be used for adapter parameters uploading and downloading.

Product Usage Instructions

1. Find the installation package and install IO Config software. Open IO Config configuration software after

installation.

2. In the menu bar, click File > Project > New Project, or use the shortcut key or right-click Project > New Project in

the project bar. Fill in the project name.

3. In the project bar, right-click NewProject Module and select CN-8031 from the pop-up window. Then select one

network port or serial port (if selecting the serial port, select the serial port number) and click OK. Note: All

network adapter modules can connect to the configuration software for debugging through the serial port. Only

the MODBUS TCP adapter can connect to the configuration software for debugging through both the Ethernet

port and serial port.

4. In the project bar, right-click CN-8031 and click Module Manager. Double-click to select the detailed IO module

that will be connected with CN8031 from the pop-up window and click OK.

5. To manually add modules, use the shortcut keys Ctrl C (copy), Ctrl V (paste), and Delete (delete). Select CN-

8031 and click the shortcut Ctrl S to save the configuration project.

6. In the information bar, click Basic Information, Process Data, Configuration Parameters, Address Table, and

Installation Information to view IO module information.

7. In the Basic Information interface, you can view the communication protocol and version information of the



current adapter module, as well as the module description and version information of the IO module.

8. In the Process Data interface, you can view the data type of the IO module, as well as the online monitoring

value of the input data the online monitoring value, and the current value of the output data.

Software introduction

IO Config configuration software is used to configure Remote IO products, which could realize the module
functions of parameter uploading and downloading, process data monitoring, data address table view, device
search, firmware upgrade, etc.
Note: when using IO-Config to configure the software, the serial port supports all the protocol adapters for
parameter uploading, configuration parameter modification, online monitoring, etc. The Ethernet port only
supports the Modbus TCP adapter (CN-8031) for parameter uploading, configuration parameter modification,
online monitoring, etc.
The serial MicroUSB cable is required for the function of data transmission and power supply. Some mobile USB
cables only with a power supply function, and no data transmission function, so it cannot be used for adapter
parameters uploading and downloading.

Offline configurations

When the device is disconnected from the software, the network adapter and IO module could be preselected

according to the user’s actual module needs, and the software will automatically generate the data address

mapping table.

The offline mode is mainly designed for the Modbus adapter, and the address in the address mapping table is

the access address of IO module data. For another protocol adapter, the IO address of the device could be

automatically generated after being configured in the configuration software of the host station system.

In offline mode, adding the module manually to view the address table is as below steps:

1. Find the installation package, click Install IO Config software, and open IO Config configuration software after

installation.

2. Click File→Project→New Project in the menu bar, or click the shortcut key or right-click Project→New Project in

the project bar, and fill in the project name.



3. Right-click the NewProject Module in the project bar, and select CN-8031 In the pop-up window, then select

one network port or serial port (if selecting serial port and it needs to select serial port number) and click OK.

Note: All network adapter modules could connect to the configuration software for debugging through the serial

port. Only MODBUS TCP adapter can connect to the configuration software for debugging both through the

Ethernet port and serial port.

4. Right-click CN-8031→click Module Manager, Double-click to select the detailed IO module that will hang with

CN8031 in the pop-up window, and click OK.



Module manually adding supports shortcut keys “Ctrl C”, “Ctrl V” and “Delete” for copy, paste and delete IO

module. Select CN-8031 and click the shortcut “Ctrl S” to save the configuration project.

5. Click Basic Information, Process Data, Configuration Parameters, Address Table and Installation Information in

the information bar to view IO module information.

In the Basic Information interface, you can view the communication protocol and version information of the
current adapter module, and the module description and version information of the IO module.

In the Process Data interface, you can view the data type of the IO module, as well as the online monitoring
value of the input data, and the online monitoring value and the current value of the output data.



In the Configuration Parameters interface, the configuration parameters and communication parameters of the
adapter module cdoul be set. Configuration parameters of IO module could be set.

In the Address Map interface, you can view the channel address of the IO module. Click the address table save
button or the shortcut “Ctrl M” to export the address table. And address table format is TXT or XLS.





In the Installation Information interface, you can check the current, size and other parameters of the module.



Online configurations

Supplying 24V power to the module, and connect the module to the computer with a Micro USB or network cable
(a Micro USB cable needs to install a driver, and the COM port will be automatically assigned after the driver
installation, such as COM3).

1. After installing IO Config software, open the configuration software, and click File→Project→New Project in the

menu bar, or click the shortcut of New Project, or right-click Project→New Project in the project menu bar, and

manually fill in the project name.

2. In the Property bar, modify the upload interface by selecting serial port and the serial port number is COM10, or

modify the upload interface to select Ethernet. The device IP address: 192.168.1.100 (MODBUS TCP

communication only). Right-click on the project menu.



When the adapter module is CN-8031 (MODBUS TCP communication), click Tool to search device or click the

shortcut  to search device, select the Local Network Card in the pop-up interface, then click Search Device,

and all adapter modules in the network structure will be scanned in the device list. In this interface, it could view

parameters such as the version of adapter hardware and software, IP address and so on. When there are

multiple adapters in the network, it supports the function of “Light Up” to find the device, “Download” to modify

the adapter IP address and “Restart”. When firmware needs to be upgraded, click “Upgrade” to enter the

upgrade interface.

Clicking “Upload” and all IO modules will be uploaded automatically in the project menu.



For the digital input module, you can manually add the counting sub-module.



After adding a sub-module, you must right-click to download the module configuration or right-click CN-8031 to

download IO parameters. Otherwise, if clicking directly online and it will result in an error in the state menu of

“the number of sub-modules does not match the total number of configuration sub-modules”.

3. Right-click the adapter module CN-8031 and click online. It could monitor the IO module data online.



Example: CT-121F in slot 1, the external power 24VDC is supplied to the DI0 of CT-121F. And in the process

data interface, the CH0 monitoring value is 1.

Example: Assigning the CH0 channel of CT-4234 in slot 4 to 16#7530= 30000, and connect it to the CH0

channel of CT-3238 in slot 3 at the same time.The CH0 of CT-3238 monitoring value is 16#3125.



4. Configuration parameters can be modified in the configuration interface.



After the parameters are changed, you can right-click on CN-8031-Download IO Parameters in the project bar.

So the configuration parameters of the adapter and IO module could be modified.

After all parameters are modified, select CN-8031 and click the shortcut key “Ctrl S” to save the configuration

project.



Update device library files

Update device library file is used to update the newly added IO module of software. When a new IO module is
released, the customer can import the IO module into the configuration software by only updating the device
library file, so there is no need to reinstall the configuration software.
First, copy and paste the latest version of the device library file of BLADE-IO-CONFIG-HSP-20200213 into the
GSD folder of the software installation directory.

Second, click Option-Configuration or shortcut key in the menu bar. And in the pop-up window, please find the
new library file (.oml) under the ‘Path config’, and click open to complete the update of the device library File.



Device firmware upgrades

In IO Config software, click Tool→Online upgrade or shortcut , and in the pop-up window, select “Serial Port”
(Ethernet could be selected for MODBUS TCP communication) and the serial port number is “COM10”. Click “read
Info” to view the version information of the current adapter or IO module.

Click the right side of the upgrade file, and select the upgrade file (.ofd) of the analog output module CT-4234 in
the pop-up window, and open it.



The upgrade version and other information could be viewed in the lower left side of the upgrade menu. And there
is no upgrade for the currently firmware version so no need for upgrading. If the version information is inconsistent,
please select the slot where the module is located(marking√) and click to start the upgrade.
Note: if the hardware version displayed on the lower left side of the menu is IO module, and it needs to select the
slot where the module is located(marking√) and click to start the upgrade.

Please note when upgrading: just click to Start for the upgrade, after the upgrade is completed, and it requires to
enter APP mode, so it needs to manually click “run APP” or power up the device again.



If it only needs to upgrade the firmware of one module, you can select Automatic Skip (to APP), and click Start for
upgrade, then the APP will run automatically when the upgrade is completed. If it needs to upgrade the firmware of
multiple modules, please do not select Automatic Skip (to APP). Clicking Run APP after all the modules upgrade is
finished.

Documents / Resources

Odot IO-Config Configuration Software  [pdf] User Guide
CN-8031, IO-Config, IO-Config Configuration Software, Configuration Software, Software

References

User Manual

https://manuals.plus/m/1eb7f1b1ed9307d7d2179dec516617b7ac8394db8b3a6da5be5ef097393656af
https://manuals.plus/m/1eb7f1b1ed9307d7d2179dec516617b7ac8394db8b3a6da5be5ef097393656af_optim.pdf
https://manual.tools/?p=10215250#MTA0LjI4LjIwMi4xNzg7Ozs7


Manuals+, Privacy Policy

This website is an independent publication and is neither affiliated with nor endorsed by any of the trademark owners. The "Bluetooth®" word mark and logos are registered trademarks owned by Bluetooth
SIG, Inc. The "Wi-Fi®" word mark and logos are registered trademarks owned by the Wi-Fi Alliance. Any use of these marks on this website does not imply any affiliation with or endorsement.

https://manuals.plus/
https://manuals.plus/privacy-policy

	Odot IO-Config Configuration Software User Guide
	Odot IO-Config Configuration Software
	Product Information
	Product Usage Instructions
	Software introduction
	Offline configurations
	Online configurations
	Update device library files
	Device firmware upgrades
	Documents / Resources
	References



