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Product Information

Specifications

Independent AI channels: 8

Independent AO channels: 8

DIO lines: 96

Functionality: Customizable with FPGA (Field-Programmable Gate Array)

Software Compatibility: LabVIEW 7.0 or later, LabVIEW FPGA Module 1.0 or later, NI-RIO 1.0 or later

Memory: Flash memory for storing startup VI

Introduction

The NI 783xR is a versatile device that offers independent AI channels, independent AO channels, and DIO

lines. Unlike traditional I/O devices, the NI 783xR features an FPGA that allows you to define device

functionality and timing according to your needs.

The LabVIEW FPGA Module enables you to design the timing and functionality of the NI 783xR using a

graphical interface, eliminating the need to learn low-level programming languages or hardware description

languages (HDL) typically used for FPGA design. With the LabVIEW FPGA Module, you can create or

download custom virtual instruments (VIs) to the FPGA and reconfigure the NI 783xR with a new VI at any

time.

The NI 783xR also supports communication and control through the LabVIEW Real-Time Module. This module

enables real-time floating-point processing, data logging, and other additional tasks while interacting with the NI

783xR.

Note: If you are using LabVIEW without the LabVIEW FPGA Module, you can control existing FPGA VIs

through LabVIEW but cannot create new FPGA VIs.

Product Usage Instructions

Required Components
Before using the NI 783xR with Windows 2000/XP and the LabVIEW Real-Time Module, ensure you have the
following components:



NI 783xR User Manual (included on the NI-RIO CD or available at ni.com/manuals)

NI PXI-783xR

Software packages: LabVIEW 7.0 or later, LabVIEW FPGA Module 1.0 or later, NI-RIO 1.0 or later

PXI/CompactPCI chassis and embedded controller running Windows 2000/XP, or a computer running Windows

2000/XP with an MXI-3 link to a PXI/CompactPCI chassis

Cables and devices for connecting signals to the PXI-783xR

Setting Up the NI 783xR with Windows 2000/XP
To set up and use the NI 783xR with Windows 2000/XP, follow these steps:

1. Install the required software packages: LabVIEW 7.0 or later, LabVIEW FPGA Module 1.0 or later, and NI-RIO

1.0 or later.

2. Ensure you have a PXI/CompactPCI chassis and a PXI/CompactPCI embedded controller running Windows

2000/XP, or a computer running Windows 2000/XP with an MXI-3 link to a PXI/CompactPCI chassis.

3. Connect at least one cable and device to the PXI-783xR for signal connection.

Setting Up the NI 783xR with the LabVIEW Real-Time Module (ETS)
To set up and use the NI 783xR with the LabVIEW Real-Time Module for ETS, follow these steps:

1. Install the required software packages: LabVIEW 7.0 or later, LabVIEW FPGA Module 1.0 or later, and NI-RIO

1.0 or later.

2. Ensure you have a host computer running Windows 2000/XP for developing your application.

3. Set up a PXI/CompactPCI chassis and a real-time embedded controller running the Phar Lap ETS real-time

operating system.

4. If the real-time PXI system is not configured on a network, use a CAT 5 Ethernet crossover cable. To connect

the PXI system to a network port, use a standard CAT 5 10/100Base-T Ethernet cable.

5. Connect at least one cable and device to the PXI-783xR for signal connection.

FAQ

Q: What is the maximum number of AI channels supported by the NI 783xR?

The NI 783xR supports a maximum of 8 independent AI channels.

Q: Can I create custom virtual instruments (VIs) using the NI 783xR?

Yes, you can use the LabVIEW FPGA Module to create or download custom VIs to the FPGA of the NI 783xR.

Q: What software packages are compatible with the NI 783xR?

The NI 783xR is compatible with LabVIEW 7.0 or later, LabVIEW FPGA Module 1.0 or later, and NI-RIO 1.0 or

later.

Getting Started with the NI 783xR
This document explains how to install and configure the National Instruments 783xR.

Introduction

The NI 783xR devices are R Series Reconfigurable I/O (RIO) devices with 16-bit analog input (AI) channels, 16-bit
analog output (AO) channels, and digital I/O (DIO) lines.
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The NI PXI-7830R and NI PCI-7830R have four independent AI channels, four independent AO channels, and

56 DIO lines.

The NI PXI-7831R/7833R and NI PCI-7831R/7833R have eight independent AI channels, eight independent AO

channels, and 96 DIO lines.

Traditional I/O devices have a fixed functionality provided by an application-specific integrated circuit (ASIC), but
the NI 783xR has an FPGA (Field-Programmable Gate Array) that allows you to define device functionality and
timing.
You can use the LabVIEW FPGA Module to graphically design the NI 783xR timing and functionality without
having to learn a low-level programming language or a hardware description language (HDL) traditionally used for
FPGA design. With the LabVIEW FPGA Module, you create or download a custom virtual instrument (VI) to the
FPGA. You can reconfigure the NI 783xR with a new VI at any time. You can use the LabVIEW Real-Time Module
to communicate with and control the NI 783xR while performing additional tasks, such as real-time floating-point
processing and data logging.

Note
If you are using LabVIEW but not the LabVIEW FPGA Module, you can create VIs that run in LabVIEW to control
existing FPGA VIs, but you cannot create new FPGAVIs.

The NI 783xR has Flash memory that you can use to store a startup VI. You can configure the VI to load to the
FPGA and to run when the device powers up.

Required Components

Documentation

This section lists the items necessary for using the NI 783xR with Windows 2000/XP and the LabVIEW Real-

Time Module.

The NI 783xR User Manual describes the electrical and mechanical aspects of the NI 783xR and contains

information about device operation and programming. This document is included on the NI-RIO CD and is also

available at ni.com/manuals.

For software reference information for the NI 783x devices, refer to LabVIEW Help, which is available in

LabVIEW by selecting Help» Search the LabVIEW Help.

Hardware and Software

PXI-783xR with Windows 2000/XP
The following items are necessary to set up and use the PXI-783xR on a computer running Windows 2000/XP:

NI PXI-783xR.

The following software packages:

LabVIEW 7.1 or later.

LabVIEW FPGA Module 1.1 or later—required to develop custom FPGA VIs.

NI-RIO 1.3 or later—included with the PXI-783xR.

Note The PXI-7831R supports LabVIEW 7.0 or later, LabVIEW FPGA Module 1.0 or later, and NI-RIO 1.0

or later.

PXI/CompactPCI chassis and PXI/CompactPCI embedded controller running Windows 2000/XP, or a computer

running Windows 2000/XP and a MXI-3 link to a PXI/CompactPCI chassis.

http://ni.com/manuals


At least one cable and device for connecting signals to the PXI-783xR.

PXI-783xR with the LabVIEW Real-Time Module (ETS)
The following items are necessary to set up and use the PXI-783xR with the LabVIEW Real-Time Module for ETS:

NI PXI-783xR.

The following software packages:

LabVIEW 7.1 or later.

LabVIEW FPGA Module 1.1 or later—required to develop custom FPGA VIs.

LabVIEW Real-Time Module 7.1 or later.

NI-RIO 1.3 or later—included with the PXI-783xR.

Ardence (formerly Venturcom) Phar Lap Embedded Tool Suite (ETS).

Note The PXI-7831R supports LabVIEW 7.0 or later, LabVIEW FPGA Module 1.0 or later, and NI-RIO 1.0

or later.

Host computer running Windows 2000/XP for developing your application.

PXI/CompactPCI chassis and real-time embedded controller running the Phar Lap ETS real-time operating

system.

CAT 5 Ethernet crossover cable if the real-time PXI system is not configured on a network. To connect the PXI

system to a network port, use a standard CAT 5 10/100Base-T Ethernet cable.

At least one cable and device for connecting signals to the PXI-783xR.

PXI-783xR with the LabVIEW Real-Time Module (RTX)
The following items are necessary to set up and use the PXI-783xR with the LabVIEW Real-Time Module for RTX:

NI PXI-783xR.

The following software packages:

LabVIEW 7.1 or later.

LabVIEW FPGA Module 1.1 or later—required to develop custom FPGA VIs.

LabVIEW Real-Time Module 7.1 or later.

NI-RIO 1.3 or later—included with the PXI-783xR.

Ardence (formerly Venturcom) RTX 5.5 or later.

Note The PXI-7831R supports NI-RIO 1.1 or later.

PXI/CompactPCI chassis and real-time embedded controller running Windows 2000/XP and RTX.

CAT 5 Ethernet crossover cable if the real-time PXI system is not configured on a network. To connect the PXI

system to a network port, use a standard CAT 5 10/100Base-T Ethernet cable.

At least one cable and device for connecting signals to the PXI-783xR.

PCI-783xR with Windows 2000/XP
The following items are necessary to set up and use the PCI-783xR on a computer running Windows 2000/XP:

PCI-783xR.

The following software packages:

LabVIEW 7.1 or later.

LabVIEW FPGA Module 1.1 or later—required to develop custom FPGA VIs.

NI-RIO 1.3 or later—included with the PCI-783xR.



Note The PCI-7831R supports NI-RIO 1.1 or later.

Development computer running Windows 2000/XP.

At least one cable and device for connecting signals to the PCI-783xR.

PCI-783xR with the LabVIEW Real-Time Module (ETS)
The following items are necessary to set up and use the PCI-783xR with the LabVIEW Real-Time Module for ETS:

PCI-783xR.

The following software packages:

LabVIEW 7.1 or later.

LabVIEW FPGA Module 1.1 or later—required to develop custom FPGA VIs.

LabVIEW Real-Time Module for ETS 7.1 or later.

NI-RIO 1.3 or later—included with the PCI-783xR.

Ardence (formerly Venturcom) Phar Lap Embedded Tool Suite (ETS).

Note The PCI-7831R supports NI-RIO 1.1 or later.

Host a computer running Windows 2000/XP for developing your application.

Target computer running the Phar Lap ETS real-time operating system.

At least one cable and device for connecting signals to the PCI-783xR.

PCI-783xR with the LabVIEW Real-Time Module (RTX)
The following items are necessary to set up and use the PCI-783xR with the LabVIEW Real-Time Module for RTX:

PCI-783xR.

The following software packages:

LabVIEW 7.1 or later.

LabVIEW FPGA Module 1.1 or later—required to develop custom FPGA VIs.

LabVIEW Real-Time Module for RTX 7.1 or later.

NI-RIO 1.3 or later—included with the PCI-783xR.

Ardence (formerly Venturcom) RTX 5.5 or later.

Note The PCI-7831R supports NI-RIO 1.1 or later.

Computer running Windows 2000/XP and RTX.

Note RTX 5.5 does not support Hyper-Threading enabled processors. Refer to the RTX documentation for

information about disabling multiprocessor access.

At least one cable and device for connecting signals to the PCI-783xR.

Installing Software

Complete the following sets of steps in the order listed to successfully install LabVIEW, the LabVIEW Real-Time

Module, the LabVIEW FPGA Module, and the NI-RIO device drivers.

If you are using NI-RIO without LabVIEW, skip these steps and proceed to the NI-RIO Device Drivers

Installation section.

LabVIEW Installation
Complete the following steps to install LabVIEW. Refer to the LabVIEW Release Notes for additional information
about installing LabVIEW.
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1. Insert the LabVIEW CD into the CD-ROM drive to display the LabVIEW installation screen.

2. Click Install LabVIEW.

3. Follow the installer prompts through the rest of the installation.

The installer also may prompt you to insert the Driver CD. Disregard this prompt. The Driver CD is not required for
the NI 783x.

LabVIEW Real-Time Module Installation
Complete the following steps to install the LabVIEW Real-Time Module. Refer to the LabVIEW Real-Time Module
Release Notes for additional information about installing the LabVIEW Real-Time Module.

Note
If you are using the NI 783xR with Windows 2000/XP only, it is not necessary to install the LabVIEW Real-Time
Module.

1. Insert the LabVIEW Real-Time Module CD into the CD-ROM drive to display the LabVIEW Real-Time Module

installation screen.

2. Click Install LabVIEW Real-Time Module.

3. Follow the installer prompts through the rest of the installation.

LabVIEW FPGA Module Installation
Complete the following steps to install the LabVIEW FPGA Module. Refer to the LabVIEW FPGA Module Release
Notes for additional information about installing the LabVIEW FPGA Module.

1. Insert the LabVIEW FPGA Module CD into the CD-ROM drive to display the LabVIEW FPGA Module

installation screen.

2. Click Install LabVIEW FPGA Module.

3. Follow the installer prompts through the rest of the installation.

NI-RIO Device Drivers Installation
Complete the following steps to install the NI-RIO device drivers that are included with the NI 783xR device.

Note
You must install LabVIEW and the LabVIEW modules you will use before you install the NI-RIO device drivers.

Tip
If you installed NI-RIO from the LabVIEW FPGA installer, skip this section.

1. Insert the NI-RIO CD into the CD-ROM drive to display the NI-RIO installation screen.

2. Click Install NI-RIO.

3. Follow the on-screen instructions until the Feature Tree window appears.

4. In the Feature Tree window, select the components to install. You must install NI-VISA, NI-RIO, and NI

Measurement & Automation Explorer (MAX).

5. Follow the on-screen instructions to complete the driver installation.

6. Restart the computer.

Installing Hardware



This section describes how to unpack and install the PXI-783xR and PCI-783xR devices.

Note
You must install the NI-RIO device drivers before installing the NI 783xR.

Unpacking

The NI 783xR is shipped in an antistatic package to prevent electrostatic discharge from damaging device
components. To prevent such damage when handling the device, take the following precautions:

Ground yourself using a grounding strap or by holding a grounded object, such as your computer chassis.

Touch the antistatic package to a metal part of the computer chassis before removing the device from the

package.

Caution
Never touch the exposed pins of connectors.

Remove the device from the package and inspect the devices for loose components or any other sign of

damage. Notify NI if the device appears damaged in any way. Do not install a damaged device into the

computer.

Store the NI 783xR in the antistatic envelope when not in use.

PXI-783xR Installation
You can install the PXI-783xR in any available peripheral slot in the PXI or CompactPCI chassis. Complete the
following instructions to install the PXI-783xR:

Note
You must install the software before installing the hardware. For software installation instructions, refer to the
Installing Software section.

1. Power off and unplug the PXI or CompactPCI chassis.

2. Make sure there are no lit LEDs on the chassis. Wait for any lit LEDs to go out before continuing the installation.

3. Remove the filler panel for the peripheral slot.

4. Ground yourself using a grounding strap or by touching a grounded object, such as the PXI or CompactPCI

chassis.

5. Insert the PXI-783xR into the slot. Use the injector/ejector handle to fully inject the PXI-783xR into place.

6. Screw the front panel of the PXI-783xR to the front panel mounting rails of the chassis.

7. Visually verify the installation. Make sure the PXI-783xR is not touching other devices or components and that

the PXI-783xR is fully inserted into the slot.

8. Plug in and power on the PXI or CompactPCI chassis.

PCI-783xR Installation

You can install the PCI-783xR in any available PCI expansion slot in the computer. To achieve the best noise
performance, leave as much room as possible between the PCI-783xR and other boards.

Complete the following instructions to install the PCI-783xR:



Note
You must install the software before installing the hardware. For software installation instructions, refer to the
Installing Software section.

1. Power off and unplug the computer.

Caution

To protect both yourself and the computer from electrical hazards, the computer must remain off and unplugged

until the PCI-783xR is completely installed.

2. Remove the computer cover. Make sure there are no LEDs on the motherboard. Wait for any LEDs to go out

before continuing the installation.

3. Touch the metal part of the power supply case inside the computer to discharge any static electricity that might

be on your clothes or body.

4. Locate the metal bracket that covers the cut-out in the back panel of the chassis for the slot you have selected.

Remove and save the bracket-retaining screw and the bracket cover.

5. Align the PCI-783xR card-edge connector with the expansion slot receptacle. Using slow, evenly distributed

pressure, press the PCI-783xR straight down until it sits in the expansion slot.

6. Reinstall the bracket-retaining screw to secure the PCI-783xR to the back panel rail.

7. Visually verify the installation.

8. Replace the computer cover, and plug the computer in.

Using the NI 783xR with the LabVIEW Real-Time Module for RTX

You can use the LabVIEW Real-Time Module for RTX with the NI 783xR. After you have installed RTX, the
LabVIEW Real-Time Module for RTX, and RTX support from the NI-RIO Driver CD, complete the following steps:

Note
The NI-RIO device drivers and NI 783xR must be installed before adding RTX support for the R Series device.

1. If necessary, close all NI software.

2. Select Start» Program Files» Ardence RTX» RTX» RTX Properties.

3. On the Plug and Play tab, right-click the name of your device and select Add RTX INF Support.

4. Click the Apply button. RTX Properties returns a Warning dialogue box. Click OK.

5. In the RTX Properties window, click OK.

6. Right-click My Computer and select Properties.

7. Select the Hardware tab and click Device Manager.

8. For Windows XP, expand NI-RIO Devices, right-click the name of your device and select Update Driver. In the

Hardware Update Wizard window, select Install the software automatically and click Next. When the wizard

finishes installing the software, click Finish. For Windows 2000, expand NI-RIO Devices, right-click the name of

your device, and select Properties. On the Driver tab, click Update Driver. In the Upgrade Device Driver Wizard

window, click Next. Select Search for a suitable driver for my device and click Next three times. When Windows

finishes installing the software, click Finish.

9. In the Device Manager window, select View» Resources by connection.

10. In the Device Manager window, expand Interrupt Request (IRQ). Make sure that the NI 783xR is not sharing an

IRQ with any other devices. Refer to the RTX Runtime Help for information about modifying a device.

11. Reboot your computer.



12. Select Start» Run. In the Run window, enter net start nitrox and click OK.

The NI 783xR now supports RTX. When you launch LabVIEW, the NI 783xR appears in the LabVIEW Execution
Target menu as FPGA Device [device name] visa://localhost::RTRTX::0/RIO0::INSTR.

Removing RTX Support

Complete the following steps to remove RTX support from the NI 7831R.

1. Close all NI software.

2. Select Start» Program Files» Ardence RTX» RTX» RTX Properties.

3. On the Plug and Play tab, right-click the name of your device and select Remove RTX INF Support.

4. Click Apply. RTX Properties returns a Warning dialog box. Click OK.

5. In the RTX Properties window, click OK.

6. Right-click My Computer and select Properties.

7. Select the Hardware tab and click Device Manager.

8. For Windows XP, expand RTX Drivers, right-click [device name] RTX Supported and select Update Driver.

You have removed RTX support for the NI 783xR.

Using Remote NI 783xR Devices

The following sections discuss working with remote NI 783x devices.

Configuring and Accessing Remote FPGA Targets

The NI 783x, which is an FPGA target, might be located in other systems on the network, which are known as

remote systems. The FPGA Module uses the NI-VISA communication protocol to locate FPGA targets in

remote systems, which are known as remote FPGA targets. MAX detects remote FPGA devices as VISA

resources and displays them in the Devices and Interfaces category for the remote system they are connected

to. To make remote FPGA targets accessible to other computers on the network, you run the NI-VISA Server on

the remote system.

The NI-VISA Server is a tool that enables users on a network to access VISA resources on the computer on

which the NI-VISA Server is running. The NI-VISA Server can run on networked RT targets, located both on and

off the local subnet, and Windows computers.

After you install and start the NI-VISA Server on the remote system, you must grant access permissions to the

remote system in MAX, as described in the Setting Access Permissions for Remote FPGA Targets section.

When the FPGA target appears in MAX, verify that you can access the FPGA target, as described in the

Verifying Communication with Remote FPGA Targets section. If you cannot verify access to the remote FPGA

target using MAX or if you receive an error message when attempting to add the remote FPGA target to the

Project Explorer window in LabVIEW, verify that you correctly set access permissions. You then can add the

remote system to the Project Explorer window in LabVIEW. Refer to the LabVIEW Help for information about

adding the remote system to the Project Explorer window. The LabVIEW Help is available by clicking Help»

Search the LabVIEW Help in LabVIEW.



Note
The NI-VISA server starts automatically after it is installed on an RT target.

Verifying Communication with Remote FPGA Targets

Complete the following steps to test communication with a remote system in MAX.

1. Expand the Remote Systems category in MAX.

2. Expand the remote system in which the FPGA target is installed and Devices and Interfaces so you can view

the FPGA targets installed in that system.

3. Select the FPGA target you want to test and click the Open VISA Test Panel button,

shown at the left.

If the VISA test panel opens, you have access to the remote FPGA target and you can add the remote FPGA

target to the Project Explorer window in LabVIEW. If the test panel does not open or if you receive an error

message when attempting to add the remote FPGA target to the Project Explorer window in LabVIEW, refer to

the Setting Access Permissions for Remote FPGA Targets section.

Setting Access Permissions for Remote FPGA Targets
If you cannot verify communication with a remote system in MAX or if you receive an error message when
attempting to add the remote FPGA target to the Project Explorer window in LabVIEW, you might need to set
access permissions for the remote system.

Complete the following steps to allow other computers to access the remote FPGA target.

1. Make sure the remote FPGA target appears in MAX. If you cannot locate the remote system and FPGA target

in MAX, refer to the Measurement & Automation Explorer Help by selecting Help»MAX Help in MAX for

information about recognizing remote systems in MAX.

2. If the NI-VISA Server is running on an RT target, select the RT target under the Remote Systems category in

MAX. If the NI-VISA Server is running on a Windows computer, open MAX on that computer and proceed to the

next step.

3. For RT targets, open the VISA Options page by clicking the Remote Systems» Remote System Name»

Software» NI-VISA x.x category, where Remote System Name is the name or IP address of the remote system

and x.x is the version of NI-VISA you have installed, and then clicking the VISA Options tab. For Windows

computers, open the VISA Options page by selecting Tools» NI-VISA» VISA Options.

4. On the VISA Options page, select VISA Server» Security to view the Remote Access List, as shown in Figure

1.



5. Click the Add button, shown at the left, and enter the name or IP address of the computer to add

a computer to the Remote Access List. You can use the * wildcard to specify a group of computers or all

computers on the network. In general, use the * wildcard to set up general allowances or denials, and follow

those entries with more specific entries. Refer to the LabVIEW Help, available by selecting Help» Search the

LabVIEW Help, for general information about access list entries and wildcards.

6. Select a Permission option to either allow access to the remote system or deny access to the remote system.

7. Click the Save button, shown at left, to set the access permissions.

Connecting Signals

Figure 2 shows the I/O connector locations for the NI PXI-783xR and the NI PCI-783xR. The NI PXI-7830R and NI
PCI-7830R do not have Connector 2 (DIO).



Figure 3 shows the I/O connector pin assignments for the I/O connectors on the NI 783xR. The DIO connector pin
assignment applies to connector 1 on the NI 7830R and connectors <1..2> on the NI 7831R/7833R.



Caution
Connections that exceed any of the maximum ratings of input or output signals on the NI 783xR can damage the
NI 783xR and the computer. NI is not liable for any damage resulting from such signal connections. Refer to the NI
783xR User Manual for the maximum input ratings for each signal.

For detailed information about connecting I/O signals, refer to the NI 783xR User Manual.

Cabling Options

Accessing the signals on the I/O connectors requires at least one cable and one signal accessory. Table 1
summarizes the National Instruments cables available for use with the NI 783xR device.

Table 1. Cabling Options



Cable Connector Description

SH68-C68-S MIO/DIO For connecting signals from the MIO or DIO connector to th
e NI SCB-68 terminal block.

SHC68-68-RMIO MIO

For connecting signals from the MIO connector to the SCB-
68 terminal block.

Improves signal integrity and noise immunity. Provides shie
lding on all AI channels and an overall analog shield to redu
ce digital-to-analog crosstalk.

NSC68-262650 MIO

For direct connection of the NI 783xR to 5B and SSR analo
g and digital signal conditioning backplanes.

Routes signal to connectors that attach directly to 5B backp
lanes (for analog signals) and SSR backplanes (for digital s
ignals).

NSC68-5050 DIO

For direct connection of the NI 783xR and SSR
backplanes.

Routes signal to connectors that attach directly to SSR bac
kplanes.

Related Documentation

Refer to the following documentation for information about the LabVIEW FPGA Module, R Series hardware, and
VIs necessary for your application.

LabVIEW FPGA Module Release Notes—describes the software installation and other known software issues.

NI 783xR User Manual—describes the electrical and mechanical aspects of the NI 783xR and contains

information about its operation and programming.

LabVIEW Help—includes VI descriptions and function reference information for the NI 783x devices.

CompactRIO R Series Expansion System Installation Instructions—describes how to install the CompactRIO R

Series Expansion chassis and CompactRIO I/O modules.

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the
Terms of Use section on ni.com/legal for more information about National Instruments trademarks. Other product
and company names mentioned herein are trademarks or trade names of their respective companies. For patents
covering National Instruments products, refer to the appropriate location: Help» Patents in your software, the
patents.txt file on your CD, or ni.com/patents.

© 2003–2005 National Instruments Corporation. All rights reserved.
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