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RF Signal Generator
Note Before you begin, install and configure your chassis and controller.

This document explains how to install, configure, and test the NI PXI-5650/5651/5652 (NI 5650/5651/5652) as a
stand-alone device. The NI 5650/5651/5652 is a continuous-wave RF signal generator with modulation capability.
The NI 5650/5651/5652 ships with the NI-RFSG instrument driver, which you use to program the device. To
access NI 5650/5651/5652 documentation, navigate to Start» All Programs» National Instruments» NI-RFSG»

Documentation. The specifications document for your device is installed with the driver software. Refer to
ni.com/manuals for the most recent specifications for your device.

. & Caution The protection provided by this product may be impaired if it is used in a manner not described
in this document.

. @Hot Surface If the NI 5650/5651/5652 has been in use, it may exceed safe handling temperatures and

cause burns. Allow the NI 5650/5651/5652 to cool before removing it from the chassis.
Electromagnetic Compatibility Guidelines

This product was tested and complies with the regulatory requirements and limits for electromagnetic compatibility
(EMC) stated in the product specifications. These requirements and limits are designed to provide reasonable
protection against harmful interference when the product is operated in the intended operational electromagnetic
environment. This product is intended for use in industrial locations. However, harmful interference may occur in
some installations, when the product is connected to a peripheral device or test object, or if the product is used in
residential or commercial areas. To minimize interference with radio and television reception and prevent
unacceptable performance degradation, install and use this product in strict accordance with the instructions in the
product documentation. Furthermore, any modifications to the product not expressly approved by National
Instruments could void your authority to operate it under your local regulatory rules.

« Caution To ensure the specified EMC performance, operate this product only with shielded cables and
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accessories.

« Caution To ensure the specified EMC performance, the length of all I/O cables must be no longer than 3 m (10
ft).

Verifying the System Requirements

To use the NI-RFSG instrument driver, your system must meet certain requirements.
For more information about minimum system requirements, recommended systems, and supported application
development environments (ADEs), refer to the product readme, which is available on the driver software media or

online at ni.com/updates.
Unpacking the Kit

Caution To prevent electrostatic discharge (ESD) from damaging the device, ground yourself using a grounding
strap or by holding a grounded object, such as your computer chassis.

1. Touch the antistatic package to a metal part of the computer chassis.

2. Remove the device from the package and inspect the device for loose components or any other sign of damage
Caution Never touch the exposed pins of connectors.
Notify NI if the device appears damaged in any way. Do not install a damaged device.

3. Unpack any other items and documentation from the kit.

Store the device in the antistatic package when the device is not in use.

Verifying the Kit Contents

®

1. NI PXI-5650/5651/5652 RF Signal Generator Module
2. Screwdriver, Part Number 772006-01
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3. Driver Software DVD
4. NI PXI-5650/5651/5652 Getting Started Guide (this document)
5. Read Me First: Safety and Electromagnetic Compatibility

6. Maintain Forced-Air Cooling Note to Users

Other Equipment
There are several required items not included in your device kit that you need to install or operate the NI
5650/5651/5652.

Required Items

« A PXI chassis and chassis documentation. The NI PXle-1085 chassis is one available option for your device.

For more information about compatible chassis options, refer to_ni.com.

« A PXI embedded controller or MXI controller system that meets the system requirements specified in this guide

and chassis documentation.

Optional Items

« A1 N - m standard SMA torque wrench (NI part number 780487-01).

Preparing the Environment

Ensure that the environment you are using the NI 5650/5651/5652 in meets the following specifications.

« Operating ambient temperature................ccceeeee. (IEC-60068-2-1, IEC-60068-2-2) 0 °C to 55 °C

« Operating relative humidity............c.ooiiiiiiniannn. (IEC-60068-2-56) 10% to 90%, non-condensing

o« Maximum altitude...........coooeiiiiii 2,000 m (800 mbar) (at 25 °C ambient temperature).
o Pollution Degree.........cocoeiiiiiiiiii e 2

Indoor use only.

« Caution Clean the hardware with a soft, nonmetallic brush. Make sure that the hardware is completely dry and
free from contaminants before returning it to service.

« Note Refer to the NI PXI-5650/5651/5652 Specifications at nhi.com/manuals for complete specifications.

Installing the Software

You must be an Administrator to install NI software on your computer.

1. Install an ADE, such as LabVIEW or LabWindows™/CVI™.,
2. Insert the driver software DVD into your computer. The installer should open automatically.

If the installation window does not appear, navigate to the drive, double-click it, and double-click autorun.exe.
3. Follow the instructions in the installation prompts to install the NI-RFSG driver software.

Note Windows users may see access and security messages during installation. Accept the prompts to

complete the installation.
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4. When the installer completes, restart your system.

Installing the NI 5650/5651/5652

Caution To prevent damage to the device caused by ESD or contamination, handle the device using the edges or
the metal bracket.

« You must install NI-RFSG before installing the hardware.
« Before you install the hardware, refer to the guidelines in the Maintain Forced-Air Cooling

« Note to Users included with the module to ensure that the chassis can cool the device effectively.

1. Ensure the AC power source is connected to the chassis before installing the module. The AC power cord
grounds the chassis and protects it from electrical damage while you install the module.

2. Power off the chassis.

3. Inspect the slot pins on the chassis backplane for any bends or damage prior to installation. Do not install a
module if the backplane is damaged.

4. Remove the black plastic connectors from all the captive screws on the module front panel.

5. Identify a supported slot in the chassis. The following figure shows the symbols that indicate the slot types.

Figure 1. Chassis Compatibility Symbols
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PXI Express System Controller Slot
PXI Peripheral Slot

PXI Express Hybrid Peripheral Slot
PXI Express System Timing Slot
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PXI Express Peripheral Slot

NI 5650/5651/5652 modules can be placed in PXI peripheral slots or PX| Express Hybrid peripheral slots.
6. Touch any metal part of the chassis to discharge static electricity.

7. Ensure that the ejector handle is in the unlatched (downward) position.

8. Place the module edges into the module guides at the top and bottom of the chassis. Slide the device into the

slot until it is fully inserted.



Figure 2. Module Installation

1. Chassis
2. Hardware Module
3. Ejector Handle in Down (Unlatched) Position
9. Latch the module in place by pulling up on the ejector handle.
10. Secure the device’s front panel to the chassis using the front-panel mounting screws.
Note Tightening the top and bottom mounting screws increases mechanical stability and also electrically
connects the front panel to the chassis, which can improve the signal quality and electromagnetic performance.
11. Cover all empty slots using filler panels or slot blockers to maximize cooling air flow.

12. Power on the chassis.

Related Information
Installing the Software on page 4

Installing the SMA Cables

To use the NI 5650/5651/5652 with other devices, you must make connections using SMA cables. For best results
when connecting signals to the NI 5650/5651/5652 front panel SMA connectors, use shielded low-loss coaxial
cables.

Caution The signal pins of this product’s input/output ports can be damaged if subjected to ESD. To prevent
damage, remove power from the product before connecting cables and employ industry-standard ESD prevention
measures during installation, maintenance, and operation.

1. Connect the cable center pin on the SMA cable to the SMA connector on the appropriate device.

Note Ensure that the SMA cable center pins properly align with the SMA connectors to avoid bending the cable
pins or damaging the front panel connectors on the device. If the SMA cable does not exactly align with the
SMA connector, bend the cable slightly by hand to align the cable and the connector. The amount of bending
should be minimal. The cables can be damaged by excessive bending.

2. Hand-tighten the SMA cable end on the SMA connector after the cable center pins are correctly aligned and
connected. The cable connectors should tighten without much torque or effort. If a cable bends due to incorrect
alignment, remove the cable from the front panel connector and repeat step 1 before continuing with this step.

3. Use an appropriate torque wrench or torque screwdriver and SMA driver bit (not included) to complete the



tightening of the SMA cable to 1 N - m. Rotate the torque wrench no more than one revolution to tighten the

SMA cable before reaching maximum torque.

Direct Connections to the NI 5650/5651/5652

The NI 5650/5651/5652 is a precision RF instrument that is sensitive to ESD and transients. Ensure you take the
following precautions when making direct connections to the NI 5650/5651/5652 to avoid damaging the device.
Note Do not apply external signals to the NI 5650/5651/5652. Applying external signals may cause damage.

« Ensure you are properly grounded when manipulating cables or antennas connected to the NI 5650/5651/5652.
« If you are using noninsulated devices, such as a non-insulated RF antenna, ensure the devices are maintained
in a static-free environment.
« If you are using an active device, such as a preamplifier or switch routed to the
NI 5650/5651/5652, ensure no signal transients are sourced to the NI 5650/5651/5652.

NI 5650/5651/5652 RF Signal Generator Module
The NI 5650/5651/5652 RF signal generator module contains two connectors and two multicolor LEDs.

Note The following figure depicts the NI 5652 module front panel, although each NI 5650/5651/5652 module front
panel contains the same connectors and LEDs.



Table 1.

Device Front Panel Icon Definitions
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Refer to the user documentation for required maintenance measures to ensure user safety and/or preser
ve the specified EMC performance.

AN

If this device has been in use, it may exceed safe handling temperatures and cause burns. Allow the dev

ice to cool before removing it from the chassis.

Table 2.

NI 5650/5651/5652 RF Signal Generator Module Front Panel Connectors




Connector

Use

RF OUT Output terminal for the RF signal at the requested frequency and power level.
Routes a frequency reference signal to or from the RF signal generator.
REF IN/OUT This connector can be configured as an external frequency reference input or as an output for

the onboard 10 MHz Reference Clock.

Table 3. NI 5650/5651/5652 RF Signal Generator Module Front Panel LEDs

LED

Indications

ACCESS

Indicates the basic hardware status of the module.
OFF—The module is not yet functional or has detected a problem with a PXI Express power rail.

AMBER—The module is being accessed. Accessed means that the device setup registers are bei
ng written to in order to control the device.

GREEN—The module is ready to be programmed by NI-RFSG.

ACTIVE

Indicates the state of the module.
OFF—The module is not yet generating a signal.

AMBER—The module phase-locked loops (PLLs) are attempting to lock. GREEN—The module is
generating a signal; applicable PLLs are locked.

RED—The module has detected an error state; this state may indicate a PLL lock failure or a ther
mal shutdown condition.

Configuring the NI 5650/5651/5652 in MAX

Use Measurement & Automation Explorer (MAX) to configure your National Instruments hardware. MAX informs
other programs about which devices reside in the system and how they are configured. MAX is automatically
installed with NI-RFSG.

1. Launch MAX.
2. In the configuration tree, double-click Devices and Interfaces to see the list of installed devices.
Note If you are using the NI 5650/5651/5652 with the LabVIEW Real-Time Module, expand Remote Systems.

Find your target IP address or name, expand it, and then expand Devices and Interfaces. Installed devices

appear under the name of their associated chassis.

3. Expand your Chassis tree item.

MAX lists all devices installed in the chassis. Your default device names may vary.

Note If you do not see your device listed, press <F5> to refresh the list of installed devices. If the device is still

not listed, power off the system, ensure the device is correctly installed, and restart.

4. Record the device identifier MAX assigns to the hardware. Use this identifier when programming the NI
5650/5651/5652.
5. Self-test the device by selecting the device in the configuration tree and clicking Self-Test in the MAX toolbar.

The MAX self-test performs a basic verification of hardware resources.




Related Information
Refer to the NI RF Signal Generators Help for information about renaming devices.

Programming the NI 5650/5651/5652

You can generate signals interactively using the NI-RFSG Soft Front Panel (SFP) or you can use the NI-RFSG
instrument driver to program your device in the supported ADE of your choice.

Table 4. NI 5650/5651/5652 Programming Options

Application Programm

ing Interface (API) Location Description

NI-RFSG SFP controls, generates and present
s data similar to stand-alone RF signal generat
ors. The NI-RFSG SFP operates on the PC, so
it provides additional processing, storage, and

display capabilities.

Available from the Start menu at St
art»All Programs» National Instr
uments»NI-RFSG» NI- RFSG Soft
Front Panel.

NI-RFSG SFP

LabVIEW—Auvailable on the LabVI
EW Functions palette at Measurem | NI-RFSG configures and operates the device h
ent I/O»NI- RFSG. ardware, performs waveform programming and
generation, and performs basic modulation tas
LabWindows/CVI— Available at Pr | ks using LabVIEW VIs or LabWindows/CVI fun
NI-RFSG ogram Files» IVI Foundation» IVl | ctions.

» Drivers» nerfs.

Instrument Driver

Add all required include and library files to your
project to create an

Microsoft Visual C/C++ NI-RFSG application in Microsoft Visual C/C++

Related Information

For detailed instructions about how to generate signals in a specific ADE, refer to the Getting Started section of the
NI RF Signal Generators Help.

Refer to the Creating an Application with Microsoft Visual C and C++ topic of the NI RF Signal Generators Help to
manually add all required include and library files to your project.

NI-RFSG Examples

Examples demonstrate the functionality of the device and serve as programming models and building blocks for
your own applications. The NI Example Finder is a utility available for some ADEs that organizes examples into
categories and allows you to easily browse and search installed examples. You can see descriptions and
compatible hardware models for each example or see all the examples compatible with one particular hardware
model.

You can locate LabVIEW or LabWindows/CVI examples with the NI Example Finder. Within LabVIEW or
LabWindows/CVI, select Help»Find Examples and navigate to Hardware Input and Output»Modular Instruments.

Generating a Signal Using the NI-RFSG Soft Front Panel
To verify your device configuration, use the NI-RFSG Soft Front Panel (SFP) in MAX to generate a simple signal.

1. Within MAX, select the NI 5650/5651/5652 RF signal generator module in the configuration tree.
2. Select Soft Front Panel from the MAX toolbar.
The NI-RFSG SFP launches.



Within the NI-RFSG SFP, specify a frequency and a power level for signal generation.

Caution Clicking RF On/Off generates a signal from the RF OUT connector of the NI 5650/5651/5652 front
panel. Disconnect any equipment that can be damaged by the test signal prior to clicking the RF On/Off button
on the

NI-RFSG SFP.

Click RF On/Off to begin signal generation.

Note Refer to the Troubleshooting section of this document if an ACTIVE LED does not turn on or if the NI-
RFSG SFP generates an error.

During signal generation, the ACTIVE LED on the NI 5650/5651/5652 hardware module illuminates.

Click RF On/Off to stop signal generation.

Building a Basic NI-RFSG Application
You can build a basic NI-RFSG application in LabVIEW for generating continuous sine wave signals.

Adding the Core NI-RFSG Vis to a Blank VI
Create a new application that includes the core NI-RFSG Vis.

. Launch LabVIEW.

2. To create a blank VI, select File» New VI.

Display the block diagram by selecting Window» Show Block Diagram
Tip Activate the LabVIEW context help by selecting Help» Show Context Help.

4. Right-click the VI block diagram to launch the Functions palette.
5. Navigate to the NI-RFSG Vls on the NI-RFSG palette.

Tip You can use the Search button on the Functions palette to find the NI-RFSG palette.
Add the core NI-RFSG Vls from the NI-RFSG palette to the block diagram, and wire the Vls together as shown

in the following figure.

Figure 4. Basic NI-RFSG Block Diagram
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Right-click the resource name input on the niRFSG Initialize VI, and select Create» Control to create a front

panel control where you specify the NI RF signal generator device name.

Figure 5. Resource Name Input on the niRFSG Initialize VI

Fesource name

. Right-click the frequency (Hz) input on the niRFSG Configure RF VI, and select Create» Control.

. Right-click the power level (dBm) input on the niRFSG Configure RF VI, and select Create» Control.
10.
11.
12.

Display the VI front panel by clicking it or by selecting Window» Show Front Panel.
In the VI front panel power level (dBm) control, enter 0. In the frequency (Hz) control, enter 100M (100 MHz).

In the VI front panel resource name control, enter the NI 5650/5651/5652 device name that you specified in



MAX.

Adding a While Loop
Add a While Loop to continuously generate the signal and check the generation status until you click the Stop
button.

1. Display the VI block diagram, and select the While Loop on the Structures palette.
Tip You can use the Search button on the Functions palette to find the Structures palette.

2. Enclose the niRFSG Check Generation Status VI in the While Loop, as shown in the following figure.
Figure 6. The niRFSG Check Generation Status VI Enclosed in the While Loop
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Right-click the While Loop tunnels, and select Replace with Shift Register.

Select the Or function on the Boolean palette. Place the function inside the While Loop.

Wire the output of the Or function to the conditional terminal of the While Loop.

o o > w

Select the Unbundle by Name function on the Cluster, Class, & Variant palette. Place the function inside the
While Loop.

7. Wire the error-out output of the niRFSG Check Generation Status VI to the Unbundle by Name function.

8. Wire the output of the status element to an input of the Or function.

9. Right-click the unused input of the Or function, and select Create» Control to create a Boolean control.
10. In the VI front panel, right-click the Boolean control created in step 9, and select Replace» Modern» Boolean»

Stop Button to create a Stop button.

Figure 8. Basic Sine Wave Generation VI Block Diagram
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Adding an Error Indicator
Add an error indicator to the VI front panel.



1. Create an error indicator by right-clicking the error-out output of the niRFSG Close VI and selecting Create»
Indicator.

2. Verify that the VI block diagram and VI front panel now look similar to the following figures.

Figure 8. Basic Sine Wave Generation VI Block Diagram
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Figure 9. Basic Sine Wave Generation VI Front Panel

3. Open the VI front panel, and select the NI 5650/5651/5652 module name specified in MAX in the resource
name control.

4. Click the Run button on the toolbar to initiate sine wave generation.

5. Click the VI front panel STOP button to stop sine wave generation.

You have successfully generated a continuous sine wave signal using the NI-RFSG instrument driver and the NI
5650/5651/5652.

Troubleshooting



If an issue persists after you complete a troubleshooting procedure, contact NI technical support or visit
ni.com/support.

Why Is the ACCESS LED Off When the Chassis is On?

« The LEDs may not illuminate until the device has been configured in MAX. Before proceeding, verify that the NI
5650/5651/5652 appears in MAX.
« If the ACCESS LED fails to illuminate after you power on the chassis, a problem may exist with the chassis

power rails, a hardware module, or the LED.

Caution Apply external signals only while the NI 5650/5651/5652 is powered on. Applying external signals while
the device is powered off may cause damage.

—_

. Disconnect any signals from the module front panel.

Power off the chassis.

Remove the module from the chassis and inspect it for damage. Do not reinstall a damaged device.
Reinstall the module in a different chassis slot.

Power on the chassis.

Verify that the device appears in MAX.

N o g M D

Reset the device in MAX and perform a self-test.
What Should | Do if the NI 5650/5651/5652 Doesn’t Appear in MAX?

1. In the MAX configuration tree, click Devices and Interfaces.

2. Expand the Chassis tree to see the list of installed devices, and press <F5> to refresh the list.

3. If the module is still not listed, power off the system, ensure that all hardware is correctly installed, and restart
the system.

4. Navigate to the Device Manager.

Operating System Description

Windows 8 Right-click the Start screen, and select All apps»Control Panel»
Hardware and Sound»Device Manager.

Windows 7 Select Start»Control Panel»Device Manager.

Windows Vista Select Start»Control Panel»System and Maintenance»Device
Manager.

Windows XP Select Start»Control Panel»System»Hardware»Device
Manager.

5. If you are using a PXI controller, verify that a National Instruments entry appears in the system device list.
Reinstall NI-RFSG and the device if error conditions appear in the list. If you are using an MXI controller, right-

click PCI-to-PCI Bridge, and select Properties from the shortcut menu to verify that the bridge is enabled.

What Should I Do if the Module Fails the Self-Test?

1. Restart the system.

2. Launch MAX, and perform the self-test again.
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3. Power off the chassis.
4. Reinstall the failed module in a different slot.
5. Power on the chassis.

6. Perform the self-test again.

Where to Go Next
Refer to the following figure for information about other product tasks and associated resources for those tasks.

Hs4 Located at ni.com/gettingstarted % Located at ni.com/manuals @ Located using the NI Example Finder

the application development gbout hardware features custom applications within
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LabWindows/CV| Generators Help® Generators Help®
more about your products through ni.com.
E5. Support RF Solutions gg Services NI Community
= gi ni.com/support ni.com/rf ;}'—“’ ni.com/services ni.com/community

*This item is also installed with the driver software.

ni.com/support
ni.com/rf

ni.com/services
ni.com/community

Tip The NI RF Signal Generators Help is an HTML version of a traditional user manual that includes detailed
information about RF fundamentals, device features, and programming with NI-RFSG.

Worldwide Support and Services

The National Instruments website is your complete resource for technical support. At ni.com/support, you have
access to everything from troubleshooting and application development self-help resources to email and phone
assistance from NI Application Engineers. Visit_ni.com/services for NI Factory Installation Services, repairs,
extended warranty, and other services. Visit ni.com/register to register your National Instruments product.
Product registration facilitates technical support and ensures that you receive important information updates from
NI. A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European Communities



http://ni.com/support
http://ni.com/rf
http://ni.com/services
http://ni.com/community
http://ni.com/support
http://ni.com/services
http://ni.com/register

using the manufacturer’s declaration of conformity. This system affords the user protection for electromagnetic
compatibility (EMC) and product safety. You can obtain the DoC for your product by visiting ni.com/certification.
If your product supports calibration, you can obtain the calibration certificate for your product at
ni.com/calibration. National Instruments corporate headquarters is located at 11500 North Mopac Expressway,
Austin, Texas, 78759-3504. National Instruments also has offices located around the world. For telephone support
in the United States, create your service request at ni.com/support or dial 1 866 ASK MYNI (275 6964). For
telephone support outside the United States, visit the Worldwide Offices section of ni.com/niglobal to access the
branch office websites, which provide up-to-date contact information, support phone numbers, email addresses,
and current events. Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on
National Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products/technology, refer to the
appropriate location: Help» Patents in your software, the patents.txt file on your media, or the National Instruments
Patent Notice at ni.com/patents. You can find information about end-user license agreements (EULAs) and third-
party legal notices in the readme file for your NI product. Refer to the Export Compliance Information at
ni.com/legal/export-compliance for the National Instruments global trade compliance policy and how to obtain
relevant HTS codes, ECCNs, and other import/export data. NI MAKES NO EXPRESS OR

IMPLIED WARRANTIES AS TO THE ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL
NOT BE LIABLE FOR ANY ERRORS.

U.S. Government Customers: The data contained in this manual was developed at private expense and is subject
to the applicable limited rights and restricted data rights as outlined in FAR 52.227-14, DFAR 252.227-7014, and
DFAR 252.227-7015.

© 2014 National Instruments. All rights reserved.
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