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Product Information

Specifications

Product Model: PXI-7854

Product Type: R Series Multifunction RIO

Compatible Devices: National Instruments PCI/PXI-781xR, PCI/PXI-783xR, PCIe/PXI-784xR, PCIe/PXI-

785xR

Operating System Compatibility: Windows Vista/XP/2000

Product Usage Instructions

Step 1. Install Application Software and Driver

Before installing the NI 78xxR, ensure you have the necessary software packages installed on your

development computer or PXI/CompactPCI chassis running the supported Windows operating systems.

Visit ni.com/info and enter rdsoftwareversion to determine the required software versions for your device.

Refer to the appropriate release notes and upgrade notes for LabVIEW, LabVIEW FPGA Module,

LabVIEW Real-Time Module, and NI-RIO driver for installation instructions and system requirements.

Step 2. Install the Device, Accessories, and Cables

Ensure not to touch the exposed pins of connectors. Inspect the device for any damage before

installation.

Store the NI 78xxR in an antistatic envelope when not in use.

Installing the NI 78xxR:

1. Choose a suitable slot on your computer or PXI chassis for installation.



2. Touch a metal part of the computer or chassis to discharge static electricity.

3. For PCI/PCIe-78xxR: Insert the device into the applicable slot gently. Do not force it. For PXI-78xxR: Use the

injector/ejector handle to insert the device into place.

4. Ensure there is enough room between the NI 78xxR and other boards for optimal performance.

Frequently Asked Questions (FAQ)

What are the necessary components to set up and use the NI 78xxR device?

You will need the required software packages, a development computer or compatible chassis running

supported Windows OS, and at least one cable and accessory for signal connections.

How can I determine the minimum software versions required for my NI 78xxR device?

Visit ni.com/info and enter rdsoftwareversion to find the minimum software versions needed for your specific

device.

What precautions should I take during the installation process?

Avoid touching the exposed pins of connectors, inspect the device for damage before installation, and store the

device in an antistatic envelope when not in use. Make sure to discharge static electricity before inserting the

device into the slot.

INTRODUCTION

This document explains how to install and configure National Instruments PCI/PXI-781xR, PCI/PXI-783xR,
PCIe/PXI-784xR, and PCIe/PXI-785xR, referred to collectively as NI 78xxR devices. This document also contains
a tutorial section that demonstrates how to begin taking a measurement using a LabVIEW FPGA example VI.

NI 78xxR Required Components

The following items are necessary to set up and use the NI 78xxR:

The following software packages:

LabVIEW

LabVIEW FPGA Module

NI-RIO device drivers

http://ni.com/info


(Optional) LabVIEW Real-Time Module

Refer to Step 1. Install Application Software and Driver, for information on R Series software support.

Development computer or PXI/CompactPCI chassis and PXI/CompactPCI embedded controller running

Windows Vista/XP/2000.

At least one cable and accessory for connecting signals to the NI 78xxR. For a list of applicable cable and

accessory options, refer to the Connectivity Options section.

Step 1. Install Application Software and Driver

Before installing the NI 78xxR, you need to install the application software and device driver. Visit ni.com/info

and enter rdsoftwareversion to determine which minimum versions of software you need for the device you are

using.

Refer to the LabVIEW Release Notes for installation instructions for LabVIEW and system requirements for the

LabVIEW software. Refer to the LabVIEW Upgrade Notes for additional information about upgrading to the

most recent version of LabVIEW for Windows.

Refer to the LabVIEW FPGA Module Release and Upgrade Notes for installation instructions and information

on getting started with the LabVIEW FPGA Module.

Refer to the LabVIEW Real-Time Module Release and Upgrade Notes for system requirements, installation

instructions, and additional information on using the LabVIEW Real-Time Module.

Refer to the NI-RIO Readme on NI-RIO installation media for system requirements and installation instructions

for the NI-RIO driver.

The listed documents are available at ni.com/manuals. In LabVIEW 8.0 or later, you can also view the LabVIEW

Manuals directory that contains these documents by selecting Start»All Programs» National

Instruments»LabVIEW»LabVIEW Manuals.

Step 2. Install the Device, Accessories, and Cables
This section describes how to unpack and install the NI PCI/PCIe/PXI-78xxR devices.
Note You must install NI-RIO device driver software before installing the NI 78xxR.

Unpacking
The NI 78xxR is shipped in an antistatic package to prevent electrostatic discharge from damaging device
components. To prevent such damage when handling the device, take the following precautions:

Ground yourself using a grounding strap or by holding a grounded object, such as your computer chassis.

Touch the antistatic package to a metal part of the computer chassis before removing the device from the

package.

Caution Never touch the exposed pins of connectors.

Remove the device from the package and inspect the devices for loose components or any other sign of

damage. Notify NI if the device appears damaged in any way. Do not install a damaged device into the

computer.

Store the NI 78xxR in the antistatic envelope when not in use.

Installing the NI 78xxR
You can install the NI PCI/PCIe-78xxR in any available PCI/PCI Express expansion slot in the computer, and the
NI PXI-78xxR in any available peripheral slot in the PXI or CompactPCI chassis. To achieve the best noise
performance, leave as much room as possible between the NI PCI/PCIe-78xxR and other boards.



Note You must install the software before installing the hardware. For software installation information, refer to
Step 1. Install Application Software and Driver.

1. Power off and unplug the computer or PXI chassis.

Caution Refer to the Read Me First: Safety and Electromagnetic Compatibility document packaged with your

PXI chassis or device before removing equipment covers or connecting or disconnecting any signal wires.

2. Remove the computer cover and/or the expansion slot cover on the computer, or the filler panel of an unused

PXI slot on the PXI chassis.

3. Touch any metal part of the computer or chassis to discharge any static electricity.

4. For the NI PCI/PCIe-78xxR, insert the device into the applicable PCI/PCI Express system slot on your

computer. Gently rock the device into place. Do not force the device into place. For the NI PXI-78xxR, insert the

device into the PXI slot. Use the injector/ejector handle to fully inject the NI PXI-78xxR into place.

1 NI PCI/PCIe-78xxR Device

2 PCI/PCI Express System Slot

3 PC with PCI/PCI Express Slot

1 PXI Chassis

2 PXI System Controller

3 NI PXI-78xxR Device



4 Injector/Ejector Handle

5 Front-Panel Mounting Screws

6 Module Guides

7 Power Switch

5. For the NI PCI/PCIe-78xxR, secure the device mounting bracket to the computer back panel rail. For the NI

PXI-78xxR, secure the device front panel to the chassis front panel mounting rail using the front-panel mounting

screws.

6. For the NI PCI/PCIe-78xxR, replace the computer cover, if applicable.

7. Plug in and power on the computer or PXI chassis.

To confirm that your device is recognized, complete the following additional steps:

1. Select Start»All Programs»National Instruments»Measurement & Automation to open Measurement &

Automation Explorer (MAX).

2. Expand Devices and Interfaces.

3. Verify that the device appears under Devices and Interfaces»RIO Devices.

Step 3. Connect Signals
Figure 4 shows the I/O connector pin assignments and locations for NI 781xR digital-only R Series devices. Figure
5 shows the I/O connector pin assignments and locations for NI 783xR/784xR/785xR Multifunction R Series
devices.





Caution Connections that exceed any of the maximum ratings of input or output signals on the NI 78xxR can
damage the NI 78xxR device and the computer or chassis. NI is not liable for any damage resulting from such
signal connections. For the maximum input and output ratings for each signal, refer to the NI R Series
Multifunction RIO Specifications, available at ni.com/manuals.
The +5V terminals on the I/O connector supply +5 V referenced to D GND. Use these terminals to power external
circuitry. All NI 78xxR devices are equipped with a fuse to protect the supply from overcurrent conditions. Refer to
the R Series Multifunction RIO User Manual, available at ni.com/manuals, for information about the device-specific
fuses.

Connectivity Options
Accessing the signals on the I/O connectors requires at least one cable and one signal accessory. Table 1
summarizes the National Instruments connectivity options available for use with the NI 78xxR device.
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Accessory

 

 

 

Description

 

NI 781xR
NI 783xR/ 784x
R/785xR

SHC68-68-RMIO

(NI Recommended) — 0 NI SCB-68

High-performance shielded cable wired s
pecifically for signal connection from the 
RMIO connector  to the NI SCB-68 termi
nal block to provide higher signal integrity
and noise immunity.

SHC68-68-RDIO

(NI Recommended) 0, 1, 2, 3 1, 2 NI SCB-68

High-performance shielded cable wired s
pecifically for signal connection from the 
RDIO connector  to the NI SCB-68 termi
nal block to provide higher signal integrity
and noise immunity.

SH68-C68-S 0, 1, 2, 3 1, 2 NI SCB-68

Basic shielded cable for signal connectio
n from the RMIO or RDIO connector to th
e NI SCB-68 terminal block for noise
reduction.

* NI 7830R does not have Connector 2.

† For a diagram of the twisted pairs in the SHC68-68-RMIO and SHC68-68-RDIO cables and the signals to
which they correspond, go to ni.com/info and enter the info code rdrmio.

For detailed information about connecting I/O signals, refer to the NI R Series Multifunction RIO User Manual,
available at ni.com/manuals.

Step 4. Using Your NI 78xxR Device with a LabVIEW FPGA Example VI (NI 783xR/784xR/785xR Only)

The NI-RIO driver installation includes a variety of example projects to help get you started. This section

demonstrates how to use an existing LabVIEW FPGA example project to take an analog input measurement

with the NI 783xR/784xR/785xR device.

Note Examples available for your device are dependent on the device-specific minimum software requirements.

For more information on software requirements for your device, refer to Step 1. Install Application Software and

Driver.

Each R Series example project includes:

A LabVIEW FPGA VI that can be compiled and run embedded in FPGA hardware

A Host VI that runs in LabVIEW for Windows and interacts with the LabVIEW FPGA VI

Each example is configured for a specific target and might not be pre-configured for your device. To use an

example for a different target, you must copy the items contained within the VI to a new FPGA target.

Note To acquire real-world data in the analog input measurement taken in this example, you will also need to

provide your own signal source, such as a battery or function generator.

To access the analog input example project and take a measurement, complete the following steps:

1. Launch LabVIEW.

2. In the Getting Started window, click Find Examples to display the NI Example Finder.

†

* †

*

http://ni.com/manuals


3. In the NI Example Finder window, select Hardware Input and Output»R Series. This directory holds

several example projects designed to help you get started using your R Series device.

4. Select Basic I/O and then select Analog Input – R Series.lvproj.

5. The Analog Input example project opens in the Project Explorer window. This project is precompiled for

the NI PCI-7831R. If you are not using an NI PCI-7831R, then you need

to copy the example files into a new target directory and recompile the code. To compile Analog Input – R

Series.lvproj for a new R Series target, complete the following steps:

In the Project Explorer window, right-click My Computer and select New»Targets and Devices to

create a new target.

Select the Existing target or device radio button.

Expand the FPGA Target folder to display a list of the R Series devices you can add. From the list,

select the device for which you want to create a new directory, and click OK. If your R Series device

does not appear under this tree structure, refer to the Step 2. Install the Device, Accessories, and

Cables section and confirm that the device was installed correctly.

In the Project Explorer window, expand the original FPGA target and locate the Items to Move

folder. This folder holds all the target VIs and I/O resources necessary to run the example VI. Click

on the folder and drag it to the new FPGA Target.

Note The new target must support all of the analog input items included in this folder.

Right-click the Analog Input (FPGA).vi file within the Items to Move folder and select Compile to

recompile the FPGA VI. Recompiling takes several minutes. When the bitstream generation is

complete, close the LabVIEW FPGA Compile Server.

Open Analog Input (Host).vi under My Computer and switch to the block diagram to update the host

VI and its references to the FPGA VI.

On the block diagram, right-click the Open FPGA VI Reference function and select Configure Open

FPGA VI Reference from the shortcut menu.

In the Configure Open FPGA VI Reference dialog box, click the Browse Project button by the

Open»VI field to open the Select VI dialog box.

In the Select VI dialog box, select Analog Input (FPGA).vi in the new target and click OK.

Click OK in the Configure Open FPGA VI Reference dialog box.

Note (LabVIEW version 8.5.1 and earlier) LabVIEW versions 8.5.1 and earlier do not use the

Configure Open FPGA VI Reference dialog to update the FPGA target in the host VI. For LabVIEW



version 8.5.1 and earlier, right-click the Open FPGA VI Reference function on the block diagram

and choose Select VI from the shortcut menu. In the Select VI dialog box, select Analog Input

(FPGA).vi in the new target and click OK.

In the Project Explorer window, right-click the original FPGA target and select Remove to delete it

from the project.

Save the project to a new directory by selecting File»Save As.

6. Click the Run button in Analog Input (Host).vi to run the VI. The host VI displays the data being acquired

by the R Series device. To view real-world data, wire a signal source or voltage source to AI0+ (RMIO pin

68) and AI0– (RMIO pin 34) of the terminal block.

Adding Analog Output to the FPGA Application
To expand the LabVIEW FPGA application to include analog output, complete the following steps:

1. On the block diagram of Analog Input (FPGA).vi, insert a new frame between the first and second frames of the

Flat Sequence structure by right-clicking the divider between the first two frames and selecting Insert Frame

from the shortcut menu, as shown in the following figure.

2. In the Project Explorer window, right-click the FPGA target and select New»FPGA I/O.

3. In the New FPGA I/O dialog box, expand Connector0 and select AO0.

Note This example reflects the naming conventions and graphic interface of LabVIEW 8.6. Items such as

FPGA I/O resources may appear differently if you are using earlier versions of LabVIEW.



4. Click Add, then click OK.

5. Click Connector0/AO0 in the Project Explorer window and drag it into the second frame of the Flat Sequence

structure on the block diagram of the FPGA VI. The FPGA I/O Node is created automatically.

6. Right-click the input terminal of the new FPGA I/O Node and select Create»Control from the shortcut menu.

Rename the control AO Voltage (bits), as shown in the following block diagram.

7. Save the VI, then right-click Analog Input (FPGA).vi in the Project Explorer window and select Compile from the

shortcut menu to recompile the FPGA VI.

8. Modify the host VI to control the additional AO channel you created by completing the following steps:

Open the Analog Input (Host).vi block diagram.

Place a Read/Write Control from the FPGA Interface palette between the Invoke method and the

Read/Write Control that already exists on the block diagram.

Wire the FPGA VI Reference Out terminal of the Invoke Method node to the FPGA VI Reference In

terminal of the new Read/Write Control. Wire the FPGA Reference Out terminal of the new Read/Write

Control to the FPGA VI Reference In terminal of the existing Read/Write Control.

Wire the error out output of the Invoke Method node to the error in input of the new Read/Write Control.

Wire the error out output of the new Read/Write Control to the error in input of the existing Read/Write

Control.

Click the section labeled Unselected and change it to AO Voltage.

Right-click the AO Voltage (bits) terminal and select Create»Control, as shown in the following block

diagram.



9. On the front panel, locate the numeric control labeled AO Voltage (bits). Right-click the control, select Replace

from the shortcut menu, and select Knob from the Express»Numeric Controls palette to change the control type

to knob.

10. On the front panel, click and highlight the value in the lower limit of the knob to change the limit to –32000. Click

and highlight the value in the upper limit to change the limit to 32000.

11. Save the VI.

12. Using the terminal block, connect analog output channel 0 to analog input channel 0 by wiring AI0+ (RMIO pin

68) to AO0 (RMIO pin 55) and AI0– (RMIO pin 34) to AOGND0 (RMIO pin 21), respectively.

13. Click the Run button in Analog Input (Host).vi and adjust the knob that controls analog output channel 0. Notice

how the change in voltage affects the reading on analog input channel 0.

Where to Go From Here

The following resources contain information for writing applications and taking measurements with R Series
Multifunction RIO devices.

Software Documentation



LabVIEW FPGA documentation

Getting Started with LabVIEW FPGA 8.x—This KnowledgeBase, available at ni.com/kb, provides links to

the top resources that can be used to assist in getting started with programming in LabVIEW FPGA.

FPGA Module book in the LabVIEW Help—Select Help»Search the LabVIEW Help in LabVIEW to view

the LabVIEW Help. Browse the FPGA Module book in the Contents tab for information about how to use

the FPGA Module to create VIs that run on the NI 78xxR device.

LabVIEW FPGA Module Release and Upgrade Notes—Contains information about installing the

LabVIEW FPGA Module, describes new features, and provides upgrade information. To access this

document, refer to ni.com/manuals. In LabVIEW 8.0 or later, you can also view the LabVIEW Manuals

directory that contains this document by selecting Start» All Programs»National

Instruments»LabVIEW»LabVIEW Manuals.

National Instruments Example Finder—LabVIEW contains an extensive library of VIs and example programs

for use with R Series devices. To access the NI Example Finder, open LabVIEW and select Help»Find

Examples, then select Hardware Input and Output»R Series.

You can also access device-specific examples by selecting Add device from the Hardware pull-down menu in

the NI Example Finder window.

Note If you are using the NI Example Finder for NI 784xR/785xR devices, you can select any NI 7831R/7833R

device from the Select devices to find examples for list and reconfigure the example for your NI 784xR/785xR

target.

Device-Specific Documentation

NI R Series Multifunction RIO User Manual —Describes the electrical and mechanical aspects of the NI

78xxR R Series devices, and contains information about R Series device operation and programming. To

access this document, refer to ni.com/manuals.

NI R Series Multifunction RIO Specifications—Lists the specifications of the NI 78xxR R Series devices. To

access this document, refer to ni.com/manuals.

Additional Resources
LabVIEW FPGA IPNet—Offers resources for browsing, understanding, and downloading LabVIEW FPGA
functions or IP (Intellectual Property). Use this resource to acquire IP that you need for your application, download
examples to help learn programming techniques, and explore the depth of IP offered by the LabVIEW FPGA
platform. To access the LabVIEW FPGA IPNet, visit ni.com/ipnet.

Where to Go for Support

The National Instruments Web site is your complete resource for technical support. At ni.com/ support you have

access to everything from troubleshooting and application development self-helpresources to email and phone

assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas,

78759-3504. National Instruments also has offices located around the world to help address your support

needs. For telephone support in the United States, create your service request at ni.com/support and follow the

calling instructions or dial 512 795 8248. For telephone support outside the United States, contact your local

branch office:

Australia 1800 300 800, Austria 43 662 457990-0, Belgium 32 (0) 2 757 0020,



Brazil 55 11 3262 3599, Canada 800 433 3488, China 86 21 5050 9800,

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, Finland 358 (0) 9 725 72511,

France 01 57 66 24 24, Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737,

Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400, Lebanon 961 (0) 1 33 28 28,

Malaysia 1800 887710, Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,

New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, Poland 48 22 328 90 10,

Portugal 351 210 311 210, Russia 7 495 783 6851, Singapore 1800 226 5886,

Slovenia 386 3 425 42 00, South Africa 27 0 11 805 8197, Spain 34 91 640 0085,

Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, Taiwan 886 02 2377 2222,

Thailand 662 278 6777, Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

Documents / Resources
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