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Legal information 
Use of application examples 
Application examples illustrate the solution of automation tasks through an interaction of several components in the form of text, 

graphics and/or software modules. The application examples are a free service by Siemens AG and/or a subsidiary of Siemens AG 

(“Siemens”). They are non-binding and make no claim to completeness or functionality regarding configuration and equipment. The 

application examples merely offer help with typical tasks; they do not constitute customer-specific solutions. You yourself are responsible 

for the proper and safe operation of the products in accordance with applicable regulations and must also check the function of the 

respective application example and customize it for your system. 

Siemens grants you the non-exclusive, non-sublicensable and non-transferable right to have the application examples used by technically 

trained personnel. Any change to the application examples is your responsibility. Sharing the application examples with third parties or 

copying the application examples or excerpts thereof is permitted only in combination with your own products. The application examples 

are not required to undergo the customary tests and quality inspections of a chargeable product; they may have functional and 

performance defects as well as errors. It is your responsibility to use them in such a manner that any malfunctions that may occur do not 

result in property damage or injury to persons. 

 

Disclaimer of liability 
Siemens shall not assume any liability, for any legal reason whatsoever, including, without limitation, liability for the usability, 

availability, completeness and freedom from defects of the application examples as well as for related information, configuration and 

performance data and any damage caused thereby. This shall not apply in cases of mandatory liability, for example under the German 

Product Liability Act, or in cases of intent, gross negligence, or culpable loss of life, bodily injury or damage to health, non-compliance 

with a guarantee, fraudulent non-disclosure of a defect, or culpable breach of material contractual obligations. Claims for damages 

arising from a breach of material contractual obligations shall however be limited to the foreseeable damage typical of the type of 

agreement, unless liability arises from intent or gross negligence or is based on loss of life, bodily injury or damage to health. The 

foregoing provisions do not imply any change in the burden of proof to your detriment. You shall indemnify Siemens against existing or 

future claims of third parties in this connection except where Siemens is mandatorily liable. 

By using the application examples you acknowledge that Siemens cannot be held liable for any damage beyond the liability provisions 

described. 

 

Other information 
Siemens reserves the right to make changes to the application examples at any time without notice. In case of discrepancies between the 

suggestions in the application examples and other Siemens publications such as catalogs, the content of the other documentation shall 

have precedence.  

The Siemens terms of use (https://support.industry.siemens.com) shall also apply.  

 

Security information 
Siemens provides products and solutions with industrial security functions that support the secure operation of plants, systems, 

machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is necessary to implement – and continuously 

maintain – a holistic, state-of-the-art industrial security concept. Siemens’ products and solutions constitute one element of such a 

concept. 

Customers are responsible for preventing unauthorized access to their plants, systems, machines and networks. Such systems, machines 

and components should only be connected to an enterprise network or the internet if and to the extent such a connection is necessary 

and only when appropriate security measures (e.g. firewalls and/or network segmentation) are in place. 

For additional information on industrial security measures that may be implemented, please visit 

https://www.siemens.com/industrialsecurity. 

Siemens’ products and solutions undergo continuous development to make them more secure. Siemens strongly recommends that 

product updates are applied as soon as they are available and that the latest product versions are used. Use of product versions that are 

no longer supported, and failure to apply the latest updates may increase customer’s exposure to cyber threats. 

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed under https://www.siemens.com/cert. 

 

https://support.industry.siemens.com/
https://www.siemens.com/industrialsecurity
https://www.siemens.com/cert
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1. Introduction 

1.1. Overview  
The converter of the SINAMICS G220 family support PROFINET S2 system redundancy. Thanks to S2 system redundancy, 

operation of the system is guaranteed even in the event of a defect or replacement of a controller, thus reducing 

downtimes. 

The prerequisite for S2 system redundancy is a so-called S7-410 fault-tolerant system, also referred to as an H system. An 

S7-410 fault-tolerant system consists of 2 fault-tolerant controllers - the primary and backup CPU - that synchronize via 

fiber optics. If one controller fails, the other automatically takes over. 

 

1.2. Principle of operation 

S2 system redundancy  

S2 system redundancy refers to a method of improving the reliability and fault-tolerance of a system. In an S2 redundant 

system, there are two identical components working in parallel. If one component fails, the other automatically assumes 

its function to ensure uninterrupted operation. 

This example describes S2 system redundancy, in which a SINAMICS G220 is operated as a PROFINET device on a fault-

tolerant system without the use of additional hardware. 

Schematic diagram  

Fault-tolerant system

SINAMICS G220

PROFINET / IE

Fiber-optic

Motor
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Advantages 

• No plant downtime in the event of a controller failure  

• Hot-swappable components during operation  

• Changes to the configuration during operation  

• Automatic synchronization after replacement of components  

Limitations of SINAMICS  

• PROFINET-IRT is not supported  

• No simultaneous operation of Shared Device and system redundancy  

• Maximum of 2 cyclic PROFINET connections  

• System redundancy only via the PROFINET X150 interface 

• While switching from one controller to the other, the setpoints of the last connection remain frozen and valid.  

Limitations on the engineering system  

Startdrive does not yet support the direct configuration of the drive as a client on a redundant system. Therefore, the 

SINAMICS G220 must be integrated into the redundant system via a GSDML file in the project. 

Limitations of the S7-410 fault-tolerant system  

Limitations of the S7-410 H-System can be found in the system manual "SIMATIC PCS 7 Process Control System CPU 410 

Process Automation V8" (\3\). 

Required knowledge  

Basic knowledge of PCS 7 and SINAMICS G220 is required. 

1.3. Components used 
The following hardware and software components were used to create this application example:  

Component Quantity Item number Note 

SIMATIC PCS 7 CPU 
410 Redundant Bundle 

1 6ES7656-6C...-.... With Sync Modules 

SINAMICS G220  1 6SL4112-0DA11-0AA0 Firmware V6.2 

SIMATIC PCS 7 V9.1 SP2 1 6ES7658-4XX68-0YT8 Engineering License required 

Startdrive V19 1 6SL3072-4KA02-0XG5 Engineering software for SINAMICS drives 

 

You can obtain the listed components from the Siemens Industry Mall, for example. 

 

This application example consists of the following components:  

Component File name Note 

Documentation 109932875_S2_Systemredundancy_ 
S7-410H_G220_DOC_V10_en.pdf 

This document 

Example project 109932875_S2_Systemredundancy_ 
S7-410H_G220_PROJ_V10.zip 

Example project for PCS 7 V9.1 SP2 

 

https://mall.industry.siemens.com/
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2. Engineering  

2.1. Hardware setup  
The following images show the hardware setup and the wiring of the application: 

 

33

2 2 11

4

 

 

S7-410H (1) 

The S7-410H redundant system should be mounted either on one shared rail or on two separate mounting rails. You will 

connect the two CPUs with fiber-optic cables to two synchronization modules in each CPU. Set up the PROFINET ring via 

the CPUs' X8 P1 R and X8 P2 R PROFINET interface.  

Power supply (2) 

The load current power supply (PM) supplies the system power supply (PS) and core modules (CPU) with DC 24 V. For 

peripheral power supplies, we recommend the devices of the SIMATIC series. These devices can be mounted on the 

mounting rail.  

Synchronization modules (S7-410H only) (3) 

You will create two redundancy connections between the H CPUs with fiber-optic cables using a total of four 

synchronization modules (two in each H CPU).  

Fiber-optic cables (S7-410H only) (4) 

You will connect the two synchronization modules for each CPU with a pair of fiber-optic cables. 
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2.2. Topology 
In order to integrate the SINAMICS G220 into the system via PROFINET, the application example will use the following 

topology:  

M

SINAMICS G220

SIMATIC S7
CPU 410-5H
CPU1

SIMATIC S7
CPU 410-5H
CPU2

P1    P2
X150

X8
P1 P2

X8
P1 P2 IF1   IF2IF1   IF2
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2.3. Configuration 

2.3.1. Configuration of the SIMATIC H system 
Follow the steps below to configure the SIMATIC S7 H system in PCS 7:  

1. Create a new PCS 7 project with the PCS 7 Wizard and select an AS410-2H or enter the part number of your fault-

tolerant S7-410H. 

 

 

2. After that, specify how many hierarchy levels you want your project to have. In addition, you can select here whether 

an OS should be created. 

 

 



Engineering 
 

Article ID: 109932875 | V1.0 | 03/2024 © Siemens 2024 | 9 

3. Then give the project a name (1) and exit the wizard (2). 

 

 

 

 

4. Assign the IP address for the first controller of the S7-410 H system by selecting the hardware configuration  

(HW Config) and open the properties of the X8 PROFINET interface of the first SIMATIC S7 controller. 
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5. Use the "General > Interface" tab to open the properties of the PROFINET interface. 

 

 

6. Enter the desired IP address here (1). In this example, we will use 192.168.1.1. Then create a new subnet (2) and give 

it a descriptive name. Assign the subnet to the IP address. 
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7. Assign the IP address for the second controller of the S7-410 H system by opening the HW Config and opening the 

properties of the X8 PROFINET interface of the second SIMATIC S7 controller. 

 

 

8. Use the "General > Interface" tab to open the properties of the PROFINET interface. Then enter the desired IP address 

(1). In this example, we'll use 192.168.1.2. Assign the previously created subnet to the IP address. Be sure to change 

the device name (2).
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9. Configure the MRP ring by selecting the "Manager (Auto)" role under "Media redundancy" in the properties of the X8 

interfaces. 
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2.3.2. Configuration of the SINAMICS G220 drive 
The SINAMICS G220 drive cannot be integrated directly into PCS 7. Instead, a GSDML file is used to integrate the drive to 

the redundant system.  

 

NOTE The GSDML file for the frequency converter can be found in the downloads for article: "SINAMICS G220 
PROFINET GSDML":  
https://support.industry.siemens.com/cs/ww/en/view/109901084  

 

This example assumes basic configuration of the SINAMICS G220 drive is already complete. Only the steps which are 

necessary beyond that in order to integrate the SINAMICS G220 into the redundant system will be explained. 

Install the GSDML file 

1. Download the GSDML file from the link above and extract the file. 

2. Open SIMATIC Manager and the prepared multiproject. 

3. Open the HW Config of the CPU. 

4. In the HW Config, click on "Options > Install GSD File...". 

 

 

 

 

https://support.industry.siemens.com/cs/ww/en/view/109901084
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5. Click on "Browse" (1) and select the extracted folder containing the GSDML files of the SINAMICS G220. After that, 

select the desired file (2) and install the GSD file (3). 

 

 

 

 

 

Configure the G220 hardware 

1. Drag the GSDML for the SINAMICS G220 with the corresponding firmware version from the "Standard" hardware 

catalog under "PROFINET IO > Drives > SINAMICS" and into the HW Config.  
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2. From the "DRIVE" list, drag and drop the telegram used into slot 1.3 of the "DRIVE" module. This application example 

uses standard telegram 20.  
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3. Open the properties of the G220 and modify the device name (1). In this application example, it is "G220". Also assign 

a suitable IP address (2); our example uses "192.168.1.3". 
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4. Switch to the "Media redundancy" tab of the G220 and assign the role "Client". Due to the configuration of the MRP 

ring, the "watchdog time" must be adjusted. 

 

 

ATTENTION Improper configuration of an MRP ring can lead to the risk of accidents and damage to the 
system! 

This is due to the watchdog time and the fact that the motor continues to run until the watchdog time 

is up. 

If this is not acceptable, it is recommended to set up S2 redundancy without an MRP ring. This can 

reduce the risk of accidents. 

It is of paramount importance that all safety precautions are taken to ensure the safety of the people 

involved. If you have any questions or concerns, please consult a professional or experts in the field. 

 



Engineering 
 

Article ID: 109932875 | V1.0 | 03/2024 © Siemens 2024 | 18 

5. Open the "IO Cycle" tab and adjust the value to achieve a "Watchdog time" greater than 200. 
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Automatic device name configuration 

1. Open the object properties of the CPU interface that the SINAMICS G220 drive system is connected to. 

2. Tick the "Support device replacement without exchangeable medium" checkbox. 

 

 

3. Right-click on the interface to which the drive system is connected (1) to open the context menu and open the 

"PROFINET IO Topology..." (2). 

 

 

 

4. Switch to the "Graphic view" tab. Connect the individual component interfaces to each other according to the physical 

connection of your system via drag and drop. 
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5. Confirm your topology configuration with "OK". 

6. Save and compile the HW Config and download it to the H system. 

7. You can use the online mode in the HW Config to verify that the name has been transferred correctly. 

 

NOTE To verify that the target topology and actual topology are identical, you must select the Ethernet 
network adapter with access to the fieldbus. Select it in the PG/PC interface. You can then check the 
target and actual topology in the Topology Editor using the "Online" button. 

 

NOTE Topology configuration is only possible within a subproject, i.e. the stations with a common PROFINET 
network must be located in the same subproject. 
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Manual device name configuration 

The device name can be manually transferred to the drive system. In order to have direct access to the drive, the ES and 

the drive system must be on the same physical network. The following options are available: 

• Use of a Service Bridge. 

• Unplugging and re-inserting the PROFINET interface for direct access to the drive system. 

 

In this application example, the ES is connected to the PROFINET interface of the CPU via the plant bus. 

 

1. Plug the network cable of the ES/single station into the fieldbus.  

2. In the menu of SIMATIC Manager, click on "Options > Set PG/PC Interface…".  

3. Select the Ethernet network adapter that you have connected to the fieldbus. 

4. Select the PROFINET system in the HW Config and then click on "PLC > Ethernet > Assign Device Name" in the menu. 

 

 

 

 

5. In the "Device name" drop-down menu, select the name of the G220 that you have assigned to the drive. 

 

6. Then select the appropriate drive from the "Available devices" list. 

7. Click "Assign name". 

 

NOTE You can filter the list by device type. To do this, check the "Show only devices of the same type" 
checkbox. 

 

8. Click "Close" to close the window.  

 

NOTE You can use the "Accessible nodes" menu in SIMATIC Manager to check whether the name has been 
correctly transferred to the drive system. 

 

9. Reconnect the ES to the plant bus of your PLC and change the PG/PC interface back if necessary. For example, to "PC 

Internal (Local)". 
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2.3.3. Symbol table 
1. Open the symbol table. 

2. In the "Symbol" column, create the symbolic names for the input and output tags. 

3. Assign the 2 "output words" and 6 "input words" tags to the symbolic names. 

 

Standard telegram type 20 contains the following values: 

 

Word Output word Input word 

1 Control word Status word 

2 Speed setpoint Speed actual value 

3  Motor current 

4  Torque 

5  Power 

6  Namur messages or freely configurable analog value 

 

 

 

4. Save the changes and close the symbol table. 

5. Open & compile the HW Config. 
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2.4. CFC engineering 

Preface 

This application example uses the "Drive" template from the Advanced Process Library (APL) to quickly and easily integrate 

the drive into the program. The template already contains the blocks "FbDrive" and "MotSpdCL", as well as all necessary 

connections. It thus offers a ready-to-use automation solution. The "Interlock", "Permit" and "Protect" interlock blocks are 

also inserted and connected. You can delete them as needed if you don't need these features. After inserting the template 

from the library into the PLC program, you will need to connect the input "PZDIn1" at the "FbDrive" block with the first 

input word "ZSW1" of the frequency converter and set a telegram type. The rest of the signal connections are done by the 

compiler. 

 

 

NOTE This application example offers only a simple standardized solution to enable a quick start. 

 

NOTE The parameterization of the drive system is not part of this application example. 
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2.4.1. Configuration 
1. Switch to SIMATIC Manager. 

2. In the menu bar, select "File > Open... ". 

3. Go to the "Libraries" tab and select the "PCS 7 AP Library V91" library (1) and confirm the dialog with "OK" (2). 

 

 

 

 

4. In the PCS 7 Advanced Process Library V91, select the "Templates" folder. Highlight the "Drive" template, open its 

context menu and select "Copy". 

 

 

 

 

5. Go to your master data library, then to "Process Tag Types" and paste the copied template by right-clicking "Paste". The 

copied template is now available in your project. 

6. Copy the template from your master data library into your plant hierarchy and assign a plant designation for the chart. 
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Configure the MotSpdCL block 

1. Open the CFC. 

2. Open the object properties of the "MotSpdCL" block. 

3. Give your drive a meaningful name and a suitable description. 

4. Change to the "I/Os" tab. 

5. In the "Identifier" column, assign texts according to the table below so that they appear properly in the faceplate in the 

OS. 

Input name Identifier 

UserAna1.Value Torque 

UserAna2.Value Power 

AV_Out.Value Current 

 

6. (Optional) Also, set the "IdleTime" to 0 if you don't need it for your application. 

(Optional) If necessary, delete the "Interlock", "Permit" and "Protect" blocks that are not required in the example. 

 

ATTENTION Improper project engineering and incorrect operation can lead to the risk of accidents and 
damage to the system! 

In order to ensure proper and safe operation of your system, it is necessary to integrate various 
protection mechanisms into the program depending on the drive, system design and area of 
application; you must also parameterize the MotSpdCL block and the drive appropriately.  

The necessary program structure and the necessary parameterization of the blocks in your project may 
therefore differ from the application example.  

Failure to do so could result in the risk of accidents and damage to the plant. 

For more information about the MotSpdCL block and its settings and feature bits, see the PCS 7 
Advanced Process Library Manual. 
https://support.industry.siemens.com/cs/ww/en/view/109812806 

 

https://support.industry.siemens.com/cs/ww/en/view/109812806
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Interconnect FbDrive 

1. In the CFC chart, select the input "PZDIn1" of the "FbDrive" block. Right-click on the context menu and select 

"Interconnection to Address…".  

2. Select the first input word of the G220, in this case "IW 512_G220". 

All other input and output words are automatically connected by the driver generator during compilation. 

 

 

 

3. At the "telegram" block parameter, set telegram 20 by setting the value to "20". 

 

NOTE For more information about FbDrive, see the PCS 7 Advanced Process Library manual. 
https://support.industry.siemens.com/cs/ww/en/view/109812806 

https://support.industry.siemens.com/cs/ww/en/view/109812806
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2.4.2. Process value scaling and units 
The setpoint speed "STW2" and the actual speed "ZSW2" are transmitted as integers in the range from 0 to 16384. In 

PCS 7, the raw value is scaled to a process value at the "FbDrive" driver block.  

There are a few places in the CFC in PCS 7 where you can scale the process value. Some of these include:  

Block Connector Description 

FbDrive PZDIn2Unit Unit of the actual value 

PZDIn2Scale.High Upper limit of the actual value 

PZDIn2 Scale.Low Lower limit of the actual value 

SPLiScale.High Maximum setpoint 

SPLiScale.Low Minimum setpoint 

MotSpdCl SP_HiLim Upper setpoint limit 

SP_LoLim Lower setpoint limit 

SP_OpScale.High Upper limit for bar chart display 

SP_OpScale.Low Lower limit for bar chart display 

SP_Unit Unit for the label on the faceplate 

 

The values PZDIn2, PZDIn2Scale and PZDIn2Unit are transmitted to the MotSpdCL block via the connectors "SpeedLink", 

"Speedscale" and "SpeedUnit". 

 

NOTE Adjust the scaling to suit your application. For pump and fan applications with the G220, values in 
percent or in revolutions per minute are recommended. 

 

Code Unit Description 

1077 Hz Hertz 

1082 1/s Revolutions per second 

1083 1/min Revolutions per minute 

1342 % Percent 

 

NOTE Units of measurement in PCS 7 are coded according to the IEC 611582 standard. A complete list of all 
units of measurement can be found in the APL manual:  
https://support.industry.siemens.com/cs/ww/en/view/109812806/156301357579  

 

Compiling and downloading to the PLC 

1. In the CFC chart, select "Compile". 

2. Select "Entire program" and check the box "Generate module drivers". 

3. Download the PLC. 

4. Close the CFC. 

https://support.industry.siemens.com/cs/ww/en/view/109812806/156301357579
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3. Downloading and 

operating the OS 
 

1. Compile the OS. 

When compiling the OS, the motor symbol and the corresponding faceplates are automatically generated. 

2. Open the WinCC application. 

3. Configure the computer name with "Computer". 

4. Use the "OS-Project Editor" to configure your OS layout. 

5. Download the OS. 

 

Monitoring and control 

The SINAMICS G220 is monitored and controlled via the MotSpdCL faceplate.  

In addition to the motor status, the faceplate displays other measured values:  

• Readback 

• Torque 

• Power 

• Motor current 
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NOTE Error messages are forwarded from the channel block "FbDrive" to the motor block "MotSpdCL". The 
error messages are displayed in the faceplate of the motor and in the motor symbol. 

 

Start the drive 

1. Start the OS runtime.  

2. Switch to the screen containing the block icon.  

3. Set a setpoint and start the motor with the Forward command. 
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4. Appendix 

4.1. Service and support  
SiePortal 

The integrated platform for product selection, purchasing and support - and connection of Industry Mall and Online 

support. The SiePortal home page replaces the previous home pages of the Industry Mall and the Online Support Portal 

(SIOS) and combines them. 

• Products & Services 

In Products & Services, you can find all our offerings as previously available in Mall Catalog. 

• Support 

In Support, you can find all information helpful for resolving technical issues with our products. 

• mySieportal 

mySiePortal collects all your personal data and processes, from your account to current orders, service requests and 

more. You can only see the full range of functions here after you have logged in. 

You can access SiePortal via this address: sieportal.siemens.com  

Technical Support 

The Technical Support of Siemens Industry provides you fast and competent support regarding all technical queries with 

numerous tailor-made offers – ranging from basic support to individual support contracts.  

Please send queries to Technical Support via Web form: support.industry.siemens.com/cs/my/src  

SITRAIN – Digital Industry Academy 

We support you with our globally available training courses for industry with practical experience, innovative learning 

methods and a concept that’s tailored to the customer’s specific needs. 

For more information on our offered trainings and courses, as well as their locations and dates, refer to our web page: 

siemens.com/sitrain 

Industry Online Support app 

You will receive optimum support wherever you are with the "Industry Online Support" app. The app is available for iOS 

and Android:  

 

 

 

 

 

https://sieportal.siemens.com/en-ww/home
https://support.industry.siemens.com/cs/my/src?lc=en-WW
https://www.siemens.com/sitrain
https://apps.apple.com/us/app/siemens-industry-online-support/id478868966
https://apps.apple.com/us/app/siemens-industry-online-support/id478868966
https://play.google.com/store/apps/details?id=com.siemens.industry.onlinesupport&hl=en
https://play.google.com/store/apps/details?id=com.siemens.industry.onlinesupport&hl=en
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4.2. Links and literature  
No. Topic 

\1\ Siemens Industry Online Support 
https://support.industry.siemens.com 

\2\ Link to the article page of the application example  

https://support.industry.siemens.com/cs/ww/en/view/109932875 

\3\ Manual: SIMATIC PCS 7 Process Control System CPU 410 Process Automation V8  
https://support.industry.siemens.com/cs/ww/en/view/109826184  

\4\ Download: SINAMICS G220 PROFINET GSDML 
https://support.industry.siemens.com/cs/ww/en/view/109901084  

 

4.3. Change documentation 
Version Date Change 

V1.0 03/2023 First edition 

 

https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/ww/de/view/109932875
https://support.industry.siemens.com/cs/ww/en/view/109826184
https://support.industry.siemens.com/cs/ww/en/view/109901084

	PROFINET system redundancy with the SINAMICS G220 and  SIMATIC S7-410
	1. Introduction
	1.1. Overview
	1.2. Principle of operation
	1.3. Components used

	2. Engineering
	2.1. Hardware setup
	2.2. Topology
	2.3. Configuration
	2.3.1. Configuration of the SIMATIC H system
	2.3.2. Configuration of the SINAMICS G220 drive
	2.3.3. Symbol table

	2.4. CFC engineering
	2.4.1. Configuration
	2.4.2. Process value scaling and units


	3. Downloading and operating the OS
	4. Appendix
	4.1. Service and support
	4.2. Links and literature
	4.3. Change documentation


