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Vibration Monitoring Application Guide v2.0 

Background 
Industrial facilities have hundreds of critical rotating assets, such as 
motors, pumps, gearboxes, and compressors. Unexpected failures result 
in costly down-time. An equipment health monitoring (EHM) preventative 
maintenance solution uses machine learning to identify when assets 
exceed pre-defined parameters.  

Value 
• Increased Uptime – Eliminate unplanned shut-downs by 

continuously monitoring up to 40 assets with a single system 
• Reduced Maintenance Cost – Repair prior to failure or extensive 

collateral damage 
• Effective Maintenance/Parts Scheduling – Spare parts and labor 

planning 
• Ease of Use – Reduce installation costs and eliminate complexity of traditional data analysis 
• Improved Asset Selection – Use data to assist in root cause and reliability analysis 
• IIoT – Real-time alerts for better decision making and remote asset management 

Banner Solution 
Monitors for changes in vibration of rotating assets 
that are the result of: 
• Imbalanced/misaligned components 
• Loose or worn components 
• Improperly driven or mounted components 
• Over-temperature condition 
• Early bearing failure 

How Banner Solves 
• Banner’s Wireless vibration/temperature sensor continually monitors RMS velocity (10-1000 Hz), RMS high 

frequency acceleration (1000-4000 Hz), and temperature on rotating equipment, but uses vibration data only when 
the asset is operational. 

• DXM Controller uses machine learning algorithm to baseline values and set control limits for alerts with limited end-
user interaction. Creates a “check engine light” for each motor! 

• DXM Controller collects data for trending and analysis. Script defines acute verses chronic issues. 
• Data and alerts can be sent to the host control or to the cloud for IIoT connectivity. 
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Guide Features and Benefits 
CONTINUOUS VIBRATION 
MONITORING  

Monitor vibration data on up to 40 assets sensing X and Z axis RMS velocity and high frequency RMS 
acceleration. RMS velocity is indicative of general rotating machine health (unbalance, misalignment, looseness) 
and high frequency RMS acceleration is indicative of early bearing wear. 

SELF-LEARNING BASELINE & 
THRESHOLDS 

Prevent users from having to generate baselines or alarms by using machine learning algorithms to create an 
initial baseline reading and warning/alarm thresholds for each motor individually.  

ACUTE & CHRONIC ALARMS “Check engine light” alarms and warnings are generated for both acute and chronic conditions for each motor. 
Acute thresholds indicate a short-term condition, such as a motor jam or stall that crosses the threshold rapidly. 
Chronic thresholds use a multi-hour moving average of the vibration signals to indicate a long-term condition, 
such as a wearing/failing bearing or motor. 

TEMPERATURE ALARMS Each vibration sensor will also monitor temperature and indicate an alarm when the threshold is exceeded. 

SMS TEXT/EMAIL ALERTS Generate SMS text and/or email alerts based on individual warnings and/or alarms. 

CLOUD MONITORING Push data to Cloud Webserver or PLC (via LAN or Cellular connection) for remote viewing, alerting, logging. 

Solution Components  
Model  Description  

QM30VT1 or DX80N9Q45VA or 
DX80N2Q45VA  

Sure Cross® Vibration and Temperature Sensor or All-in-one Vibration Sensor with Radio Node  

DX80N9Q45U or Q45VTP  
DX80N2Q45U or Q45VTP  
P6 or P6L Performance Radios  

Sure Cross® Wireless Q45 Sensor Node Universal 1-Wire Serial or Q45VTP or P6 or P6L Nodes; select 
either 900 MHz or 2.4 GHz ISM radio to match the DXM100  

DXM700-B1R1 or DXM700-B1R3  DXM700 or newer Wireless Controller; select either 900 MHz or 2.4 GHz ISM radio to match the Q45s  

The following mounting options are listed from least effective to most effective. In all mounting options, care must be taken 
to ensure there is no sensor movement as this could lead to inaccurate information or changes in from the time-trended 
data. 

Mounting Options Bracket Application Description 

BWA-BK-022 Center Mount Bracket 
and Thermal Conductive Adhesive 
Tape (included with QM30VT1 
sensor) 

 

Center mount bracket for direct screw or epoxy mounting to allow for sensor 
removal. Thermal tape for single use flexible mounting option but can 
introduce flex that reduces accuracy. 
Recommend epoxy designed for accelerometer mounting: Loctite Depend 330 
and 7388 activator. 

BWA-BK-013 Flat magnet sensor 
bracket 

 

Highly flexible and re-usable, flat magnetic mount for larger diameter surfaces 
or flat surface 

BWA-BK-019 Center mounting 
bracket with curved surface magnet 
attached to sensor bracket  

 

Curved surface magnet mounts are best suited to smaller curved surfaces. 
Attention should be made to orient in the correct direction for the strongest 
mount. Offers flexibility for future sensor placement. 

The following guide demonstrates how to load a preconfigured XML file and script to the DXM700 or newer models for up 
to 40 Vibration Sensor Nodes. The XML file only requires some minor modifications to be customized for any site. Follow 
binding and site survey instructions on the datasheet of your specific Node. 

Step 1: Install the Sensor 
Mounting and installing the vibration sensors on a motor are important for getting the most accurate readings. Sensors 
can be mounted using magnetic brackets, thermal transfer dual-sided tape, standard brackets epoxied directly to the 
motor, or standard brackets bolted directly to the motor. 
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The vibration sensors have an X and Z axis indication on the face of the sensor. The Z axis goes in a plane through the 
sensor while the X goes horizontally. 

1. Install the sensor so that the X axis line in aligned with the motor shaft of the motor, or axially.  
2. Install the sensor’s Z axis into/through the motor. These can be swapped where the X axis is going into/through the 

motor and the Z axis is in line with the shaft of the motor if you are placing the sensing vertically for easier 
installation. 

3. Install the sensor as close to the bearing of the motor as possible. Using a cover shroud or location far from the 
bearing may result in reduced accuracy or a reduced ability to detect certain vibration characteristics. 

Step 2: Configure the System 
To customize the system to an actual application, make some basic modifications to the template files. There are two files 
uploaded to the DXM700 or newer models: the XML file sets the DXM’s initial configuration and the ScriptBasic file reads 
vibration data, performs the machine learning, sets the thresholds for warnings and alarms, and organizes the information 
in logical and easy to find registers in the DXM. 
Loading these files and making adjustments requires using Banner’s DXM Configuration Software and the Vibration 
Monitoring files available from in the links below. 

1. Install the Sensor Node pairs after the Nodes are bound to the master radio and a site survey performed. The files 
automatically begin baselining after they are loaded to the DXM. Avoid any unrelated vibrations from sensor 
installation. 

2. Download the preconfigured files.  
3. Extract the ZIP files into a folder on your computer. Note the location where the files were saved. 
4. Connect the DXM, via the USB cable supplied with the DXM, to a computer containing the DXM Configuration Software 

v4 or download the software and install it on a computer.  
5. Launch the software and select the DXM700 or newer model. 
6. Open the Vibration Monitoring XML file by going to the File > Open menu and choosing the configuration files. 
7. Connect the software to the DXM by going to the Device > Connection Settings menu. Select Serial and then select 

the COM port that the USB cable is plugged into. Click Connect. If unsure which COM port and multiple appear, 
attempt to connect to each one of them until successful. 

8. Upload the Vibration Monitoring script file (.sb) by going to the Settings > Scripting tab. Click Upload file and select 
the script file. 

9. Save the XML file any time the XML has been changed because the tool DOES NOT autosave. 

https://www.bannerengineering.com/us/en/lp/vibration-monitoring-configuration.html
http://info.bannerengineering.com/cs/groups/public/documents/software/b_4496867.exe
http://info.bannerengineering.com/cs/groups/public/documents/software/b_4496867.exe
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Optional Steps: Customize the XML file 
1. Within the DXM Software, go to the Local 

Registers >  Local Registers in Use 
screen. 

2. Rename the Motors by clicking on the 
register and using the text boxes within the 
Register Overview Box on the lower half of 
the screen. Because there are 5 registers 
per motor being monitored, copy and paste 
names for efficiency. To display the motor 
vibration data, warnings and alarms on the 
website, change the Cloud Settings to 
Read for each motor’ information piece 
(velocity, acceleration, alert mask, etc.) that 
you would like to appear on the Banner Cloud 
Data Service (CDS) website. All recommended 
registers to send to the cloud are preselected to Read. 

3. To change multiple Node’s motor 
vibration data on the website, change 
the Cloud Settings. 

a. On the Modify Multiple 
Registers screen (lower half), 
select Set in the drop-down list 
next to Cloud Settings. 

b. Set the Starting Register to 1 
and the Ending Register to the value equal to 5 × Number of motors in the system (for example, set the 
ending register 80 for only using 16 motors). 

c. In the drop-down list to the right, select Read for Cloud Permissions. This will push those registers every 5 
minutes. (RECOMMENDED for Raw Data registers and alarm masks registers 1-240) 

d. Set to Write or Read/Write to be able to update the register value from the Banner CDS website. 
(RECOMMENDED for Re-baselining registers 321-360) 

e. Set to Push UTC 00:00 to only have those registers push once a day (RECOMMENDED for Baseline, 
Warning and Alarm Registers 5181-5660) 

f. Click Modify Registers on the bottom right of the section. 
NOTE: If you are using fewer than 40 Nodes, change the Cloud Settings to NONE for registers that aren’t being used in 
the ranges listed in the previous steps to avoid sending unnecessary data. 

4. Warnings and alarms within the system are contained within a register for each Nodes in local registers 201-240. 
The registers are labeled “NXX VibMask” where XX is the Node number. The number displayed is a decimal form of 
a 18-bit binary number with a value of 0 or 1 to accommodate up to 18 warnings or alarms for each Node.  

The 18-bit binary masks are broken out as follows: 
Bit0 – Warning – X-Axis – Acute Velocity = (0/1) * 2^0 

Bit1 – Warning – X-Axis – Acute Acceleration (Hi Freq) = (0/1) * 2^1 

Bit2 – Warning – Z-Axis – Acute Velocity = (0/1) * 2^2 

Bit3 – Warning – Z-Axis – Acute Acceleration (Hi Freq) = (0/1) * 2^3 

Bit4 – Alarm – X-Axis – Acute Velocity = (0/1) * 2^4 

Bit5 – Alarm – X-Axis – Acute Acceleration (Hi Freq) = (0/1) * 2^5 

Bit6 – Alarm – Z-Axis – Acute Velocity = (0/1) * 2^6 

Bit7 – Alarm – Z-Axis – Acute Acceleration (Hi Freq) = (0/1) * 2^7 

Bit8 – Warning – X-Axis – Chronic Velocity = (0/1) * 2^8 

Bit9 – Warning – X-Axis – Chronic Acceleration (Hi Freq) = (0/1) * 2^9 

Bit10 – Warning – Z-Axis – Chronic Velocity = (0/1) * 2^10 

Bit11 – Warning – Z-Axis – Chronic Acceleration (Hi Freq) = (0/1) * 2^11 

Bit12 – Alarm – X-Axis – Chronic Velocity = (0/1) * 2^12 

Bit13 – Alarm – X-Axis – Chronic Acceleration (Hi Freq) = (0/1) * 2^13 

Bit14 – Alarm – Z-Axis – Chronic Velocity = (0/1) * 2^14 
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Bit15 – Alarm – Z-Axis – Chronic Acceleration (Hi Freq) = (0/1) * 2^15 

Bit16 – Warning Temperature ( > 158°F or 70°C ) = (0/1) * 2^16 

Bit17 – Alarm Temperature ( > 176°F or 80°C ) = (0/1) * 2^17 

 
The decimal version is the sum of the calculations shown in the right column for each Node’s mask register. Note that any 
value greater than zero in registers 201-240 indicates a warning or alarms for that particular Node. To know the exact 
warning or alarm, the decimal value will need to be backed out to a binary value, which is done on the Banner CDS cloud 
site using the automated dashboard icons or can be done with a PLC or HMI. Multiple warnings and alarms may trigger 
on an event depending on severity. 

5. Configure to Receive Email or Text 
Alerts based on an Action Rule. An 
example action rule is when the 
warning/alarm masks in registers 
201-240 are greater than zero, trigger 
an email or text message. There are 
six threshold rules that are already 
configured that trigger on Any Error, 
Any Acute Warning or Alarm, Any 
Chronic Warning or Alarm, or Any 
Radio Connection Error. The steps 
below can be used for any action 
rule. 

a. Click on the Action Rules tab and expand any rule using the arrow next to the rule OR create a new action 
rule using the Add Threshold Rule button on the top. 

b. Click on the arrow next to Email/SMS on State Transition. 
c. Select the recipient of the SMS and/or email upon the action rule becoming true. 

In the example shown, both SMS Recipient 1 and 2 and Email Recipient 1 and 2 receive a message when the action rule 
meets its criteria. 

Set up the Ethernet or Cellular Connection 
By default, the XML file configures the DXM700 with an Ethernet Push interface with the ability to send emails and push 
the data registers to a webserver. The device can also be configured to use a cellular push if the DXM Controller contains 
a cellular module and data plan. This section is only necessary if the user wants to receive or display information beyond 
just the DXM Controller's LCD. 

 
1. If the DXM will text, email, or push to the cloud webserver, set up the push interface. 

a) On the DXM Configuration Tool, go to the Settings > Cloud Services screen. 
b) Select the appropriate Push Interface (Ethernet or Cell) from the drop-down list. Selecting Cell requires a 

cellular module be installed in the DXM Controller and a wireless plan be set up for sending data. 
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2. The Cloud Push Interval is set to None for XML because the script associated with this file establishes the five 
minute push interval internally, so it occurs immediately after the sample of the Nodes. To enable the Script to push, 
register 844 must be have the Value Type set to Constant and the value of 1 on the Local Register in Use screen.  

3. To send emails or text messages, go to the Settings > Notifications screen and enter in the addresses and/or 
phone numbers in the recipient boxes.  

a) To send emails, fill out all SMTP fields for the mail server delivering the email messages. 
b) Passwords are not stored in the XML and must be send via the Send SMTP Password button when the DXM 

software is connected to the DXM. 

Step 5: Save and Load the XML File to DXM 
When changes are made to the XML file, save the changes. To apply the changes, load the XML file to the DXM. 

1. Save the file by going to the File > Save menu. 
2. Load the file onto the DXM by going to the Device > Send XML Configuration to DXM menu. 

Because of the size of the XML file, the file may take up to three minutes to load. Verify the file is loading by looking at the 
Application Status indicator in the status bar. 
If the Application Status indicator is RED, close and restart the DXM Configuration Software, unplug and re-plug in the 
USB cable and reconnect the DXM to the software. If the Application Status indicator is GREEN, the file upload is 
complete. If the Application Status indicator is YELLOW, the file transfer is in progress. 
 

Step 6: Push Information to the Cloud 
The DXM700 can connect to the web via Ethernet or an internal cell module to push data from the site to the cloud and 
display the data on a website. To enable this capability for remote monitoring and alarms settings, modify the XML file. 
The Banner Cloud Data Services (Banner CDS) website can be used for storing, monitoring, and visualizing the system's 
data at https://bannercds.com/. 

1. Connect the DXM to a computer with the DXM Configuration Software. 
2. Launch the software and connect to the DXM. 
3. Open the saved XML file (File>Open). 
4. Go to the Settings > Cloud Services screen. 
5. Visit the Banner CDS website (https://bannercds.com/) and log into an existing account or register a new account. 
6. Click + New Site, select the company where the site will reside and name your site. 
7. Highlight and copy the Site ID and click Save. 
8. On the DXM Configuration Software: Return to the Settings > Cloud Services screen and verify the server name is 

push.bannercds.com. 
9. Paste the copied ID into the Site ID field. 
10. Save the XML file (File > Save). 
11. Upload the file to the DXM (Device > Send XML Configuration to DXM). 
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12. On the Banner CDS website, click Options next to the newly created site.  
13. In the pop-up window, click the highlighted Update XML box and select the XML file that was just saved and uploaded to 

the DXM. 
14. To have Banner CDS automatically configure dashboard visualization “check engine” widgets based on the 

vibration mask and dashboard item graphs based on the raw data (shown below), change the Site Type to 
Vibration and in Objects enter the number of sensor Nodes in the network. 

 

 
Completing these steps creates continuity between the 
site created on the website with the DXM used in the field. The DXM pushes data to the website, which can be viewed at 
any time. Use the Support tab on the website for more information about monitoring, comparing data, and establishing 
warnings/alarms on the website. 
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Register Glossary and Options for User Interaction 
Acute Samples – Non-Volatile Register 853 – Set to a default value of 5 consecutive samples before triggering an acute 
alert. User adjustable to any value 1 or greater for the number of consecutive samples above a warning or alarm threshold 
before triggering an acute alert. 
Baseline Samples – Non-Volatile Register 852 – Set to a default value of 300 samples for a baseline. User adjustable to 
any number of five minute samples used to generate a baseline, warning, and alarm thresholds. 
Baseline, Warning and Alarm Levels – Local Registers 5181-5660 – Each Node has a baseline, warning, and alarm 
level for each of the four vibration characteristics stored in these registers. Set to push once per day. Use for graphing 
with raw vibration data for comparison. 
Cloud Push – Local Register 844 – Set to a value of 1 to enable cloud pushing from script. 
Load Baseline – Local Register 842 – Users can manually adjust warning and alarm thresholds by entering values into 
non-volatile registers 7001-7320 for vibration and 7681-7760 for temperature. After the data is entered in those registers, 
change register 842 to 1 for 10 seconds, then set it back to 0 to load the data and override the automatically generated 
values 
Motor Run Flag On/Off (0/1) – Local Registers 241-280 – The script determines whether or not a motor is running and 
only uses data from a running motor for trending, alerts, and baselining. These registers could be used to track run time or 
ON/OFF count with action rules. 
Node Connection Status – Local Registers 281-320 – A value of 1 in the 8th bit (decimal 128) indicates a Node is in 
sync with its master radio. Any other value indicates a Node is no longer in sync with its master radio. This could be due 
to radio interference or low battery. 
OR’d Warnings and Alarms – Local Registers 570-578 – All registers here provide a value of 0 or 1 to indicate if the 
value is false or true. These indicate a warning or error on any of the 40 Nodes based on the description of the register. 
Some are for vibration acute or chronic warnings or alarm, some for temperature, and some for the radio connection. 
Sensor Vibration and Temperature Data – Local Registers 1-200 – Each Node has five registers, two for RMS velocity, 
two for RMS High Frequency Acceleration, and one for Temperature. The data is unscaled for easier viewing. In English 
units (in/s), the velocity = Register value ÷ 10000. For metric (mm/s), the velocity = Register value ÷ 1000. For either units, 
acceleration (g) = Register value ÷ 1000. For example, a velocity register value of 500 = 0.05 in/s and an acceleration 
register value of 15 = 0.015 g. 
Setup Nodes – Local Register 833 – When the DXM boots up, it attempts to automatically set up Nodes in sync to have 
the proper vibration characteristics in the correct inputs. When a new Node is bound to the system after initial boot up, the 
new Node(s) need to be configured. This requires either sending a value of 1 to register 833 or rebooting the DXM. 
User Adjustable Temperature Warning and Alarm Levels – Non-Volatile Registers 7681-7760 – Set to a default of 
158F(70 deg C) for warning and 176 F(80 C) for alarm. Enter in the required level for each Node. Trigger Load Baseline 
register to a 1 for 10 seconds after setting user adjusted levels. 
User Adjustable Vibration Warning and Alarm Levels – Non-Volatile Registers 7001-7320 – Default level is 0 to use 
automatically generated values. Users can adjust the level manually by entering a value for any warning or alarm level on 
any vibration characteristic. In English units (in/s), the velocity = Register value ÷ 10000. For metric (mm/s), the velocity = 
Register value ÷ 1000. For either units, acceleration (g) = Register value ÷ 1000. For example, 0.05 in/sec = register value 
of 500. Trigger Load Baseline register to a 1 for 10 seconds after setting user adjusted levels. 
Vibration Alerts Mask – Local Registers 201-240 – Each Node has one register in this grouping where all the vibration 
and temperature alerts are bitpacked into a single register. Any value greater than zero indicates a warning or alarm 
condition and can be used as a “check engine light” for setting up notifications via email or SMS. 
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Additional Features 
Adjusting the Velocity thresholds for Run Flag 
The script in this Vibration Application Guide uses a function to automatically generate baselines and standard deviations 
by recognizing when a motor is running and collecting data. If a motor has a very low RMS velocity and acceleration when 
running, it can be very difficult to distinguish between the baseline and deviations. To ensure the system is working 
properly, view the Run Flag and X/Z RMS velocity over time. Visually it can be seen when a motor is running. If the Run 
Flag doesn’t turn ON (1) when the motor turns on, decrease the Running Motor RMS Velocity threshold. To assess this, 
view the data over time as shown below: 

 
On the left, we can see that the motor Node 2 is between 150 and 425 for RMS velocity when running and below 100 
when it is not running. Looking at the Run Flag (green line) it only indicates the motor is running when the velocity spikes. 
In comparison, if we look at the RMS velocities for Node 2 on the right, we can see the Run Flag (green line) clearly 
indicates when the motor is running and not running even if the velocities are fairly low. This means the acceleration is 
high enough to distinguish a Running state. 
To adjust for this, move the Running RMS Velocity Thresholds for the X and Z axis down to a level that is above the OFF 
state and below the lowest data collected in the Running state. In this case, 100 would be the appropriate value, but it will 
vary depending on the motor and should be assessed for each individual situation. To change the Run Velocity 
thresholds: 

1. Using the DXM Configuration tool, go to Local Registers -> Local Registers in Use. 
2. The X Velocity Run thresholds are in registers 661-700 and are labeled NX_RunThres_XV (where X is the motor 

ID number). 
3. Change the value in the Constant or Timer column to an appropriate threshold for that motor as described above. 
4. The Z Velocity Run thresholds are in registers 701-741 and are labeled NX_RunThres_ZV (where X is the motor ID 

number). 
5. Change the value in the Constant or Timer column to an appropriate threshold for that motor as described above. 
6. After you have completed this for each motor, Save and Load XML File to DXM. 

After adjusting this velocity threshold, re-baseline the motor.  

Re-Baseline a Motor 
The script included with this guide uses the first few days’ worth of data points of a motor running after loading the script 
to the DXM to generate a baseline and statistics for determining warning and alarm threshold levels. If changes are made 
to the motor or vibration sensor, generate a new baseline to ensure the system is running as accurately as possible. Re-
baselining a motor can be done either from the DXM or from the website. 

Baselining from the DXM 
1. On the DXM: Use the arrows to select Registers. The registers are labeled NX_Baseline (where X is the motor node 

ID you want to baseline).  
2. Select the appropriate register to reset. 
3. Click the Enter button. 
4. Change the value to 1 then push Enter three times. The reset register automatically returns to zero after baselining. 

Baselining from the Website 
1. Go to the Dashboard > Sites screen. 
2. Click Update Device for the site where the particular device location exists. The Update pop-up window appears. 
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3. From the Type drop-down list, select Register. 
4. From the Register Name drop-down list, select the motor Node ID you want to baseline. 
5. Enter 1 into the Value field and click Queue. 
6. Repeat steps 4 and 5 for each motor Node that needs to be reset. 

Adjusting Vibration Warning and Alarm Thresholds 
After baselining is complete, warning and alarm thresholds are set for each vibration characteristic on each axis 
automatically. To view those values, check registers 5181-5660 (12 registers per Node). To adjust those thresholds, use 
registers 7001-7320 (8 registers per Node). These values are stored in non-volatile registers so they will remain through a 
power loss. Triggering a new baseline zeroes out the user-defined registers.  

Adjusting Vibration Thresholds from the DXM tool. 
1. Using the DXM Configuration Software, connect to the DXM that is running the Vibration Solutions Kit. 
2. Go to Tools -> Register View. 
3. The vibration warning and alarm thresholds are in registers 7001 through 7320 and are labeled 

User_NX_XVel_Warning or User_NX_XVel_Alarm, etc. (where X is the motor ID number). 
4. Use the right column and enter in the starting register to change and the value to set it to. 
5. Click Write Registers. 
6. To change another threshold, follow steps 3 through 5. 
7. To modify up to 40 thresholds at a time, adjust the number of registers underneath the starting register and fill in 

each value next to the register. Click Write Registers when complete. 
8. To return to using an original baseline value for a particular Node’s vibration characteristic, set the user-defined 

register (7001 through 7320) back to 0 for that particular vibration characteristic.  

Adjusting Vibration Thresholds from a host (PLC or HMI) 
1. Write the appropriate value in to registers (X is the Node number 1 through 40): 

7000+X for X Velocity Warning  
7001+X for X Velocity Alarm   
7002+X for Z Velocity Warning   
7003+X for Z Velocity Alarm   

7004+X for X Acceleration Warning   
7005+X for X Acceleration Alarm   
7006+X for Z Acceleration Warning   
7007+X for Z Acceleration Alarm 

2. To return to using an original baseline value for a node’s vibration characteristic, set the user-defined register (7001 
through 7320) back to 0 for that particular vibration characteristic. 

Adjusting Temperature Thresholds 
1. Set temperature warning values in registers 7681 through 7720 for sensors 1 through 40. 
2. Set temperature alarm values in registers 7721 through 7760 for sensors 1 through 40. 
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Local Registers 
Name Register Range Description Cloud Push 

Default 

Vibration Data 

1 + (N - 1) × 5 1-200 Z Axis Velocity (Scaled ÷ 10000) ✔ 

2 + (N - 1) × 5  Z Axis Hi Freq Acceleration (Scaled ÷ 1000) ✔ 

3 + (N - 1) × 5  X Axis Velocity (Scaled ÷ 10000) ✔ 

4 + (N - 1) × 5  X Axis Hi Freq Acceleration (Scaled ÷ 1000) ✔ 

5 + (N - 1) × 5  Temperature (Scaled ÷ 20) (Signed Reg) ✔ 

Vibe Mask 201 + (N - 1) 201-240 Bit Packed Alarm Message ✔ 

Run Flag 241 + (N - 1) 241-280 Motor Running Flag (0/1)  

Node Status 281 + (N - 1) 281-320 Connection Status of Radio (128 = Connected) ✔ 

Baseline 321 + (N - 1) 321-360 Indication of Baseline & Trigger to Re-baseline a Sensor Node 
(0/1) Read/Write 

Raw Register Data 

1 + (N - 1) × 5 361-560 

Placeholder Registers for Script 

 

2 + (N - 1) × 5   

3 + (N - 1) × 5   

4 + (N - 1) × 5   

5 + (N - 1) × 5   

Warn/Alarm masks  561-574 

OR'd Alarm Registers 

 

Temp ORs  575-576  

Status Radio ORs  577-578  

Temp Warn 581 + (N - 1) 581-620 Individual Temperature Warning Regs (0/1)  

Temp Alarm 621 + (N - 1) 621-660 Individual Temperature Alarm Regs (0/1)  

Run Thresholds Constants 

661 + (N - 1) 661-700 

Threshold Constant for Motor Run determination 

 

701 + (N - 1) 701-740  

741 + (N - 1) 741-780  

781 + (N - 1) 781-820  

Site Survey  821-823 
Solutions Kit Functionality 

 

Binding  824  

Alert Warning Lights  825-830 Trigger for lights on DXM related to Alerts/Alarms  

Sample Count  831 1-Second Timer Count up to 300 between Samples  

Read Rule Enable  832 System Function to trigger read rules when sample count hits 
300  

Setup Nodes  833 Register to trigger Node Config Setup(0/1) (Controlled by Script)  

Sample Time  834 
Placeholder Registers for Script 

 

Push Count  835  

Nodes 1-10 Status  836 

Solutions Kit Functionality 

 

Nodes 11-20 Status  837  

Nodes 21-30 Status  838  

Nodes 31-40 Status  839  

Fast Sample Trigger  843  

Cloud Push Enable  844 Enable or Disable cloud pushing (0/1)  

First Run  851 Solutions Kit Functionality (0/1, set to 0 to reinitialize settings)  

Baseline samples  852 Set number of samples for a baseline (default 300)  

Acute Sample  853 Number of samples in a row for Acute fault (default 5)  

CT Enable  854 Set to 1 to enable CT Measurements (0/1)  
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Name Register Range Description Cloud Push 
Default 

Chronic Fault Trends           
100 Point Moving Average 

5021 + (N - 1) × 4 

5021-5180 

Z Velocity Trend  

5022 + (N - 1) × 4 Z Acceleration Trend  

5023 + (N - 1) × 4 X Velocity Trend  

5024 + (N - 1) × 4 X Acceleration Trend  

Visible Baseline and 
Alarms 

5181 + (N - 1) × 
12 5181-5660 

Baseline & Thresholds being used for alarms (Selected from 
Learned or User Defined)(X Velocity(3), Z Velocity(3), X 
Acceleration(3), Z Acceleration (3). (Scaling = Velocity ÷ 10000, 
Acceleration ÷ 1000) 

Push once a 
day at UTC 

00:00 

Learned Thresholds 5661 + (N - 1) × 8 5661-5980 

Calculated Baseline & Thresholds from algorithm (used in 5181-
5660 if equivalent user thresholds in 7001-7320 are set to 0)(X 
Velocity(3), Z Velocity(3), X Acceleration(3), Z Acceleration (3) 
(Scaling = Velocity ÷ 10000, Acceleration ÷ 1000) 

 

Scaled Temp Reading 5981 + (N - 1) 5981-6020 Placeholder Registers for Script  

User Selected Nodes 6021 + (N - 1) 6021-6060 Solutions Kit Functionality  

Current (A) Reading 6061 + (N - 1) 6061-6100 Current reading in amps from CM node if used (Scaled ÷ 100) ✔ 

Current Alerts Mask 6101 + (N - 1) 6101-6140 Current Alerts Mask (Bit 1 Warning, Bit 2 Alarm) ✔ 

User Defined Thresholds 7001 + (N - 1) × 8 7001-7320 

User Defined Vibration Thresholds (will override Learned 
Thresholds) (X Velocity(2), Z Velocity(2), X Acceleration(2), Z 
Acceleration (2) (Scaling = Velocity ÷ 10000, Acceleration ÷ 
1000) 

 

Saved Count/Mean/StdDev 7321 + (N - 1) × 9 7321-7680 Solutions Kit Functionality  

Temp Warn Thresholds 7681 + (N - 1) 7681-7720 
User Defined Temperature Thresholds (Unscaled) 

Push once a 
day at UTC 

00:00 / Write Temp Alarm Thresholds 7721 + (N - 1) 7721-7760 

Current Warn Thresholds 7761 + (N - 1) 7761-7800 
User Defined Current Thresholds (Scaled ÷ 100) 

Push once a 
day at UTC 

00:00 / Write Current Alarm Thresholds 7801 + (N - 1) 7801-7840 

Current Scale 7841 + (N - 1) 7841-7880 Current Scale (read from dip switches but user adjustable for 
non-standard CTs) (Unscaled)  

 
Where N represents the Motor Node ID number. 
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