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RZ/G2L RZ/G2LC 
Getting Started with Flexible Software Package 
Introduction  
This manual describes how to use the Renesas Flexible Software Package (FSP) for writing applications for 
the RZ microprocessor series. 

 
Target Device 
RZ/G2L RZ/G2LC 
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1. Introduction  
1.1 Overview 
This application note describes how to use the Renesas Flexible Software Package (FSP) running on the 
Cortex®-M33 (hereinafter referred to as CM33) incorporated on RZ/G2L and RZ/G2LC. 

 

1.2 Introduction to FSP 
1.2.1 Purpose 
The Renesas Flexible Software Package (FSP) is an optimized software package designed to provide easy 
to use, scalable, high quality software for embedded system design. The primary goal is to provide 
lightweight, efficient drivers that meet common use cases in embedded systems. 

 

1.2.2 e2 studio IDE 
FSP provides a host of efficiency enhancing tools for developing projects targeting the Renesas RZ series of 
MPU devices. The e2 studio IDE provides a familiar development cockpit from which the key steps of project 
creation, module selection and configuration, code development, code generation, and debugging are all 
managed. 

 

1.3 Limitations 
1.3.1 Peripherals and pins assignment 
RZ/G2L has a multi-core configuration of Cortex-A55 (hereinafter referred to as CA55) and CM33. It is 
possible to use each peripheral and GPIO from each core. This package provides drivers for each peripheral 
for CM33, but each driver can operate on the assumption that it is not used in CA55. 

 

1.3.2 RAM Initialization 
In RZ/G2L FSP, there is no implementation for initializing internal RAM and external DDR SDRAM, and it is 
expected that the RAMs are initialized in the software that should run before CM33 is kicked. This is because 
CA55 is always the primary boot core because of RZ/G2L specification and initialization of RAMs should be 
carried out as a part of bootstrap. 
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2. Starting Development Introduction 
2.1 e2 studio setup 
2.1.1 What is e2 studio? 
Renesas e2 studio is a development tool encompassing code development, build, and debug. e2 studio is 
based on the open-source Eclipse IDE and the associated C/C++ Development Tooling (CDT).  

When developing for RZ MPUs, e2 studio hosts the Renesas Flexible Software Package (FSP). FSP 
provides a wide range of time saving tools to simplify the selection, configuration, and management of 
modules and threads, to easily implement complex applications.  

 

2.1.2 e2 studio Prerequisites 
2.1.2.1 Obtaining an RZ MPU Kit 
To develop applications with RZ/G2L FSP, start with RZ/G2L Evaluation Board Kit. 

Start-up guide of RZ/G2L Evaluation Board Kit is available at RZ/G2L SMARC EVK Start-up Guide. 

 

2.1.2.2 PC Requirements 
The following are the minimum PC requirements to use e2 studio: 

• Windows 10 with Intel i5 or i7, or AMD A10-7850K or FX 
• Memory: 8-GB DDR3 or DDR4 DRAM (16-GB DDR4/2400-MHz RAM is preferred) 
• Minimum 250-GB hard disk 

 

2.1.2.3 Licensing 
FSP licensing includes full source code, limited to Renesas hardware only. 

 
2.1.3 e2 studio installation 
This chapter describes how to install the e2 studio IDE. 

 

2.1.3.1 Download 
The latest e2 studio IDE installer package can be downloaded from Renesas website for free. Please check 
detailed information from: https://www.renesas.com/e2studio. Note that user has to login to the Renesas 
account (in MyRenesas page) for the software download.  

 

2.1.3.2 Installation of e2 studio IDE 
1. Double-click on e2 studio installer to invoke the e2 studio installation wizard page. Click [Install].  
 
Note: If e2 studio was installed in your PC, the option to modify, remove the existing version or install  

e2 studio to a different location will be displayed 

https://www.renesas.com/us/ja/document/mat/rzg2l-smarc-evk-start-guide
https://www.renesas.com/us/ja/document/mat/rzg2l-smarc-evk-start-guide
https://www.renesas.com/e2studio
https://www.renesas.com/e2studio
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Figure 1: e2 studio installation wizard 
 

2. Welcome page 
User can change the install folder by clicking [Change…]. Click [Next] to continue. 

 

Note1: If you would like to have multiple versions of e2 studio, please specify new folder here.  
Note2: Multi-byte characters cannot be used for e2 studio installation folder name. 

 

Figure 2: Installation of e2 studio – Welcome page 
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3. Device Families 
Select Devices Families to install. Click the [Next] button to continue. 
 

 

Figure 3: Installation of e2 studio – Device Families 
 
4. Extra Features 
Select Extra Features (i.e., Language packs, SVN & Git support, RTOS support…) to be installed. For non-
English language users, please select Language packs at this step if needed.  

Click the [Next] button to continue. 

 

Figure 4: Installation of e2 studio – Extra Features 
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5. Customize Features 
Select the components to install and click the [Next] button to continue 

 

Figure 5: Installation of e2 studio – Features 
 
6. Additional Software 
Select additional software (i.e., compilers, utilities, QE…) to be installed. Be sure that you select the "GCC 
ToolChains & Utilities" tab, choose the following items and click [Next] to continue. 

GNU ARM Embedded 9.2.1 2019q4 
LibGen for GNU ARM Embedded 

 

 

Figure 6: Installation of e2 studio – Additional Software 
 
Be sure that LibGen for GNU ARM Embedded is essential for RZ/G2L FSP. If it’s not installed, FSP won’t be 
built successfully. 
 
For more details on the installation of Additional Software, please see the section 2.1.4. 
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7. License Agreement 
Read and accept the software license agreement. Click the [Next] button. Please note that user must accept 
the license agreement, otherwise installation cannot be continued. 

 

Figure 7: Installation of e2 studio – Licenses 
 
8. Shortcuts 
Select shortcut name for start menu and click [Next] button to continue. 

Note: If e2 studio was installed in another location, it is recommended to rename to distinguish from the other 
e2 studio(s). 

 

Figure 8: Installation of e2 studio – Shortcuts 
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9. Summary 
Components list to be installed is shown. Please confirm the contents and click the [Install] button to install 
the Renesas e2 studio IDE. 

 

Figure 9: Installation of e2 studio – Summary 

 
10. Installing... 
The installation is performed. Depending on selected items of additional software, new dialog prompts may 
appear during the installation process. Please see chapter 0 for more detailed information. 
 
11. Results 
Click the OK button to complete the installation.  

 

Figure 10: Summary Page 
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2.1.4 Installation of Additional Software 
As mentioned in the section 2.1.3.2, the additional software listed below is essential for RZ/G2L FSP.  

GNU ARM Embedded 9.2.1 2019q4 
LibGen for GNU ARM Embedded 

 

In this section, the detail procedure for installing these tools. 

 
2.1.4.1 GNU ARM Embedded Toolchain 9.2.1 2019q4 
If it was selected in the Additional Software pane of e2 studio, you will see the installation wizard for the GNU 
ARM Embedded Toolchain during the installation process. 

 

Figure 11: Installation of GNU ARM Embedded Toolchain 
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2.1.4.2 Libgen Update for GNU ARM Embedded Toolchains 
If it was selected in the Additional Software pane of e2 studio, you will see the installation wizard for the 
Libgen Update for GNU ARM Embedded Toolchains during the installation process.  

1. Click Click here to select your GNU ARM Embedded Toolchain installation folder. 
2. Select the folder where GNU ARM Embedded Toolchain 9.2019-q4-major is installed. 
 

 

 

Figure 12: Libgen Update for GNU ARM Embedded: Select Toolchain Folder 
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3. Next, click Install Libgen Update for GNU ARM Embedded Toolchains. 
 

 

 

Figure 13: Libgen Update for GNU ARM Embedded: Update Toolchain 
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2.2 FSP setup 
2.2.1 Installation of FSP Packs 
FSP Packs can be downloaded from here. You can integrate FSP to e² studio by the procedure described 
below: 

1. Exit e2 studio. 
2. Extract FSP Packs. 
3. Copy the extracted FSP Packs (folders under \internal\projectgen\rz_fsp) to the following folder: 

• <e2 studio installation folder>\internal\projectgen 

 

 
4. Launch e2 studio. 
5. Click Help > About e2 studio. 

 

 

6. Click Installation Details. 

 

 

https://www.renesas.com/document/scd/rzg2l-fsp_packs_v100
https://www.renesas.com/document/scd/rzg2l-fsp_packs_v100
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7. Click the link to e2 studio support area. At that time, the explorer should be launched automatically. 

 

 

8. Check if the FSP Packs is copied to the following folder. 
• <e2 studio support area>\internal\projectgen\rz_fsp\rzg\packs 

 

 

6. Check xml files is extracted to the following folder. 
• <e2 studio support area>\internal\projectgen\rz_fsp\rzg\packs 
• <e2 studio support area>\internal\projectgen\rzg\modules 
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3. Set up an RZ/G2L SMARC EVK 
Below is an example of a typical system configuration. 

 

Figure 14: System Configuration Example – RZ/G2L SMARC EVK 
 

3.1 Supported Emulator 
• SEGGER J-Link 
 
For details on SEGGER J-Link, please see J-Link Debug Probes by SEGGER – the Embedded Experts. 

 

3.2 Board Setup 
3.2.1  Boot MODE 
To set the board to Boot mode 3(QSPI Boot(1.8V) Mode), set the SW11 as below. 

 

Figure 15: Boot MODE 
  

https://www.segger.com/products/debug-probes/j-link/
https://www.segger.com/products/debug-probes/j-link/
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3.2.2 JTAG connection 
When connecting JTAG, you must set the DIP SW1 settings as follows: 

 

Figure 16: JTAG connection 
 

Please note that RZ/G2L SMARC EVK has CoreSight 10 connector and therefore, the following adapter 
must be needed to connect Segger J-Link. 

https://www.segger.com/products/debug-probes/j-link/accessories/adapters/9-pin-cortex-m-adapter/ 
 

3.2.3 Debug Serial (console output) 
Debug serial uses CN14. The baud rate is 115200bps. 

 

Figure 17: Debug Serial(console output) 
 

  

https://www.segger.com/products/debug-probes/j-link/accessories/adapters/9-pin-cortex-m-adapter/
https://www.segger.com/products/debug-probes/j-link/accessories/adapters/9-pin-cortex-m-adapter/
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3.2.4 Power Supply 
Here are the power supply related goods to be used in Renesas’ development. Please prepare for the 
equivalent ones for your development. 

• USB Type-C cable CB-CD23BK (manufactured by Aukey) 
• USB PD Charger Anker PowerPort III 65W Pod (manufactured by Anker) 

 

Figure 18: Power Supply 
 

Connect USB-PD Power Charger to USB Type-C Connector. Then LED1(VBUS PWR On) and LED3 
(Module PWR On) lights up. Press SW9 to turn on the power. Then LED4(Carrier PWR On) lights up. 

 

Figure 19: LED Status after Turning on EVK 
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3.2.5 How to check the operation of the board 
First, check the board for problems. There are two ways to do this. Please check with either.  

 

BOOT MODE: QSPI Boot(1.8V) Mode 

If u-boot is written to the serial flash, When the power is turned on, the following will be output to the 
console(CN14). 

 

 

BOOT MODE: SCIF Download Mode 

When the power is turned on, the following will be output to the console (CN14). 
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4. Tutorial: Your First RZ MPU Project - Blinky 
4.1 Tutorial Blinky 
The goal of this tutorial is to quickly get acquainted with the Flexible Platform by moving through the steps of 
creating a simple application using e2 studio and running that application on an RZ MPU board. 

 

4.2 What Does Blinky Do? 
The application used in this tutorial is Blinky, traditionally the first program run in a new embedded 
development environment. 

Blinky is the "Hello World" of microprocessors. If the LED blinks you know that: 

• The toolchain is setup correctly and builds a working executable image for your chip. 
• The debugger has installed with working drivers and is properly connected to the board. 
• The board is powered up and its jumper and switch settings are probably correct. 
• The microprocessor is alive, the clocks are running, and the memory is initialized. 
• Timer (GTM) interrupt is intentionally fired and GPIO is properly controlled. 

 
Note:  SRMAC EVK board does not have any LED. 

Thus, Blinky sample application used in this tutorial is designed to use the Pmod module described 
below alternatively:  
• Pmod LED (Four High-brightness LEDs): https://reference.digilentinc.com/pmod/pmodled/start 

 
This module is not included on the SRMAC EVK board and so, please prepare it beforehand. 

 

Figure 20: Connection Pmod LED module (410-076)  
 

4.3 Create a New Project for Blinky 
The creation and configuration of an RZ/G C/C++ FSP Project is the first step in the creation of an 
application. The base RZ/G2L pack includes a pre-written Blinky example application. 

Follow these steps to create an RZ MPU project: 

1. In e2 studio, click File > New > C/C++ Project. 

 

Figure 21: New C/C++ Project 

https://reference.digilentinc.com/pmod/pmodled/start
https://reference.digilentinc.com/pmod/pmodled/start
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2. Select [Renesas RZ] > [Renesas RZ/G C/C++ FSP Project] and Click Next. 

 

Figure 22: Renesas RZ/G C/C++ FSP Project 
 

3. Assign a name to this new project. Blinky is a good name to use for this tutorial. 
4. Click Next. The Project Configuration window shows your selection. 

 

Figure 23 : e2 studio Project Configuration window (part 1) 
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5. Select the board support package by selecting the name of your board from the Device Selection drop-
down list. Select GNU ARM Embedded in Toolchains and version is 9.2.1.20191025 and Click Next. 

 

Figure 24 : e2 studio Project Configuration window (part 2) 
 
6. Select the build artifact and RTOS. Be sure that on the current version, Secure should always be 

chosen at the Sub-core start state. Otherwise, the created project can’t be built successfully. 

 

Figure 25 : e2 studio Project Configuration window (part 3) 
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7. Select the Blinky template for your board and click Finish. 

 

Figure 26 : e2 studio Project Configuration window (part 4) 
 
Once the project has been created, the name of the project will show up in the Project Explorer window of  
e2 studio. Now click the Generate Project Content button in the top right corner of the Project 
Configuration window to generate your board specific files. 

 

Figure 27 : e2 studio Project Configuration tab 
 
Your new project is now created, configured, and ready to build. 
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4.3.1 Details about the Blinky Configuration 
The Generate Project Content button creates configuration header files, copies source files from templates, 
and generally configures the project based on the state of the Project Configuration screen. 

For example, if you check a box next to a module in the Components tab and click the Generate Project 
Content button, all the files necessary for the inclusion of that module into the project will be copied or 
created. If that same check box is then unchecked those files will be deleted. 

 
4.3.2 Configuring the Blinky Clocks 
By selecting the Blinky template, the clocks are configured by e2 studio for the Blinky application. The clock 
configuration tab (see 5.2.3.Configuring Clocks) shows the Blinky clock configuration. The Blinky clock 
configuration is stored in the BSP clock configuration file. 

 
4.3.3 Configuring the Blinky Pins 
By selecting the Blinky template, the GPIO pins used to toggle the LED1 are configured by e2 studio for the 
Blinky application. The pin configuration tab shows the pin configuration for the Blinky application (see 
5.2.4.Configuring Pins). The Blinky pin configuration is stored in the BSP configuration file. 

 
4.3.4 Configuring the Parameters for Blinky Components 
The Blinky project automatically selects the following HAL components in the Components tab: 
 

• r_gtm 
• r_ioport 

 

To see the configuration parameters for any of the components, check the Properties tab in the HAL window 
for the respective driver (see 5.2.8.Adding and Configuring HAL Drivers). 

 
4.3.5 Where is main()? 
The main function is located in < project >/rzg_gen/main.c. It is one of the files that are generated during the 
project creation stage and only contains a call to hal_entry(). For more information on generated files, see 
Adding and Configuring HAL Drivers. 

 
4.3.6 Blinky Example Code 
The blinky application is stored in the hal_entry.c file. This file is generated by e2 studio when you select the 
Blinky Project template and is located in the project's src/ folder. 

The application performs the following steps: 
 

1. Get the LED information for the selected board by bsp_leds_t structure. 
2. Set the configuration of Timer (GTM) and the callback function that is called when interrupt is fired. 
3. Define the output level HIGH for the GPIO pins controlling the LEDs for the selected board. 
4. Toggle the LEDs by writing to the GPIO pin with “R_BSP_PinWrite((bsp_io_port_pin_t) pin, 

pin_level)” in callback function of GTM that is called with the specified interval. 
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4.4 Build the Blinky Project 
Highlight the new project in the Project Explorer window by clicking on it and build it. 

There are three ways to build a project: 
 

1. Click on Project in the menu bar and select Build Project. 
2. Click on the hammer icon. 
3. Right-click on the project and select Build Project. 

 

Figure 28 : e2 studio Project Explorer window 
 
Once the build is complete a message is displayed in the build Console window that displays the final image 
file name and section sizes in that image. 

 

 

Figure 29 : e2 studio Project Build console 
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4.5 Debug the Blinky Project 
4.6 Debug prerequisites 
To debug the project on a board, you need 
 

• The board to be connected to e2 studio 
• The debugger to be configured to talk to the board 
• The application to be programmed to the microprocessor 

 
Applications run from the internal ram or external ram of your microprocessor. To run or debug the 
application, the application must first be programmed to ram by JTAG debugger. SMARC EVK board has an 
JTAG header and requires an external JTAG debugger to the header. 

 

4.7 Debug steps 
To debug the Blinky application, follow these steps: 

1. Configure the debugger for your project by clicking Run > Debugger Configurations ... 

 

Figure 30 : e2 studio Debug icon 

 or by selecting the drop-down menu next to the bug icon and selecting Debugger 
Configurations ... 

 

Figure 31 : e2 studio Debugger Configurations selection option 
 

2. Select your debugger configuration in the window. If it is not visible, then it must be created by 
clicking the New icon in the top left corner of the window. Once selected, the Debug 
Configuration window displays the Debug configuration for your Blinky project. 
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Figure 32 : e2 studio Debugger Configurations window with Blinky project (1) 
 

3. Select the debug configuration for the generated project and select the Startup tab. 
4. Write the commands listed below in Run Commands: 

   set {int} 0x4102080C=0x1001FF80 
   set {int} 0x41020810=0x00010000 
 

These commands are for setting the address of Secure and Non-secure Vector Offset mapped in 
Blinky project. Please note that these addresses vary in accordance with linker settings. 

 

 

Figure 33: e2 studio Debugger Configurations window with Blinky project(2) 
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5. Click Debug to begin debugging the application. 
6. Extracting RZ Debug. 

 

 

4.8 Details about the Debug Process 
In debug mode, e2 studio executes the following tasks: 

1. Downloading the application image to the microprocessor and programming the image to the 
internal and/or external memory. 

2. Setting a breakpoint at main(). 
3. Setting the stack pointer register to the stack. 
4. Loading the program counter register with the address of the reset vector. 
5. Displaying the startup code where the program counter points to. 

 

Figure 34 : e2 studio Debugger memory window 
 

4.9 Run the Blinky Project 
While in Debug mode, click Run > Resume or click on the Play icon twice. 

 

Figure 35 : e2 studio Debugger Play icon 
 

The LEDs on the Pmod LED marked LD0, LD1, LD2 and LD3 should now be blinking. 
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5. FSP application launch with e2 studio 
5.1 Create a Project 
5.1.1 What is a Project? 
In e2 studio, all FSP applications are organized in RZ MPU projects. Setting up an RZ MPU project involves: 

1. Create a Project 
2. Configuring a Project 

 

These steps are described in detail in the next two sections. When you have existing projects already, after 
you launch e2 studio and select a workspace, all projects previously saved in the selected workspace are 
loaded and displayed in the Project Explorer window. Each project has an associated configuration file 
named configuration.xml, which is located in the project's root directory. 

 

Figure 36 : e2 studio Project Configuration file 
 

Double-click on the configuration.xml file to open the RZ MPU Project Editor. To edit the project 
configuration, make sure that the FSP Configuration perspective is selected in the upper right-hand corner 
of the e2 studio window. Once selected, you can use the editor to view or modify the configuration settings 
associated with this project. 

 

Figure 37 : e2 studio FSP Configuration Perspective 
Note: 

Whenever the RZ project configuration (that is, the configuration.xml file) is saved, a verbose RZ 
Project Report file (rzg_cfg.txt) with all the project settings is generated. The format allows differences 
to be easily viewed using a text comparison tool. The generated file is located in the project root 
directory. 

 

 

Figure 38 : RZ Project Report 
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The RZ Project Editor has several tabs. The configuration steps and options for individual tabs are discussed 
in the following sections. 

Note 
The tabs available in the RZ Project Editor depend on the e2 studio version and the layout may vary 
slightly, however the functionality should be easy to follow. 

 

Figure 39 : RZ Project Editor tabs 
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5.1.2 Creating a New Project 
For RZ MPU applications, generate a new project using the following steps: 

1. Click on File > New > C/C++ Project. 

 

Figure 40 : New RZ MPU Project 
 

2. Then click on the Renesas RZ/G C/C++ FSP Project template for the type of project you are 
creating. 

 

Figure 41 : New Project Templates 
 

3. Select a project name and location. 

 

Figure 42 : RZ MPU Project Generator (Screen 1) 
4. Click Next. 
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5.1.2.1 Selecting a Board and Toolchain 
In the Project Configuration window select the hardware and software environment: 

1. Select the FSP version. 
2. Select the Board for your application. You can select an existing RZ MPU Evaluation Kit or select 

Custom User Board for any of the RZ MPU devices with your own BSP definition. 
3. Select the Device. The Device is automatically populated based on the Board selection. Only change 

the Device when using the Custom User Board (Any Device) board selection. 
4. To add threads, select RTOS, or No RTOS if an RTOS is not being used. 
5. The Toolchain selection defaults to GNU Arm Embedded. 
6. Select the Toolchain version. This should default to the installed toolchain version. 
7. Select the Debugger. The J-Link Arm Debugger is preselected. 
8. Click Next. 

 

Figure 43 : RZ MPU Project Generator (Screen 2) 
 
5.1.2.2 Selecting a Project Template 
In the next window, select the build artifact, Sub-core start state and RTOS. Be sure that you select Secure 
as Sub-core start state in the current version. 

 

Figure 44 : RZ MPU Project Generator (Screen 3) 
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In the next window, select a project template from the list of available templates. By default, this screen 
shows the templates that are included in your current RZ/G MPU Pack. Once you have selected the 
appropriate template, click Finish. 

Note: 
If you want to develop your own application, select the basic template for your board, Bare Metal - 
Minimal or FreeRTOS - Blinky. 

 

Figure 45 : RZ MPU Project Generator (Screen 4) 
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When the project is created, e2 studio displays a summary of the current project configuration in the RZ MPU 
Project Editor. 

 

Figure 46 : RZ MPU Project Editor and available editor tabs 
 
On the bottom of the RZ MPU Project Editor view, you can find the tabs for configuring multiple aspects of 
your project: 

• With the Summary tab, you can see all they key characteristics of the project: board, device, 
toolchain, and more. 

• With the BSP tab, you can change board specific parameters from the initial project selection. 
• With the Clocks tab, you can configure the MPU clock settings for your project. 
• With the Interrupts tab, you can add new user events/interrupts. 
• With the Stacks tab, you can add and configure FSP modules. For each module selected in this 

tab, the Properties window provides access to the configuration parameters, interrupt selections. 
• The Components tab provides an overview of the selected modules. Although you can also add 

drivers for specific FSP releases and application sample code here, this tab is normally only used 
for reference. 

 
The functions and use of each of supported tabs is explained in detail in the next section. 

RZ/G MPU Pack doesn’t support Pins and Event Links tab. When you select those tabs, you should see the 
following warnings on the top of Pins and Event Links pane, respectively. Please never touch those tabs. 

 

 

Figure 47 : Warning for unsupported tabs 
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5.2 Configuring a Project 
Each of the configurable elements in an FSP project can be edited using the appropriate tab in the RZ 
Configuration editor window. Importantly, the initial configuration of the MPU after reset and before any user 
code is executed is set by the configuration settings in the BSP tab. When you select a project template 
during project creation, e2 studio configures default values that are appropriate for the associated board. 
You can change those default values as needed. The following sections detail the process of configuring 
each of the project elements for each of the associated tabs. 

 

5.2.1 Summary Tab 

 

Figure 48 : Configuration Summary tab 
The Summary tab, seen in the above figure, identifies all the key elements and components of a project. It 
shows the target board, the device, toolchain and FSP version. Additionally, it provides a list of all the 
selected software components and modules used by the project. This is a more convenient summary view 
when compared to the Components tab. 

 
5.2.2 Configuring the BSP 
The BSP tab shows the currently selected board (if any) and device. The Properties view is located in the 
lower left of the Project Configurations view as shown below. 

Note: 
If the Properties view is not visible, click Window > Show View > Properties in the top menu bar. 

 

Figure 49 : Configuration BSP tab 
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The Properties view shows the configurable options available for the BSP. These can be changed as 
required. The BSP is the FSP layer above the MPU hardware. e2 studio checks the entry fields to flag invalid 
entries. For example, only valid numeric values can be entered for the stack size.  

When you click the Generate Project Content button, the BSP configuration contents are written to 
rzg_cfg/fsp_cfg/bsp/bsp_cfg.h This file is created if it does not already exist. 

Warning 
Do not edit this file as it is overwritten whenever the Generate Project Content button is clicked. 

 
5.2.3 Configuring Clocks 
The Clocks tab presents a graphical view of the MPU's clock tree, and each HAL driver uses the settings for 
dedicated numerical calculation. For example, scif_uart driver calculates the communication rate from the 
settings in Clocks tab. Please note that the clock configuration is carried out on the main core (CA55) in 
advance. Thus, clocks configuration here must align with the settings on CA55. 

 

Figure 50 : Configuration Clocks tab 
 

When you click the Generate Project Content button, the clock configuration contents are written to: 
rzg_gen/bsp_clock_cfg.h  

This file will be created if it does not already exist. 

Warning 
Do not edit this file as it is overwritten whenever the Generate Project Content button is clicked. 
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5.2.4 Configuring Pins 
RZ/G2L FSP doesn’t support Pins tab. Thus, don’t touch this tab. If you use I/O port, I/O Port setting should 
be modified “pin_data.c” manually. For details on I/O Port setting, please refer to RZ/G2L Setting GPIO with 
Flexible Software Package. 

 

Figure 51: Pin Configuration 
 
5.2.5 Configuring Interrupts from the Stacks Tab 
You can use the Properties view in the Stacks tab to enable interrupts by setting the interrupt priority. 
Select the driver in the Stacks pane to view and edit its properties. 

 

Figure 52 : Configuring Interrupts in the Stacks tab 
 

https://www.renesas.com/document/apn/rzg2l-setting-gpio-with-flexible-software-package
https://www.renesas.com/document/apn/rzg2l-setting-gpio-with-flexible-software-package
https://www.renesas.com/document/apn/rzg2l-setting-gpio-with-flexible-software-package
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Figure 53: Add new stack Timer (GTM) 
 

5.2.6 Creating Interrupts from the Interrupts Tab 
On the Interrupts tab, the interrupt of the driver selected in the Stacks tab is registered.  

 

Figure 54 : Configuring interrupt in Interrupt Tab 
And on the Interrupts tab, the user can add a peripheral interrupt create by user. This can be done by adding 
a new event via the New User Event button. 
 
5.2.7 Viewing Event Links 
RZ/G2L FSP doesn’t support Event Links tab. Thus, don’t touch this tab. 

 

Figure 55: Event Links Configuration 
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5.2.8 Adding and Configuring HAL Drivers 
For applications that run outside or without the RTOS, you can add additional HAL drivers to your application 
using the HAL/Common thread. To add drivers, follow these steps: 

1.  Click on the HAL/Common icon in the Stacks pane. The Modules pane changes to HAL/Common 
Stacks. 

2.  Click New Stack to see a drop-down list of HAL level drivers available in the FSP. 
3.  Select a driver from the menu New Stack > Driver. 

 

Figure 56 : e2 studio Project configurator - Adding drivers 

4.  Select the driver module in the HAL/Common Modules pane and configure the driver properties in 
the Properties view. 

 
e2 studio adds the following files when you click the Generate Project Content button: 

• The selected driver module and its files to the rzg/fsp directory 
• The main() function and configuration structures and header files for your application as shown in 

the table below. 
File Contents Overwritten by Generate 

Project Content? 
rzg_gen/main.c Contains main() calling generated 

and user code. When called, the 
BSP already has Initialized the 
MPU. 

Yes 

rzg_gen/hal_data.c Configuration structures for HAL 
Driver only modules. 

Yes 

rzg_gen/hal_data.h Header file for HAL driver only 
modules. 

Yes 

src/hal_entry.c User entry point for HAL Driver 
only code. Add your code here. 

No 

 
The configuration header files for all included modules are created or overwritten in this folder: 
rzg_cfg/fsp_cfg 
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5.3 Reviewing and Adding Components 
The Components tab enables the individual modules required by the application to be included or excluded. 
Modules common to all RZ/G MPU projects are preselected. All modules that are necessary for the modules 
selected in the Stacks tab are included automatically. You can include or exclude additional modules by 
ticking the box next to the required component. 

 

Figure 57 : Components Tab 
 
Clicking the Generate Project Content button copies the .c and .h files for each selected component into 
the following folders: 

• rzg/fsp/inc/api 
• rzg/fsp/inc/instances 
• rzg/fsp/src/bsp 
• rzg/fsp/src/<Driver_Name> 

 
e2 studio also creates configuration files in the rzg_cfg/fsp_cfg folder with configuration options set in the 
Stacks tab. 
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5.4 Debugging the Project 
Once your project builds without errors, you can use the Debugger to download your application to the board 
and execute it. 

To debug an application, follow these steps: 

1. On the drop-down list next to the debug icon, select Debug Configurations. 

 

2. In the Debug Configurations view, click on your project listed as MyProject Debug. 

 

3. Write the commands listed below in Run Commands 
   set {int} 0x4102080C=0x1001FF80 
   set {int} 0x41020810=0x00010000 
 

These commands are for setting the address of Secure and Non-secure Vector Offset mapped in 
Blinky project. Please note that these addresses vary in accordance with linker settings. 

 

 

4. Connect the board to your PC via a standalone Segger J-Link debugger and click Debug. 
Note: 

For details on using J-Link and connecting the board to the PC, see 3.2.2.JTAG connection. 
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5.5 Modifying Toolchain Settings 
There are instances where it may be necessary to make changes to the toolchain being used (for example, 
to change optimization level of the compiler or add a library to the linker). Such modifications can be made 
from within e2 studio through the menu Project > Properties > Settings when the project is selected. The 
following screenshot shows the settings dialog for the GNU Arm toolchain. This dialog will look slightly 
different depending upon the toolchain being used. 

 

Figure 58 : e2 studio Project toolchain settings 
 

The scope for the settings is project scope which means that the settings are valid only for the project being 
modified. 

The settings for the linker which control the location of the various memory sections are contained in a script 
file specific for the device being used. This script file is included in the project when it is created and is found 
in the script folder (for example, /script/fsp.ld). 
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5.6 Importing an Existing Project into e2 studio 
1. Start by opening e2 studio. 
2. Open an existing Workspace to import the project and skip to step d. If the workspace does not 

exist, proceed with the following steps: 
 

a. At the end of e2 studio startup, you will see the Workspace Launcher Dialog box as shown in the 
following figure. 

 

Figure 59 : Workspace Launcher dialog 

b. Enter a new workspace name in the Workspace Launcher Dialog as shown in the following figure. 
e2 studio creates a new workspace with this name. 

 

Figure 60 : Workspace Launcher dialog - Select Workspace 

c. Click Launch. 
d. When the workspace is opened, you may see the Welcome Window. Click on the Workbench 

arrow button to proceed past the Welcome Screen as seen in the following figure. 

 

Figure 61 : Workbench arrow button 

3. You are now in the workspace that you want to import the project into. Click the File menu in the 
menu bar, as shown in the following figure. 

 

Figure 62 : Menu and tool bar 
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4 Click Import on the File menu or “Import project” on Project Explorer, as shown in the following 
figure. 

 

Figure 63 : File drop-down menu 
 

5. In the Import dialog box, as shown in the following figure, choose the General option, then 
Existing Projects into Workspace, to import the project into the current workspace. 

 

Figure 64 : Project Import dialog with "Existing Projects into Workspace" option selected 
 

6. Click Next. 
7. To import the project, use either Select archive file or Select root directory. 
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a. Click Select root directory file as shown in the following figure. 

 

Figure 65 : Import Existing Project dialog 1 - Select root directory 

8. Click Browse. 
9. For Select root directory, browse to the project folder that you want to import. 
10. Select the file for import. 
11. Click Open. 
12. Select the project to import from the list of Projects, as shown in the following figure. 
 

 

Figure 66 : Import Existing Project dialog 2 

13. Click Finish to import the project. 
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General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 
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