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Application note

Update procedure and configuration in DTM firmware for X-NUCLEO-BNRG2A1

Introduction

This document describes how to update the DTM firmware in the X-NUCLEO-BNRG2A1 expansion board and different
hardware settings to be configured to port the BlueNRG-2 SDK DTM firmware for X-NUCLEO-BNRG2A1 to any custom
application.

The X-NUCLEO-BNRG2A1 is a Bluetooth® Low Energy (BLE) evaluation and development board system designed around
BlueNRG-M2SP Bluetooth® Low Energy module based on the BlueNRG-2 processor.

The processor communicates with the STM32 microcontroller, hosted on the STM32 Nucleo development board, through the
SPI link available on the Arduino UNO R3 connectors.

Figure 1. X-NUCLEO-BNRG2A1 expansion board components
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For further information contact your local STMicroelectronics sales office.


https://www.st.com/en/product/x-nucleo-bnrg2a1?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
https://www.st.com/en/product/bluenrg-2?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
https://www.st.com/en/product/x-nucleo-bnrg2a1?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
https://www.st.com/en/product/x-nucleo-bnrg2a1?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
https://www.st.com/en/product/BlueNRG-M2?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
https://www.st.com/en/product/bluenrg-2?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
https://www.st.com/stm32nucleo
https://www.st.com/en/product/m95640-r?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
https://www.st.com/en/product/BlueNRG-M2?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5651
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System requirements

1 System requirements

1.1 Hardware requirements
The table below lists the boards to be used to upgrade the DTM firmware on the BlueNRG-M2SP.

Table 1. Hardware requirements

X-NUCLEO-BNRG2A1 Evaluation platform based on the BlueNRG-M2SP module for STM32 Nucleo
NUCLEO-L476RG STM32 Nucleo-64 development board with STM32L476RG MCU

To program the X-NUCLEO-BNRG2A1, its 5-pin SWD connector (J12) has to be connected to the NUCLEO-
L476RG via ST-LINK and a mini-USB cable is required to connect the development board to your laptop/PC.

Figure 2. X-NUCLEO-BNRG2A1 and NUCLEO-L476RG connection via ST-LINK programming cable

Important:
Connect the STM32 Nucleo development board debug connector first five pins only and leave pin 6 unconnected.
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PCllaptop requirements

3

1.2 PC/laptop requirements
The minimum requirements to set up the software environment are:

. a PCllaptop with Intel or AMD processor running one of the following Microsoft operating systems: Windows
XP or Vista/Windows 7/Windows 10

. 2 USB ports

. At least 128 MB of RAM

. 40 MB of hard disk space

. BlueNRG-1ST-LINK Utility to update the firmware through SWD connector
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DTM firmware update procedure

2 DTM firmware update procedure

21 Direct update on the X-NUCLEO-BNRG2A1 expansion board
Step 1. Remove CN2 jumper from the NUCLEO-L476RG development board.

Figure 3. NUCLEO-L476RG development board CN2 pin (highlighted in purple)

Step 2. Connect the board via ST-LINK using the programming cable or wires.
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Step 3. Add a jumper to X-NUCLEO-BNRG2A1 J15 to wake up the device when in sleep mode.
This jumper is connected to the BlueNRG-2 DIO7 pin and must be shorted for boot pin high. DIO7 can
be used for bootloader activation.
Figure 4. X-NUCLEO-BNRG2A1 expansion board J15 pin (highlighted in light blue)
Step 4. Download the latest DTM image from the BlueNRG-M2SP web page, selecting the Documentation tab

and then Utilities at the page bottom.

Figure 5. BlueNRG-1 ST-LINK Utility

AN5651 - Rev 1

B8 BlueNRG-1 ST-LINK Utility - a x
File Edit View Target ST-LINK Help
COML D
“m PG WE
Memory  splay Device BlueNRG-2
version ID ver 1
Address: | 0x10042000 v |Sze: | 0x20c88 | Data Width: RevsoniD | Rev Z
Flash size 256KBytes
Device Memory @ 0x 10042000 :  File : BlueNRG_2N_FW_V3_2_0.bin [LiveUpdate
Target memory, Address range: [0x10042000 0x 10062CB8]
Address 0 ‘4 ‘ 8 I c | ASCIl =)
0x10042000 20006000 10062A87 1006159F 100615A8 LEtLYa
0x10042010 AASS35AA 42405545 00020888 00000000 AVU2EULB,.......
0x10042020 00000000 00000000 00000000 10061587
0x10042030 00000000 00000000 1004609F 10061589
010042040 100615C5 10046123 00000000 00000000
0x10042050 100615CD 100466DF 1006160F 10047E0B
0x10042060 00000000 00000000 00000000 00000000  |......ceoiienna
0x10042070 00000000 10047E2B 10047F7F 10048677 vt~ L0 wt
0x10042080 00000000 10046AFB 10046D4F 10046F83 ..0j..0m..fo v
< >
T o T00 : TW0 G UeL Lo IECiED
15:34:20 : ST-LINK SN : 067 1FF565554787167043749 2
15:34:20 : ST-LINK Firmware version : V2124M11
15:34:20 : Connected via SWD.
15:34:20 : SWD Frequency = 1,8 MHz,
15:3 Connection mode : Normal.
15:3 Debug in Low Power mode enabled.
15: Device : BlueNRG-2
15:34:21 : Device family :BlueNRG-2
15:34:21: Device flash Size : 256KBytes
v

Debug in Low Power mode enabled. Device : BlueNRG-2

Core State ! Live Update Disabled
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Update through BlueNRG GUI

Step 5. Open BlueNRG-1 ST-LINK Utility tool and connect to the target.

Figure 6. BlueNRG-1 ST-LINK Utility - target connection

B8, BlueNRG-1 ST-LINK Utility - O X
Eile Edit ... .. jet ST-LINK Help
2l § k2 B2 @
Memaory display Device  BlueNRG-2
Address: | 0x10040000 v | size: | 0:x3F000 | Datawicth: |32 bits | ::\,i::,?;?o ::le

Flash size 256KBytes
Device Memory @ 0x10040000 : File : DTM_SPL.bin
[DTM_SPL.bin], File size: 142360 Bytes

e |4 ‘ é'hmn oad [ DTM_SPL.bin ] L Py

0x000000... | 20006.. | 10040.. 1 Startaddress
0x000000... | AA555...  00000... File path -|CAUsers\ﬁwank\ST\BlueNRG%,2 DK 8.2.1\ProjechBLE_Ex| | Browse

Verification
(®) Verify while programming () Verify after programming

0x000000... | 00000... ' 00000...

lalala

0x000000... | 00000... | 00000...
| Click "Start” to program target.
0x000000... | 10040... | 10040...

=3

0x000000... | 10040... | 10040...

|

0x000000... | 00000... 00000.. ¢ [¥]Resetafterprogramming
0x000000... | 00000... |10040.. 1 Start Cancel
0x000000... | 00000... | 10040.. 10040 710040.. T..." a.n

0x000000... | 10040... | 10040.. 10040.. 10040
0x000000... | 6803B... |43A32.. 60C16.. 68016.. .u.h. $£C."A'B . h 4
<

1370943 © SWU rrequency = 10U RiZ.
13:09:43 : Connection mode : Connect with Pre-Reset.

13:09:43 : Debug in Low Power mode enabled.

13:09:44 : Device : BlueNRG-2

13:09:44 : Device family :BlueNRG-2

13:09:44 : Device flash Size : 256KBytes

13:09:47 : [BlueNRG2_Lighting_Demo.bin] opened successfully.

Step 6.  From the package downloaded at 4., select the DTM image to be uploaded onto the X-NUCLEO-
BNRG2A1 and click [Start].
By default, the DTM image for the BlueNRG-M2SP is:
en.BlueNRG-
M2SA M2SP_DTM Stack v2 1c\BlueNRGM2SA M2SP DTM Stack v2.1lc\BLUENRG-
M2SP_32MHz RO_SMPS off\SPI\BLUENRG-M2SP_ DTM SPI.hex
as shown in the following figure (you can find it in the BlueNRG-M2 web
page by selecting the Documentation tab and then Utilities at the page bottom, as detailed in step 4).

Figure 7. BlueNRG-2 DTM image

en.BlueNRG-M2SA_M2SP_DTM_Stack v2_Tc » BlueNRG-M2SA_M2SP_DTM _Stack v2.1c » BLUENRG-M2SP_32MHz_RO_SMPS off » SPI

~

i Name v Date modified Type Size
| ] BLUENRG-M2SP_DTM_SPI.hex 1/19/2021 3:21 PM HEX File 382 KB
[] BLUENRG-M2SP_DTM_SPI_for_updater.bin 1/19/2021 3:22 PM FTE Binary Export File 146 KB

Step 7. Add the jumper back on CN2 and remove it from J15.

2.2 Update through BlueNRG GUI
Step 1.  Download the X-CUBE-BLEZ2 package from www.st.com.

Step 2. Load the VCOM binary on the NUCLEO-L476RG (the binary path is: Xx-CUBE-
BLE2\Projects\STM32L476RG-Nucleo\Applications\Virtual COM Port\Binary).

Step 3.  Open BlueNRG GUI

AN5651 - Rev 1 page 6/15
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Update through IFRStack_Updater application

Step 4. From [Tools]>[Settings], set baud rate to 115000 and open the COM port.

Figure 8. BlueNRG GUI v4.0.0

&7 BlueNRG GUI v4.0.0 - a x
File Tools Settings Help
BluelRG-2 HWvi.2

Port: |€OM7 - | HwReset BlueNRG-2 FW v2.1c- DTM SPI v3.2.0
Motherboard FW v1.6

ACICommands ~ ACIUtliies  Saipts  Beacon ~ RFTest  Throughtput

Init Device...

\ |
\ |
[ Seurity Configuration... |
| Seaity Informaton... |

Peripheral Role
Central Role
‘ e ‘ [ Advertising... |
[ Connectors... |
[ Update Connectons... I Update Advertisng Data... |

The following message appears:

Figure 9. Old DTM firmware detected

1
&7 BlueNRG GUI X

1 Old DTM fw detected.
Update DTM fw.
L

Terminate Connections...

il

L

Step 5. Ignore the pop-up and, in [Tools]>[Stack Updater] menu, select

en.BlueNRG-
M2SA M2SP DTM Stack v2 1c\BlueNRGM2SA M2SP DTM Stack vZ2.1c\BLUENRG-
M2SP 32MHz RO _SMPS off\SPI\BLUENRG-M2SP DTM SPI for updater.bin

and click [Update].

2.3 Update through IFRStack_Updater application
Step 1.  Download the X-CUBE-BLE2 package from www.st.com.

Step 2.  Load the YMODEM_Stack_Updater_L476RG.bin binary on the NUCLEO-
L476RG (the binary path is: X-CUBE-BLE2\Projects\STM32L476RG-
Nucleo\Applications\IFRStack Updater\Binary).

Step 3. Launch a serial terminal (e.g., Tera Term) and open a connection setting the parameters as follows:
—  Speed: 115200
—  Data: 8-bit
—  Parity: None
—  Stop bits: 1
- Flow control: none
—  New-line: Receive=AUTO
—  Transmit=CR
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Emulating the BlueNRG-2N device with the X-NUCLEO-BNR2A1 expansion board

In [File]>[Transfer]>[YMODEM]>[Send], select en.Bl1ueNRG-
M2SA M2SP_DTM Stack v2 1c\BlueNRGM2SA M2SP DTM Stack v2.1lc\BLUENRG-
M2SP_ 32MHz RO_SMPS off\SPI\BLUENRG-M2SP DTM SPI for updater.bin

YMODEM selection in Tera Term

¥ COM4 - Tera Term VT

File Edit Setup Control Window Help

New connection... Alt+N
Duplicate session Alt+D
Cygwin connection Alt+G
Log...

Stop Logging (Q

Send file...

Transfer > Kermit

SSH SCP XMODEM >

Change directory... YMODEM > Receive...
Replay Leg... ZMODEM > Send,..
TTY Record A >

TTV Replay Quick-VAN

Print... Alt+P

Disconnect Alt+|

Exit Alt+Q

Exit All

At the end of the file transfer, the fast-blinking LD2 LED (T = 0.5 secs) on the NUCLEO-L476RG
indicates that the updating process has successfully terminated (the slowly blinking LD2 LED (T = 3
secs) indicates that the updating process has failed).

Emulating the BlueNRG-2N device with the X-NUCLEO-BNR2A1 expansion
board

The BlueNRG-2N device is an ultra-low power (ULP) network coprocessor solution for Bluetooth® low energy
applications and can be emulated on the X-NUCLEO-BNRG2A1 as described hereafter.

Download and unpack the STSW-BNRG2N-V320, which contains the BlueNRG-2N image
(BlueNRG_2N_FW_V3_2_0.bin).

BlueNRG-2N image
en.stsw_bnrg2n_v320 » en.stsw-bnrg2n-v320 > fw_images

~

Name Date modified Type Size
BlueNRG_2N_FW_V3_2_0.bin 7/3/2020 9:23 PM FTE Binary Export File 132 KB
| BlueNRG_2N_FW_V3_2 0.c 7/7/2020 4:18 PM C File 3 KB
BlueNRG_2N_Updater.bin 7/3/2020 9:23 PM FTE Binary Export File 8 KB

Follow steps 1 to 4 of Section 2.1 to flash the BlueNRG-2N firmware image to emulate the
BlueNRG-2N device.
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Custom DTM image generation for applications on X-NUCLEO-BNRG2A1

Custom DTM image generation for applications on X-NUCLEO-

BNRG2A1

DTM firmware available in the STSW-BLUENRG1-DK (BlueNRG-1_2DK 3.2.1
\Firmware\BLE_Examples\DTM\BlueNRG-2) is a starting point for the generation of an image based on

applications.

The pre-processor in the DTM SPI example has to be configured for the BlueNRG-M2SP module.

Table 2. Pre-processor symbol value for BlueNRG-M2SP mounted on X-NUCLEO-BNRG2A1

Pre-processor symbol BlueNRG-M2SP

HS_SPEED_XTAL
LS_SOURCE
SMPS_INDUCTOR

HS_SPEED_XTAL_32MHZ
LS_SOURCE_INTERNAL_RO
SMPS_INDUCTOR_NONE

The above pre-processor symbols will be configured in the project workspace as shown in the following figures.

Figure 12. Pre-processor symbols in IAR workspace of DTM SPI project

mbedded Workbench IDE - Arm 8.50.4

File Edit View Project ST-link Tools
DO @@ = £ K0 O
Workspace

SPI

Files
=y IDTM-SPL |
i DTM_Updater

i Hal

M Library

+—® ol Stack

M Startup

—C1 B User

| [ BlueNRG1_itc

[ B emde

| ) DTM_bootc

& DTM_burstc
E1DTM_cmd_db.c
I DTM_cmds.c
B DTM_main.c

E) hei_parser.c

Lo B s mmnfic -

| oM

Build

Messages

DTM_SPlout

Converting

Performina Post-Build Action

Options for node “DTM*

Category:

General Options
Static Analysis
Runtime Checking
Assembler
Output Converter
Customn Build
Build Actions
Linker
Debugger
Simulator

CADI

CMSIS DAP
GDB Server
I-jet
JLink/JTrace
TI Stellaris
Nu-Link

PE micro
ST-LINK
Third-Party Driver
TI MSP-FET
TIXDS

Factory Settings
] Multi-file Compilation
Discard Unused Publics
MISRA-C:1998 Encodings Extra Options
Language 1 Language 2 Code Optimizations Output
List Preprocessor Diagnostics MISRA-C:2004

["]ignore standard include directonies

Additional include directories: (one per line)

$PROJ_DIRS\..\..\inc

$PROJ_DIRS$\.\.\.\.\. \Library\BlueNRG1_Periph_Driveriinc
$PROJ_DIRS\.\..\.\..\..\LibrarACMSIS\Device\ST\BlueNRG 1\Inch

~

$PROJ_DIRSL.\.\.
$PROJ_DIRSL.L.\.L.

Preinclude file:

ALibrary\CMSIS\Include
. \Library\Bluetooth_LE\inc v

Defined symbols: (one per line)

HS_SPEED_XTAL=HS_SPEEI ~
LS_SOURCE=LS_SOURCE_II
SMPS_INDUCTOR=SMPS_IN
USER_BUTTON=BUTTON_1 ~

[ Preprocessor output to file
Preserve comments
Generate #iine directives

Cancel

configh x DT

ded to write

s reduced to

PREP WRITE
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Custom DTM image generation for applications on X-NUCLEO-BNRG2A1

Figure 13. Pre-processor symbols in Keil workspace of DTM SPI project

B C\Users\tiwarik\ST\BlueNRG-1_2 DK 3.2.1\Project\BLE_Examples\DTM\MDK-ARM\BlueNRG-2\DTM.uvprojx - pVision

File Edit View Project Flash Debug Peripherals Tools SVCS Window Help
| T lﬁ H ﬂ ‘ ] a m| ‘ | F h 'b r“,| £ I/ .l’f| B nci_gatt_zl(hangz_(nnli.v. 3 '.| Q " [ ] (9 |
EEE e W e EEE R A
roject =B _] DTM_mainc |
8% f'rojed: O™ E Options for Target 'SPI’ x
o &3 SPI
& 3 DTM_Updater Device | Target | Output | Listing | User  C/C++ | Asm | Linker | Debug | Utities |
(3 Hal
@ [ Library Preprocessor Symbols
@ 3 Stack Define: [._32MHZ LS_SOURCEFLS_SOURCE_INTERNAL_RO SMPS_INDUCTOR=SMPS_INDUCTOR_NONE
® E__] Startup Ucdedine: I
B &5 User
] BlueNRG1_it.c [~ Language / Code Generation
] emdc ™ Execute-only Code ™ Strict ANSIC Wamings: |Al Wamings 'I
] DTM_boot.c Optimization: [Level 2(02) ~ [~ Enum Container always int I Thumb Mode
] DTM_burst.c [ Optimize for Time [™ Plain Charis Signed I~ No Auto Includes
] DTM_cmd_db.c I~ Spit Load and Store Mutiple I™ Read-Only Postion Independent ¥ €39 Mode
] DTM_cmds.c [¥ One ELF Section per Function [~ Read-Write Postion Independent I~ GNU extensions
_'] DTM_main.c
] hci_parser.c !"g:; |.‘\..\r-c:,.\..\‘.\‘.\.‘\Lbraty\&JeNHG1_Pe|'uh_Driver\hc;_.\.‘\,‘\..\..\Lbrm\CMSIS\Device\ST\&.u J
J hw_config.c
] transport_layer.c Cw;rd:‘fc IW32
Compier |99 ¢ ~cpu Cortex-MD -D__MICROLIB g 02 -apcs=intenwork ~splt_sections -| ../ /inc -1 ~
control |./../../../. /Library/BueNRG1_Periph_Driver/inc -
o | » string v
Eijed 6800&.5 {} Funct.. l],T&mpI.”
uild Output ok | Cacel |  Defaus | Help

BlueNRG Sleep API can be commented to generate X-NUCLEO-BNRG2A1 image to avoid the BlueNRG-2
device to go into sleep mode when not required.

Figure 14. BlueNRG_Sleep APl commented in while loop of DTM SPI project

© DTM - 1AR Embedded Workbench IDE - Arm 8.50.4 =
File Edit View Project ST-link Tools Window Help
DO = A0 DC

2$Q>%r=< B> MG-=0" &7

Workspace * B X | hci_parser.c DTM_burst.c  DTM_cmd_db.c  system_bluenrgl.c  bluenrgl_apih DTM_mainc x DTM_boot.c DTM_configh
SPI 4
" P crash_info.R1,
Files LA crash_info.R2,
£ @DTM-SPI v crash_info.R3,
—= M DTM_Updater crash_info.R12,
2 RDTM_Updater_.. crash_info.LR,
| = o Output crash_info.PC,
| “— B compilerh crash_info.xPSR,
L— 1 DTM_Updater_.. 0,
= i Hal H NULL) ;
M Library ] !
1 i Stack .
M Startup El while(l) ¢
o Wl User /* BlueNRG-1 stack tick */
B BlueNRG1_itc BURST Tick ()
La = BTLE_StackTick();
Bemde transport layer tick():
ggm—gnm-c // BlueNRG Sleep (SLEEPMODE NOTIMER, IO WAKEUP PIN[DTM INTERFACE], 0); // 4: I011 0: low level
urstc & B N B - B
= ]
B DTM_cmd_db.c )
B DTM_cmds.c v L
[omM <

Ruiild

Other configurations, such as max. value for ATT MTU, can be changed by modifying the MAX ATT MTU macro in
DTM_config.h (by default, set to 220 in the DTM firmware available in STSW-BLUENRG1-DK).
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IMPORTANT NOTICE - PLEASE READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST”) reserve the right to make changes, corrections, enhancements, modifications, and improvements to ST
products and/or to this document at any time without notice. Purchasers should obtain the latest relevant information on ST products before placing orders. ST
products are sold pursuant to ST’s terms and conditions of sale in place at the time of order acknowledgement.

Purchasers are solely responsible for the choice, selection, and use of ST products and ST assumes no liability for application assistance or the design of
Purchasers’ products.

No license, express or implied, to any intellectual property right is granted by ST herein.
Resale of ST products with provisions different from the information set forth herein shall void any warranty granted by ST for such product.

ST and the ST logo are trademarks of ST. For additional information about ST trademarks, please refer to www.st.com/trademarks. All other product or service
names are the property of their respective owners.

Information in this document supersedes and replaces information previously supplied in any prior versions of this document.

© 2021 STMicroelectronics — All rights reserved
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