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1 Overview

1.1 Software function

OPGateway is software that provides data linking between OPC systems, serving as a bridge for
communication between multiple OPC servers or between MQTT and OPC DA servers.
OPGateway can function as both a client and a server. As an OPC client, users can collect data
from one or more OPC servers via OPGateway. As an OPC server, OPGateway can gather,
organize, and link data from other OPC servers and then provide the data to OPC clients.
Additionally, OPGateway supports the direct transmission of real-time industrial data to enterprise
device clouds, big data analysis platforms, and databases via interfaces such as MQTT and Native.

1.2 Supported Operating Systems

• Windows 11
• Windows 10
• Windows Server 2022
• Windows Server 2019
• Windows Server 2016
• Windows Server 2012 R2 and 2012

1.3 Supported Interfaces

• OPC DA 3.0
• OPC DA 2.0
• MQTT 3.1
• MQTT 3.1.1
• MQTT 5.0
• Native

1.4 Revision History

Date Revision Description

2024-12-30 V2.1 First Release



www.SSTAutomation.com 3

2 Installation and Activation

2.1 Installation

Double -click the installation file (.exe file) and gradually install according to the software
prompts.
To install the software, double-click the installation file (.exe), and follow the on-screen
instructions step by step.

2.2 Activation

If the software is not activated, the "Software activation" prompt will pop up:

(1) Activate: After purchasing the software, please contact a technical support engineer to obtain
the activation file. Click the "Import" button, and the activation will be completed after the
file is imported.

(2) Trial: If activation is not required, you can click the "Trial" button to enter the main interface
of the software. The trial period lasts for 2 hours (there will be a countdown reminder on the
software interface).After the trial period expires, the software will automatically exit. Please
make sure to save your project files in time.



www.SSTAutomation.com 4

3 Software User Manual

3.1 Navigating the Configuration

The application Configuration is divided into four panes: the Server View, the Group&MQTT
View, the Link View, and the Event Log View.

 Server View:It can display all OPC Servers on the local computer.
 Group&MQTT View:It allows operations such as creating, modifying, deleting, importing

CSV, and exporting CSV for Group and MQTT.
 Link View:It allows operations such as creating, modifying, deleting, copying, and pasting

Links.
 Event Log View: Information displays the user's operation log and allows the log to be saved.

You can also click on "News" to get the latest news.
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3.2 What is the OPC Groups

OPGateway provides Tag linking functionality between single or multiple local OPC servers,
enabling data transfer between Tags across multiple servers. Users can add multiple Groups and
assign Link Items to them to achieve the linking functionality.

3.2.1 Group Properties

The parameter descriptions are as follows:
 Name: The name of the Group, which must be unique.
 Description: Set a description for the Group name.
 Scan Rate: Set the update rate for server data, with a minimum value of 10ms. Range: 10ms

to 600000ms.
 Connection Timeout: Effective when "Automatic Reconnection" is enabled. Range: 1 to

3600 seconds.
 Automatic Reconnection: Enable this option to allow OPGateway to automatically

reconnect to an OPC Server with an established connection. The interval for automatic
reconnection can be configured.
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3.2.2 Link Item Properties

The Link Item properties interface includes the following sections: General,Input,and Output.
1. General Interface:

The parameter descriptions are as follows:
 Name: Set the name for this Link.
 Description: Set the description for the Link name.

2. Input Interface:

The parameter descriptions are as follows:
 Machine name: Currently, only OPC servers on the local computer are supported.
 Server: The name of the OPC server to be accessed.
 Access Path: Some OPC servers require this parameter to help determine the Item ID. Refer

to the actual OPC server to determine whether this parameter needs to be filled in.
 Item ID: The data source referenced by the OPC server. If the OPC server supports tag

browsing, you can click the "..." button to open the tag browsing dialog. Double-clicking a
tag will set the Item ID, and the dialog will automatically close, with the Item ID being filled
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in automatically.
 Data Type: Set the data type for communication with the OPC server. Supported data types

are defined as follows:

Native Default as determined by the OPC server

Boolean Single bit

Char Signed 8-bit value

Byte Unsigned 8-bit value

Short Signed 16-bit value

Word Unsigned 16-bit value

Long Signed 32-bit value

DWord Unsigned 32-bit value

Float Single precision floating point value. (32-bits)

Double Double precision floating point value (64-bits)

String Zero terminated character array

*Except for Boolean and String types, all the above data types can be selected as arrays.

3. Output Interface:

The parameter description is the same as Input.
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3.3 What is the OPC DA to MQTT

OPGateway can act as an OPC client to collect data from one or more OPC servers. It transmits
the data to the enterprise's device cloud, big data analysis platform, or database through interfaces
such as MQTT, Native, etc. OPGateway needs to create MQTT, Topic, and Link for related
configurations.

3.3.1 MQTT Properties

The parameter descriptions are as follows:

 Connection Properties:

 MQTT Name: The username and identity key for connecting to the general MQTT
platform, which can be obtained from the cloud platform you wish to connect to.

 Username,Password: Set the username and password for authentication.
 MQTT Broker Address: The IP or URL address of the cloud platform to connect to.
 MQTT Broker Port: The port number of the cloud platform to connect to.
 Publish Type: There are two options:
Interval: Sends changed data to the cloud when data changes.
Change of value: Sends data to the cloud at a configured interval, regardless of whether the

data has changed.
 Scan Rate(ms): Effective when the data transmission mechanism is set to "Interval"

This sets the time interval for sending data, with a range of 10–600000ms. The default
setting is 1000ms.
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 Keep Alive Interval(s): The interval between sending successive Keep Alive packets
after OPGateway sends a Keep Alive and receives a correct reply. The range is
10–99999990s, with a default setting of 60s.

 MQTT Version: The MQTT protocol version. Currently, versions V3.1, V3.1.1, and
V5.0 are supported. Users can select the version according to their needs.

 Clean Session: The default is checked.
Checked: If the OPGateway service disconnects, a new connection will be created, and data

from before the disconnection will not be retained.
Unchecked: When the OPGateway service reconnects, it can continue to receive messages

published to the topics it subscribes to during the offline period.
 Auto Reconnect: The auto-reconnect feature. The default is checked. If the MQTT

connection times out and disconnects, it will automatically attempt to reconnect.
 Enabled: Whether to enable this MQTT connection. The default is checked, enabling

this MQTT connection.

 Advanced:

 Client ID: The unique identifier for the MQTT client when connecting to the server.
Each client connection to major cloud platforms must have a unique Client ID. If there
are no special requirements, it is recommended to click the "Auto new Client ID" button
to randomly generate a Client ID. The parameter can be set with a character length of
1–128.

 Custom Message Format: The default is off, meaning custom data formatting is
disabled, and data will be transmitted in the default format. The default data
transmission format is:
{
"Tag4_K":12
}

 Edit Message Format: Effective when "Custom Send Data Format" is set to "On."
Users can edit the data transmission format, and the device will automatically convert
data into the corresponding format before sending it.
Click the "Edit" button to open the settings window as shown below:
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1 Example Format Description:
{

"timestamp": |TIMESTAMP|,
"values": {

|#each VALUES|
"id": "|TAGNAME|", "name": "|PROPERTIESNAME|", "v":

|VALUE|, "q": |QUALITY|, "t": |OPCTIME||#unless @last|,|/unless|
|/each|

}
}
|TAGNAME|: The full path of the Tag.

|PROPERTIESNAME|: The name of the property.

|VALUE|: The value of the tag.

|QUALITY|: The quality of the tag.

|OPCTIME|: The timestamp when the tag value was updated.

|TIMESTAMP|: The time when the tag value was read.

2 Click "Check JSON" to validate the JSON format.
3 Click "Preview" to view the message preview, as shown below:
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 SSL/TLS: By default, SSL/TLS is disabled. When enabled, it allows secure MQTT
connections to the cloud platform, ensuring safe data transmission.

3.3.2 Topic Properties

The parameter descriptions are as follows:

 Topic Name: Set the name of this Topic. It can be customized, but should not be duplicated.
It is used to filter or organize the data published/subscribed on the broker.

 Topic Type: Set the Topic type. There are three options available: Publish, Subscribe, and
Publish and Subscribe.
Publish: OPC data is sent to the MQTT platform.
Subscribe: MQTT data is sent to the OPC side.

 QoS: The default setting is 0. There are three options available: 0, 1, and 2.
QoS 0: For OPC, data will be sent only once, regardless of whether MQTT receives it.
Suitable for less critical data.
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QoS 1: For OPC, an acknowledgment (ack) will be sent to ensure that data reaches the client
or server. However, it cannot guarantee that the data is sent only once. If the ack is not
received, the data will be resent, up to a maximum of 3 times.
QoS 2: For OPC, a complex four-step handshake is used to ensure secure data delivery to the
client or server, ensuring that messages are neither lost nor duplicated.

 Retain:
Checked: Ensures that subscribers can receive messages that were published earlier,
addressing subscription delays and providing immediate message delivery.
Unchecked: New clients subscribing to this Topic will not receive retained messages.

3.3.3 MQTT Item Properties

The MQTT Item properties interface consists of the following sections: General, MQTT End, and
Output.

1. General Interface

The parameter descriptions are as follows:
 Name: Set the name of the Link.
 Description: Set the description for the Link name.

2. MQTT End Interface
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The parameter descriptions are as follows:

 Tag Name: Set the name of the MQTT side tag.
 State: Determines whether the current point is enabled.
 Byte Swap: Currently only supports "No", meaning the data is transmitted normally.
 Scale: Default is 1.000. The range is from 0.001 to 1000. Example: Set the scaling factor to

0.001, with an input value of 123000. The output value will display as 123000 x 0.001 = 123.
 NwFault: Currently only supports "Hold".

Hold: When a network failure occurs at the input, the output will retain the last correctly
received data.

3. Output Interface

The parameter descriptions are as follows:
 Machine name: Currently, only OPC servers on the local computer are supported.
 Server: The name of the OPC server to be accessed.
 Access Path: Some OPC servers require this parameter to help determine the Item ID. Refer

to the actual OPC server to determine whether this parameter needs to be filled in.
 Item ID: The data source referenced by the OPC server. If the OPC server supports tag

browsing, you can click the "..." button to open the tag browsing dialog. Double-clicking a
tag will set the Item ID, and the dialog will automatically close, with the Item ID being filled
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in automatically.
 Data Type: Set the data type for communication with the OPC server. Supported data types

are defined as follows:

Native Default as determined by the OPC server

Boolean Single bit

Char Signed 8-bit value

Byte Unsigned 8-bit value

Short Signed 16-bit value

Word Unsigned 16-bit value

Long Signed 32-bit value

DWord Unsigned 32-bit value

Float Single precision floating point value. (32-bits)

Double Double precision floating point value (64-bits)

String Zero terminated character array

*Except for Boolean and String types, all the above data types can be selected as arrays.
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3.4 How Do I...Configure OPC Groups

OPGateway can achieve data transfer between Tags in an OPC Server by creating Groups and
Items. Taking the local OPC Server (KEPServerEX software) as an example, the process of
transferring data between two Tags is explained as follows.

3.4.1 Starting a New Project

To start, open OPGateway by double-clicking the desktop icon. Alternatively, select OPGateway
from the Windows Start menu.
Click the menu bar [File-> New] button, or toolbar [New] button to create a new project file:

3.4.2 Adding a Group

1. Below OPC Groups, click [Click to add an OPC Group] button to create a new group.

The Group can also be created in the following ways：
(1) Right-click on OPC Groups, open the context menu, and select [New Group] to

configure.

(2) Right-click on the added Group, open the context menu, and select [New Group] to
configure.
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You can also click the [Delete Group] button to delete the Group.
You can also click the [Import CSV...] or [Export CSV...] button to import/export the Link
Items under the Group using a CSV file.

(3) Click the [Edit -> New Group] button in the menu bar to configure.

You can also click the [Delete Group] button to delete the Group.

(4) Click the [New Group] button on the toolbar to configure.

You can also click the [Delete] button to delete the Group.

2. Open the Group Properties interface:
You can set the name and other parameters of the Group. If there are no special requirements, the
default settings can be used.
To modify the Group configuration, double-click on the Group to open the properties interface.
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 For more information, please refer to“3.2.1 Group Properties”.

3. Click 'OK' to complete the configuration.

3.4.3 Adding a Link

Before creating a Link, ensure that the local OPC Server is installed and the Tags for input and
output have been created.
The OPC Server used in this document is the KEPServerEX software, which is installed locally.
Tag1_R and Tag2_K, have been created using the Simulator driver.

1. On the blank area on the right side, click [Click to add a link] to create a new link.

The Link can also be created in the following ways：
(1) Right-click on the blank area on the right side, open the context menu, and select [New

Link] to configure.
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(2) Right-click on the added Link, open the context menu, and select [New Link] to
configure.

You can also click other buttons to Delete, Copy, or Paste the Link.

(3) Click the [Edit -> New Link] button in the menu bar to configure.

You can also click other buttons to Delete, Copy, or Paste the Link.

(4) Click the [New Link] button on the toolbar to configure.

You can also click the [Delete] button to delete the Link.

2. Open the Link Properties interface:
The General interface allows you to set the Link's name and description. Set them according to
your needs. To modify a Link, double-click on the Link to open the properties interface.
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3. Next, open the Input tab:
In the example below, the machine name is "Local Machine" and the server is
Kepware.KEPServerEX.V6.

Click the “...” button to open the following interface:

Double-click Tag1_R to complete the addition:
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Data Type: Select the default setting, Native.
 For more information, please refer to“3.2.2 Link Item Properties”.

4. Next, open the Output tab:

Click the “...” button to open the following interface:

Double-click Tag2_K to complete the addition:
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Data Type: Select the default setting, Native.
 For more information, please refer to“3.2.2 Link Item Properties”.

5. Click 'OK' to complete the configuration.

3.4.4 Saving the Project

1. After completing the project file setup, click the [File -> Save] button in the menu bar or the
[Save] button on the toolbar to save the file.

2. Open the save window, enter the project file name, and click the Save button to save.

3. Click the [Service -> Apply] button in the menu bar to start the service.
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A progress bar will pop up. Once the progress bar completes, the prompt will automatically close,
and the service will start running.

The Link will appear as follows:

4. Open the KEPServerEX software interface, click the QC button on the toolbar, and check the
data transmission results.

The data from Tag1_R has been transferred to Tag2_K:
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3.5 How Do I...Configure OPC DA to MQTT

An example is given to explain the configuration process for publishing and subscribing between
the local OPC Server (KEPServerEX) and the MQTT Broker using OPGateway.

3.5.1 Adding a MQTT

1. Below OPC DA to MQTT, click [Click to add a MQTT connection] button to create a new
MQTT.

The MQTT can also be created in the following ways：
(1) Right-click on OPC DA to MQTT, open the context menu, and select [New MQTT] to

configure.

(2) Right-click on the added MQTT, open the context menu, and select [New MQTT] to
configure.

You can also click other buttons to delete or disable the MQTT. Click the [Add Topic] button
to create a Topic under this MQTT.

(3) Click the [Edit -> New MQTT] button in the menu bar to configure
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You can also click the [Delete MQTT] button to delete the MQTT.

(4) Click the [New MQTT] button on the toolbar to configure.

You can also click the [Delete] button to delete the MQTT.

2. Open the MQTT Properties interface：
In this interface, configure the MQTT client by filling in the MQTT Broker's username, password,
Broker address, and port. Click 'Create new Client ID' to fill in the 'Client ID,' and leave the other
settings as default.
To modify the MQTT configuration, double-click on the MQTT to open the properties interface.

 For more information, please refer to“3.3.1 MQTT Properties”.

3. Click 'OK' to complete the configuration.
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3.5.2 Adding a Topic

1. Under the created MQTT, click [Click to add a Topic] to create a new Topic.

The Topic can also be operated as follows:
(1) Right-click on the added MQTT, open the context menu, and select [Add Topic] to

configure.

(2) Right-click on the added Topic to open the context menu, where you can delete or
disable the Topic.

You can also click the [Import CSV...] or [Export CSV...] button to import/export the Link
Items under the Topic using a CSV file, and click [New link] to create a new link.

(3) Select the added Topic and click the [Disable] button on the toolbar to disable the Topic.
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2. Open the Topic Properties interface:
(1) Add a publish Topic: Topic0

 For more information, please refer to“3.3.2 Topic Properties”.

(2) Add a subscribe Topic: Topic1

 For more information, please refer to“3.3.2 Topic Properties”.

3. Topic creation complete:

3.5.3 Adding a Link

Before creating a Link, ensure that the local OPC Server is installed and the Tags for input and
output have been created.
The OPC Server used in this document is the KEPServerEX software, which is installed locally.
Tag3_R and Tag4_K, have been created using the Simulator driver.
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1. Select Topic0 (Publish Topic):
（1）On the blank area on the right side, click [Click to add a link] to create a new link.

The Link can also be created in the following ways：
1 Right-click on the blank area on the right side, open the context menu, and select [New

Link] to configure.

2 Right-click on the added Link, open the context menu, and select [New Link] to
configure.

You can also click other buttons to Delete,Disable, Copy, or Paste the Link.
3 Click the [Edit -> New Link] button in the menu bar to configure.



www.SSTAutomation.com 28

You can also click other buttons to Delete, Copy, or Paste the Link.

4 Click the [New Link] button on the toolbar to configure

You can also click the [Delete] button to delete the Link.

（2）The 'Select Item ID' interface pops up, and select Tag3_R in KEPServerEX to be used for
publishing:

Click the 'OK' button to complete the addition of the Link, as shown below:

（3）To modify the Link settings, double-click the Link to open the Link properties interface as
shown below: You can configure the parameters on the General, MQTT End, and Output tabs.

 For more information, please refer to“3.3.3 MQTT ItemProperties”.

2. Select Topic1(Subscribe Topic):
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（1）On the blank area on the right side, click [Click to add a link] to create a new link.

（2）The 'Select Item ID' interface pops up, and select Tag4_K in KEPServerEX to be used for
publishing:

Click the 'OK' button to complete the addition of the Link, as shown below:

（3）To modify the Link settings, double-click the Link to open the Link properties interface as
shown below: You can configure the parameters on the General, MQTT End, and Output tabs.

 For more information, please refer to“3.3.3 MQTT ItemProperties”.
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3.5.4 Saving the Project

1. After completing the project file setup, click the [File -> Save] button in the menu bar or the
[Save] button on the toolbar to save the file.

2. Open the save window, enter the project file name, and click the Save button to save.

3. Click the [Service -> Apply] button in the menu bar to start the service.

A progress bar will pop up. Once the progress bar completes, the prompt will automatically close,
and the service will start running.

4. Use MQTT.fx software to illustrate the data exchange process with KEPServerEX:
(1) Open the MQTT.fx software and configure the MQTT Broker information.
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(2) Click the Connect button to establish communication. Select the 'Subscribe' button, enter the
published Topic name Topic0, and the data value of Tag3_R in KEPServerEX can be read.
The example is shown below:
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(3) Select the 'Publish' button, enter the subscribed Topic name Topic1, and according to the
default data output format, the data value can be sent to Tag4_K in KEPServerEX. The
example is shown below:

 For the data format sent by the MQTT Broker, please refer to“3.3.1 MQTT Properties”.

3.6 How Do I... Import and Export Links Using a CSV File

OPGateway can import and export Links in CSV file format, which can quickly create/modify
project files.

1. Inporting Links from a CSV File
(1) Right-click on Group/Topic to open the context menu, and select [Import CSV...]

(2) A file open window will pop up. Select the CSV file and click 'Open,' and the Group/Topic
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will automatically add the Link information from the CSV file.

2. Exporting Links to a CSV File
(1) Right-click on Group/Topic to open the context menu, and select [Export CSV...]

(2) A save window will pop up. Enter a file name and click 'Save' to save the Links in the
Group/Topic to the CSV file.
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3.7 Apply/Start/Stop/Restart Service

In the menu bar, under [Service], you can perform operations such as Apply, Start, Stop, and
Restart the service. When changes are made to the project file, click "Apply" to make the
changes take effect.

In the Task Manager under "Services", you can view the current status of the service.

1. Apply Service：

Click [Service -> Apply] in the menu bar to immediately apply the current configuration. If the
configuration has not been saved, save the file first and then apply the configuration.

2. Start Service：
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When the OPGateway service is stopped, click [Service -> Start] in the menu bar to start the
service.

3. Stop Service：

When the OPGateway service is running, click [Service -> Stop] in the menu bar to stop the
service.

4. Restart Service：

When the OPGateway service is running, click [Service -> Restart] in the menu bar to restart the
service. If the OPGateway service has been stopped, this will be a "Start Service" operation
instead.
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3.8 Check for updates

When the computer is connected to the network, click [Help -> Check for Updates] in the menu
bar to check if the current software version is up to date.
If it is not the latest version, in the "Software Update" window, you can click the "Install Update"
button to update to the latest version. Alternatively, you can click "Skip this version" to skip the
update or click "Remind me later" to update at a later time.
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Appendix

KEPServerEX Software Project File Description

A brief explanation of creating a project file with KEPServerEX software used as an OPC Server.
1. Adding a Channel:
(1) In the tree view, right-click on the Connectivity node and select New Channel (or choose

Edit | Connectivity | New Channel).

(2) Select type of channel to be created from the drop-down list of available drivers. Select
Simulator driver.

(3) Click Next,enter the Channel name, all following settings are default until completed.
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2. Adding a Device:
(1) Right-click and select New Device or choose Edit | Connectivity | New Device.

(2) Enter the Device name, all following settings are default until completed.

3. Adding Tags:
Set the Tag according to the example content below:
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The project file for KEPServerEX software has been created.

4. View Data:
Click the QC button on the toolbar to check the data transmission results.


	1 Overview
	1.1 Software function
	1.2 Supported Operating Systems
	1.3 Supported Interfaces
	1.4 Revision History

	2 Installation and Activation
	2.1 Installation
	2.2 Activation

	3 Software User Manual
	3.1 Navigating the Configuration
	3.2 What is the OPC Groups
	3.2.1Group Properties
	3.2.2Link Item Properties

	3.3 What is the OPC DA to MQTT
	3.3.1MQTT Properties
	3.3.2Topic Properties
	3.3.3MQTT Item Properties

	3.4 How Do I...Configure OPC Groups
	3.4.1 Starting a New Project
	3.4.2 Adding a Group
	3.4.3 Adding a Link 
	3.4.4 Saving the Project

	3.5 How Do I...Configure OPC DA to MQTT
	3.5.1 Adding a MQTT
	3.5.2 Adding a Topic
	3.5.3 Adding a Link
	3.5.4 Saving the Project

	3.6 How Do I... Import and Export Links Using a CSV F
	3.7 Apply/Start/Stop/Restart Service
	3.8 Check for updates

	Appendix
	KEPServerEX Software Project File Description


