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Chapter 1 Overview of the DXMR90-X1

Banner's DXMRO0-X1 Series Controller consolidates data from multiple sources to provide local data processing as well as
accessibility for host systems as a platform for the Industrial Internet of Things (IlaT).

The DXMRS0-X1 contains four individual Modbus masters allowing for concurrent communication to up to four independent
networks. Data is collected into the internal logic controller to facilitate edge processing, protocol conversion to Industrial Eth-
ernet, and pushing information to web servers.

Overview of the DXMR20-X1 Series Controller

E-.:rnﬁgural:lhsl_h_h__H

Modbus Port O
{famalka)

ey Configurabla
i | —— Modbus Part 0
L= and Powar (maka)

¥ T D-codad Ethernat

Modbus Mastar (famale)

Parls 1-4—/

[famala)

One male M12 connection provides common power and ground to all M12 Modbus ports. The two-port 0 Modbus connec-
tions can be configured as pass-through wiring to connect to a Modbus trunk. One 100 Mbps Ethernet port (female) using an

M12 D-coded Ethernet connection.
* Modbus TCP
« EtherMNet/IP
» Profinet
« Configuration/discovery port

Four Modbus master connections using female M12 connectors.
« 2-wire R5-485 physical transceiver with power/ground at each connector
« Separate Modbus master control and programmability for each connection poirnt
« Independent and selectable baud rate and parity settings
« Individual timing and packet timing for each Modbus connection
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Logic Controller

Program the DXMRS0-X1"s logic controller using action rules and/or ScriptBasic or MicroPython programming lan-
guages, which can execute concurrently. The control functions allow freedom when creating custom sensing and contral

sequences. The logic controller supports the Modbus protocol standards for data management, ensuring seamless inte-
gration with existing automation systems. File password protection is an option.

Action Rules
« Thresholds (IFFTHEMW ELSE) with timers, minimum on/off ime
Math/Logic Rules (arithmetic and bitwise operators)
Control Logic (logical operators and SR/T/DAK flip flops)
Trending (multiple averaging filters)
Tracking (counts, onfoff imes)
Email notifications
Push data on conditions

Programming Language—ScriptBasic to create variables, arrays, functions, loops, IFRTHEMN/ELSE, logical and arithmetic
operators, APl commands, register access, string functions and operators, time commands

Scheduler

« Timelcalendar-based events
Holiday skips
One-time events
Dynamic scheduler updating
Astronomical clock

Push to the Cloud
Email

Register Mapping
« Cyclical Read rules from wireless devices or local wired Modbus devices that include optional scaling, error can-
ditions, and the ability to activate a read rule
= Cyclical or Change of State Write rules to local wired Modbus devices with scaling
« Modbus/TCP Master Read or Write rules for external devices on the network

Wired Connectivity

Ethernet: Modbus/TCP (master/'slave) or Ethernet|P
Field Bus: Modbus RS-485 Master/Slave

User Interface

API Interface—Host Initiated control and Web service integration

User-defined LED indicators—The DXMR90-X1 has six user-configurable LED indicators to indicate the status of
the DXMRO90-X1, processes, or equipment

Modbus registers for imernal local registers (Modbus D 199)

Local Reqisiars Ty Dascaan o

1-34s A2-4nnarag as Local dara saqiaers

AdE—34% 324 wreqg ar Reasar, CoSEnr, TuTler

451-500 240 Agaedlanla vitagas Dara 1ash, Aoa-ealanla

SOL-1000 Rasaryad for ineaal uge

LO01-2000 Floanag @cer Floanag oaar ragqeara g, local dara saqisees

SO0L- o000 324 wreqg ar Local dara reqigers

TOOL-3000 240 Agaedlanla vitagas Dara 1ash, Aoa-ealanla
= LO00D Read o ly viaudl reqisiecs, SysieTiHawel dara
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DXMR90-X1M odek

flodel Ef 212 o ABChined flodious MASE Coeld BCnas Oey SoAngminasg
One male M12 (Fort O) for incoming power and
One femake W12 D-Code Efemeat Four female 12 connections for { yieri 9
DM GO-2 1 tladious RE-4AS, ang tenala M12 o da gy ol -
Coagomos fdcd s Masier oA ach oS

11 Foet 0 9ga3ls,

H ardw are0 vervew O

The DAMRS0-X1 Series Controller can have multiple configurations. The DXMRI0-X1 will have a model number label on the
housing. Use the model number to identify which boards are included in the contraller.

Aubm atonProcoio kL

The DXMRS0-X1 Series Controller supports the following automation protocaols.

EtherMet/IP ™

By default, EtherMet/IP is disabled. Configure the DXMRS0-X1 Local Registers as EtherNet/IP input or output registers
using the DXM Configuration Software. A single register can only be set as either an EtherNet/IP input or output register.

EtherMNet/IP registers are limited to 228 registers set as E/IP Originator to DAM and 228 registers set as DXM to Origina-
tor

Modbus® RTU

The DXMR90-X1 manages five separate physical ports running the Modbus RTU protocol. The DXMR90-X1 is the Mod-
bus Master when operating the Modbus master RTU port (port 1-4). The DXMRE90-X1 uses the master Modbus RTU bus
to communicate with locally connected Modbus slave devices.

The other Modbus RTU part (part 0) is used by a host system to access the DXMR90-X1 a5 a slave device. The slave
Modbus RTU port allows access all the internal local registers concurrently with the master RTU port. Port 0 can be con-
figured as a Modbus Master Port using the DXM Configuration Software but is defined as a slave port by default.

Configure the port parameters using the DXM Configuration Software.
Modbus TCR/IP

A host system acting as a Modbus master (client) can access the DXMRS0-X1 using the Modbus TCP/IP protocol over
Ethernet. Standard Modbus TCP port 502 is used by the DXMR90-X1 for all Modbus TCP/IP requests.

Allinternal local registers are available to the host system concurrently with Modbus TCP.

By default, the DXMRS0-X1 is configured as a Modbus TCP/IP Server. To configure theDXMRS0-X1 as a Modbus TCP

Client, Modbus TCP must be enabled in the DXM Corfiguration Software and sockets must be defined to point
the DXMRO0-X1 to up to 5 Servers.

Jume 0, 2023 i& Banner Engmneenng Conp.



DXMBS0-X1 Series Controller Instruction Manual

PROFINET®

By default, PROFINET is disabled on the DXMRS0-X1 . To configure the DXMRS0-
A1 for PROFINET communications, PROFINET must be enabled using the DXM Configuration Software. The DXMR90-
A1 uses fixed Slot sizes and locations in the Local Registers for the Input and Output values.

Module sizes supported are 64, 128, 256, and 512 bytes which range from 32 to up to 256 Local Registers in
the DXMRS0-X1.

Modbus® is a registered trademark of Schneider Electric USA, Inc. PROFINET® is a registered trademark of PROFIBUS
MNutzerorganisation e V. EtherNet/IP™ is a trademark of ODVA, Inc. All other trademarks and registered trademarks cited are

the property af their respective owners.

M odbusO verview [

The DXMRS0-X1 Series Controller uses internal 32-bit registers to store information. The processor's internal Local Registers
serve as the main global poal of registers and are used as the commaon data exchange mechanism. External Modbus device
registers can be read into the Local Registers or written from the local data registers.

The DAXMRS0-X1, as a Modbus master device or slave device, exchanges data using the Local Registers. Modbus over Eth-
ernet (Modbus/TCP) uses the Local Registers as the accessible register data.

Using Action, Read/Write, and Threshold Rules allows you to manipulate the processor's Local Registers. The MicroPython
or ScriptBasic programming capabilities extends the use of Local Registers with variables to create a flexible programming

solution for more complex applications.

The processor's Local Registers are divided into three different types: integer, floating point, and non-volatile. When using Lo-
cal Registers internally, the user can store 32-bit numbers. Using Local Registers with external Modbus devices follows the
Modbus standard of a 16-bit holding register. Local Registers are accessible as Modbus 1D 199 when using ScriptBasic or

MicroPythan.

DAMRO0-X1 Modbus overview

ProcessoriOulputs (Base Boand)

"' Local Regishers ]
{Miodbus 1D 159 Ouitpists o dhis 10 203) Processor Conoled

Efamal o o [ lﬂﬂli "lﬂ:-ﬂ- J E Outpist (L EDs) j [ M 1a Mana ]
RE-425 (mastar] g9 o Traflbe: Sarlrl
Local Registers

RE54ES (slave] sm— |: Floal :

aral Hrashers
Riar-uid sl

M odbusR egsiersh

The DXMRS80-x1 Series Controller may have up to two internal Modbus slave addresses:
Intarnal Modbus slave 1Ds (Tactory delault)

todious Slave |0 D2 vice
153 Local Reqisiecs—arain 3l Siorage raisisg

203 LED widwzanzrsg

All Modbus registers are defined as 16-bit Modbus Holding Registers. The local register slave |D (199} is fixed for access via
ScriptBasic or MicroPython. When accessing the Local Registers through an external Modbus RTU Master, the Slave Port
(Port 0} slave ID can be changed using the DXM Configuration Software. Connected devices can use any Modbus Slave ID.
For a complete list of registers, see “Internal Local Registers (Slave ID 199)° on page 17.

Modbus registars for internal local registers (Modbus slave D 199)

Local Reqeeiees Ty Dagzaan iz
L-84% A2-mn e g Lozal dana maqisigss
45345 A2-aniAnger Rasa

Continuwed on page 9
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Continued from page 8

Local Raqiesg Ty Dascaanca
a5 1300 A2-nr Aca-walania wager Dara 1ash, Aoa-walanle
SO1- 1000 Rasayad Boareadl uge
100 L5000 Floanag goear FIoanaq piar reqesiaes, Iocal dard iaqisees
SO0 L-T000 A2-nnAagas Localdard saqigeeg
TOO L2000 32-or A ga-wolanle wnggas Dara 1ash, non-wolanle
= 10000 Raad -caly wiaudl aaq gars, SysraT-ayal dara,

Modbus ragisters tor the LCD board {Modbus slave 1D 203)

#odius Regiater LED Coloe Srare
2101 e LED 1 5eaan

2102 ;e O LED 2 Red

2103 bt 0 LED 2 ATt \ = om

2104w i LED 4 Ao o= o

2105 e LED = Red

2106 e LED & Graan

D 1h ensDnsL

All measurements are listed in millimeters, unless noted otherwise.

DXMRO0-X1 dimensions

163 mm, |
|0 Edn

--—
Omim | 20 mm i
T T
1217 i
| TG
2.3 mim
T g ! g
B3 5
= 3 i [ = 3 i
| IL2T {F = IL2T

205 i
4+_ ILen
=

L1
2 400 B ) .
hig——— 12 a1 Foimabs)
1022 MI1Z a1 ™ Lem
(el
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Chapter 2 Quick Start Guide

Apply Power to the Controller

Follow these instructions to apply 12-30 V DC power to the DXMRS0-X1 using a wall plug.
R equiedequipm ent

e DXMRO0D-X1 Series Controller
¢ PSW-24-1W aTiplig pow erfsupp ¥; 24V DC 1A prequivaknt24 VD C M 12/pow erfsupp )0

1. Connect the PSW-24-1 power supply to the male M12 connector on the DXMRS0-X1, Port 0.
2. Plug in the PSW-24-1 wall plug power supply.

Wiring

Parts 04 famale connactar

Fort O—d S-pan M 12 Coaasoor (famale) Fin Whea ol o Dascannoa
1l B i | 2w Do 20w DS
I Winre i RE435 ! OL' B +
a Blua {ru] Dz coememan {aM0]
d Black ok RE435 /DO A -
= Graw fgy] ror o sedivasanwad

CAUTION:

« Wiring devices incorrectly will cause electrical damage.
= Do not apply more than 12 volts on pins 2 or 4 for ports 1 through 4.

Part 0 make connactor

Fovt 2 dyma w112 Soanacior (mala) Fia Wahia Col o Dascaanca
1 Bl L2 0T many 0C
2 Winra i REAAS!OLIB Y 4
2 Blue fi ] DZ comemea (0]
4 Black fak) RE4AS DO ALY -
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D-codad industrial Etharnal connactor

g~ adu st al Erverasr Coaa e (eaae] Fin W Sl Di2scagnoa
1 Bl ack ok +Ta
2 Rad f{d] + R
3 Graan {ga] —Ta
E winna i —F

Configuration Instructions

DXM Configuration Software

Configure the DXMR90-X1 using the configuration software. Use this software to customize your configuration and to
process data from the Controller.

Download the latest version of all configuration saftware from http:/’www. bannerengineering.com. For more information on
using the DXM Configuration Software, refer to the instruction manual (p/n 209933).

Overview of the configuration software features

—— S S

DXM Configuration Software I
|
|
|

" Local Registers N

( Register Mapping)

( Action Rules )
( Scheduler ) |

. ( ScriptBasic > ). |

System Register |
Settings View Utility

|
| |
XML Gonfig —c
‘ File
|

- —_ —_ - -1

The configuration software creates an XML file that is transferred to the DXM using an Ethernet connection. The DXM can al-
50 receive the XML configuration file from a Web server using an Ethernet connection. This configuration file governs all as-
pects of the DXM operation. The DXM Configuration Software allows the user to define parameters for the DXMRI0-X1, then
saves the configuration in an XML file on the PC.

After the configuration file is saved, upload the XML configuration file to the DXMR90-X1 for operation.

i Banner Enginearing Conp. Jume O, 2023
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IMPORTANT:The DXMR90-X1 Series Contraller comes preloaded with a default configuration XML file.
You can download the default XML on the product page for the DXMRS0-X1.

This quick start guide outlines the basic operations to set up a DXMRS0-X1 using the configuration software. For a more
comprehensive explanation of features, refer to the DXM Configuration Software Instruction Manual (pin 209933),

Configuring the DXMRS0 Controller

This section will walk you through the method of setting up the DXM Configuration Software and communicating with a con-
nected DXM device. Version 4 of the DXM Configuration Software supports multiple DXM device models, each of which in-
corporates different features.

As soon as a DXM model is connected to your computer, the software automatically detects the correct model and loads the
appropriate screens. You may also manualy select which model of DXM you are configuring if you intend to create a configu-
ration file without connecting a device. This ensures that the interface and the configuration file use the correct features.

Mot all screens are available for all models. To change to another model of DXM, go to the Select Mode screen and use the
drop-down list to select anather model. If the active configuration is incompatible with the selected model, you will be prompt-
ed to either proceed and wipe out the active configuration or cancel the model change and preserve the configuration.

Opening splash screen for Traditional Setup mode
Fl TJaly [0 Hels m

Contqurason Moge: Tt Sato =

Lipcal IReisiars

Siae Fowbvoy o 000k

Fegrsbr Mg
L [*T1H Wi Sl i Fyu o ety

Sattrags -ﬂ"."-;f':

Toas
P gy | DODE b, [ r——

Salect DM Modal:  Dsesis

When the Select DXM Model drop-down is set to DXMRO0-X1, a new network discovery table is displayed. Click Scan Net-
work for DXMs to detect DXM devices on the host computer's network. Discovered DXMs are listed in the network discovery
table. Double-click any row entry to connect to that DXM. If the DXM's IP address is already known, the standard TCP con-
nection option is available below the network discovery table.

IMPORTANT :Any model of DXM may connect to the configuration software regardless of which device

model is selected in the configuration software. Compatibility is checked before configuration files are up-
loaded to the device.

Configuration Example: Reading Reqisters on a Modbus Slave Device

The local registers are the main global pool of registers that are defined by the user to store data within the DXM. The local
registers are listed on the Local Registers » Local Registers in Use screen.

The bottom status bar displays the communications status, application status, and the DXM Configuration Software version,

In this short example, we will configure the DXM to read six registers on an external Modbus server device and save the data
into the local registers.

The software only loads a file to the DXM. Internal parameter settings that are changed in the tool but not saved to the: file will
not be sent to the device.

Jume 0, 2023 i& Banner Engmneenng Conp.
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M odiyM ultpE R egBters:
Modify a range of registers from the Local Registers » Local Registers in Use » Modify Multiple Registers screen.
Select which parameter fields to modify. Most parameters have three selections.

¢ Unchanged- nochanges’

» Defulk- changebdefiultsettihgs

* Set modfyheparam eer/) herisekctonsiv lappearbasedonhe paran eter.

Modify Multiple Registers screen

Edil Ragiwier Mol ity Mullple Higelny

ey RN 1had  Ereeg Regate 1 Lm Moty Fngiiiats | sl Fam
PaTm |Unchanged | = | Counfer IJr\-l:"lul'l;-l\:lr - LCD permemiscrs JUncharged | =

Rt D | LAechanged | = | Scaing  Unoranged | = BD card Kggmg  Unchanged | = |

i |Lrscranged | = | g vpa Uromanged | = | CiaH S80S L |=| [Fesi

Pl o DTN UBORanagl | ¥ |

. Enter the Starting register and Ending register.

. Select the value to change using the drop-down list next to each value.
. Enter the new value in the field provided.

. To push register values to the web server, setCloud Settings to Read.

If the Cloud Settings are set to Read, the web server only views data from the device and cannot write data to the de-
vice. Ifthe permissions are set to Write, the web server only writes to the device and cannot read the data. If the per-
missions are set to Read\Write, the web server can read the data from the device and write to the device from the
weh,

5. Click Modify Registers to save and apply the changes.

Defmnelan RTU Read RukC

Follow these steps to create a new read rule. This example creates a read rule to read six registers (address 1 through ),
from Port 1 Modbus Slave 4. The results are stored in the Local Registers 1 through 6.

e e L

1. Define the Port settings to be compatible with the connected devices.
a. Go to the Register Mapping » RTU » RTU Configuration screen.

RTU Configuration screen

RTU Caonfiguration | REARFREEET Y RaARRR L

Dislay babwean
Eaudl rabe | 15G040 - Fanty |None b Timesout (hhcmm:ss. 1) Wﬂﬂﬂbm@ mesiages MWWHHE
L I L deic) (it i 55 11T

=0

. Go to the Register Mapping » RTU » RTU Configuration screen.

0

. Maodify the Port settings as needed.

Verify the Baud Rate and Parity match that of the connected Modbus slave devices.

The Timeout controls how long the DXMRS0-X1 waits before determining a command failed to send. Set
based on the specific application reguirements.

The Delay between messages defines the minimum wait time between resending another command. Set
based on the specific application reguirements.

. Fram the Register Mapping » RTU » RTU Read screen, click Add Read Rule.

. Click the arrow next to the name to display the parameters.

. Name your rule.

. Select the Port number to which the device is connected.

Select the Modbus 1D of the device.

Select how many registers to read, and the beginning register.

Define the register type, how often to read the register, and any other appropriate parameters.

+

*

*

e~ Bt B oWk
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9. If necessary, select the error condition. For this example, if the read function fails after three attempts, the read rule
writes 12345 to the DXM local registers. Notice the list of local register names this read rule is using.

Read Rules - Configuration Example
7 [

RTU Configuraton QTR BT ke

AddFeed Fuds | Dons Seleced Pl | Debeie Selacind Fuls [ ||
E- Yorm Pat| 1 | = | Feam sk 1D qilmw :-iilmpmumm'qi |l|'rmqn B Iblecal rspEba §Lafng @l 1£nmm:-
Fosiielogs ]
RAemole o Haidng segiler | = ':::b“”"iz'_
Frisguis R0 s _::'"‘Fmi
— ool vaige  DOOOMOE] Sl oPani (37 e
T Ay ot Balir Scili vishea
Lz umdton Ay vl 1:.'“:.! L Jﬁumruum
I lzabry el | ] mmiap weids
L reggier n'esl
Baud Rate Parity
D efned foriboth(the ™ odbusm aserandshve D efhed forboththe M odbusm asterand shvel
Settings include: 19200 (default), 1200, 2400, 9600, 38400, Setthgs hckde ;N onel(de fau )/ odd Jeven [space Jand i ark(
57600 Jand(115200 .0 ,
Timeout
Delay between messages AppltesiotheM odbusm asterport!
Applesinthe M odbus m asterport) Covers the expectad time for messages o be sent throughout
Setsfthem hium waitie efos thelend ofaM odbustrans- thew Tebssinetw ok [Forthe D XM /e Timeout pamas eterisl
actonothelbeg hnnglofthehext™ odbustransacton them axmum [am ountofte ethe D XM should watafleraire-
quest is sam untd the response message i recaived fram the
M odbusshve devie.
Set the Time

Use the Settings » System screen to define the time zone and daylight saving option. The time zone and DST options are
saved into the configuration file.

Settings = System = Device Time

Cumrent device lime -~

| Gal time from devica | I Synch PC lima wilh devica

Device timezone (UTC) UTC (UTC+D000) JE.d
Device observes DST [

1. Go to the Settings » System screen.

2. ITyou connect the DXM to a computer, click Sync PC Time with Device to set the time on the DXM to malch the time
of the computer.

3. Set your time zone and select whether or not your device observes daylight saving time (DST).

SettheP Addressl
Follow these instructions to change the DXMR90-X1's IP address.

By de fiukthe DXMRI0-X1MEsetina statc P laddressof192 168.0.1.The P laddresscan becthanged byusing the D XM
Configuration Software Landupda tihgthe XM L 0

1. Launch the DXM Configuration Software.
2. Go to the Settings » Ethernet screen.
3. In the |P Address section, select Static IP or DHCP from the drop-down list.
* |f Static IP is selected, enter the IP address, Subnet, and Gateway address as desired.

* |f DHCP is selected, the IP address, Subnet, and Gateway address are grayed out and not configurable.
Changing the IP Address to DHCP can make it so the DXM cannat be reached. Before changing this
to DHCP, you MUST have a server that is going to assign an IP Address to the DAXMRES0-X1,
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4. Save your changes to the configuration file (File » Save).
5. Upload the configuration file to your controller (DXM » Send Configuration to DXM).

Save and Upload the Configuration File
After making any changes to the configuration, you must save the configuration files to your computer, then upload it to the
device.

Changes to the XML file are not automatically saved. Save your configuration file before exiting the tool and before sending
the XM L flefbthedevieiniavo il bshgdata Hyouse bctDXM » Send XML Configuration to DXMbefbresavihg thecon-
fyuratbnfike, he sofiv arelw llprom ptyoufoichoose bew eensavig dhe fikorcon thungw thoutsavihgdhefile.

1. Save the XML configuration file to your hard drive by going to the File » Save As menu.
2. Go to the DXM » Send XML Configuration to DxXM menu.

Status indicator bar

* If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in
the cable and reconnect the DXM to the software.

* Ifthe Application Status indicator is green, the file upload is complete.
* [fthe Application Status indicator is gray and the green status bar is in motion, the file transfer is in progress.
After the file transfer is complete, the device reboots and begins running the new configuration.

M echantalhstalhtonD

Install the DXMRB0-X1 to allow access for functional checks, maintenance, and service or replacement. Do notinstall
the DXMRI0-X1 in such a way to allow for intentional defeat.

Fasteners must be of sufficient strength to guard against breakage. The use of permanent fasteners or locking hardware is
recommended to prevent the loosening or displacement of the device. The mounting hole (4.5 mm) in the DAMRS0-X1 ac-
cepts M4 (#8) hardware. See the figure below to help in determining the minimum screw length.

16.0 mm
I mm*
NUT 4 N
for minirmum
Screw Length = 16.0 mm + “X" mm + 3 mm engagement of
three threads

CAUTION: Do not overtighten the DXMRS0-X1's mounting screw during installation. Overtightening can
affect the performance of the DXMRS0-X1,
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Chapter 3 Controller Connections

C-.:Inﬁgural:lha_h_ﬁqﬂ

Modbus Port 0
(famala)

P, Configurabla
f | —— Modbus Part 0
= and Powar (maka)

- D-coded Etharnat

Modbus Mastar (famale)

Pars 1-4—/

{famala)

E themett

Before applying power to the DXMRS0-X1 verify the Ethernet cable is connected.

The Ethernet connection supports the DXM Cornfiguration Software, Modbus/TCP, PROFINET, and EtherNet/IP. ScriptBasic
also has access to Ethernet for custom programming. Use the software to configure the characteristics of the Ethernet con-
nection, including the |P address. Any parameters not changeable from the menu system are configurable from the configura-
tion software.

Internal Local Registers (Slave ID 199)

The main storage elements for the DXMRI0-X1 are its Local Registers, which can store 4-byte values that result from regis-
ter mapping, action rules, MicroPythan, or ScriptBasic commands.

Local Registers updated from Modbus transactions are restricted to a16-bit data value to follow standard Modbus Holding
Register definition.

The Local Registers defined in Action Rules must all be within the same register group. For example, an Action Rule cannot
have inputs from an integer group with the result register defined as a floating point register. To move between integers and

floats, use the Register Copy Rule.

Modbus registars for internal local registers (Modbus slave ID 199)

Local Reqisiess Ty D500 o
L3445 A2-anneges Lowzal d ara, maqismass
Ad =345 A= e giae RBasal
A3 15300 32-mr Aca-walanla negar Dara 1ash, Aca-wolanha
TO1- 1000 Resarvad Braremnal use
100 1—=000 Floanag gt Floanag g saqesrees, local dara raqisiaes
SO0 1-TO00 A2-anineges Lowzal d ara, reqrsiaes
TOO 1-A.000 32-ar Aca-walanla negar Dara 1ash, Aca-wolanha

Continued on page 18
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Contnuwed from page 17
Local Reqrsiees T Descagn o

= oo Read-caly vutudl maqeagess, sysiaT-Heyal dara

Local Registers 1-B45 and 50017000 (Internal Processar Memaory, 32-bit, Unsigned)—The Local Registers are the main
global pool of registers. Local Registers are used as basic storage registers and as the common data exchange mechanism.
External Modbus device registers can be read into the Local Registers or written from the Local Registers. The DXMRO0-X1,
as a Modbus master device or a Modbus slave device, exchanges data using the Local Registers. Modbus over Ethernet
(Modbus/TCP) uses the Local Registers as the accessible register data

Local Registers B46-849 (Reset, Unsigned)—These Local registers are reserved for use as Reset registers. A time interval
can be specified in the configuration software for the DXM to reset. If the data in the register does not change within the user-
specified time interval, the DXM resets.

Local Registers B51-900 and 7001-8000 (Data Flash, Non-valatile, 32-bit, Unsigned)—The top 50 Local Registers are spe-
cial non-volatile registers. The registers can store constants or calibration type data that must be maintained when power is
turned off. This register data is stored in a data flash component that has a limited write capability of 100,000 cycles, so these
registers should not be used as common memaory registers that change frequently.

Local Registers 1001-5000—These Local Registers are paired together to store a 32-hbit |IEEE floating point format number in
big endian format. Registers 1001 [31:16), 1002 [15:0] store the first floating point value; registers 1003, 1004 store the sec-
ond floating point number. There are a total of 2000 floating point values; they are addressed as two 16-bit pieces to accom-
modate the Modbus protocol. Use these registers when reading/writing external devices that require Modbus registers in
floating point format. Since Modbus transactions are 16-bits, the protocol requires two registers to form a 32-bit flaating point
number.

Virtual Registers—The DXMRO0-X1 has a small pool of virtual registers that show internal variables of the main processor,
Some register values will be dependent upon the configuration settings of the DXMRS90-X1. Do not use Read Rules to move
Virtual Local Registers data into Local Registers. Use the Action Rule > Register Copy function to move Virtual Local Regis-
ters into Local Registers space (1-850).

Modbus ragistars for virlual registars

ReqEag Diaheliticn
1oool GFE lanude dwvacnoa i, 5 E, W]
Loog 2 GF S lantude
GFE Coordwane Dara fme DXs g oo igurad o eaad a0 axeaaal G FS o,
Looo3 GFE loaguude dwacnoa (], & E W
LooGd GF 5 longiude
10011-10012 Rgyal [nmay EAguaanag usa
10013~ 100 14 Riagyl [neTlay F ol a s EAgQuaanag usa
100 13— 100 LS Reooor cau 58 (Resad Codas anoya) Rigtonor Ty
1001710013 Warchdog resar ool COuATR: 10 [FAK NoW Many r8sars hane baen cavsad Dy mea Warchdog
o0 25— 1002 Hro Fus EEL Aoquieas
Statstical counts of connecions, disconnections and forced disconnecis when
1OQ2AT=10023 Hmp Fus1 S50 Relaasas
e ma DEEREN0-E 1 crearas 3 conascnod using SELUTLS (Encryaiad Coanacno 5]
o0 25— 10030 Hmgo Fus S50 Foroad Ralaazsas
1003l-10032 Hmp Fus1 Araqons
1003310034 Hio Fugh & Statstical counts of connectons, disconnedtions and forced diEconnects when the
e HECeSses OXf connanllar Crganes A oo A2cnod usig HTTF acn-ancayprad
10035 10035 Hmp Fust Faluas
Last DEMRSO-E 1 qogh sragus
O = lnal srare, Ao push e Tl as hishad war
100 3T— 10033 Hro Fush Last Sams N - = ' ¥
1 = ArreTipl coemplans
2 = AreTor anoaed
LoCas=10025 AlAATIS, ST, ANSTIS Emnail amemars

Continued on page 19
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Reqiesg Dtz
LOCS T—100sa3 Alasms, s, tals Emanl tarluras
10100 Mumoas ot raad magsa dataulr
1ol rumisas ot read Magp successes
o2 rumioes ot e ad Magn meaurs Read mlap Sransnes
1ol rumisas ot read Magp 8mes
Louod Read Map suooess sraalk
Lo Mo mioes of wale Map guocegsas
LOLoE Mo mioe s of wale Magn mecurs
Ware hlag sransncs
o Pl Tioe s Of Ware Magn 8ses
1oua WAl Mag Sulcess Saak
Loues rlumioes of pa s Thedugh guooesses
oL Mo mioes of (A g tug T oS
AF 1message (a5 Stansnes

10111 Mumipe s of pasaivough aates
iz Fassrnaough guocess Jeaal
Luoo Read Map SuC02Es Coual
L2000 WAl Man SuCCess Coual
Lacog Read Mao nTeour Couat
Ldoon WAL (T30 DeTIRC UL 204 AL
Laoon Read Map aeoe ooual Raad fring Mags Fansncg
LEoOD WAL (T3 B e 20|
LToog Read Map suooess Sraal
Lacon WAl Mag Sulcess Saak
Laoon Read mag s dafaulr

TCP Client Stats—The "x" represents the socket O through 4. The flex socket is not used. This range repeats for the next
socket.

TCP chant statistics

Reqisiar Dehainon
23001 E0oCMEl 3 oo ecnon aETIEns (20001 5 e Iem socker, 20001 8 e sacond sochar. .
23003 EOCMEl 3 Coea2Ccnns
2300 Eockar 1 disoon Aacnon
23007 Eocdal 3 Wans s
2E00E Eockar 3 sacaiyes
2a0LL Sk 1 rasolyer amadans (rasanved |
21013 Eochar 1 sasolvars (rasaread]

LIS A0 Resarved

2a021 Sockal 3 Rulg O r#aAasqirs
2a02a Sockel i Rulg O racsiyas
2025 Sockal i Rule O oimeours
2a0AT Soohar d Rule O ovoadoass

Continued on page 20
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Raqisnar Oahaimaa
23025 Rasayad
2x031 Sochal i Rul2 1 reaasdns
2x033 Sochal i Rul2 1 racayas
2x035 Sochal i Rul2 1 nmasurs
2I0aT Sockar i Rule 1 ioegadoasis
23035 Rasayad

Reset Codes—The reset codes are in virtual register 11015 and define the condition of the last restart operation.

Reasat codas

Rasar Coda Datmnda
o Uadethaad
1 L1 bix1 a1
2 Saaasal
3 B.iotae1 2t
E] WAz diog
) =y
& Sommane
T Rawr ¥ aackog moda

Connecting to Remote Modbus Devices

The DEMRS0-X1 is configured with four independent Modbus Master Ports, all ports use a 4-pin M12 female connector to
connect to remote devices. No additional wiring is required if the sensors use compatible wiring.

Ports 04 famale connactor

Fout O—4 2 w112 Soanamor fhamala) Fia Whea Soloe Dascapnca
1 Betir i ] 12w DS o 30w OS
2 Winra ] RE435 ! OLMB ! 4
k| Blue fi ] D comemiea (0]
e Black fak] RE4A5 /DO ALY -
E Graw (vl rod wsadivasasyed

M odbusM asterands hvePorsl

The DXMRES0-X1 can be a Modbus RTU master device to other slave devices and can be a Modbus slave device to another
Modbus RTU master. The DXM uses the ports 1-4 as Modbus RTU master ports to contral external slave devices. All wired
devices connected to the master R5-485 port must be slave devices.
« As a Modbus RTU master device, the DXMRS0-X1 controls external slaves connected to ports 1-4
« As a Modbus RTU slave device, the DXMRO0-X1 |ocal registers can be read from or written to by another Modbus
RTU master device via port 0.

The Modbus RTU slave connection, port 0, is controlled by another Modbus master device that is not the DXKMRS0-X1. The
slave port is used by an external Modbus master device that will access the DXMRS0-X1 as a Modbus slave Device. Use the
DX¥M Configuration Software to define the operational settings for both the Modbus RTU master ports 1-4 and the Modbus

RTU slave port 0.
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SetteM asterrand S hvePortParam eters(|

The basic communications parameters for the RS-485 ports are set in the DXM Configuration Software and are saved in the
XML configuration file. Each port can have unigue settings such as a unigue baud rate, parity, timeout, and delays between
messages.

RTU Configuration screen for ports 0-4

[FITU Configuratan | BELENEZCe=Tal RE4ENRS it

UART Bussis
= Calary bebweon =
Baud rafe | 15200 - FI‘I'I'.IIH:ﬂl - Timaoar i mm 55 0T mmmmg MEsEales mmmuﬁﬂlﬂ
LT e —— [ mimss i)
Peet 2
Caslary Ddfvaan
Baud rate | 19200 | =|  Pasiy |Mene - THmaoul (8 mm 55T mwmm% SRS mmmm@
(s PR g AT
Porl 3
Baud rafe | 19200 Parity | Mon Timaows i fmy mmn&uﬂna WMWHE
¢ = ] - mim £5 MEssaids
L = ( | - o -
Porl d
= Detay betwaan -
Hﬂuﬂr.ﬂl'l 19200 1=y Party | Mona r Timaois = mm s 1T mmmuﬂng Massegds {I:IIHI{I:II]EUE
e (T i e, A7)

1. Define the Port settings to be compatible with the connected devices.
a. Go to the Register Mapping » RTU »RTU Configuration screen.

RTU Configuration screen

RTU Configuraton | RRIRMEZCSTE REELR 10

LWAHT Buzes

Port 1

Dwday betwaen
hﬂrﬂ:ﬂl 153100 | F'i'l\'ll'ﬂi !'- Timieoiat ikl mmss T IZH]D'IJ{E-IZI]]E Mas5agRE D'I]I]'EIIII}I]'EI]E
{hih e 55 1)

b. Go to the Register Mapping » RTU » RTU Configuration screen.
c. Modify the Port settings as needed.

* Verify the Baud Rate and Parity match that of the connected Modbus slave devices.
* The Timeout controls how long the DXMR90-X1 waits before determining & command failed to send. Set
based on the specific application reguirements.

* The Delay between messages defines the minimum wait ime between resending another command. Set
based on the specific application reguirements.

2. To set the Modbus Slave parameters for Port 0, go to Settings » System » Slave Port 0 Settings.

3. Modify the Baud Rate, Parity, and change the Internal Slave |1D. (For a description of the parameters, see "Define an
RTU Read Rule "on page 14))

The Internal Slave 1D is the Modbus ID that an external Modbus Master will access to read'write to the local registers
on the DXMRO0-X1.
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Slave Port 0 Settings

Mokificatons ogging § Scripling | Adrmmisiration

Cyrrani davice Bme ———

Baud rale 19200 1= Parity |Fione [l
ntemal Slave 10 of&] | =ET

| et nme iom device | | Sync PG ime wilh device

Dswvice Smezone (UTC) |UTC (UTC-00-00} x

i& Banner Engmneenng Conp. Jume 06, 2023



DXMBS0-X1 Series Controller Instruction Manual

Chapter Contents

E e o L s LT = T | RS OPRPSSPRE 23
T L T T PPN 24
O TR TH [ LWL en LT un L0 R DL L L LT = 24
T [ L L I e = e 7 24

Chapter 4 Working with Modbus Devices

The DAMRS0-X1 has five physical RS-485 connections using Modbus RTU protocal.

The master Modbus RS5-485 ports are for the DXMR90-X1 to act as a Modbus master device to control external Modbus
slave devices.

The Modbus master R5-485 ports are labeled Port 1-4. The Modbus slave portis used when another Modbus master device
wants to communicate with the DXMR90-X1 when the DXMRO0-X1 is a Modbus slave device.

The Modbus slave RS-485 port is labeled Port 0.

DXMRO0-X1 system overview

ProcessoriOutputs (Base Board]
- Local Registers i
(Mot 1D 193] Dhafputs o dbiss 1D 203 Frocessor Coninolad

%nmn-:: . [ Lnnll Hlﬂrllrl. j E Outpust (LEDs) :) [ -:-“H'-l-g n.TJfI ]
RE-485{master] « — o W_} 1l ool
[ =t T e S — Float
IE Al Resl 2hers }
kbir-ulr de Hl4

. A

The DXMRS0-X1 has dual Modbus roles: a Modbus slave device and a Modbus master device. These run as separate
processes.

The Modbus slave port can only access the DXMRI0-X1 local registers. To operate as a Modbus slave device, the DXMRS0-
X1 needs to be assigned a unique Modbus slave ID as it pertains to the host Modbus network. This slave 1D is separate from
the internal Modbus slave 1Ds the DXMRS0-X1 uses for its own Modbus network. The DXM Modbus slave ID and other Mod-
bus slave port parameters are defined by using the configuration software.

The DXMRS0-X1 operates the Modbus master ports. Each device on a master port must be assigned a unique slave ID.
There are slave 1Ds that are reserved for internal devices in the DXMR90-X1. Each device that shares a master port must
have a unigue |D. Devices on separate ports may have the same |D.

Intarnal Madbus slavea (D (Tactory datault)

Modioos Slaye |0 Dawvice
155 Local Reqrsees—Inred al Ssiocage cagqeeies

03 LED wdhzanaes

AssgnngM odbusS hveD sO

Assign the DXM Modbus Slave ID only if a Modbus master device is reading or writing the DXM Local Register data through
the Modbus RS-485 slave port 0.

To set the Modbus Slave parameters for Port 0, go to Settings » System » Slave Port 0 settings. Here you can modify

the Baud Rate, Parity, and change the Internal Slave |D, The Internal Slave |D is the Modbus 1D that an external Modbus
Master accesses 1o readiwrite to the local registers on the DXMRI0-X1.
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DXM Master Configuration—When the DXM operates as a Modbus master device, use the configuration software to config-
ure read or write operations of the DXM Modbus network. The DXM communicates with all internal and external peripheral
devices using the external Modbus bus RS-485 port(s).

M odbusiO peratbnC

All Modbus transactions are managed by a central Modbus engine.

If there are Modbus messages intended for a Modbus slave that doesn't exist, the Modbus engine waits for a response until
the timeout period is expired. This slows down the Modbus polling loop for read and write operations. Each Master port is
running its own modbus engine; timeouts on one port will not affect the other ports.

Verify all Modbus read and write operations are intended for Modbus slave devices that are in the network.

M odbusC om m untTatonTin eouts’

A Modbus timeout is the amount of time a Modbus slave is given to return an acknowledgment of a message sent by the
Modbus master. If the Modbus master waits for the timeout period and no response is seen, the Modbus master considers it
a lost message and continues an to the next operation.

The timeout parameter is simple to set for Modbus devices directly connected to the DXMR90-X1. Special considerations
need to be made to set the timeout parameter when the DXMRO0-X1 is communicating to an external Modbus device
through a serial data radio. In general, longer timeouts may be required to ensure the data is sent and received.

Configure cantrollers operating wireless networks to allow for enough time for hardware transmission retries. Set the Commu-
nications Timeout parameter to cover the expected time for messages to be sent throughout the wireless network. For

the DXMRS0-X1, the Communications Timeout parameter is the maximum amount of time the DXMR90-X1 should wait after
a request is sent until the response message is received from the Modbus slave device. Use the DXM Configuration Saft-
ware 1o set the timeout parameter on the Register Mapping » RTU » RTU Configuration screen.

The default setting for the timeout parameter is 5 seconds.

M odbusTCP [C Tent

The DXMRO0-X1 can operate as a Modbus TCP client on Ethernet. Users may define up to five socket connections for Mod-
bus TCP server devices to read Modbus register data over Ethernet. Use the DXM Configuration Software to define and con-
figure Modbus TCP client communications with ather Modbus TCP servers.
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Chapter 5 Confguratonhstructonsr

Scheduler

Use the Scheduler screens to create a calendar schedule for local register changes, including defining the days of the week,
start time, stop time, and register values.

Schedules are stored in the XML corfiguration file, which is loaded to the DXMRS0-X1, Reboot the DXMRS0-X1 to activate a
new schedule.

If power is cycled to the DXMRS0-X1 in the middle of a schedule, the DXMRS0-X1 Jooks at all events scheduled that day and
processes the last event before the current time.

For screens that contain tables with rows, click on any row to select it. Then click Clone or Delete to copy/paste or remove
that row.

CreakeaW eeklyEvent]

Use the Scheduler » Weekly Events screen to define weekly events.

Scheduler = Weekly Events screen
| A VWeukty Evest | | Clone Lint Ewert| | Datnt Lt Evpet|

regee: EICS vow aowens QO D QO == 1 @ zveom

Slarl Walse 10 snar (Seecm Teme | = | | 2200 24 howr tormat

O] Gmavweioe | o[5]Bram (Soechc Tme | = | | 0001 5] 24 howr tpimat

1. Click Add Weekly Event,
A new schedule rule is created.

2. Click on the arrow to the left of the new rule to expand the parameters into view.
The user-defined parameters are displayed.

. Name your new rule.

. Enter the local register.

. Select the days of the week this rule applies to.

. Enter the starting value for the local register.

. Use the drop-down list to select the type of Start at time: a specific ime or a relative time.
. Enter the starting time.

. Enter the end time and end value for the local register.

[ s T I e 2 R o R A
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Register updates can be changed up to two times per day for each rule. Each rule can be set for any number of days in the
week by cickingihe butons™ [T, W [Th/F /S jorSull

Fworegiterchangesaredefhed Hraday, defhethe starttn e o bebebretheend th e [SekctEnd Value benablethe
second event in a 24 hour period. To span across two days (crossing the midnight boundary), set the start value in the first
day/w fhoutsekctngEnd Value [Usedhe nhextday bcreakhefnalregitershae

Start and end times can be specified relative to sunrise and sunset, or setto a specific time within a 24 hour period. When
ushgsunrie orisunsetitm es sethel PS toordhates onthe devie So tcana bub e Sunrseand sunsetl

Createa ne-Th e Event

Define one-time events to update registers at any time within a calendar year.

S oW eeklyievents theti esicanbespeciftiorie htve o sunrieorsunset D efinebne-th e eventsiushgtheSched-
uler » One Time Events(screen [

Scheduwlear > One Time Evants screan

Aot One-Tesa wrd | | Clorw Lawt vert| | Dotiete Lt Evert

[=) [Soecial Gake [egeter ot 21[8] None St 1 a1 ODGE0TE DWWRG) End 0 ai 021018 DUSKTI0
eart Vi 1H] Statan |Relabwe Tme| =] | Tusstey, February 19, 20090 ~|  t100fl HHmn (Betoe | =| (Sunsse | =
(W Endvaie OfH Endat [FetatveTene|=|  Tussdry Febeeary 19 019 »| | 12000 Himm Mer | =| [Sumet | =

1. Click on Add One Time Event.
A new one-time event is created.

2. Click on the arrow to expand the parameters into view.
The user-defined parameters are displayed.

. Name your ane-time event by clicking on the name link and entering a name.
. Enter the local register.

. Enter the starting time, date, and starting value for the local register.

. Enter the ending time, date, and ending value for the local register.

oy tn I W

CreatelaHoldayEvent

Use the Scheduler s Holidays screen to create date and/or time ranges that interrupt weekly events.

Scheduler > Holidays screen

hukl Hobdry | | Clors Seleched Holdury | | Deledn Seleched Holday |

P H A Tosewsary, Fasiuary 19, 2018, 0000 [§] = Tussday, Fabruany 19, 219, 03031 f] = |

1. Click on Add Holiday.
A new rule is created.

2. Enter a name your new holiday rule.
3. Select the start date and time for the new holiday.
4. Select the stop date and time for the new holiday.

Authentication Setup

The DXMRO0-X1 has three different areas that can be configured to require a login and password authentication.
* Webserver/ Cloud Services Authentication
= Mail Server Authentication
= DM Configuration Authentication

The webserver and mail server authentication depends upon the service provider.
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SetteControTerbbuseAuthentatonl

The DXMRS0-X1 can be configured to send login and password credentials for every HTTP packet sent to the webserver,
This provides another layer of security for the webserver data.

C onfhuratbnrequ res’bothihew ebserveriand the D XMRA0-X1 o begiventhe sam e credenta kibrithe bghnand password [
The webserver authentication username and password are not stored in the XML configuration file and must be stored in

the D XMRED0-X1 [
1. Fram within the DXM Configuration Software, go to the Settings » Cloud Services screen.

2. In the upper right, select Show advanced settings.
3. Define the username and password in the Web Server Authentication section of the screen.

Web Server Authentication screen

‘Wabsermer Aulhenticalon

USernamss

Fasswond:

‘Send Aulhenlicaton

The first time you select Require Authentication, a pop-up box appears with additional instructions. Since the data is
not stored in the XML configuration file, it is hidden from view of the DXM Configuration Software.

4. Click on Send Authentication.
The controller must be connected to the PC for this operation to succeed.
The data transmits directly to the DXMR90-X1's non-volatile memory. If successful, a pop-up window appears, asking
to reboot the device.,

5. Select Yes to reboot the device.

SetteW ebS ervites/ bl selAuthentcaton(

1. Atthe Banner Cloud Data Services website, go to Settings » Sites,
2. To edit the site settings, clickEdit on the line of the site name.

Settings = Sites screen of the Banner CDS website

ROOF SOLAR TEST: 142ce0d T-08 T 8-4a30.b TcS-cOab i 553817

Efle Name  ROOF SOLAR TEET
She Type | oMl =

Sie ID 142 raddT -0 T E-4a30- b T 5 EabOatgaary

¥ | [Rool_Solaraml - 02262018 12:0 m

A ]
Browse.., M T Bt fed
e | !
Authentcaton | O

ALD-Configurne O

Al the bottom of the pop-up window is a checkbox to enable authenticationfvalidation.

3. Enter the same username and password as used in the DXM Configuration Software. The username and password
do not need to be a defined user within the Banner Cloud Data Services website.

ContoTerConfguraton/Authentiaton(

The DXMRS0-X1 can be programmed to allow changes to the configuration files only with proper authentication by setting up
a password on the Settings » Administration screen in the DXM Configuration Software.

With the DXMRS0-X1 connected to the PC, click Get Device Status, The DXMRO0-X1 status displays next to the button.
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Settings > Administration screen

Uindrgsr
Dot gcdrmn guyened
dooan ST s mereed

e gl g ieeed

Al Py (I CFET

LD s 1

LrarsoE wraneg

Use the DXM Configuration Software to:
= Sel the Admin Password
= Change the Admin Password
* Remove the Admin Password

To change or remove an admin password, the current password must be supplied. The DXMRS0-X1 must be connected to
the PC to change the administration password.

Register Flow and Configuration

The DXMRO0-X1 register data flow goes through the Local Registers, which are data storage elements that reside within the
processor. Using the configuration software, the controller can be programmed to move register data from the Local Register
pool to remote devices or the /O base.

Register flow

| Procassar |'H‘
Etharnail

B astT/ApproachiioC onfguraton(

When programming an application in the DXMR90-X1, first plan the overall data structure of the Local Registers. The Local
Registers are the main storage elements in the DXMR30-X1. Everything goes into ar out of the Local Registers.

Local
Reogistors

1’0 Baza

Ramota Davicas

1. In the DXM Configuration Software, name the Local Registers to provide the beginning structure of the application.

2. Configure the read/write rules to move the data. The Read/\Write rules are simple rules that move data between de-
vices (Nodes, Modbus servers, sensors, elc) and the Local Registers.

3. Most applications require the ability to manipulate the Local Register data, not just move data around. Use the Action
rules to make decisions or transform the data after the data is in the Local Registers. Action rules can apply many dif-
ferent functions to the Local Register data, including conditional statements, math operations, copy operations, or
trending.

4. To perform scheduled events in Local Registers, go to the Scheduler screen in the DXM Configuration Software.
These rules provide the ability to create register events by days of the week. The scheduler can also create events
based on sunrise or sunset.

TroubkshoothgaConfguratonl

View Local Registers using the Local Registers » Local Registers in Use screen of the configuration software.

When a configuration is running on the DXMRS0-X1, viewing the Local Registers can help you to understand the
application’s operation. This utility can also access data from remote devices and the LED registers.
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SavihgandLoadhg Confguraton(F ksl

The DXM Configuration Software saves its configuration information in a XML file. Use the File menu to Save or Load config-
uration files.

Save the configuration file before attempting to upload the configuration to the DXMRES0-X1, The DXM Configuration Soft-
ware uploads the configuration file saved on the PC to the DXMR90-X1; itwill not send the configuration loaded in the toal.

UpbadigorDownbadhgConfguraton(F ks

The DXMRS0-X1 requires a XML configuration file to become operational. To upload or download configuration files, connect
a computer to the DXMRO0-X1 using the Ethernet port. Then use the Upload Configuration to Device or Download Configura-
tion from Device under the Device menu.

EtheMetPP™ Confguraton

The DXMRS0-X1 can be configured to send/receive local register data to and from an EtherNet/IP™'" hpst. EDS (Electronic
Data Sheet) files allow users of the EtherNet/|P pratocol to easily add a Banner DXM device to the PLC. Download the EDS

files from the Banner website.

= DXM EDS Configuration File (for PLCs) (p/n b 4205242)
« DXM EIP Config File for DXM Controller with Internal Gateway (Models: DXM1xx-BxR1, DXM1xx-BxR3, and
DXMLxx-BxCxR1) (pin 194730)

ConfgurhgiheHostPLCL

On the host PLC, install the DXMR90-X1 using an EDS file or by using the following parameters:
= Assemblyl: Originator to DXM = Instance 112, 456 byles (228 words)
= Assembly2: DXM to Originator = Instance 100, 456 bytes (228 words)

The Originator is the host PLC system, and the DXM is the DXMR90-X1. The host system sees the DXMRO0-X1 as a generic
device with the product name of Banner DXM (ProdType: 43 - Generic Device, ProdMame: Banner DXM, Integer Type -
INT).

IMPORTANT :Do not set the Requested Packet Interval (RPI) any faster than 150 ms.

ConfgurhgtheContoTer

Use the configuration software to define the Protocol conversion for each local register to be EIP Originator » DXM ar EIP
DXM : Originator from the Edit Register or Modify Multiple Register screens.

Define a DXM local register as EIP Originator » DXM when the host PLC (Originator) will send data to the DXMR90-X1 local
register (DXM).

Define a DXM local register as EIP DXM » Originator when that register data will be sent from the DXMR90-X1 (DXM) to the
host PLC (Originator).

Data from an EIP contraller in assembly instance 112 is data destined for the DXMR90-X1 local registers. The PLC is normal-
ly configured for INT or UINT data transfer. This allows for a seamless transfer of data.

EIP Assembly Instance 112 (16-bit) DXM Local Registers
Adrs Data Adrs Data
0 1122 1 1122
1 3344 2 3344
2 abbb 3 obbh
3 7788 4 7788

Continued on page 30

(1 EtterhetIP ia a trademark of Rockwell Aulomation.
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Continued from page 29
EIP Assembly Instance 112 (16-bit) DXM Local Registers

4 9500 2 9900

Data from the DXMR90-X1 local registers is sentto the EIP controller using assembly instance 100. Each local register in
the DXMRS0-X1 defined as EIP DXM » Originator is collected in numerical order and placed into the data buffer destined for
assembly instance 100. DXM local registers are capable of 32-bits, but only the lower 2-bytes (16-bits) for each local register
are transferred.

EIP Assembly Instance 100 (16-hit) DXM Local Registers
Adrs Data Adrs Data
0 1122 11 1122
1 3344 12 3344
P abbb 13 abbhb
3 788 14 /788
4 9900 15 9900

Set up the Email

The DXMRO0-X1 can be configured to send email messages based on threshold conditions.
Ethernet-connected systems can only use email, but can send email to cellular phones as a SMS message depending upon

the hew okl camreri T osendem aflioaV erfron phone Jusehephonenum berbbwedbyfivte xt . com,Hriexam -
plk,1234567890@vtext . com [

Forim oreCnom aton [re®erfinthe DXM Confguraton Softwarehstucton™ anuallph209933). Follow these instructions
andusetheDXM Configuration Software fo(program thetontroTerBriem aill

1. On the Settings » System screen, set the Device Time on the DXMRI0-X1,

2. On the Settings » Cloud Services screen, select Ethernet for the Push Interface,

3. Configure your Ethernet connection by setting the IP settings on the Ethernet screen,
4. Set the email and message parameters on the Motifications screen,

5. To send alert messages, define the threshold rule to use email.

M ailServertAuthentcaton(

Complete the mail server settings to have the DXMR30-X1 send email alert messages.

The SMTP password is stored in the DXMR30-X1, nat the XML configuration file. Use the Settings » Motifications screen to
complete this configuration.

i Banner Enginearing Conp. Jume O, 2023
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Mail server settings

Mail Sarver Sathings

SMTP server | smtpmail visi.com |
SMTP server port 587
& Mo encryption

i Situational encryption

[x] Enable SMTP authentication

User name | device@sensono com

Password sxdamail|

| Send SMTP Password |

After selecting Enable SMTP Authentication for the first time, a pop-up box appears with additional instructions to complete
the mail server authentication process.

After entering the user name and password, click on Send SMTP Password to save the user name and password to
the DXMRO0-X1. The DXMRI0-X1 must be connected to the PC to complete this operation. If successful, a pop-up window
appears, asking to reboot the device. Select Yes to reboot the device.

D efhelthe N eworkhterfaceSetthgsl

On the Cloud Services screen, define the network connection settings by selecting HTTP Cloud Push to send data to Banner
CDS or AWS loT Core Push to send data to AWS loT Core.

If you don't reguire pushing data to a web server, set the Cloud Push interval to zero.

Cloud Services screen
[ i Bovafiss b

CE . _
_.,_..mpmp“h Servai niem ) I | puih Baeneicdh ton AN Thing Endpasin
Punh masitaed
() ANS. 9T Cave Fige Jpesh aspe
Cr—
| | Galesay D& |GUID - Poxt Bk 54
C0apdl s el ] - | —
IEI e R i Rl R ] Priml debeg messsoes T Beftsl Consoi
Puillh pachsl taimal Dt = |
[ Aoty scae and ofaet s purs oo E .
= | Cuslom HTTP Headers
Saspie ceust e O el | | pr—— —
Pl B ush Oyt 4 | |
(5] E i Include XML GLID in s pesh il b Fild [Seeat |
Ermaimid spivrs pET pish fmersad EE ] inciete sonal nUMDE N pushes
—y Figal TA Fie !:.IMI
] Print: puss: gelsug messages Ip senal consoie L Wi WS AufBEn N pudhid e
U L st coll conseclion quality in peihas
N || o posh fusunes i g
[]use HFTFSE - |
| [0 R Autaribcitnas |

Usemane

Farkiannd

S Aasmonba a0

Confgure yourE themetC onnectbnl

To send email based on a threshold rule, first define the network and email servers. When selecting Ethernet, go to the Set-
tings s Ethernet screen.

1. To define the Ethernet IP address, give the DEMRS0-X1 a static IP address. In most cases you may select the device
ta use DHCP and have the |P address automatically assigned.
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2. DNS seftings are not typically required. The DXMR90-X1 uses a public service to resolve Domain names, but if the

network connection does not have Internet access, the DMS settings may be required.

System § Cloud Services MNolifications | Logging § Scripting

Settings > Ethernet screen

Administration

B Current Dewice IP

[¥] Show advanced settings

i| IP Address 0000 DHCP -
!| Subnet 0.0.0.0
! IF address
{| Gafeway address 0000
|| Device MAC 00:00:00:00:00:00 | | 00!
Galeway address

Gel Seitngs from DE'.n-cl_='|

IP Address

H LUDF Console

[ Enable UDP console Primary DNS IP address

N

Secondary DNS IP address

Elhernel DNS

0000

0,000

[[] Enable Profinet

SetteEm ailParam etersl

From the Settings » Motifications screen, enter the SMTP definition, login, and password for a mail server.

To send email, you must supply the SMTP Server, Server Port, and login credentials.

The default SMTP port is 25 but may need to be adjusted for Ethernet-based networks. Note that many facilities block port
25. Port 587 is another common SMTP submission port.

The SMTP password is not stored in the XML configuration file, but on the DXMRE90-X1. After the password is entered, click

on Send SMTP Password to send it to the DXMR90-X1. The password is stored in non-volatile memory, so reboot

the DXMRS0-X1 to recognize the new password.

When using a GMail server, select Situational encryption and Enable SMTP authentication. GMail may notify you that you
must allow access for less secure apps in your email settings.

For other email servers, the parameters may vary and will require information from the provider.

£ Banner Engnearing Conp.
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Email settings
fuaisomszomngs ———— Wewatroopes |
SMTP sens ¥ E-mai Racipssni 1 ASdrgsE
SMTP sahis poel 250 ¢ [E-mail Racipant 2 BB
(&) My aniryplon » E-mail Racipani § AURETRLE
i) Sihmhional encrypeon ¥ E-mail Facipesnl 4 Auldrgss

¥ E-mail Recipsnt 5 ASIrgss
v E-mai Racipsnt 6 ASIress
¢ E-mail Racipsgnt T ACETESS

[ Enfpie SMTP siranbcation

e » E-mail Recipent s Addness
| Send SMTP Passeornd * E-mail Racipant § ASdrass
v E-'mail Aecipeent 10 Address

At the bottom of the screen, define the recipient to receive emails. These recipients selected in the threshold definition for
sending alert messages.

D efheThreshodRuksorEm aill
To define a threshold, go toLocal Registers » Action Rules » Threshaolds.

Depending upon which recipients are defined, select the appropriate email or SMS checkbox for the threshold rule [un-
der Email/SMS on state transition). When the threshold rules goes active or inactive, an email is generated.

For more information on how to set up threshold rules, refer to the DXM Configuration Software Instruction Manual (p/
n 200933).

Push Retries

Ethernet—The DXMRS0-X1 can be configured to send register data packets to a webserver. When the Ethernet communica-
tions path is not operating, the DXMRI0-X1 retries the send procedure. With an Ethernet-based network connection,

the DXMRE0-X1 retries a message five times. The five retry attempts immediately follow each other. After all attempts are ex-
hausted, the register data packetis lost. At the next scheduled time, the DXMRO0-X1 attempts to send only the new data.
Any past data that the DXMR90 was unable to push is lost and cannot be recovered. Using SSL on Ethernet will have no re-
tries.

Event/Action—Event-based pushes caused by Action rules sent using email follow the same process when failures occur,
based on the network connection.

Email—There are no retries for emails that fail to be sent from the DXMRS0-X1,
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Chapter Contents

General Station Description Markup LANGUALE FIE ..o ettt e et et e s s e s s s s s e e e s s s b s s s st s s s s st e s eb s s e s e s st s s asaar e s s e ae s e e e eenanes A5
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Lot L = T B s PSP 12

Chapter 6 PROFINET®

PROFIMNET is a data communications pratocal for industrial automation and processes. PROFINET 10 defines how con-

trollers (1O controllers) and peripheral devices (10 devices) exchange data in real-time. PROFINET® is a registered trade-
mark of PROFIBUS Nutzerorganisation e V. and the standard is maintained by PROFIBUS & PROFINET International (P1)

an arganization headquartered in Karlsruhe, Germany.
Cnly the DXMRO90, DXM700, DXM1000, and DXM1200 Controller models support PROFINET 10.

G eneralS tatonD escrptonM arkuplLanguage(F el

A PROFINET General Station Description (GSD) file is a description of an 10 device provided by the device manufacturer in
an XML format (GSDML.xml).

The GSD file is a standardized way of describing the device information to engineering tools and the 1O contraller and can
work acraoss a variety of tools as a standard set of device information.

DXMPROFNETD DataM odel

The PROFINET IO data model is based on the typical, expandable field device that has a backplane with slots. Modules
have different functionalities.

Modules are plugged into slots. In the PROFINET 1O data model, Skot 0, Subslot 1 is reserved for the Device Access Point
(DAP) or network interface.

ConfguretheD XM ContollerorialPRO FINETD [C onnectbnl

To use PROFINET, follow these instructions.

1. Using the DXM Configuration Software, go to the Settings » Ethernet screen.

2. Select Enable PROFINET,

3. Save the configuration file and upload it to the DXM Controller (see "Save and Upload the Configuration File® on page
16).
After PROFINET is enabled, the |P address for the DXM Controller is controlled by the PROFINET host.

The PROFIMNET data type and data size to/from the DXM Controller is configurable. The PROFINET dala is processed from
the LocalR egserofheDXM Contoler)

Configure the 10-Link ports in the XML according to the modules selected for each paort.

Save and Upload the Configuration File

After making any changes to the configuration, you must save the configuration files to your computer, then upload it to the
device.

Changes to the XML file are not automatically saved. Save your configuration file before exiting the tool and before sending
the XM L fiefothe devieiofavodl bshgdata Jyouse bctDXM » Send XML Configuration to DXMbe bre’saving e con-
fguratibn fike, hesofiv arew illprom ptyoubichoose bew eensavigthe fik orfcon thuhgw ihoutsavihgthe fike .

1. Save the XML configuration file to your hard drive by going to the File » Save As menu.
2. Goto the DXM » Send XML Configuration to DXM menu.
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Status indicator bar

Cormesied 102 18801

BGLTEED.

Corrmcies

Bl e e

* If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in

the cable and reconnect the DXM to the software.

* [fthe Application Status indicator is green, the file upload is complete.

* [fthe Application Status indicator is gray and the green status bar is in motion, the file transfer is in progress.

After the file transfer is complete, the device reboots and begins running the new configuration.

SbtsandM oduksdrDXM PROFNET

There are ten slots to accommodate the DXM Controller data.

Slats for input and output valuas

Waluasg
kMun walues 1440 as

Curpur valueg Lddd onwas

Skot 1 - Input (DXM --> PLC)

Modubs [0 Submaodule ID Al [T Size (yiea)
Banmner 10-Link
ol 4 iy Master Info ]

wazumuq DAar3, Saze

RegiEter Stan

1 3
& ]

123 123

Direction

It is important to note that the module placed in slot 2 corresponds to Port 1; the module placed in slot 3 corresponds to Port

2, the module placed in slot 4 corresponds to port 3. etc.

For the DXMRO90-4K 10-Link Master device, slots 6 through 9 are unused.

If the 10-Link InfOut process data modules (all except digital input and output) are used, the attached 10-Link device must
have PDI and PDO size less than or equal to the number of data bytes allowed in the module. Data transfers will not be ap-
plied otherwise. For example, plugging in the 16/16 byte module to a slot corresponding to a device that has 22 bytes of PDO
resulls in an error. Process data sent from the PLC to DXM will not be applied.

Slots 2-9 (1 par 10dink port)

Size
Module ID Submodule (D bl o b
{oyiea)

ag
LS Qa0 2Ll | 2o 2032 Byle 4+ Srams

q45

a0
Crids Qaol 2Lk b 2ur LELE Byta + Sramws

an
Crad T Qaol 2Lk 1 fourdfd Bye + Srarus 12

w0
w506
w5
n851
w0
w5
w5
n851

w01

Continued on page 37

Regaier Star

£ Banner Engnearing Conp.

Register End

=017
®507
LTy
»850
nO0d
Elir
®05D
»850

x005

Directon

B2z 3)

Bidivacmiza al

Bidivacmiza al
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Contnued from page 36

Module 1D Submodube 1D Modube WTE; Regisier Stan Register End Directon
x506 x507
%51 x055
22
1. | *HED
x001 x003
a
x506 x507
Crida Q=L 2Lk W fourdid By + Srarus Bdwamia a3l
%51 x053
13
1. | *EED
x001 x02
=}
x506 x507
Crads Q=L 2Lk four 202 Byia + Srarus Bdwamia a3l
%51 x052
15
1. | *HED
x001 x02
=
x506 x507
Cricdh, Q=L 2Lk four AL Byra + Srarus Bdwamia a3l
%51 x052
1%
1. | *HED
%51 x051
1. | x851
CrdB Q=L Chgreal Curor = Culpul Madula
xA53 x853
xAESR *8E8
i x001 x001
x5 x0&1
r 00l Dugecal 1ot x851 851 B v 3l
d
xAE3 x8E3
xA58 *850
Slhot 10 (1S0)
Module ID Submodule D b osdu be Size (byles) Regiater Start Regiater End Direction
196 351 442
ixaD i ISDU 190 Byl + Status
196 200 F41
Bid mectional
a6 i51 K1
=4 E i g | 50U A2 Bwe + Srams
86 200 245
Ezamale Sondgqueanoa
o bodube Deacription
Slot 1 Banner |0-Link Master Info :::-:h:-f IO, Deviaa 10, Mumsar ot Soppatad Shaaaal s, 3ad Fiewacs Vaesso 1115 Ta-
Slot 2 IO -Link IOt 32/32 Byte + Status Getizend 10-Link PDIFDO for 10-Lnk device on Port 1 with PD Size betwesn 17 and
A2 byles
Slot 3 K3-Link In/Out 1618 Byle + Status Get/zend 10-Link FDIFDO for 10-Lnk device on Port 2 with FD Size betwesn 9 and
16 byles
Siot 4 IO -Link IOl 22 Byte + Status Getisend [O-Link FDIFDO for 1I0-Link device on Port 3 with PD Size between 1 and 2

byles
Continued on page 38
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Siot Module
Slot 5 Digital Output

Slot 10 120U 190 Byte + Status

Contnuwed from page 37

Ezamae Coatgqueanoa

Uze S0 Output mode on Port 4

Degcription

IS DU readiwrnite access for all porls 0 0-Link mode

Confguratonhstuctonsh

InstallthelGSD Fil

Although these instructions are specific for the Siemens TIA Portal (v14) software, you may use these instructions as a basis

far installing the GSD file into another contraller.

1. Download the GSD file from www bannerengineering. com.
2. Launch the Siemens TIA Portal (v14) software.

3. Click Open existing project.
4. Select a project and open it

5. After the project is uploaded, click Devices & networks.

6. Click Configure netwaorks.

Devices and networks screen

First sleps

ITotalky

£ Banner Engnearing Conp.

Canfigers a device

Write PLC progeam

Canbigurs
it hivsdingy oljects

Conligene an HW scoeen

Oipeni the project view

Progact: DM Prodinet DA0 120207 vas operad successlully. Pease select the nes
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Configure networks screen
o

Devices &

natworks *‘5‘
r‘ﬂ#

# Show all devices

.' Configure networks

-
-
#

.--""f

-~

7. Click Options and select Manage general station description file (GSD).
The Install general station decription file window opens.

8. Click the More options (...} icon to the right of the Source path field and browse to the location the DXM GSD file was
downloaded to.

9. Select the DXM GSD file.
10. Click Install,

Hardware catalog

Options I:",I_'Eill
=l
2
'-*|£atalng g
“Seanchs |!|||,[ |||T' E
M Filter  Profile: [ <Al =] | E
b :’ Power supply and distnbution i: ':
+ i Field devices
- :! Other field devices |
» L@l Additional Ethernet devices §
w [ PROFINET IO =
b 1§ Controllers E:-
b :;. Drives s
b _j Encoders P
b _;. Gateway =
~ o L f_{
+ _l Balluff GmbH i
« i Banner Engineering Corp. 3
v Ll Banner &
w [ DXM Series I
m 1-port Device E

The system installs the DXM GSD file and places itin the Hardware catalog. In the example, the DXM GSD file is lo-
cated under Other field devices » PROFINET 10 » Banner Engineering Corp. » Banner.

Hthe D XM (G SDfikdoes nothstaTiproperly  savethe bgand tontactB annerE ngheering Comp.[
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ChangeltheD evielP Address(
Follow these instructions to change the |P address of the DXM device using the Siemens TIA Portal (v14) software. Use
these instructions as a basis if you are using another controller (PLC).

1. Launch the Siemens TIA Portal (v14) software.
. Click Open existing project.

2
3. Select a project and open it.
4. Click Devices & networks.

Metwark view

The Network view displays.

5. Double-click an the DXM icon to open the Device view screen.

6. Click on the DXM icon in the graphic area of the Device view screen.
The Module properties window displays and the module can now be configured.

7. Click Properties.
8. Click General.

9. Select PROFIMET Interface » Ethernet addresses.

Ethernet addresses

durn [1-port Davics]

10. Select Set IP address in the project.
11. Enter the |P address.
12. Right-click on the device icon and select Online & diagnostics.

i& Banner Engmneenng Conp. Jume 06, 2023
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15.
16.

17.
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Online & diagnostics menu and screen

[ Device configuranen

Write I0-Device name to Micno Memaony Card

¥ cut
¥§ Copy
Tu Paste

W Delete

T

Cirl+X
Crrl 4
Cirl+y

Dl
F2

Disconnect frorm DP master system [ 10 system

fell Highlight DF master system | 10 sy tem

2 Go to topolegy view

Compile

Dowmnload to device
& Gocnline
l:' E e
LY Cnlee & dagnastic:
= Assign device name

The Online & diagnostics windows displays.

Select Assign IP address under Functions,

Click Accessible devices.
The Select device window searches the network for available devices.

Click Assign IP address to complete the step.
This step is completed for every device.

Carl+X

d = Disgnestics
Diagnosbic thatus
Channel dugnu;l:u::
F PROFINET interface
= Funchong
Assign IF address
Assign FROFINET device na...
Rezetto mctory settings

Determine the device to be adjusted via the MAC address and select it.

Click Apply.
The IP address for the device is updated.

By defiutjeach DXM shppedfon the factory Elassgnedthe P (address 192 168 01 11

Immediately after the PROFIMNET protocol is enabled, the DXM has an IP address of 0.0.0.0. We recommend using the TIA
Portal to give the DXM an IP address so that the address is saved in the unit. When the PLC powers up, this |P address is

accessb’e. TheP LC canichangethe P (address itk con fgured bidoso .

If the PLC assigns the DXM IP address (for example, using the Set IP address in the project option in Siemens T1A Portal),
the DXM receives the specified address, but only after the program has been loaded into the PLC and is running. If the DXM
5 restarted after it was discovered and configured by the PLC, the DXM retains the |P address that was assigned to it using
the L C D (orf sofiw are untilafierhe P LC [dscovers he DXM (and assgnsiitthe spec fed address/aga n.H ow ever,/ifthsad-
dresssd ferenthan v hatsspecifed mthe PLC [the D XM (teversiothe address specifiednthe P LC afierthe PLC (be-

com esactivelagan [

Theseconfhuratbnoptbnsiconform Mothe PROFINET stndard O
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Change(theD evielNam e[

Follow these instructions to change the name of the DXM using the Siemens TIA Portal (v14) software. Use these instruc-
tions as a basis if you are using another contraller (PLC).

1. Open a project and click on Devices & networks,
The Metwork view displays.

2. Right-click on the DXM icon and select Assign device name,
The Assign PROFINET device name window displays. The software searches for devices of the same type.

3. Enter the desired name in the FROFINET device name field. Note that each name can be used only once.
4. Click Assign name.
The device now has a PROFINET name.

i Banner Enginearing Conp. Jume O, 2023
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Chapter Contents

Chapter 7 Accessoresforrhe D XM R 90X 1

FPower Supplies

FS0-24-4—DC Power Supply, Desktop style, 3.9 A, 24 v DC, Class 2, 4-pin M12/Euro-style quick disconnect (QD)
FSDIMP-24-06—DC power supply, 0.63 Amps, 24 V DC, with DIN Rail Mount, Class | Division 2 (Groups A, B, C, D) Rat-
ed

PEDIMNP-24-13 —DC power supply, 1.3 Amps, 24 V DC, with DIN Rail Mount, Class | Division 2 (Groups A, B, C, D) Ral-
ed

PEDIMNP-24-25 — DC power supply, 2.5 Amps, 24 V DC, with DIN Rail Mount, Class | Division 2 (Groups A, B, C, D) Rat-
ed

PSW-24-1—DC power supply with multi-blade wall plug, 100-240 V AC 50/60 Hz input, 24 vV DC 1 A output, UL Listed
Class 2, 4-pin female M12 connector

PSWE-24-1—DC power supply with multi-blade wall plug,100-240 V AC 50/60 Hz input, 24 V DC 1 A output, UL Listed
Class 2, barrel jack connector

SMBRIOS 8.8 B
=
= Sranlezs sraal beackar
= datd-07 pamaurs (B] -]
= khdudes 2x M4 sraaless seal ey head socews and far washers 74 A
-
Hole center spacing: & = 42, B = 20 %
|~
Heode size: & = 2% - 24
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e Laagri Eryla Cvmeasizag Finour [Famala)
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':h - L = Baowe
% 2 = ‘Whra
3 = Blua
d = Black

Jume 0, 2023 i Banner Enginearing Conp.



DXMBS0-X1 Series Controller Instruction Manual

Ly [aTel=
WMODECALOLES
MO DE C-a0388
MO DE C-A0858
WQDEC LLES
WODEC4 2055

WIQDEC4 A0S

WQDECS0ES

MODEC-A03RE
MODEC-a08RE
MODEC-412RE
WM DECALIO0RE

MODEC-430RE

MODEC-A50RS

MODECA0IRR
MODEC-a0eRR

MODEC-A12RR

MODECAZ0RR

Mgl
MODC1-501.5
MODC1-503
MODC 1 -5068
MODC1-515
MODC1-530
MODC1-560
MO 1 -51 00
MODC1-506RA
MODC1-51 5RA

MODC1-530RA

MODC1-550RA

Leagri
.21 m {1 T
.31 M {239 %)
133 m {E 1)
165 m (12 %]
6.10 M {20 1]

2.14 M {30.2 %)

132 M (d43.3 %)

.31 M {235 %)
1.33 m i& 1)
1E6mM (12 1]
6.10 M {20 1]

2.14 m (30.2 %)

132 M (d43.3 %)

0.3 M (2.3 11
Lam {351

16m{11af)

6.1 M (20 T

Laagen
0.5 M (LS 1
0.2 M (2.5 17
Imiest)

2 mil64 1)
M 2351
13 M (23 ]
1M (LOL.T H)
imiest)

% m {164 1)

M (235 1)

13 M (62.2 1]

4-Fa Tareaded w112 Covdsars—Douda Eaded

Ernyla Dhmaasigas

tlale Sreagin ! Fa-

mala Sreagic -I—1I I‘EE|
[~

mim B

MZa 1

a14.5[0EF]

T

oo

flale Rigac-dagla |
Famala Sreangar

Male Right-Anghe |
Famale Rugh-A0-
gle

2P Threaded W12 Covdsars—Saiagle Eaded

Eryla Onmaasicas
£ o i
S angir r [ﬂ
M1ZEx 1
a 14.54
ST
I
— I Tup
Figrr-gagle 11127

12 x 1 —}=—a]
2145 [057H

£ Banner Engnearing Conp.

Fracur

Famale

fale

J

Fiicur (Famale

Jume O, A3



DXMBES0-X1 Series Controller Instruction Manual

doma Wl D-oode o R4S Snaldad Ermamar

fald ! Laage Eryla Cnmaasioag Fracur {nala)
STPF-M12 0406 1Al miE 1]
STPRLA0-4 15 457 ML 1)
~ L = Whiatvaange
RI45 4
2 = Qvange
A = Whama/Blua
o 5 = Blua
Ercan g:.-": I-— 4.4 ]_'-F-.—ll-
2 1
STPF-M1L20-4.30 214 M {20 )
MI2 % 1.0- 6 3 4

ald 5
1 = wWinaf2range
= Wihama/Blua
3= Dvange
d = Blua

June 09, 203 & Banner Engineaning Corp.






DXMBS0-X1 Series Controller Instruction Manual
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Spacifications for tha DXMREA0-XT s
Fila System and Archive Process e
Update Your DXEM Processar Firmsvare Using the Configuraton Saltware
AN Euppun_ F'u||t_|,r ...............................................................................
L= L g T

Chapter 8

Product Support and Maintenance

Specifications for the DXMR90-X1

Supply Voltagse
12V DCio 30 vV DC

Supply Protaction Circuitry
Protected against revarsa polarity and transiant valtagas

Powar Consumpfion
120 mA maximum at 12V DG

Construction
Coannactor Body: PVYC transhucant black

Indicatars
Ambear: Pawar part 0
Ambar: Modbus communications por 0-4
Greanfambar: Ethematl communications
Red/ambarigraan: Usar-configurabla LEDs
Connactons
Fivaintegral 5-pin M12 famale quick disconnact
Ona integral 4-pin M12 malke quick disconnact
Onaintegral 5-pin M12 famale D-Coda quick disconnact

Application Nala

When cammactng extamal devicas through the DXMRES0-X1, 11
i5 important not to excaad maximum currant imitations of 3.5
Amps

Carifications

Banner Enginaaring &Y
Park Lana, Culliganlaan 2F bus 3
1831 Dimgam , BELGIM

Raquirad Ovarcurrant Protaction

WARNIMG: Electrical connections must
be made by qualified parsonnel in ac-
cordance with local and national alactri-
cal codas and lEg.ll-ﬂitll‘lE.

Oharcurrant protaction is required 1o be provded by end prod-
uct applcaton per the supplied table.,

Owarcurrant protaction may ba provided with axtarnal fusing
ar via Currant Limiting, Class 2 Powar Supply.

June 09, 203

Communication Hardwara (R5-485)
Intarfaca: 2-wira hal-duplax R5-485

Baud rates: 1.2K, 24K, 9.6k, 19.2k (default), 38.4k, 57.6K, ar
115 2K

Data format: 8 data bits, no parity, 1 stap bit

Communication Protocols

Modbus® RTU, Modbus/TCP,EtharNel/IP™,
and PROFINETE

EtherMet/IP™ iz a rademark of ODVA, Inc. ModbusE s 5 reg-
islarad tradamark of Schnaidar Elactric USA,

Inc. PROFINETE® is a registered trademark of PROFIBUS
Mutzararganisation a.Vv.

Securly Protocals
TLS, 55L, HTTPS

Ermviranmantal Ratings
Far Indoor Usa Onky
IPES, IPET, MEMA 1, UL Type 1

Wibraton and Mechanmical Shock

Measats |[EC 60068-2-6 raquiramants (Vibration: 10 Hz o 55
Hz, 1.0mm amplituda, 5 minulas swaap, 30 minutas dwall)

Meels |IEC 60068-2-27 requirameants (Shock: 300G 11 ms dura-
tion, half sina wava)

Oparating Conditions
—40 *C 1o +70 *C {—40 *F ta +158 *F)
Q0% at +70 "C maximum relativa humidity (non-condansing)

Staraga Teamparatura
—40 *C 1o +80 *C (—40 *F ta +176 *F)

l IK 7L e Bene LTD BIer 4 douge
0 enlsine Sonl

Winkfend, Meaom G511 4%
REAT BRITAl

{CEUKCA approval anly applies to 2.4 GHz modals)

Supply wiring kads = 24 AWG shall not ba splicad.

Far additional product suppart, go
1o waww . bannaranginaaring.com |

?.:E::: Raguirad Owarcurmnt ?.:I':::; Rsquirad Crarcurant
(ANG) Pmtacian (&) (AWGE) Prataciion (&)

20 5.0 24 110

22 30 28 08

Cantinued an page 48
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Cartinuad fram paga 47

Supply Reguirad Cwamswrant Supply Reagquimd Overcurrant
3:.:1?' Prateciion &) :ILT'.‘E-?l Protacian {A)
24 110 3a 05
FCCPartl5C hss/AL

This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to part 15 of the
FCC Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is
operated in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not

installed and used in accordance with the instruction manual, may cause harmful interference to radio communications. Op-
eration of this equipment in a residential area is likely to cause harmful interference in which case the user will be required to

correct the interference at his own expense.

IhdustyC anadaStatem entiorhientonalRadabrsh
This device contains licence-exempt transmitters(s)/receiver(s) that comply with Innovation, Science and Economic Develop-
ment Canada's licence-exempt RS5(s). Operation is subject to the following two conditions:

1. This device may not cause interference.
2. This device must accept any interference, including interference that may cause undesired operation of the device.

Cet appareil contient des émetteurs/récepteurs exemptés de licence conformes a la norme Innovation, Sciences, et
Developpement economigue Canada. L'exploitation est autorisée aux deux conditions suivantes:
1. L'appareil ne doit pas produire de brouillage.
2. L'utilisateur de 'appareil doit accepter tout brouillage radioglectrique subi, méme si le brouillage est susceptible d'en
compromettre le fonctionnement.

FikeS ystem @andA rchivelP rocessh

The DXM file system is in a serial EEPROM that stores non-volatile configuration information. The serial EEPROM slores ba-
sic data that is required to be non-volatile, including network configuration data, |P address, MAC address, network masks,

firewall settings, and authentication information.

The controller XML configuration file created by the DXM Configuration Software is stored in EEPROM. The small section of
nor-volatile local registers is also stored in EEPROM.

U pdateYourD XM [P rocessoriFim w arelU shgthelConfgura-
tonSofvarer

To update your processor firmware using the DXM Configuration Software, follow these instructions.

1. Using the DXM Configuration Software version 4 or later, connect to the DXMRS0-X1 via Ethernet.
File loads to the DXMRI0-X1 will take several minutes.
2. On the DXM Configuration Software, go to Tools » Reprogram » Get Device Information to verify the current firmware

version.
You must load a different version with the same firmware number for the bootloader to operate. Download firmware

files from the Banner website.

Example Device Information screen; every device's information will be different

T —— W] vl AR OO palDy kg Coakpasng DM
Pracesso teemaven
Sarial b
Meslsl rurmibssr

Furrams e

L

3. Under Tools » Reprogram, click Upload bootloader file to select the firmware file to program.

i Banner Enginearing Conp. Jume O, 2023
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A fierhefikelbad % com peted | rebootthedevie byse BcthgDXM » Reboot DXM .

Toverily e fim warelhas beenupdated | gooTools » Reprogram » Get Device Information and veriy e new ersbns!
are listed.

D XM SupportPolcyD

The DXM Wireless Controllers are industrial wireless controllers that facilitate Industrial Internet of Things (10T} applications.
As a communications gateway, it interfaces local serial ports, local VO ports, and local ISM radio devices to the Internet using
either a cellular connection or a wired Ethernet network connection. In a continuing effort to provide the best operation for

the DXM, stay connected with Banner Engineering Corp to hear about the latest updates through the Banner website. Create
a login today to stay informed of all Banner product releases.

Fim warelUpdatesl

The DXM has been designed to be a robust and secure 10T device. To provide the most reliable and secure device possible,
periodic firmware updates are released to enhance and expand the capabilities of the DXM. Firmware updates and descrip-
tion details are found on the Banner website. Customers with critical update requirements will get access to pre-released
firmware from the factory.

W ebsielform atonl

The Banner website is the main method of disseminating DXM information to customers. The data found on the website in-
clude:

= DXM instruction manuals

= Configuration manuals

« Firmware downloads

» Firmware release noles

= Errata data, any known issues with a release of firmware

= Possible work-around solutions for known issues

« DXM Solutions Guides

FeatureR equestsl

Owr customer is our most valuable resource to improve our DXM. If you have suggestions for improvements to the DXM or
configuration toals, please contact Banner Engineering Corp.

PotentalD XM Esues(]

Potential issues with the DXM are collected from Banner's support engineers to provide solutions. Users can get help from
the website documentation or by calling Banner Engineering for support help. Solutions are as simple as configuration adjust-

ments, work-around configuration solutions, or potential new firmware updates.

D XM (S ecuriy(

The DXM was designed to collect local wireless sensor data, local sensor data, provide simple control, and send the data to
the cloud.

The DXM does not run a Linux or Windows based operating system but an embedded real-time aperating system (RTOS)
environment. As a proprietary operating system, the security aspects are easier to manage and minimize.

Security updates are released through the Banner Engineering Corp website (www.bannerengineering.com) and New Prod-
uct Release Announcements (NPRA),

Jume 0, 2023 i& Banner Engmneenng Conp.
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Warnings

WARNING:

+ Do not use this device for personnel protection

« Using this device for personnel protection could result in serious injury or death.

= This device does not include the self-checking redundant circuitry necessary to allow its use in
personnel safety applications. A device failure or malfunction can cause either an energized (on)

or de-energized (off) output condition.

IMPORTANT :Please download the complete DXMRS0-X1 Series Controller technical documentation,
available in multiple languages, from www.bannerengineering.com for details on the proper use, applica-
tions, Warnings, and installation instructions of this device.

IMPORTANT :Por favor descargue desde www.bannerengineering.com toda la documentacion técnica de
los DXMRO0-X1 Series Controller, disponibles en mdltiples idiomas, para detalles del uso adecuado, apli-
caciones, advertencias, y las instrucciones de instalacion de estos dispositivos.

IMPORTANT \euillez télécharger la documentation technigue compléte des DXMRO0-X1 Series Con-
troller sur notre site www. bannerengineering.com pour les détails sur leur utilisation correcte, les applica-
tions, les notes de securiteé et les instructions de montage.

Install and properly ground a qualified surge suppressor when installing a remote antenna system. Remote antenna configu-
rations installed without surge suppressors invalidate the manufacturer's warranty. Keep the ground wire as short as possible
and make all ground connections to a single-point ground system to ensure no ground loops are created. Mo surge suppres-
sor can absorb all lightning strikes,; do not touch the Sure Cross® device or any equipment connected to the Sure Cross de-
vice during a thunderstorm.

Exporting Sure Cross® Radios. It is our intent to fully comply with all national and regional regulations regarding radio fre-
guency emissions. Customers who want to re-export this product to a country other than that to which it was sold must en-
sure the device is approved in the destination country. The Sure Cross wireless products were certified for use in these coun-
tries using the antenna that ships with the product. When using other antennas, verify you are not exceeding the transmit
power levels allowed by local governing agencies. This device has been designed to operate with the antennas listed on
Banner Engineering's website and having a maximum gain af 9 dBm. Antennas not included in this list or having a gain
greater than 9 dBm are strictly prohibited for use with this device. The required antenna impedance is 50 ohms. To reduce
potential radio interference to other users, the antenna type and its gain should be so chosen such that the equivalent
isotropically radiated power (EIRP) is not more than that permitted for successful communication. Consult with Banner Engi-
neering Corp. if the destination country is not on this list.

IMPORTANT:
= Mever operate a 1 Watt radio without connecting an antenna
« Operating 1 Watt radios without an antenna connected will damage the radio circuitry.
= To avoid damaging the radio circuitry, never apply power to a Sure Cross® Performance or Sure
Cross MultiHop (1 Watt) radio without an antenna connected.

IMPORTANT:
« Electrostatic discharge (ESD) sensitive device

+ ESD can damage the device. Damage from inappropriate handling is not covered by warranty.
« Use proper handling procedures to prevent ESD damage. Proper handling procedures include

leaving devices in their anti-static packaging until ready for use; wearing anti-static wrist straps;
and assembling units on a grounded, static-dissipative surface.

i Banner Enginearing Conp. Jume O, 2023



DXMBES0-X1 Series Controller Instruction Manual

BannerEngheerng CompLm iedW amantyl

Banner Engineering Corp. warrants its products to be free from defects in material and workmanship for one year following
the date of shipment. Banner Engineering Corp. will repair or replace, free of charge, any product of its manufacture which, at
the time it is returned to the factory, is found to have been defective during the warranty period. This warranty does not cover
damage or liability for misuse, abuse, or the improper application or installation of the Banner product.

THIS LIMITED WARRANTY 15 EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES WHETHER EXPRESS OR M-
PLIED (INCLUDING, WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICU-
LAR PURPOSE), AND WHETHER ARISING UNDER COURSE OF PERFORMANCE, COURSE OF DEALING OR TRADE
USAGE.

This Warranty is exclusive and limited to repair or, at the discretion of Banner Engineering Corp., replacement. IN NO
EVENT SHALL BANMNER ENGINEERING CORP. BE LIABELE TO BUYER OR ANY OTHER PERSON OR ENTITY FOR ANY
EXTRA COSTS, EXPENSES, LOSSES, LOSS OF PROFITS, OR ANY INCIDENTAL, CONSEQUENTIAL OR SPECIAL
DAMAGES RESULTING FROM ANY PRODUCT DEFECT OR FROM THE USE OR INABILITY TO USE THE PRODUCT,

WHETHER ARISING IN CONTRACT OR WARRANTY, STATUTE, TORT, STRICT LIABILITY, NEGLIGENCE, OR OTHER-
WISE.

Banner Engineering Corp. reserves the right to change, modify ar improve the design of the product without assuming any
obligations or liabilities relating to any product previously manufactured by Banner Engineering Corp. Any misuse, abuse, or
improper application or installation of this product or use of the product for personal protection applications when the product
is identified as not intended for such purposes will void the product warranty. Any modifications to this product without prior
express approval by Banner Engineering Corp will void the product warranties. All specifications published in this document
are subject to change; Banner reserves the right to modify product specifications or update documentation at any time. Spec-

ifications and product information in English supersede that which is provided in any other language. For the most recent ver-
sion of any documentation, refer to: www. bannerengineering.com.

For patentinformation, see www.bannerengineering.com/patents,

Contact Us

Banner Engineering Corp. headquarters is located at: 9714 Tenth Avenue Morth | Minneapolis, MN 55441, USA | Phone: + 1
BBB 3T3I67TET

For worldwide locations and local representatives, visit www bannerengineering.com.
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