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ECP PASSTHRU OVERVIEW

CellCom and DualCom Universal Communicators enable you to take over and manage ECP panels with
connection to the ECP Bus. This feature is called ECP Passthru.

This guide is designed to walk you through ECP passthru installation and setup. For more complete
information, refer to the CellCom Installation Guide (LT-1817) or the DualCom Installation Guide (LT-1859).

@ Procedure

The installation must follow this procedure:

Step 1: Mount the communicator.

Step 2: Wire the communicator.

Step 3: Program Vista keypad device address 20
Step 4: Configure ECP settings (remotely or locally)

Required Materials

The following software and hardware components are required to perform system takeovers:
e Compatible Honeywell VISTA panel (refer to “VISTA Panel Compatibility™)
¢« CellCom or DualCom with minimum firmware Version 202
¢ (Optional) Programming keypad with Model 330 or Model 330-24V programming cable
e (Optional) Cat 5 Ethernet cable
e 18-22 AWG unshielded wire (RYGB)
* Remote Link minimum Version 2.02

g Mounting Holes
@ Cellular Antenna

e SMA Connector

@ Cell Modem
e Tamper

Programming Connection
Terminal Block
Load and Reset Buttons

Power and Armed LEDs

Ethernet (DualCom only)
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Figure 1: CellCom and DualCom Components
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https://buy.dmp.com/dmp/products/documents/LT-1817.pdf
https://buy.dmp.com/dmp/products/documents/LT-1859.pdf

STEP 1: MOUNT THE COMMUNICATOR

It is not necessary to remove the PCB from the housing when installing the communicator.

The communicator should be mounted to a wall using the included #6 screws in the mounting holes. Refer
to Figure 1 for mounting hole locations.

Mount the communicator in a secure, dry place to protect it from tampering and weather damage. If using a
685 Series Conduit Backbox, refer to the 685 Installation Sheet (LT-1431) for mounting instructions.

STEP 2: WIRE THE COMMUNICATOR

The communicator can be connected to the ECP Bus of a VISTA panel. See Table 1 and Figure 2 for the
necessary wiring connections.

Caution: Remove all AC and battery power from the panels before wiring.

1. Attach the antenna to the SMA connector. Refer to Figure 1.
2. Connect system batteries as needed, then connect the panels to an appropriate power source.
3. Connect a programming keypad to the communicator.

a. For 12 VDC applications, connect the keypad to the communicator PROG header with a Model 330
programming harness.

b. For 24 VDC applications, connect the keypad to the communicator PROG header with a
Model 330-24V programming harness with an in-line resistor.

4. After programming is complete, remove the keypad and replace the housing cover on the mounted base.

E Note: Address 1is reserved by the system for programming keypads.
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https://buy.dmp.com/dmp/products/documents/LT-1431.pdf

Communicator to ECP Wiring

Com Series | ECP Bus Typical Color
+DC Keypad Power | Red

-DC Keypad GND Black

Z4+ Data Out Green

Z4- Data In Yellow

Table 1: Wire Connections

CellCom or DualCom
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Figure 2: ECP Wiring
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STEP 3: PROGRAM THE VISTA KEYPAD

In this step, you will program VISTA Keypad 5 Device Address 20. This enables the VISTA panel to
communicate with a CellCom or DualCom. This step must be performed locally at the VISTA panel.

1. Power down and then power up the VISTA panel.

2. Within 1 minute of powering up the VISTA panel, simultaneously press and hold the # and * buttons on
the keypad.

3. The keypad displays INSTALLER CODE. Enter the installer code (default is 4112), followed by 8 0 O.
Enter *193, then enter 1 0.

5. To save and exit programming, enter *99.

STEP 4: CONFIGURE ECP SETTINGS

For the communicator to properly process data from the VISTA panel, keypad input must be set to ECP. You
can perform this programming remotely with Dealer Admin or locally with a programming keypad.

Remote programming requires communicators with firmware Version 212 or higher. Local configuration
requires communicators with firmware Version 202 or higher.

During configuration, refer to “Troubleshooting” for programming messages and troubleshooting steps.

Remotely (Dealer Admin)
Before programming, ensure the ECP panel’s IP address is set as default.

—_

Go to Customers.
Find and select the system name.
Go to Full Programming > System Options.

In Keypad Input, select ECP.

2
3
4
5. In ECP Partition, enter the number of the partition where you want the communicator to operate.
6. Press Begin ECP Setup.

7.° If the host panel is a VISTA 128, turn on VISTA 128.

8. Enter the host panel’s installer code in VISTA Installer Code.

9

Press Begin.

S, °

After setup is complete, Dealer Admin automatically retrieves zones from the host panel. If you need to
retrieve zones again later, open System Options and select Get Zones.

System Options Cross Zone Time i
ECP Setup

o VISTA 1287

Swinger Bypass Trips
Q VISTA Installer Code

Reset Swinger Bypass

Time Change g
e Begin |

Hours'from EMT ("

Power Fail Delay

o Keypad Input ECP .

Gaeqm ECP Setup | Get Zones @
e ECPPartition 1 -

Weather Zip Code 00000
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Locally (Keypad)

To advance through the programming menu, press CMD. To go back, press the Back Arrow key. To enter a
menu, press any select key or area. To select an option, press the select key or area under that option.

Before programming, ensure the ECP panel’s IP address is set as default.

—_

Power up or reset the communicator.

At the communicator keypad, enter 6653 (PROG) and press CMD.

Advance to SYSTEM OPTIONS, then press any select key or area to enter the menu.
Advance to KYPD INPUT, then press any select key or area.

Select ECP by pressing the third select key or area under that option.

SRR NN

At ECP PARTN NBR, enter the number of the partition where you want the communicator to operate.
Range is 1- 8. Default is 1.

N

To save programming, advance to STOP and press any select key or area.

At the communicator keypad, enter 2313 (DIAG) and press CMD.

Advance to ECP SETUP and press any select key or area.

10. At ECP SETUP VISTA 1287?: If the panel is a VISTA 128, select YES. Otherwise, select NO.

1. At INST CODE, enter the ECP panel installer code and press CMD.

12. After configuration is finished, the keypad advances to GET ZONES. Press any select key or area.

As the communicator retrieves zones from the ECP panel, the number of zones is displayed and incremented
as ZONE CT (zone count).

Troubleshooting

Message ‘ Meaning ‘ Next Steps

PROGRAMMING The communicator is attempting to Wait for the configuration attempt to complete.
configure ECP panel programming Afterward, a programming status message is
settings for ECP Passthru. displayed (success, fail, or busy).

PROGRAM SUCCESS | The ECP panel has been successfully | Finish configuration at GET ZONES.
configured.

PROGRAM FAIL The ECP panel could not be Check wiring connections and communication
programmed. settings, then retry programming.

BUS IS BUSY The ECP panel could not be Wait and retry programming or reduce traffic on the
programmed due to high ECP bus ECP bus, then retry programming.
traffic.

Table 2: Programming Messages and Troubleshooting
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STEP 5: REMOTE PROGRAMMING

Starting with Remote Link™ Version 1.93, you can connect a customer’s Honeywell VISTA® panel with
CellCom, DualCom, or iComSL Series communicators using Honeywell’s Compass® software and Remote
Link.

Set up Remote Link

The following instructions assume that you already have a basic communicator account added to your
Remote Link accounts. To enable ECP Passthru for that account, complete the following steps.

1. Right-click Remote Link and select Run as administrator.

2. Double-click the communicator account to open it.

3. Go to Program > System Options.

4. To enable communication, go to Keypad input and select ECP. Press OK.
5. Go to File > Panel Information.

6° In Connection Information, enter the VISTA account number in Ecp Acct.
7.° Press OK.

8° Go to ECP Passthru > ECP Start/Stop Server.

9. Minimize Remote Link.

|Receiver] Account| Model | Version| Dat{ A - o 2

1onon XRS50 182 Region INurtheasl LI

1 12355 DuaiCom 182

1 234 XL 192 Connection Information

1 32154 X150 192 Network -

1 44733 XRS50 191 e | J '.: Remote Link : [1-12355] 12355 e

1 55667 XRS50 193 Remote Key e File System Panel Program | Ecp Passthru Language Window Help
P Address |192,153‘n 1 § Panel Information Close Pa;‘ Ecp Start/Stop server onnect Diagnostics
- | Ecp Passthrulog  Alt+F12
1P Port 2001

e EcpAcct [ 3 | 3005

~Backup Connection Information

Type |None j
Location
Address |
|
city |Busrun

v || staterzip e
>
Voice Phone
Delete Archive | Night Phone

Extra Information

_, Expart ‘ System info ‘
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Add the VISTA Panel in Compass

1. Open Compass.

2. In the lower right corner of the Customers page, select Add. The Customer Detail window opens.
3" In Subscriber Data, enter a Receiver number and Account number.

4% In the Panel Data section, select the VISTA panel model and revision number.

5. In Network Device MAC Addr, enter FFFFFF.

6. Press OK.

Subscriber Data
Receiver Account Last Name First Name
3 i 1.134 — S e S
Business Voice Phone Fax
Address 1 Address 2
City State Zip Code Zip Ext
I ; U
user_field_1 user_field_2
Panel Data bicile= )
Panel Revision e
|vistatsp ~| |vistatsp-9 =
Claszs Panel Phone Mumber
CallerID — | EEProm
CallerlD ;
Firmmware =
IP Communication Device ’N ]
- Mass Download Job Name | “O"® i
Network Device MAC Addr. | 00D020 FFFFFF
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Set Up Communication in Compass
1. In Customers, double-click the account that you created in the previous section.

The Panel Editor opens. Go to Tools > Communications.
Go to File > Communication Settings.
Select TCPIP Port Settings.

Press Add.
Back in Communication Settings window, select Apply.

2
3
4
5° To ensure that Compass uses a TCP/IP connection, select a TCP/IP port.
6
7
8. Press OK.

©1  Communication Settings == =% | Configure TCPIP Port )

-Select Company-

é Select TCPIP Part for Compass ©
’Ademco.-"First Alert b I
|TCRIPA =l fdd

~Modem Settings
Select COM ports | vl LConfigure COM ports
IP Address I

Standard Modems : Custom Modems : [Eantral Server)

Intemet  Intranet Contraller

<Maone

Ademco Cla 2400

Hayes Accura 144 V4.0

Hayes Optima 336 Esxternal

Hayes Optima SMARTMODER 2400
Haypes Smartmodem 1200

AR ]

Yiew | aad | Edi | Delte | Deeten | ’

[ Touch Tone Dial Out Prefix I
[ SpeakerOn

I O After Cornect Moderm Yolume ILow VI
Off & hnect

O TCPIP Port Settings... | e ok | LCancel | oA

AlarmMeti Website Icontrolsewer.alarmnet.com Ok Cancel

] »

- | 1 ] 3

pply |
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Configure TCP/IP Settings in Compass

1. In the lower left corner of the Compass Communication window, press Connect.

2. A dialog pops up to notify you that communication settings must be configured. Press OK.
3. Select Enable TCP/IP.

In the TCPIP Port dropdown, select the appropriate TCP/IP port.

5° Ensure that the Network Device MAC Addr is FFFFFF.

6.” In Connection Mode, select ECP.

7.° Ensure that AlarmNet-i is selected.

8° Press Connect.

-
% Communications | J

- TCPIP Port
| TCPIP 1 =]

— Cotinection Detail

* Use Account CSID

™ Firgt Time Cammunication

e W &cct#in Panel
W Enable TCRAF
Metwork Device MAC Addr IDEIDEI2D = "FFFFFF E e | Hi

Connection Mode

ECP hd

(& AlarmMet ™ Private LAN
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REFERENCE

Virtual Keypad
Virtual Keypad enables users to manage their systems remotely, including arming, disarming, viewing zone
status, bypassing zones, view history, manage users, and more.

To use Virtual Keypad for remote management, the configuration must meet the following conditions:

* ECP Panels must be programmed as Stay/Away for remote arming and disarming (No Partitions).

HYOUR LOGO

BUSINESS
8 vioeo © Arming (4) History
B
?,\ () HISTORY Y 7soAm
L=ge] p—— oo
9 asam
) Doors
STAY AWAY v
9 rasam
8 THeRMoSTATS
9 asam pac
Disarmed Q ueHTs
scheouLes
8 Locknown { GARAGEDOOR - L0CK | () REFRESH
() HisTORY AcTions

oUTPUTS I BACK DOOR @ FRONT DOOR

@ B

Friday, June 5,2020

L'} 7:59 AM FRONT DOOR Unlocked by Wi & &
JORDAN JONES

PROFILES

L'} 7:46 AM All System Off - Disarmed by
JORDAN JONES

REPORTS

NOTIFICATIONS

Q) 7:45 AM BACK DOOR Locked

| r N
—

COM SERIES HOW-TO GUIDE: ECP PASSTHRU | DIGITAL MONITORING PRODUCTS



VISTA Panel Compatibility

Panel Type

VISTA-10SE

VISTA-10P

VISTA-15

VISTA-15P

VISTA-20SE

VISTA-20P

VISTA-20PI

VISTA-21iP

VISTA-21iPLTE

ECP Remote
Rev 15 or higher No
Yes Yes
Yes No
Yes Yes
Rev 12 or higher No
Yes Yes
Yes Yes
Yes Yes
Yes Yes

Remote

User Management Arming/Disarming

No

Yes

No

Yes

No

Yes

Yes

Yes

Yes

Remote

No

Yes

No

Yes

No

Yes

Yes

Yes

Yes

Zone Status

a Note: Vista 32, 40, 50, 128, 250 are not compatible with ECP Virtual Keypad and eSuite.

Designed, engineered, and
manufactured in Springfield, MO

LT-2209 21213
© 2021

using U. S. and global components.

INTRUSION -

FIRE -

ACCESS

Compatible with
Compass

No

Firmware version
2.0 or higher

No

Firmware version
5.2 or higher

No

Firmware version
5.2 or higher

Firmware version
5.0 or higher

Yes

Yes

e NETWORKS

2500 North Partnership Boulevard
Springfield, Missouri 65803-8877

800.641.4282 | DMP. com
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