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Technical Support

Altair provides comprehensive software support via web FAQs, tutorials, training classes, telephone, and
e-mail.

Altair One Customer Portal

Altair One (https://altairone.com/) is Altair’s customer portal giving you access to product downloads, a
Knowledge Base, and customer support. We recommend that all users create an Altair One account and
use it as their primary portal for everything Altair.

When your Altair One account is set up, you can access the Altair support page via this link:
www.altair.com/customer-support/

Altair Community

Participate in an online community where you can share insights, collaborate with colleagues and peers,
and find more ways to take full advantage of Altair’s products.

Visit the Altair Community (https://community.altair.com/community) where you can access online
discussions, a knowledge base of product information, and an online form to contact Support. These
valuable resources help you discover, learn and grow, all while having the opportunity to network with
fellow explorers like yourself.

Altair Training Classes

Altair’s in-person, online, and self-paced trainings provide hands-on introduction to our products,
focusing on overall functionality. Trainings are conducted at our corporate and regional offices or at your
facility.

For more information visit: https://learn.altair.com/

If you are interested in training at your facility, contact your account manager for more details. If you
do not know who your account manager is, contact your local support office and they will connect you
with your account manager.

Telephone and E-mail

If you are unable to contact Altair support via the customer portal, you may reach out to technical
support via phone or e-mail. Use the following table as a reference to locate the support office for your
region.

When contacting Altair support, specify the product and version number you are using along with
a detailed description of the problem. It is beneficial for the support engineer to know what type
of workstation, operating system, RAM, and graphics board you have, so include that in your
communication.

Location Telephone E-mail

Australia +61 3 9866 5557 anzsupport@altair.com

Brazil +55 113 884 0414 br_support@altair.com


https://altairone.com/dashboard
https://www.altair.com/customer-support/
https://community.altair.com/community
https://learn.altair.com/
mailto:anzsupport@altair.com
mailto:br_support@altair.com
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Technical Support

Location
Canada
China
France
Germany
Greece

India

Israel

Italy

Japan
Malaysia
Mexico

New Zealand
South Africa
South Korea
Spain
Sweden
United Kingdom

United States

If your company is being serviced by an Altair partner, you can find that information on our web site at

Telephone

+1 416 447 6463
+86 400 619 6186
+33 141 33 0992
+49 703 162 0822
+30 231 047 3311

+91 806 629 4500
+1 800 425 0234 (toll free)

+39 800 905 595
+81 3 6225 5830
+60 32 742 7890
+52 55 5658 6808
+64 9 413 7981
+27 21 831 1500
+82 704 050 9200
+34 910 810 080
+46 46 460 2828
+44 192 646 8600

+1 248 614 2425

https://www.altair.com/PartnerSearch/.

E-mail
support@altairengineering.ca
support@altair.com.cn
francesupport@altair.com
hwsupport@altair.de
eesupport@altair.com

support@india.altair.com

israelsupport@altair.com
support@altairengineering.it
support@altairjp.co.jp
aseansupport@altair.com
mx-support@altair.com
anzsupport@altair.com
support@altair.co.za
support@altair.co.kr
support-spain@altair.com
support@altair.se
support@uk.altair.com

hwsupport@altair.com

See www.altair.com for complete information on Altair, our team, and our products.
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Creating a Rectangular Horn 1

The example is intended for users with no or little experience with CADFEKO. It makes use of a
completed rectangular horn model to familiarise yourself with model creation in CADFEKO and viewing
the simulated results in POSTFEKO.

This chapter covers the following:

e 1.1 Example Overview (p. 13)

e 1.2 Topics Discussed in this Example (p. 14)
e 1.3 Example Prerequisites (p. 15)

e 1.4 Feko Components and Workflow (p. 16)
e 1.5 Introduction to CADFEKO (p. 17)

e 1.6 Introduction to POSTFEKO (p. 31)
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1.1 Example Overview

This example shows a completed rectangular horn model to familiarise yourself with the Feko
components and workflow. The main elements and terminology in the CADFEKO and POSTFEKO
graphical user interface are discussed.

Figure 1: Illustration of the horn antenna.

© Tip: Watch the demo video before working through this example. The model in the demo
video is similar to the horn model used in this example.

Find the short demo video in the Altair installation directory, for example:
Altair/2022.1/help/feko/videos/DemoExample.mp4 for Windows and

Altair/2022.1/help/feko/videos/DemoExample.html for Linux.

J\ ALTAIR
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1.2 Topics Discussed in this Example

Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.
The topics discussed in this example are:

e View the Feko general workflow.

e Launch CADFEKO.

e View the CADFEKO layout.

¢ View the POSTFEKO layout.
e View the far field results and near field results in POSTFEKO.

Note: Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

L=

(7] Tip: Find the completed model in the application macro Iibrarym:

GS 1: Rectangular Horn Antenna

3. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.

J\ ALTAIR
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1.3 Example Prerequisites

Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

Feko 2022.1 or later should be installed.

[ ]
It is recommended that you watch the demo video before attempting this example.

e This example should not take longer than 30 minutes to complete.

|5/ Note: When using CADFEKO over a remote desktop connection, you may need to enable 3D
support for remote desktop[4] for the host's graphics card should a crash occur when clicking

New Project in CADFEKO.

See the Troubleshooting section in the Appendix of the Feko User Guide for more details.

J\ ALTAIR
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1.4 Feko Components and Workflow

View the typical workflow when working with the Feko components.

Use CADFEKO Use POSTFEKO

Create new

- graph / display
geometry
—

Add / view results

Run Feko Solver
Post-processing of

or add component Define frequency,

from
component library

results / scripting

sources and requests

Export results /
generate report

CADFEKO

Create or modify the geometry (or model mesh) in CADFEKO, import geometry or mesh, or use a
component from the component library. Apply solution settings, define the frequency, specify the
required sources and request calculations.

When the frequency is specified or local mesh settings are applied, the automatic mesh algorithm
calculates and creates the mesh to obtain a discretised representation of the geometry or model mesh.
View the status of the model in the Notification centre. If any warnings or errors are given, correct the
model before running the Solver.

Solver
Run the Solver to calculate the specified output requests.

POSTFEKO

Create a new graph or 3D view and add results of the requested calculations on a graph or 3D view.
Results from graphs can be exported to data files or images for reporting or external post-processing.
Reports can be created that export all the images to a single document or a custom report can be
created by configuring a report template.

After viewing the results, it is often required to modify the model again in CADFEKO and then repeat the
process until the design is complete.

Proprietary Information of Altair Engineering A ALTAI R
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1.5 Introduction to CADFEKO

Use CADFEKO to configure a solver-ready input file for Solver simulations.

CADFEKO is the Feko component that allows you to create complex CAD geometry using primitive
structures (for example, cuboids and polygons) and to perform Boolean operations (for example,

union and subtract) on the geometry. Complex geometry models and mesh models can be imported or
exported in a wide range of industry standard formats. Reduce development time by using a component
from the list of antennas and platforms in the component library.

In CADFEKO, you can request multiple solution configurations, specify calculation requests as well as
specify the solution settings for the model. If an optimisation search is required, you can specify the
optimisation parameters and goals.

In CADFEKO, you can request multiple solution configurations, specify calculation requests as well as
specify the solution settings for the model. If an optimisation search is required, you can specify the
optimisation parameters and goals.

J\ ALTAIR
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1.5.1 Launching CADFEKO (Windows)

There are several options available to launch CADFEKO in Windows.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.

s Altair Feko 2022.1 - *

File Home Documentation  Utilities

» » »

&c &p & EDITFEKO “p' Zw LA |~ e =4,
CADFEKO POSTFEKD QUELEFEKO ProMan WallMan AMan | .2 | newFASANT | WRAP  SAM Chedk for  Terminal
Updates
Feko WinProp newFASANT WRAP Tools

Figure 2: The Launcher utility.

e Open CADFEKO by double-clicking on a .cfx file.
e Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

[5/ Note: If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

1.5.2 Launching CADFEKO (Linux)

There are several options available to launch CADFEKO in Linux.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.
e Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:
/home/user/2022.1/altair/feko/bin/cadfeko

e Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

/home/user/2022.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

[/ Note: Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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1.5.3 Start Page

The Feko start page is displayed when starting a new instance (no models are loaded) of CADFEKO,
EDITFEKO or POSTFEKO.

The start page provides quick access to Create a new model, Open an existing model, and a list of

Recent models.

p.19

Links to the documentation (in PDF format), introduction videos and website resources are available on

the start page. Click the

2 icon to launch the Feko help.

CADFEKO

D Create a New Project

Recent Models

No recent models

-
E}Open an Existing Project

?
-
Documentation
7 Get to Know New CADFEKO
[ User Guide [ Getting Started Guide
[l Example Guide [/ Release Notes
Videos

3 Tour and Demo
3 CADFEKO Introduction
Website

@ Altair Feko Product Page
@ Altair Feko Resources
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Figure 3: The CADFEKO start page.
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1.5.4 User Interface Layout

View the main elements and terminology in the CADFEKO graphical user interface (GUI).

st CADFEKOD 2022.1 - Hon
D Qe 30 View
Home  Construct Sourcefload Request Mesh 2 View _Display Options
og i .
C||:| 5 & create ﬁ I3 comectrity 2 A Triangles = A tx.)f.ZJ @ m
Dgom 7 P Al
Ma\r $- Filter Windscreen | Geomelry %
e O oot~ Lavens & Tevahesa- | e Poms | rots | us') | Enioes m &
Style r-bdel visiity Entity Display ues
¥ Configurations Ead [ 30 Viewl B Model Status ~ iw  »
@ StandardConfiguration Maodel is valid
|ﬁ ch etichdod, qurati
Construction | Configuration
Items “\'f g @
» Definitions
~ Model
¥ Geometry
» %9 UnionT Y
(P Cuboid X
) Flarel
Meshes
v Ports
@) WaveguidePortl
Meshing Rules
~ Cutplanes
&
2' ) £& Notes View - a x
Solution Settings ) = :')‘) "‘b r (145 hel Dl 2 ~[s ~|H B Ir "
Optimisation
Project name: Getting Started Gude 01
Details Creator: Altair
Union1 &y & B & Edited by: At
Edges Description:
v Faces For more informatan, epen the “Getting Started Guide™ by diddng on the help icon in the top right-hand cormer of
P Facel O Mahd (CADFEKO or POSTFEKD. The guide wil explain the steps that are required to oreate the moded, how to configure the
' Face2 B MeM sividaton and how to process the results,
P et W Mah
P Faces | | MoM
' Faced B MaM
P Faced | | Mo W 6 7
E- ) leav:@ Q:@ Tools: @5, & Selacton: [y @ 57 - [ Model Status: (0)
——

1. Quick access toolbar
The quick access toolbar is a small toolbar that gives quick access to actions that are
performed often. The actions available on the quick access toolbar are also available via the
ribbon. The quick access toolbar includes: New, Open, Save, Undo and Redo.

2. Ribbon
The ribbon is a command bar that groups similar actions in a series of tabs. The ribbon
consists of the application menu, core tabs and contextual tab sets.

3. Configuration list
The configuration list is a panel that displays all defined configurations in the model. A new
model starts by default with a single standard configuration. The following configuration
types are supported: Standard configuration, Multiport S-parameter configuration and
Characteristic modes configuration.
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© Tip: Multiple configurations allow you to perform efficient simulations using
different configurations (different loads, sources, frequencies or power scaling) in
a single model.

4. Model tree

The model tree is a panel that organises the model-creation hierarchy and configuration-
specific items of the model into two separate tabs at the top of the panel. A right-click
context menu is available for all items in the model tree. Double-click on an item to open its
properties.

Predefined variables, named points, media, workplanes, field/current data, worksurfaces
and cables are listed in both the Construction tab and the Configuration tab to provide
quick access.

a. Construction tab
The Construction tab lists the model-creation hierarchy in a tree format.

5/ Note: Select a geometry or mesh part on the Construction tab
and in the details tree (5), modify its wire / edge / face / region
properties, solution settings and custom mesh settings.

b. Configuration tab
The Configuration tab lists the configuration-specific items in a tree format.

5/ Note: Select a configuration in the configuration list (3) and view its
configuration-specific items in the Configuration tab.

5. Details tree
The details tree is a panel that displays the relevant wires, edges, faces and regions for the
geometry or mesh part selected in the Construction tab (4). From the right-click context
menu specify the properties for its wire, edge, face or region properties in the details tree.
You can modify the selected item's local mesh size, material definition or coating or solution
properties that are specific to the selection.

6. Status bar
The status bar is a small toolbar that gives quick access to macro recording, general display
settings, tools, selection method and type, snap settings and the model unit.

7. Model Status icon
The Model Status icon shows the current status of the model in the Notification centre. The
Notification centre can be hidden but the Model Status icon in the status bar will still indicate
the current status of the model.
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8. Notes view
The notes view is a window where you can document model details. Add additional

comments or information for future reference.

© Tip: The notes view is hidden by default, but can be enabled.

On the Home tab, in the Create view group, click the / Notes icon.

9. Notification centre

The Notification centre performs computational electromagnetic model (CEM) validation and
shows the status of the model. When problems in the model are detected, it is highlighted in
the Notification centre with hyperlinks to the problematic entities.

10. 3D view

The 3D view window displays the geometry and mesh as well as solution requests (for
example, a far field request).

O Tip:

Select the Construction tab (4.a) to view only CAD in the 3D view.

Select the Configuration tab (4.b) to view both CAD and solution requests
in the 3D view.

11. Help

The Help icon gives quick access to the Feko manuals.

& Tip: Press F1 to access context-sensitive help.

12. Search bar

The search bar is a single-line textbox that allows you to enter a keyword and search for
relevant information in the GUI. Entering a keyword in the search bar will populate a drop-

down list of actions as well as the location of the particular action on the ribbon or context
menu. Clicking on an item in the list will execute the action.

13. Application launcher

The application launcher toolbar is a small toolbar that gives quick access to other Feko
components.
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1.5.5 Ribbon

The ribbon is a command bar that groups similar actions in a series of tabs.

El=) (2 )
File IHome Construct Transform ables \’u‘mdscreen Source/Load Request Me_sh Solveﬁﬁun Tools iewl Display Cptions

& @ DEE BBRIEB s & B Meff™™

Symmetry FOTD Boundary MNGF Enable  Solver Model View by Feko POSTFEKD EDITFEKO PREFEKO Feko

Conditions Solution Settings | Status Solution | Solver Terminal |;|3 Remote
Solution Settings Validate ‘ 4 ! Run / Launch

Figure 4: The ribbon in CADFEKO.

3D View

1. File menu
The File menu is the first item on the ribbon. The menu allows saving and loading of models,

import and export options as well as giving access to application-wide settings and a recent file
list.

2. Core tabs
A tab that is always displayed on the ribbon, for example, the Home tab and Construct tab.

The Home tab is the first tab on the ribbon and contains the most frequently used commands for
quick access.

3. Contextual tab sets
A tab that is only displayed in a specific context.

For example, the Schematic contextual tab set contains the Network Schematic contextual

tab. Contextual tabs appear and disappear as the selected items such as a view or item on a view,
change.

4. Ribbon group
A ribbon tab consists of groups that contain similar actions or commands.

5. Dialog launcher

Click the dialog launcher to launch a dialog with additional and advanced settings that relate to
that group. Most groups don't have dialog launcher buttons.

Keytips
A keytip is the keyboard shortcut for a button or tab that allows navigating the ribbon using a

keyboard (without using a mouse). Press F10 to display the keytips. Type the indicated keytip to
open the tab or perform the selected action.

I"j ‘:ﬁ |—L||.:v=; 3D View

4
':"E Hnma Consh’uct Transf'orm Sourceﬂ_oad Request Mesh  Solve/fRun  Tools  View  Display Options

R M u — o v __ﬁ
NE % . = 2 [ )
pimfhey W 2 e | El ||
Mew  Open Save |Component Import Export Protection 3D Schematic Motes Model Model | |Automatic
Meshing

Project  File Library o o View o Unit Status
File Create View Model Attributes | Validate

Figure 5: An example of keytips.
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1.5.6 Construction Tab

The Construction tab contains the geometry and mesh representation of the current model in a tree
structure. It also lists ports and the optimisation configuration.

The tree contains a Definitions branch, Model branch and Optimisation branch.

Construction | Configuration

Items q-? qSF
~  Definitions

g;_ Variables

xé: Mamed Points
v B Media

Perfect electric conductor

Perfect magnetic conductor

. Free space
@ Mesh Settings
L Workplanes
,é.. Field/Current Data
I7 Work Surfaces
hd EETE Cables
Cable Cross Sections
Paths
Shields
~ Maodel
¥ Geometry
’:"¢ Bent_dipole
|:|¢ Reflector
Meshes
~ Ports
#% WirePort1
Meshing Rules
Cutplanes
Selution Settings
“  Optimisation
F-?} OptimisationSearchl [Automatic]

Figure 6: The Construction tab in the model tree.

Definitions Branch
The Definitions branch contains by default the predefined variables, named points, media, mesh
settings, workplanes, field/current data, worksurfaces and cables.

Model Branch

The Model branch is mainly a visualisation of the geometry and mesh creation hierarchy. Where
geometry or mesh objects are derived from existing ones, the original (parent) objects are
removed from the top level of the model and listed as sub-levels (children) under the new object.

[5/ Note: The highest-level items in the Model are referred to as “parts”.
For example, Conel and Cuboidl (parent objects) were unioned and the result is that they have

become children of the new object (Union1). Union1 is the highest-level item and referred to as
a part.
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~ Maodel
¥ Geometry
hd @ Union1
C} Conel

(P Cuboidl

Figure 7: The Construction tab in the model tree showing the part, Union1.
The Model branch also contain the ports, meshing rules, cutplanes and solution settings.

Optimisation Branch
The Optimisation branch contains the optimisation searches, associated masks, parameters and
goal functions defined for the model.

5/ Note: The Optimisation branch is only displayed if the model contains an
optimisation search or mask.
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1.5.7 Configuration Tab

The Configuration tab contains the global and configuration-specific model settings and requests of the
current model in tree form.

The tree contains a Definitions branch, Global branch and Configuration specific branch.

Construction | Configuration

StandardConfigurationl “uf {ﬁv SHE v
“  Definitions
1 Variables
& MNamed Points
' Media
@ Mesh Settings
. Workplanes
A Field/Current Data
T" Work Surfaces

ES._E Cables
Cable Harnesses
¥ Global

VW Frequency [299.792 MHz]
v E Sources

'@' VeltageSourcel

~ Configuration specific
Far Fields

Figure 8: The Configuration tab in the model tree.

Definitions Branch
The Definitions branch contains by default the predefined variables, named points, media, mesh
settings, workplanes, field/current data, work surfaces and cables.

Global Branch
The Global branch contains the global specific model settings. From the right-click context menu
define solver settings, specify the global frequency, sources, loads, networks and power.

Configuration specific Branch
The Configuration specific branch contains configuration specific settings. From the right-
click context menu define requests per configuration, frequency per configuration, sources per
configuration, loads per configuration and power per configuration.
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1.5.8 Notification Centre

The Notification centre performs computational electromagnetic model (CEM) validation and shows the
status of the model and notifications.

The Notification centre lets you stay informed of the model status at all times. When problems in

the model are detected, it is highlighted in the Notification centre with hyperlinks to the problematic
entities.

The Notification centre can be hidden but the Model Status icon in the status bar will still indicate the
current status of the model.

Model Status .+ P
Notices
@ The mesh is busy being
calculated.

276,809 Estimated number
of elements.

972 MB Estimated peak
memary required for meshing.
5,272 MB available.

Model Status: €9 Unit: m

Figure 9: The Notification centre in CADFEKO. Note the Model Status
icon at the bottom that shows the current status of the model.

Show or hide the Notification centre using one of the following workflows:
¢ Click the Model Status icon in the status bar.

e Drag the splitter from the right edge of the application to open the pane. To close, drag the splitter
all the way to the right.

On the Home, in the Validate group, click the Model Status icon.
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1.5.9 Dialog Error Feedback

CADFEKO provides error feedback for dialogs by showing a soft message bubble when validation fails on
a dialog.
Click the 0 icon to show or hide the message bubble or click elsewhere in CADFEKO to hide the

message bubble. The error feedback is also shown per tab when the validation fails on a multi-tab
dialog.

sc Create Rectangle X s¢ Create Rectangle *
Geometry Workplane Geometry @) Workplane

Definition methods Predefined workplane

Base corner, width, depth w () Custom workplane
na (® Predefined workplane
Global XY w~
Cl.D
£/ T
i T— V
IS

Base corner (C)

v |D'D | & Variable not found at

v position 1 for

|D'D | & expression: Rectangle 1
N (Width property) = x
oo B

Dimensions

width (W) [x ?

Depth () [1 |
Label |Rectanglel |

Create Add Cloze Create Add Close

Figure 10: The soft message bubble indicating that an undefined variable
was used on the Geometry tab of the Create Rectangle dialog.
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1.5.10 Custom Keyboard Shortcut Settings

CADFEKO provides default keyboard shortcuts. To better fit your workflow and work style, you can
reassign keyboard shortcuts to different commands.

To reassign mouse buttons, click the Application menu button. On the application menu panel, click
Settings > Keyboard Shortcut Settings.

s¢ Keyboard Shortcut Settings X

Marne DefaultkeySequence CurrentieySequence "
2 IDViewBottomSide 2 2
3 IDViewFrontSide 5 5
4 IDViewlsometric 0 0
5 IDViewlLeftSide 4 4
6 IDViewRightSide 6 6
7 IDViewTopSide 8 8
] About
] AboutAltairSimulationProducts
10 ActivateQptimisationSearch
11 AdaptiveRefinement
12 AddAnalyticalCurve V.5 V.5
13 AddAnisotropicDielectric

v
Restore defaults
OK Cancel
Figure 11: The Keyboard Shortcut Settings dialog.

For example, to change the shortcut key for the undo command, on the Keyboard Shortcut Settings
dialog, click in the CurrentKeySequence column and enter the shortcut key that suits your work style.
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Bindings
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CADFEKO provides default commands for all the mouse buttons. To better fit your workflow and work
style, you can reassign mouse buttons to different commands.

To reassign mouse buttons, click the Application menu button. On the application menu panel, click

Settings > Mouse Binding Settings.

¢ Mouse Binding Settings d
Narme Configuration ~
v Zoom Click to Configure
KeyboardModifier
MeouseButtons
MouseEvent Maouse wheel
Inwvert |
FineZoom Click to Configure
DragZoom Click to Configure
Pan Click to Configure
DragPan Click to Configure
ScrollPanVertical Click to Configure
ScrollPanHorizontal Click to Configure
DragPanVertical Click to Configure
DragPanHorizantal Click to Configure
Rotate Click to Configure
ScrollRotatePhi Click to Configure
ScrollRotateTheta Click to Configure
DragRotatePhi Click to Configure
DragRotateTheta Click to Configure
Select Click to Configure
SelectToggle Click to Configure W

Restore defaults

OK Cancel

Figure 12: The Mouse Binding Settings dialog.

For example, to reverse the mouse wheel direction to better suit your workflow, on the Mouse
Bindings dialog, click Click to Configure. On the Zoom dialog, select the Invert check box.

sc Zoom *

Mouse whee! event
Keyboard Modifiers

[] shift
[] contral
[] ait

[] Meta

Mouse Buttons
[] Left Button

[] right Button
[] Middle Button
D Invert

OK

Figure 13: The Zoom dialog.
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1.6 Introduction to POSTFEKO

Use POSTFEKO to validate meshed geometry and analyse and post-process results.

POSTFEKO is the component that allows you to verify that your model is constructed and configured
correctly before starting a simulation and analyse the results after the simulation completes. The
POSTFEKO component is particularly useful to verify models created using EDITFEKO, but it is just as
relevant for CADFEKO model verification.

Result post-processing and analysis is the primary function of POSTFEKO. Once a model has been
simulated, POSTFEKO can be used to display and review the results. It is easy to load multiple models
in a single session and compare them on 3D views, Cartesian graphs, Smith charts, polar graphs

and surface graphs. Various measurement and other data formats are supported for comparison to
the simulated results. A powerful scripting interface makes it easy to post-process results, automate
repetitive tasks and create plug-in extensions that customise the interface and experience.
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1.6.1 Launching POSTFEKO

Open POSTFEKO from within CADFEKO.
Use one of the following workflows to launch POSTFEKO:

¢ On the Solve/Run tab, in the Run/Launch group, click the <7 POSTFEKO icon.

* On the application launcher toolbar, click the POSTFEKO icon inthe [E =~ = & | group.

e Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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1.6.2 User Interface Layout

View the main elements and terminology in the POSTFEKO graphical user interface (GUI).
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1. Quick access toolbar
The quick access toolbar is a small toolbar that gives quick access to actions that are
performed often. The actions available on the quick access toolbar are also available via the
ribbon. The quick access toolbar includes: New project, Open project, Save project,
Undo and Redo.

2. Ribbon
The ribbon is a command bar that groups similar actions in a series of tabs. The ribbon
consists of the application menu, core tabs and contextual tab sets.

3. Project browser
The project browser is a panel that lists the models loaded in the current project, imported
data, stored data and scripted data.
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© Tip: Collapse the project browser to expand the 3D view.

On the View tab, in the Show group, click the ;| Project icon.

4. Model browser
The model browser is a panel that organises the model information of the selected model in
the project browser (3), into two separate tabs.

Model tab
The Model tab lists the model information and results for the selected model.

Results tab
The Results tab lists the results and solution information.

5. Details browser
The details browser is a panel that shows in-depth detail for the selected item in the model
browser (4).

& Tip: View the solution information for the selected model.
On the model browser, click Solution information to view:
e memory per process
e total CPU-time
¢ total runtime.

6. Status bar
The status bar is a small toolbar that gives quick access to general display settings, tools,
and graph cursor settings.

7. 3D view/2D graphs

3D view
The 3D view displays the geometry, mesh, solution settings as well as 3D results.
2D graphs
The 2D graphs display the 2D results on either a Cartesian graph, polar graph, Smith
chart or Cartesian surface graph.

O Tip:
e Re-order the window tabs by simply dragging the tab to the desired location.

e Rename the window tab by using the right-click context menu and selecting
Rename.
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8. Result palette
The result palette is a panel that gives access to options that control the data in the 3D view
or 2D graph for the relevant result type. For example, 3D far field data allows the phi cut
plot type and gain in dB to be specified.

9. Help
The Help icon gives quick access to the Feko manuals.

© Tip: Press F1 to access context-sensitive help.

10. Search bar
The search bar is a single-line textbox that allows you to enter a keyword and search for
relevant information in the GUI. Entering a keyword in the search bar will populate a drop-
down list of actions as well as the location of the particular action on the ribbon or context
menu. Clicking on an item in the list will execute the action.

11. Application launcher
The application launcher toolbar is a small toolbar that gives quick access to other Feko
components.

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1
1 Creating a Rectangular Horn p.36

1.6.3 Validating the Model in POSTFEKO

View the model using visualisation tools in POSTFEKO to confirm the model was created as intended.

Confirm the horn model is open in the 3D view.
1. Enable the mesh edges of the model.
a) On the 3D View contextual tabs set, on the Mesh tab, in the Visibility group, click the
4L Metal icon. From the drop-down list, select the Edges check box.

2. Zoom to extents of the 3D view using one of the following workflows:

On the View tab, in the Zoom group, click the :‘Q: Zoom to Extents icon.

e Press F5 to use the keyboard shortcut.
3. Enable tick marks on the axes.
a) On the 3D View contextual tabs set, on the Display tab, in the Axes group, click the
A}j Tick Marks icon.

4. Use the distance measurement tool to validate the dimensions of the horn.
a) On the 3D View contextual tabs set, on the Mesh tab, in the Tools group, click the
8} Measure Distance icon.

b) On the Measure Distance dialog, ensure that the Point1 field is active.
c) In the 3D view, press Ctrl+Shift+left click on the first point.
d) Repeat Step 4.c for the second point.

<p Measure distance X
Paint 1
x |0.275 &
Y |0.214 &
Z 046 &
Paint 2
X |0.275 5
¥ [0.214 &
z [0.46 &
Distance (D)
¥ distance I:I
Y distance  |0.428
Z distance I:I
Close

Figure 14: The Measure distance dialog showing the distance between two points.

e) Click Close the close the dialog.
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1.6.4 Viewing the Near Field Results (3D)

View the near field results in the 3D view and add a legend and contours.
1. Add the near field data to the 3D view.

a) On the Home tab, in the Add results group, click the E Near Fields icon. From the drop-
down list, select NearField1.

. H‘fl - | - g] - :_"'7 -
O, @ & 2 % =
LS - LP) o
Far | Mear . Source  Loads/ :

field . |[figldy =F ~ dats . Networks & - < =

Horn : StandardConfigurationl |
D: |Program Files [Afta._Horn_Antenna [Horm. bof

Ei MearField 1

Figure 15: Section of the ribbon showing the Add results group.

2. View the magnitude of the E, component of the field.
a) On the result palette, in the Quantity, clear the X check box and the Z check box.

¥ Quantity
Electric field w

[] scale near field power

[dx Y [z
(®) Magnitude

() Phaze

() Real

O Imaginary
O Instantaneous magnitude

Phase (wt)
dB ] Mormalise

Figure 16: The Quantity panel in the result palette.

3. View the electric field in dB.
a) On the result palette, in the Quantity panel, select the dB check box.
4. Add a legend to the 3D view (top left).
a) On the 3D View contextual tabs set, on the Display tab, in the Legends group, click the
%\ Top left icon. From the drop-down list select NearFields.
5. Add contours to the near field result.
a) On the 3D View contextual tabs set, on the Result tab, on the Contours group, click the
¢» Show contours icon.
6. Specify the number of contours for the near field.
a) On the 3D View contextual tabs set, on the Result tab, in the Contours group, click the
C’;J Position icon. Click Number of contours and set its value to 11.
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<p Contour positions b

Specify contours
{®) Number of contours 11 |5

() Spedify contour values

Apply Cancel

Figure 17: The Contour positions dialog.

b) Click OK to close the dialog.

Y E-Field Magnitude [dBV fm]

42.0
39.0
36.0
33.0
30.0
27.0
24.0
21.0

18.0
I 15.0
12.0

Figure 18: The near field results with contours.
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1.6.5 Viewing the Near Field Results (2D)

Create a new Cartesian graph. Create two near field traces and compare the E, and E, components of
the near field along the X direction.

1.

2,

3.

4.

Proprietary Information of Altair Engineering

Create a new Cartesian graph.
a) On the Home tab, in the Create new display group, click the LL\_ Cartesian icon.
Add the near field result to the Cartesian graph.

a) On the Home tab, in the Add results group, click the B Near Fields icon. From the drop-
down list, select NearField1.
View the near field along the X direction.

a) On the result palette, in the Slice panel, make the following changes:
e From the Independent axis (Horizontal) list, select X position.
e From the Frequency list, select 1.645 GHz.
e From the Y position list, select 100 mm.
e From the Z position list, select 460 mm.

¥ Slice

Independent axis (Horizontal)

¥ position ~
Fixed

Frequency | 1.645 GHz w
Y posiion | 100 mm w
Z position | 450 mm w

Figure 19: The Slice panel in the result palette.

View the magnitude of the E, component of the field.
a) On the result palette, in the Quantity panel, clear the X check box and the Z check box.

¥ Quantity
Electric field ~

[ scale near field power

[ x [ ¥ 1z
(®) Magnitude

Phase

Rea
[de [] Mormalise

Figure 20: The Slice and part of the Quantity panels in the result palette.

Add a second trace to the Cartesian graph by duplicating the NearField1 trace.
a) On the Trace tab, in the Manage group, click the Iﬁ Duplicate trace icon.

A second trace, NearField1_1, is created.
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6. View the magnitude of the E, component of the field.

a) On the result palette, select

the NearField1_1 trace.

p.40

b) On the result palette, in the Quantity panel, select the X check box and clear the Y check

box.
7. Set the vertical axis to dB.

a) In the result palette, select both traces (NearField1l and NearField1_1).
b) In the Quantity panel, select the dB check box.

8. Modify the minimum and maximum values for the vertical axis.

a) On the Cartesian context tab, on the Display tab, on the Axes group, click the L’-S"? Axis

settings icon.

b) On the Axis settings (Cartesian graph) dialog, select the Vertical tab.

c) Clear the Automatically determine the grid range check box.

d) In the Maximum value field, enter a value of 40.

e) In the Minimum value field, enter a value of -20.

s Axis settings (Cartesian graph)

Harizontal Vertical
Ranges

] automatically determine the grid ranges
Auto range setting

Maximum dynamic range in dB | 100

Manual grid range settings

Maximum value |4D |
Minimum value |-ZD |
Grid spacing

Automatically determine the major grid spacing

Major grid spacing 10

Ak

Minor grid subdivisions |4

Mumber format
Mumber format Decimal

Automatically determine the number of significant digits

£ -

-ifiramt diqit i
g 5 i} =

umber of significant digits

Aol Cancel

Figure 21: The Axis settings (Cartesian graph) dialog.

f) Click OK to close the dialog.
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Near field
¥ X
40
30
g 20
= 10
=
x
L
u 0
10
20
~300

X position [mm]

Figure 22: The E, and E, components of the near field along the X direction.
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1.6.6 Viewing the Far Field Results (3D)

View the far field results in the 3D view.
1. Select the 3D view window.
2. Add the far field result to the 3D view.

a) On the Home tab, in the Add results group, click the @ Far Field Source icon. From the
drop-down list, select FarField1.
3. Hide the near field result still displayed in the 3D view.

a) In the result palette, on the Traces panel, click the <% “eye” icon next to NearField1l.

FarField1 =

Figure 23: An open £ “eye” icon indicates that the trace is shown.

learFielc -
FarField1 =

Figure 24: A closed +«._+ “"eye” icon indicates that the trace is hidden.

4. Add an annotation to the far field.

a) Add an annotation to the desired location by pressing Ctrl+Shift+left click.
5. View the fields in dB.

a) On the result palette, in the Quantity panel, select the dB check box.
6. Change the size of the far field compared to the geometry.

a) On the 3D View contextual tabs set, on the Result tab, in the Rendering group, click the
Q}' Size icon. From the drop-down list, select Custom.

b) On the Specify dialog, set the size as 70%.

Total Gain [dBi]

Figure 25: The 3D far field result.

c) Click OK to specify the size of the far field and to close the dialog.
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1.6.7 Viewing the Far Field Results (2D)

View the far field results on a polar graph.

L=l

Note: Since a full 3D set of data was requested for this example, 2D cuts can be extracted.

1. Create a new polar graph.

a) On the Home tab, in the Create new display group, click the .@ Polar icon.
2. Add the far field result to the polar graph.

a) On the Home tab, in the Add results group, click the @ Far Field Source icon. From the
drop-down list, select FarField1.

3. View the far field gain plotted in the YZ plane.

a) On the result palette, in the Slice panel, make the following changes:
[ )

From the Independent axis (Angular) drop-down list, select Theta (wrapped).
From the Frequency drop-down list, select 1.645 GHz.

From the Phi drop-down list, select 90 deg (wrapped).
4. On the result palette, in quantity panel panel, select the dB check box.

Far field

FarField1

270

240

Figure 26: The far field results on a polar graph.
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The example is intended for users with no or little experience with CADFEKO. This example is not an
example intended for simulation, but rather to familiarise yourself with model creation in CADFEKO.

This chapter covers the following:

e 2.1 Example Overview (p. 45)

e 2.2 Topics Discussed in this Example (p. 46)
e 2.3 Example Prerequisites (p. 47)

e 2.4 Creating the Model in CADFEKO (p. 48)
e 2.5 Final Remarks (p. 73)
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2.1 Example Overview

Create a simple model using basic geometry and transformations to familiarise yourself with model
creation in CADFEKO.

Figure 27: Illustration of the geometry created in this example.

[ Note:

¢ The example does not use the fastest or most effective way to create geometry, but
instead it highlights a subset of tools available in CADFEKO to create complicated
geometrical structures.

[/ Note:

e This example is not intended for running the Solver. No electromagnetic solution is
performed and no results are presented.
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2.2 Topics Discussed in this Example

Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:
e CADFEKO

o Launch CADFEKO.
o Define variables to create a parametric model.
o Add a custom workplane.
o Create a rectangle.
o Create a line.
- Create a cuboid by sweeping the rectangle along the line.
o Create a flare.
> Union the flare and cuboid to ensure the parts are electrically connected.
o Remove a redundant face in the flare to create a horn.
> Add a feed pin to the line.
> Use automatic selection in the 3D view.
o Create an ellipse and subtract the shape from the cuboid face to create a hole.

Note: Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Qi

o Tip: Find the completed model in the application macro Iibrary[5]:

GS 2: Model Construction

5. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.

J\ ALTAIR
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2.3 Example Prerequisites

Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

Feko 2022.1 or later should be installed.

[ ]
It is recommended that you watch the demo video before attempting this example.

e This example should not take longer than 40 minutes to complete.

|5/ Note: When using CADFEKO over a remote desktop connection, you may need to enable 3D
support for remote desktop[G] for the host's graphics card should a crash occur when clicking

New Project in CADFEKO.

See the Troubleshooting section in the Appendix of the Feko User Guide for more details.

J\ ALTAIR
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2.4 Creating the Model in CADFEKO

Create the model geometry using the CAD component, CADFEKO.
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2.4.1 Launching CADFEKO (Windows)

There are several options available to launch CADFEKO in Windows.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.

s Altair Feko 2022.1 - *

File Home Documentation  Utilities

» » »

&c &p & EDITFEKO “p' Zw LA |~ e =4,
CADFEKO POSTFEKD QUELEFEKO ProMan WallMan AMan | .2 | newFASANT | WRAP  SAM Chedk for  Terminal
Updates
Feko WinProp newFASANT WRAP Tools

Figure 28: The Launcher utility.

e Open CADFEKO by double-clicking on a .cfx file.
e Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

[5/ Note: If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

2.4.2 Launching CADFEKO (Linux)

There are several options available to launch CADFEKO in Linux.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.
e Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:
/home/user/2022.1/altair/feko/bin/cadfeko

e Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

/home/user/2022.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.
[/ Note: Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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2.4.3 Building a Horn

Learn to create variables, workplanes and primitive shapes. Continue by combining these basic entities
and modifying their properties.
5/ Note: To demonstrate the path sweep tool, the cuboid in this example is constructed using
a rectangle and the path sweep tool.

J\ ALTAIR
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Adding Variables

Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.
1. Open the Create Variable dialog using one of the following workflows:
® On the Construct tab, in the Define group, click the _Ix Add Variable icon.
e On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Construct | Configuration

Items Y H5F v

v Definitions A
“ Wariables i
o0 = 1/sqrifeps0™mul)
eps0 = 8.35413?31?51Eg; Edit Variahles
mul = pi*de-7
pi = 3.14159265358979323846
zfl = sgri{mul/epsl)
MNamed Points
[ Media
Workplanes
A Field/Current Data
Waork Surfaces
E}Ts Cables
¥ Model
Geometry v

1. Add Variable #

Figure 29: The model tree (Construction tab).

On the model tree, click the & 3 icon. From the drop-down list, select Add Variable.

- -
I Add Variable #
& Add Point
E Media v
A Field/Current Data 4
AL Add Workplane Fo
{{) Cable Definition v
% Port ’
[ Mesh Refinement 4
- Solution Settings ’
T

Figure 30: The E|=,i| drop-down list available in the model tree.

e Press # to use the keyboard shortcut.

J\ ALTAIR
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2. Create the following variables:

Name

Width

Length
BottomDepth
BottomWidth
FlareLength
TopWidth

TopDepth

O Tip:

Expression
1

1

p.52

Comment [Optional]
Width of rectangle.
Length of rectangle.
Bottom depth of flare.
Bottom width of flare.
Length of flare.

Top width of flare.

Top depth of flare.

¢ Create Variable

Label |Width

Expression |1

Comment |

Value [x

7 Limit

Create

Add

Close

Figure 31: The Create Variable dialog.

e Click Add to keep the Create Variable dialog open and add more variables.

e Click Create to add a variable and close the Create Variable dialog.

Proprietary Information of Altair Engineering
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Defining a Workplane

Define a workplane to create an oblique plane. Workplanes simplify the process of creating geometry on
oblique planes in comparison to using transforms.

The use of workplanes during construction is not compulsory, but is a more efficient method for creating
geometry. For this example you will create a custom workplane and set as the default workplane.

5/ Note: A workplane can be defined relative to another workplane.

1. Open the Create Workplane dialog using one of the following workflows:
* On the Construct tab, in the Define group, click the .1, Add Workplane icon.

¢ On the model tree, a right-click context menu is available on the Workplanes group. Select
Add Workplane from the drop-down list.

Construct | Configuration

Items Y HE -
* Definitions

Variables

Marmed Points

' Media

Global XZ
Global ¥Z
A Field/Current Data
Work Surfaces
EETE Cables
Model

Figure 32: The Add Workplane group is available on both
the Construct and Configuration tabs in the model tree.

On the model tree, click the & 4 icon. From the drop-down list, select Add Workplane.

e Press F9 to use the keyboard shortcut.
2. On the Create Workplane dialog, from the drop-down list, select Global YZ.
3. Use the default workplane label, Workplanel.

J\ ALTAIR
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s¢ Create Workplane *
Predefined workplane

Global ¥Z w
Origin

U lo.0 |
v |00 |
N |o.0 |
U Vector

U Lo |
v |00 |
N |o.0 |
V Vector

U |00 |
v [Lo |
N |o.0 |
Label [warkplane1 |
Create Add Close

Figure 33: The Create Workplane dialog.

4. Click Create to create the workplane and to close the dialog.

The default workplane is used when creating new geometry primitives. For this example, set the new
workplane as the default workplane.

5. In the model tree, select Workplanel.
a) From the right-click context menu, select Set as default.

Construct | Configuration

Items Y 5F -
v Waorkplanes ~
Global XY [Default]
Global XZ
Global YZ
i Workplanel

E3 Delete Del

fer Rename F2

(ﬁ! Copy (Duplicate) Ctrl+K
Copy Special 4

Set az default

Transforms L4

@ Properties

Figure 34: The right-click context menu options for workplanes.
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5/ Note: The current default workplane is indicated by the text, [ Default].

Construct | Configuration

Items Q? 5F
~ Workplanes A
Global XY
Global ¥Z
Global ¥Z
1. Workplanel [Defautt] .

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1
2 Creating CADFEKO Models

p.56
Creating a Rectangle

Create a rectangle to be used in the construction of the horn.

1. On the Construct tab, in the Create Surface group, click the [ ] Rectangle icon.

s¢ Create Rectangle *

Geometry Waorkplane
Definition methods
Base centre, width, depth e
Ha

-
v

W
<c*
G

I

Base centre (C)

U lo.0 | @
v |00 | @
N |o.0 | @

Dimensions

width (W) [1 |
Depth (D) |1 |

Label |[Rectangle1 |

Create Add Close

Figure 35: The Create Rectangle dialog.

]

Note: Default values are used on geometry creation dialogs to allow a preview in the
3D view. You may change the values as required.

& Tip: An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctri+Shift+left click on a variable or named point in the model tree.

2. Create a rectangle using the Base centre, width, depth definition method.
a) Use the following dimensions:

e Base centre (C): (0, 0, 0)
e Width (W): 1
e Depth (D): 1

3. Click Create to create the rectangle and to close the dialog.
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Figure 36: The rectangle created using Workplanel.

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1

2 Creating CADFEKO Models p.58

Creating a Line

Create a line to be used in the construction of the horn. This line will be used to create a cuboid by
sweeping the rectangle along the line.

1. On the Construct tab, in the Create Curve group, click the / Line icon.
2. On the Create line dialog, enter the start point and end point for the line.
e Start point: (0, 0, 0)
e End point: (0, 0, 1)

s¢ Create Line >
Geometry Waorkplane
o P2
w2 /
s
Start point
Ul | @
Vo | @
N o | @
End point
Ul | @
v o | @
N1 | @
Label [Line1 |
Create Add Close

Figure 37: The Create Line dialog.

3. Click Create to create the line and to close the dialog.

Figure 38: The rectangle and line created using Workplanel.
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Creating a Cuboid by Sweeping a Rectangle along a Line

Create a cuboid by sweeping the rectangle along a line (path).

o

Tip: For demonstrative purposes, a rectangle is swept along a path to create a cuboid.
The preferred method to create a cuboid is to make use of the cuboid tool.

1. In the model tree, select Rectanglel.

5/ Note: Selecting Rectanglel in the model tree enables Path Sweep on the ribbon

2. 0On the Construct tab, in the Extend group, click the £ Path Sweep icon.

sc Path Sweep X

Geometry Workplane
Path |

Geometry to sweep

1 Rectanglel

Options

Alignment MNormal

Twist angle |u

Scale factor |1

lUse default path end orientation

Label [pathsweepl

Create

Cancel

Figure 39: The Path Sweep dialog.

3. In the model tree, click Linel to use as path.

4. On the Path Sweep dialog, use the default values.

5. Click Create to create the path sweep and to close the dialog.

z

Figure 40: The rectangle swept along a path (line) to create a cuboid.
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Creating a Flare

Create a flare primitive to be used in the construction of the horn.

1. On the Construct tab, in the Create Solid group, click the /} Flare icon.
2. Create the flare using the Base centre, width, depth, height, top width, top depth method.

sc Create Flare *
Geometry Waorkplane
Definition methods
| Base centre, width, depth, height, top width, top depth L
H '

Dt

Base centre (C)

U loo ||
V |oo ||
N |o.o ||

Dimensions
Bottom width (Wh) |1

|

Bottom depth (Db) |1 |
Height (H) [1 |
Top width (Wt) 0.2 |
|

Top depth (DY) 0.4

Label |Flare1 |

Create Add Cloze

Figure 41: The Create Flare dialog.

3. Specify the flare dimensions using one of the following workflows:
e Add the defined variables manually.

Select a field on the Create Flare dialog and use point-entry to enter the values.

[E/ Note: An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctri+Shift+left click on a variable or named point in the model tree.

Use the following dimensions:
 Base centre (C): (0, 0, 0)
o Bottom width (Wb): BottomWidth
o Bottom depth (Db): BottomDepth
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e Height (H): -FlareLength
e Top width (Wt): TopWidth
e Top depth (Dt): TopDepth

© Tip: Parametric models are the preferred construction method. A parametric model
updates automatically when updating a defined variable.

Alternatively, use values instead of defined variables.

4. View the preview of the flare in the 3D view. Confirm that the model looks correct.

Figure 42: The preview of the flare is indicated in green.

5. Click Create to create the flare and to close the dialog.

J\ ALTAIR
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Creating a Union of the Flare and Cuboid

Union the flare and cuboid to create the horn.

p.62

[E/ Note: The union operation is used to define connectivity between parts.

Parts that touch, but are not unioned, are not considered to be physically connected and will
result in an incorrect mesh.

1. In the model tree, select the flare and the cuboid (PathSweep1l).

Construct | Configuration

Items q-? 5F -
Definitions ~
v Model
v Geometry
0 Flarel
,£ PathSweep1 o

Figure 43: The Construction tab in the model tree showing the selected Flarel and PathSweep1.

2. Union using one of the following workflows:

® On the Construct tab, in the Modify group, click the @ Union icon.

e Press U to use the keyboard shortcut.

Construct | Configuration

Items %? 5F -
Definitions ~
¥ Model
¥ Geometry
hd ’:@ Union1
P Flarel
A PathSweep! v

Figure 44: The Construction tab in the model tree showing the unioned part, Union1.
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Removing Redundant Geometry Faces

Delete the redundant faces in the geometry to create a horn.

1.
2.

In the model tree, select Unionl.

In the details tree, under Faces, go through the list of faces. For each face, click on ' to hide the
face until only Facel3 and Facel4 are displayed.
a) Select Facel3 and Facel4.

Details 7
Unicenl 9 ﬁ %
> Edges
~ Faces
rr Facel_ . Mo
rr Facel_2 . Mo
rr Facel 4 . Mo
P race1 s [ MaM
rr Facel B . Mo =
P race2 B MaM
P race2 B MaM
rr Facell . Mo
rr Facell . Mo
P Face1z [ MaM
P Face12 [ MaM
> Regions

Figure 45: Select the two redundant faces.
b) From the right-click context menu, click Delete.

[/ Note: Deleting one of a regions's enclosing faces, removes the PEC region.

c) Select any of the remaining faces and from the right-click context menu, click Show All.

z

Figure 46: The redundant faces were deleted.
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2.4.4 Adding a Feed Pin to the Horn

Add a wire feed to the model. As this example is only for demonstration purposes, this example does
not cover the adding of a port or source to the wire feed.
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Creating the Feed Wire

Create a wire feed for the model.

1. On the Construct tab, in the Create Curve group, click the / Line icon.

2. On the Create Line dialog, click the Workplane tab.

a) On the Workplane tab, select Custom workplane.

b) Under Origin, click on X field to make point-entry active (indicated by a yellow outline).
3. Press Ctrl+Shift while moving the mouse cursor over the bottom face centre of the cuboid.

= Note: The circles with a black outline indicate special shapping points. The red outline
indicates the position of the mouse cursor.

Use snapping points to snap the workplane to an object. Although only special
snapping points are indicated, you can snap to any point in the 3D view.

4. Press Ctrl+Shift+left click to snap the workplane to the bottom face centre of the cuboid.
5. On the Create Line dialog, click the Geometry tab.
a) Create a line.
e Start point: (0, 0, 0)
e End point: (0, 0, 0.25)
e Label: Feed
6. Click Create to create the line and to close the dialog.

Z

Figure 47: The feed wire is selected (highlighted in yellow).
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Unioning the Feed Wire and Horn

Union the feed wire and horn to ensure mesh connectivity and a correct mesh.
1.

2.
3.
4

In the model tree, expand Union1.

In the model tree, select Feed and drag it to below Union1.
From the right-click context menu, select Move in.

View the model tree and confirm that it is correct.

Construct | Configuration

Items i? 5F -
¥ Model ~
v Geometry
A '@) Union1
/ Feed
0 Flarel
£ PathSweep1 W

p.66

Figure 48: Union by dragging as item into a union in the model tree.
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2.4.5 Using Selection in the 3D View

Use the selection type tool to highlight an element in the 3D view.

The following steps are not required for constructing the model, but it illustrates how selection works in
CADFEKO.

1. Move the mouse cursor to one of the faces on the inside of the flare.

2. Click on a face.

Figure 49: The part is selected and highlighted in yellow.

3. Click again on the face.

Figure 50: The face is selected and highlighted in yellow.

=l  Note:

The default selection method (Auto) cycles through the applicable selection types
when repeatedly clicking on the model.

The first click selected the part. The second click selected the face.

4. Change the selection type using one of the following workflows:

® On the Tools tab, in the Selection group, click the f%i Selection Type icon.

® On the status bar, click f%i Selection Type icon. Select the required selection type from the

list. selection: @ O

J\ ALTAIR
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2.4.6 Creating an Aperture in a Face

Create an aperture (hole) in a face or region by using the subtract tool. Create the geometry to be

removed and subtract it from the target part. The target is the part that is reduced by cutting away a
section of the part.
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Creating and Placing the Ellipse
Create an ellipse to subtract from the horn. The ellipse is placed on the face of the horn.
1. On the Construct tab, in the Create Surface group, click the () Ellipse icon.
2. On the Create Ellipse dialog (Geometry tab), create an ellipse using the following dimensions:
e Centre point (C): (0, 0, 0)
¢ Radius (Ru): 0.3
e Radius (Rv): 0.2
3. On the Create Ellipse dialog, click the Workplane tab.
a) On the Workplane tab, select Custom workplane.
b) Under Origin, click on X field to make point-entry active (indicated by a yellow outline).

c) Move the mouse cursor over the flare while holding down Ctri+Shift until the local workplane
is orientated as displayed in the image.

Figure 51: The placement of the ellipse on the horn.

5/ Note: The history of from where the mouse cursor was moved to the face
centre, affects the orientation of the workplane.

4. Click Create to create the ellipse and to close the dialog.
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Subtracting the Ellipse from the Horn

The ellipse is subtracted from the horn to create a hole.
1. In the model tree, select Ellipsel.
2. Subtract using one of the following workflows:

® On the Construct tab, in the Modify group, click the Q Subtract From icon.

¢ On the model tree, a right-click context menu is available on the primitive. From the list

select Apply > Subtract From.

Figure 52: The ellipse was subtracted from the horn.

3. In the model tree, select Union1.

5/ Note: The T in the model tree indicates the target (object that was subtracted from).

Construct | Configuration

Items ? I£|]Z'v
> Definitions
v Model
~ Geometry
v Q Subtractl
D Ellipsel
v T @ Union
/ Feed
P Flarel

> A& PathSweepl

~
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2.4.7 Setting the Simulation Frequency

Specify the frequency range of interest. For this example, a single frequency point is used

1. On the Source/Load tab, in the Settings group, click the /|| Frequency icon.

2. In the Frequency (Hz) field, enter 1e9.

¢ Solution Frequency

Freguency Export

Single frequency

anced

Frequency (Hz) | 125

OK

Apply

Cancel

Figure 53: The Solution Frequency dialog.

3. Click OK to set the frequency and to close the dialog.
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2.4.8 Saving the Model

Save the model to a CADFEKO. c£x file.

1. Save the model using one of the following workflows:

On the Home tab, in the File group, click the G Save icon.

Press Ctrl+S to use the keyboard shortcut.
2. Save the model as Model creation.cfx.
3. Click Save to close the dialog.
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2.5 Final Remarks

This example showed aspects of model creation in CADFEKO.
1) Important: This example is not an example intended for simulation, but rather an
introductory example that illustrates the power of CADFEKO when creating complex models.
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The example considers a left-handed circular polarised GPS patch antenna on a finite substrate.

This chapter covers the following:

e 3.1 Example Overview (p. 75)

e 3.2 Topics Discussed in Example (p. 76)

e 3.3 Example Prerequisites (p. 77)

e 3.4 Creating the Model in CADFEKO (p. 78)

e 3.5 Launching the Solver (p. 110)

e 3.6 Viewing the Results in POSTFEKO (p. 111)
e 3.7 Final Remarks (p. 117)
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3.1 Example Overview

Calculate the input reflection coefficient and circular components of a left-handed circular polarised GPS
patch antenna on a finite substrate close to 1.57 GHz.

Figure 54: The chamfered GPS patch antenna on a finite substrate.
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3.2 Topics Discussed in Example

Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:
e CADFEKO

o Activate macro recording of a model.
o Changing the model unit.
> Create and group variables.
> Create a dielectric.
> Create geometry (polygon, cuboid and line).
o Set the region of a cuboid to dielectric.

Set the faces of a dielectric cuboid to PEC!”!,

o Add a voltage source to a wire segment.
> Modify the auto-generated mesh.
> Add a far field request.
o Deactivate macro recording and run the resulting Feko Lua script.
o Run the Solver.
e POSTFEKO
> View the input reflection coefficient on a Cartesian graph.
> View the left-hand and right-hand circular components of the far field on a Cartesian graph.

Note: Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

[

o Tip: Find the completed model in the application macro Iibrary[g]:

GS 3: GPS Patch Antenna

perfect electric conductor

The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.

J\ ALTAIR
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3.3 Example Prerequisites

Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

Feko 2022.1 or later should be installed.

[ ]
It is recommended that you watch the demo video before attempting this example.

e This example should not take longer than 40 minutes to complete.

|5/ Note: When using CADFEKO over a remote desktop connection, you may need to enable 3D
support for remote desktop[g] for the host's graphics card should a crash occur when clicking

New Project in CADFEKO.

See the Troubleshooting section in the Appendix of the Feko User Guide for more details.

J\ ALTAIR
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3.4 Creating the Model in CADFEKO

Create the model geometry using the CAD component, CADFEKO.
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3.4.1 Launching CADFEKO (Windows)

There are several options available to launch CADFEKO in Windows.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.

s Altair Feko 2022.1 - *

File Home Documentation  Utilities

» » »

&c &p & EDITFEKO “p' Zw LA |~ e =4,
CADFEKO POSTFEKD QUELEFEKO ProMan WallMan AMan | .2 | newFASANT | WRAP  SAM Chedk for  Terminal
Updates
Feko WinProp newFASANT WRAP Tools

Figure 55: The Launcher utility.

e Open CADFEKO by double-clicking on a .cfx file.
e Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

[5/ Note: If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

3.4.2 Launching CADFEKO (Linux)

There are several options available to launch CADFEKO in Linux.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.
e Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:
/home/user/2022.1/altair/feko/bin/cadfeko

e Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

/home/user/2022.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

[/ Note: Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.

J\ ALTAIR
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3.4.3 Activating Macro Recording of Model

Use macro recording to record actions in a script. Play the script back to automate the process or view

the script to learn the Lua-based scripting language by example. Macro recording allows you to perform
repetitive actions faster and with less effort.

[E/ Note: This step is optional when creating a model in CADFEKO but it is included in this
example to highlight the functionality.

Activate macro recording using one of the following workflows:
L]

On the Home tab, in the Scripting group, click the % Record Macro icon.

® Click the Ef% icon in the status bar.
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3.4.4 Setting the Model Unit

Set the model unit to millimeters.
The default unit length in CADFEKO is metres. Since the structure that you will build is small, the model
unit is set to millimetres. All dimensions entered will be in the new model unit.

1. Set the model unit to millimetres using one of the following workflows:

® On the Construct tab, in the Define group, click the Eﬁ“‘ Model unit icon.

km

On the status bar, click Unit: m.

2. On the Model Unit dialog, select Millimetres (mm).
3. Click OK to change the model unit to millimetres and to close the dialog.

¢ Model Unit *

Unit

(®) Millimetres (mm)
() Centimetres {cm)
() Metres (m)

() Inches (n)

() Feet (ft)

() Spedifiy

oK Apply Cancel

Figure 56: The Model Unit dialog.
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3.4.5 Adding Variables

Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.
1. Open the Create Variable dialog using one of the following workflows:
]

On the Construct tab, in the Define group, click the _Ix Add Variable icon.

e On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Construct | Configuration

Items Y H5F v

v Definitions A
“ Wariables i
o0 = 1/sqrifeps0™mul)
eps0 = 8.35413?31?51Eg; Edit Variahles
mul = pi*de-7
pi = 3.14159265358979323846
zfl = sgri{mul/epsl)
MNamed Points
[ Media
Workplanes
A Field/Current Data
Waork Surfaces
E}Ts Cables
¥ Model
Geometry v

1. Add Variable #

Figure 57: The model tree (Construction tab).

On the model tree, click the & 4 icon. From the drop-down list, select Add Variable.

- -
I Add Variable #
& Add Point
E Media v
A Field/Current Data 4
AL Add Workplane Fo
{{) Cable Definition v
% Port ’
[ Mesh Refinement 4
- Solution Settings ’
T

Figure 58: The E|=,i| drop-down list available in the model tree.

e Press # to use the keyboard shortcut.

J\ ALTAIR
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2. Create the following variables:

Name Expression Unit
patch_size 18.8 mm
chamfer_d 4.3 mm
feed_pos -6.4 mm
substrate_w 45 mm
substrate_d 45 mm
substrate_h 5 mm
ceramic_epsR 5.6
ceramic_tanD 0.0041
¢ Create Variable b
Label |patch_size

Expression | 13.3

|
|
Comment | |
|

Value | 13.8

] vLimit

Create Add Close

Figure 59: The Create Variable dialog.

O Tip:
e Click Add to keep the Create Variable dialog open and add more variables.
¢ Click Create to add a variable and close the Create Variable dialog.

3. [Optional] Group the variables related to the patch.
a) In the model tree, under Variables, select patch_size and chamfer_d.

© Tip: To select multiple objects, press and hold Ctrl while you click the items.

b) From the right-click context menu, select Group > Create.
c) Select Groupl and from the right-click context menu, click Rename.
d) Rename the group to pPatch.
4. [Optional] Group the variables related to the substrate.
a) In the model tree, select substrate_w, substrate_d and substrate_h.

J\ ALTAIR
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b) From the right-click context menu, select Group > Create.
c) Select Group2 and from the right-click context menu, click Rename.

© Tip: Press F2 to use the keyboard shortcut to rename a selected item.

d) Rename the group to Substrate.

J\ ALTAIR
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3.4.6 Defining a Dielectric Medium

Define a lossy frequency-independent dielectric with a relative permittivity (¢;) = 5.6 and a dielectric
loss tangent (tand) = 0.0041 to be used as the patch substrate.

1. Open the Create Dielectric Medium dialog using one of the following workflows:
® On the Construct tab, in the Define group, click the % Media icon. From the drop-down
list, click the () Dielectric icon.

e On the model tree, a right-click context menu is available on Media. From the list, click
Dielectric Medium.
Two variables (ceramic_epsR and ceramic_tanD) were added to the model to define the dielectric.
2. Set the Relative permittivity (¢;) to ceramic_epsR.
3. Set the Dielectric loss tangent (tand) to ceramic_tanD.

sc Create Dielectric Medium *

(® Manually define medium
() Import medium from file

Dielectric modelling Magnetic modelling

Definition method Freguency independent | ?
Conductivity type Dielectric loss tangent b
Relative permittivity (£, |ceramic_epsR |

Diglectric loss tangent (tan &) |ceramic_tanD |

Mass density (g, kg/m) | 1000.0 |

Label |ceramic |

Create Add Cloze

Figure 60: The Create Dielectric Medium dialog.

4. Set the Label to Ceramic.
5. Click Create to create the dielectric and to close the dialog.

5/ Note: In the model tree, the defined dielectric is displayed under Dielectric. CADFEKO
assigns a colour to each medium randomly but the colour may be changed by using the
Change Display Colour right-click context menu option.

Construct | Configuration

Items ¥ =5r
v [ Media ~
Perfect electric conductor
Perfect magnetic conductor
. Free space
A f_? Dielectric
. Ceramic ]
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3.4.7 Creating the Patch

Create the chamfered!'®’ patch using a polygon.

1. On the Construct tab, in the Create Surface group, click the @ Polygon icon.

s¢ Create Polygon *
Geometry Waorkplane
C1 “CB
n+
Vv c2 C5 %
u - r.|
- c3)
C4 L
Corner 1
U o &
U &
N o &
1 (0,00
2 (1.0,0
3 01,0
Add row Remove row
Import points
Rewverse normal
Label |Palygoni
Create Add Close

Figure 61: The Create Polygon dialog showing the default values. Active fields are outlined in yellow

[/ Note: Default values are used on geometry creation dialogs to allow a preview in the

3D view. You may change the values as required.

@ Tip: An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctrl+Shift+left click on a variable or named point in the model tree.

2. Under Corner 1, add the following coordinates:
e Corner 1:
o U: patch_size
o V: patch_size
o N: substrate_h

10. An edge created at 45° between two adjoining right-angled edges.

p.86
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3. In the table, click on the second row to make Corner 2 active. Add the following coordinates:
e Corner 2:
o U: -patch_size + chamfer_d
o V: patch_size
o N: substrate_h
4. Click on the third row to make Corner 3 active. Add the following coordinates:
e Corner 3:
o U: -patch_size
o V: patch_size - chamfer_d
o N: substrate_h
5. Click Add row for Corner 4. Add the following coordinates:
e Corner 4:
o U: -patch_size
o V: -patch_size
o N: substrate_h
6. Repeat Step 5 twice to add Corner 5 and Corner 6 using the following coordinates:
e Corner 5:
o U: patch_size - chamfer_d
o V: -patch_size
o N: substrate_h
e Corner 6:
o U: patch_size
o V: -patch_size + chamfer_d
o N: substrate_h
7. Set the Label to patch.

J\ ALTAIR
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s¢ Create Polygon =

Geometry | Waorkplane

| Corner &

U |patch_size |
v |—patd'1_siz'e + chamfer_d |

N |substrate_h |

1 (18.8,18.8, 5)
(-14.5,18.8, 5)
(-18.8,145,3)
(-18.8, -18.8, 5)
(14.5,-18.8, 3)
(18.8, -14.5, 5)

[= T T S O R X ]

[ Add row l [ Remove row

|
[ Import points |
[ Reverse normal |
|
|

Label [patch
[ Create ] l Add ] l Close

Figure 62: The Create Polygon dialog.

8. Click Create to create the polygon and to close the dialog.

Figure 63: Top view of the chamfered patch. Note that the face is set to perfect
electric conductor (PEC) by default (PEC is indicated by the colour orange).
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3.4.8 Creating the Patch Substrate

Create a finite substrate!!!] by creating a cuboid. Set the region of the cuboid to the medium, ceramic.
Create the cuboid.

a) On the Construct tab, in the Create Solid group, click the (j Cuboid icon.
b) Create the cuboid using the Base corner, width, depth, height definition method.
c) Use the following dimensions:

e Base corner (C): (-22.5, -22.5, 0)

e Width (W): substrate_w

e Depth (D): substrate_d

e Height (H): substrate_h

e Label: substrate

¢ Create Cubeid *

Geometry Workplane
Definition methods
Base corner, width, depth, height e

Ha

WS
I: e

Base corner (C)

U 225 | fa
v [22s | fa
N [o.0 | f@

Dimensions

Width (W) |substrate_'..\' |
Depth (D) [substrate_d |
Height (H) [substrate_h |

Label |substrate |

Create Add Close

Figure 64: The Create Cuboid dialog.

d) Click Create to create the substrate and to close the dialog.

11. An alternative method is to model the substrate using an infinite planar multilayer substrate. See
the Feko Example Guide for an example.
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3.4.9 Setting a Region to a Dielectric

Change the region property of the substrate to dielectric.
1. In the model tree, select substrate.
2. In the details tree, under Regions, select Region1l.
3. From the right-click context menu, select Properties.

Details
substrate 9 ﬁ 5:'_1}
Edges
Faces
v Regions
@ Region] MMerfart locteic o] ccn
o i Wi Delete Del
fer Rename F2

e Copy (Duplicate)
Create Port L4

Show / Hide Ctrl+H
Show Only in Collection
Show Only
Show All
Set Mot Suspect
E:; Zoom to Selection

Select All Ctrl+A
Select All in Part Ctrl+Shift+4A
E Properties

Figure 65: The right-click context menu options available for regions.

4. On the Modify Region dialog (Properties tab), set Medium to Ceramic.

<t Modify Region *

Properties Meshing Solution
Region medium
Medium | Perfect electric conductor w |

Perfect electric conductor
Free space

58 Creale new...

0K Apply Cancel

Figure 66: The Modify Region dialog.

i Tip: Simplify workflow by using |i|;,';| Create new to define items when needed.

5. Click OK to modify the region property and to close the dialog.
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5 Note: The O icon in the model tree and details tree indicate items set to dielectric.

Construct | Configuration

Ttems Y S+~
Definitions
v Model
¥ Geometry

{f_] patch
Ga substrate

~

Details

substrate 9 ;ﬁ E.:‘}

Edges

Faces
~ Regions

(P Regionl [Ceramic] [l SEP
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3.4.10 Creating the Feed Pin

Create the feed pin using a single line element.

1. On the Construct tab, in the Create Curve group, click the / Line icon.

2. On the Create Line dialog, enter the start and end point for the line.
e Start point: (0, feed_pos, 0)
e End point: (0, feed_pos, substrate_h)
e Label: feed line

sc Create Line *
Geometry Waorkplane
" 72
u/~ PL~
3 o
Start point
Ul | @
¥ |feed_pos | &
N o | @
End point
Ul | @
¥ |feed_pos | &
N |substrate_h | &
Label [feed_line |
Create Add Close

Figure 67: The Create Line dialog.

3. Click Create to create the line and to close the dialog.
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3.4.11 Unioning the Geometry for Mesh Connectivity

Union the geometry (feed_line, patch and substrate) to create a single geometry part. A single
geometry part will ensure mesh connectivity when the model is meshed.
1. 1n the model tree, select feed_line, patch and substrate!?.

© Tip: To select multiple objects, press and hold Ctrl while you click the items.

* Model ~
v Geometry
/ feed line
A patch
Go substrate v

Figure 68: The three geometry parts in the model tree.

2. 0On the Construct tab, in the Modify group, click the @ Union icon.

v Model A
¥ Geometry
hd @@ Union1
/" feed_line
.rf:] patch
[?C? substrate ]

Figure 69: The model tree showing Union1 (the union between feed_line, patch and substrate).

12. Alternative method is to select the items in the 3D view.

J\ ALTAIR
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3.4.12 Setting Faces to PEC

Change the surface property of the patch to perfect electric conductor (PEC).

1. Change the face of the patch to PEC.

a) In the 3D view, left-click on the patch face repeatedly until the face is highlighted in yellow.

Figure 70: Top view of patch and substrate. The yellow
highlighting indicates that the patch face is selected.

b) From the right-click context menu, select Properties.

c) On the Modify Face dialog (Properties tab), set the Medium to Perfect electric

conductor.

¢ Modify Face
Properties Meshing Solution

Face medium

Coating
(] Apply coating

OK

Medium | Perfect electric conductor

Apply

Cancel

g

Figure 71: The Modify Face dialog.

d) Click OK to change the face property and to close the dialog.

Figure 72: Top view showing the face of the patch set to PEC.

2. Change the face of the bottom substrate to PEC.
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a) In the model tree, under Union1, select substrate.

b) In the details tree, under Faces, go through the list of faces. For each face, click on Gﬁ to
hide the face until only the bottom face of the substrate remains.

Details
Union1 6;' ,ﬁ \"“ “
] MoM
Py Mol
] MoM
] MoM
G[i Faceb Mol
] MoM
PP MoM v

Figure 73: Hidden items are greyed out when hidden in the 3D view.

¢) From the right-click context menu, select Properties.
d) On the Modify Face dialog (Properties tab), set Medium to Perfect electric conductor.
e) Click OK to modify the face property and to close the dialog.

Figure 74: Bottom view showing the bottom substrate face set to PEC.

f) In the details tree, click on any of the faces. From the right-click context menu, click
Show All to make faces visible again.

5 Note: The icon in the details tree indicate faces set to PEC.
Details
Unicn1 ﬁ ﬁ h; ~
@ﬁ Face2 Mo
@ﬁ Facel Mo
(PP Faced MaoM
@ﬁ Face3 Mo
@ﬁ Facef Mo
@ﬁ Face? Mo
@ﬁ Facel Mo %
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3.4.13 Ports, Sources and Loads in CADFEKO

Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Creating the Port

Define a wire port on the feed pin. A voltage source will be added to this port.

[/ Note: A portis a mathematical representation of where energy can enter (source) or leave
a model (sink). Use a port to add sources and discrete loads to a model.

1. Open the Create Wire Port dialog using one of the following workflows:

On the Source/Load tab, in the Ports group, click the /,“’ Wire Port icon.

¢ In the details tree, a right-click context menu is available on the wire. From the list, click

Create port > Wire Port.
2. Select the wire where the port is to be added.
a) In the model tree, select feed_line.
b) In the details tree, select the wire of feed_line.
3. Under Location on wire, select Start.

¢ Create Wire Port *

Edge |Unioni.feed_line.Edgeis |

Place port on
@ Segment O Vertex

[] reverse polarity

Label [port1

Create Add Cloze

Figure 75: The Create Wire Port dialog.

4. Click Create to create the port and to close the dialog.
5. Change the label to port1.
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Adding a Voltage Source

Add a voltage source to the port of the pin.

p.98

1. On the Source/Load tab, in the Sources on Ports group, click the @ Voltage Source icon.

2. On the Add Voltage Source dialog, use the default settings.

Port | Portl
Voltage
Magnitude

Phase

s Create Voltage Source

[1o

0.0

Reference impedance (Ohm) |50.D

Label |uo|tage50urce1

Create

Add

Cloze

Figure 76: The Create Voltage Source dialog.

3. Click Create to define the voltage source and to close the dialog.

[l Note: The Configuration tab was selected automatically when you defined the

voltage source. You may also add sources, loads and set the frequency from here.
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3.4.14 Setting the Simulation Frequency

Specify the frequency range of interest. For this example continuous frequency sampling is used where
Feko automatically determines the frequency sampling for optimal interpolation.

1. On the Source/Load tab, in the Settings group, click the /|| Frequency icon.

2. On the Solution Frequency dialog, from the drop-down list, select Continuous (interpolated)
range.
3. In the Start frequency (Hz) field, enter 1.27e09.

4. In the End frequency (Hz), enter 1.85e09.

¢ Solution Frequency >

Freguency Export Advanced

Continuous (interpolated) range v

Start frequency (Hz) |1,2;'Eg |

End frequency (Hz) |1,3559 |

0K Apply Cancel

Figure 77: The Solution Frequency dialog.

5. Click OK to specify the frequency and to close the dialog.
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3.4.15 Modifying the Auto-Generated Mesh

When the frequency is set or local mesh settings are applied to the geometry, the automatic mesh
algorithm calculates and creates the mesh automatically while the GUI is active using default mesh
settings. When required, these mesh settings may be modified.

The patch requires a finer mesh as the standard mesh sizelt?]

specified.

and a wire segment radius needs to be

1. Open the Modify Mesh Settings dialog using one of the following workflows:
* On the Mesh tab, in the Meshing group, click the € Modify Mesh icon.

e Press Ctrl+M to use the keyboard shortcut.
2. Set the Mesh size to Fine.
3. Set the Wire segment radius to 0.7.

¢ Modify Global Mesh Settings *

Options Advanced
Global mesh sizes
Mesh size | Fine ~
Global wire radius

Wire segment radius ||:|, 7 |

oK Apply Cancel

Figure 78: The Modify Mesh Settings dialog.

4. Click OK to create the mesh and to close the dialog.

Figure 79: Top view of the patch and substrate showing the mesh.

5. View the effect in the 3D view of specifying a Wire segment radius.
a) Press F5 to use the keyboard shortcut to zoom to extents the 3D view.
b) Enable a default cutplane. In the model tree (Construction tab), under Cutplanes, click the

@ icon next to XZ-Cut[M]'

13. See the Feko User Guide Appendix A-3 for more information regarding automatic mesh sizes.

14. To change the default cutplane settings, double-click on the cutplane text (for example, XZ-Cut).
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Construct | Configuration

Items q‘? 'ﬂjv
» Definitions A
v Model
> Geometry
Meshes
» Ports

Meshing Rules
v Cutplanes

& xv-cut
& xz-cut
@ WZ-Cut W

Figure 80: Note that a cutplane icon is greyed out when the cutplane is not active.

Figure 81: The cutplane shows a cross-sectional view of the patch
substrate. Note the thick feedpin as specified by the Wire segment radius.

C) Disable the cutplane. Click the @ button next to XZ-Cut again.
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3.4.16 Setting Local Mesh Sizes for Chamfered Edges
Refine the mesh locally at the chamfered edges

The mesh can be refined globally but will result in an unnecessary large number of mesh elements. A
more efficient approach is to only refine the mesh locally where a finer mesh is required.

[5/ Note: Local mesh refinement takes precedence over global mesh settings.

1. In the 3D view, select a chamfered edge.

,,,,,,,,,,,,,,,,

Figure 82: Top view of patch and substrate. The yellow edge indicates that it is selected.

2. From the right-click context menu, select Properties.

3. On the Modify Edge dialog (Meshing tab), specify the following:
a) Select the Local mesh size check box.
b) Set the Mesh size to 2.

¢ Modify Edge d

Properties Meshing Solution

Mesh size
Local mesh size
Mesh size |1

0K Apply Cancel

Figure 83: The Modify Edge (Meshing tab) dialog.

4. Repeat Step 1 to Step 3 for the second chamfered edge.
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4

Figure 84: Top view of patch and substrate. The second chamfered edge is selected.

5. Click OK to apply the properties and to close the dialog.

Figure 85: Top view of patch and substrate showing the localised mesh refinement at the chamfered edges.

= Note: The i icon in the details tree indicate that a local mesh setting is applied.

Details

Union1 ﬂ & % ~
{ Edgeli7as
{ Edgeli7en
{~ Edgel1800
B~ Edgelizm
{~ Edgelizoz
{ Edgeli803

B~ Edgeliznd v
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3.4.17 Adding a Far Field Request

Add a far field request to the model.

p.104

1. On the Request tab, in the Solution Requests group, click the @ Far Fields icon.

2. On the Request Far Fields dialog, click 3D pattern.

s Request Far Fields

Position Waorkplane Scope Advanced
(@) Calculates fields as spedfied
() Calculates fields in plane wave inddent direction

Coordinate system
(®) Spherical () Cartesian

All angles are in degrees

Horizontal cut (UV plane)
Vertical cut (UM plane)
Vertical cut (WM plane)

3D pattern

Start End

8 oo | || @ [10.0 |
© o ||| @ [0 |
Increment MNumber of field points

8 |50 ||| & [z2 |
o 50 MXE |

Label |FarField1

Create Add Close

Figure 86: The Request Far Fields dialog.

3. Click Create to create a far field request and to close the dialog.
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3.4.18 Deactivating Macro Recording

Deactivate the macro recording of the model, inspect the resulting Feko Lua script and use the script to
recreate the model.

1. Deactivate macro recording using one of the following workflows:
®* On the Home tab, in the Scripting group, click the % Record Macro icon.

® Click the % icon in the status bar.

Macro recording is deactivated. The Script Editor window is displayed containing the Feko Lua script.

s¢ Script Editor - O X
File Edit Zoom Run Help

=B Hd OO0 O M &d 9 FAMd> -

MacroRecordingl® @

1 application = cf.BApplication.getInstance () -

2 —— NewProject

3 project = application:NewProject ()

4

5 —— SetProperties

6 P =}s)s cation.Project.ModelAttributes:GetProperties ()

7 cf.Enums.ModelUnitEnum.Millimetres

8 ject .ModelAttributes: SetProperties (properties)

=

10

11 cf.Variable.GetDefaultProperties ()

12 X¥pression = "18.8"

13 abel = "patch size"

14 application.Project.Definitions.Variables:Add (propertiesl)
< »
< »

Figure 87: The Script Editor window.

2. Save the Feko Lua script.
a) On the Script Editor window, save the Feko Lua script by clicking on the E| icon.

b) On the Save As dialog, browse to a folder and specify a file name.
c) Click Save to save the Feko Lua script and to close the Save As dialog.
3. Open a new project and recreate the model using the Feko Lua script.

a) On the Home tab, in the File group, click the D New Project icon.
b) On the Script Editor window, click the () icon to run the Feko Lua script.

The model is recreated using the Feko Lua script (see Macro Recording of Example 3).

[l Note: For more information regarding scripts and the Feko application programming
interface (API), see the Feko Scripting and API Reference Guide.
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3.4.19 Macro Recording of Example 3

The CADFEKO macro recorded Lua script for Example 3 is given below.

application = cf.Application.getInstance ()

-- NewProject
project = application:NewProject ()

-- SetProperties

properties = application.Project.ModelAttributes:GetProperties()
properties.Unit = cf.Enums.ModelUnitEnum.Millimetres
application.Project.ModelAttributes:SetProperties (properties)

-- Add

propertiesl = cf.Variable.GetDefaultProperties ()

propertiesl.Expression = "18.8"

propertiesl.Label = "patch size"

patch size = application.Project.Definitions.Variables:Add (propertiesl)
-- Add

propertiesl.Expression = "4.3"

propertiesl.Label = "chamfer d"

chamfer d = application.Project.Definitions.Variables:Add (propertiesl)

-- Add

propertiesl.Expression = "-6.4"

propertiesl.Label = "feed pos"

feed pos = application.Project.Definitions.Variables:Add (propertiesl)
-- Add

propertiesl.Expression = "45"

propertiesl.Label = "substrate w"

substrate w = application.Project.Definitions.Variables:Add (propertiesl)

-- Add

propertiesl.Expression = "45"

propertiesl.Label = "substrate d"

substrate d = application.Project.Definitions.Variables:Add(propertiesl)

-- Add

propertiesl.Expression = "5"

propertiesl.Label = "substrate h"

substrate h = application.Project.Definitions.Variables:Add (propertiesl)

-- Add

propertiesl.Expression = "5.6"

propertiesl.Label = "ceramic epsR"

ceramic epsR = application.Project.Definitions.Variables:Add (propertiesl)

-- Add
propertiesl.Expression = "0.0041"
propertiesl.Label = "ceramic tanD"

ceramic_tanD = application.Project.Definitions.Variables:Add (propertiesl)

-— CreateGroup
groupl = application.Project.Definitions.Variables:CreateGroup ()

-— Moveln
groupl:Moveln ({patch size, chamfer d})

-- Setting Label
groupl.Label = "Patch"”

—-— CreateGroup
groupll = application.Project.Definitions.Variables:CreateGroup ()

-— Moveln
groupll:Moveln ({substrate w, substrate d, substrate h})

-- Setting Label
groupll.Label = "Substrate”

-- AddDielectric
properties?2 = cf.Dielectric.GetDefaultProperties()
properties2.DielectricModelling.RelativePermittivity = "ceramic epsR"
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properties2.DielectricModelling.LossTangent = "ceramic tanD"
properties2.Label = "Ceramic"
ceramic = application.Project.Definitions.Media.Dielectric:AddDielectric (properties?2)

-- Setting Colour

ceramic.Colour = "#aa55ff"
-- AddPolygon
properties3 = cf.Polygon.GetDefaultProperties ()
properties3.Corners[1].U = "patch size"
properties3.Corners[1l].V = "patch size"
properties3.Corners[1l].N = "substrate h"
properties3.Corners[2].U = "-patch size + chamfer d"
properties3.Corners[2].V = "patch size"
properties3.Corners[2].N = "substrate h"
properties3.Corners[3].U = "-patch _size"
properties3.Corners[3].V = "patch size - chamfer d"
properties3.Corners[3].N = "substrate h"
properties3.Corners[4] = {}
properties3.Corners[4].U = "-patch size"
properties3.Corners[4].V = "-patch size"
properties3.Corners[4].N = "substrate h"
properties3.Corners[5] = {}
properties3.Corners[5].U = "patch size - chamfer d"
properties3.Corners[5].V = "-patch size"
properties3.Corners[5].N = "substrate h"
properties3.Corners[6] = {}
properties3.Corners[6].U = "patch size"
properties3.Corners[6].V = " -patch size + chamfer d"
properties3.Corners[6].N = "substrate h"
properties3.LocalWorkplane.WorkplaneDefinitionOption
= cf.Enums.LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane

globalXY = application.Project.Definitions.Workplanes:Item("Global XY")

properties3.
properties3.

LocalWorkplane.ReferencedWorkplane = globalXY
Label = "patch"

patch = application.Project.Contents.Geometry:AddPolygon (properties3)

-- AddCuboid

propertiesd

propertiesd.
properties4.
propertiesd.
propertiesd.
properties4.
propertiesd.

= cf.Cuboid.GetDefaultProperties ()
Origin.U = "-22.5"

Origin.v = "-22.5"

Width = "substrate w"

Depth = "substrate d"

Height = "substrate h"
LocalWorkplane.WorkplaneDefinitionOption

= cf.Enums.LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane
propertiesd.LocalWorkplane.ReferencedWorkplane = globalXY
properties4.Label = "substrate"

substrate = application.Project.Contents.Geometry:AddCuboid (propertiesd)
-- SetProperties
properties5 = substrate.Regions:Item("Regionl") :GetProperties ()
properties5.Medium = ceramic
substrate.Regions:Item("Regionl") :SetProperties (propertiesb)

-- AddLine

properties6
properties6.
properties6.
properties6.
properties6.
properties6.
= cf.Enums.
properties6.
propertiesé6.
feed line =

-- AddUnion

= cf.Line.GetDefaultProperties ()

StartPoint.V = "feed pos"
EndPoint.U = "0"
EndPoint.V = "feed pos"
EndPoint.N = "substrate h"

LocalWorkplane.WorkplaﬁgDefinitionOption
LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane
LocalWorkplane.ReferencedWorkplane = globalXY

Label = "feed line"
application.Project.Contents.Geometry:AddLine (properties6)

unionl = application.Project.Contents.Geometry:Union ({patch, substrate,

-- SetProperties

properties?

= unionl.Faces:Item("Face8") :GetProperties ()

feed line})

perfectElectricConductor = application.Project.Definitions.Media.PerfectElectricConductor

properties?7.

Medium = perfectElectricConductor

unionl.Faces:Item("Face8") :SetProperties (properties?)

-- ToggleVisibility
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substrate.Faces:Item("Face2") :ToggleVisibility ()

-- ToggleVisibility

substrate.Faces:Item("Face2") :ToggleVisibility ()

-- SetProperties

properties8 = unionl.Faces:Item("Face6") :GetProperties ()

properties8.Medium = perfectElectricConductor
unionl.Faces:Item("Face6") :SetProperties (propertiess)

-—- AddWirePort

properties9 = cf.WirePort.GetDefaultProperties/()

edgel9 = feed line.Edges:Item("Edgel9")
properties9.Wire = edgel9
properties9.Label = "Portl"”

portl = application.Project.Contents.Ports:AddWirePort (properties9)

—-—- AddVoltageSource

propertieslO = cf.VoltageSource.GetDefaultProperties ()

propertieslO.Terminal = portl

propertiesl0.Label = "VoltageSourcel"

voltageSourcel =
application.Project.Contents.SolutionConfigurations.GlobalSources:AddVoltageSource (propertiesl0)

-- SetProperties

propertiesll = application.Project.Contents.SolutionConfigurations.GlobalFrequency:GetProperties ()
propertiesll.Start = "1.27e9"

propertiesll.End = "1.85e9"

propertiesll.RangeType = cf.Enums.FrequencyRangeTypeEnum.Continuous
application.Project.Contents.SolutionConfigurations.GlobalFrequency:SetProperties (propertiesll)

-- SetProperties

propertiesl?2
propertiesl?2
propertiesl2
propertiesl?2

.MeshSizeOption =
.WireRadius =
.Advanced.GrowthRate =
propertiesl?2.
propertiesl?2.

= application.Project.Mesher.Settings:GetProperties ()
cf.Enums.MeshSizeOptionEnum.Fine
"07"

30
Advanced.RefinementFactor =
Advanced.MinElementSize = 80

80

application.Project.Mesher.Settings:SetProperties (propertiesl?2)

-- ToggleVisibility
application.Project.Contents.Cutplanes:Item("XZ-Cut") :ToggleVisibility ()

-- ToggleVisibility
application.Project.Contents.Cutplanes:Item("XZ-Cut") :ToggleVisibility ()

-- SetProperties

propertiesl3 = unionl.Edges:Item("Edge6") :GetProperties ()
propertiesl3.LocalMeshSizeEnabled = true
propertiesl3.LocalMeshSize = "2"

unionl.Edges:

Item ("Edge6") :SetProperties (propertiesl3)

-- SetProperties

propertiesl4

propertiesl4.
.LocalMeshSize =
unionl.Edges:

propertiesl4

-- Add

propertieslb
propertiesl5
propertiesl5
propertieslb
propertieslb
propertiesl5
propertieslb

.Theta.End =
.Theta.Increment =
.Phi.End =
.Phi.Increment =
.Label =
.LocalWorkplane.WorkplaneDefinitionOption

= unionl.Edges:Item("Edge3") :GetProperties ()
LocalMeshSizeEnabled = true

"2 ”n

Item ("Edge3") :SetProperties (propertiesl4)

= cf.FarField.GetDefaultProperties|()
"180.0"

"5.0"

"360.0"

"5.0"

"FarFieldl"

= cf.Enums.LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane

propertieslb5.

farFieldl =

application.

-— SaveAs

LocalWorkplane.ReferencedWorkplane = globalXY

Project.Contents.SolutionConfigurations:Item("StandardConfigurationl") .FarFields:Add (propertiesl5)

application:SaveAs ("C:/Users/eh/Desktop/Example2.CADFEKO")
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3.4.20 Saving the Model

Save the model to a CADFEKO. c£x file.

1. Save the model using one of the following workflows:

On the Home tab, in the File group, click the G Save icon.

e Press Ctrl+S to use the keyboard shortcut.
2. Save the model as Patch.cfx.

3. Click Save to close the dialog.
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3.5 Launching the Solver

Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

® On the Solve/Run tab, in the Run/Launch group, click the @) Feko Solver icon.

* On the application launcher toolbar, click the Feko Solver icon in the |1 = . % | group.

e Press Alt+4 to use the keyboard shortcut.
If the model contains unsaved changes, the Save Model dialog is displayed.
2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

¢ Bxecuting runfeko X

Model: Patch

¥ Details oK ® stop

Figure 88: The Executing runfeko dialog.
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3.6 Viewing the Results in POSTFEKO

Display the model as well as the results using the post-processor component, POSTFEKO.
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3.6.1 Launching POSTFEKO

Open POSTFEKO from within CADFEKO.
Use one of the following workflows to launch POSTFEKO:

¢ On the Solve/Run tab, in the Run/Launch group, click the <7 POSTFEKO icon.

* On the application launcher toolbar, click the POSTFEKO icon inthe [E =~ = & | group.

e Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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3.6.2 Viewing the Input Reflection Coefficient

View the input reflection coefficient on a Cartesian graph in dB.

1. On the Home tab, in the Create new display group, click the & Cartesian icon.

2. 0On the Home tab, in the Add results group, click the @ Source data icon. From the drop-down

list, select VoltageSourcel.
3. View the input reflection coefficient in dB versus frequency.
a) On the result palette, in the Traces panel, select VoltageSourcel.

b) On the Quantity panel, confirm that Reflection coefficient is selected (default option).
c) On the Quantity panel, select the dB check box.

Traces

VoltageSourcel (AlSource)

¥ Source ~

patch
GPS_antenna -
VoltageSource 1

¥ Slice
Independent axis (Horizontal)

Frequency v
¥ Quantity

Reflection coeffident w
[] Use custom reference impedance

Reference impedance (from source)

50 +j*0 Ohm

[ subtract loading
Impedance

0 +i*0

(® Magnitude
() Phaze
() Real

O Imaginary
de [ normalise

W

Figure 89: The result palette containing the Traces, Source,
Slice and Quantity panels (listed from top to bottom).

4. Change the legend position to bottom-right.

a) On the Display tab, in the Display group, click the Position icon. From the drop-down
list select Overlay bottom right.
5. Remove the graph footer.

a) On the Display tab, in the Display group, click the uz Chart text icon.
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b) In the Graph footer field, clear the Auto check box and delete the text.
c) Click OK to apply the text changes and to close the dialog.

Excitation

Reflection coefficient [dB]

VoltageSource1

1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9
Frequency [GHz]

Figure 90: The input reflection coefficient in dB versus frequency.
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3.6.3 Viewing the Circular Components of the Far Field

1. On the Home tab, in the Create new display group, click the & Cartesian icon.

2. 0On the Home tab, in the Add results group, click the @ Far Field Source icon. From the drop-
down list, select FarField1.
3. Make a copy of the trace, FarField1l.
a) On the result palette, in the Traces panel, select FarField1.
b) Duplicate the trace, FarField1, using one of the following workflows:
e On the Cartesian context tab, on the Trace tab, in the Manage group, click the
‘A= Duplicate trace icon.
e On the result palette, a right-click context menu is available on the trace. From the drop-
down list, select Duplicate trace.
e Press Ctrl+K to use the keyboard shortcut.
A trace with label FarField1_1 is created.
4. Rename the trace, FarField1_1.
a) On the result palette, in the Traces panel, select FarField1_1.
b) Press F2 to use the keyboard shortcut and rename the trace to FarField2.
5. View the left-hand circular component of the far field in dB versus frequency.
a) In the Traces panel, select FarField1.
b) On the result palette, in the Quantity panel, click LHC.
c) On the result palette, in the Quantity panel, select the dB check box.
6. View the right-hand circular component of the far field in dB versus frequency.
a) In the Traces panel, select the duplicate trace, FarField2.
b) On the result palette, in the Quantity panel, click RHC.
c) On the result palette, in the Quantity panel, select the dB check box.
7. [Optional] Repeat Step 4 and Step 5 to change the legend position and remove the graph footer.
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Figure 91: The left-hand circular and right-hand circular components of the far field.
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3.7 Final Remarks

This example showed the construction, configuration and solution of a left-handed circular polarised
GPS patch antenna on a finite substrate.

The input reflection coefficient and circular components of the far field were calculated and displayed.
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The example considers the antenna placement of a GPS patch antenna on a quadcopter.

This chapter covers the following:

e 4.1 Example Overview (p. 119)

e 4.2 Topics Discussed in Example (p. 120)

e 4.3 Example Prerequisites (p. 121)

e 4.4 Creating the Model in CADFEKO (p. 122)
e 4.5 Launching the Solver (p. 134)

e 4.6 Viewing the Results in POSTFEKO (p. 135)
e 4.7 Final Remarks (p. 137)
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4.1 Example Overview

Calculate the input reflection coefficient and circular components of a left-handed circular polarised GPS

patch antenna on a finite substrate close to 1.57 GHz placed on a quadcopter. Compare the results with
that of Example 3.
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4.2 Topics Discussed in Example

The topics discussed in this example are:

e CADFEKO
o Specify the model unit.
o Add a component from the component library.
o Import a model from a .cfx file.
o Create a workplane and perform transformations on the workplane (rotate).
o Use the Align tool for antenna placement.
> Run the Solver.
o Show/hide the simulation mesh in the 3D view.
o Show/hide a part in the 3D view.

e POSTFEKO
> View the Lua script to set up the graphs (similar to Example 2) for the following:

View the input reflection coefficient on a Cartesian graph.

View the left-hand and right-hand circular components of the far field on a Cartesian
graph.

View an example of a Lua script to configure graphs.

Note: Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Qi

o Tip: Find the completed model in the application macro Iibrary[15]:

GS 4: GPS Patch on a Drone

15. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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4.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

e Feko 2022.1 or later should be installed.
It is recommended that you watch the demo video before attempting this example.

e This example should not take longer than 40 minutes to complete.

Note: When using CADFEKO over a remote desktop connection, you may need to enable
3D support for remote desktop[16] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

=

16. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1

4 GPS Patch on Quadcopter p.122

4.4 Creating the Model in CADFEKO

Create the model geometry using the CAD component, CADFEKO.
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4.4.1 Launching CADFEKO (Windows)

There are several options available to launch CADFEKO in Windows.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.

s Altair Feko 2022.1 - *

File Home Documentation  Utilities

» » »

&c &p & EDITFEKO “p' Zw LA |~ e =4,
CADFEKO POSTFEKD QUELEFEKO ProMan WallMan AMan | .2 | newFASANT | WRAP  SAM Chedk for  Terminal
Updates
Feko WinProp newFASANT WRAP Tools

Figure 92: The Launcher utility.

e Open CADFEKO by double-clicking on a .cfx file.
e Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

[5/ Note: If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

4.4.2 Launching CADFEKO (Linux)

There are several options available to launch CADFEKO in Linux.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.
e Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:
/home/user/2022.1/altair/feko/bin/cadfeko

e Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

/home/user/2022.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

[/ Note: Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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4.4.3 Setting the Model Unit

Set the model unit to millimeters.
The default unit length in CADFEKO is metres. Since the structure that you will build is small, the model
unit is set to millimetres. All dimensions entered will be in the new model unit.

1. Set the model unit to millimetres using one of the following workflows:

® On the Construct tab, in the Define group, click the Eﬁ“‘ Model unit icon.

km

On the status bar, click Unit: m.

2. On the Model Unit dialog, select Millimetres (mm).
3. Click OK to change the model unit to millimetres and to close the dialog.

¢ Model Unit *

Unit

(®) Millimetres (mm)
() Centimetres {cm)
() Metres (m)

() Inches (n)

() Feet (ft)

() Spedifiy

oK Apply Cancel

Figure 93: The Model Unit dialog.
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4.4.4 Adding a Quadcopter from the Component Library

Select a simplified quadcopter model from the Component library and add it to the project.

1. On the Home tab, in the File group, click the @ Component Library icon.

2. On the Component Library dialog, in the Filter field, enter the text quadcopter.

e Component Library *

Components Quadcopter - Simple

Filter [quadcopter |

N \—i—\

Description

Cuadcopter

P éQuadcopter - Simple

o

Keywords: aircraft, geometry, generic, drone, UAV, quadrotor, helicopter

A simplified quadcopter model. Dimensions: Width 0.45 m, length 0.45 m, height 0.07 m.

Add to model Cancel

Figure 94: The Component Library dialog.

3. From the filtered results, click Quadcopter - Simple.
4. Click Add to model to add the quadcopter and to close the dialog.

5. On the Align dialog, under Destination workplane, in the Origin field, for the Z field, enter a
value of -100.
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sc Align *
" Source workplane " Destination workplane
(®) Custom workplane (®) Custom workplane
() Predefined workplane () Predefined workplane
" Origin ~ | [ Origin -
N ra— R &)
Yoo fa|| Y oo |
2o fa|| 2w @
| U Vector - | U Vector -
xbo  fa|| x [0 |
Vo || ¥ oo |
2o ifa|| 2 o =)
[V Vector — | [V vecter -
xfoo — |fa || x oo |
v fa|| f Lo |
2o fa|| Z oo @
| oK | | Close |

Figure 95: The Align dialog.
5/ Note: The offset separates the patch from the quadcopter on import.

6. Click OK to place the quadcopter and to close the dialog.

Figure 96: The simple quadcopter model from the component library.
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4.4.5 Importing the GPS Patch

Import the GPS patch model (.cftx file) created in Example 3.
1. On the Home tab, in the File group, click the I_S‘*‘:I Import icon. From the drop-down list select the
ﬁm CADFEKO Model (*.cfx) icon.

2. Onthe Import CADFEKO Model dialog, browse to the location of where you saved Example 3l
and click OK.

s¢ Import CADFEKD Model *

Filename l:l Browse...

Import

Geometry

Meshes

Meshing Rules

Cable Definitions
Solution Entities
Optimisation Searches

Merge Optlions

[] Merge Identical Variables and Points
[] Merge Identical Media

[] Merge Identical Workplanes

Prefix |

0K Restore defaults Close

Figure 97: The Import CADFEKO Model dialog.

The patch is located above the quadcopter. The next step is to align the GPS patch with the quadcopter.

iy %

d A
'.Aegm\ ey
TN vAva!
ARy e

Figure 98: The imported GPS patch model above the quadcopter.

17. Alternatively, open GS 3: GPS Patch Antenna in the application macro library.
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4.4.6 Defining a Workplane

Define a workplane to assist with aligning the patch on the quadcopter.
1. Hide the patch antenna in the 3D view to focus on the quadcopter.
a) In the model tree, click the icon next to Union1.

Construct | Configuration

Items q? & -
* Model -
¥ Geometry
‘PO Quadcopter_simple
Q¥®P .

Figure 99: Unionl is greyed out to indicate that the part is hidden in the 3D view.

2. Hide the simulation mesh!® to focus on the geometry using one of the following workflows:
® On the status bar, click the 8 Overlay icon.

e On the 3D View context tab, on the Display Options tab, in the Display Mode group, click
the @ Overlay icon.

3. Define a workplane.

a) On the Construct tab, in the Define group, click the ,{, Add Workplane icon.

sc Create Workplane >
Predefined Warkplane

Global XY ~
Qrigin

U loo | @
V |00 | @
N |o.o | @
U Vector

U [1o | @
V |00 | @
N |o.o | @
V Vector

U loo |
v [0 |
N |o.o || @
Label [warkplane1 |
Create Add Close

Figure 100: The Create Workplane dialog.

18. The simulation mesh refers to the final mesh used by the Solver. CAD always has to be meshed.
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b) Press Ctrl+Shift while moving the mouse cursor over the top face centre of the quadcopter.

[l Note: The circles with a black outline indicate special snapping points. The red
outline indicates the position of the mouse cursor.

Use snapping points to snap the workplane to an object. Although only special
snapping points are indicated, you can snap to any point in the 3D view.

Figure 101: Special snapping points are indicated by circles with a black
outline. The red outline indicates the position of the mouse cursor.

c) Press Ctrl+Shift+left click to snap the workplane to the top face centre of the quadcopter.
d) Click Create to create Workplanel and to close the dialog.

z

Figure 102: Workplanel has snapped to the top centre of the quadcopter.

4. Align Workplanel with the top of the quadcopter.
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a) In the model tree, select Workplanel.
b) From the right-click context menu, click Transforms > Rotate.

c) On the Rotate dialog, under Rotation angle, in the Angle [degrees] field, specify a value
of 45°,

s¢ Rotate *

Rotate Workplane

Origin

U |00 |
v |00 |
N |o.0 |
Axis direction

U lo.0 |
v |00 |
N Lo |

Rotation angle
Angle [degrees] ag

oK Close

Figure 103: The Rotate dialog.

d) Click OK to rotate Workplanel and to close the dialog.

z

Figure 104: Workplanel is “aligned” to the top centre of the quadcopter.

5. Repeat Step 1 to show the patch again.
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4.4.7 Aligning the Patch and Quadcopter

Align the patch to the quadcopter.
1. In the model tree, select Quadcopter_simple.
2. Align the GPS patch antenna on the quadcopter.
a) On the Transform tab, in the Transform group, click the ﬁ? Align icon.

b) On the Align dialog, under Source workplane, select Predefined workplane. From the
drop-down list, select Workplanel.

& Tip: If Workplanel is unavailable in the drop-down list, repeat Step 1.

c) Under Destination workplane, select Custom workplane.
e Click the X, Y or Z field to make it active.

e Press Ctrl+Shift and hover with the mouse over the top face of the patch and click when
the workplane snaps to the center point.

sc Align >

Source workplane Destination workplane

() Custom workplane (® Custom workplane

(®) Predefined workplane () Predefined workplane

Workplane1 + | | Origin
X [o | f@
¥ [-3.5527136788e-15 ||
E | f@
U Vector
X 1 | @
Y o | @
Z o | @
V Vector
X [o | f@
F | f@
Z o | f@

0K Apply Cancel

Figure 105: The Align dialog.

d) Click OK to align the quadcopter to the patch and to close the dialog.
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Figure 106: The GPS patch antenna placed on the quadcopter.

3. Union the GPS patch antenna and the quadcopter using one of the following workflows:
® On the Construct tab, in the Modify group, click the @ Union icon.

e Press U to use the keyboard shortcut.

[E/ Note: The union operation is used to define connectivity between parts.

Parts that touch, but are not unioned, are not considered to be physically connected
and will result in an incorrect mesh.

4. Show the simulation mesh again.

a) On the status bar, click the @ Overlay icon.
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4.4.8 Saving the Model

Save the model to a CADFEKO. c£x file.

1. Save the model using one of the following workflows:

On the Home tab, in the File group, click the G Save icon.

e Press Ctrl+S to use the keyboard shortcut.
2. Save the model as patch on Drone.cfx.
3. Click Save to close the dialog.
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4.5 Launching the Solver

Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

® On the Solve/Run tab, in the Run/Launch group, click the @) Feko Solver icon.

* On the application launcher toolbar, click the Feko Solver icon in the |1 = . % | group.

e Press Alt+4 to use the keyboard shortcut.
If the model contains unsaved changes, the Save Model dialog is displayed.
2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

¢ Bxecuting runfeke X

Model: Patch_on_Drone

¥ Details oK ® stop

Figure 107: The Executing runfeko dialog.

Proprietary Information of Altair Engineering A ALTAI R



Altair Feko 2022.1.1

4 GPS Patch on Quadcopter p.135

4.6 Viewing the Results in POSTFEKO

Display the model as well as the results using the post-processor component, POSTFEKO.
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4.6.1 Using a Lua Script to Configure Graphs

View the Lua script to set up the graphs for the input reflection coefficient and circular components of
the far field.

The step-by-step instructions to create this script is beyond the scope of the Feko Getting Started
Guide, but it is recommended to view the script and to compare it with setting up Graph 1 and Graph 2
from Example 3.

app = pf.GetApplication ()

-— Graph 1
graphl = app.CartesianGraphs:Add ()
excitationTrace = graphl.Traces:Add(app.Models[1l].Configurations[1l].Excitations[1])

excitationTrace.Quantity.ValuesScaledToDB = true
graph?2.Footer.Text = ""
graph2.Legend.Position = pf.Enums.GraphLegendPositionEnum.OverlayBottomRight

-- Graph 2

graph2 = app.CartesianGraphs:Add ()

farFieldTracelLHC = graph?2.Traces:Add (app.Models[1l].Configurations[1l].FarFields[1])
farFieldTraceLHC.Quantity.Type = pf.Enums.FarFieldQuantityTypeEnum.Gain
farFieldTraceLHC.Quantity.Component = pf.Enums.FarFieldQuantityComponentEnum.LHC
farFieldTracelLHC.Quantity.ValuesScaledToDB = true

farFieldTraceRHC = farFieldTraceLHC:Duplicate()

farFieldTraceRHC.Quantity.Type = pf.Enums.FarFieldQuantityTypeEnum.Gain
farFieldTraceRHC.Quantity.Component = pf.Enums.FarFieldQuantityComponentEnum.RHC
farFieldTraceRHC.Label = "FarField2"

farFieldTraceRHC.Quantity.ValuesScaledToDB = true
graph2.Footer.Text = ""
graph?.Legend.Position = pf.Enums.GraphLegendPositionEnum.OverlayBottomRight

[5/ Note: For more information regarding scripts and the Feko application programming
interface (API), see the Feko Scripting and API Reference Guide.
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4.7 Final Remarks

This examples showed how to place a GPS patch antenna on a quadcopter that was obtained from the
component library.

The input reflection coefficient and circular components of the far field were calculated and displayed.
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The example considers the coupling between a typical monopole antenna and a loaded transmission line
above a ground plane.

This chapter covers the following:

e 5.1 Example Overview (p. 139)

e 5.2 Topics Discussed in Example (p. 140)

e 5.3 Example Prerequisites (p. 141)

e 5.4 Creating the Model in CADFEKO (p. 142)
e 5.5 Launching the Solver (p. 159)

e 5.6 Viewing the Results in POSTFEKO (p. 160)
e 5.7 Final Remarks (p. 165)
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5.1 Example Overview

Consider the coupling between a monopole antenna and a loaded transmission line above a ground
plane.

Create the monopole antenna using a line and the loaded transmission line using a polyline. The ground
plane is modelled using an infinite ground plane.

A

diameter = 30 mm

12 m
Z2m 12m
a | ]
diameter = 8 mm E] 4
=1 m
v .":\ : R kQ: i '50 m
P =1W

Figure 108: The monopole antenna and the loaded transmission line above an infinite ground plane.
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5.2 Topics Discussed in Example

Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

e CADFEKO
- Create a monopole using a line. Specify the local wire radius for the monopole.
o Create the transmission line using a polyline.
- Define a ground plane using an infinite ground plane.
> Add a port and voltage source to the monopole.
- Specify the radiated power of the model.
> Add a port and complex load to the transmission line.
- Set the solution frequency. Use adaptive frequency sampling to obtain continuous data.
o Mesh the model.
o Run CEM validate to ensure the model is electromagnetically validated.
> Run the Solver.

e POSTFEKO
- View the simulated input impedance and currents on a graph.
o Change the line colour, marker style, marker colour of a trace on the graph.
- Add shapes (line, arrow, rectangle or circle) to highlight certain areas on the graph.

Note: Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Qi

o Tip: Find the completed model in the application macro Iibrary[lg]:

GS 5: EMC Coupling

19. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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5.3 Example Prerequisites

Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

Feko 2022.1 or later should be installed.

[ ]
It is recommended that you watch the demo video before attempting this example.

e This example should not take longer than 30 minutes to complete.

5/ Note: When using CADFEKO over a remote desktop connection, you may need to enable
3D support for remote desktop[zo] for the host's graphics card should a crash occur when

clicking New Project in CADFEKO.

See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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5.4 Creating the Model in CADFEKO

Create the model geometry using the CAD component, CADFEKO.
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5.4.1 Launching CADFEKO (Windows)

There are several options available to launch CADFEKO in Windows.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.

s Altair Feko 2022.1 - *

File Home Documentation  Utilities

&c &p & EDITFEKD “pt Lw La | . =4, Ef-
CADFEKO POSTFEKD QUELEFEKO ProMan WallMan AMan | .2 | newFASANT | WRAP  SAM Chedk for  Terminal
Updates
Feko WinProp newFASANT WRAP Tools

Figure 109: The Launcher utility.

e Open CADFEKO by double-clicking on a .cfx file.
e Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

[5/ Note: If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

5.4.2 Launching CADFEKO (Linux)

There are several options available to launch CADFEKO in Linux.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.
e Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:
/home/user/2022.1/altair/feko/bin/cadfeko

e Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

/home/user/2022.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

[/ Note: Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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5.4.3 Creating a Monopole

Create a monopole antenna as a single line element with a local wire radius. Zoom to extents and hide
the main axes to view the full-length monopole in the 3D view.

Create the monopole antenna. The length of the monopole is 12 m along the Z axis.

1. Create a line.

a) On the Construct tab, in the Create Curve group, click the / Line icon.

b) On the Create Line dialog, enter the start point and end point for the line.

e Start point: (0, 0, 0)
e End point: (0, 0, 12)

[/ Note: Default values are used on geometry creation dialogs to allow a preview in

the 3D view. You may change the values as required.

szc Create Line

W Workplane
na e
u/—2 PL
. o
Start point
U lo | fa
v |o | fa
N [o | fa
End point
U lo | f@
v lo | f@
N [12 | f@

Label [Manopole

Create

Add

Close

Figure 110: The Create Line dialog.

2. Set the label to Monopole.

3. Click Create to create the line and close the dialog.

To view the full-length monopole in the 3D window, zoom the monopole to the window extent.
4. Zoom to extents of the 3D view using one of the following workflows:

e Press F5 to use the keyboard shortcut.

On the View tab, in the Zoom group, click the '{' Zoom to Extents icon.

Disable the main axes to view the monopole without the Z axis obstructing it.
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5. On the 3D View context tab, on the Display Options tab, in the Axes group, click the 1, Main
AXxes icon.
6. Repeat Step 5 to enable the main axes display.
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5.4.4 Creating a Transmission Line

Create a transmission line using a polyline curve with four corners. The length of the polyline is 12 m
along the Y axis, placed 50 mm above ground.

p.146

1. On the Construct tab, in the Create Curve group, click the /:j Polyline icon.

N

sc Create Paolyline >
Geometry Workplane
C1 LA
na '
u/~ |2 C5 s
E —
C31\
cal”
Corner 1
u o fa
U &
N o &
1 (0,00
2 (1.1, 1
Add row Remove row
Import points
Label |Palyline1
Create Add Close

Figure 111: The Create Polyline dialog.

Under Corner 1, add the following coordinates:

e Corner 1: (0,20)

In the table, click on the second row to make Corner 2 active. Under Corner 2, add the following

coordinates:
e Corner 2: (0, 2, 0.05)

Click on Add row. Under Corner 3, add the following coordinates:

e Corner 3: (0, 14, 0.05)

Click on Add row. Under Corner 4, add the following coordinates:

e Corner 4: (0, 14, 0)

Set the label to Transmission line.

Click Create to create the polyline and to close the dialog.

Zoom to extents of the 3D view using one of the following workflows:

e Press F5 to use the keyboard shortcut.

Proprietary Information of Altair Engineering

On the View tab, in the Zoom group, click the ' Zoom to Extents icon.
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5.4.5 Defining an Infinite Ground Plane

Define a perfectly conducting (PEC) infinite ground plane. An infinite ground plane is an efficient method
to model a large ground plane compared to a discretised, finite sized ground plane.

Define the infinite ground plane.

a) On the Construct tab, in the Structures group, click the Planes/Arrays icon. From the
drop-down list, select F:J Plane / Ground.

b) On the Plane / Ground dialog, from the Definition method drop-down list, select Perfect
electric (PEC) ground plane at Z=0.

¢ Plane / Ground *
Definition method | Perfect electric (PEC) ground plane at Z=0 e
oK Apply Cancel

Figure 112: The Plane / Ground dialog.

c) Click OK to create the infinite plane and to close the dialog.
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5.4.6 Ports, Sources and Loads in CADFEKO

Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Adding a Wire Port to the Monopole

Define a wire port on the monopole. A voltage source will be added to this port.
1. Select the monopole using one of the following workflows:
e Click on the monopole in the 3D view.
¢ In the model tree, select Monopole. In the details tree, select Edgel.

Construct | Configuration

Items \D‘) HE -
Definitions -
v Model
¥ Geometry

Details
Meonopole 9 ﬁ ;"5
v Edges

{~ Edgel MaoM

&

Figure 113: Edgel in the details tree is the wire element associated with Linel in the model tree.

2. Define the wire port on the selected wire (monopole) using one of the following workflows:

On the Source/Load tab, in the Ports group, click the /,“’ Wire Port icon.

e On the details tree, a right-click context menu is available on the edge. Click Create Port >
Wire Port.

& B
E Delete Del
fer Rename F2
(ﬂg Copy (Duplicate)
Create Port b 2% Wire Port
Show / Hide Ctrl+H T EdgePort
&5 Microstrip Port

Show Only in Collection
.

)y Waveguide Port
&8 FEM Line Port

2 FEM Modal Port

Show Only
Show All

Set Mot Suspect

Cable Port
E:; Zoom to Selection i
Select All Ctrl+A
Select All in Part Ctrl+Shift+A

Select Connected Faces

E Properties

Figure 114: The right-click context menu options for an edge in the details tree.

3. Use the default port settings.
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¢ Create Wire Port

Edge |Line1.Edge1

Place port on
@ Segment O Vertex

Location on wire
(@) Start

() Middle

() End

() other

[] reverse polarity

Label [wirePort1

Create Add

Cloze

Figure 115: The Create Wire Port dialog.

4. Click Create to create the port and close the dialog.
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Figure 116: Front view of the monopole and its wire port and
the transmission line. The port is indicated by a silver sphere.

p.150

J\ ALTAIR



Altair Feko 2022.1.1
5 EMC Coupling

Adding a Wire Port to the Transmission Line

Define a wire port for the transmission line.

p.151

1. Select the short, vertical wire in the 3D view located farthest away from the monopole.
The wire element associated with the selected wire is highlighted in the details tree.

2. On the details tree, a right-click context menu is available on the edge. Click Create Port > Wire

Port (see Figure 2).

3. View the port preview in the 3D view to ensure the correct edge is selected.

4. Use the default settings for the port.

¢ Create Wire Port

Edge [Polyline 1. Wire2

Place port on
@ Segment O Vertex

Location on wire
(@) Start

() Middle

() End

() other

[] reverse polarity

Label [wirePortz

Create Add

Cloze

Figure 117: The Create Wire Port dialog.

5. Create Create to create the port and close the dialog.

iw

Figure 118: Front view of the monopole and transmission line together
with their wire ports. The ports are indicated by silver spheres.
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Adding a Voltage Source

Add a voltage source to the port of the monopole.

1. On the Source/Load tab, in the Sources on Ports group, click the @ Voltage Source icon.

The radiated power must be 1 Watt for this example. Since the input impedance for the monopole is not
known, the voltage can not be changed to scale the radiated power.

2. Ensure WirePort1 is selected in the drop-down list and use the default voltage settings.

¢ Create Voltage Source d
Port | WirePortl e
Voltage
Magnitude [10 |
Phase 0.0 |

Reference impedance (Ohm) [50.0 |

Label |1,.'.:.|tage5-:uurce 1 |

Create Add Cloze

3. Click Create to define the voltage source and to close the dialog.

im

Figure 119: Front view of the monopole and transmission line together with their wire
ports. The wire port with a voltage source applied to it, is indicated by a red sphere.
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Adding a Complex Load to a Port

Add a resistive load to the port of the transmission line.

p.153

1. On the Source/Load tab, in the Loads/Networks group, click the @ Add Load icon.

2. Specify the port for the load as WirePort2.
3. Set the Real part of the complex impedance to 1000.

sc Create Load

Port | WirePaort2
Load type

Complex impedance

Complex impedance (Ohm)

Real part | 1000

Imaginary part |D

Label |Load1

Create Add

Close

4. C(Click Create to create the load and close the dialog.
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5.4.7 Setting the Radiated Power Level

Specify the power settings to scale the radiated power.

1. 0On the Source/Load tab, in the Settings group, click the (F) Power icon.

p.154

The radiated power should be 1 Watt. Power losses as a result of source mismatch are deducted before

the 1 Watt is calculated.
2. Click Total source power (no mismatch).
3. Enter a source power of 1 Watt.

¢ Power Settings

Scale settings
O Mo power scaling

Source power (Watt)

OK

{®) Total source power (no mismatch)
() Incident power (transmission line model)

[1

Apply

[] pecouple all sources when calculating power

Cancel

4. Click OK to specify the source power and to close the dialog.
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5.4.8 Setting the Simulation Frequency

Specify the frequency range of interest. For this example continuous frequency sampling is used where
Feko determines the frequency sampling for optimal interpolation automatically.

1. On the Source/Load tab, in the Settings group, click the /|| Frequency icon.

2. On the Solution Frequency dialog, select Continuous (interpolated) range from the drop-
down list.

Specify the frequency range between 1 MHz and 30 MHz.
3. Enter the start frequency and end frequency.
e Start frequency (Hz): 1e6
e End frequency (Hz): 30e6

¢ Solution Frequency >

Freguency Export Advanced
Continuous (interpolated) range ~

Start frequency (Hz) [1e6 |

End frequency (Hz) |3De6 |

0K Apply Cancel

Figure 120: The Solution Frequency dialog.

4. Click OK to specify the frequency and to close the dialog.
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5.4.9 Modifying the Auto-Generated Mesh

When the frequency is set or local mesh settings are applied to the geometry, the automatic mesh
algorithm calculates and creates the mesh automatically while the GUI is active using default mesh
settings. When required, these mesh settings may be modified.

Specify the global wire segment radius to be used in the model.
1. Open the Modify Mesh Settings dialog using one of the following workflows:
* On the Mesh tab, in the Meshing group, click the € Modify Mesh icon.

e Press Ctrl+M to use the keyboard shortcut.
2. On the Modify Mesh Settings dialog, set the Wire segment radius to 0.004.

¢ Modify Mesh Settings *

Options Advanced
Global mesh sizes
Mesh size | Standard v ?
Global wire radius

Wire segment radius ||:|,|:||:|4

oK Apply Cancel

Figure 121: The Modify Mesh Settings dialog.

3. Click OK to create the mesh and to close the dialog.
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5.4.10 Setting a Local Wire Radius for the Monopole

Specify a local wire radius for the monopole.

The monopole and transmission line are each assigned a different wire radius. Due to the differences in
the wire radii, we specify a local wire radius for the monopole.

5/ Note: Local mesh refinement takes precedence over global mesh settings.

1. In the model tree (Construction tab), select Monopole. In the details tree, select Edgel.
2. From the right-click context menu, select Properties.
3. On the Modify Edge dialog (Properties tab), specify the following:

a) Select the Local wire radius check box.

b) Set the Radius to 0.015.

¢ Modify Edge d

Properties Meshing Solution

Wire radius
Local wire radius
Radius |D.D 15

Wire core medium

Medium | Perfect electric conductor e
Coating
[T Apply

0K Apply Cancel

Figure 122: The Modify Edge dialog.

4. Click OK to apply the properties and to close the dialog.

=  Note: The {_—} icon in the details tree indicate that a local wire radius is applied.

Details

Line &y 9
v Edges

{5 wirel Mol

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1
5 EMC Coupling p.158

5.4.11 Saving the Model

Save the model to a CADFEKO. c£x file.

1. Save the model using one of the following workflows:

On the Home tab, in the File group, click the G Save icon.

e Press Ctrl+S to use the keyboard shortcut.
2. Save the model as Coupling.cfx.

3. Click Save to close the dialog.
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5.5 Launching the Solver

Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

® On the Solve/Run tab, in the Run/Launch group, click the @) Feko Solver icon.

* On the application launcher toolbar, click the Feko Solver icon in the |1 = . % | group.

e Press Alt+4 to use the keyboard shortcut.
If the model contains unsaved changes, the Save Model dialog is displayed.
2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

¢ Bxecuting runfeko X

Model: Coupling

¥ Details oK ® stop

Figure 123: The Executing runfeko dialog.
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5.6 Viewing the Results in POSTFEKO

Display the model as well as the results using the post-processor component, POSTFEKO.
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5.6.1 Launching POSTFEKO

Open POSTFEKO from within CADFEKO.
Use one of the following workflows to launch POSTFEKO:

¢ On the Solve/Run tab, in the Run/Launch group, click the <7 POSTFEKO icon.

* On the application launcher toolbar, click the POSTFEKO icon inthe [E =~ = & | group.

e Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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Viewing the Load Current

View the load current of the transmission line on a Cartesian graph.

1. Create a new Cartesian graph.
a) On the Home tab, in the Create new display group, click the & Cartesian icon.
2. Add the load current to the Cartesian graph.

a) On the Home tab, in the Add results group, click the Loads/Networks icon. From the
drop-down list, select Load1.
3. View the load current (in dB) versus frequency.
a) On the result palette, on the Traces panel, select Load1.
b) On the Quantity panel, from the drop-down list select Current.
c) On the Quantity panel, select the dB check box.
4. Change the legend position to top-right.

a) On the Display tab, in the Display group, click the Position icon. From the drop-down
list select Overlay top right.
5. Remove the graph footer.

a) On the Display tab, in the Display group, click the ﬂz Chart text icon.

b) In the Graph footer field, clear the Auto check box and delete the text.
c) Click OK to apply the text changes and to close the dialog.

Gain
60

Load1

-65

-10

-5

Current [dBA)

-80

-85
0 5 10 15 20 25 30

Frequency [MHz]

Figure 124: The load current in dB versus frequency.
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Viewing the Input Impedance
View the source input impedance (real part and imaginary part) of the transmission line on a Cartesian
graph.
1. Create a new Cartesian graph.
a) On the Home tab, in the Create new display group, click the & Cartesian icon.
2. Add the source input impedance to the Cartesian graph.
a) On the Home tab, in the Add results group, click the @ Source data icon.

3. View the real part of the impedance.
a) On the result palette, in the Traces panel, select VoltageSourcel.
b) On the Quantity panel, from the drop-down list select Impedance.
c) On the Quantity panel, click Real.
4. Duplicate the VoltageSourcel trace using one of the following workflows:
¢ On the Cartesian context tab, on the Trace tab, in the Manage group, click the
‘A~ Duplicate trace icon.
¢ On the result palette, a right-click context menu is available on the trace. From the drop-
down list, select Duplicate trace.
e Press Ctrl+K to use the keyboard shortcut.
5. View the imaginary part of the impedance.
a) On the result palette, in the Traces panel, select VoltageSourcel_1.
b) On the Quantity panel, click Imaginary.
6. [Optional] Repeat Step 4 and Step 5 to change the legend position and remove the graph footer.

Excitation

Real

Imaginary

Impedance [kOQhm)

30
Frequency [MHz]

Figure 125: The input impedance (real and imaginary) versus frequency.
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Formatting the Graph
Format the line colour, marker colour and marker style of a trace. Add a line, arrow (single or double),
rectangle or circle to the graph to highlight certain aspects of the graph.
1. Select a trace to format.
a) On the result palette, in the traces panel, select VoltageSourcel_1.
2. Change the line colour to red.
a) On the Format tab, in the Line group, click the L‘ Line colour icon. From the drop-down
list, select the colour red.
3. Change the marker style to a triangle.

a) On the Format tab, in the Marker group, click the (O Marker style icon. From the drop-
down list select the triangle.
4. Change the marker colour to match the colour of the trace.

a) On the Format tab, in the Marker group, click the é Marker colour icon. From the drop-
down list select the colour red.
5. [Optional] Repeat Step 4 and Step 5 to change the legend position and remove the graph footer.

Excitation

Real
—&— Imaginary

Impedance [kOhm]

30
Frequency [MHz]

Figure 126: An example of a formatted graph.
6. [Optional] Add a line, arrow, double arrow, rectangle or circle to the graph to highlight an aspect
on the graph.

a) On the Format tab, in the Drawing group, click the °|._,Q Shapes icon. Select the required
item from the drop-down list.

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1
5 EMC Coupling p.165

5.7 Final Remarks

This example showed the construction, configuration and solution of an EMC coupling scenario. The
model consists of a monopole antenna and transmission line on an infinite PEC ground plane. Coupling
of current into the transmission line is viewed from 1 MHz to 30 MHz.
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The example considers the transmission and reflection coefficients of a waveguide power divider.

This chapter covers the following:

e 6.1 Example Overview (p. 167)

e 6.2 Topics Discussed in Example (p. 168)

e 6.3 Example Prerequisites (p. 169)

e 6.4 Creating the Model in CADFEKO (p. 170)
e 6.5 Launching the Solver (p. 190)

e 6.6 Launching POSTFEKO (p. 191)

e 6.7 Final Remarks (p. 195)
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6.1 Example Overview

Calculate the transmission and reflection coefficients of a waveguide power divider.

Create the power divider to split equally the power between the two output ports while minimising
any power reflected back to the source port. The power is split by placing a metal pin at the junction
between the three waveguide sections. The model utilises symmetry to reduce memory requirements
and calculation speed.

Figure 127: The waveguide power divider and instantaneous near field.
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6.2 Topics Discussed in Example

Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

e CADFEKO
o Create the pin using a cylinder.
o Create the waveguide sections using cuboids.
- Define waveguide ports on each end of the waveguide.
> Add a waveguide source.
> Set the solution frequency.
o Specify local (fine) meshing for the waveguide ports.
- Specify symmetry to save computational resources.
- Specify near fields on a plane inside the waveguide.
o Mesh the model.
o Run CEM validate to ensure the model is electromagnetically validated.
> Run the Solver.

e POSTFEKO
> View the simulated input reflection coefficient on a graph.
- View the instantaneous near field inside the waveguide.
- View an animation of the near fields.

Note: Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

[

o Tip: Find the completed model in the application macro Iibrary[21]:

GS 6: Waveguide Power Divider

21. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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6.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

e Feko 2022.1 or later should be installed.
It is recommended that you watch the demo video before attempting this example.

e This example should not take longer than 30 minutes to complete.

Note: When using CADFEKO over a remote desktop connection, you may need to enable
3D support for remote desktop[zz] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

=

22. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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6.4 Creating the Model in CADFEKO

Create the model geometry using the CAD component, CADFEKO.
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6.4.1 Launching CADFEKO (Windows)

There are several options available to launch CADFEKO in Windows.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.

s Altair Feko 2022.1 - *

File Home Documentation  Utilities

» » »

&c &p & EDITFEKO “p' Zw LA |~ e =4,
CADFEKO POSTFEKD QUELEFEKO ProMan WallMan AMan | .2 | newFASANT | WRAP  SAM Chedk for  Terminal
Updates
Feko WinProp newFASANT WRAP Tools

Figure 128: The Launcher utility.

e Open CADFEKO by double-clicking on a .cfx file.
e Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

[5/ Note: If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

6.4.2 Launching CADFEKO (Linux)

There are several options available to launch CADFEKO in Linux.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.
e Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:
/home/user/2022.1/altair/feko/bin/cadfeko

e Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

/home/user/2022.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

[/ Note: Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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6.4.3 Setting the Model Unit

Set the model unit to millimeters.
The default unit length in CADFEKO is metres. Since the structure that you will build is small, the model
unit is set to millimetres. All dimensions entered will be in the new model unit.

1. Set the model unit to millimetres using one of the following workflows:

® On the Construct tab, in the Define group, click the Eﬁ“‘ Model unit icon.

km

On the status bar, click Unit: m.

2. On the Model Unit dialog, select Millimetres (mm).
3. Click OK to change the model unit to millimetres and to close the dialog.

¢ Model Unit *

Unit

(®) Millimetres (mm)
() Centimetres {cm)
() Metres (m)

() Inches (n)

() Feet (ft)

() Spedifiy

oK Apply Cancel

Figure 129: The Model Unit dialog.
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6.4.4 Adding Variables

Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.
1. Open the Create Variable dialog using one of the following workflows:
® On the Construct tab, in the Define group, click the _Ix Add Variable icon.
e On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Construct | Configuration

Items Y H5F v

v Definitions A
“ Wariables i
o0 = 1/sqrifeps0™mul)
eps0 = 8.35413?31?51Eg; Edit Variahles
mul = pi*de-7
pi = 3.14159265358979323846
zfl = sgri{mul/epsl)
MNamed Points
[ Media
Workplanes
A Field/Current Data
Waork Surfaces
E}Ts Cables
¥ Model
Geometry v

1. Add Variable #

Figure 130: The model tree (Construction tab).

On the model tree, click the & 4 icon. From the drop-down list, select Add Variable.

- -
I Add Variable #
& Add Point
E Media v
A Field/Current Data 4
AL Add Workplane Fo
{{) Cable Definition v
% Port ’
[ Mesh Refinement 4
- Solution Settings ’
T

Figure 131: The E|=,i| drop-down list available in the model tree.

e Press # to use the keyboard shortcut.
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2. Create the following variables:
a) Optional: Add the variable comments.

Name Expression Comment
freq 9e9 The operating frequency.
lambda c0/freg*1000 Free space wavelength.
pin_r 1 Pin radius.
wg_h 10 Waveguide height.
wg_w 20 Waveguide width.

O Tip:

¢ Click Add to keep the Create Variable dialog open and add more variables.
¢ Click Create to add a variable and close the Create Variable dialog.
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6.4.5 Creating the Power Dividing Pin

Create the power dividing pin using a cylinder.

1. Create a cylinder located at the origin along the Z axis.

a) On the Construct tab, in the Create Solid group, click the [j Cylinder icon.
b) Create a cylinder using the Base centre, radius, height definition method.
¢) Use the following dimensions:

e Radius (R): pin_r

e Height (H): wg_h

5/ Note: Default values are used on geometry creation dialogs to allow a preview in the
3D view. You may change the values as required.

a) Click Create to create the cylinder and to close the dialog.

sc Create Cylinder *

Geometry Workplane
Definition methods

Base centre, radius, height e

Base centre (B)

U [o.0 | @
v [o.0 | @
N [o.0 | @

Dimensions
Radius (R) ||:|in_r |
Height (H) |wg_h |

Label |Cylinder1 |

Create Add Cloze

Figure 132: The Create Cylinder dialog.

2. Zoom to extents of the 3D view using one of the following workflows:

On the View tab, in the Zoom group, click the | ' Zoom to Extents icon.

e Press F5 to use the keyboard shortcut.
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6.4.6 Creating the Waveguide Sections

Create the waveguide sections using two cuboids.
1. Create the first waveguide section.

a) On the Construct tab, in the Create Solid group, click the fj Cuboid icon.

b) Create the cuboid using the Base centre, width, depth, height definition method.

¢) Use the following dimensions:
e Base centre (C): (0, 0, 0)
e Width (W): wg w
e Depth (D): 2*wg_w
e Height (H): wg_h
e Label: cuboidl

¢ Create Cubeid *

Geometry Workplane
Definition methods
Base centre, width, depth, height b

H&

L G" : &
u v

Base centre (C)

U [o.0 | fa
v o0 | fa
N [o.0 | fa
Dimensions

Width (W) [wg_w |

Depth (D) [2=wg_w |
Height (H) [wg_h |

Label [Cubaidi |

Create Add Close

Figure 133: The Create Cuboid dialog.
d) Click OK to create the waveguide section and to close the dialog.
2. Create the second waveguide section.
a) On the Construct tab, in the Create Solid group, click the (7 Cuboid icon.

b) Create the cuboid using the Base corner, width, depth, height definition method.
c) Use the following dimensions:

e Base corner (C): (wg_w/2, -wg_w/2, 0)
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e Width (W): wg w
e Depth (D): wg_w
e Height (H): wg_h
e Label: cuboid?2

s¢ Create Cuboid >

|GE0I‘I1Etr1f' |Workp|ane |

| Definition methods
| Base corner, width, depth, height >

Ha

" Base corner (C)

U |wg_wf2

v [wg_wi2
M |0

e

" Dimensions
Width (W) [wg_w
Depth (0)  [wg_w
Height (H) [wg_h

Label |Cuboidz |

| Create || Add || Close |

Figure 134: The Create Cuboid dialog.

d) Click OK to create the waveguide section and to close the dialog.

Figure 135: The two waveguide sections and power dividing pin.
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6.4.7 Unioning the Geometry for Mesh Connectivity

Union the geometry (Cuboidl and Cuboid2) to create a single geometry part. A single geometry part
will ensure mesh connectivity when the model is meshed.

1. 1n the model tree, select Cuboidl1 and Cuboid2!3.,

o

Tip: To select multiple objects, press and hold Ctrl while you click the items.

Construct | Configuration

Items q-? 5F -
Definitions
v Model
v Geometry
(P Cuboid1
P Cuboid2
[ cylindert

W

Figure 136: Cuboidl and Cuboid2 selected in the model tree.

On the Construct tab, in the Modify group, click the @ Union icon.

Construct | Configuration

Items i? 5F -
Definitions
~ Model
¥ Geometry
[ cylindert
hd ’:@ Union1
(P Cuboidl
(P Cuboid2

~

W

Figure 137: The model tree showing Union1 (the union between Cuboidl and Cuboid2).

23. Alternative method is to select the items in the 3D view.
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6.4.8 Removing Redundant Faces

Use the simplify tool to remove redundant faces.
1. In the model tree, select Union1.
2. 0On the Transform tab, in the Simplify group, click the @ Simplify icon.
3. Use the default settings on the Simplify dialog.

¢ Simplify *

Points
Remove redundant geometry points

Edge/Wires

Remove edges on metal surfaces

Remove edges on dielectric surfaces

Remove wires inside metal regions

[] remove wires inside dielectric regions

Keep edges/wires with local mesh sizesfwire radii

Faces

Remove faces between equal metal regions
Remove faces between equal dielectric regions
Remove faces between shell regions

Keep faces with local mesh sizes

Regions
Keep regions with local mesh sizes

Create Cancel

Figure 138: The Simplify dialog.

4. Click Create to simplify Union1 and to close the dialog.

The redundant face at the junction between the two cuboids is removed.

Figure 139: The waveguide section after the redundant faces were removed.
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6.4.9 Changing the Waveguide to a Shell (Hollow) Part

Change the solid waveguide part to a shell (hollow) part with metal walls.

1. In the model tree, select Union1.
2. In the details tree, under Regions, select Region1l.
3. From the right-click context menu, select Properties.

Details

substrate

Edges
Faces
v Regions
ﬁﬂ Region] Mrfmct ~loctri bl
................................ Delete

e
per Rename

e Copy (Duplicate)

Create Port

Show / Hide

Show Only in Collection
Show Only

Show All

Set Mot Suspect

E:; Zoom to Selection

Select All
Select All in Part

E Properties

Del
F2

Ctrl+H

Ctrl+A
Ctrl+Shift+4A

Figure 140: The right-click context menu options available for regions.

4. On the Modify Region dialog (Properties tab), set Medium to Free space.

¢ Meodify Region

Properties Meshing Solution

Region medium
Medium | Free space

OK Apply

Cancel

X

Figure 141: The Modify Region dialog.

5. Click OK to modify the region properties and to close the dialog.
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6.4.10 Unioning the Waveguide and Power Dividing Pin

Create a single geometry part from the waveguide and power divider pin to ensure mesh connectivity
when the model is meshed.

1. 1n the model tree, select Cylinderl and Union1[?%],

© Tip: To select multiple objects, press and hold Ctrl while you click the items.

2. 0On the Construct tab, in the Modify group, click the @ Union icon.

Construct | Configuration

Items Q-? 5F -
v Model A
¥ Geometry
[ cytindert
v 3 Union
'@ Union1 ]

Figure 142: Select Cylinderl and Union1 in the model tree.

24. Alternative method is to select the items in the 3D view.
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6.4.11 Ports, Sources and Loads in CADFEKO

Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Adding Waveguide Ports

Define waveguide ports with the correct orientation.

p.183

[/ Note: A portis a mathematical representation of where energy can enter (source) or leave

a model (sink). Use a port to add sources and discrete loads to a model.

Waveguide ports without sources are considered to be absorbing waveguide terminations.

1. Add the first waveguide port on the face at the most positive X position.
a) In the 3D view, repeatedly left-click until the face is highlighted.

z

Figure 143: The face at the most positive X position is selected.

b) Open the Create Waveguide Port dialog using one of the following workflows:

®* On the Source/Load tab, in the Ports group, click the Q Waveguide Port icon.

e In the details tree, a right-click context menu is available on the face. From the list, click
Create Port > Waveguide Port.

Figure 144: The Create Waveguide Port dialog.

sc Create Waveguide Port

Specification Advanced

Face |Union1.Face15

Propagation direction opposite to normal
Rotate reference direction

[] mManually set the reference vector
(®) 0 degrees

() 90 degrees

() 180 degrees

() 270 degrees

Label [waveguidePort1

Create Add

Close

c) Use the default settings for the port.
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Figure 145: The preview of the waveguide port is displayed in green.

5/ Note: The white line is the reference vector and shows the direction of m, where
m is the number of half-wavelengths across the width of the waveguide.

d) Click Add to add the waveguide port, but do not close the dialog.
2. Add the second waveguide port at the face at the most negative Y position.

a) On the dialog, click on the Face user input field to make it active. An active field is
highlighted in blue (see Figure 144).

b) In the 3D view, repeatedly left-click until the face is highlighted.
c) Click Add to add the waveguide port, but do not close the dialog.
3. Add the third waveguide port at the face at the most positive Y position.
a) On the dialog, click on the Face field to make it active. An active field is highlighted in blue.
b) In the 3D view, repeatedly left-click until the face is highlighted.
c) Click 180 degrees to ensure the correct reference direction.
d) Click Create to add the port and to close the dialog.
4. Enable the port annotations. On the 3D View context tab, on the Display Options tab, in the
Entity Display group, click the L] Port Annotations icon.

Figure 146: The waveguide power divider with three defined waveguide ports.
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Adding a Waveguide Source

Add a waveguide source to the first port using the fundamental mode.

[/ Note: Default values are used in this example. The fundamental mode for this source will
be excited (TE10).

Add multiple modes as a single source by selecting Specify modes manually.

1. On the Source/Load tab, in the Sources on Ports group, click the
[+] Waveguide Source icon.

2. In the drop-down list, select WvaeguidePort1.

sc Create Waveguide Source

WaveguidePortl

(®) Excite fundamental mode only
(") specify modes manually

Fundamental mode

Magnitude | 1.0

Phase |u,u

Label |waveguideSourcel

Create Add

Close

Figure 147: The Create Waveguide Source dialog.

3. Click Create to create the source and to close the dialog.

Figure 148: A port with a source is indicated in red.
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6.4.12 Setting the Simulation Frequency

Specify the frequency range of interest.

p.186

1. On the Source/Load tab, in the Settings group, click the /|| Frequency icon.

A variable was created at the beginning of the example that contains the solution frequency.

2. In the Frequency (Hz) field, enter freq.

¢ Solution Frequency
Frequency Export

Single frequency

Advanced

Frequency (Hz) |ﬁeq

OK

Apply

Cancel

3. Click OK to close the dialog.

With the frequency set to freq, the actual frequency is 9 GHz. In the model tree, click the

Configuration tab to view the specified simulation frequency.
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6.4.13 Adding a Near Field Request

Add a near field request to calculate the fields on a surface through the centre of the waveguide.

p.187

1. On the Request tab, in the Solution Requests group, click the [E] Near Fields icon.

2. On the Request near fields dialog, enter the values as indicated.

Dimension
U

4

3. Clear the Sample on edges check box.

Start End Number of Field Points
-10 30 32
-20 20 32
0 0 1
sc Request Near Fields >
Position Workplane Scope Advanced
Definition method
Cartesian o
Specify number of points ~
Start End
U [-10 RIRCRES |
v |20 | [| v |2 |
N 0.0 | || N[0 |
Increment Mumber of field points
U [125 | || u [z |
v [125 | | v [32 |
N [o | || N [32 |

[] sample on edges

Label |NearField1

Create

Add

Close

4. In the Label field, use the default (NearField1).

5. Click Create to add the near field request and to close the dialog.
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6.4.14 Setting Local Mesh Sizes for Waveguide Port Faces

Refine the mesh locally at the waveguide port faces. The faces for the waveguide ports require a finer
mesh to represent the highest mode that should be taken into account. The higher order modes are

typically evanescent modes.

1. In the 3D view, select the three waveguide port faces.

2. From the right-click context menu, select Properties.
3. On the Modify Face dialog (Meshing tab), specify the following:
a) Select the Local mesh size check box.

b) Set the Mesh size to /Jambda/20.

sc Modify Face

Properties

Mesh size
Local mesh size

Meshing

Solution

Mesh size [lambda/20

OK

Apply

Cancel

Figure 149: The Modify Face (Meshing tab) dialog.

4. Click OK to apply the properties and to close the dialog.

z

Figure 150: Note the localised mesh refinement at the waveguide port faces.

= Note: The @ icon in the details tree indicate that a local mesh setting is applied.

Details

Unienl

ﬁ' Face5
' Facef
ﬁ' Face?
7 Faced 1
[ Faces 2
' Facell

' Facel3

& & B "

Mo
Mo
Mo
Mo
Mo
Mo
Mol A
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6.4.15 Saving the Model

Save the model to a CADFEKO. c£x file.

1. Save the model using one of the following workflows:

On the Home tab, in the File group, click the G Save icon.

e Press Ctrl+S to use the keyboard shortcut.
2. Save the model as Wwaveguide Divider.cfx.
3. Click Save to close the dialog.
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6.5 Launching the Solver

Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

® On the Solve/Run tab, in the Run/Launch group, click the @) Feko Solver icon.

* On the application launcher toolbar, click the Feko Solver icon in the |1 = . % | group.

e Press Alt+4 to use the keyboard shortcut.
If the model contains unsaved changes, the Save Model dialog is displayed.
2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

¢ Bxecuting runfeko X

Model: Waveguide_Divider

¥ Details oK ® stop

Figure 151: The Executing runfeko dialog.
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6.6 Launching POSTFEKO

Open POSTFEKO from within CADFEKO.
Use one of the following workflows to launch POSTFEKO:

® On the Solve/Run tab, in the Run/Launch group, click the <. POSTFEKO icon.

® On the application launcher toolbar, click the POSTFEKO icon in the ‘@ BT ] ‘group.

e Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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6.6.1 Viewing the Input Reflection Coefficient

Plot the input reflection coefficient on a Cartesian graph in dB.

The model was solved at a single frequency only. Therefore the graph will contain a single data point.
1. Create a new Cartesian graph.
a) On the Home tab, in the Create new display group, click the LL\_ Cartesian icon.
2. Add the input reflection coefficient to the Cartesian graph.
a) On the Home tab, in the Add results group, click the @ Source data icon. From the drop-
down list, select WaveguideSourcel.
3. View the input reflection coefficient in dB.

a) On the result palette, in the Traces panel, select WaveguideSourcel.
b) On the Quantity panel, select the dB check box.
4. Change the legend position to top-right.

a) On the Display tab, in the Display group, click the Position icon. From the drop-down
list select Overlay top right.
5. Remove the graph footer.

a) On the Display tab, in the Display group, click the ﬂz Chart text icon.

b) In the Graph footer field, clear the Auto check box and delete the text.
c) Click OK to apply the text changes and to close the dialog.

Excitation

——  WaveguideSource1

Reflection coefficient [dB]
: ]

8.7 5.8 8.9 9.0 9.1 9.2 9.3
Frequency [GHz]

6. [Optional] Add annotations to the graph.
a) On the Cartesian context tab, on the Measure tab, on the Custom annotations group,
click the \fE Points icon. From the drop-down list, click \fﬁ Global maximum.
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[5/ Note: The power reflected back to Portl is more than 30 dB lower than the power
applied to the same port.
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6.6.2 Viewing the Near Fields

Display the calculated near fields in the 3D view. Animate the instantaneous near field.

1.
2.

Proprietary Information of Altair Engineering

Select the 3D View1 window.
Enable mesh opacity to view the near field inside the waveguide.
a) On the 3D View contextual tabs set, on the Mesh tab, in the Opacity group, click the
ﬁ Mesh opacity icon. From the drop-down list, select a value of 40%o.

On the Home tab, in the Add results group, click the E Near Fields icon. From the drop-down
list, select NearField1l.
Animate the phase of the near field.
a) In the result palette, in the Quantity panel, select Instantaneous magnitude.
b) On the 3D View contextual tabs set, on the Animate tab, on the Settings group, click the
@ Type icon. From the drop-down list, select the E Phase icon.

Start the animation process.
a) On the 3D View contextual tabs set, on the Animate tab, on the Control group, click the
O Play icon.

b) Stop the animation by clicking the (*) Play icon again.

Instantaneous magnitude XYZE-Field [V im]
500.0
! 450.0
400.0
350.0
300.0
@ 250.0
- 200.0
150.0

B 100.0
I 50.0
0.0

7

A

Figure 152: The near field in the power divider (refer to the
WebHelp to view the animation of the instantaneous magnitude).
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6.7 Final Remarks

This example showed the construction, configuration and solution of a waveguide power divider. The
model consists of a hollow cuboidal sections with a cylinder (pin) in the centre. The near field and input
reflection coefficient was calculated and displayed.
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Optimisation of Bent Dipole
and Plate

The example considers the optimisation of the gain of a bent dipole in front of a plate.

This chapter covers the following:

e 7.1 Example Overview (p. 197)

e 7.2 Topics Discussed in this Example (p. 198)
e 7.3 Example Prerequisites (p. 199)

e 7.4 Creating the Model in CADFEKO (p. 200)
e 7.5 Launching the Solver (p. 218)

e 7.6 Launching POSTFEKO (p. 219)

e 7.7 Closing Remarks (p. 226)
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7.1 Example Overview

Calculate and maximise the gain of a bent dipole in front of a plate. Optimise the dipole-plate
separation distance and the dipole bend-angle.

The goal is to maximize the maximum gain in the azimuth plane at a single frequency.

Feed point

Figure 153: Sketch of the model showing dimensions and other relevant parameters.
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7.2 Topics Discussed in this Example

Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

e CADFEKO
o Define an optimisation search in CADFEKO.
o Run the optimiser (OPTFEKO).
> Add a wire port to a wire segment.
o Specify symmetry to save computational resources.
- Add a voltage source to a wire port.
o Mesh the model.
- Run CEM validate to ensure the model is electromagnetically validated.
o Run the Solver

e POSTFEKO
o View the optimisation results in POSTFEKO.

5/ Note: Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

(7] Tip: Find the completed model in the application macro Iibrary[25]:

GS 7: Optimisation of a Bent Dipole and Plate

25. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1
7 Optimisation of Bent Dipole and Plate p.199

7.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

e Feko 2022.1 or later should be installed.
It is recommended that you watch the demo video before attempting this example.

e This example should not take longer than 20 minutes to complete.

Note: When using CADFEKO over a remote desktop connection, you may need to enable
3D support for remote desktop[26] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

=

26. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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7.4 Creating the Model in CADFEKO

Create the model geometry using the CAD component, CADFEKO.
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7.4.1 Launching CADFEKO (Windows)

There are several options available to launch CADFEKO in Windows.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.

s Altair Feko 2022.1 - *

File Home Documentation  Utilities

» » »

&c &p & EDITFEKO “p' Zw LA |~ e =4,
CADFEKO POSTFEKD QUELEFEKO ProMan WallMan AMan | .2 | newFASANT | WRAP  SAM Chedk for  Terminal
Updates
Feko WinProp newFASANT WRAP Tools

Figure 154: The Launcher utility.

e Open CADFEKO by double-clicking on a .cfx file.
e Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

[5/ Note: If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

7.4.2 Launching CADFEKO (Linux)

There are several options available to launch CADFEKO in Linux.
Launch CADFEKO using one of the following workflows:
e Open CADFEKO using the Launcher utility.
e Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:
/home/user/2022.1/altair/feko/bin/cadfeko

e Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

/home/user/2022.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

[/ Note: Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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7.4.3 Adding Variables

Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.
1. Open the Create Variable dialog using one of the following workflows:
]

On the Construct tab, in the Define group, click the _Ix Add Variable icon.

e On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Construct | Configuration

Items Y H5F v

v Definitions A
~ iVariables . :
0 = 1/sqrt{eps0*mul) % Add Variable *r
eps0 = 8.35413?31?51Eg; Edit Variahles
mul = pi*de-7
pi = 3.14159265358979323846
zfl = sgri{mul/epsl)
MNamed Points
[ Media
Workplanes
A Field/Current Data
Waork Surfaces
E}Ts Cables
¥ Model
Geometry v

Figure 155: The model tree (Construction tab).

On the model tree, click the & 4 icon. From the drop-down list, select Add Variable.

- -
I Add Variable #
& Add Point
E Media v
A Field/Current Data 4
AL Add Workplane Fo
{{) Cable Definition v
% Port ’
Mesh Refinement 4
- Solution Settings ’
T

Figure 156: The E|=,i| drop-down list available in the model tree.

e Press # to use the keyboard shortcut.
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2. Create the following variables:

Name
alpha
alpha_rad
d

lambda

freg

O Tip:

Expression
60
alpha*pi/180
0.25

1

cO0/lambda

p.203

e Click Add to keep the Create Variable dialog open and add more variables.
¢ Click Create to add a variable and close the Create Variable dialog.
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7.4.4 Creating the Bent Dipole

Create the bent dipole using a polyline.

To illustrate the usage of custom workplanes, the bent dipole is created using a custom workplane.

1. On the Construct tab, in the Create Curve group, click the /:j Polyline icon.

sc Create Polyline >
Geometry Workplane
1 GE“-.,_:
n‘
u/~ |2 C5 s
B —
C3\
cal”
Corner 1
U ol fa
U &
N o &
1 (0,00
2 (1.1, 1
Add row Remove row
Import points
Label [palyline1
Create Add Cloze

Figure 157: The Create Polyline dialog showing the default values. Active fields are outlined in yellow.

5/ Note: Default values are used on geometry creation dialogs to allow a preview in the
3D view. You may change the values as required.

@ Tip: An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctri+Shift+left click on a variable or named point in the model tree.

2. Create a polyline.
a) Under Corner 1, add the following coordinates:
e Corner 1:
o U: lambda/4*cos(alpha_rad) - d
o V:0
o N: lambda/4*sin(alpha_rad)

b) In the table, click on the second row to make Corner 2 active. Add the following
coordinates:
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e Corner 2:
o U: -d
o V:0
o N: O
c) Click Add row for Corner 3. Click on the third row to make Corner 3 active. Add the
following coordinates:
e Corner 3:
o U: lambda/4*cos(alpha_rad) - d
o V:0
o N: -lambda/4*sin(alpha_rad)
d) Set the Label to Bent dipole.

Figure 158: The bent dipole with corner point on the X axis.
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7.4.5 Creating the Plate

Create the plate with a vertical orientation located at the origin using a rectangle.

1. On the Construct tab, in the Create Surface group, click the [ _| Rectangle icon.
2. Create a rectangle using the Base centre, width, depth definition method.

a) Base centre (C): (0, 0, 0)

b) Width (W): lambda

c) Depth (D): /lambda

d) Label: rReflector

sc Create Rectangle >

Geometry Workplane
Definition methods
Base centre, width, depth w
Ha

*
Vv

D
oS

u
[

Base centre (C)

U loo |
v |oo |
N |0 |
Dimensions

Width (W) |lambda |
Depth (0)  |lambda |

Label [Reflector |

Create Add Close

Figure 159: The Create Rectangle dialog.

3. Maodify the orientation of the rectangle.

a) On the Create Rectangle dialog, click the Workplane tab.
b) Click Predefine workplane.

c) From the drop-down list, select Global YZ.
4. C(Click Create to create the rectangle and to close the dialog.
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7.4.6 Ports, Sources and Loads in CADFEKO

Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Creating the Port

Define a wire port on the feed pin to excite the dipole. A voltage source will be added to this port.

[/ Note: A portis a mathematical representation of where energy can enter (source) or leave
a model (sink). Use a port to add sources and discrete loads to a model.

1. Select the wire where the port is to be added.
a) In the model tree, select Bent_dipole.
b) In the details tree, select one of the wires of Bent_dipole.
2. Open the Create Wire Port dialog using one of the following workflows:

On the Source/Load tab, in the Ports group, click the /o“’ Wire Port icon.

e In the details tree, a right-click context menu is available on the wire. From the drop-down
list, click Create port > Wire Port.

3. Under Place port on, click Segment.

¢ Create Wire Port *

Edge |Bent_dipole.WireS |

Place port on
@ Segment O Vertex

Location on wire
(@) Start

() Middle

() End

() other

[] reverse polarity

Label [wirePort1

Create Add Cloze

Figure 160: The Create Wire Port dialog.

4. Under Location on wire, select the option that places the port on the X axis for the selected
wire.

5. Click Create to create the port and to close the dialog.

J\ ALTAIR
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Adding a Voltage Source

Add a voltage source to the port of the bent dipole.

p.209

1. On the Source/Load tab, in the Sources on Ports group, click the @ Voltage Source icon.

2. On the Add Voltage Source dialog, use the default settings.

Port | WirePortl
Voltage
Magnitude

Phase

¢ Create Voltage Source

[1o

0.0

Reference impedance (Ohm) |50.D

Label |1,.'.:.|tage5-:uurce 1

Create

Add

Cloze

Figure 161: The Create Voltage Source dialog.

3. Click Create to create the voltage source and to close the dialog.

5/ Note: The Configuration tab was selected automatically when you defined the

voltage source. You may also add sources, loads and set the frequency from here.

Proprietary Information of Altair Engineering

J\ ALTAIR



Altair Feko 2022.1.1

7 Optimisation of Bent Dipole and Plate p.210

7.4.7 Setting the Simulation Frequency

Specify the frequency range of interest. For this example, a single frequency point is used.
1. On the Source/Load tab, in the Settings group, click the /|| Frequency icon.

A variable was created at the beginning of the example that contains the solution frequency.
2. In the Frequency (Hz) field, enter freq.

¢ Solution Frequency *

Frequency Export Advanced

Single frequency

Frequency (Hz) |ﬁeq |

0K Apply Cancel

Figure 162: The Solution Frequency dialog.

3. Click OK to set the frequency and to close the dialog.

5/ Note: With the frequency set to freqg, the actual frequency is 299.792 MHz. In the
model tree, click the Configuration to view the specified simulation frequency.
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7.4.8 Requesting Far Fields
Add a far field request (in the azimuth direction) to the model.

1. On the Request tab, in the Solution Requests group, click the @ Far Fields icon.
2. On the Request Far fields dialog, click Horizontal cut (UV plane).

s¢ Request Far Fields *
Position | Workplane | Scope Advanced

(® Calculates fields as specified

(O Caleulates fields in plane wave incident direction

Coordinate system
(® Spherical () Cartesian

All angles are in degrees

Start End

& [s0.0 |1 @ [s0.0 |
@ loo ||| @ [ss0.0 |
Increment Mumber of field points

& oo [ /| & [ |
@ [20 ||| o [s1 |

Horizontal cut (UV plane)
Vertical cut (UM plane)
Vertical cut (VM plang)

30 pattern

Label [FarField1

Create Add Close

Figure 163: The Request Far Fields dialog.

3. Use the default label.

4. Click Create to create a far field request and to close the dialog.
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7.4.9 Defining an Optimisation Search

Add an optimisation search to maximise the maximum gain in the azimuth direction.

1. On the Request tab, in the Optimisation group, click the ’;}\j Add Search icon.

2. On the Create Optimisation Search dialog, set the Optimisation convergence accuracy to
Normal (default).

3. Click Create to create the new optimisation search and to close the dialog.

¢ Create Optimisation Search >

Method type: | Automatic

e

Options Advanced

Optimisation convergence accuracy (standard deviation)
() High (slower)

(®) Mormal (default)

() Low (faster)

Label |Optimisationsearch1

Create Add Cloze

Figure 164: The Create Optimisation Search dialog.
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7.4.10 Specifying the Optimisation Parameters

Specify the optimisation parameters. Choose from existing variables and specify their minimum and
maximum values

1. In the model tree (Construction tab), select the relevant search. On the Request tab, in the

- - - . = .
Optimisation group, click the (;;; Parameters icon.

2. On the Modify Optimisation Parameters dialog, click the Add button to add a second

parameter.

3. Populate the fields on the Modify Optimisation Parameters dialog as given in the table.
Variable Min value Max value Start value
alpha 20 110 80
d 0.7 0.9 0.8

4. Click OK to set the parameters and to close the dialog.
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7.4.11 Specifying the Far Field Goal

Specify the goal focus, the operations to perform on the goal, and the goal objective.

1. In the model tree, on the Construction tab, select OptimisationSearch1l.

2. 0On the Request tab, in the Optimisation group, click the () Add goal function icon. From the

drop down list, select () Far Field Source.

3. Under Goal focus, specify the requested output from the Solver.
a) Under Focus source type, select Defined in CADFEKO.
b) In the Focus source field, from the drop-down list, select FarField1.
c) In the Focus type field, from the drop-down list select Gain.
d) In the Polarisation field, from the drop-down list select Total.

4. Under Focus processing steps, specify the processing to be performed prior to comparing with
the objective.

a) In the Operation column, from the drop-down list, select Max.
5. Under Goal operator, specify how the objective and focus is compared.
a) In the Operator type drop-down list, select Maximise to maximise the gain.

e The Goal objective is the value or values with which the focus is compared. For
maximisation and minimisation the Goal objective is hidden.

e For multiple goals, the Weight will determine the contribution of the particular goal to
the global error function during the fitness evaluation.
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zc Create Far Field Optimisation Goal *

Goal focus
Focus source type

(®) Defined in CADFEKO
(") Defined in EDITFEKD

Focus source | FarField1
Focus type Gain
Polarisation Total

Focus processing steps

Expression | max(Focus)

Operaticn Value

1 Max ~ 0.0

Add Remove
Goal operator

Operator type | Maximise

Weight |1 |

Label |FarFieldoptimisationGoall |

Create Add Close

Figure 165: The Create Far Field Goal dialog.

6. Click Create to create the new far field goal and to close the dialog.
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7.4.12 Modifying the Auto-Generated Mesh

When the frequency is set or local mesh settings are applied to the geometry, the automatic mesh
algorithm calculates and creates the mesh automatically while the GUI is active using default mesh
settings. When required, these mesh settings may be modified.

1. Open the Modify Mesh Settings dialog using one of the following workflows:

* On the Mesh tab, in the Meshing group, click the € Modify Mesh icon.

e Press Ctrl+M to use the keyboard shortcut.
2. On the Modify Mesh Settings, set the Mesh size to Coarse.
3. Set the Wire segment radius to 0.001.

¢ Modify Mesh Settings >

Options Advanced
Global mesh sizes
Mesh size | Coarse “| ?
Global wire radius

Wire segment radius  [0,001 |

oK Apply Cancel

Figure 166: The Modify Mesh Settings dialog.

4. Click OK to create the mesh and to close the dialog.
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7.4.13 Saving the Model

Save the model to a CADFEKO. c£x file.

1. Save the model using one of the following workflows:

On the Home tab, in the File group, click the G Save icon.

e Press Ctrl+S to use the keyboard shortcut.
2. Save the model as Dipole Optimisation.cfx.
3. Click Save to close the dialog.
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7.5 Launching the Solver

Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

® On the Solve/Run tab, in the Run/Launch group, click the @) Feko Solver icon.

* On the application launcher toolbar, click the Feko Solver icon in the |1 = . % | group.

e Press Alt+4 to use the keyboard shortcut.
If the model contains unsaved changes, the Save Model dialog is displayed.
2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

¢ Bxecuting runfeke X

Model: Dipole_Optimisation

¥ Details oK ® stop

Figure 167: The Executing runfeko dialog.
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7.6 Launching POSTFEKO

Open POSTFEKO from within CADFEKO.
Use one of the following workflows to launch POSTFEKO:

® On the Solve/Run tab, in the Run/Launch group, click the <. POSTFEKO icon.

® On the application launcher toolbar, click the POSTFEKO icon in the ‘@ BT ] ‘group.

e Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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7.6.1 Setting Up POSTFEKO to View Optimisation Progress

Create a 3D view with the far field results as well as two Cartesian graph to view the distance
parameter and far field goal.

When POSTFEKO is opened, the model is displayed in a single 3D view.
1. Display the far field in the 3D view.

a) On the Home tab, in the Add results group, click the @ Far Field Source icon.
b) From the drop-down list select FarFieldl.

Total Gain
6.75
6.00
5.25
450
3.75
3.00
2.25
150

I 0.75
0.00

Figure 168: The far field result for the bent dipole and plate.

2. Add a Cartesian graph and view the optimised parameter, alpha.
a) On the Home tab, in the Create new display group, click the & Cartesian icon.
b) On the Home tab, in the Add results group, click the (©) Optimisation icon. From the

drop-down list, select Optimisation.
c) In the result palette, in the Trace list, select alpha.

Optimisation (Optimisation)

P Source

¥ Slice
Independent axis (Horizontal)

Optimisation run number e
Fixed

Trace alpha w

Figure 169: The Optimisation panel in the result palette.

3. Duplicate the first graph (to create a second graph) to view the optimised parameter, d.
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a) On the 3D View contextual tabs set, on the Display tab, in the Duplicate group, click the
[ Duplicate view icon.

b) In the result palette select the trace, Optimisation.
¢) In the result palette, in the Trace field, select d.

4. Duplicate the first graph (to create the third graph) and view the far field goal versus optimisation
run number.

a) On the 3D View contextual tabs set, on the Display tab, in the Duplicate group, click the
[ Duplicate view icon.

b) In the result palette select the trace, Optimisation.
c) In the result palette, in the Trace field, select searchl.goals.farfieldgoall.
5. [Optional] Arrange (tile) the four windows to view the multiple windows at once.

a) On the View tab, in the Window, click the H ] Tile icon.

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1
7 Optimisation of Bent Dipole and Plate p.222

7.6.2 Launching OPTFEKO
Run OPTFEKO and view the output of the optimisation progress.

The following steps are performed in POSTFEKO, but the optimiser can also be launched from CADFEKO
1. On the Home tab, in the Run/Launch group, click the @ Optimisation icon.

5/ Note: The Executing optfeko dialog is displayed in a condensed format.

Click Details to view any problems encountered during the optimisation process.

sc Executing optfeke d

Madel: Dipale_Optimisation

g -
0 2 distinct notice(s) occurred

oY

¥ Details @ ox ® stop

Figure 170: The Executing optfeko dialog in condensed format.

2. Scroll to the bottom of the Executing optfeko window output to view the onvergence
information, as well as the optimal parameters.

5/ Note: Sensitivity information is included if sufficient data is available for the analysis.

s¢ Executing optfeko d

Model: Dipole_Optimisation
Total progress:

=
(=]
&#

Current phase:
> optfeko Dipole_Optimisation —run-from-gui
Output O riotices (2 Finy Warnings M Errors

Value of the aim function (analysis no. 17) is -5.404195353e+00 L]

SIMPLEX NELDER-MEAD finished
Standard deviation small enough: 1.700326222e-04

Sensitivity of optimum value with respect to each optimisation parameter:

Parameter Sensitivity
alpha 2.726861851e-04
d 6.078676330e-01

Cptimum found for these wvariables:

alpha = §.234867141e+01
d = 7.830116975e-01

Optimum aim function value: -5.40427&6487e+00 v
¥ Details @ox || @ stop

Figure 171: The Executing optfeko dialog with details.

The Executing optfeko window displays the optimum values as follows:
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e alpha: 82.349°
e d: 0.783 meters

J\ ALTAIR

Proprietary Information of Altair Engineering



Altair Feko 2022.1.1
7 Optimisation of Bent Dipole and Plate p.224

7.6.3 Viewing the Optimisation Results

View the optimisation results obtained by OPTFEKO.

The graphs have already been configured to view the progress of the optimisation process.

View the final results of OPTFEKO for the optimisation parameters on the previously defined 3D view
and 2D graphs.

Optimisation

90

] R e LY e il ALl

80

] R ECRGEL LR ST EFP PR

Optimisation

0 3 & 9 12 15 18

Optimisation run number

Trace = alpha

Figure 172: The optimisation run number on a Cartesian graph.

[/ Note: For more details on the optimisation process, view the log file,
Dipole Optimisation.log, that was created in the same directory as the current model.

OPTFEKO creates multiple CADFEKO (.cfx) models for each iteration, located in the same directory as
the current model. For example:

Dipole Optimisation opt 1.cfx
Dipole Optimisation opt 2.cfx
Dipole Optimisation opt 3.cfx

Dipole Optimisation opt 17.cfx

including the model with the variables set to the optimum values (indicated by the optimum file
extension).

Dipole Optimisation optimum.cfx
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Total Gain
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4.
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OO e = N W W

Figure 173: The optimised far field for the bent dipole and plate.
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7.7 Closing Remarks

This example showed the construction and optimisation of a bent dipole in front of a plate.

Many concepts were introduced in this simple example that are applicable to models commonly created
in CADFEKOQ. This example has demonstrated how to configure a CADFEKO model as well as how
optimisation in CADFEKO is executed. The optimisation process as well as the optimum values for the
model parameters were displayed in POSTFEKO, but can also be viewed in the . 1og file.
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