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Safety Guidelines 
This manual contains notices you have to observe in order to ensure your personal safety, as well as to 
prevent damage to property. The notices referring to your personal safety are highlighted in the manual 
by a safety alert symbol, notices referring to property damage only have no safety alert symbol. The 
notices shown below are graded according to the degree of danger.

Siemens AG 
Automation and Drives  
Postfach 4848 
90437 NÜRNBERG 
GERMANY 

Copyright © Siemens AG 2006
A5E00595265-01 

Siemens AG 2005 
Technical data subject to change. 

! Danger 
indicates that death or severe personal injury will result if proper precautions are not taken. 

! Warning
indicates that death or severe personal injury may result if proper precautions are not taken.

! Caution 
with a safety alert symbol indicates that minor personal injury can result if proper precautions are not 
taken.

Caution 
without a safety alert symbol indicates that property damage can result if proper precautions are not 
taken.

Notice 
indicates that an unintended result or situation can occur if the corresponding notice is not taken into 
account.

If more than one degree of danger is present, the warning notice representing the highest degree of 
danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a 
warning relating to property damage.

Qualified Personnel 
The device/system may only be set up and used in conjunction with this documentation. Commissioning 
and operation of a device/system may only be performed by qualified personnel. Within the context of 
the safety notices in this documentation qualified persons are defined as persons who are authorized to 
commission, ground and label devices, systems and circuits in accordance with established safety 
practices and standards.

Prescribed Usage 
Note the following: 

Warning! This device and its components may only be used for the applications described in the catalog or the 
technical description, and only in connection with devices or components from other manufacturers 
which have been approved or recommended by Siemens. 
Correct, reliable operation of the product requires proper transport, storage, positioning and assembly 
as well as careful operation and maintenance.

Trademarks 
All names identified by ® are registered trademarks of the Siemens AG.  
The remaining trademarks in this publication may be trademarks whose use by third parties for their 
own purposes could violate the rights of the owner.

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and 
software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. 
However, the information in this publication is reviewed regularly and any necessary corrections are 
included in subsequent editions.



Preface

Purpose of the Manual 
This manual provides information necessary to set up PCS 7/APACS+™ OS for 
V6.1.

Required Basic Knowledge 
Readers are presumed to be knowledgeable in the use of PCS 7 and  APACS+.

Where is this Manual valid? 
This manual is valid for the software package PCS 7/APACS+ OS for V6.1. 

Training Centers 
Siemens Technical Training Center provides extensive training for all levels of 
plant personnel to ensure optimal performance from APACS+  and PCS 7 control 
systems. Classes include extensive hands-on activities using appropriate 
equipment, making the training directly and immediately applicable. 
On-line information is available: http://www.sea.siemens.com/sitrain
Siemens also offers a number of training courses to familiarize you with the 
SIMATIC S7 automation system. Please contact your regional training center or 
our central training center in D 90327 Nuremberg, Germany for details:  
Telephone:  +49 (911) 895-3200.  
Internet: http://www.sitrain.com
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A&D Technical Support 
Worldwide, available 24 hours a day:  

Beijing

Nürnberg 

Johnson City 

United States: Johnson City, TN Worldwide: Nürnberg Asia / Australia: Beijing 
Technical Support  
24 hours a day, 365 days a year 
Phone:+49 (180) 5050-222 
Fax:+49 (180) 5050-223 
E-Mail: ad.support@siemens.com
GMT:+1:00 

Technical Support and Authorization 
Local time: Monday to Friday  
8:00 AM to 5:00 PM 
Telephone:+1 (423) 262 2522 
or +1 (800) 333-7421 (USA only) 
Fax:+1 (423) 262 2289 
Mail to: techsupport.sea@siemens.com
GMT: -5:00

Authorization 
Local time: Monday to Friday  
8:00 AM to 5:00 PM 
Phone: +49 (180) 5050-222 
Fax: +49 (180) 5050-223 
Mail to: ad.support@siemens.com
GMT: +1:00 

Technical Support and Authorization 
Local time: Monday to Friday  
8:00 AM to 5:00 PM 
Phone:+86 10 64 75 75 75 
Fax:+86 10 64 74 74 74 
Mail to:ad.support.asia@siemens.com
GMT:+8:00

Automation and Drives Service and Support International 
http://www.siemens.com/automation/service&support

The languages of the SIMATIC Hotlines and the authorization hotline are generally German and English. 
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1 Introduction 

The purpose of this document is to outline the steps required to set up a PCS 7 
system and a corresponding PCS 7 project that communicate to APACS+ 
Controllers. Project development is done on an OS Engineering Station using 
SIMATIC Manager. This document is based on the architectural layout below.  

Note 
For further information on a specific topic in this document, refer to the 
documentation on the PCS 7 DVD set, the WinCC Information System, or in the 
documentation folder Start > SIMATIC > Documentation > English on the hard 
drive.

Note 
Your client and your engineering station may be the same physical computer. The 
diagram below shows them to be different computers.  

Ethernet

OS Engineering 
Station OS Client

Primary OS Server Standby OS Server
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Introduction 

1.1 Software Installation Overview   

Prerequisite Note 
For APACS+ ACM systems V2.05 or below, or CCM systems older than V3.30, 
please refer to the following Service Memos located on the APACS+ Electronic 
Manuals CD. 

SM39ACM-13 – APACS+™ ACM Operating System Software Version 4.40 or 
Higher to Correct Rest Problems. 
SMQLCCM-2 – QUADLOG® Control Module (CCM, ACM+/ACM) System 
Software Maintenance Issue for Versions 3.03 to 3.23.  

Note 
If you are upgrading an existing project, ensure that you have archived your project 
and saved the archive to media or another computer before installing software on 
your stations.  

Note 
Administrator rights are required to install the software. In addition, disable any 
virus protection software that is currently running. 

Note 
All computers on the network must have the same user accounts and passwords. 

Step Procedure 

1 Install the Operating System  

2 Install Third Party Software 

3 Install PCS 7 Software

4 Install APACS+ Control CD V6.1 

5 Install  PCS 7/APACS+ OS Option V6.1 

6 Install authorizations and licenses  

7 Create a new OS Project  

8 Download the OS Project 

Note 
The installation of some components automatically reboots the computer.  
Following the reboot, log on again as the PCS 7 user.  

PCS 7/APACS+ OS Setup Guide for V6.1 
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2 Install the Software 

Note 
If you are updating an existing installation, please review section three prior to 
installing any software.

2.1 Install the Operating System 
Refer to the following references for detailed installation instructions:  

From the PCS7 Installation DVD (PCS7 Toolset v6.1 with SP1), find
Manuals > English > PCS 7 – PC Configuration and Authorization.PDF 

Please review installation instructions in both readme files:  

 From the root directory of the PCS 7 Installation DVD (PCS7 Toolset v6.1 with 
SP1), find the file PCS7-Readme.wri. Note: If the logon name of the user who 
performed the installation of PCS 7 differs from the operator of the PCS 7 
software, pay particular attention to the "OPC - Settings under Windows 2000" 
section of this document. 

 From the PCS 7 Installation DVD (PCS7 Toolset v6.1 with SP1), find 
Manuals > English > PCS 7 System Documentation Readme.wri

Additional information: Start > Simatic > Information > English

2.2 Install Third Party Software 
Third party software (e.g. Microsoft Office, PC Anywhere, Virus software etc…) 
should be installed prior to installing PCS 7.  Refer to the PCS 7-Readme.wri and 
PC Configuration and Authorization. PDF file for further information.

2.3 Install PCS 7 Software  
Refer to the following references for detailed installation instructions: 

From the PCS7 Installation DVD (PCS7 Toolset v6.1 with SP1), find 
Manuals > English > PCS 7 – PC Configuration and Authorization.PDF 

Please review installation instructions in both readme files:  

 From the root directory of the PCS 7 Installation DVD (PCS7 Toolset v6.1 with 
SP1), find the file PCS7-Readme.wri

 From the PCS 7 Installation DVD (PCS7 Toolset v6.1 with SP1), find 
Manuals > English > PCS 7 System Documentation Readme.wri 
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Install the Software 

Note 
Select the appropriate software packages during PCS 7 software installation.  
Use the following as a guide:  

 Engineering Node - Select PCS 7 Engineering 
 OS Servers - Select OS Server 
 OS Clients - Select OS Client (All clients must be upgraded to PCS 7 V6.1 

SP1 to communicate with PCS 7/APACS+ OS V6.1.) 

 Batch  
 Batch Engineering Node - Select PCS 7 Engineering and Batch 

Engineering 
 Batch Servers - Select Batch Server 
 Batch Clients - Select Batch Clients 

 Archive Server – There are no PCS 7/APACS+ OS V6.1 software 
components that need to be installed on the Archive Server.  
However, the Archive Server must be at PCS 7 V6.1 SP1.  

PCS 7/APACS+ OS Setup Guide for V6.1 
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Install the Software 

2.4 Install APACS+ Control CD V6.1 

Note 
The following procedure is based on a typical installation. Refer to the table in 
section 9.1 for components to install per node type.  

Note 
The OPC Device Server needs MS SQL Server. If MS SQL Server is not installed, 
install a copy of the MSDE from the Microsoft folder on this CD.   

Note 
Prior to installing this software, log on with Administrator rights and disable any 
virus protection software that is currently running.  

1. Insert the APACS+ Control CD V6.1 into the CD ROM drive.  
The Welcome to Siemens window opens. 
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Install the Software 

2. Click the Next button. 
The Software License Agreement window opens. 

3. Read the Software license agreement.   
Click the Yes button to accept the agreement. 
The Choose Installation Path dialog box opens.  

PCS 7/APACS+ OS Setup Guide for V6.1 
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Install the Software 

4. Select an installation path, and click the Next button.
The Choose Directory dialog box opens (only if you click on the browse button 
in the Choose Installation Path dialog box.)  

5. Click the OK button.
For new installations, the Choose the License Source dialog box opens.  
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Install the Software 

For upgrade installations, the Select Install Type dialog box opens.  

6. Select the license file source. For new installations, the license should be on the 
diskette.  
Click the Next button.
The APACS+ Component Selection dialog box opens. Make any changes to 
the list of components selected for installation by selecting a category, clicking 
the Change button, and selecting the components to install.  
Please refer to the table in section 9.1 APACS+ Control CD V6.1 for the 
appropriate selection. Your choice of components depends on the type of 
station (server, client, etc…) you are installing.  
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Install the Software 

7. Click the Next button.
If this is the first time OPC Server is being installed, the Select OPC Device 
Server Startup Mode dialog box opens.  

If OPC Server has been installed before, the Select Runtime API dialog box 
opens. 
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Install the Software 

8. Select the appropriate option for your installation. 
Click the Next button.
The Review Selections and Installation Paths dialog box opens. 

9. Scroll through the list and verify that the correct components have been 
selected. If any components are missing or were incorrectly selected, click the 
Back button to return to the screen to reselect the appropriate components. 
When you are satisfied that the list is correct, click the Install button. 

The installation begins copying the files. 
The Installing Support Software progress bar opens.  

Note 
If you are installing on Windows XP or Windows 2003, the installation will inform 
you that the software has not undergone Windows Logo testing. Click OK to 
acknowledge, and continue the installation. The Windows operating system will 
again warn you that the software has not undergone Windows Logo testing. Click 
the Continue Anyway button to continue the installation. Windows Logo testing 
does not affect the installation or operation of the software. 
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Install the Software 

10.The Reboot your System? dialog box opens. 
If you had a license diskette in the floppy drive, remove it. Take the Install CD 
out of the CD drive.
Select the Yes, I want to restart my computer now. radio button, and click the 
Finish button.
The installation is complete.  
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Install the Software 

2.5 Install APACS+ OS Option V6.1  

Note 
The following procedure is based on a typical installation. Refer to the table in 
section 9.2 for packages/components to install per node type.  

Note 
Prior to installing this software, log on with Administrator rights and disable any 
virus protection software that is currently running. In addition, this software should 
be installed after all other PCS 7 software has been installed. Ensure that all PCS 
7 log on activity is complete. Refer to the Readme.wri file on the installation CD for 
more information. 

1. Insert the PCS 7 APACS+ OS V6.1 CD 1 into the CD-ROM drive.  
The setup program automatically opens.  
The Welcome dialog box opens. 

2. Click the Next button to continue. The Readme dialog box opens. 
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Install the Software 

3. To view the readme file, click the I want to read the readme file button. 
Click the Next button to continue.  
The Software License Agreement dialog box opens. 

4. Read the Software license agreement.
Click the Yes button to continue.  
The User registration dialog box opens. 
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Install the Software 

5. Enter Name, Company and ID no. The ID number can be found on the 
Certificate of License that comes with the software or on the Authorization disk. 
Click the Next button to continue.  
The Target drive dialog box opens. 
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Install the Software 

6. Select the Target drive. This is the drive where PCS 7 Options for APACS+ will 
be installed. It should be on the same drive as the PCS 7 product.  
Click the Next button to continue.  
The Packages dialog box opens. 

7. Select the packages to install. Please refer to the table in section 9.2 PCS 7 
APACS+ OS Option V6.1 for the appropriate packages to install for your 
system.  
Click the Next button to continue.  
The PCS 7 Options for APACS+ Components dialog box opens.  
Please refer to the table in section 9.2 PCS 7 APACS+ OS Option V6.1 for the 
appropriate components to install on a station. The choice here depends on the 
type of station you are installing (client, server, etc…).  
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Install the Software 

8. Scroll through the list and add or delete any components as appropriate. 
Click the Next button to continue.  
After the appropriate software components are installed, the PCS 7 Options for 
APACS+: Installation completed dialog box opens. 

9. Remove the CD from the CD-ROM drive. 

10.Select the Yes, restart the computer now radio button, and click the Finish
button to reboot the PC. 
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Install the Software 

2.6 Install authorizations and licenses 
1. Insert the Authorization floppy disk that came with your software into drive ‘A’.  

2. From the Windows taskbar, click Start button>SIMATIC>License 
Management>Automation License Manager.

3. Double-click the ‘A’ drive. 

4. Select all of the authorizations. 

5. Transfer the authorizations from the floppy to the target drive. 

6. Remove the floppy disk from drive A’.

Note 
Please refer to the following link for the most current information regarding product 
updates:  

http://support.automation.siemens.com /WW/View/en/14905487/133100 

2.7 Enhanced Trend Control  
Several enhancements to the standard PCS 7 Trend Control are available as an 
add-on. See the EnhancedTrendControl folder on the APACS+ OS Option V6.1 CD 
for further details. 

Install the Enhanced Trend Control to each node type: 

 Engineering Station  

 Servers  

 Clients 
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3 Update a project from V6.0 to V6.1 

Note 
OS Project development is done on the OS Engineering Station using SIMATIC 
Manager. This project will be downloaded to the system’s single server or 
redundant server pair and the clients. The sample project below assumes a single 
project with a redundant server pair and one client.  

3.1 Create a new project in SIMATIC Manager 
1. Open SIMATIC Manager, Start > SIMATIC > SIMATIC Manager 

The PCS 7 Wizard: ‘New Project’ dialog box opens.  

Note 
Press the F1 function key for help on each screen of the PCS 7 New Project 
Wizard, or press the Help button.  
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Update a project from V6.0 to V6.1 

2. Select a project type. For example, select the Single Project radio button. 

Multiproject with project and master data library – select this option if you 
want to distribute project engineering across multiple engineering stations.  

Single Project – select this option when project engineering will be performed 
from a single engineering station.  

3. Click the Continue button.  
The Which CPU will you use in your project? dialog box opens.  

4. Click the Continue button to accept the default. (Choices here are only relevant 
to S7 projects.)  
The Which objects will be used in the project? dialog box opens.  
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Update a project from V6.0 to V6.1 

- In the Plant Hierarchy area, the Number of levels should be configured 
when using S7-400 controllers in the same OS project as APACS 
controllers. It should be set to the same value used in DBA.  

- In the AS objects area, clear CFC chart and SFC chart check boxes. 
These are only relevant to S7 projects.   

- In the OS objects area, select the PCS 7 OS check box, and the 
appropriate system type.   

Single-user System – a single PC station will be created with an OS 
project.  

Multi-user System – two PC stations will be created, an OS server 
project, and an OS client project.  

Multi-user system redundant – three PC stations will be created, two OS 
server projects and an OS client project.  

Note 
For SIMATIC Batch options, a SIMATIC Batch check box will also appear in the 
OS Objects area. It is not necessary to check this box for SIMATIC Batch, even if 
you are installing the Batch option.  
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Update a project from V6.0 to V6.1 

5. Click the Continue button.  
The Where do you want to save the multiproject or the project? dialog box 
opens.  

- In the Directory name box, enter a directory folder name or accept the 
default. This is the folder name for the directory under which the 
client/server projects will be created. Do not use the same directory as the 
existing project.  

- In the Storage location (path) box, enter a path or accept the default. This 
path is where the directory folder will be located. This is the path for the 
master project on the engineering station.  
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Update a project from V6.0 to V6.1 

6. Click the Make button.
The Message Number Assignment Selection dialog box opens.  

7. Accept the default.  Click the OK button. The project is created. This setting 
applies to projects that include S7-400 controllers and does not apply to 
messages created by DBA. 
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Update a project from V6.0 to V6.1 

3.2 Create New Folders on the Primary and Standby 
Servers and All Clients 
Shared folders on the servers and clients are needed to store the project created 
on the Engineering Station.  When the project is downloaded, it will be transferred 
from the Engineering Station to these folders. You cannot configure your stations in 
SIMATIC Manager until these folders are created and properly set up. Follow these 
steps to create and set up these folders, if they don’t already exist. 

1. Using Windows Explorer, create a new folder such as ‘PROJECT’ on one of the 
drives of the Primary and Standby servers, as well as all clients. The client and 
server projects created on the Engineering Station shall be downloaded to this 
folder on each node. If desired, you may create a ‘Projects’ folder under 
\Program Files\Siemens\Step7\s7proj\ for your projects. However, the name 
of the folder and where you place it is up to you.  

2. Setup sharing on the newly created PROJECT folder. Right-click the PROJECT
folder and select Sharing… The PROJECT properties dialog box opens. 

3. Select the Sharing tab, select the Share this folder radio button.

4. Click the Permissions button. The Permissions window opens.  Select 
Everyone, and then click the Full Control check box in the Allow column.  

5. Click OK to close the Permissions window.  

6. Click the OK button to close the Project Properties dialog box. 
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Update a project from V6.0 to V6.1 

3.2.1 Configure the Stations 
Configuring the stations identifies which computers are the server or client stations, 
and the path to which the project will be downloaded.  

The following stations are shown in the SIMATIC Manager component view: 

 SIMATIC PC Station (1) – Primary OS server 

 SIMATIC PC Station (2) – Standby OS server 

 SIMATIC PC Station (3) – Client 

1. Close the plant view.  

2. Expand the tree view for each station in the Component view.  
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Update a project from V6.0 to V6.1 

3.2.1.1 Primary Server  
1. In the Component view, right-click SIMATIC PC Station(1), and select Object 

Properties. The Properties – SIMATIC PC Station dialog box opens.  

2. In the General tab, enter the computer name of the primary computer in both 
the Name and Computer name fields. These names must be entered in ALL 
CAPS. Click the Ok button.   
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3. In the Component view, below the WinCC Application, right-click OS(1), and 
select Object Properties. The Properties dialog box opens.  
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4. From the General tab, in the Name field, rename the OS(1) to the existing 
Server Project Name.  
Important Note: If the OS name is not the same, two mcp files will be created 
in the new project.  
In the Author field, enter your Engineering Station Name.  

5. Click the Target OS and Standby OS Computer tab 

.

Note 
This step can be deferred until the OS servers and clients are actually set up and 
connected to the network. This must be completed before starting Download the 
Projects.  
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6. Press the Search button.  The Select target OS dialog box opens.  

Note 
It is important to have only one mapped drive to any target directory. Multiple 
mapped drives to the same location can cause download errors.  

7. Click the Network button to browse and map to the shared project folder on OS 
Server. If a mapped drive already exists, select it from the available drives listed 
in the Load In list box. This is the path to the folder on your primary server 
where you will store and operate the project. This path must include the network 
name of the target computer. Note: This folder must already exist on the 
primary and standby servers and be shared. This folder’s permissions should 
be set to Full Control for Everyone. Refer to section Create New Folders on 
the Primary and Standby Servers and All Clients in this document. Click the 
OK button.

8. Click the OK button.
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3.2.1.2 Standby Server  
1. In the Component view, right-click SIMATIC PC Station(2), and select Object 

Properties.

2. In the General tab, enter the computer name of the standby computer in both 
the Name and Computer name fields. These names must be entered in ALL 
CAPS. Click the Ok button.   
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3. In the Component view, below the WinCC Application, right-click OS(1)_StBy,
and select Object Properties. The default project name of Primary 
Server/Project Name_StBy must be used.  
The Properties dialog box opens.  
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4. Click the Target OS and Standby OS Computers tab.  

Note 
This step can be deferred until the OS servers and clients are actually set up and 
connected to the network. This must be completed before starting Download the 
Projects.  

5. Press the Search button. The Select target OS dialog box opens.  
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Note 
It is important to have only one mapped drive to any target directory. Multiple 
mapped drives to the same location can cause download errors.  

6. Click the Network button to browse and map to the shared project folder on OS 
Server. If a mapped drive already exists, select it from the available drives listed 
in the Load In list box. This is the path to the folder on your standby server 
where you will store and operate the project. This path must include the network 
name of the target computer.  
Note: This folder must already exist on the primary and standby servers and be 
shared. This folder’s permissions should be set to Full Control for Everyone.
Refer to section Create New Folders on the Primary and Standby Servers 
and All Clients in this document. Click the OK button.

7. Click the OK button. 
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3.2.1.3 Client Station  
Note: If your client is not the same computer as your OS Engineering Station, then 
perform the following steps. 

1. In the Component view, right-click SIMATIC PC Station(3), and select Object 
Properties.

2. In the General tab, enter the computer name of the client computer in both the 
Name and Computer name fields. These names must be entered in ALL 
CAPS. Click the Ok button.   

3. In the Component view, below the WinCC Application, right-click OSC(3), and 
select Object Properties. The Properties dialog box opens.  
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4. From the General tab, in the Name field, rename the OSC(3) to the existing 
client project name. 
Important Note: If the OS name is not the same, two mcp files will be created 
in the new project. 
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5. Click the Target OS tab.

6. Press the Search button.  The Select target OS dialog box opens.  

Note 
This step can be deferred until the OS servers and clients are actually set up and 
connected to the network. This must be completed before starting Download the 
Projects.  

Note 
It is important to have only one mapped drive to any target directory. Multiple 
mapped drives to the same location can cause download errors.  
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7. Click the Network button to browse and map to the shared project folder on OS 
Server. If a mapped drive already exists, select it from the available drives listed 
in the Load In list box. This is the path to the folder on your client server where 
you will store and operate the project. This path must include the network name 
of the target computer.  
Note: This folder must already exist on the primary and standby servers and be 
shared. This folder’s permissions should be set to Full Control for Everyone.
Refer to section Create New Folders on the Primary and Standby Servers 
and All Clients in this document.Click the OK button. 

8. From the Component view, add and configure additional clients, servers, and 
server pairs as needed.  You can add up to a total of 32 clients and 12 server 
pairs.
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3.3 Update a project from V6.0 to V6.1 
The procedure below is based on a project developed using the symbols and 
faceplates provided with PCS 7/APACS OS V6.0 or V6.0 SP1.

PCS 7 V6.1 added new functionality to the standard symbols/block icons and 
faceplates. The PCS 7/APACS OS V6.1 standard symbols/block icons and 
faceplates were updated to include this new functionality. If you have custom 
symbols/block icons and faceplates in your V6.0 project, you may want to modify 
these to include this new functionality. This should be completed before updating 
your project with DBA. Below is a list of the new functionality:   

Symbols/Block Icons 
 Block icon full name field is back lit when navigating to a picture from Loop-In-

Alarm.

 The Alarm Group Display was replaced to support Alarm Lock.  

 A new attribute was added to define where the faceplate opens. 

Faceplates
 The Alarm Group Display was replaced to support Alarm Lock. 

 The Alarm Lock icon was added.  

 Increase/decrease buttons added for Controller Output and Setpoint changes. 

 New attributes were added to define faceplate operation as 1-step or 2-step. 1-
Step does not provide a confirmation dialog box.  

 The Push Pin icon was added to keep the faceplate open when a new picture is 
opened.  

Contact Siemens for guidance on whether your custom symbols/block icons and 
faceplates can support the new V6.1 functionality and how to make the necessary 
modifications.  
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3.3.1 Import a current WinCC project into SIMATIC Manager 
1. Using the SIMATIC Manager project created in Section 3.1, verify that the name 

of the Server OS is the same name as the OS in your existing WinCC project.  

2. From the Windows start menu,  select Start > Simatic > WinCC > Tools > 
Project Duplicator. The WinCC Project Duplicator dialog box opens. 

3. Browse to existing server or client WinCC project in the Select the source 
project that is to be duplicated field.

4. Click the Save As button. The Saves a WinCC project window opens.  

5. Browse to the new SIMATIC Manager OS project folder, and enter the same file 
name as your current WinCC project name. Click the Save button.

6. The message The “project” already exists. Do you want to replace it? opens. 
Click the Yes button. 

7. The message The project already exists! Do you want to overwrite the project? 
opens. Click the Yes button.  

8. Confirm file replace, click yes to all.

9. Confirm folder replace, click yes to all.  The Copying progress bar opens. 
When the copy is complete, the former WinCC project will be embedded in a 
SIMATIC Manager project. 

10.Repeat steps 4 through 9 for all primary server and client projects.  

11.Open the new OS project and re-run the OS project editor for server and client 
projects. 

12.Select START > SIMATIC > DBA > PCS 7 DBA 

13. Select File > Open.  Browse to the existing V6.0 DBA project and Open.
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14.The following dialog is displayed, “This DBA project was not created with the 
same version of the DBA Utility that you are using. Do you want to convert the 
DBA project to current version?”  Click OK.

15.Select the PC Station View tab in the lower window. 

16.Select the Server OS, right-click, and Edit Object Properties.

17.For the Offline MCP file, browse to the new Server OS, and click OK.

18.Recompile DBA. 

19. Select File > Save Project As, and browse to the new project folder. You will 
be prompted that the file already exists, do you want to replace. Click OK.

20.Update the block icons. 

- From WinCC Explorer, open Graphic Designer on the ES station.  

- Open any PDL file in the project. 

- In the Dynamic Wizard section, select the 'Picture Functions' tab and 
double click on 'Update of the picture objects'.
Note: Template Picture and Control File fields should not exceed 256 
characters when running the 'Update of the picture objects' wizard. 

- Follow the prompts to update all pictures in the project or the active picture. 
In this case, select the 'yes, all pictures' radio button. Click the Next 
button to continue. 

- The Options dialog box is displayed. In the 'Please specify the name of 
the template picture' field, click the ellipse (…) button and select 
@@APACSTypicals.pdl. 

- Do not change the 'Please specify a name for the control file' field. 

- Click the Next button, then the Finish button to continue. 

- All graphic windows that contain the modified block icons should be 
updated. 

- If problems occur, refer to the ChangeObjects.log file.

- Close WinCC.

Note 

Additional recommendations 
Make a copy of the @@APACSTypicals.pdl file (and/or other project specific 
typical files) and place it in a separate directory on the hard drive.  This 
eliminates the possibility of @@APACSTypicals.pdl being overwritten if you 
upgrade to a new version of the PCS 7/APACS OS Options down the road.
Currently, you have to manually create the @@APACSTypicals.pdl. This 
may not be the case in the future.  
Copy the @@APACSTypicals.pdl to the \Program
Files\SIEMENS\WINCC\options\pdl\faceplatedesigner_v6 directory. In 
doing so, whenever a new project is created, the @@APACSTypicals.pdl file 
is automatically copied to the GraCS file of the new project. 
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21.Return to SIMATIC Manager, Component view. Right-click on WinCC 
Application > Primary Server project, and select Generate Server Data. After 
an hourglass is displayed, a message box appears to report Server data are 
generated successfully. Click OK.

22.Right-click on each client project, and select Assign OS Server.  Select the 
appropriate project check box. Click OK. The Assigning OS Server to…
progress message box appears. When the procedure is completed, click OK.

Note 
If the selected project is reported as unknown, clear the unknown project check 
box. Click OK. Select Assign OS Server to select the appropriate project check 
box.

23.Download the project to your servers and client using SIMATIC Manager. Any 
further changes to the project can be downloaded using SIMATIC Manager.  
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4 Create a New OS Project 

Note 
OS Project development is done on the OS Engineering Station using SIMATIC 
Manager. This project will be downloaded to the system’s single server or 
redundant server pair and the clients. The sample project below assumes a single 
project with a redundant server pair and one client.  

4.1 Create a new project in SIMATIC Manager 
1. Open SIMATIC Manager, Start > SIMATIC > SIMATIC Manager

The PCS 7 Wizard ‘New Project’ dialog box opens.  

Note 
Press the F1 function key for help on each screen of the PCS 7 New Project 
Wizard.  
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2. Select a project type. For example, select the Single Project radio button. 

Multiproject with project and master data library – select this option if you 
want to distribute project engineering across multiple engineering stations.  

Single Project –  select this option when project engineering will be performed 
from a single engineering station.  

3. Click the Continue button.
The Which CPU will you use in your project? dialog box opens.  

4. Click the Continue button to accept the default. (Choices here are only relevant 
to S7 projects.)  
The Which objects will be used in the project? dialog box opens.  
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- In the Plant Hierarchy area, the Number of levels should be configured 
when using S7-400 controllers in the same OS project as ACM/CCM 
controllers. It should be set to the same value used in DBA.  

- In the AS objects area, clear CFC chart and SFC chart check boxes. 
These are only relevant to S7 projects.   

- In the OS objects area, select the PCS 7 OS check box, and the 
appropriate system type.   

Single-user System – a single PC station will be created with an OS 
project.  

Multi-user System – two PC stations will be created, an OS server 
project, and an OS client project.  

Multi-user system redundant – three PC stations will be created, two OS 
server projects and an OS client project.  

Note 
For SIMATIC Batch options, a SIMATIC Batch check box will also appear in the 
OS Objects area. It is not necessary to check this box for SIMATIC Batch, even if 
you are installing the Batch option.  

5. Click the Continue button.  
The Where do you want to save the multiproject or the project? dialog box 
opens.  
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- In the Directory name box, enter a directory folder name or accept the 
default. This is the folder name for the directory under which the 
client/server projects will be created.  

- In the Storage location (path) box, enter a path or accept the default. This 
path is where the directory folder will be located. This is the path for the 
master project on the engineering station.  

6. Click the Make button.
The Message Number Assignment Selection dialog box opens.  

7. Accept the default.  Click the OK button. The project is created. This setting 
applies to projects that include S7-400 controllers and does not apply to 
messages created by DBA. 
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4.2 Create New Folders on the Primary and Standby 
Servers and All Clients 
Shared folders on the servers and clients are needed to store the project created 
on the Engineering Station.  When the project is downloaded, it will be transferred 
from the Engineering Station to these folders. You cannot configure your stations in 
SIMATIC Manager until these folders are created and properly set up. Follow these 
steps to create and set up these folders, if they don’t already exist. 

1. Using Windows Explorer, create a new folder such as ‘PROJECT’ on one of the 
drives of the Primary and Standby servers, as well as all clients. The client and 
server projects created on the Engineering Station shall be downloaded to this 
folder on each node. If desired, you may create a ‘Projects’ folder under 
\Program Files\Siemens\Step7\s7proj\ for your projects. However, the name 
of the folder and where you place it is up to you.  

2. Setup sharing on the newly created PROJECT folder. Right-click the PROJECT
folder and select Sharing… The PROJECT properties dialog box opens. 

3. Select the Sharing tab, select the Share this folder radio button.

4. Click the Permissions button. The Permissions window opens.  Select 
Everyone, and then click the Full Control check box in the Allow column.  

5. Click OK to close the Permissions window.  

6. Click the OK button to close the Project Properties dialog box. 
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4.2.1 Configure the Stations 
Configuring the stations identifies which computers are the server or client stations, 
and the path to which the project will be downloaded.  

The following stations are shown in the SIMATIC Manager component view: 

 SIMATIC PC Station (1) – Primary OS server 

 SIMATIC PC Station (2) – Standby OS server 

 SIMATIC PC Station (3) – Client 

1. Close the plant view.  

2. Expand the tree view for each station in the Component view.  
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4.2.1.1 Primary Server  
1. In the Component view, right-click SIMATIC PC Station(1), and select Object 

Properties.

2. In the General tab, enter the computer name of the primary computer in both 
the Name and Computer name fields. These names must be entered in ALL 
CAPS. Click the Ok button.   

3. Right-click OS(1), and select Object Properties.

4. The Properties dialog box opens.  

5. Rename, as desired, the OS(1) to the Server Project name.  

6. Click the Target OS and Standby OS Computer tab.

Note 
This step can be deferred until the OS servers and clients are actually set up and 
connected to the network. This must be completed before section Download the 
Projects.  
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7. Select the Network button to browse and map to the shared project folder on 
OS Server. If a mapped drive already exists, select it from the available drives 
listed in the Load In list box. This is the path to the folder on your primary 
server where you will store and operate the project. This path must include the 
network name of the target computer.  
Note: This folder must already exist on the primary and standby servers and be 
shared. This folder’s permissions should be set to Full Control for Everyone.
Refer to section Create New Folders on the Primary and Standby Servers 
and All Clients in this document. 

8. Click the OK button.
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4.2.1.2 Standby Server  
1. In the Component view, right-click SIMATIC PC Station(2), and select Object 

Properties.

2. In the General tab, enter the computer name of the standby computer in both 
the Name and Computer name fields. These names must be entered in ALL 
CAPS. Click the Ok button.   

3. Right-click OS(1)_StBy, and select Object Properties.  The default project 
name of Primary Server/Project Name_StBy must be used.  
The Properties dialog box opens.  

4. Click the Target OS and Standby OS Computers tab.  

Note 
This step can be deferred until the OS servers and clients are actually set up and 
connected to the network. This must be completed before section Download the 
Projects.  
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5. Select the Network button to browse and map to the shared project folder on 
OS Server. If a mapped drive already exists, select it from the available drives 
listed in the Load In list box. This is the path to the folder on your primary 
server where you will store and operate the project. This path must include the 
network name of the target computer.  
Note: This folder must already exist on the primary and standby servers and be 
shared. This folder’s permissions should be set to Full Control for Everyone.
Refer to section Create New Folders on the Primary and Standby Servers 
and All Clients in this document. 

6. Click the OK button. 
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4.2.1.3 Client Station  
Note: If your client is not the same computer as your OS Engineering Station, then 
perform the following steps. 

1. In the Component view, right-click SIMATIC PC Station(3), and select Object 
Properties.

2. In the General tab, enter the computer name of the client computer in both the 
Name and Computer name fields. These names must be entered in ALL 
CAPS. Click the Ok button.   

3. Right-click OSC(3), and select Object Properties.
The Properties dialog box opens.  

4. Rename, as desired, the OSC(3) to the client project name. 

5. Click the Target OS tab.

Note 
This step can be deferred until the OS servers and clients are actually set up and 
connected to the network. This must be completed before section Download the 
Projects.  
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6. Select the Network button to browse and map to the shared project folder on 
OS Server. If a mapped drive already exists, select it from the available drives 
listed in the Load In list box. This is the path to the folder on your primary 
server where you will store and operate the project. This path must include the 
network name of the target computer.  
Note: This folder must already exist on the primary and standby servers and be 
shared. This folder’s permissions should be set to Full Control for Everyone.
Refer to section Create New Folders on the Primary and Standby Servers 
and All Clients in this document.Click the OK button. 

7. From the Component view, add and configure additional clients, servers, and 
server pairs as needed.  You can add up to a total of 32 clients and 12 server 
pairs.
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4.3 Start DBA for new projects 
Define the following (refer to the DBA help or PDF file for details Start > SIMATIC 
> Documentation > English > PCS 7 APACS+ DBA Help or PCS 7 APACS+ 
DBA PDF, section Creating or Opening a DBA project.

The following steps summarize the actions to be performed within DBA:  

 In the AS View of the DBA, define the AS (4-mation configurations) 

 In the PC Station View, add a PC Station(s) and add the application(s) (OS 
Server) 

 Configure your Plant View (Picture Tree) 

- define your areas 

- define which pictures belong to which area  

- edit properties of the project in the hierarchy tab from  
File > Properties > Project Options

- define which controller objects belong to a specific picture 

- define Alarm priorities for each controller object 

- modify symbol definitions on a per-instance basis (optional) 

- assign each upper-level Plant View Folder to the proper OS application 

- save the DBA project file. Save in the project folder to ensure it will be 
backed up with your project.  

 Compile to the OS Server project(s) 

4.4 Run OS Project Editor (optional) 
If you want to change your layout, screen resolution, monitor configuration, 
message configuration, message display, area, runtime window, or basic data, run 
the OS project editor from WinCC Explorer. When configuring servers that will not 
be used as clients, it is recommended to use the SIMATIC server layout.  

4.5 Edit Each Graphic 
Customize the graphics for your process including the addition of Trend Objects to 
graphics. 
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4.6 Lifebeat Monitoring Setup 

Important Note 
Integration of the PCS 7 Options Lifebeat Monitoring Symbols with SIMATIC PCS 
7 Version 6.1 requires a one-time manual procedure. This step is performed after 
installing (or reinstalling) PCS 7 Options software.  

1. Open the OS server project in SIMATIC Manager. From the Component view, 
right-click on the Primary OS Server and select Open Object. Your project 
opens in WinCC Explorer.

2. Click the Graphics Designer icon in the left pane of the WinCC Explorer
window. 
In the right pane, a list of picture files (with .PDL filename extensions) appears. 
In the right pane, select and right-click the file 
@@APACSConfigTypicals.PDL. From the drop-down menu, select Open 
picture. The Graphics Designer program opens the picture for editing. 

3. Select all the symbols on the @@APACSConfigTypicals.pdl.  From the program 
menu bar, select: 

Edit > Select All 
Edit > Copy 

4. Close the graphic.  If asked whether to save changes, select No.  The file 
closes. 

5. Open the @@ConfigTypicals.pdl. Paste the APACS symbols onto the 
@@ConfigTypicals.pdl by clicking on the blank space to the right of the PCS7 
symbols and selecting Edit > Paste.  While the symbols remain selected, move 
the entire selection to the right if necessary so that they are distinct from the 
original PCS7 symbols. 

Note 
If you intend to create future projects (such as client stations), at the same time, 
you should also copy the APACS Symbols from the @@APACSConfigTypicals.pdl 
and paste them into the 
ProgramFiles\SIEMENS\WINCC\options\pdl\base_Data_Pool\@@ConfigTypic
als.PDL.

6. Select File > Close, then Save. A Performance Warning dialog box opens, 
cautioning you that the file contains cyclic triggers. You can safely ignore this 
warning and click the OK button. Close Graphic Designer. 
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7. In the left pane of WinCC Explorer, right-click Lifebeat Monitoring. Click Open.
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The Lifebeat Monitoring window opens.  

8. In row one, double-click the cell under Device Name. Enter the name of the 
controller that you want monitored, make sure this is the name of the controller 
defined in your DBA project.  
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9. Double-click the cell under Device Type, and select the controller type from the 
drop-down list.  

10.Double-click the cell under Connection, and select APACS+.
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11.Repeat steps 8-11 for each controller that you want monitored. 

12.Under the Device positioning in the system configuration section, select 
automatic.

13.Select a Monitoring Cycle time. The default is 10 seconds. 

14.When complete, select the Update button. The following dialog box is 
displayed. 

15.Click the Yes button. When complete, the Lifebeat Monitoring dialog box may 
appear indicating that the CCLBMRTServer.exe could not be entered into the 
start up list of the server computer <computername>.  

16.This message can be safely ignored. Click the OK button to continue. 

17.Click the Close button to close the Lifebeat Monitoring window.  

18.The system may respond with the following message “The process picture has 
not been updated, do you want to update before closing?“ Click Yes.

19.The following dialog box may be displayed. Click Yes.

20.The following dialog box is displayed. Click OK.

21.To configure Lifebeat Monitoring to view the health of other system resources 
such as computers, for example OS Servers and the Archive Server, refer to 
Start > SIMATIC > WinCC > WinCC Information System > Options > 
Options for Process Control > Lifebeat Monitoring > How to configure 
lifebeat monitoring with OPC connection.            
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Note 
The following steps should only be done by opening your project in WinCC 
Explorer via SIMATIC Manager as described in the Lifebeat Monitoring section. 
You only need to do this for the Primary Server OS project. When you have 
finished, close WinCC Explorer. 

4.7 Time Synchronization Setup 
For Clients and Server PCs:  

For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Options > Options for Process Control > Time 
Synchronization

For APACS+/QUADLOG Controllers:  

Refer to the user documentation APACS+ System Time Synchronization  
(SG39-13).  

4.8 Configure Alarm Logging 
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Working with WinCC > Setting Up an Alarm 
System > Alarm Logging 

4.9 Configure Tag Logging 
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Working with WinCC > Archiving Process 
Values

4.10 Create Trends (if adding the Trend Object to a Graphic) 
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Working with WnCC > Archiving Process 
Values > Output of Process Values > Process Value Output in Process 
Screens

4.11 Configure User Administrator 
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Working with WinCC > Setting up User 
Administration 
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4.12 Generate Server Data  
From the Component view in SIMATIC Manager, right-click the primary OS server 
project, and select Generate Server Data.

When the procedure is complete, The server data are generated successfully
dialog box opens.  

Perform this procedure for each primary OS server.  

4.13 Configure lmhosts and hosts Files  
All PCS 7 stations should be entered in the LMHOSTS and HOSTS files (in 
%windir%\system32\drivers\etc directory). These files should be copied to each of 
the PCS 7 station computers. 

For additional information, the following URL is accurate for NT/Win2k, but not for 
XP or Win2k3:  

http://www.microsoft.com/resources/documentation/windowsnt/4/workstation/reskit/
en-us/lmhw.mspx

PCS 7/APACS+ OS Setup Guide for V6.1 
4-22 A5E00595265-01 

http://www.microsoft.com/resources/documentation/windowsnt/4/workstation/reskit/en-us/lmhw.mspx
http://www.microsoft.com/resources/documentation/windowsnt/4/workstation/reskit/en-us/lmhw.mspx


Create a New OS Project 

4.14 Configure WinCC Project Network Settings 
If the PC (computer) has more than one network adapter, configure WinCC for the 
network adapter it will be using.

1. Open Windows Explorer and select My Computer > SIMATIC shell > 
Settings. The Terminal bus selection window opens. 

2. Select the appropriate network adapter. Click OK. The message box Network 
communications need to be initialized opens. Click Yes.

The WinCC Communications Configurator configures WinCC to use different 
network speeds (e.g. for dial-up or radio) 

  To start, click Start > SIMATIC > WinCC > Tools > Communication 
Configurator.

- Slide bar should be set to reflect network speed 

- “Server Pings Client” should be set unless there are dial-up clients 

- Settings should only be changed if CCAgent, CCClient, and CCServer 
processes have been (manually) stopped. 

Note 
Refer to WinCC Help for additional details regarding WinCC Communication 
Configurator. 

PCS 7/APACS+ OS Setup Guide for V6.1 
A5E00595265-01 4-23



Create a New OS Project 

4.15 Client Project Setup  

4.15.1 Assign OS Server  
1. From the Component view in SIMATIC Manager, right-click OS Client and 

select Assign OS server… The OS server assignment window opens.  

2. Check the project check box for each server as needed, and click OK.  A 
progress bar indicating the status opens. When the procedure is complete, The
Procedure was complete without error message is displayed.  

3. Click the OK button.

4.15.2 Configure a Standard Server 

Note 
The "Standard Server" represents the Server or Server pair that will store all 
operator actions and Runtime Trends.  If a Standard Server is not configured, 
operator actions will be stored on the local machine instead of on the "Server". In 
addition, any Runtime Trends created will only be viewable from the client on which 
they are created. 

On the OS Engineering Station, open the OS client project from SIMATIC 
Manager. Set up a standard server for Alarms and SSM.  

1. Right-click on Server Data.

2. Select Standard Server.

3. Click on the Symb. Computer Name field next to the Alarms Component. 
From the drop-down list, select the package that is the server for this client and 
is providing alarms for the client you are currently configuring.  

4. Repeat step 3 for the SSM component.  

5. Click the OK button.

This step can also be performed on the client after downloading the project to 
redefine the standard server for a particular client station. This customization will 
be overwritten during a subsequent download.  

4.15.3 Configure Preferred Server 
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Options > Options for Process Control > 
Preferred Server 

This step can also be performed on the client after downloading the project to 
customize the preferred server connection for a particular client station. This 
customization will be overwritten during a subsequent download. 
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4.15.4 Lifebeat Monitoring Setup 
1. Open the client project. From the Component view in SIMATIC Manager, right-

click on the OS client project and select Open Object. The project opens in 
WinCC Explorer. 

2. Right-click Lifebeat Monitoring and select Open. The Lifebeat Monitoring
window is displayed.  

3. Set the Device positioning in the system configuration to automatic. Select a 
Monitoring Cycle time, and then click the Update button. 

4. When complete, the system configuration section will update. See the Lifebeat 
Monitoring window below.  

PCS 7/APACS+ OS Setup Guide for V6.1 
A5E00595265-01 4-25



Create a New OS Project 

5. Lifebeat Monitor setup on the client is complete. Click the Close button to close 
Lifebeat Monitoring. 

4.15.5 Configure Area Display in Runtime 
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Options > Options for Process Control > OS 
Project Editor > The Areas Tab 

This step can also be performed on the client after downloading the project to 
customize the area display for a particular client station. This customization will be 
overwritten during a subsequent download.  

4.15.6 Configure User Administrator  
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Options > Options for Process Control > User 
Administrator 

This step can also be performed on the client after downloading the project to 
customize user administration for a particular client station. This customization will 
be overwritten during a subsequent download. 
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4.15.7 Create Runtime Trends (archive or online trends) 
For further information, please refer to the help file Start > SIMATIC > WinCC > 
WinCC Information System > Options > Options for Process Control > Trend 
System 

This step can be performed on the client after downloading the project. 

Note 
This customization will not be overwritten during a subsequent duplication. It is 
important to note that Runtime Trends created from a client application are not 
viewable from a server being used as a client. Any Runtime Trends created on the 
OS Server being used as a client are not viewable from a client connected to the 
OS server.  
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4.16 Download the Projects 

Note 
Only download the project to the client if the client is not the same computer as 
your OS Engineering Station. All stations to which you will download the project 
must have WinCC shut down.  

4.16.1 Download all projects at the same time
1. From Component view, right-click the project name and select PLC > Compile 

and Download Objects…. The Compile and Download Objects window 
opens. 

2. Check the Download check box for each client and server project name. 

3. Select each project, and click Edit. Ensure that the Entire WinCC Project radio 
button is selected for each project.  

Note 
Do not check any Compile check boxes. Doing so will overwrite your DBA compile 
with incorrect data. The compile check boxes only apply to S7 projects.  

4. Click the Test button, to ensure that all settings are valid. 

5. Click the Start button.
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Download each project separately:  

4.16.2 Download the project to the Primary Server 
1. From SIMATIC Manager component view, right-click the Primary Server OS 

(PC Station 1), and select PLC > Download.

2. Ensure that The Entire WinCC Project radio button is selected.  

3. Click OK to download the project.  

4. A success window is displayed. Click OK to acknowledge that the 
download has completed. 

4.16.3 Download the project to the Standby Server   
1. From SIMATIC Manager component view, right-click the Standby Server OS 

(PC Station 2), and select PLC > Download.

2. Ensure that The Entire WinCC Project radio button is selected.  

3. Click OK to download the project.  

4. A success window is displayed. Click OK to acknowledge that the 
download has completed. 

4.16.4 Download the project to the Client Station 
1. From SIMATIC Manager component view, right-click the Client Station OS (PC 

Station 3), and select PLC > Download.

2. Ensure that The Entire WinCC Project radio button is selected.  

3. Click OK to download the project.  

4. A success window is displayed. Click OK to acknowledge that the 
download has completed. 
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4.17 Project Activation Sequence 

Note 
Projects can be automatically activated when the operating system starts using the 
AutoStart Utility. For more information, refer to the help file within WinCC Explorer. 
Or to FAQ ID: 19249315

1. Activate the project on the primary server.  

2. Wait four minutes for the project to fully start. 

3. Activate the project on the backup server. 

4. Wait four minutes for the project to fully start. 

5. Activate the project on the client. 

4.18 Restarting an OS Server  

Wait five minutes prior to reactivating the WinCC runtime of an OS Server 
associated with a redundant pair to ensure that all synchronization activities will 
start-up properly. 
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5 Download the Changes 

This section describes how to make changes to an existing project from the 
Engineering Station, and then downloading those changes into the servers and 
client. These changes may include: 

 Making changes to a Controller program.  

 Making changes to the plant view in DBA. 

 Making changes to the project in SIMATIC Manager. 

 Making changes to the project in WinCC.  

5.1 Overall Steps 
1. Make changes. Ensure that DBA changes have been compiled.  

2. Download changes to your stations.  

5.2 Making Changes to the Controller Configuration 
1. Make any required changes to controller programs. Anytime you make 

changes to an existing controller configuration, DBA detects the changes 
and shows the AS Source Node that represents the controller as 
“(changed)”: 

2. Right-click the changed AS Source Node and select Update Controller 
Objects from the menu. 
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The AS Objects panel in the lower-right quadrant of DBA is updated to reflect the 
changes made from the controller. The Status column indicates which objects 
have been added, deleted or modified since the last time the controller objects 
were updated. 

Note 
Update Controller Objects changes the status column in the details pane to 
indicate which AS Objects have been modified since the last update. This is a 
visual status indication of what has changed in the controller. This column reflects 
the status information from the current Update Controller Objects when run multiple 
times between DBA compiles to the OS project. To ensure the accuracy of the OS 
compile, DBA retains the status of all changed objects no matter how many times 
Update Controller Objects is run.  

Use DBA to modify the Plant View to reflect the new AS object changes: 

 AS objects marked as Deleted should be Unassigned from the currently 
assigned folder in the Plant View. 

 AS Objects marked as Add should be assigned to a folder in the Plant View. 
You may wish to make additional changes to the attributes of the new 
objects, such as Alarm Priority. See Object Attributes section of the DBA Help 
File for more details.

 For AS Objects marked as Modified, no action is required. The changes will 
be made automatically in the PCS 7 OS Project the next time you perform a 
“Compile”. Note that DBA color codes all modified AS Objects as green in the 
Plant View, indicating that there has been a change to the object that has not 
been compiled to the WinCC project. 
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5.3 Making additional Changes to the DBA Configuration
1. Use DBA to make any additional changes desired, such as  

- Fine-tuning of the Plant View assignments 

- Renaming folders or graphic files assigned to folders 

- Editing of AS Object attributes such as Symbol Names and Alarm 
Priorities (see DBA Help File, section Object Attributes, for more details) 

2. The server project that you are compiling to must not be in runtime on this 
station.

3. From DBA, select Compile and choose the Changes option on the compile 
dialog box: 
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5.4 Modify the project in WinCC 
On the OS Engineering Station, start WinCC Explorer and open the OS Server 
project. 

Make any new changes to the project that you need (for example, create 
new graphics, modify existing graphics, etc.). 

Note 
All changes must be made on the OS Engineering Station to preserve the 
Changes Only download. Changes made on another station cannot be 
downloaded to the other stations via SIMATIC Manager. These changes would 
have to be downloaded manually. Changes made on any station other than the 
Engineering Station will require a full download when future changes are made.   
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5.5 Download changes 
You can only download changes when all stations have PCS 7 activated. Unlike 
downloading the entire project, you do not need to explicitly request a 
download to the Standby Server. The download to the Primary Server 
will automatically include the Standby Server. You will not explicitly see the 
changes downloaded to the Client, this download is done in the 
background. 

If the scope of changes made is restricted to:  

 picture changes within Graphics Designer. 

 addition of new object instances within the controller configuration using 4-
mation and then assigned to an existing area/folder/picture in the plant view. 

 deletion of object instances from 4-mation/DBA.

then perform steps one through six.  

If the scope of changes is greater than those listed above (such as changes to 
an existing instance in 4-mation or DBA, or the renaming/moving of hierarchical 
folders in the plant view of DBA), then perform steps one through fifteen. 

1. From SIMATIC Manager component view, right-click the Primary Server OS
(PC Station 1), and select PLC > Download.

2. Ensure that the Changes radio button is selected.  

3. Click OK to download the project.  

4. A success window is displayed indicating a successful download to the 
Primary Server. Click OK to acknowledge that the download has 
completed. 

5. The project is now automatically downloaded to the Standby Server.  

6. A success window is displayed indicating a successful download to the 
Standby Server. Click OK to acknowledge that the download has 
completed. 

7. Deactivate PCS 7 on the Primary Server.  

8. Wait five minutes. 

9. Reactivate PCS 7 on the Primary Server.  

10. After fifteen minutes, look in the Process Alarms screen on the Primary 
Server for the “Sync Start/Finish“ message. If the message is not there, 
continue checking the process alarms screen until the message appears.  

11. Once the synchronization has completed, deactivate PCS 7 on the Standby 
Server.

12. Wait five minutes.  

13. Reactivate PCS 7 on the Standby Server.  

14. After fifteen minutes, look in the Process Alarms screen on the Primary 
Server for the “Sync Start/Finish“ message. If the message is not there, 
continue checking the process alarms screen until the message appears.  

15. The changes are now fully downloaded.  
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6 Modify Faceplates and Symbols 

The following exercise provides the recommended steps to create PCS 7 
customized faceplates and symbols based on those delivered in the standard 
PCS 7/ APACS+ Option product. 

The procedure essentially clones an existing faceplate and symbol.  
The PCS 7 Faceplate Designer utility should not be used.

1. Select a standard faceplate that is most like the one you wish to create  

Note: This exercise assumes you have selected the SINGLE_LOOP_AFB 
faceplate and symbol, and that you want to create a CUSTOM1_AFB 
faceplate and symbol from it. 

2. If the new CUSTOM1_AFB faceplate is for a specific WinCC project, select 
the PDL files from the GraCS folder of the WinCC project.  

If the modifications are to be global for all WinCC projects, select the files 
from the SIEMENS\WINCC\options\pdl\FaceplateDesigner_V6 folder.
Any newly created WinCC project initially gets its files from the 
SIEMENS\WINCC\options\pdl\FaceplateDesigner_V6 folder. 

6.1 Faceplate Procedure 
1. Using the WinCC Graphics Designer, open up the following PDL files, and 

use the File > Save As.. menu option to save a copy of the file under a new 
name.

Original File Name New Customized File Name 
@PG_SINGLE_LOOP_AFB.pdl @PG_CUSTOM1_AFB.pdl 
@PG_SINGLE_LOOP_AFB_OVERVIEW.pdl @PG_CUSTOM1_AFB_OVERVIEW.pdl 
@PG_SINGLE_LOOP_AFB_STANDARD.pdl @PG_CUSTOM1_AFB_STANDARD.pdl 
@PG_SINGLE_LOOP_AFB_VIEWLIST.pdl @PG_CUSTOM1_AFB_VIEWLIST.pdl 
@PL_SINGLE_LOOP_AFB.PDL @PL_CUSTOM1_AFB.PDL 

2. All references to the old SINGLE_LOOP_AFB type need to be changed to 
reference the new CUSTOM1_AFB type. These changes are made in WinCC 
Graphics Designer by opening the PDL file, and modifying the reference 
using the object’s property dialog box. 

The following table lists all of the references that must be changed. 
PDL FileName Object Name Property Name 
@PG_SINGLE_LOOP_AFB.pdl @Faceplate FirstView 
@PG_SINGLE_LOOP_AFB.pdl ViewList Picture Name 
@PG_SINGLE_LOOP_AFB.pdl BlockType Output Value 
@PL_SINGLE_LOOP_AFB.pdl OverviewWindow Picture Name 
@PL_SINGLE_LOOP_AFB.pdl View1 Picture Name 
@PL_SINGLE_LOOP_AFB.pdl BlockType Output Value 
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The result is a copy of the SINGLE_LOOP_AFB faceplate that supports the 
new CUSTOM1_AFB type. 

The objects on the new PDL files can now be added/deleted/modified. How 
to modify the PDL files is now up to the user, and is beyond the scope of this 
document.

6.2 Symbol Procedure 
1. Using the WinCC Graphics Designer, open up the @@APACSTypicals.PDL 

file.

2. Save this under the new name @APACSTypicals.PDL.  

3. Make a copy of the @SINGLE_LOOP_AFB/2 object and name it 
@CUSTOM1_AFB/1.  

4. Using the property dialog box for the new @CUSTOM1_AFB/1 object, 
change all references to the old SINGLE_LOOP_AFB type to reference the 
new CUSTOM1_AFB type. 

5. The following properties must be changed: 

- type 

- Servername 

The result is a new symbol that will be used for the new CUSTOM1_AFB 
type.
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7 Software Installation for SIMATIC BATCH 
on APACS 

7.1 Batch Architecture 

MBUS / MNET

APACS Controllers

TCP/IP

Redundant
OS

Servers

APACS OS
Batch Single

Station

Redundant
Batch

Servers

APACS OS
Batch

Engineering
Station

Batch Client
(Alternate Config.)

OS / Batch Client
(Primary Config.)
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7.2 Batch Authorizations 
The following authorizations need to be installed on the Engineering Station (ES) 
in order to configure SIMATIC BATCH on APACS solutions.   

 SIK/ PCS 7 SIMATIC BATCH DBA APACS+ V6.0 

 SIK/ PCS 7 SIMATIC BATCH DBA V6.0 

On the OS the following authorization is needed: 

 SIK/ PCS 7 SIMATIC BATCH APACS RT V6.0 
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7.3 Installation sequence 
Before the SIMATIC BATCH on APACS option is installed, all appropriate PCS7, 
APACS+, and PCS 7 Options for APACS+ software must be installed. Refer to 
section 1 in this manual for an installation overview.  

Follow sections 2.1 through 2.5 step 5 in this manual, then proceed with the 
following:

1. Select the packages to be installed: 

- For installation on ES, select “PCS 7/APACS+ DBA w/ Batch”. 

- For installation on OS server, select “PCS 7/APACS+ OS Server w/ 
Batch”. 

- For installation on Batch Single Station, select “PCS 7/APACS+ OS 
Single Station w/ Batch”. 

2. Click the Next button. The PCS 7 Options for APACS+: Components
dialog box opens.  
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3. Select the packages to install. Please refer to the table in section 9.2 PCS 7 
APACS+ OS Option V6.1 for the appropriate packages to install for your 
system.  
Click the Next button to continue. The options begin installing.  

The Installation completed dialog box opens.  
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8 Create a SIMATIC BATCH project 

In SIMATIC BATCH on APACS option, SIMATIC BATCH project is created and 
edited with DBA on Engineering Station.  

The pre-requirement for DBA to create a new SIMATIC BATCH project is that all 
OS objects (WinCC projects) have to be created and downloaded to target OS 
nodes by SIMATIC Manager.  

The working flow of creating a SIMATIC BATCH project is shown below 

Run SIMATIC Manager on Engineering Station to 
create OS server and OS client objects by using “New 
Project Wizard”. Refer to section 4.1 in this document.  

Use SIMATIC Manager to download initial OS objects 
to target computers. 

Run DBA on Engineering Station to translate 
configuration from AS to SIMATIC Batch Process Cell 
configuration. Refer to the DBA help or PDF file for 
details Start > SIMATIC > Documentation > English > 
PCS 7 APACS+ Batch DBA Help or PCS 7 APACS+ 
Batch DBA PDF.

In DBA, compile Process Cell and download it to the OS 
in SIMATIC Manager.  

Go back to SIMATIC Manager to download finalized OS 
objects to the target computers. 
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9 Product Installation Guidance Tables 

The following tables for APACS+ Control CD V6.1 and PCS 7/APACS+ OS 
Option V6.1 provide installation guidance for installing components and 
packages.  
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