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Software Warranty Agreement
GRANT OF LICENSE. AMX Corporation grants to you the right to use the enclosed OLDesign software program (the 
SOFTWARE) on a single central processing unit (CPU). This license is for object code only and does not convey any 
rights to use of the source code.
This Agreement does not authorize you to distribute the SOFTWARE.

COPYRIGHT. The SOFTWARE is owned by AMX Corporation, and is protected by United States copyright laws and 
international treaty provisions. Therefore, you must treat the SOFTWARE like any other copyrighted material (e.g., a 
book or musical recording) except that you may either (a) make one copy of the SOFTWARE solely for backup or archi-
val purposes, or (b) transfer the SOFTWARE to a single hard disk provided you keep the original solely for backup or 
archival purposes. You may not copy the written materials accompanying the SOFTWARE.
OTHER RESTRICTIONS. You may not rent or lease the SOFTWARE, but you may transfer the SOFTWARE and 
accompanying written materials on a permanent basis provided you retain no copies and the recipient agrees to the 
terms of this Agreement. You may not reverse engineer, decompile, or disassemble the SOFTWARE. If the SOFT-
WARE is an update or has been updated, any transfer must include the most recent update and all prior versions.

You may use only one version of the SOFTWARE at any time. You may not use the version of the SOFTWARE not 
being run on your CPU on any other CPU or loan, rent, lease or transfer them to another user whether with or without 
consideration.

LIMITED WARRANTY

LIMITED WARRANTY. AMX Corporation warrants that the SOFTWARE will perform substantially in accordance with 
the accompanying written materials for a period of ninety (90) days from the date of receipt. Any implied warranties on 
the SOFTWARE and hardware are limited to ninety (90) days and one (1) year, respectively. Some states/countries do 
not allow limitations on duration of an implied warranty, so the above limitation may not apply to you.

CUSTOMER REMEDIES. AMX Corporation’s entire liability and your exclusive remedy shall be, at AMX Corporation's 
option, either (a) return of the price paid, or (b) repair or replacement of the SOFTWARE that does not meet AMX Cor-
poration's Limited Warranty and which is returned to AMX Corporation. This Limited Warranty is void if failure of the 
SOFTWARE or hardware has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be 
warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. 

NO OTHER WARRANTIES. AMX Corporation disclaims all other warranties, either expressed or implied, including, but 
not limited to implied warranties of merchantability and fitness for a particular purpose, with regard to the SOFTWARE, 
the accompanying written materials, and any accompanying hardware. This limited warranty gives you specific legal 
rights. You may have others which vary from state/country to state/country.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES. In no event shall AMX Corporation be liable for any damages 
whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business 
information, or any other pecuniary loss) arising out of the use of or inability to use this AMX Corporation product, even 
if AMX Corporation has been advised of the possibility of such damages. Because some states/countries do not allow 
the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.

U.S. GOVERNMENT RESTRICTED RIGHTS

The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the 
Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data and Com-
puter Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the Commercial Computer Soft-
ware--Restricted Rights at 48 CFR 52.227-19, as applicable. Manufacturer is AMX Corporation, 3000 Research Drive, 
Richardson, TX  75082.

If you acquired this product in the United States, this Agreement is governed by the laws of the State of Texas.

Should you have any questions concerning this Agreement, or if you desire to contact AMX for any reason, please 
write: AMX Corporation, 3000 Research Drive, Richardson, TX  75082.
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Introduction
Introduction

The OLDesign Overlay Design software is a 16-bit Windows® program that creates custom control 

overlays for AMX wireless transmitters, wired control panels, and touch panels. This program 

offers a wide variety of text sizes, control symbols, and button grouping options that you can use to 

design custom AMX controller overlays.

Supported Operating Systems
The minimum system requirements for OLDesign include:

! 486/33 MHz processor

! 8 MB RAM

! 20 MB of free disk space

! VGA monitor

! Microsoft® Windows or Windows NT® operating systems:

! Windows 3.x

! Windows 3.5x

! Windows 95®/98®/ME®

! Windows NT 4.x®/2000®

! CD-ROM drive compatible with Multimedia PC (MPC) specifications

! Serial or bus mouse pointing device (or equivalent)

Installing OLDesign from the AMX Control Disc
To install OLDesign:

1. Put the AMX Control Disc into the CD-ROM drive.

2. The Welcome To OLDesign 2.1 Setup dialog appears, reminding you to close all Windows 

programs before going any further. Click Next to proceed.

3. In the Select OLDesign 2.1 Install Location dialog, use the Browse button to navigate to a 

directory other than the default install directory, if desired. Click Next.

4. Enter the name of the Program Manager Group to add OLDesign 2.1 icons to, and select Next.

5. In the OLDesign 2.1 Shortcut Creation dialog, select Yes, I would like to create Shortcuts on 
my Desktop, if desired.

6. Click Next in the Start OLDesign 2.1 Installation dialog to install the selected components.

7. When OLDesign 2.1 has been successfully installed, click Finish to exit the installation.

OLDesign is a 16-bit program. You may experience difficulty running OLDesign on a 
32-bit operating system.
1OLDesign Overlay Design Program (Version 2.1)



Introduction
Supported AMX Products
The following products are supported in the OLDesign program. 

AMX Products Supported in OLDesign
Wireless Transmitters

TXC4+

TXC16+

TXC32+

TX64

TX-MLCD

TXC-MS

TXC+ Transmitter Series

TXC+ Transmitter Series

TXC+ Transmitter Series

TXC+ Transmitter Series

Mini-LCD Transmitter

23-Button Transmitter

Wired control panels

AXD-MSP8

AXD-MSP16

AXD-MSP32

AXP-MLCD

AXU-MLCD

AXU-MSP8

AXU-MSP16

AXU-MSP24

AXU-MSP32

AXU-SP+

WPD8

Decor Mini-Softwire Panel

Decor Mini-Softwire Panel

Decor Mini-Softwire Panel

Mini-LCD Panel Series

Mini-LCD Panel Series

UniMount Mini-Softwire Panel Series

UniMount Mini-Softwire Panel Series

UniMount Mini-Softwire Panel Series

UniMount Mini-Softwire Panel Series

SP+ Softwire Panel Series

Decor 8-Button Wall Panel

Touch panels

AXD-CA10

AXD-CG10

AXD-CP

AXD-CV10

AXD-EL+

AXD-LC

AXD-MCA

AXD-MCV

AXD-MLC

AXT-MCA

AXT-MCV

AXT-MLC

AXU-CA

AXU-CA10

AXU-CG10

AXU-CP

AXU-CV

AXU-CV10

AXU-EL+

AXU-LC

AXU-MCA

AXU-MCV

AXU-MLC

AXD-CP4

Decor 10.4" Color Active-Matrix LCD Wall Touch Panel

Decor 10.4" Color Graphic Wall Touch Panel

Decor 8.5" Color Passive-Matrix LCD Touch Panel

Decor 10.4" Color Video Wall Touch Panel

Decor 8.5" Electroluminescent Wall Touch Panel

Decor 8.5" LC Wall Touch Panel

Decor Mini Color Active-Matrix Touch Panel

Decor Mini Color Video-Matrix Touch Panel

Decor Mini B&W Touch Panel

Color Active Mini-Tilt Screen Touch Panel

Color Video Mini-Tilt Screen Touch Panel

B&W Mini-Tilt Touch Panel

UniMount Color Active Touch Panel

UniMount Power Tilt/Power Touch Panel

UniMount Power Tilt/Power Touch Panel

UniMount Color Passive-Matrix LCD Touch Panel

UniMount Color Video LCD Touch Panel

UniMount 10.4" Color Video LCD Touch Panel

UniMount 8.5" Electroluminescent LCD Touch Panel

UniMount 8.5" B&W LCD Touch Panel

UniMount 5.5" Mini Color Active-Matrix LCD Wall Touch Panel

UniMount 5.5" Mini Color Video-Matrix LCD Wall Touch Panel

UniMount 5.5" Mini B&W LCD Wall Touch Panel

Decor 4" Color Wall Panel
2 OLDesign Overlay Design Program (Version 2.1)
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Main Window and Toolbar Buttons

Main Window
The main window contains a menu bar and toolbar buttons you can use to perform common 

OLDesign program operations. There is also an edit mouse menu you can use to perform common 

editing operations. FIG. 1 shows the main window that opens when you launch the OLDesign 

program, the menu bar, and toolbar buttons.

! Menu bar  Provides access to File, Edit, Button, Group, Panel, Options, Window, and 

Help menu options.

! Toolbar buttons  Provides single-click selections to perform common operations.

FIG. 1  OLDesign main window

Menu Bar Toolbar buttonsOverlay title bar Panel edit window
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Main Window and Toolbar Buttons
Toolbar Buttons
The OLDesign toolbar buttons provide a shortcut to common operations. The following table lists 

the toolbar buttons and their functions.

Toolbar Buttons
Title Button Description

Open Program File Opens an OLDesign program file.

Save Program File Saves the current program file to disk.

Add Button Title Opens the Add Button Title dialog, enter button titles, and choose 
the position, size, and font settings for the active button.

Add Symbol Opens the Add Symbol dialog, choose a symbol, and its position 
for the active button.

Select Button Color Opens the Select Button Color dialog, choose the button color, 
and the default panel color for the active button.

Add Group Outline Adds a group outline to the active buttons. New button group out-
lines appear with resizing handles.

Add Group Title Opens the Add Group Title dialog, enter button-group text, and 
choose the text size, font, direction, and vertical/horizontal position 
for the active button group.

Add Group and Button Title Opens the Add Group Title dialog, enter button-group text, and 
choose the text size, font, direction, and vertical/horizontal position 
for the active button group. Then, click OK to open the Add Button 
Title dialog, enter a button text title, set the position, size, and font 
for each button in the active group.

Add Panel Title Opens the Add Panel Title dialog, enter panel text, and choose the 
text size, font, direction, and vertical/horizontal position for the 
active panel. The dialog also contains a preview area showing the 
active panel and text.

Add Panel Opens the Add Panel dialog and add a new panel type to the OLD-
esign program file.

Repaint Repaints the active overlay in the main window.
4 OLDesign Overlay Design Program (Version 2.1)



Main Window and Toolbar Buttons
Menu Bar
Each menu bar option opens a drop-down list that you can choose to perform the program-specific 

operation. Menu bar options include File, Edit, Button, Group, Panel, Options, Window, and Help.

File menu

The File drop-down menu options are grouped into four basic operations: Creating/saving overlays 

and program files, entering job-related information, printing, and exiting the program. The 

following table lists the options and their descriptions. 

Edit menu

The Edit drop-down menu contains options to perform common editing operations. The following 

table lists the options and their descriptions. 

Button menu

The Button drop-down menu contains options to add symbols, titles, text, colors and also remove/

restore buttons. The following table lists the options and their descriptions.  

File Menu Options
New Opens the New Panel dialog where you choose a new overlay type.

Open Opens the Open dialog where you choose an OLDesign program file.

Close Closes the current program file.

Save Saves the program file to disk.

Save as Opens the Save As dialog where you choose the directory to store the program file.

Job info Opens the Job Information dialog where you enter job-related information to store with the 
program file. This information also appears on program file printouts.

Print Opens the Print dialog where you choose a printer, set printer options, and print program 
files.

Print Preview Displays the program file report on your monitor.

Print Setup Opens the Print Setup dialog where you choose printer-specific options.

Exit Closes the program.

Edit Menu Options
Undo or Undo Cut Reverses the immediately preceding action or change.

Cut Stores the current selection (highlighted) in clipboard memory and deletes it 
from the field.

Copy Stores the current selection (highlighted) in clipboard memory.

Paste Inserts the contents of clipboard memory into the current field.

Delete Deletes the current selection (highlighted).

Button Menu Options
Add Symbol Adds symbols next to the active button.

Button Title Adds button titles and sets the text size, font, and position.

Button Text Adds button text and sets the text size, font, and position.The Button Text option is only avail-
able for the AXP-MLCD, AXU-MLCD wired control panels, and the TX-MLCD wireless trans-
mitter.

Button Color Sets the active button's color and default colors for new overlays.

Description Enters information about the button.
5OLDesign Overlay Design Program (Version 2.1)



Main Window and Toolbar Buttons
Group menu

The Group drop-down menu contains options to add button-group outlines, titles, descriptions, 

restore original button groupings, and save/recall button group outlines. The following table lists 

the options and their descriptions. 

Panel menu

The Panel drop-down menu contains options to add panel overlays, set panel overlay attributes, 

delete panels, export overlays as .DXF vector-graphic files, remove/restore panel bargraphs, and set 

the viewing size. The following table lists the options and their descriptions. 

Options menu

The Options drop-down menu contains a Preferences option that enables/disables OLDesign 

program settings.

Button Menu Options (Cont.)
Remove Removes the active button.

Restore Restores deleted buttons back into the active overlay.

Group Menu Options
Add Group Adds group outlines around active buttons.

Group Title Adds titles to button group outlines.

Description Adds descriptions to button groups for reference purposes.

Reassign Returns active button groups to their original sizes.

Save Saves button groups as .GRL files so that they can be used in multiple overlays. Use the Recall 
option to choose a .GRL file and paste it into panel overlays.

Recall Recalls previously saved .GRL button group files and pastes them into overlays.

Panel Menu Options
Add Panel Adds new panel overlays to the program file.

Panel Title Adds text titles to overlays, and sets text sizes, fonts, vertical/horizontal positions, and 
vertical/horizontal position in relation to the panel or buttons.

Radio Code Sets radio codes on wireless transmitters (only).

Rename Renames panel overlays in the program file.

Properties Enters panel descriptions, set overlay/text colors, and panel types.

Delete Deletes panels.

Create DXF File Exports active overlay files to .DXF vector-graphic files.

Remove Bargraph Deletes active bargraphs from the panel overlay.

Restore Bargraph Restores deleted bargraphs back into the panel overlay.

25% - 200% size Sets the panel overlay's viewing size in the main window.
6 OLDesign Overlay Design Program (Version 2.1)
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Window menu

The Window drop-down menu contains options to set how panel over-lays appear in the main 

window. 

Help menu

The Help menu contains options to launch the OLDesign and Windows help programs, and also 

open the About window. 

Windows Menu Options
Tile Resizes and arranges all open overlays side-by-side in the main window.

Cascade Resizes and arranges all open overlays diagonally (left to right) in the main window.

Arrange Allows you to manually resize and arrange all open overlays in the main window.

Help Menu Options
Index Launches the OLDesign help program. You can also launch the help program by pressing 

the F1 keyboard key.

Using help Launches the Windows help program that describes how to use help programs.

About OLDesign Opens the About window that lists the program's version number and AMX copyright infor-
mation.
7OLDesign Overlay Design Program (Version 2.1)
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Using OLDesign
Using OLDesign

This section contains step-by-step instructions you can use to design overlays for wireless 

transmitters, wired control panels, and touch panels. Then, you can return the program file 

containing the overlays back to your AMX Sales Representative for processing. AMX Corporation 

will promptly return your engraved overlays so that you can replace the blank overlays shipped on 

the control devices. FIG. 2 shows a sample overlay and construction elements.

Setting Program Preferences
Click Preferences to open the Preferences dialog, and choose the Overlay, Printout, and Desktop 

checkbox options. Clicking inside the option boxes toggles the options on and off. A checkmark 

indicates the option is on, FIG. 3. 

! Preferences-Overlay options:

! Force new panel name: Click to automatically open the Panel Name dialog when 

panel overlays are added to the program file and enter their name. Click off to allow 

the OLDesign program to name panels.

! Always create Back Up files: Click to automatically create/update .BXL backup 

program files. Click off to disable backup files.

! Show button numbers on MLCD panel types: Click to display the Axcess channel 

numbers on AXP-MLCD, AXU-MLCD, and TX-MLCD overlays.

! Preferences-Printout options:

! Show button numbers: Click to include button numbers in printouts. Click off to 

disable button numbers.

FIG. 2  Sample overlay and construction elements

Panel title

Group title

Button group outline

Button symbol

Button title
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Using OLDesign
! Show button-by-button descriptions: Click to include button-by-button descriptions 

in printouts. Click off to disable button information.

! Show information for all visible buttons: Click to include button information for all 

visible buttons in printouts. Click off to disable button information. This option 

automatically sets the Show button numbers and Show button-by-button 

descriptions option on.

! Skip Comments box: Click to exclude information in the Comments field in 

printouts. Click off to include comment information.

! Skip Approved By box: Click to exclude approval information in the Approved By 

field in printouts. Click off to include approval information.

! Skip Overlay/Text Color box: Click to exclude the Overlay/Text information in 

printouts. Click off to include overlay/text information.

! Skip Radio Code box: Click to exclude the radio code information in the printouts 

for transmitters. Click off to include radio code information.

! Skip Enclosure box: Click to include touch panel information in the printouts.

! Skip Dealer Information box: Click to exclude dealer information in the printouts. 

Click off to include dealer information.

! Skip Panel Description box: Click to exclude the panel description box in the 

printouts. Click off to include panel information.

! Preferences-Desktop options:

! Icon view maximize: If you are using Windows 3.x, click to maximize the size of the 

program icon in the program folder. Click off to view the program icon in normal 

size.

FIG. 3  Preferences dialog
10 OLDesign Overlay Design Program (Version 2.1)



Using OLDesign
Creating OLDesign Program Files
Each OLDesign program file can contain multiple wireless transmitters, wired control panels, and 

touch panel overlays. This allows you to maintain small-to-large overlay projects in one file. To 

create OLDesign program files, follow these steps:

1. Click File > New to open the New Panel dialog (FIG. 4).

2. Choose a wireless transmitter, wired control panel, or touch panel button in the New Panel 

dialog to create the overlay template. Then, go to step 3. If you prefer to name each overlay 

added to the program file, refer to the Options menu section on page 6 and enable the Force 

new panel name option. This option sets the program to prompt you to name each overlay.

3. Click File > Job Info to open the Job Information dialog shown in FIG. 5. Enter the dealer 

name, job number, AMX Dealer ID, purchase order (PO) number, and sales order (SO) 

number. Then, click OK to save the job information, close the dialog, and return to the main 

menu. The job information is used by AMX Corporation to track your program file and its 

disposition throughout the engraving process.

4. Click File > Save as... to open the Save as dialog. Enter the filename and choose the target 

directory to store the program file.

5. Click Save As Current to save the open program file to disk. If you want to create a new 

program file, enter the new name in the File Name field and click Save As New to save the 

new file. Then, the Save as dialog closes and returns to the main window.

Click the Get Info button to open the Information dialog to see the .TXL file-name, file size, 

date, and time it was last saved to disk. You can also click the Build List button to refresh the 

list of program files.

FIG. 4  New Panel dialog

The OLDesign program creates new overlays using the name that appears on the 
New Panel dialog button you choose. If an overlay name already exists in the 
program file, an A, B, C, etc., is appended to the overlay's name.
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Using OLDesign
Working with Overlays
Before you start working with overlays, make a list of the equipment to be controlled and include 

their control function requirements. Then, you can refer to this list throughout the design process to 

ensure all equipment and their control functions are addressed correctly.

Adding/editing panel overlay titles

You can add titles to panel overlays to convey button functions. Text options include size, font, 

vertical/horizontal direction, and the optional vertical/horizontal orientation in relation to the panel 

or active buttons. To add/edit panel overlay titles, follow these steps:

1. Click Panel > Panel title to open the Add Panel Title dialog shown in FIG. 6. You can also 

double-click on existing overlay titles to open the same dialog.

2. Enter or edit the text in the Text field. Then, choose the text size, font, vertical or horizontal 

direction, and the optional vertical/horizontal text position in relation to the panel or buttons. 

Then, click OK to save the panel title, close the dialog, and return to the main window. You can 

click on one or more panel titles and adjust their position using your directional (arrow) 

FIG. 5  Job Information dialog

FIG. 6  Add Panel Title dialog
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Using OLDesign
keyboard keys.

The preview area in the Add Panel Title dialog shows you a real-time view of the overlay, and 

updates dynamically as you choose different options. You can also choose the vertical/

horizontal Relation to: Buttons option, and click one or more buttons in the preview area to 

reset the text location.

3. Click the Save Program File button to save your changes.

Copying/pasting panel overlays

You can use the copy/paste options to copy existing overlays to clipboard memory, and then paste 

them into different program files. This can substantially reduce the overall design time by starting 

new projects with pre-designed overlays. You can also create a library program file containing 

multiple transmitter and panel overlays, and use the library as a source for creating new over-lays. 

To copy and paste overlays:

1. Click File > Open to open the Open dialog. Choose the source program file containing the 

target overlay in the File Name field. Click OK to open the program file.

2. Locate and double-click the overlay's name in the Panel Edit window (FIG. 1 on page 3) to 

open the overlay in the main window. If it is the correct overlay, click the overlay's name again 

in the Panel Edit window.

3. Click Edit > Copy or press Ctrl+C to copy the target overlay to clipboard memory. Click 

File > Close to close the program file.

4. Click File > Open to open the Open dialog. Choose the destination program file in the File 

Name field. Click OK to open the program file.

5. Click Edit > Paste or press Ctrl+P to paste the overlay into the destination program file.

6. Click the Save Program File button to save your changes.

Choosing overlay colors

After creating an overlay, you must specify its color. The overlay color is required by AMX 

Corporation to produce the final engraved overlay. Your AMX Sales Representative must include 

the overlay colors when submitting your order to the Engraving department for processing. So, it is 

very important to include the color information with your program file to eliminate any 

unnecessary delays. To choose overlay colors, follow these steps:

1. Open the target overlay. Then, click Panel > Panel Properties to open the Panel Properties 

dialog.

2. Choose the color option in the Overlay/Text Color option list. For special color specifications, 

please enter the alternate colors in the Comment field. Then, contact your AMX Sales 

Representative to verify that the color you need is available.

3. Click OK to save the color specifications, close the dialog, and return to the main window.

4. Click the Save Program File button to save your changes.

The Clear Nudge option is active when you manually move panel titles with the 
directional (arrow) keyboard keys. Clicking the Clear Nudge option repositions the 
panel title back to the location specified with the Vertical/Horizontal Position settings 
in this dialog.
13OLDesign Overlay Design Program (Version 2.1)



Using OLDesign
Working with Buttons
Adding/editing button titles and graphic symbols is the most common operation in the overlay 

design process. Text options include size, fonts, and position. Available symbol options include 

common transport and lighting symbols that can be combined with text to convey button-by-button 

control functions on the overlay.

Adding/editing button titles and descriptions

You can add/edit button titles and descriptions individually, or as a group. To add/edit button titles 

and descriptions on one button or a group of buttons:

1. Open the target overlay. Select one button or hold down the Shift key and select multiple 

buttons to activate a group of buttons.

2. Click Button > Button Title to open the Add Button Title dialog.

3. Enter or edit the button's title in the Text field. Then, choose the text size, font, and text 

position.

4. Click OK to save the button title, close the dialog, and return to the main window.

5. Click OK to save the active button's title, close the dialog, and the program automatically 

opens the Add Button Title dialog for the next button in the group. Enter or edit the button's 

title in the Text field, and choose the text size, font, and text position. Repeat this step to add 

titles to all the buttons in the group. When you add/edit the title for the last button in the group, 

the dialog closes and returns to the main window.

6. Click one button or hold down the Shift key and click multiple buttons to activate a group of 

buttons. You can click on one or more button titles and adjust their position using your 

directional (arrow) keyboard keys.

7. Click Button > Description to open the Button Description dialog. If you are adding a 

description to one button, you can double-click the button to automatically open the dialog.

8. Enter or edit the button description in the Description/Display field.

9. Click OK to save the button's description, close the dialog, and return to the main window. 

10. Click OK to save the button's description, close the dialog, and the program automatically 

opens the Button Description dialog for the next button in the group. Enter or edit the button's 

description in the Description/Display field. Repeat this step to add descriptions to all the 

buttons in the group. When you add/edit the description for the last button in the group, the 

dialog closes and returns to the main window.

11. Click the Save Program File button to save your changes. FIG. 7 shows a sample overlay and 

the indicators that appear on buttons that have descriptions.

FIG. 7  Sample overlay showing button description indicators

Button description indicators
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Adding/changing button symbols

You can add/change button symbols one at a time or as a group just like the button titles and 

descriptions. To add/change symbols on one button or a group of buttons, follow these steps:

1. Open the target overlay. Click one button or hold down the Shift key and click multiple buttons 

to activate a group of buttons. You can click on one or more button symbols and adjust their 

position using your directional (arrow) keyboard keys.

2. Click Button > Add Symbol to open the Select Symbol dialog shown in FIG. 8. You can also 

click an existing symbol to automatically open the dialog.

3. Click the symbol that best represents the function of the active button. The active symbol 

appears in the Current Symbol field. Choose the symbol's position in relation to the text and 

button. 

4. Click OK to save the button symbol, close the dialog, and return to the main window.

5. Click OK to save the button's symbol, close the dialog, and the program automatically opens 

the Select Symbol dialog for the next button in the group. Add or change the button's symbol. 

Repeat this step to add symbols to all the buttons in the group. When you add/change the 

symbol for the last button in the group, the dialog closes and returns to the main window.

6. Click the Save Program File button to save your changes. FIG. 9 shows a sample button 

symbol and text combination.

FIG. 8  Select Symbol dialog

FIG. 9  Sample button symbol and text

Button symbol and text
15OLDesign Overlay Design Program (Version 2.1)



Using OLDesign
Setting button colors

To select active and default button colors:

1. Open the target overlay. Then, hold down the Shift key and select the buttons you want assign 

a specific color to.

2. Click Button > Button Color to open the Select Button Color dialog.

3. Choose a button color in the Current Button Color list. Colors not available for the active 

overlay are disabled (grayed-out). 

You can also set the default button color for the active overlay's type by choosing a default 

color in the Default Panel Button Color list. Then, each time you add a new overlay that 

matches the active overlay's type, the OLDesign program automatically applies the default 

color to the buttons.

4. Click OK to save the color options, close the dialog, and return to the main window.

5. Click the Save Program File button to save your changes.

Removing buttons

To remove buttons from an overlay:

1. Open the target overlay. Then, hold down the Shift key and select the buttons you want to 

delete from the overlay.

2. Click Button > Remove. The program opens the Panel Edit dialog to confirm removing each 

selected button. The message in the dialog identifies the button number to be deleted by 

number.

3. Click Yes to delete all the buttons. Continue clicking Yes in each dialog until all buttons are 

deleted from the overlay. When you delete the last button in the group, the dialog closes and 

returns to the main window.

4. Click the Save Program File button to save your changes.
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Restoring removed buttons

To restore removed buttons:

1. Open the target overlay. Then, click Button > Restore drop-down menu to open the Restore 

Button dialog (FIG. 10). Removed buttons appear in blue.

2. Select the blue buttons to restore in the overlay. 

3. Click OK to restore the buttons in the active overlay, close the dialog, and return to the main 

window.

4. Click the Save Program File button to save your changes.

Working with Button Groups
In most cases, the overlays you design will have one or more button groups that perform 

equipment-specific operations, and can be titled accordingly with specific references to the 

associated equipment (i.e. VCR, TV, and DVD player).

Adding/editing button groups

To add/edit button group outlines, titles, and group descriptions to overlays:

1. Open the target overlay. Then, hold down the Shift key and click the buttons you want to 

include in the button group outline.

2. Click Group > Add Group to add the group outline around the active buttons. Use the resizing 

handles to set the outline's size. New button group outlines appear like the sample shown in 

FIG. 11.

FIG. 10  Restore Button dialog showing the buttons to be restored
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3. Click the group outline to activate the resizing handles. 

4. Then, click Group > Group Title to open the Add Group Title dialog (FIG. 12).

5. Enter or edit the button group's title in the Text field. 

6. Then, set the text size, font, direction, and vertical/horizontal position in relation to the active 

buttons. Then, click OK to save the text, close the dialog, and return to the main window.

You can also use the Below Button option to locate the text next to the button number you 

enter into this field. FIG. 13 shows a sample button group outline, title, and description 

indicator.

7. Double-click on any vacant area inside the button group to open the Group Description dialog. 

Enter or edit the description for the active button group. Use group descriptions to maintain 

detailed control information about button groups.

The three types of panels that support the Combine Group Buttons option include the 

AXP-MLCD, AXU-MLCD, and TX-MLCD. Use the Combine Group Buttons option to 

remove the button outlines in the active group. Then, you can add button titles, symbols, and/or 

group titles that appear on top of the panel buttons in the active group.

8. Click the Save Program File button to save your changes.

FIG. 11  Sample button group outline and resizing handles

FIG. 12  Add Group Title dialog

Group outline

Resizing handles
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Saving button groups

1. Open the target overlay. Then, click on any vacant area inside the button group you want to 

save. Make sure the button group handles are active before proceeding to the next step.

2. Click Group > Save to open the Group Save dialog (FIG. 14).

3. Enter the group outline's name in the File Name field. Then, choose the target directory and 

drive location to save the group outline.

4. Click OK to save the group outline, close the dialog, and return to the main window.

5. Click the Save Program File button to save your changes.

FIG. 13  Sample button group outline, title, and description indicator

FIG. 14  Group Save dialog

Button group description indicator 

Button group outline and title
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Recalling and pasting button groups

To recall a saved button group, follow these steps:

1. Open the target overlay. Then, click Group > Recall to open the Group Recall dialog (FIG. 15).

2. Choose the target directory and button group name. You can preview button groups by 

clicking the files listed under the File Name field. The active (highlighted) file appears in the 

preview window.

! Click the Get Info button to open the Information dialog to view the .GRL file name, file 

size, date, and time it was last saved to disk. 

! Click the Build List button to refresh the list of button group files.

3. Click OK to place the button group in the Paste buffer, close the dialog, and return to the 

overlay in the main window.

4. Click the top-left button in the target area of the overlay to paste the button group stored in the 

buffer. Make sure the size of the recalled button group does not exceed the available space in 

the target overlay. If it does, the program generates an error message and cancels the paste 

operation.

5. Click the Save Program File button to save your changes.

Copying button groups

To copy button groups, follow these steps:

1. Open the target overlay. Then, click on any vacant area inside the button group you want to 

copy. Make sure the button group handles are active before proceeding to the next step. 

2. Click Edit > Copy to copy the active button group.

3. Click the top-left button in the target area of the overlay to paste the button group stored in the 

copy buffer. 

FIG. 15  Group Recall dialog

Preview window
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4. Click the Save Program File button to save your changes.

Removing button groups

To remove button group outlines, titles, and descriptions:

1. Open the target overlay. Then, click any vacant area inside the button group to activate the 

resizing handles.

2. Click Edit > Delete to open the Panel Edit dialog. Click Yes to delete the selected button group 

and its title.

3. If you delete button groups containing symbols and/or button titles, the program automatically 

opens a Panel Edit dialog for each symbol and button title contained in the deleted button 

group. The message that appears in the dialog identifies the symbol or button number to be 

deleted. Click No to keep the symbol or button title or Yes to delete it from the overlay. Repeat 

this step until the Panel Edit dialog prompts stop.

4. Click the Save Program File button to save your changes.

Working with Bargraphs
Most of the wired control panel overlays you can create with the OLDesign program include red 

bargraphs that represent actual LED bargraph indicators included with the panels. Bargraphs are 

programmed with the Axcess programming language to work in conjunction with one or more 

buttons on the panels. Bargraphs appear on the overlays as red circles and can be removed or 

retained as project requirements dictate.

Removing bargraph LEDs

To remove specific LEDs from a bargraph:

1. Open the overlay and double-click the target bargraph to open the Edit Bargraph dialog shown 

in FIG. 16.

2. Click to remove the checkboxes adjacent to the LED indicators to be removed. Then, click OK 

to save the bargraph settings, close the dialog, and return to the main window. Checkmarks 

indicate the bargraph indicators will appear on the active overlay. FIG. 16 shows the first two 

LED indicators disabled, and they will be removed from the active overlay.

Make sure the size of the copied button group does not exceed the available space in 
the target overlay. If it does, the program generates an error message and cancels 
the paste operation.

FIG. 16  Edit Bargraph dialog
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3. Click the Save Program File button to save your changes.

Removing bargraphs

To remove bargraphs from overlays:

1. Open the overlay and click the target bargraph to remove. Then, click Panel > Remove 

Bargraph to open the Panel Edit dialog.

2. Click Yes to remove the selected bargraph from the overlay, close the dialog, and return to the 

main window.

3. Click the Save Program File button to save your changes.

Restoring bargraphs

To restore removed bargraphs:

1. Open the target overlay. Then, click Panel > Restore to open the Restore Bargraph dialog.

2. Click on one or more of the blue bargraphs in the dialog. A rectangle appears on each bargraph 

you choose to indicate that it will be restored.

3. Click OK to restore the bargraphs, close the dialog, and return to the main window.

4. Click the Save Program File button to save your changes.

Working with Radio Codes
A radio code represents the group of Axcess channel numbers that are assigned to the pushbuttons 

on wireless transmitters. These channel numbers are used to program button-specific operations 

that are executed by the master. The wireless transmitter overlays available in the OLDesign 

program can be customized with different radio codes. 

Use of different radio codes in multiple wireless transmitter environments prevents the potential for 

conflicting control operations. For more information on radio codes, refer to the TXC+ Transmitter 

Series instruction manual.

Setting radio codes (wireless transmitters only)

To set radio codes for wireless transmitters, follow these steps:

1. Open the target wireless transmitter overlay. Then, click Panel > Radio Code to open the Set 

Radio Code dialog (FIG. 17).

2. Choose a radio code to reassign the Axcess channel numbers on the transmitter buttons. Click 

None to start the channel numbers at 1.

3. Click OK to save the radio code, close the dialog, and return to the main window.

4. Click the Save Program File button to save your changes.
22 OLDesign Overlay Design Program (Version 2.1)



Using OLDesign
Working with DXF Files
The OLDesign program includes an export tool that converts overlay files to .DXF formatted files. 

The .DXF files can be used with a wide variety of drawing programs that support vector-type 

graphic files. 

Creating .DXF overlay files

1. Select Panel > Create DXF File to open the Create DXF File dialog.

2. Enter the filename for the overlay, and choose the target directory to store the .DXF file. Then, 

click OK to create the .DXF file, close the dialog, and return to the main window.

FIG. 17  Set Radio Code dialog

Some .DXF drawings created by AMX Corporation contain proprietary fonts that are 
not embedded in the drawing files. If your drafting program is not equipped with these 
fonts, the drawings may appear slightly different from the actual drawings as they 
appear in the OLDesign program.
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Printing Program Files
The three print-related options are Print Preview, Print, and Print Setup. The Print option allows 

you to print one page, a range of pages, or all the overlay pages in the program file. Print Preview 

allows you to view thumbnail views of the overlay pages in the program file with their page 

numbers and filenames. Print Setup allows you to set various parameters on your printer.

! Print Preview:  Open the target program file. Then, click File > Print Preview to open the 

Print Preview dialog (FIG. 18).

! Print: Click Print to open the Print dialog or File > Print. Then, choose the print range, 

quality, and printer setup options. Click OK to print the program file.

! Print Setup:  Since Print Setup options are different for every printer, instructions are not 

provided in this manual. Refer to your printer manufacturer's literature for setup 

information.

FIG. 18  Print preview dialog
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Sending OLDesign Program Files to AMX Corporation
The preferred way to send your OLDesign .TXL program files to AMX Corporation is by attaching 

them to an electronic-mail (e-mail) message, and e-mailing it directly to your AMX Sales 

Representative. Sending program files electronically ensures the engraved overlays are promptly 

processed and returned back to you.

E-mailing program files to your AMX sales representative

Before sending .TXL program files to your AMX Sales Representative to process, please ensure the 

body of your e-mail contains the required information as described in these instructions. To e-mail 

program files to your AMX Sales representative:

1. Open the target program file. Click File > Save as to open the Save As dialog (FIG. 19).

2. Click the Get Info button to open the Information dialog, and write down the .TXL filename. 

Click the OK and Cancel buttons to return to the main window.

3. Write the e-mail message and attach the .TXL program file. Before sending the e-mail, please 

verify that the following information is included in the body of your e-mail message:

! Your name, mailing address, and telephone number

! AMX Sales Representative's name

! Dealer name

! Job Title

! Dealer ID

! Purchase Order #

! Shipping Order #

! Overlay Return Request Date

Most, if not all, e-mail programs support file attachments that are less than 500 KB in 
size. Also, please call your AMX Sales Representative after sending the e-mail and 
.TXL program file to verify the message and file were received.

FIG. 19  Save As dialog
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