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Introduction

Juniper Networks EX Series Ethernet Switches are shipped with the Juniper Networks

Junos operating system (Junos OS) installed.

Junos OS has the following primary user interfaces:

Juniper Web Device Manager (J-Web) GUI

Junos OS CLI

You can use these interfaces to access, configure, and manage your EX Series switch.

This topic provides an overview of the newly re-designed J-Web interface.
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Supported EX Series Switches

In J-Web Application Package 23.2A3 which aligns with Junos OS Release 23.2R2, the

J-Web interface supports the following models: EX2300, EX2300-C, EX2300-MP,

EX3400, EX4100, EX4100-F, EX4300-48MP, EX4400, EX4400-24X, and the EX4400-

EM-1C uplink module for EX4400 and EX4400-24X switches, which were also

supported in earlier releases.

NOTE: You cannot connect to and perform initial configuration of the EX4650 switches

by using the EZSetup procedure from the J-Web interface; you must use EZSetup from

the switch console.

To obtain more information about the components that are supported on each switch,

and the special compatibility guidelines for the release, see the Hardware Guide for

the switch.

To determine the features supported on EX Series switches in this release, use the

Juniper Networks Feature Explorer, a Web-based application that helps you to explore

and compare Junos OS feature information to find the right software release and

hardware platform for your network. Find Feature Explorer at

https://apps.juniper.net/feature-explorer/.

https://apps.juniper.net/feature-explorer/
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For Junos OS Release 14.1X53-D10 and later, the J-Web interface is available in two

packages:

Platform package— Provides basic features of J-Web and is installed as part of

Junos OS.

The Platform package of J-Web is installed as part of Junos OS that is shipped with

your EX Series switch. The Platform package provides the basic features of the J-Web

interface. The Platform package enables you to configure and maintain your switch.

Application package— Provides all features of J-Web and is a separately installable

package.

The Application package is not installed by default on your switch. You must download

it and install it over the Platform package on your switch. The Application package

provides all the features of the J-Web interface that enable you to configure, monitor,

maintain, and troubleshoot your switch.

For information about installing the Application package, see “Upgrading to J-Web

Application Package” on page 5 Upgrading to J-Web Application Package.

The Platform package, which is installed as part of the Junos OS that is shipped

with your switch, follows the Junos OS release cycle. However, the Application

packages have their own release cycle which is independent of the Junos OS

release cycle. This separate release cycle helps you get the latest features of J-

Web by installing the latest version of the Application package, without waiting for

Junos OS releases.

NOTE:

The J-Web Application package is hot-pluggable. You can install it on top of the

current Junos OS installation, and you need not reboot the switch after the installation.



To determine which J-Web package you are currently using, click Help > About. The

About window appears. If you are using a Platform package, only the Platform

package details are displayed. If you are using an Application package, both the

Platform package and Application package details are displayed.

If your current J-Web package is: Then you can:

Platform package Upgrade to the Application package.

Application package

Update to a latest version of the Applicati

on package available on the Juniper

Networks server that is compatible with th

e Junos OS on your switch.

NOTE: If you upgrade Junos OS on your switch, the current J-Web package is replaced

with the J-Web Platform package that is associated with the upgraded Junos OS

release. You can then install the latest Application package that is associated with the

main release of the upgraded Junos OS, over the Platform package.

Release Compatibility

The Application packages of J-Web have their own release cycles (A1, A2, A3, and so

on), which are independent of the Junos OS release cycle. An Application package is

compatible only with the corresponding major release of Junos OS.

Table 1 on page 4 lists the release compatibility.

Table 1: J-Web Release Compatibility Matrix

Junos OS Release
Associated J-Web Application Package R

elease

21.4R1 Application package 21.4A1

22.2R1 Application package 22.2A1



22.4R1 Application package 22.4A1

23.2R1 Application package 23.2A1

23.2R1 Application package 23.2A2

23.2R2 Application package 23.2A3

Any available later version of the Application package for a Junos OS release

supersedes the earlier version. We recommend that you install the latest available

version of the Application package.
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This section describes the features and enhancements in J-Web Application Package

Release 23.2A3.

What’s New in J-Web Application Package Release 23.2A3

In J-Web Application Package 23.2A3 which aligns with Junos OS Release 23.2R2, the

J-Web interface supports the following models: EX2300, EX2300-C, EX2300-MP,

EX3400, EX4100, EX4100-F, EX4300-48MP, EX4400, EX4400-24X, and the EX4400-

EM-1C uplink module for EX4400 and EX4400-24X switches, which were also

supported in earlier releases.

NOTE: You cannot connect to and perform initial configuration of the EX4650 switches

by using the EZSetup procedure from the J-Web interface; you must use EZSetup from

the switch console.



Upgrading to J-Web Application Package

There are two ways in which you can download and install the J-Web Application

package:

Manual update

CLI procedure

There is a prescribed order for the installation tasks for updating to the Application

package from an earlier version or from the Platform package. See Table 2 on page 6 to

determine the prescribed order of tasks for your installation.

Table 2: Installation Outline

Mode of Installation Installation Outline

Manual Update

To manually check and install the latest J-

Web Application package:

1. Go to Maintain > Update J-Web in the s

ide pane, and click Select Application P

ackage.

2. Select Local File in the Update J-Web 

window, enter authentication details do

wnload the file to your local system, sel

ect the file, and click Update.

CLI Procedure

1. Download the J-Web Application packa

ge and save it in the switch.

2. Log in to the CLI and enter the operatio

nal mode.

3. Install the package using the CLI comm

and request system software add <appl

ication package file name>.



Software Compatibility

To access the J-Web interface for the switch, your management device requires the

following software:

Supported browsers—Mozilla Firefox and Google Chrome.

NOTE:

We recommended a screen resolution of 1440 X 900 pixels.

Microsoft ended Internet Explorer support in June 2022. Therefore, starting with

Junos OS Release 22.4R1 or later, J-Web user interface is not supported in

Internet Explorer.

Language support—English-version browsers.
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This section lists the known issues in the J-Web Application package Release 23.2A3.

Known Issues

Table 3 on page 8 lists the PR numbers and its description that are known issues in the

J-Web Application package Release 23.2A3.

Table 3: Known Issues

PR Number Problem Description



NA

Adobe Flash Player support ended on De

cember 31, 2020. Therefore:

For Junos OS Release 20.3R1 and earl

ier releases, the following pages will no

t load correctly:

Monitor > System View > Process Deta

ils

Monitor > Interfaces

Monitor > Power over Ethernet

Monitor > Service > DHCP > Server

Monitor > Service- > DHCP > Relay

Monitor > Switching > IGMP Snooping

Monitor > Virtual Chassis

Monitor > Security > Port Security

Monitor > Routing > OSPF Information

For Junos OS Release 20.4R1 and late

r releases, the following pages will not 

be supported:

Monitor > System View > Process Deta

ils

Monitor > Power over Ethernet

Monitor > Service- > DHCP > Relay

Monitor > Switching > IGMP Snooping

Monitor > Virtual Chassis

Monitor > Security > Port Security

Monitor > Routing > OSPF Information

PR Number Problem Description



For Junos OS Release 20.4R1 and late

r releases, the following pages will be s

upported. However, the Flash compone

nts are removed.

Monitor > Interfaces

Monitor > Service > DHCP > Server

1029736

In the Maintain > Update J-Web page, Sel

ect Application package > Update J-Web, 

local file does not work in Microsoft IE9 a

nd later releases, because of the default s

ecurity options set on these browsers. As 

a workaround, increase the security level:

Method 1:

1. Navigate to Internet Options > Security.

2. Select the zone Local intranet.

3. Click the custom level button.

4. Disable the option Include local director

y Path when uploading file to the server

in the Settings > miscellaneous section.

5. Repeat Step 3 and Step 4 for the zone I

nternet.

Method 2:

Navigate to Internet Options > Security > 

Custom level… and set Reset custom set

tings to Medium-High or High. This autom

atically disables the option Include local di

rectory Path when uploading file to the se

rver under Settings > miscellaneous secti

on.



1810275

For Junos OS Release 23.2A2, in J-Web, 

we’ve deprecated the feature to Install Ju

nos OS Upgrade package from a remote 

server, which was available at Maintain > 

Update Junos.

Known Limitations

Table 4 on page 10 lists the PR numbers and its description that are known limitations in

the J-Web Application package Release 23.2A3.

Table 4: Known Limitations

PR Number Problem Description

777372

If a Virtual Chassis contains more than si

x members, the Support Information page

(Maintain > Customer Support > Support i

nformation) might not load. This is a know

n software limitation.

604595

The J-Web interface does not support rol

e-based access control; it supports only u

sers in the super-user authorization class.

Therefore, a user who is not in the superu

ser class, such as a user with view-only p

ermission, is able to launch the J-Web int

erface and is allowed to configure everyth

ing, but the configurations fail on commit, 

and the switch displays access permissio

n errors. This is a known software limitati

on.



1026308

If you uninstall the J-Web Platform pack

age by using CLI, reinstalling the Applic

ation package will not restore J-Web.

Workaround: Reinstall Junos OS

software.

1006208

J-Web software does not compare for a

ppropriateness of the Application packa

ge or restrict you from installing inappro

priate Application package on top of a 

Platform or Application package.

Workaround: Install the appropriate J-

Web package.

PR Number Problem Description

915069

The J-Web interface does not display C

LI generated certificates in the

Certificate section in the Management 

Access Configuration page (Configure 

> System Properties > Management Ac

cess). Using J- Web interface you cann

ot create or edit certificates.

Workaround: Use the CLI interface for

accessing certificate related configurati

ons.



400814

In the J-Web interface, you cannot com

mit some configuration changes in the 

Ports Configuration page or the VLAN 

Configuration page because of the follo

wing limitations for port-mirroring ports 

and port- mirroring VLANs:

A port configured as the output port for 

an analyzer cannot be a member of an

y VLAN other than the default VLAN.

A VLAN configured to receive analyzer 

output can be associated with only one 

interface.

This is a known software limitation. Wor

karound: None.

425693

In the J-Web interface, the Ethernet Switc

hing Monitor page (Monitor > Switching > 

Ethernet Switching) might not display

monitoring details if the switch has more t

han 13,000 MAC entries. This is a known 

software limitation.

866976

When you try to commit your changes t

o the switch from your laptop by using t

he EZsetup procedure, the status of

the commit operation is displayed as Su

ccess, even if the laptop is disconnecte

d from the switch.

Workaround: Reconnect your laptop to

the switch and commit the changes aga

in.
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trademarks of Juniper Networks, Inc. in the United States and other countries. All other

trademarks, service marks, registered marks, or registered service marks are the

property of their respective owners. Juniper Networks assumes no responsibility for any

inaccuracies in this document. Juniper Networks reserves the right to change, modify,

transfer, or otherwise revise this publication without notice. Copyright © 2025 Juniper

Networks, Inc. All rights reserved.

FAQ

Q: Can I use the J-Web interface to configure EX4650 switches?

A: No, you must use the switch console for initial configuration of EX4650 switches as

EZSetup is not supported via J-Web interface for this model.
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