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Release Information

IP versions are the same as the IntelA® QuartusA® Prime Design Suite software versions up to v19.1. From Intel
Quartus Prime Design Suite software version 19.2 or later, IP cores have a new IP versioning scheme. The IP
versioning scheme (X.Y.Z) number changes from one software version to another. A change in:

« Xindicates a major revision of the IP. If you update your Intel Quartus Prime software, you must regenerate the
IP.
« Y indicates the IP includes new features. Regenerate your IP to include these new features.

« Zindicates the IP includes minor changes. Regenerate your IP to include these changes.

Item Description
IP Version 24.2

Intel Quartus Prime 21.2
Release Date 2021.06.21

Design Example Quick Start Guide for External Memory Interfaces Intel Agilex™ FPGA IP

An automated design example flow is available for Intel Agilex™ external memory interfaces. The Generate
Example Designs button on the Example Designs tab allows you to specify and generate the synthesis and
simulation design example file sets which you can use to validate your EMIF IP. You can generate a design
example that matches the Intel FPGA development kit, or for any EMIF IP that you generate. You can use the
design example to assist your evaluation, or as a starting point for your own system.

General Design Example Workflows

> Compilation » Functional
[Simulator) Simulation

Intel Quartus EMIE IP )

N ; p| Design Example | |

Prime Project "l Configuration Generation

Creation

y| Compilation | o Timing Analysis > Hardware
1 [Quartus Prime) {Quartus Prime) Testing

Creating an EMIF Project

For he Intel Quartus Prime software version 17.1 and later, you must create an Intel Quartus Prime project before
generating the EMIF IP and design example.

1. Launch the Intel Quartus Prime software and select File » New Project Wizard. Click Next. Design Example
Quick Start Guide for External Memory Interfaces Intel Agilex™ FPGA IP

2. Specify a directory (<user project directory>), a name for the Intel Quartus Prime project (<user project
name>), and a top-level design entity name (<user top-level instance name>) that you want to create. Click
Next.



W New Project Wizard ]

Directory, Name, Top-Level Entity

What is the working directory for this project?

| user project directory

What is the name of this project?

user project name
What is the name of the top-level design entity for this project? This name is case sensitive and must exactly match the
entity name in the design file

user top level instance name

This project uses a Partition Database (.qdb) file for the root partition

Use Existing Project Settings...

Help < Back Next > Finish Cancel

3. Verify that Empty Project is selected. Click Next two times.



& New Project Wizard O X

Project Type

Select the type of project to create.

® Empty project

Create new project by specifying project files and libraries, target device family and device, and EDA
tool settings.

O Project template

Create 2 project from an existing design template. You can choose from design templates installed
with the Quartus Prime software, or download design templates from the Design Store.

< Back Next > Finish Cancel Help

4. Under Family, select Intel Agilex.
5. Under Name filter, type the device part number.

6. Under Available devices, select the appropriate device.



Ej New Project Wizard b4
Family, Device & Board Settings

Device Board

Select the family and device you want to target for compilation. You can install additional device support with the Install Devices command on the Tools menu.
To determine the version of the Intel Quartus Prime software in which your target device is supported, refer to the Device Support List webpage.

Device family Show in ‘Available devices' list
Eamily: ;ngile: [F-Series I-Series) - | - 3
= Package: | Any >
Device: | All - ¢ §
Pin count: | Any x
Target device Core spesd grade: | Any -

8 specific device selected in ‘Available devices' list
¥| Show advanced devices

Other. nfa
Filter: | Name v |
) Name Tile Core Voltage ALMs Total IfOs | GPIOs HSSI Channels | Memaory Bits M20K | DSP Blocks yop™

1 ;AEFAO‘!ZRZM‘I ETV P-Tile VID 399500 924 768 32 120832000 5300 3743 24

2 ;AGFAO12R24A1I1V P-Tile VID 399500 924 768 32 120832000 5500 3743 24

3“ :AGFAO'FZREMZEZV P-Tile viD 399500 924 768 32 120832000 5900 3743 24

4 |AGFADT2R24A2E3E P-Tile VID 399500 924 768 32 120832000 5800 3743 24

5 AGFADTZR24A2E3V P-Tile VID 399500 924 768 32 120832000 5900 3743 24

6 ;AGFA012R24A2I2V P-Tile VID 399500 924 768 32 120832000 5900 3743 24

7 EAGFAOTZRZ#\ZIBE P-Tile VID 399500 924 768 32 120832000 5900 3743 24
i ’ 3

Avallable devices: 112

Help | < Back MNext > | FEinish | Ccancel

7. Click Finish.

Generating and Configuring the EMIF IP

The following steps illustrate how to generate and configure the EMIF IP. This walkthrough creates a DDR4
interface, but the steps are similar for other protocols. (These steps follow the IP Catalog (standalone) flow; if you
choose to use the Platform Designer (system) flow instead, the steps are similar.)

1. In the IP Catalog window, select External Memory Interfaces Intel Agilex FPGA IP. (If the IP Catalog window is

not visible, select View » IP Catalog.)

~ & Installed IP
= Library
* Basic Functions
= Simulation; Debug and Verification
+ Simulation
# External Memory BFM intel FPGA IP
= Memory Interfaces and Controllers

External Memory Interfaces intel Agilex FPGA IP

# External Memory Interfaces intel Calibration IP

2. In the IP Parameter Editor, provide an entity name for the EMIF IP (the name that you provide here becomes

the file name for the IP) and specify a directory. Click Create.



New IP Variant

Look In: | example |'| ’EHE”EI EH'B:

] adb

File Marme:

| <user instance name> |

Files of Type: |IP Variation Files (*.in) v

| Create || Cancel |

3. The parameter editor has multiple tabs where you must configure parameters to reflect your EMIF

implementation.

Intel Agilex EMIF Parameter Editor Guidelines
This topic provides high-level guidance for parameterizing the tabs in the Intel Agilex EMIF IP parameter editor.

Table 1. EMIF Parameter Editor Guidelines

Parameter Editor Tab

Guidelines

General

Ensure that the following parameters are entered correctly:
+ The speed grade for the device.
« The memory clock frequency.

» The PLL reference clock frequency.

Memory

» Refer to the data sheet for your memory device to enter the paramet
ers on the Memory tab.

* You should also enter a specific location for the ALERT# pin.
(Applies to DDR4 memory protocol only.)

Mem I/O

« Forinitial project investigations, you may use the default settings on
the

Mem I/O tab.

» For advanced design validation, you should perform board simulatio
n to derive optimal termination settings.




» For initial project investigations, you may use the default settings on
the

» For advanced design validation, you should perform board simulatio
n with associated IBIS models to select appropriate /O standards.

» For initial project investigations, you may use the default settings on
the

Mem Timing Mem Timing tab.

» For advanced design validation, you should enter parameters accor
ding to your memory device’s data sheet.

Set the controller parameters according to the desired configuration an

Controller )
d behavior for your memory controller.

You can use the parameters on the Diagnostics tab to assist in testing

Diagnostics and debugging your memory interface.

The Example Designs tab lets you generate design examples for
synthesis and for simulation. The generated design example is a compl
ete EMIF system consisting of the EMIF IP and a driver that generates r
andom traffic to validate the memory interface.

Example Designs

For detailed information on individual parameters, refer to the appropriate chapter for your memory protocol in the
External Memory Interfaces Intel Agilex FPGA IP User Guide.

Generating the Synthesizable EMIF Design Example

For the Intel Agilex development kit, it is sufficient to leave most of the Intel Agilex EMIF IP settings at their default
values. To generate the synthesizable design example, follow these steps:

1. On the Example Designs tab, ensure that the Synthesis box is checked.
« If you are implementing single interface example design, configure the EMIF IP and click File» Save to

save the current setting into the user IP variation file (<user instance names>.ip).



: W Farameiors S@ e :
|Systenr [I0R4  Path: emif_fn 0 =t

. Deiails
External Memory Interfaces Intel Agilex FPGA IP =
altera_emi_fm i Generats Example Dasign...

™ Memory Frotocol 1
Pratocal: [pppa i

[ General | Wemor | “Mem D [TFPGAYD “MemTiming | Boad | Controller ["Diagnustics |”Example Designs | T

= Example Design with Multi-IP's |
] Simulation  [F] Synthesis [ SignalInteqrity [ SpyalasscDC  SIMUlaton HOL Tormat [verilng |+ -

Humber of IPs: |1'
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[ Target Development Kit
Select hoard: |n0ng
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Apply 3 development kit presetinthe Prezels panel fo configure the example design for develaprment kit e ating.
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development kit. [ you 3ra not generating your sxample desion for a davelopment kit §.e. devaloping an a custom
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o If you are implementing an example design with multiple interfaces, specify Number of IPs to the
desired number of interfaces. You can see the total number of EMIF ID same as the selected
Number of IPs. Follow these steps to configure each interface:

Select the Cal-IP to specify the connection of the interface to the Calibration IP.

Configure the EMIF IP accordingly in all the Parameter Editor Tab.

Return to Example Design tab and click Capture on the desired EMIF ID.

Repeat step a to ¢ for all EMIF ID.
« You may click the Clear button to remove the captured parameters and repeat step a to ¢ to make
changes to the EMIF IP.

Click File» Save to save the current setting into the user IP variation file (<user instance namex.ip).

% pammers 5 = l:lu
System: DDR4  Path: ernit_irm_ o

External Memory Interfaces Intel Agilex FPGA IP —
altera_emif_fm Generate Exampls Design..

~ Memory Protocol
Protocol: | pppg ik

[ Genzral [“hemory | Mem 0 [TFRGANC ["MemTiming [“Board [ Conirdller [ Diagnostcs [ Example Designs |
* E Iz Design with Mulfi-IPs

[»

Sirmulation Syrthasis ] Signal Iniegrty  [] SpyplasscDC SIMUIAton HOLTOTET barlagy |v|

Mumber ofiPs: (g

There are two Calibraton [Ps on the device. Each ofthe EMIF IP must be connected to either ot the two Cal-IPs.
Plzasa selact, for each EMIF IP, which ofthe two CAL-IPs shauld the EMF IP be connected to.

EMIF ID CALIP

e S GIESTS Come] |

EMIF #1 CaklP: [CalP o [+ [ capue | [ clem F
| i
| | |

Captura Clear

EMIF #2 CatP: [Carip a || Capture Clear
EMIF #3 CakIF: [ral P n : Captura Claar

- Target Development Kit
Select hoard:

ARplY @ devIapment KItpreset In the Presets panel 1o contigure he example design 107 cerelOpment ki testing,

Salect 2 development kit preset fram the 'Presets’ panel to configure the exarmmple design for testing on a specific
developrment kit If you are not genersting your example desion for & development kit e, devaloping on & custom
poard). please select none'from the diop-down menu above,

4] I [»]

2. Click Generate Example Design in the upper-right corner of the window.



W parameters s = (=]
System: Test  Path: emif frm D

External Memory Interfaces Intel Agilex FPGA IP e
altera_emif_fm . Generate Example Design...

~ Memory Protocol |
Protocol: |DDR4 e

[ General | Memory | Mem /0 | FFGA O | Mem Timing | Board | Contreller | Diagnostics | Example Designs

3. Specify a directory for the EMIF design example and click OK. Successful generation of the EMIF design

example creates the following fileset under a qii directory.

. Select Example Design Directory X

select the directory for the example design

Path: | <design example directory>

Cancel OK

4. Click File » Exit to exit the IP Parameter Editor Pro window. The system prompts, Recent changes have not
been generated. Generate now? Click No to continue with the next flow.

5. To open the example design, click File » Open Project, and navigate to the
<project_directory>/<design_example_name>/qgii/ed_synth.qpf and click Open.
Note: For information on compiling and programming the design example, refer to

Compiling and Programming the Intel Agilex EMIF Design Example.

Figure 4. Generated Synthesizable Design Example File Structure

.qsys_edit p ed_synth
ddr4_example Il qi I ip
I emif_fm_0_example_design I sim qdb
qdb | ed_sim.qsys rl@] ed_synth.qpf I
I | ddrd_example.ip |<— | ed_synth.gsys | ed_synth.qsf
3] emif_example.qpf | ipgen.log I " | ed_synth.gsys I#
| emif_example.qsf ) make_gii_design.tcl | ip_generate.out
 make_sim_design.tcl | ftag_example.sdc
e  Generated external ) params.tcl
memory interface IP file =| readme.txt ¢  Generated example
- oottt | omiepomane | |, Sl
¥ GgchtacomplEhe add/remove/modify IPs

example design in the example design

For information on constructing a system with two or more external memory interfaces, refer to Creating a Design
Example with Multiple EMIF Interfaces, in the External Memory Interfaces Intel Agilex FPGA IP User Guide. For
information on debugging multiple interfaces, refer to Enabling the EMIF Toolkit in an Existing Design, in the
External Memory Interfaces Intel Agilex FPGA IP User Guide.



Note: If you don’t select the Simulation or Synthesis checkbox, the destination directory contains only Platform
Designer design files, which are not compilable by the Intel Quartus Prime software directly, but which you can
view or edit in the Platform Designer. In this situation you can run the following commands to generate synthesis
and simulation file sets.

« To create a compilable project, you must run the quartus_sh -t make_qjii_design.tclscript in the destination
directory.
« To create a simulation project, you must run the quartus_sh -t make_sim_design.tcl script in the destination

directory.

Note: If you have generated a design example and then make changes to it in the parameter editor, you must
regenerate the design example to see your changes implemented. The newly generated design example does not
overwrite the existing design example files.

Generating the EMIF Design Example for Simulation

For the Intel Agilex development kit, it is sufficient to leave most of the Intel Agilex EMIF IP settings at their default
values. To generate the design example for simulation, follow these steps:

1. On the Example Designs tab, ensure that the Simulation box is checked. Also choose the required Simulation
HDL format, either Verilog or VHDL.

2. Configure the EMIF IP and click File » Save to save the current setting into the user IP variation file (<user
instance namex>.ip).

3. Click Generate Example Design in the upper-right corner of the window.

4. Specify a directory for the EMIF design example and click OK. Successful generation of the EMIF design
example creates multiple file sets for various supported simulators, under a sim/ed_sim directory.

5. Click File » Exit to exit the IP Parameter Editor Pro window. The system prompts, Recent changes have not

been generated. Generate now? Click No to continue with the next flow.

Generated Simulation Design Example File Structure

I'I aldec I

altera_merlin_master_translator_191

| Aldec Riviera-Pro|

altera_merhn_slave_translator_191

gsys_edit ip _P altera_mm_interconnect_191

ddrd_example qii ip altera_reset_controller_191
I cmii_lrn_l]_:xcmplc_dmignIM | ed sim.qsys common
qdb | ed_sim.qsys o | mentor ] «— Mentor Graphics Modelsim|
| ddrd_exampleip | ed_synth.gsys sim
(5] emif_example.qp | ipgen.log synopsys <+— Synopsys VCS/VCS-MX |
| emif_examplegsf make_gii_design.tcl yeelium
make_sim_design.tcl [ S *\l Cadence Xceliumm |
params.tcl =
ey 8- ed_sim.csv

12| ed_sim.html

| | ed_sim.qgsimc

|| ed_sim.sopcinfo

| | ed_sim.spd

| ed_sim_bbv

[’ ed_sim_generation.rpt
|.__]" ed_sim_inst.v

u" ed_sim_inst.vhd




Note: The External Memory Interfaces Intel Agilex FPGA IP currently supports only the VCS,
ModelSim/QuestaSim, and Xcelium simulators. Additional simulator support is planned in future releases.

Note: If you don’t select the Simulation or Synthesis checkbox, the destination directory contains only Platform
Designer design files, which are not compilable by the Intel Quartus Prime software directly, but which you can
view or edit in the Platform Designer. In this situation you can run the following commands to generate synthesis
and simulation file sets.

« To create a compilable project, you must run the quartus_sh -t make_qjii_design.tcl script in the destination
directory.
« To create a simulation project, you must run the quartus_sh -t make_sim_design.tcl script in the destination

directory.

Note: If you have generated a design example and then make changes to it in the parameter editor, you must
regenerate the design example to see your changes implemented. The newly generated design example does not
overwrite the existing design example files.

Simulation Versus Hardware Implementation
For external memory interface simulation, you can select either skip calibration or full calibration on the
Diagnostics tab during IP generation.

EMIF Simulation Models
This table compares the characteristics of the skip calibration and full calibration models.

Table 2. EMIF Simulation Models: Skip Calibration versus Full Calibration

Skip Calibration Full Calibration

System-level simulation focusing on user logic. Memory interface simulation focusing on calibration.
Details of calibration are not captured. Captures all stages of calibration.

Has ability to store and retrieve data. Includes leveling, per-bit deskew, etc.

Represents accurate efficiency.

Does not consider board skew.

RTL Simulation Versus Hardware Implementation
This table highlights key differences between EMIF simulation and hardware implementation.

Table 3. EMIF RTL Simulation Versus Hardware Implementation

RTL Simulation Hardware Implementation

Nios® initialization and calibration code execute in par | Nios initialization and calibration code execute
allel. sequentially.

Interfaces assert cal_done signal simultaneously in si | Fitter operations determine the order of calibration, an
mulation. d interfaces do not assert cal_done simultaneously.

You should run RTL simulations based on traffic patterns for your design’s application. Note that RTL simulation



does not model PCB trace delays which may cause a discrepancy in latency between RTL simulation and
hardware implementation.

Simulating External Memory Interface IP With ModelSim
This procedure shows how to simulate the EMIF design example.

1. Launch the Mentor Graphics* ModelSim software and select File » Change Directory. Navigate to the
sim/ed_sim/mentor directory within the generated design example folder.

2. Verify that the Transcript window is displayed at the bottom of the screen. If the Transcript window is not visible,
display it by clicking View » Transcript.

3. In the Transcript window, run source msim_setup.tcl.

4. After source msim_setup.tcl finishes running, run Id_debug in the Transcript window.

5. After Id_debug finishes running, verify that the Objects window is displayed. If the Objects window is not
visible, display it by clicking View » Objects.

6. In the Objects window, select the signals that you want to simulate by right-clicking and selecting Add Wave.

7. After you finish selecting the signals for simulation, execute run -all in the Transcript window. The simulation
runs until it is completed.

8. If the simulation is not visible, click View » Wave.

Pin Placement for Intel Agilex EMIF IP
This topic provides guidelines for pin placement.

Overview
Intel Agilex FPGAs have the following structure:

« Each device contains up to 8 I/0 banks.
Each 1/0 bank contains 2 sub-1/0O banks.

Each sub-I/O bank contains 4 lanes.

Each lane contains 12 general-purpose I/0 (GPIO) pins.

General Pin Guidelines
The following are general pin guidelines.

Note: For more detailed pin information, refer to the Intel Agilex FPGA EMIF IP Pin and Resource Planning
section in the protocol-specific chapter for your external memory protocol, in the External Memory Interfaces Intel
Agilex FPGA IP User Guide.

« Ensure that the pins for a given external memory interface reside within the same I/O row.

Interfaces that span multiple banks must meet the following requirements:

o The banks must be adjacent to one another. For information on adjacent banks, refer to the EMIF
Architecture: I/O Bank topic in the External Memory Interfaces Intel Agilex FPGA IP User Guide.
« All address and command and associated pins must reside within a single subbank.

Address and command and data pins can share a sub-bank under the following conditions:

o Address and command and data pins cannot share an I/O lane.

o Only an unused I/O lane in the address and command bank can contain data pins.



Table 4. General Pin Constraints

Signal Type Constraint

Data Strobe All signals belonging to a DQ group must reside in the same I/O lane.

Related DQ pins must reside in the same I/O lane. For protocols that do
Data not support bidirectional data lines, read signals should be grouped
separately from write signals.

Address and Command pins must reside in predefined locations within a

Address and Command n /O sub-bank.

Note: For more detailed pin information, refer to the Intel Agilex FPGA EMIF IP Pin and Resource Planning
section in the protocol-specific chapter for your external memory protocol, in the External Memory Interfaces Intel
Agilex FPGA IP User Guide.

» Ensure that the pins for a given external memory interface reside within the same I/O row.

Interfaces that span multiple banks must meet the following requirements:
o The banks must be adjacent to one another. For information on adjacent banks, refer to the EMIF
Architecture: 1/0 Bank topic in the External Memory Interfaces Intel Agilex FPGA IP User Guide.

« All address and command and associated pins must reside within a single subbank.

Address and command and data pins can share a sub-bank under the following conditions:
o Address and command and data pins cannot share an I/O lane.

o Only an unused I/O lane in the address and command bank can contain data pins.

Generating a Design Example with the TG Configuration Option

The generated EMIF design example includes a traffic generator block (TG). By default, the design example uses
a simple TG block (altera_tg_avl) which can only be reset in order to relaunch a hard-coded traffic pattern. If
necessary, you may choose to enable a configurable traffic generator (TG2) instead. In the configurable traffic
generator (TG2) (altera_tg_avl_2), you can configure the traffic pattern in real time through control registers—
meaning that you do not have to recompile the design to change or relaunch the traffic pattern. This traffic
generator provides fine control over the type of traffic that it sends on the EMIF control interface. Additionally, it
provides status registers that contain detailed failure information.

Enabling the Traffic Generator in a Desigh Example

You can enable the configurable traffic generator from the Diagnostics tab in the EMIF parameter editor. To enable
the configurable traffic generator, turn on Use configurable Avalon traffic generator 2.0 on the Diagnostics tab.

Figure 6.

* Traffic Generator (settings only applicable for example design)

l¥| Use configurable Avalon traffic generator 2.0
Enable default traffic pattern (pattern configured during compile-time)

\»| Enable user-configured traffic pattern (pattern configured during run-time)
TG2 default traffic duration:

TG2 Configuration Interface Mode: JTAG =

« You may choose to disable the default traffic pattern stage or the userconfigured traffic stage, but you must



have at least one stage enabled. For information on these stages, refer to Default Traffic Pattern and User-
configured Traffic Pattern in the External Memory Interfaces Intel Agilex FPGA IP User Guide.
« The TG2 test duration parameter applies only to the default traffic pattern. You may choose a test duration of
short, medium, or infinite.
« ou may choose either of two values for the TG2 Configuration Interface Mode parameter:
o JTAG: Allows use of a GUI in the system console. For more information, refer to Traffic Generator
Configuration Interface in the External Memory Interfaces Intel Agilex FPGA IP User Guide.

o Export: Allows use of custom RTL logic to control the traffic pattern.

Using the Design Example with the EMIF Debug Toolkit

Before launching the EMIF Debug Toolkit, ensure that you have configured your device with a programming file
that has the EMIF Debug Toolkit enabled. To launch the EMIF Debug Toolkit, follow these steps:

1. In the Intel Quartus Prime software, open the System Console by selecting Tools » System Debugging Tools
» System Console.

2. [Skip this step if your project is already open in the Intel Quartus Prime software.] In the System Console, load
the SRAM obiject file (.sof) with which you programmed the board (as described in Prerequisites for Using the
EMIF Debug Toolkit, in the External Memory Interfaces Intel Agilex FPGA IP User Guide).

3. Select instances to debug.

4. Select EMIF Calibration Debug Toolkit for EMIF calibration debugging, as described in Generating a Design
Example with the Calibration Debug Option. Alternatively, select EMIF TG Configuration Toolkit for traffic
generator debugging, as described in Generating a Design Example with the TG Configuration Option.

5. Click Open Toolkit to open the main view of the EMIF Debug Toolkit.
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6. If there are multiple EMIF instances in the programmed design, select the column (path to JTAG master) and

memory interface ID of the EMIF instance for which to activate the toolkit.

Collechon_2 =2

Welome =

ed_synth_inst
Toollkdit: *ErF Calibration Debug Toolkit” femd” cad_ohg_ag 2300
[USE-1]|AEFEM 4 (F25A|R24AROME |ad_synth_inst

Syslems: AGF FPGA Developrnant Kitan
JTAG Master HPATH: gd_synih_insiemif callernif calljzn_master widamon Infertace 10 0w Export Populated Tahlasl

7. Click Activate Interface to allow the toolkit to read the interface parameters and calibration status.

Wisloome 3% Collection 2 52 |
- ed_synth_inst
Toolkit; "EMIF Calibration Debug Toolkit" (emd cad cbg_ay 2.3.0)
[USE-1]|AGFEO14(F2SAIFZ4AR0 @1 |ed_synth_inst
es |

Systems: AGF FPCGA Davelopmeant Kiton

| Astivate Inte face |
8. You must debug one interface at a time; therefore, to connect to another interface in the design, you must first

deactivate the current interface.
The following are examples of reports from the EMIF Calibration Debug Toolkit and the EMIF TG Configuration

Toolkit:, respectively.



Welcome £ | Collection_2 53|
ed_synth_inst

Toolkit: "EMIF Calibration Debug Toolkit' (emd cal_dhgy s 2.3.0)
Systems: AGF FPGA Development Kit on pg-emiffpgal .gar.corpintel.com [USB-1]RGFBOT4(F25AR24ARME T [ed_synth_inst
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termary Configuration  Calibration | Calibration Report | Calibrate Termination | YWrefbdargining = Diiver bzargining | 1S5F | Pin Delay Settings

[+ ODT Settings In Effect

| Calibration Status
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Note: For details on calibration debugging, refer to Debugging with the External Memory Interface Debug Toolkit,
in the External Memory Interfaces Intel Agilex FPGA IP User Guide.

Note: For details on traffic generator debugging, refer to Traffic Generator Configuration User Interface, in the
External Memory Interfaces Intel Agilex FPGA IP User Guide.



Design Example Description for External Memory Interfaces Intel Agilex FPGA IP

When you parameterize and generate your EMIF IP, you can specify that the system create directories for
simulation and synthesis file sets, and generate the file sets automatically. If you select Simulation or Synthesis
under Example Design Files on the Example Designs tab, the system creates a complete simulation file set or a
complete synthesis file set, in accordance with your selection.

Synthesis Desigh Example
The synthesis design example contains the major blocks shown in the figure below.

« A traffic generator, which is a synthesizable Avalon®-MM example driver that implements a pseudo-random
pattern of reads and writes to a parameterized number of addresses. The traffic generator also monitors the
data read from the memory to ensure it matches the written data and asserts a failure otherwise.

« An instance of the memory interface, which includes:

o A memory controller that moderates between the Avalon-MM interface and the AFI interface.
o The PHY, which serves as an interface between the memory controller and external memory devices to

perform read and write operations.

Figure 7. Synthesis Desigh Example
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Note: If one or more of the PLL Sharing Mode, DLL Sharing Mode, or OCT Sharing Mode parameters are set to
any value other than No Sharing, the synthesis design example will contain two traffic generator/memory interface
instances. The two traffic generator/memory interface instances are related only by shared
PLL/DLL/OCTconnections as defined by the parameter settings. The traffic generator/memory interface instances
demonstrate how you can make such connections in your own designs.

Simulation Design Example
The simulation design example contains the major blocks shown in the following figure.

« An instance of the synthesis design example. As described in the previous section, the synthesis design
example contains a traffic generator, calibration component, and an instance of the memory interface. These
blocks default to abstract simulation models where appropriate for rapid simulation.

« A memory model, which acts as a generic model that adheres to the memory protocol specifications.
Frequently, memory vendors provide simulation models for their specific memory components that you can
download from their websites.

« A status checker, which monitors the status signals from the external memory interface IP and the traffic

generator, to signal an overall pass or fail condition.



Figure 10. Simulation Design Example
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Example Designs Interface Tab
The parameter editor includes an Example Designs tab which allows you to parameterize and generate your
design examples.
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2.4.2

In the Design Example Quick Start chapter:

» Added a note to the Compiling and Program
ming the Intel Agilex EMIF Design Example top
ic.

+ Modified the title of the Generating a Design
Example with the Calibration Debug Option topi
C.

» Added the Generating a Design Example wi
th the TG Configuration Option and Enabling th
e Traffic Generator in a Design Example topics.

+ Modified steps 2, 3, and 4, updated several
figures, and added a note, in the Using the Des
ign Example with the EMIF Debug Toolkit topic.

2021.03.29

211

2.4.0

In the Design Example Quick Start chapter:

» Added a note to the Generating the Synthes
izable EMIF Design Example and Generating t
he EMIF Design Example for Simulation topics.

» Updated the File Structure diagram in the G
enerating the EMIF Design Example for Simulat
ion topic.
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20.4

2.3.0

In the Design Example Quick Start chapter, ma
de the following changes:

+ Updated the Generating the Synthesizable
EMIF Design Example topic to include multi-E
MIF designs.

» Updated the figure for step 3, in the
Generating the EMIF Design Example for Simul
ation topic.
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2.3.0

In the Design Example Quick Start Guide chapt
er, made the following changes:

» In Creating an EMIF Project, updated the im
age in step 6.

» In Generating the Synthesizable EMIF Desi
gn Example, updated the figure in step 3.

* In Generating the EMIF Design Example for
Simulation, updated the figure in step 3.

* In Simulation Versus Hardware Implementat
ion, corrected a minor typo in the second table.

* In Using the Design Example with the EMIF
Debug Toolkit, modified step 6, added steps 7
and 8.
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* Inthe About chapter, modified the table in t
he

Release Information topic.
» Inthe Design Example Quick Start Guide
chapter:

— Modified step 7 and the associated image,
in the Generating the Synthesizable EMIF Desi
gn Example topic.

— Modified the Generating the Design Examp
le with the Debug Option topic.

— Modified the Using the Design Example wit
h the EMIF Debug Toolkit topic.

2019.12.16

19.4

2.0.0

* Inthe Design Example Quick Start chapter:
— Updated the illustration in step 6 of the
Creating an EMIF Project topic.

— Updated the illustration in step 4 of the Ge
nerating the Synthesizable EMIF Design Exam
ple topic.

— Updated the illustration in step 4 of the Ge
nerating the EMIF Design Example for Simulati
on topic.

— Modified step 5 in the Generating the EMIF
Design Example for Simulation topic.

— Modified the General Pin Guidelines and A
djacent Banks sections of the Pin Placement fo
r Intel Agilex EMIF IP topic.




2019.10.18

19.3

* Inthe Creating an EMIF Project topic, updat
ed the image with point 6.

* Inthe Generating and Configuring the EMIF
P

topic, updated the figure with step 1.

* Inthe table in the Intel Agilex EMIF Paramet
er Editor Guidelines topic, changed the
description for the Board tab.

* Inthe Generating the Synthesizable EMIF
Design Example and Generating the EMIF Des
ign Example for Simulation topics, updated the
image in step 3 of each topic.

» Inthe Generating the EMIF Design
Example for Simulation topic, updated the Gen
erated Simulation Design Example File Structur
e figure and modified the note following the figu
re.

* Inthe Generating the Synthesizable EMIF
Design Example topic, added a step and a figu
re for multiple interfaces.

2019.07.31

19.2

1.2.0

» Added About the External Memory Interface
s Intel Agilex FPGA IP chapter and Release Inf
ormation.

» Updated dates and version numbers.

* Minor enhancement to the Synthesis
Design Example figure in the Synthesis Design
Example topic.
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