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Design Example Quick Start Guide for External Memory Interfaces Intel® Arria® 10 FPGA IP

A new interface and more automated design example flow is available for Intel® Arria® 10 external memory
interfaces.

The Example Designs tab in the parameter editor allows you to specify the creation of synthesis and simulation
file sets which you can use to validate your EMIF IP.

You can generate an example design specifically for an Intel FPGA development kit, or for any EMIF IP that you
generate.

Figure 1. General Design Example Workflows

Design Example

Figure 2. Generating an EMIF Example Design With an Intel Arria 10 Development Kit
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Creating an EMIF Project

For the Intel Quartus® Prime software version 17.1 and later, you must create an Intel Quartus Prime project
before generating the EMIF IP and design example.

1. Launch the Intel Quartus Prime software and select File » New Project Wizard. Click Next.

¥ Quartus Prime Pro Edition

File Edit View Project Assignments Proce

.

MNew... Ctri+N
~ Open.. Ctri+Q
Close Ctrl+F4

= New Project Wizard...
& Open Project... Ctrl+J
Save Project

Close Project

2. Specify a directory and name for the project that you want to create. Click Next.



¥ New Project Wizard

Directory, Name, Top-Level Entity

What is the working directory for this project?

|C;\,intelFPGA_pro‘l.1 7.N\example_design | ‘

What is the name of this project?

|emif_enample |j

What Is the name of the top-level design entity for this project? This name is case sensitive and rmust
exactly match the entity name in the design file.

|emif_example | ‘

[] This project uses a Partition Database [.qdb) file for the root partition

‘Use Existing Project Settings...

< Back ‘ Next > Finish Cancel Help

3. Verify that Empty Project is selected. Click Next two times.



¥ New Project Wizard

Project Type

Select the type of project to create.

® Empty project
Create new project by specifying project files and libraries, target device family and device, and EDA
tool settings.

O Project template

Create a project from an existing design template. You can chocse from design templates installed
with the Quartus Prime software, or download design templates from the Design Store.

< Back ‘ Finish Cancel Help

4. Under the Name filter, type the device part number.

5. Under Available devices, select the appropriate device.



&' New Project Wizard

Family, Device & Board Settings

Device Board

Select the family and device you want to target for compilation. You can install additional device support with the Install Devices command on the Tools menu.
To determine the version of the Quartus Prime software in which your target device is supported, refer to the Device Support List webpage.

Transceiver speed grade: | Any

® Specific device selected in ‘Available devices' list

Device family Show in 'Available devices' list
Family: |Arr|a 10 (GX/SX/GT) - Package: Any - |
Device: |All S| Pin count: Any A |
Core speed grade: Any v |
Target device |

MName filter:
Other: n/a [ Show advanced devices
Available devices:

Name Core Voltage ALMs Total 1/Os GPI0s HSSI Channels PCle Hard IP Blocks Memory Bit "
T0AXT115R4F40I3LG 0.9V 427200 55562240
Toaxiismaraoss Josv 427200 m-__m
T0AX1155TF45E1SG 0.9V or 0.95V 427200 960 55562240 ~
< >

< Back Finish Cancel Help

6. Click Finish.

Generating and Configuring the EMIF IP

The following steps illustrate how to generate and configure the EMIF IP. The steps are similar regardless of the
memory protocol that you are targeting.

1. In the IP Catalog window, select Intel Arria 10 External Memory Interfaces. (If the IP Catalog window is not

visible, select View » Utility Windows » IP Catalog.)

IP Catalog g x

v -.‘ Installed IP
V¥ Project Directory
No Selection Available
Vv Library
> Basic Functions
> DSP
? Interface Protocols
> Low Power
¥ Memory Interfaces and Controllers
¥ Arria 10 External Memory Interfaces
¥ External Memory Interfaces Debug Component
¥ Hybrid Memory Cube Controller



2. In the IP Parameter Editor, provide an entity name for the EMIF IP (the name that you provide here becomes

the file name for the IP) and specify a directory. Click Create.

New IP Variant X

LookIn: | example_design v | |@] ﬁ| | BRI R=

(=] qdb

File Name: |arria10_ddr4

Files of Type: |IP Variation Files (*.ip) -
Create Cancel

3. The parameter editor has multiple tabs where you must configure parameters to reflect your EMIF

implementation:

Intel Arria 10 EMIF Parameter Editor Guidelines

Table 1. EMIF Parameter Editor Guidelines

Parameter Editor Tab Guidelines

Ensure that the following parameters are entered correctly:
+ The speed grade for the device.

General
» The memory clock frequency.

+ The PLL reference clock frequency.




+ Refer to the datasheet for your memory device to enter the paramet
ers on the Memory tab.

Memory * You should also enter a specific location for the ALERT# pin.
(Applies to DDR4 memory protocol only.)
« Forinitial project investigations, you may use the default settings on
the

Mem 1/O Mem 1/O tab.
» For advanced design validation, you should perform board simulatio
n to derive optimal termination settings.
« Forinitial project investigations, you may use the default settings on
the

FPGA I/O FPGA 1/O tab.
+ For advanced design validation, you should perform board simulatio
n with associated IBIS models to select appropriate /O standards.
» For initial project investigations, you may use the default settings on
the

Mem Timing Mem Timing tab.

» For advanced design validation, you should enter parameters accor
ding to your memory device’s datasheet.




« Forinitial project investigations, you may use the default settings on
the

Board tab.

Board » For advanced design validation and accurate timing closure, you sh
ould perform board simulation to derive accurate intersymbol interferen
ce (ISI)/ crosstalk and board and package skew information, and enter i
t on the Board tab.

Set the controller parameters according to the desired configuration an

Controller )
d behavior for your memory controller.

You can use the parameters on the Diagnostics tab to assist in testing

Diagnostics and debugging your memory interface.

The Example Designs tab lets you generate design examples for
synthesis and for simulation. The generated design example is a compl
ete EMIF system consisting of the EMIF IP and a driver that generates r
andom traffic to validate the memory interface.

Example Designs

For detailed information on individual parameters, refer to the appropriate chapter for your memory protocol in the
Intel Arria 10 External Memory Interfaces IP User Guide.

Generating the Synthesizable EMIF Design Example

For the Intel Arria 10 development kits, there are presets that automatically parameterize the EMIF IP and
generate pinouts for the specific board.

1. Verify that the Presets window is visible. If the Presets window is not visible, display it by selecting View »



Presets.

2. In the Presets window, select the appropriate development kit preset and click Apply.

L]
&

Presets for emif_0

=]

Clear preset filters

4

Project

Library

me.4

Click New... to create a preset,

[ Arria 10 GX FPGA Development Kit with DDR3 HILO

[ Arria 10 GX FPGA Development Kit with DDR4 HILO

[) Arria 10 GX FPGA Development Kit with RLDRAM3 HILO

[ Arria 10 SoC Development Kit with DDR4 HILO for FPGA (x72)
[ Arria 10 SoC Development Kit with DDR4 HILO for HPS (x40)
[} DDR3-1066E CL6 Component 1C5 1Gb (128Mb x8)

[) DDR2-1066E CL6 Component 1C5 1Gb (256Mb x4)

[) DDR3-1066E CL6 Component 1CS 1Gh (64Mb x16)

[} DDR3-1066E CL6 Component 1CS 2Gh (128Mb x16)

[ DDR2-1066E CL6 Component 1C5 2Gh (256Mb x8)

[) DDR3-1066E CL6 Component 1C5 2Gb (512Mb x4)

3

4]

3. Configure the EMIF IP and click Generate Example Design in the upper-right corner of the window.




% Parameters &0 - =

System: cddr  Path: emif_0

External Memory Interfaces Intel Arria 10 FPGA IP Retaiis ]

altera_emif Cenerate Example Design... I

-

[~ Memory Protocol - A

Protocol: [ppre L]
17

( General | Memory | Mem 1/0 |

[~ Avallable Example Designs
Select design (EMIF Example Design | w

FPGAI/O | Mem Timing | Board | Controller [ Diagnostics | Example Designs |

[~ Example Design Files
] Simulation

[#] Synthesis

The example design supports generation, simulation, and Quartus compilation flows for any selected device, To use the
example design for simulation, select the Simulation' option above. To use the example design for compilation and
hardware, select the 'Synthesis’' option above

[~ Generated HDL Format
Simulation HOL format: [yerjiog ‘ v)

[~ Target Development Kit
Select board |Arria 10 GX FPGA Development Kit with DDR4 HILO |+

Famity: Arria 10 Device: 10AX11552F45115C

Select a development kit preset from the 'Presets' panel 1o configure the example design for testing on a specific
dewvelopment kit If you are not generating your example design for a development kit (i e. developing on a custom
board), please select 'none' from the drop-down menu above

4. Specify a directory for the EMIF design example and click OK. Successful generation of the EMIF design

example creates the following files under a Wii directory.

Figure 3. Generated Synthesizable Design Example File Structure

.qsys_edit e ed_synth
ddrd_example qii > ip
| emif_0_example_design sirm qdb
qdb [ ed_sim.qsys :l@ ed_synth.qpf
| _ ddrd_example.ip I-l— _ ] ed_synth.qsys | | ed synth.qsf
: g . o le
k| emif_example.qpf ] ipgen.log | | | ed synth.qsys |+
| emif_example.qsf [ make_gii_design.tcl | | ip_generate.out
| emif_example.qws [ make_sim_design.tcl | | jtag_example.sdc
J params.tel
Generated external | readme.tt * Generated example
memory interface IP file - Quartus Prime project file design QSYS file
+  Open this file to modify - Open to compile the * Open this file to
the EMIF IP example design add/remove/modify IPs
in the example design

Note: If you don’t select the Simulation or Synthesis checkbox, the destination directory will contain Platform
Designer design files, which are not compilable by the Intel Quartus Prime software directly, but can be viewed or
edited under the Platform Designer. In this situation, you can run the following commands to generate synthesis
and simulation file sets.

« To create a compilable project, you must run the quartus_sh -t make_qjii_design.tcl script in the destination

directory.
« To create a simulation project, you must run the quartus_sh -t make_sim_design.tcl script in the destination

directory.
« The Select board pulldown in this section applies the appropriate development kit pin assignments to the

example design.



« This setting is available only when you turn on the Synthesis checkbox in the Example Design Files section.

« This setting must match the applied development kit present, or else an error message appears.

« If the value None appears in the Select board pulldown, it indicates that the current parameter selections do not
match any development kit configurations. You may apply a development kit-specific IP and related parameter
settings by selecting one of the preset from the preset library. When you apply a preset, the current IP and
other parameter settings are set to match the selected preset. If you want to save your current settings, you
should do so before you select a preset. If you do select a preset without saving your prior settings, you can
always save the new preset settings under a different name

« If you want to generate the example design for use on your own board, set Select board to None, generate the
example design, and then add pin location constraints.

Related Information

« Synthesis Example Design on page 17

« Intel Arria 10 EMIF IP Parameter Descriptions for DDR3

« Intel Arria 10 EMIF IP Parameter Descriptions for DDR4

« Intel Arria 10 EMIF IP Parameter Descriptions for QDRII/I1+/Xtreme
« Intel Arria 10 EMIF IP Parameter Descriptions for QDR-IV

« Intel Arria 10 EMIF IP Parameter Descriptions for RLDRAM 3

« Intel Arria 10 EMIF IP Parameter Descriptions for LPDDR3

Generating the EMIF Design Example for Simulation

For the Intel Arria 10 development kits, there are presets that automatically parameterize the EMIF IP and
generate pinouts for the specific board.

1. Verify that the Presets window is visible. If the Presets window is not visible, display it by selecting View »
Presets.

2. In the Presets window, select the appropriate development kit preset and click Apply.



8 rresets B -4

Presets for emif_0
[ ] Clear preset filters

||

Project
Click New... to create a preset,
Library

D Arria 10 GX FPGA Development Kit with DDR2 HILO

D Arria 10 GX FPCA Development Kit with DDR4 HILO

D Arria 10 GX FPGA Development Kit with RLDEAM S HILO

[ Arria 10 SoC Development Kit with DDR4 HILO for FPGA (x72)
D Arria 10 SoC Dewvelopment Kit with DDR4 HILO for HPS (x40)
D DDR2-1066E CL6 Component 1C5 1Gh (128Mb x8)

D DDR2-1066E CLE Component 1C5 1Gh (256Mb x4)

[) DDR2-1066E CL6 Component 1CS 1Gb (64Mb % 16)

D DDR2-1066E CL6 Component 1C5 2Gb (128Mb x16)

[ DDR2-1066E CL6 Component 1CS 2Gb (256Mb x8)

D DDRE2-1066E CL6 Component 1C5 2Gh (512Mb x4)

mokd

-

14 il [ »]

3. Configure the EMIF IP and click Generate Example Design in the upper-right corner of the window.

" P

System: ddr  Patle emif_0

External Memory Interfaces Intel Arria 10 FPGA IP

altera,emif

Generate Example Design...

Protocol ||

‘General | Memery | Mem /O | FPGAI/O | Mem Timing | Board | Comtroller | Diagnostics | Example Designs |

~ Avallable Example Design

Select design: |EMIF Exampie Design | » |
~ Example Design Files

[¥] Simulation

[#] Synthesis

The example design suppons generation, simulation, and Quartus compilation flows for any selected device. To use the
example design for simulation, select the Simulation’ option above. To use the axample design for compilation and
harcware, select the ‘Symhesis’ option above

d HDL Forma

Simulation HDL format
Select boara: |arria 10 Gx FPGA Development Kit with DOR4 HILO [x]

Family. Arria 10 Device: 10AX11552F45115G

Select a development kit preset from the 'Presets' panel 1o configure the example design for testing on a specific
development kit, If you are not generating your example design for a development kit (L. developing on a custom
board), please select ‘none’ from the drop-down menu above,

4. Specify a directory for the EMIF design example and click OK.

Successful generation of the EMIF design example creates multiple file sets for various supported simulators,

under a sim/ed_sim directory.
Figure 4. Generated Simulation Design Example File Structure
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Note: If you don’t select the Simulation or Synthesis checkbox, the destination directory will contain Platform
Designer design files, which are not compilable by the Intel Quartus Prime software directly, but can be viewed or
edited under the Platform Designer. In this situation you can run the following commands to generate synthesis
and simulation file sets.

« To create a compilable project, you must run the quartus_sh -t make_qii_design.tcl script in the destination
directory.
« To create a simulation project, you must run the quartus_sh -t make_sim_design.tcl script in the destination

directory.

Related Information

« Simulation Example Design on page 19
« Intel Arria 10 EMIF IP — Simulating Memory IP

Simulation Versus Hardware Implementation

For external memory interface simulation, you can select either skip calibration or full calibration on the
Diagnostics tab during IP generation.

EMIF Simulation Models

This table compares the characteristics of the skip calibration and full calibration models.

Table 2. EMIF Simulation Models: Skip Calibration versus Full Calibration

Skip Calibration Full Calibration
System-level simulation focusing on user logic. Memory interface simulation focusing on calibration.
Details of calibration are not captured. Captures all stages of calibration.

continued...




Skip Calibration

Full Calibration

Has ability to store and retrieve data.

Includes leveling, per-bit deskew, etc.

Represents accurate efficiency.

Does not consider board skew.

RTL Simulation Versus Hardware Implementation

This table highlights key differences between EMIF simulation and hardware implementation.
Table 3. EMIF RTL Simulation Versus Hardware Implementation

RTL Simulation

Hardware Implementation

Nios® initialization and calibration code execute in par
allel.

Nios initialization and calibration code execute
sequentially.

Interfaces assert cal_done signal signal simultaneousl
y in simulation.

Fitter operations determine the order of calibration, an
d interfaces do not assert cal_done simultaneously.

You should run RTL simulations based on traffic patterns for your design’s application. Note that RTL simulation
does not model PCB trace delays which may cause a discrepancy in latency between RTL simulation and

hardware implementation.

Simulating External Memory Interface IP With ModelSim

This procedure shows how to simulate the EMIF design example.

1. Launch the Mentor Graphics* ModelSim software and select File » Change Directory. Navigate to the

sim/ed_sim/mentor directory within the generated design example folder.

2. Verify that the Transcript window is displayed at the bottom of the screen. If the Transcript window is not visible,

display it by clicking View » Transcript.

3. In the Transcript window, run source msim_setup.tcl.




4. After source msim_setup.tcl finishes running, run Id_debug in the Transcript window.

5. After Id_debug finishes running, verify that the Objects window is displayed. If the Objects window is not
visible, display it by clicking View » Objects.

6. In the Objects window, select the signals that you want to simulate by right-clicking and selecting Add Wave.

7. After you finish selecting the signals for simulation, execute run -all in the Transcript window. The simulation
runs until it is completed.

8. If the simulation is not visible, click View » Wave.

Related Information

Intel Arria 10 EMIF IP — Simulating Memory IP

Pin Placement for Intel Arria 10 EMIF IP

This topic provides guidelines for pin placement.

Overview

Intel Arria 10 FPGAs have the following structure:

« Each device contains 2 I/O columns.

Each 1/0 column contains up to 8 I/O banks.

Each 1/0O bank contains 4 lanes.

Each lane contains 12 general-purpose I/O (GPIO) pins.

General Pin Guidelines

The following points provide general pin guidelines:

« Ensure that the pins for a given external memory interface reside within a single 1/O column.
« Interfaces that span multiple banks must meet the following requirements:

o The banks must be adjacent to one another. For information on adjacent banks, refer to the Intel Arria 10
External Memory Interfaces IP User Guide.

o The address and command bank must reside in a center bank to minimize latency. If the memory
interface uses an even number of banks, the address and command bank may reside in either of the two
center banks.

« Unused pins can be used as general-purpose I/O pins.
o All address and command and associated pins must reside within a single bank.
« Address and command and data pins can share a bank under the following conditions:

o Address and command and data pins cannot share an I/O lane.

o Only an unused /O lane in the address and command bank can be used for data pins.

Table 4. General Pin Constraints



Constraint

Signal Type

Data Strobe All signals belonging to a DQ group must reside in the same I/O lane.
Related DQ pins must reside in the same 1/O lane. DM/DBI pins must be

Data paired off with a DQ pin for proper operation. For protocols that do not su

pport bidirectional data lines, read signals should be grouped separately f
rom write signals.

Address and Command pins must reside in predefined locations within a

Address and Command n 1/O bank.

Pin Assignments
If you applied a development kit preset during IP generation, all pin assignments for the development kit are
automatically generated and can be verified in the .gsf file that is generated with the design example.

Related Information

« Intel Arria 10 EMIF IP DDR3

« Intel Arria 10 EMIF IP for DDR4

« Intel Arria 10 EMIF IP for QDRII/ll+/Xtreme
« Intel Arria 10 EMIF IP for QDR-IV

« Intel Arria 10 EMIF IP for RLDRAM 3

« Intel Arria 10 EMIF IP for LPDDR3

Compiling and Programming the Intel Arria 10 EMIF Design Example

After you have made the necessary pin assignments in the .gsf file, you can compile the design example in the
Intel Quartus Prime software.

1. Navigate to the Intel Quartus Prime folder containing the design example directory.

2. Open the Intel Quartus Prime project file, (.qpf).

3. To begin compilation, click Processing » Start Compilation. The successful completion of compilation
generates an .sof file, which enables the design to run on hardware.

To program your device with the compiled design, open the programmer by clicking Tools » Programmer.
In the programmer, click Auto Detect to detect supported devices.

Select the Intel Arria 10 device and then select Change File.

Navigate to the generated ed_synth.sof file and select Open.

© N o g &

Click Start to begin programming the Intel Arria 10 device. When the device is successfully programmed, the

progress bar at the top-right of the window should indicate 100% (Successful).



Debugging the Intel Arria 10 EMIF Design Example

The EMIF Debug Toolkit is available to assist in debugging external memory interface designs. The toolkit allows
you to display read and write margins and generate eye diagrams. After you have programmed the Intel Arria 10
development kit, you can verify its operation using the EMIF Debug Toolkit.

1. To launch the EMIF Debug Toolkit, navigate to Tools » System Debugging Tools » External Memory Interface
Toolkit.

2. Click Initialize Connections.

3. Click Link Project to device. A window appears; verify that the correct device is selected and that the correct
.sof file is selected.

4. Click Create Memory Interface Connection. Accept the default settings by clicking OK.

5. The Intel Arria 10 development kit is now set up to function with the EMIF Debug Toolkit, and you can generate

any of the following reports by double-clicking on the corresponding option:

« Rerun calibration. Produces a calibration report summarizing the calibration status per DQ/DQS group along
with the margins for each DQ/DQS pin.

« Driver Margining. Produces a report summarizing the read and write margins per I/O pin. This differs from
calibration margining because driver margining is captured during user mode traffic rather than during
calibration

« Generate Eye Diagram. Generates read and write eye diagrams for each DQ pin based on calibration data
patterns.

« Calibrate Termination. Sweeps different termination values and reports the margins that each termination value

provides. Use this feature to help select the optimal termination for the memory interface.

Design Example Description for External Memory Interfaces Intel Arria 10 FPGA IP

When you parameterize and generate your EMIF IP, you can specify that the system create directories for
simulation and synthesis file sets, and generate the file sets automatically. If you select Simulation or Synthesis
under Example Design Files on the Example Designs tab, the system creates a complete simulation file set or a
complete synthesis file set, in accordance with your selection.

Synthesis Example Design

The synthesis example design contains the major blocks shown in the figure below.

« A traffic generator, which is a synthesizable Avalon®-MM example driver that implements a pseudo-random
pattern of reads and writes to a parameterized number of addresses. The traffic generator also monitors the
data read from the memory to ensure it matches the written data and asserts a failure otherwise.

« An instance of the memory interface, which includes:

o A memory controller that moderates between the Avalon-MM interface and the AFI interface.
o The PHY, which serves as an interface between the memory controller and external memory devices to

perform read and write operations.

Figure 5. Synthesis Example Design



Synthesis Example Design

Avalon-MM AFl Memory
Traffic Generator |«——— Controller |€—» PHY +——>
| ; |

If you are using the Ping Pong PHY feature, the synthesis example design includes two traffic generators issuing
commands to two independent memory devices through two independent controllers and a common PHY, as
shown in the following figure.

Figure 6. Synthesis Example Design for Ping Pong PHY

Simulation Example Design

Abstract instance of the synthesis example design

Memory| Memory

Model

Traffic Generator |q—p| Controller ««——»  PHY

F Y

Status
Checker

If you are using RLDRAM 3, the traffic generator in the synthesis example design communicates directly with the
PHY using AFI, as shown in the following figure.
Figure 7. Synthesis Example Design for RLDRAM 3 Interfaces

Simulation Example Design

Abstract Instance of the Synthesis Example Design

Traffic Avalon-MM Controller 0 AFl Memt}rx Memory
Generator 0 : : Model 0
4 4 PHY | !
Traffic | . |Avalon-M »l Controller 1 ¢ . Memory | Memory
Generator 1 ; : Model 1

|

¢ v Y

Status Checker

=

Note: If one or more of the PLL Sharing Mode, DLL Sharing Mode, or OCT Sharing Mode parameters are set to



any value other than No Sharing, the synthesis example design will contain two traffic generator/memory interface
instances. The two traffic generator/memory interface instances are related only by shared PLL/DLL/OCT
connections as defined by the parameter settings. The traffic generator/memory interface instances demonstrate
how you can make such connections in your own designs.

Note: Third-party synthesis flow as described in Intel Quartus Prime Standard Edition User Guide: Third-party
Synthesis is not a supported flow for EMIF IP.

Related Information

Generating the Synthesizable EMIF Design Example on page 7

Simulation Example Design

The simulation example design contains the major blocks shown in the following figure.

« An instance of the synthesis example design. As described in the previous section, the synthesis example
design contains a traffic generator and an instance of the memory interface. These blocks default to abstract
simulation models where appropriate for rapid simulation.

« A memory model, which acts as a generic model that adheres to the memory protocol specifications.
Frequently, memory vendors provide simulation models for their specific memory components that you can
download from their websites.

« A status checker, which monitors the status signals from the external memory interface IP and the traffic

generator, to signal an overall pass or fail condition.

Figure 8. Simulation Example Design

Simulation Example Design

Abstract instance of the synthesis example design

Memory

»/ Memory

Traffic Generator |q—p| Controller ««——»  PHY Model
ode

F Y

Status
Checker

If you are using the Ping Pong PHY feature, the simulation example design includes two traffic generators issuing
commands to two independent memory devices through two independent controllers and a common PHY, as
shown in the following figure.

Figure 9. Simulation Example Design for Ping Pong PHY
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If you are using RLDRAM 3, the traffic generator in the simulation example design communicates directly with the
PHY using AFI, as shown in the following figure.

Figure 10. Simulation Example Design for RLDRAM 3 Interfaces
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Related Information
Generating the EMIF Design Example for Simulation on page 10

Example Designs Interface Tab

The parameter editor includes an Example Designs tab which allows you to parameterize and generate your
example designs.|

Figure 11. Example Designs Tab in the External Memory Interfaces Parameter Editor
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Available Example Desighs Section
The Select design pulldown allows you to select the desired example design. At present, EMIF Example Design is
the only available choice, and is selected by default.
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