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The iQ-Luminance software calculates luminance values from the image data taken with a calibrated camera. The
obligatory camera calibration provides how the camera’s raw RGB data are mapped to the Luminance considering
various exposure settings. Rectangular, elliptical, circular, or polygonal Regions of Interest (ROI) can be drawn on
the image to evaluate the selected area. The corresponding Luminance is displayed as a grayscale or false-color
image.

PRECONDITIONS

Camera Calibration
The obligatory camera calibration provides the knowledge of how the camera’s raw RGB data are mapped to the
Luminance considering various exposure settings. This camera- and lens-specific calibration is performed in our
test lab.

Attention!
You must send Image Engineering your camera for calibration before you use the software. Without a pre-
calibration from IE, you will not be able to use the software.

The camera calibration requires two measurements:

Opto-electronic conversion function (OECF)

Spectral response (SR)

Optional: Shading correction

System Requirements
Operating system → Windows 7 64bit (or newer)

GETTING STARTED WITH THE USER INTERFACE

You will need to input the license key when starting the software for the first time. The key can be found on the
USB stick that will be sent to you upon purchase of the software. Without the license key, you can only access the
demo version. Only the example images provided by IE are compatible with the demo version (images are
available for download on our website).
The iQ-Luminance software is divided into three operation areas:



1. Control area

Manage images for measurement in a file list

2. Menu Bar

→ Open/close image files

View → Switch between three different image views/export and import ROIs

→ ROI management

Report→ Edit report or Export report

Scale → Switch between logarithmic or linear scale/reset scale

View and Report are visible if an image is loaded.

Scale is visible when an image is loaded, and a luminance view is active.

3. Image

Displays the current image

Displays a color-coded luminance image with a color bar

ROIs can be drawn directly on the image

4. Image Toolbox

Contains measurement (Rectangle ROI, Ellipse ROI, Line, Polygon ROI) and display tools (zoom in / out)

5. Results Area

Displays and manages measurements of selected areas

Image area and Results area are visible if an image is loaded.

Control Area
Manage Images
The iQ-Luminance software only supports the usage of RAW image files, and the calibration data provided by IE
are based on RAW images.

Add image files to a list

Remove selected image files from the list

Clear list

Show or hide additional meta-information of the image

Load Calibration Data 



The camera and lens-specific calibration is performed in our test lab.
The software is delivered with calibration text files that can then be loaded in the calibration data screen: File →
Calibration Data

1. Add (+) or remove (-) a set of calibration data (e.g., for one camera lens combination). You can rename the set

of files once loaded (double click the file name)

Select a set of calibration data by clicking on the specific entry.



The currently active set displayed on the right side and used by the software is highlighted with a blue

background color.

2. Spectral response (SR)

Import or remove (-) the spectral response calibration file

3. Opto-electronic conversion function (OECF)

Load or remove one or more OECF calibration files

4. Shading data (optional) – image 3

Load one or more shading correction calibration files

If you select more than one OECF or shading calibration file, the software will choose the suited calibration files
based on the exposure of the loaded image (ISO, f-stop, f [mm]). The software will ensure that the ISO and f-stop
for both the calibration and image files match.
Your calibration data will be saved and available after loading the calibration files.
Once saved, the calibration data is also accessible from the calibration menu on the left side (image 4).

Selecting Vλ 
For more information on vλ 2006, please follow the link below: Official publication:

https://cie.co.at/publications/fundamental-chromaticity-diagram-physiological-axes-part-1 Additional text
files for the v(symbol) curve 2006 (files already implanted into the iQ-Luminance software):
http://cvrl.ioo.ucl.ac.uk/ciepr.htm 

https://cie.co.at/publications/fundamental-chromaticity-diagram-physiological-axes-part-1
http://cvrl.ioo.ucl.ac.uk/ciepr.htm


Image Management
After loading and selecting an image, it is displayed in the image area.
The toolbox will then appear above the image and the result area to the right beside the image.

The toolbox contains tools to select ROIs for the measurement and some options for displaying the image.

Zoom In and Out 

Zoom in: You can zoom to a specific area by clicking and dragging a rectangle over the desired location.

Zoom out: Displays the entire image.

Select an ROI 
iQ-Luminance offers four different shapes when selecting a region of interest:

Rectangular ROI

Elliptical ROI

Arbitrary line

After choosing one of the above tools, the ROI is created by clicking and dragging the desired shape over the
image.



Polygonal ROI 
The polygon is created by clicking into the image. Each click sets a point of the polygon. You can select a
minimum of three points.

After setting the points, you must confirm the shape. You can create multiple shapes on the image.

Click to cancel a shape that has not been confirmed or to go back to the main menu bar.

Multiple ROIs may be created, which are managed in the result area. The ROIs can be moved and re-shaped
afterward. To remove a shape that has been confirmed, right-click the shape and delete ROI.
Please note: While you are in Polygon mode, most of the GUI will be disabled until you confirm or cancel the
polygon creation.

ROI Management
Control and move multiple ROIs at one time by holding down the Ctrl key and selecting the ROIs you would like to
control.
You can delete an ROI by right-clicking and selecting delete.
Selected ROIs can be resized by typing new values into fields Width and Height.
Selected ROIs can be copied and pasted into the same or into other images (image 4).

You can save, export, and import ROIs in the View dropdown menu.

Save and Load Projects
You can save your project and load it again at any time. The image and the ROIs will be saved as well. File →
Save Project

Change the Display Mode
The iQ-Luminance software offers three different display modes found in the menu bar:
View → Original RGB
View → Luminance (B/W)
View → Luminance (Color)
Luminance (Black/White) and Luminance (color) means that the measured luminance values in the image are
displayed using grayscale (image 5) or false colors (image 6) with corresponding luminance values in candela per
square meter.
A color bar on the left side of the image indicates the correlation between color or gray values in the image and
luminance values.



Scaling the Luminance Value Range 
It is possible to change the correlation between color and luminance values.
The denotation of false colors / grayscale values:
Red (false color) / white (grayscale) means a high luminance value.
Blue (false color) / black (grayscale) means a low luminance value.
When loading an image, the maximum and minimum luminance values are calculated and used as limits for this
scaling.
The scaling can be changed by entering new values in the fields for the minimum and maximum values.



You can apply the scaling of the current image to all opened images in the menu bar:

Scale → Apply Range to all Open Images

Scale → Reset Range resets the limits of the current image to maximum and minimum luminance values of the

image.

Logarithmic Scaling
You can switch to logarithmic scaling in the menu bar: Scale → Logarithmic Scale

Result Area
Every ROI created in the image appears in the results list along with the measured luminance value.



The currently selected ROI is highlighted in both the image and the result list. Toggling the selection in the list
activates the corresponding ROI in the image.

Profile Plot
The line selection is used to evaluate a luminance distribution along a line with variable width. The luminance
values along this line are be plotted in a chart:

RESULT EXPORT

You can export the results as an XML file.
You can add your logo, title, editor, and date to the PDF Export. You can open the relevant dialog in the menu bar:
Report → Configure



Report Generation (PDF)
Fill out the correct information.
The “Show ROI” checkboxes imply that you can show the ROIs either on the false-color image or the report
image.

TRADEMARK AND COPYRIGHT

Trademarks
Microsoft® and Windows® are either registered trademarks or trademarks of Microsoft Corporation in the United
States and/or other countries.

Software by Third Parties
Armadillo

Armadillo C++ Linear Algebra Library is licensed under the Apache License 2.0 Copyright 2008-2020 Conrad

Sanderson

Copyright 2008-2016 National ICT Australia (NICTA)

Copyright 2017-2020 Arroyo Consortium

Copyright 2017-2020 Data61, CSIRO

This product includes software developed by Conrad Sanderson

This product includes software developed at National ICT Australia (NICTA) This product includes software

developed at Arroyo Consortium

This product includes software developed at Data61, CSIRO



dcraw 
Copyright © 1997-2015 by Dave Coffin
This is free software. Web site of the author: http://www.dechifro.org/index.html
The documentation can be found here: http://www.dechifro.org/dcraw/dcraw.1.html
(www.cybercom.net/~dcoffin/dcraw/)

OpenCV – Open Source Computer Vision Library 
License Agreement For Open Source Computer Vision Library (3-clause BSD License)

Copyright (C) 2000-2020, Intel Corporation, all rights reserved.

Copyright (C) 2009-2011, Willow Garage Inc., all rights reserved.

Copyright (C) 2009-2016, NVIDIA Corporation, all rights reserved.

Copyright (C) 2010-2013, Advanced Micro Devices, Inc., all rights reserved.

Copyright (C) 2015-2016, OpenCV Foundation, all rights reserved.

Copyright (C) 2015-2016, Itseez Inc., all rights reserved.

Copyright (C) 2019-2020, Xperience AI, all rights reserved.

Third party copyrights are property of their respective owners.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following

disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the

following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the names of the copyright holders nor the names of the contributors may be used to endorse or

promote products derived from this software without specific prior written permission.

This software is provided by the copyright holders and contributors “as is” and any express or implied warranties,
including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are
disclaimed. In no event shall copyright holders or contributors be liable for any direct, indirect, incidental, special,
exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services;
loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in
contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software,
even if advised of the possibility of such damage. (www.opencv.org)

Libtiff

Copyright (c) 1988-1997 Sam Leffler

Copyright (c) 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby
granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of
the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used
in any advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler
and Silicon Graphics.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR
OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS

http://www.dechifro.org/index.html
ttp://www.dechifro.org/dcraw/dcraw.1.html
http://www.cybercom.net/~dcoffin/dcraw/
http://www.opencv.org


FOR A PARTICULAR PURPOSE.
IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR

ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED OF
THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Qt 
The Qt framework is licensed under the commercial Qt license.

Qwt 
The Qwt library contains GUI Components and utility classes which are primarily useful for programs with a
technical background. Beside a framework for 2D plots it provides scales, sliders, dials, compasses,
thermometers, wheels and knobs to control or display values, arrays, or ranges of type double.
Qwt is distributed under the terms of the Qwt License, Version 1.0.

Copyright Information 

By installing this software, you accept and agree to be bound by the terms of the software license agreement that
appears below.
Copyright © Image Engineering GmbH & Co. KG, 2022
The software furnished under this agreement is provided on an “as is” basis, without any warranties or
representations express or implied, including, but not limited to, any implied warranties of merchantability or
fitness for a particular purpose. It is solely the responsibility of the consumer to determine the software’s suitability
for a specific purpose or use. Image Engineering GmbH & Co. KG, and anyone else who has been involved in the
creation, production, delivery, or support of this software, will in no event be liable for direct, indirect, special,
consequential, or incidental damages resulting from any defect, error, or omission in the diskette or software or
any other events, including, but not limited to, any interruption of service, loss of profits or goodwill, legal action or
any other consequential damages. The user assumes all responsibility arising from using this software, for which
Image Engineering GmbH & Co. KG shall have no liability, regardless of whether such use is lawful or
foreseeable. Image Engineering GmbH & Co. KG shall have no liability for any data or programs stored by or used
with this software, including the costs of recovering such data or programs. Image Engineering GmbH & Co. KG
reserves the right to make corrections or improvements to the information provided and to the related software at
any time, without notice.
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