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Preface

As part of an improvement effort, revisions of the software and hardware are periodically released. Some functions
that are described in this document are not supported by all versions of the software or hardware currently in use.
The product release notes provide the most up-to-date information about product features. Contact your service
provider if a product does not function properly or does not function as described in this document.

 NOTE: PowerStore X model customers: For the latest how-to technical manuals and guides for your model,
download the PowerStore 3.2.x Documentation Set from the PowerStore Documentation page at
dell.com/powerstoredocs.

Where to get help
Support, product, and licensing information can be obtained as follows:

Product information—For product and feature documentation or release notes, go to the PowerStore

Documentation page at dell.com/powerstoredocs.

Troubleshooting—For information about products, software updates, licensing, and service, go to Dell Support

and locate the appropriate product support page.

Technical support—For technical support and service requests, go to Dell Support and locate the Service

Requests page. To open a service request, you must have a valid support agreement. Contact your Sales

Representative for details about obtaining a valid support agreement or to answer any questions about your

account.

Monitoring Your System Overview

This chapter includes:
Topics:

Overview

Overview
This document describes the functionality available in the PowerStore Manager to monitor, and optimize various
PowerStore appliances.

Monitoring features
PowerStore Manager provides the following features and functionality to monitor your system:

Events to notify when there are changes in the system.

Alerts to inform you that an event occurred that requires your attention.

Capacity charts display current capacity usage of a PowerStore cluster and resources.

Performance charts indicate the system health so you can anticipate problems before they occur.

Optimizing features and functionality
As you monitor the system, alert notifications provide a mechanism to respond to the issue and reduce
troubleshooting times.
Understanding how the system capacity is being used can:

http://dell.com/powerstoredocs


Alert you to the resources that are the top consumers of storage space.

Help you to balance the load across your available storage.

Indicate when you may need to add more storage to your cluster.

Finally, should an event occur that requires further troubleshooting, PowerStore has a mechanism for collecting
support materials which helps analyze and resolve the issue.

Managing Alerts

This chapter includes:
Topics:

Events and alerts

Monitor alerts

CloudIQ Health Score

Configure email notification preferences

Temporarily disable support notifications

Configure SNMP

Critical Information Banner

System Checks

Remote logging

Events and alerts
Events provide information about changes to the system. Alerts are events that require attention and most alerts
indicate that there is a problem with the system. Clicking the description of an alert reveals additional information
about the alert.
Active and unacknowledged alerts are displayed in the Alerts card on the dashboard and the Alerts page under
Monitoring.
You can view and monitor alerts for individual objects in a cluster such as an appliance, storage resource, or virtual
machine, from the Alerts card on the details page of the object.
To review events that do not rise to the level of an alert, go to Monitoring > Events.
When you view events and alerts, you can sort the alerts by the columns and filter the alerts by the column
categories. The default filters for alerts are:

Severity—Event and alerts can be filtered by the severity of the event or alert. You can select the severities to

display by clicking the Severity filter and selecting one or more severities from the dialog box.

○ Critical—An event has occurred that has a significant impact on the system and must be remedied

immediately. For example, a component is missing or has failed and recovery may not be possible.

○ Major—An event has occurred that may have an impact on the system and should be remedied as soon as

possible. For example, the last synchronization time for a resource does not match the time that its protection

policy indicates.

○ Minor—An event has occurred that you should be aware of but does not have a significant impact on the

system. For example, a component is working, but its performance may not be optimum.

○ Info—An event has occurred that does not impact system functions. No action is required. For example, new

software is available for download.

Resource Type—Events and alerts can be filtered by the resource type that is associated with the event or

alert. You can select the resource types to display by clicking the Resource Type filter and selecting one or



more resource types from the dialog box.

Acknowledged—Alerts can be filtered by whether the alert is acknowledged or not. When a user acknowledges

an alert, the alert is hidden from the default view on the Alerts page. You can view acknowledged alerts by

clicking the Acknowledged filter and selecting the Acknowledged check box in the filter dialog box.

 NOTE: Acknowledging an alert does not indicate that the issue is resolved. Acknowledging an alert only

indicates that the alert has been acknowledged by a user.

Cleared—Alerts can be filtered by whether the alert is cleared or not. When an alert is no longer relevant or is

resolved, the system clears the alert with no user intervention. Cleared alerts are hidden from the default view

on the Alerts page. You can view a cleared alert by clicking the Cleared filter and selecting the Cleared check

box in the filter dialog box.

Monitor alerts
PowerStore Manager provides alert views at multiple levels, from the overall cluster to individual objects.
About this task
The alerts page is automatically refreshed every 30 seconds.

Steps

1. Find the alert view that you are interested in.

● To view alerts at the cluster level, click View All Alerts in the Alerts card on the dashboard or select Monitoring

> Alerts.

● To view alerts for an individual object, such as a volume, view the object and select the Alerts card.

2.  From the Alerts page or Alerts card, you can:

● Show or hide acknowledged and cleared alerts.

● Filter the alert list by category.

● Choose the columns to be displayed in the table.

● Export the alerts to a . c s v or . x l s x file.

● Refresh the table.

3.  Click the description of an alert to see more information, including its impact on the system, timeline, suggested

remediation, and other associated events.

 NOTE: The Associated Events table can display only ten events. To view the full list of events associated

with a resource, go to the Monitoring > Events and filter the displayed events by the resource name.

4. To acknowledge an alert, select the alert check box and click Acknowledge. When you acknowledge an alert,

the system removes the alert from the alert list, unless acknowledged alerts are displayed in the alert list.

CloudIQ Health Score
Displaying the CloudIQ Health Score provides a high-level overview of the cluster health and enables you to
quickly identify existing issues.

 NOTE: Support Connectivity must be enabled on the cluster to send data to CloudIQ.

 NOTE: The PowerStore Manager displays the CloudIQ Health Score card on the Dashboard screen. The
health score card provides an overview of the system health status by displaying an overall health score and
health status of five attributes (components, configuration, capacity, performance, and data protection). For each
attribute, the health score card displays the number of existing issues. You can hover over the attribute and select
View Related Alert Details to view the details of the related alerts.
PowerStore automatically uploads an updated health score every five minutes.



To enable the CloudIQ Health Score card, select Settings > Support > Support Connectivity, then select the
Connection Type tab and select Enable. If the Connect to CloudIQ checkbox is not enabled, select to enable it.
The CloudIQ Health Score card is enabled only for systems that are connected to Secure Remote Services and
have CloudIQ connectivity:

When CloudIQ is not enabled, the Dashboard does not display the Health Score card.

When CloudIQ is enabled, the connection is active, and data is available the Health Score card is displayed

and indicates the updated health score.

If connection to Secure Remote Services is disrupted, the Health Score card is disabled and indicates a

connection error.

Configure email notification preferences
You can configure your system to send alert notifications to email subscribers.
About this task
For more information about SMTP server settings, see the context-sensitive help entry for this feature in
PowerStore Manager.

Steps

1. Select the Settings icon, and then select SMTP Server in the Networking section.

2.  If the SMTP Server feature if disabled, click the toggle button to enable the feature.

3.  Add address of the SMTP server in the Server Address field.

4.  Add the email address from which alert notifications are sent in the From Email Address field.

5. Click Apply.

(Optional) Send a test email to verify that the SMTP server is set up correctly.

6. Click Add/remove email subscribers under Email Notifications.

7. To add an email subscriber, click Add and type the email address to which you want to send alert notifications in

the Email Address field.

When you add an email subscriber, you can select the severity level of the alert notifications that are sent to the

email address.

(Optional) To verify that the email address can receive alert notifications, select the check box for the email

address, and click Send Test Email.

Temporarily disable support notifications
Disable support notifications to prevent call home alerts from being sent to Support when performing actions such
as unplugging cables, swapping out drives, or upgrading software.

Steps

1. On the Settings page, select Disable Support Notifications in the Support section.

2.  Select the appliance on which to temporarily disable notifications and click Modify.

3.  In the Modify Maintenance Mode slide-out panel, select the Enable Maintenance Mode check box, and specify

the number of hours to disable notifications in the Maintenance Window Duration field.

 NOTE: Support notifications are automatically re-enabled after the maintenance window ends.

4. Click Apply.

The time that the maintenance window ends is displayed in the table.



Configure SNMP
About this task
You can configure your system to send alert information to up to 10 designated SNMP Managers (trap
destinations).

 NOTE: Only notifications are supported.
The authoritative Local Engine ID used for SNMPv3 messages is given as a hexadecimal string. It is discovered
and added automatically.

 NOTE: To verify the Local Engine ID select Settings, and under Networking, select SNMP. The Local Engine
ID appears under Details.
Using PowerStore Manager, do the following:

Steps

1. Select Settings and, under Networking, select SNMP.

The SNMP card appears.

2.  To add an SNMP Manager, click Add under SNMP Managers.

The Add SNMP Manager slide out appears.

3.  Depending on the version of SNMP, configure the following information for the SNMP Manager:

● For SNMPv2c:

○ Network Name or IP address

○ Port

○ Minimal Severity Level of Alerts

○ Version

○ Trap Community String

● For SNMPv3

○ Network Name or IP address

○ Port

○ Minimal Severity Level of Alerts

○ Version

○ Security Level

 NOTE: Depending on the security level selected, additional fields appear.

� For the level None, only Username appears.

� For the level Authentication only, Password and Authentication Protocol appear along with Username.

� For the level Authentication and privacy, Password, Authentication Protocol, and Privacy Protocol appear

along with Username.

○ Username

 NOTE: When the Security Level of None is selected, the username must be NULL. When a Security Level

of Authentication only or Authentication and privacy is selected, the username is the Security Name of the

SNMPv3 user sending the message. The SNMP username can contain up to 32 characters in length and

include any combination of alphanumeric characters (uppercase letters, lowercase letters, and numbers).

○ Password

 NOTE: When a Security Level of either Authentication only or Authentication and privacy is selected, the

system determines the password.



○ Authentication Protocol

 NOTE: When a Security Level of either Authentication only or Authentication and privacy is selected,

select either MD5 or SHA256.

○ Privacy Protocol

 NOTE: When a Security Level of Authentication and privacy is selected, select either AES256 or TDES.

4. Click Add.

5. (Optional) To verify whether SNMP Manager destinations can be reached and the correct information is

received, click Sent Test SNMP Trap.

Critical Information Banner
A banner displays critical information for system users.
The information banner, which is displayed at the top of PowerStore Manager, displays information about global
alerts to all users logged into the system.
When only a single global alert is issued, the banner displays the alert’s description. When there are multiple
alerts, the banner indicates the number of active global alerts.
The color of the banner matches the alert with the highest severity level as follows:

Information alerts – blue (information) banner

Minor/Major alerts – yellow (warning) banner

Critical alerts – Red (error) banner

The banner disappears when the alerts are cleared by the system.
System Checks
The System Checks page enables you to initiate health checks on the overall system, independent of the system-
issued alerts.
About this task
You can launch a system check before actions such as upgrade or enabling Support Connectivity. Performing a
system check enables intercepting and resolving any issues before upgrading the system or enabling Support
Connectivity.

 NOTE: With PowerStore operating system version 4.x or later, the System Checks page displays the system
check profile above the System Checks table. The displayed profile is of the last system check that was run, and
the displayed results are based on the respective profile. Selecting Run System Check only triggers the Service
Engagement profile.
However, other profiles can be triggered by other operations or actions within PowerStore Manager. For example,
when you enable Support Connectivity from the Settings page or through the Initial Configuration Wizard (ICW),
the System Check page shows the results of the system check for Support Connectivity and Support Connectivity
appears as the Profile.
The System Check table displays the following information:
Table 1. System check information



Name Description

Item The health check item.

Description The description of the health check result.

Status The health check result (Passed or failed).

Category The health check category (Configured Resource, Hardware, or Software Services).

Appliance The appliance for which the health check item was performed.

Node The node for which the health check item was performed.

You can add and remove filters to narrow the displayed results according to your needs.
Steps

1. Under Monitoring, select the System Checks tab.

2. Click Run System Check.

Results
The system check results are listed in the table. Clicking a failed item reveals additional information about the
check results.
Also, the Profile and Last Run information are updated.

Remote logging
The storage system supports sending audit log messages and system alert-related events to a maximum of two
hosts. The hosts must be accessible from the storage system. Audit log message transfers can use a one-way
authentication (Server CA Certificates) or an optional two-way authentication (Mutual Authentication Certificate).
An imported certificate applies to each remote syslog server that is configured to use TLS Encryption.
To review or update remote logging settings, log in to PowerStore and click Settings. In the Settings side bar,
under Security, select Remote Logging.
For more information about remote logging, see PowerStore Security Configuration Guide on the PowerStore
Documentation page.

Monitoring Capacity

This chapter includes:
Topics:

About monitoring system capacity

Capacity data collection and retention periods

Capacity forecasting and recommendations

Capacity data locations in PowerStore Manager

Start monitoring capacity usage

Data Savings features

About monitoring system capacity
PowerStore provides various current usage, and historical metrics. The metrics can help you monitor the amount
of space that your system resources use, and determine your future storage needs.
Capacity data can be viewed from the PowerStore CLI, REST API, and PowerStore Manager. This document
describes how to view this information from PowerStore Manager. See the PowerStore Online Help for specific
capacity metric definitions and  calculations.



Monitoring current usage capacity
You can use the PowerStore Manager, REST API, or CLI to monitor the current capacity usage for a cluster, and
for individual storage resources such as storage containers, volumes, file systems, and appliances.

 NOTE: Monitoring capacity metrics is enabled when an appliance is in Out Of Space (OOS) mode. This
enables you to monitor the amount of space that is freed as a result of deleting unused snapshots and storage
resources.
Monitoring historical usage and forecasting
PowerStore capacity trending and predictive metrics are also collected for forecasting future storage needs of a
cluster or appliance. Also, the trending and predictive metrics can be shared with the Dell Technologies Support
Center when PowerStore is configured with Dell SupportAssist. These metrics provide intelligent insight on how
capacity is being used and help to predict future capacity needs.
Capacity data collection and retention periods
Collection of capacity metrics is always enabled.
Current capacity data collection and retention periods
Capacity data for system resources is collected at 5 minute intervals and rolled up to 1 hour and 1-day aggregates.
The capacity charts refresh interval is set according to the selected granularity level as follows:
Table 2. Capacity charts refresh intervals 

Granularity Level Refresh Interval

Last 24 hours 5 minutes

Last month 1 hour

Last 2 years 1 day

The following table displays the retention periods for each timescale and the resources to which they apply:
Table 3. Real-time capacity data retention periods 

Timescale Retention period Resources

5 minutes 1 day Cluster, appliances, volume groups, volumes, vVols, and virtu
al machines

1 hour 30 days Cluster, appliances, volume groups, volumes, vVols, and virtu
al machines

1 day 2 years Cluster, appliances, volume groups, volumes, vVols, and virtu
al machines

Historical capacity data collection and retention periods
Historical capacity is displayed once data collection begins. One year of capacity usage data is displayed in the
charts, and the data is retained for up to 2 years. Historical charts scroll automatically to the left when new data is
available.

Capacity forecasting and recommendations
PowerStore uses historical capacity metrics to forecast when your appliance or cluster may run out of storage
space, and to provide recommendations on how to free up the system resources.
Capacity forecasting
There are three threshold levels that are used to forecast system capacity alerts. Thresholds are set by default and
cannot be changed.
Table 4. Capacity alert thresholds 



Priority Threshold

Major 1–4 days until the appliance or cluster is full.

Minor 15–28 days until the appliance or cluster is full.

Okay 4+ weeks until the appliance or cluster is full.

Alerts appear in the appliance or cluster charts, and also in the Notifications > Alerts page.
Forecasting starts after 15 days of data collection for the cluster or appliance. Before 15 days of data collection, an
“Insufficient data to predict time to full” message appears in the Physical Capacity area next to the chart.
Forecasting includes data for up to one year, with a two-year retention period.
You can look at the capacity chart to get a graphic visualization of the capacity forecast for the cluster. To open the
capacity chart, go to the Dashboard window and select the Capacity tab.

1. Selecting the Forcast option, displays the mean predicted physical usage (for the next seven days).

2.  Selecting the Forcast Range option, displays the range of low-to-high predicted physical usage (for the next

seven days).

3. Hovering over the forecast section of the capacity chart, displays the values for mean-predicted usage and

range of predicted usage.

Capacity recommendations
PowerStore also provides a recommended repair flow. The repair flow provides options to free up space on the
cluster or appliance. The Repair Flow options are provided in the Alerts panel and include the following:
Table 5. Capacity recommendations 



Option Description

Assisted Migration

Provides recommendations of volumes, or volume groups to migrate from one applianc
e to another.
Migration recommendations are generated based on factors such as appliance capacity
, and health. You can also choose to manually migrate volumes, or volume groups, bas
ed on your own calculations, when your cluster or appliance is approaching capacity.
Migration is not supported for file systems.
Migration is supported within a single cluster with multiple appliances.
Migration recommendations are provided in the PowerStore Manager after a Major thre
shold is met.
However, you can use the PowerStore REST API to review migration recommendations
at any time.

Clean Up System Delete system resources that are no longer being used.

Add More
Devices Purchase additional storage for your appliance.

Recommendations expire in 24 hours to ensure that the recommendation is always current.
Capacity data locations in PowerStore Manager
You can view capacity charts for PowerStore systems, and system resources from the PowerStore Manager
Capacity cards and views in the following locations:
Table 6. Capacity data locations 

For Access path

Cluster Dashboard > Capacity

Appliance Hardware > [appliance] opens the Capacity card.

Virtual Machine Compute > Virtual Machines > [virtual machine] opens the Capacity card.

Virtual Volume (vVol) Compute > Virtual Machines > [virtual machine] > Virtual Volumes > [virtual volume] ope
ns the Capacity card.

Table 6. Capacity data locations (continued)



For Access path

Volume Storage > Volumes > [volume] opens the Capacity card.

Volume Family Storage > Volumes. Select the checkbox next to the volume and select More Actions >
View Topology. In the Topology view, select Capacity. A

Storage Container Storage > Storage Containers > [storage container] opens the Capacity card.

Volume Group Storage > Volume Groups > [volume group] opens the Capacity card.

Volume Group Family
Storage > Volume Groups. Select the checkbox next to the volume group and select Mo
re
Actions > View Topology. In the Topology view, select Capacity.B

Volume Group memb
er (volume)

Storage > Volume Groups > [volume group] > Members > [member] opens the Capacity
card.

File System

Storage > File Systems > [file system] opens the Capacity card.

 NOTE: Only available with PowerStore T model and PowerStore Q model applianc
es.

NAS Server

Storage > NAS Servers > [NAS server] opens the Capacity card.

NOTE: Only available with PowerStore T model and PowerStore Q model applianc
es.

a. Family Capacity displays all the space that the base volume, snapshots, and clones use. The Family Capacity
space values may include system snapshots that are used for replication, but do not appear in the volume
topology diagram. As a result, the Family Capacity space values may not match the objects in the topology.
b. Family Capacity displays all the space that the base volume group, snapshots, and clones use. The Family
Capacity space values may include system snapshots that are used for replication, but do not appear in the
volume group topology diagram. As a result, the Family Capacity space values may not match the objects in the
topology.

Start monitoring capacity usage
You can start to evaluate your capacity usage and needs from the PowerStore Manager Dashboard > Capacity
card.
Current capacity usage
The cluster capacity dashboard presents the current amount of storage being used, and the amount of available
storage in the cluster. When there is a risk to the capacity usage of a cluster, alerts are also in the Capacity area of
the capacity dashboard.
PowerStore Manager displays all capacities in base 2 by default. To view capacity values in base 2 and base 10,
hover over the Percentage Used, Free, and Physical values (at the top of the Capacity tab). For more information,
see Dell Knowledge Base Article 000188491 PowerStore: How PowerStore physical capacity is calculated.

 NOTE: Deleting files and directories in an SDNAS file system is asynchronous. While the response to the
Delete request is received immediately, the ultimate release of storage resources takes longer to complete. The
asynchronous deletion is reflected in the file system capacity metrics. When files are deleted in the file system, the
update in capacity metrics may appear gradually.
Historical capacity usage and recommendations
You can use the historical chart to evaluate space utilization trends for the cluster, and review recommendations
for your future capacity storage requirements. You can view the historical data for the last 24 hours, month, or
year. Also, print charts for presentation, or export the data into a .CSV format for further analysis using your tool of
choice.
Top consumers
The cluster capacity dashboard also presents which of the cluster resources are the top capacity consumers in the
cluster. The Top Consumer area provides a high-level summary of the capacity statistics for each resource. Once
you have identified the top consumers, you can further analyze to the resource level to review the capacity of a



specific Volume, Volume group, Virtual Machine, or File system.
Data savings
Finally, the capacity dashboard shows you the Data Savings as a result of automated data efficiency features such
as deduplication, compression, and thin provisioning. See Data Savings features for details.

Data Savings features
Data savings metrics are based on the automated inline data services that are provided with PowerStore.
The automated inline data services occur in the system before the data is written to the storage drives. The
automated inline data services include:

Data reduction, which consists of deduplication and compression.

Thin provisioning, which enables multiple storage resources to subscribe to a common storage capacity.

The drive usage that is saved by these data services results in cost savings and consistent, predictable high
performance, regardless of workload.

Data reduction
The system achieves data reduction by using the following techniques:

Data deduplication

Data compression

There is no performance impact from the use of data deduplication or compression.

Data deduplication
Deduplication is the process of consolidating redundancies that are contained within data to reduce storage
overhead. With deduplication, only one copy of data is stored on drives. Duplicates are replaced with a reference
that points back to the original copy. Deduplication is always enabled and cannot be disabled. Deduplication
occurs before the data is written to storage drives.
Deduplication provides the following benefits:

Deduplication enables high capacity growth without requiring a drastic increase in space, power, or cooling.

Fewer writes to the drive results in Improved drive endurance.

The system reads the deduplicated data from the cache (instead of the drives) which results in Improved

performance.

Compression
Compression is the process of reducing the number of bits that are required to store and transmit data.
Compression is always enabled, and cannot be disabled. Compression occurs before data it is written to storage
drives.
Inline compression provides the following benefits:

Efficient storage of data blocks saves storage capacity.

Fewer writes to the drive improve drive endurance.

There is no performance impact from compression.

Reporting the capacity savings
The system reports the capacity savings that are gained from data reduction using the Unique Data metric. The
Unique Data metric is calculated for a volume and its associated clones and snapshots (volume family).



The system also provides the following capacity savings properties:

Overall DRR

Reducible DRR – Indicates the Data Reduction Ratio that is based only on reducible data.

Unreducible Data – The amount of data (GB) written to the storage object (or objects across an appliance or

cluster) that is considered as not applicable for deduplication or compression.

To view capacity saving metrics:

Clusters – Select Dashboard > Capacity and hover over the Data Reduction section of the Data Savings chart.

Appliances – Select Hardware > Appliances > [appliance] > Capacity and hover over the Data Reduction

section of the Data Savings chart or see the Appliances table.

Volumes and volume groups – These properties are displayed in the respective tables and in the volume family

capacity view (as Family Overall DRR, Family Reducible DRR, and Family Unreducible Data).

VMs and storage containers – See the respective tables.

 File systems – Capacity saving data is displayed in the File System Family Unique Data column on the File

Systems table.

 NOTE: The columns displaying capacity savings are not visible by default. To view these columns select

Show/Hide Table Columns and check the relevant columns.

Thin provisioning
Storage provisioning is the process of allocating available drive capacity to meet the capacity, performance, and
availability requirements of hosts and applications. In PowerStore, volumes and file systems are thin provisioned
to optimize the use of available storage.
Thin provisioning works as follows:

When you create a volume or file system, the system allocates an initial quantity of storage to the storage

resource. This provisioned size represents the maximum capacity to which the storage resource can grow

without being increased. The system reserves only a portion of the requested size, called the initial allocation.

The requested size of the storage resource is called the subscribed quantity.

The system will only allocate physical space when data is written. A storage resource appears full when data

written to the storage resource reaches the provisioned size of the storage resource. Since provisioned space

is not physically allocated multiple storage resources could subscribe to the common storage capacity.

Thin provisioning allows multiple storage resources to subscribe to a common storage capacity. Therefore, it
allows organizations to purchase less storage capacity up front, and increase available drive capacity on an on-
demand basis, according to actual storage usage. While the system allocates only a portion of the physical
capacity requested by each storage resource, it leaves the remaining storage available for other storage resources
to use.
The system reports the capacity savings gained from thin provisioning using the Thin Savings metric, which is
calculated for volume families and file systems. A volume family consists of a volume and its associated thin
clones and snapshots. Thin provisioning is always enabled.

Monitoring Performance

This chapter includes:
Topics:

About monitoring system performance



Performance metrics collection and retention periods

Performance data locations in PowerStore Manager

Monitoring user virtual machines performance

Comparing object performance

Performance policies

Working with performance charts

Generating performance metrics archives

About monitoring system performance
PowerStore provides you with various metrics that can help you monitor the health of your system, anticipate
problems before they occur, and reduce troubleshooting times.
You can use the PowerStore Manager, REST API, or CLI to monitor the performance of a cluster, and for
individual storage resources such as volumes, file systems, volume groups, appliances, and ports.
You can print performance charts and download metrics data as a PNG, PDF, JPG, or .csv file for further analysis.
For example, you can graph downloaded CSV data using Microsoft Excel, and then view the data from an offline
location or pass the data through a script.

Performance metrics collection and retention periods
Collection of performance metrics is always enabled in PowerStore.
All system performance metrics are collected every five seconds except for volumes, virtual volumes, and file
systems, for which performance metrics are collected by default every 20 seconds.
All storage resources that are configured to collect performance metrics every five seconds are listed in the Metric
Collection Configuration window (Settings > Support > Metric Collection Configuration.
You can change the granularity of performance data collection for volumes, virtual volumes, and file system:

1. Select the relevant storage resource (or resources).

2. Select More Actions > Change Metric Granularity.

3.  From the Change Metric Collection Granularity slide-out panel, select the granularity level.

4.  Click Apply.

The collected data is retained as follows:

Five seconds data is retained for one hour.

 20 seconds data is retained for one hour.

Five minute data is retained for one day.

One hour data is retained for 30 days.

One day data is retained for Two years.

The performance charts refresh interval is set according to the selected Timeline as follows:

Table 7. Performance charts refresh intervals 



Timeline Refresh Interval

Last hour Five minutes

Last 24 hours Five minutes

Last month One hour

Last two years One day

Performance data locations in PowerStore Manager
You can view performance charts for PowerStore systems, and system resources from the PowerStore Manager
Performance card, views, and details as follows:
Performance data is available from the PowerStore CLI, REST API, and PowerStore Manager user interface. This
document describes how to access performance data and charts from PowerStore Manager.
See the PowerStore Online Help for specific performance metric definitions and calculations.
Table 8. Performance data locations 

For Access path

Cluster Dashboard > Performance

Virtual Machine
● Compute > Virtual Machine > [virtual machine] opens with the Compute
Performance card that is displayed for the virtual machine.
● Compute > Virtual Machine > [virtual machine] > Storage Performance

Virtual Volume (vVol) Storage > Virtual Volumes > [virtual volume] > Performance

Volume Storage > Volumes > [volume] > Performance

Volume Group Storage > Volume Groups > [volume group] > Performance

Volume Group memb
er
(volume)

Storage > Volume Groups > [volume group] > Members > [member] > Performance

File System

Storage > File Systems > [file system] > Performance

 NOTE: This option is only available with PowerStore T model and PowerStore Q 
model appliances.

NAS Server Storage > NAS Servers > [NAS server] > Performance

Host Compute > Host Information > Hosts &Hosts Groups > [host] > Performance

Host Group Compute > Host Information > Hosts &Hosts Groups > [host group] > Performance

Initiator Compute > Host Information > Initiators > [initiator] > Performance

Appliance Hardware > [appliance] > Performance

Node Hardware > [appliance] > Performance

Ports
● Hardware > [appliance] > Ports > [port] > IO Performance
● Hardware > [appliance] > Ports > [port] > Network Performance opens the
Network Performance card that is displayed for the port.

Monitoring user virtual machines performance
Use PowerStore Manager to monitor CPU and memory usage of all user-configured VMs or per VM.
You can monitor the percentage of CPU and memory usage of user VMs in PowerStore Manager and use this



information to improve resource management.
Select Hardware > [appliance] and select AppsON CPU Utilization from the Category menu to view historical CPU
utilization of user VMs per appliance. To view CPU utilization of user VMs per node, use the Show/Hide menu.
Select Hardware > [appliance] and select AppsON Mem Utilization from the Category menu to view historical
memory utilization of user VMs per appliance. To view CPU utilization of user VMs per node, use the Show/Hide
menu.
You can view the CPU and memory usage per virtual machine in the Virtual Machines list (Compute > Virtual
Machines).

 NOTE: If you cannot see the CPU Usage (%) and Memory Usage (%) columns, add them using the
Show/Hide Table Columns.

Comparing object performance
Use the PowerStore Manager to compare performance metrics of objects of the same type.
You can compare performance metrics to help troubleshoot system performance-related issues.
You can select two or more objects from the respective lists of the following objects:

volumes

 volume groups

 file systems

 hosts

 host groups

 virtual volumes

 virtual machines

appliances

ports

Selecting More Actions > Compare Performance Metrics displays the performance charts of the selected objects.
See Working with performance charts for details on how to use the different menus of the performance charts to
display the relevant data.
Comparing object performance can help in identifying potential misconfiguration or resource allocation issues.

Performance policies
You can choose to change the performance policy set on a volume, or a virtual volume (vVol).
The performance policies are provided with PowerStore. You cannot create or customize performance policies.
By default, volumes and vVols are created with a medium performance policy. The performance policies are
relative to the performance of the volumes. For example, if you set a High-performance policy on a volume, the
usage of the volume will take priority over volumes set with a medium, or low policy.
You can change the performance policy from medium to low or high, when a volume is created or after the volume
has been created.
Members of a volume group can be assigned different performance policies. You can set the same performance
policy for multiple volumes in a volume group simultaneously.
Change performance policy set for a volume
About this task
You can change the performance policy set for a volume.

Steps

1. Select Storage > Volumes.

2. Check the checkbox next to the volume and select More Actions > Change Performance Policy.

3. In the Change Performance Policy slide-out, select the performance policy.

4. Select Apply.



Change performance policy for multiple volumes
About this task
You can set the same performance policy for multiple volumes in a volume group simultaneously.
Steps

1. Select Storage > Volume Groups > [volume group] > Members.

2. Select the volumes on which you are changing the policy.

 NOTE: You can only set the same policy on the selected volumes.

3. Select More Actions > Change Performance Policy.

4. Select a performance policy, and select Apply.

Working with performance charts
You can work with the performance charts to customize the display. Print performance charts, or export the
performance data to display in an alternative application.
A performance summary for the current time period is always displayed at the top of the Performance card.
Performance charts are displayed differently for the cluster and the cluster resources.
Working with the performance chart for a cluster

Figure 2. Cluster performance chart

1. Select whether to view the Overall or File performance of a cluster.

 NOTE: The File tab displays a summary of file protocols (SMB and NFS) operations for all NAS file

systems. The Overall tab displays the summary of all block-level operations across volumes, virtual volumes,

and NAS file systems internal volumes, but does not include the file protocols operations that are displayed in

the File tab.

2.  Select or clear the type of metric values to show or hide in the chart.

3. Select the type of chart to display from the View menu. You can choose whether to display the performance

summary in the chart, or display the details of a specific metric in the chart.

4.  Select the time range to display by changing the time period selected in the For: menu.

5. View the historical data in the chart area, and hover over any point on the line graph to get display the metric

values at that point-in-time.



 NOTE: You can zoom into an area of the chart by selecting the area with the mouse. To reset the zoom

setting, click Reset zoom.

Working with performance charts for cluster resources
Performance charts are displayed for virtual volumes (vVols), volumes, volume groups, file systems, appliances,
and nodesThe following options are available for viewing the performance metrics for appliances and nodes:

1. Select whether to view the Overall or File performance of a cluster.

 NOTE: The File tab displays a summary of file protocols (SMB and NFS) operations for all NAS file

systems. The Overall tab displays the summary of all block-level operations across volumes, virtual volumes,

and NAS file systems internal volumes, but does not include the file protocols operations that are displayed in

the File tab.

2. Select the metric category to display from the Category list. A chart is displayed for each appliance and node

that are selected in the Show/Hide list.

3.  Select or clear the appliance and nodes to display or hide from the Show/Hide list.

4.  Select the amount of historical performance data to display from the Timeline list.

5. Download the charts as a .png, .jpg, .pdf file or export the data to a .csv file.

6.  View the historical performance data in the chart or hover over a point on the line graph to display the metric

values at that point-in-time.

7. Select or clear the types of metric values to show or hide in the chart.

 NOTE: You can zoom into an area of the chart by selecting the area with the mouse. To reset the zoom

setting, click Reset zoom.

The following options are available for viewing the performance metrics for other cluster resources, such as

volume groups:



1. Select the metric categories to display from the Host IO list. A chart is displayed for each category that is

selected.

 NOTE: If the storage object is configured as metro or is part of a replication session, more metric lists are

displayed.

2. Select the amount of historical performance data to display from the Timeline list.

3.  Download the charts as a .png, .jpg, .pdf file or export the data to a .csv file.

4. View the historical performance data in the chart or hover over a point on the line graph to display the metric

values at that point-in-time.

5. View the current metric values for the average latency, read latency, and write latency metrics.

6. Select or clear the types of metric values to show or hide in the chart.

7. You can zoom into an area of the chart by selecting the area with the mouse. To reset the zoom setting, click

Reset zoom

For storage objects that are part of an asynchronous replication session (volumes, volume groups, NAS

servers, file systems), you can select additional metrics from the Replication list:

● Replication Remaining Data – The amount of data (MB) left to be replicated to the remote system.

● Replication Bandwidth – The replication rate (MB/s)

● Replication Transfer Time – The amount of time (seconds) required for copying the data.

For volumes and volume groups that are configured as metro, and for storage resources that are part of a

synchronous replication session (volumes, volume groups, NAS servers, file systems), you can select

additional metrics from the Metro/ Synchronous Replication list:

● Session Bandwidth

● Remaining Data

For volumes and volume groups that are the sources of remote backup, you can select additional metrics from

the Remote Snapshot list:

● Remote Snapshot Remaining Data

● Remote Snapshot Transfer Time

For NAS servers and file systems that are part of a replication session, additional charts can be displayed for

IOPS, bandwidth, and latency that allow you to monitor the impact of replication on latency and track data that

is replicated to the destination  system, separately from the data that is written to the local system. You can



select to view the following charts:

● For block performance 20s metrics:

○ Block Write IOPS

○ Block Write Latency

○ Block Write Bandwidth

● For replicated data performance 20s metrics

○ Mirror Write IOPS

○ Mirror Write Latency

○ Mirror Overhead Write Latency

○ Mirror Write Bandwidth

For each of these metrics, you can select to view charts displaying average and maximum performance data.

Generating performance metrics archives
You can collect and download performance metrics to help troubleshoot performance-related issues.
About this task
You can use the PowerStore Manager, REST API, or CLI to collect performance data and download the generated
archives. You can use the gathered information to analyze and troubleshoot performance-related issues.
Steps

1. Select the Settings icon and then select Metrics Archives in the Support section.

2. Select Generate Metrics Archive and confirm to initiate the process.

A progress bar indicates when the archive is generated and the new archive is added to the Metrics Archives

list.

3. Select the generated archive and then select Download and confirm to initiate the download.

When download is complete, the download date and time is displayed in the Downloaded column.

Collecting System Data

This chapter includes:
Topics:

Support materials collection

Collect support materials

Support materials collection
You can collect support materials to help troubleshoot the appliances in your system.
Depending on the option you choose, support materials can include system logs, configuration details, and other
diagnostic information. Use this information to analyze performance issues, or send it to your service provider so
they can diagnose and help you resolve the issues. This process does not collect user data.
You can collect support materials for one or more appliances. When you start a collection, data is always collected
at the appliance level. For example, if you request a collection for a volume, the system collects support materials
for the appliance that contains the volume. If you request a collection for multiple volumes, the system collects
support materials for all appliances that contain the volumes.
You can set a timeframe for collecting support materials. Setting a timeframe can result in smaller and more
relevant data collection which is easier to analyze . You can either set a predefined timeframe or set a custom
timeframe that suits your needs.
You can also include additional information in the support materials collection from Advanced collection options.
Collecting additional information can take longer than the default support materials collection, and the size of the
resulting data collection is larger. Select this option if your service provider requests it. By default the support



materials collection uses the essentials profile. Use the s v c _ d c service script to collect support materials for
other profiles. See the PowerStore Service Scripts Guide for more information about the s v c _ d c service script
and the available profiles.

 NOTE: The system can run only one collection job at a time.
You can perform the following actions on a collection of support materials:

View information about existing collections.

Upload a collection to support, if remote support through Secure Remote Services is enabled.

Download a collection to a local client.

Delete a collection.

 NOTE: Some of these operations might not be available if the cluster is operating in a degraded state.

Collect support materials
Steps

1. Select the Settings icon, and then select Gather Support Materials in the Support section.

2.  Click Gather Support Materials.

3.  Type a description of the collection in the Description field.

4. Select the timeframe for the data collection.

You can select one of the available options from the Collection Timeframe drop-down menu, or select Custom

and set a timeframe.

 NOTE: If you select Custom as the timeframe for the data collection, the estimated finish time for the data

collection is displayed in the Collection Timeframe Finish column of the Support Materials Library table.

5. Select the type of support data to collect from the Object type drop-down menu.

6. In the Objects to collect data for: area, select the check boxes of the appliances from which to collect support

data.

7. To send the data collection to support when the job completes, select the Send materials to Support when

finished check box.

 NOTE: This option is available only when Support Connectivity is enabled on the system. You can also

send the data collection to support from the Gather Support Materials page after the job is completed.

8. Click Start.

The data collection is initiated, and the new job appears in the Support Materials Library table. You can click the

job entry to view its details and progress.

Results
When the job is completed, the job information is updated in the Support Materials Library table.
Next steps
After the job is finished, you can download the data collection, send the data collection to support, or delete the
data collection.
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