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Specifications

Product Name: Benewake LiDAR Viewer GUI

Platform: Windows 10 and above

Main Functionality: Realtime display, recording, and playback of point cloud data

Product Usage Instructions

1. Brief Introduction

The Benewake LiDAR Viewer GUI (BLV) is a software designed for use with the AD2 LiDAR system. It allows
users to perform realtime display, recording, and playback of point cloud data.

2. System Introduction

BLV is compiled for the Windows 10 platform and is recommended \to be used on Windows 10 and above
systems. Before using the software, ensure that your computer meets the system requirements.

3. Terms and Abbreviations

BLV uses certain terms and abbreviations such as IP, MDOP, DCSP, DSOP, *.pcd, *.csv, *.pcap. Refer to Table 1
for their meanings.

4. Precautions before Use

Before using the LiDAR system, follow these precautions:

1. Change the IP address of your computer to match the network segment of the LiDAR IP address.

2. Ensure that your computer’s firewall is turned off for proper connection.

FAQ

Q: Can BLV be used on operating systems other than Windows 10?

A: BLV is compiled for the Windows 10 platform and it is recommended to be used on Windows 10 and

above systems for optimal performance.

Q: What are the main functions of BLV?

A: The main functions of BLV include real-time display, recording, and playback of point cloud data from

the AD2 LiDAR system.

Brief Introduction

Objective

The purpose of this article is to explain the basic functions, operation methods and precautions of Benewake
LiDAR Viewer GUI (hereinafter referred to as BLV).

System Introduction



BLV is a GUI software used by AD2 LiDAR, which is mainly used for real-time display, recording and playback of
point cloud data. BLV is compiled on the Windows 10 platform, and it is recommended to install and use it on
Windows 10 and above systems.

Terms and Abbreviations

Precautions before use

Before using the LiDAR, you need to change the IP address of your computer.
Network and Internet → Ethernet → Change adapter options → Properties → Internet Protocol version 4
(TCP/IPv4), set the host IP address to remain on the same network segment as the LiDAR IP address (i.e.,
segment 0), subnet mask 255.255.255.0, and host IP address used in this instruction manual is 192.168.0.10 (the
last byte is different from the IP address of the connected device).



1. Make sure that your computer’s firewall is turned off (this is optional: if you can’t connect properly, try this step

again). Control Panel → System and Security → Windows Defender → Turn on/off Windows Defender Firewall.



File Structure

BLV file structure (part of the file) as shown in the figure, double-click\ Benewake_LiDAR_Viewer.exe to open the
GUl program.



Interface Introduction

The main interface of BLV is shown in the following figure:



1. Menu Bar: Basic configuration options

2. Toolbar: Basic function options, the specific functions are as follows:



3. Device Management Bar: Manage device addition and deletion, control device start and stop, display device

information and connection status, etc.

4. Point cloud display area: Displays real-time point clouds or plays point cloud data files.

Functions Introduction

Point Cloud Display Adjustment

Point cloud display

1. Please complete the configuration before use according to Chapter 1.4

2. Open the BLV software, there are two ways to add LiDAR: [Method 1]

1. Click Device Management Bar → Add button to set the IP, PORT, DSOP of the LiDAR.



In general, the following table describes the parameters:

3. Finally, confirm the addition.

[Method 2]

1. Click the icon in the toolbar  to search for the device (the search port is 62702), as shown in the

figure, and click OK to complete the addition.



2. After the addition is completed, the device information will be displayed in the Device Management Bar,

as shown in the following figure:

(Due to different devices, the device information is not exactly the same. and the device information in the

figure is for reference only).

Starting LiDAR

After completing the steps of adding the device, you can click the Device Management Bar → Start button, wait for
a while, and then start to get the point cloud data, which will be displayed in the Point Cloud



Display Area in real time. Click the Stop button to stop the LiDAR from working.

Point Cloud Display Adjustments

1. Point cloud display adjustment: as shown in the red box, the area\ encircled

The following table describes how to do this:



Note: When you cannot continue to zoom in on the point cloud display using the mouse wheel, you can

continue to zoom in on the point cloud display by clicking the F key on the keyboard. At this point, the point

cloud display continues to zoom in centered on the mouse-over position:

2. Angle Adjustment: select the following icons in the Toolbar to adjust the point cloud data display view, or in the

Menu Bar → Point Cloud Display → Set View.



3. Point Size Adjustment: Click the icon  in the Toolbar to change the size of the point, and a pop-up window

will appear as shown in the following figure after clicking it (or set it in the Menu Bar → Point Cloud Display →

Set Point Size). The point size range is 1~10, and the default setting is 2.



4. Set the color scheme: Set the color scheme in the Menu Bar → Point Cloud Display → Set color scheme to

render point cloud display according to reflectivity, distance, and elevation (In general, the default rendering

color is to render at reflectivity).

Record and Playback Point Cloud Data



Recording & Playback *.PCD file

1. Click the Menu Bar → File → Save File → Save PCD File (from the device), select the save path to start

recording or click the Toolbar  icon). If you need to end the recording, click the Menu Bar → File → Save

File → Stop Saving PCD File (From Device) option to stop the recording (or click the Toolbar  icon).

(Note: You need to choose the storage location, it is recommended to create a new dedicated folder to save

*PCD data).

2. After you start recording, you can find the generated * PCD files under the saved path of the settings, which are

the corresponding point cloud data, are named according to the timestamp.



3. Click the Menu Bar → File → Playback PCD File option (or click the toolbar  icon to find the saved path you

have set after waiting for a while, click the icon • in the toolbar to play back *.PCD files.

4. Once playback starts, the  icon will change to ” an icon, and you can tap to pause the playback data at any

time. You can drag the progress bar to view the point cloud data you want to focus on.



Recording & Playback *.PCAP file

1. Click the Menu Bar → File → Save File → Save PCAP File options select the save path, set the file name, and

start recording. If you need to end the recording, click the Menu Bar → File → Save File → Stop Saving PCAP

File options to stop the recording. If the recording is successfully stopped, a pop-up window will prompt that the

saving is successful.

(Note: You need to choose the storage location, it is recommended to create a new dedicated folder to save

*PCAP data).



2. Click on the Menu Bar → File → Playback PCAP File option, and select Save the finished *PCAP file, after a

while, a pop-up window will o prompt that the file has been successfully imported. Click the icon in the

toolbar to play back *.PCAP file.

3. Follow-up and playback*. PCD files.



Save *.CSV file

1. Click the Menu Bar → File → Save File → Save CSV File option, and select the save path, you can save a

frame of data in the save path, and the recorded file will be named according to the timestamp. Use Excel to

open a saved *.CSV file. Come no ted to ense dedi stor to do to save cord it is

Functions Related to Device Management Bar

As shown in the figure below, click the corresponding button in the Device Management Bar to use the
corresponding functions.



1. Add: Add a new LiDAR device

2. Delete: Delete the added device

3. Start: Run the devices that have been added

4. Stop: Stop the running device that you added

5. Display: Display the point cloud data of the selected device in the point cloud display area

6. Hide: Hide the point cloud data of the selected device

Toolbar Related Functions

Scale Display

Select/invert the icon in the toolbar  to control whether the scale is displayed, and the contrast (comparison)
effect is shown in the following figure:



Hue Indicator



Select/invert the icon in the toolbar  to control whether the hue indicator bar is displayed, and the contrast
effect is shown in the following figure:



Distance Measurement

Click the icon in the toolbar  to perform ranging operations on the point cloud. Stop the device, click  the
icon, use the left mouse button to select the point to be measured on the point cloud data in the point cloud display
area, the selected point will be displayed in red, after selecting two points, the distance between the two points can
be automatically calculated, and the distance information will be displayed near the ranging line, and the distance

measurement function can be turned off by clicking the icon  again.

Point Cloud Frame Selection

Click the icon  in the toolbar to select the point cloud. After clicking the icon , click the Left Mouse
Button once in the Point Cloud Display Area, press the X key on the keyboard, then press and hold the Left Mouse
Button to select the point cloud image (can be selected multiple times), and release the Left Mouse Button to
complete the box selection. The selected point cloud data is shown in red, and an information window will appear
on the right side of the BLV interface to display detailed information of the selected point cloud. Then press the X

key on your keyboard and invert the icon to turn off the box selection.



Perspective Projection

Depending on your display requirements, select the icon  in the Toolbar to change the display of point cloud
data. The point cloud display effect of perspective projection is closer to the visual effect of human eye.

Orthographic Projection



According to your requirements, click the icon  in the Toolbar to change the display effect of the point cloud
data to ortho projection. In the ortho projection effect, objects near and far are scaled at the same scale.

Rotation Function

Click the icon  in the toolbar to turn on the rotation function. When enabled, the point cloud display will rotate
slowly 360° horizontally along the plane formed by the X-axis and Y-axis of the LiDAR with the Z-axis of LiDAR as
the rotation axis.



Menu Bar-Related Functions

File

As shown in the figure, file menu main functions are: playback PCD file, play back PCAP file, save PCD file, save
CSV file, save the PCAP file, etc. For more information, please



Window

As shown in the figure, click the Menu Bar → Window → Open/Close Device Window options to display and hide
the device management bar.



Device Information

As shown in the figure, click the Menu Bar → Device Information option, and secondary options such as Get
Device Information, Get Device Heartbeat Information, Get Device Logs, and Search for Devices in the Current
Network will appear. By clicking these options, you can understand the basic information of the LiDAR device.



1. Get Device Information: The SN number and firmware version of the current device are displayed.

2. Obtain device heartbeat information: The heartbeat signal of the current device can be detected.

3. Get Device Logs: displays the log information of the current device. Search for devices on the current network:

Search for radars waiting to connect in the current network segment.

Configuring Device

Click the Menu Bar → Configure Device option to configure some functions of the device (Note: If the LiDAR is in
the running state, the Configure Device function is not available).

1. Click the Menu Bar → Configure Device → LiDAR Operation Settings → Set Mode options to make the LiDAR

operate in different working modes. If you want to know the parameters of each mode, please\ contact

Benewake technical support: at support@benewake.com

2. For other function configurations, please contact the Benewake technical support team: at

support@benewake.com, and use professional guidance.

Point Cloud Display

Point cloud display, the main functions are: set the color scheme, set the display scale, view, exhibition mode,
display color bar, display scale, ranging box selection, set point size and so on. For more information,

mailto:support@benewake.com
mailto:support@benewake.com


Help Menu

In addition to the above features, BLV offers a number of other features. Click the Menu Bar → Help option to view.

Frequently Asked Questions and Answers: Frequently asked questions and explanations, including the device



does not start, the point cloud is displayed incorrectly or cannot be displayed, etc.

Select Language: Select the display language of the BLV interface.

About Benewake: Company Introduction.

Product introduction: Benewake product positioning, application fields, etc., please refer to the product

introduction page of the official website for details.

Viewer Version: GUl software version and release date.

Contact us: If you encounter any problems during use, please contact Benewake technical support.
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