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Product InformationThe speedy drive.web is a drive.web automation Distributed Process Controller. It is a
model dw229 and is designed for permanent installation by qualified professionals.

The product complies with UL Certification Statements and conforms to EMC Standard, EN 61326-1: 2006 for
Electrical Equipment for Measurement, Control and Laboratory Use. It also meets Emissions Class A,
Commercial Equipment and Immunity Table 2,Industrial Equipment.

For safety requirements, the product adheres to LVD Standards,EN 61010-1: 2010 and EN 61010-2-030:
Particular Requirements for Testing and Measuring Circuits.

The product contains recyclable materials and a small rechargeable battery, which is permanently affixed to the
underside of the main circuit board. The battery must be removed with wire-cutting pliers and separated for proper
disposal.

It is important to note that the device complies with Part 15 of the FCC Rules and must not cause harmful
interference or be affected by interference from other devices.

Various warnings are provided in the manual, emphasizing the need to read and understand the entire manual
and the savvy software Help menu before installation and configuration. Users are warned about potential risks
associated with using the savvy software and drive.web devices, including the possibility of motors and machinery
powering up with high voltages or operating in unexpected or dangerous ways. Proper familiarity with the
equipment and system design is essential, along with conducting a risk assessment to identify hazards.

The product is identified as speedy HG503855Iss1.1 and more information, including manuals and software
downloads, can be found at www.driveweb.com.

Product Usage Instructions

1. Only qualified professionals should perform the installation and configuration of the speedy drive.web.

2. Before proceeding with the installation, it is essential to read and understand the entire user manual and the

savvy software Help menu.

3. Follow the savvy installation instructions provided on page 5 of the manual.

4. To download manuals and software, visit www.driveweb.com or contact the manufacturer.

5. Always conduct a risk assessment to identify potential hazards associated with the use of the product and take

necessary precautions to reduce risks to tolerable levels.

6. When disposing of the product, remove the small rechargeable battery by using wire-cutting pliers and

separate it for proper disposal.

7. Avoid exceeding any minimum or maximum values to prevent permanent damage to the speedy drive.web.

8. Do not connect any speedy terminal to mains circuits.

9. After loading new firmware or installing new options, verify the proper operation of the speedy drive.web.

http://www.driveweb.com
http://www.driveweb.com


10. Users are entirely responsible for the configuration and use of the drive.web products and agree to indemnify

and hold harmless the manufacturer and its affiliates against any consequences resulting from their

configuration or use.

Note: It is important to refer to the ratings provided on page 3 of the manual for proper usage.

Installation & Operation Manual

UL Certification Statements
This process control equipment to be supplied by Class2, LPS, limited power supply.

Conformity Statements

EMC Standard, EN 61326-1: 2006, Electrical Equipment for Measurement, Control and Laboratory Use.

Emissions Class A, Commercial Equipment.

Immunity Table 2, Industrial Equipment.

LVD Standards, EN 61010-1: 2010, Safety Requirements for Electrical Equipment for Measurement, Control

and Laboratory Use and;

EN 61010-2-030: Particular Requirements for Testing and Measuring Circuits. speedy is an industrial controller

designed for permanent installation by qualified professionals.

If it is used in a manner not specified herein the protection provided may be impaired.

speedy and its packaging contain recyclable materials and a small rechargeable battery, classed as “portable”,

that is permanently affixed to the underside of the main circuit board. The battery must be removed with wire-

cutting pliers and separated for proper disposal.

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions:

(1)This device may not cause harmful interference, and (2)this device must accept any interference received,

including interference that may cause undesired operation.

This Class [A] digital apparatus complies with Canadian ICES-003. Cet appareil numerique de la classe [A] est

conforme à la norme NMB-003 du Canada.

Warning! It is essential that you read and understand this entire manual and the entire contents of the savvy

software Help menu before proceeding with your installation and configuration. See page 5 for savvy

installation instructions. For more information and to download manuals and software, go to

www.driveweb.com or contact us. See page 8.

Warning! Your use of savvy software and drive.web devices may cause motors and machinery to power up

with high Voltages or start or operate in an unexpected, dangerous or lethal way. It is essential that you are

completely familiar with all of the equipment and the system design before attempting to program or edit a

program or connect to any live device. It is also essential that a risk assessment is conducted to identify

hazards.

Risks must be reduced to tolerable levels.

SAVVY, SAVVYPANEL, SPEEDY, BARDAC, and DRIVE.WEB are trade marks of Bardac Corporation,registered
in the U.S. and other countries.

Warning!



You are entirely responsible for the configuration or use of any drive.web product. By configuring or using these

products you agree to indemnify and hold harmless Bardac Corporation, its employees, directors, officers,

distributors, and resellers against the consequences of your configuration or use of the products.

Information in this manual is subject to change without notice. You are responsible for verifying the proper

operation of your speedy. Special care must be taken after loading new firmware or installing new options.

Avoid permanent damage to your speedy, never exceed any min or max values. Do not connect any speedy

terminal to mains circuits. See page 3 for ratings.

lwIP is incorporated into speedy firmware. lwIP Copyright (c) 2001-2004 Swedish Institute of Computer

Science. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following

disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the

following disclaimer in the documentation and/or other materials provided with the distribution.

3. The name of the author may not be used to endorse or promote products derived from this software without

specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
SUCH DAMAGE.

Product Identification

Models

speedy is a programmable device using drive.web distributed control over Ethernet for industrial process

automation. To program and use speedy you must get the savvy software tools from www.driveweb.com.

Find speedy firmware version. Use savvy, Get Detailed

Info from speedy contextual menu. Page 5.

dw229 Generic CANopen Master

speedy Standard Features



drive.web distributed process control.

10/100Base-T(X) Ethernet. See page 3.

Update firmware with savvy software.

Ultra-compact, may be permanently bonded inside equipment.

High-speed CANopen. Up to 1Mb/s.

Basic Control function block library.

Options

Software options may be added using savvy. See page 6.

04 ModbusTCP/IP – Slave/server. See page 8.

05 Process Control – Recommended for most applications.

06 Winder Control – Diameter Calc., Taper Tension, Torque Comp.

10 Math – With internal 32-bit Calculator.

25 EIP/PCCC – Slave/server. See page 8.

26 savvyPanel – Operator station interface. See pages 7, 8.

29 Solar – Calculates sun position azimuth and zenith.

36 Motion Control – With Trapezoid Motion and Cam Profile.

50 DIN rail mount with terminal block wiring.

Installation

speedy is designed for permanent installation by qualified professionals.

Environment – UL/IEC Pollution Degree 2,Temperature, Operating, 0°C to 50°C. Storage, -20°C to 60°C.

Altitude 3000m max.

Humidity 95% max. non-condensing.

Weight – Standard-19g(0.7oz). w/ DIN rail & terminals – 28g(1.0oz).

Power requirements – Regulated 24VDC ±5%, 40mA. Do not connect to a distributed DC power network. A



100mA fastacting fuse or 1A current-limiting is required!

Supply from Class 2, LPS, limited power supply only.

Unisolated serial port – Power and serial circuits must have compatible common-mode Voltages.

Ethernet – MDI 8P8C, “RJ45” jack, 100baseTX, 10BaseT, Full Duplex, Auto Negotiation, Auto-MDIX, IEEE

802.3ab.

USB port – Peripheral-type, Micro-B jack.

Ethernet LEDs – For setup, troubleshooting, and monitoring:

100 Green LED indicates 100BaseTX Ethernet connection.

Link / Activity Yellow LED. On for Link, flashing for activity.

Adhesive mounting – Clean adhering surfaces with alcohol first.

Use caution, bond is permanent. Adhere on or near the drive or Modbus device.

Do not obstruct air vents, access points or product labels. Do not attach speedy near AC power lines, hot spots,

heatsinks,cooling fans, etc.

DIN rail option – Use 35×7.5mm rail per IEC 60715, EN50022.

Terminal wiring – Strip 7mm(0.28”) or use ferrules.

Use 0.2mm2 (AWG24) minimum.

One wire, 2.5mm2 (AWG12) maximum.

Two wires, 1.5mm2(AWG14) maximum.

Two wires with ferrules, 1mm2 (AWG18) maximum.

Terminal tightening torque – 0.5 Nm (4.4 in⋄lbs).

Power and Serial Port Connections

CAN+ and CAN- must share a single twisted-pair. 0V may use one or both conductors in another pair. Do NOT

pair 0V with other signals.

Maximum total serial cable length is 1m!

Multi-drop networks are not supported. Each speedy can connect to only one CANopen server.

Line termination is built-in and should not be used at the opposite end of the serial cable. Do not add line

termination at either end of the serial cable.

Signal wiring notes – Use twisted-pair wiring. All wiring outside of the metal enclosure should be shielded
cable with individually shielded twisted-pairs such as Belden 8163.



Ground the shield at only one end with a 360° clamp where the shield enters your metal enclosure. Maximum

serial cable length is 1m!

Dimensions & Clearances – 1” clearances must be provided on three long sides to promote airflow.

Set up your computer – Get savvy

Use free drive.web savvy software to setup, program, monitor, and perform data trending.

Go to www.driveweb.com and click on Get savvy, or contact us to get the latest version of savvy.

USB – Plug and Play

Experience plug-and-play access to speedy and its local

Ethernet network. Requires 0x201A firmware or later. speedy

Ethernet Networking & Programming

Assigning an invalid or duplicate IP address will cause serious network malfunctions!

Find useful networking information. Under the Help menu click on Getting Started with savvy section. speedys

are all shipped with the IP address, 10.189.189.189.

Use Category 5e cable or better, with 8P8C/RJ-45 connectors for each drive.web device and the host

computer.

For systems with more than one drive.web device, use an Ethernet switch for all drive.web devices and

computer.

http://www.driveweb.com


Get started with savvy

We strongly recommend attending our free online training seminars. See page 8.

We strongly recommend you read the User Manual and Getting Started Guides under the Help menu.

Use Create Phantom in the Directory menu to explore drive.web products and options, design,and configure

offline. Export Data to save your work. Import Data into phantoms to work offline.

savvy Window Title Bar indicates the current view.

Status Bar, above the viewing area, provides Navigation Arrows and object and location data.

savvy views are hierarchical with the Device Directory View at top. Use the Navigation Arrows to go up, back,or

forward. Window menus change as you navigate.

Hover cursor over active object, device, function block,connection, or parameter icon to view object information

in the Status Bar and reveal a Hover Button.

Click a Hover Button or right-click an active object to access a Contextual Menu. See below.

savvy functions are limited by password-protected capability level . See File > Capability…

Device Directory Window

Warning! Changing a device IP address WILL disrupt its network connections! If a speedy is communicating

with other devices, be prepared for system disruption. In the File menu choose Utility > Remap Export File to

remap a dw-system file with different IP address(es).

Select File>Administrate>Set IP Addresses for System.

speedy serial number is also its MAC Address.

Enter a valid IP address and click OK.

An icon appears with IP address beneath. Drive-dedicated models depict the actual frame size of the drive.

If the icon at right appears, a network connection problem exists. Check connections, LEDs, and that speedy IP
address is within the computer’s Ethernet subnet mask.

Warning! Importing data into your speedy will result in immediate execution of that configuration. Dangerous
Voltages and rotating machinery may result! Use a phantom to preview a configuration.



Directory > Import / Export Data. All device configurations and connections in the directory in one .dw-system file.

Icon Contextual Menu

Change Name – Name your speedy for easy identification.

Import / Export Device Data… – Load / save configuration data to / from this speedy only.

Unlock, Lock, Set Password – Choose Restrict

Modification for view-only, or Restrict All Access.

Click the speedy icon to view the device configuration.

Function Block Engine Window – FBE Menu

(Standard savvy, no SFD)

Add function blocks in the order to be processed. Processing order is left to right, top to bottom.

Click function blocks to view parameters and details.

Connect between parameters and other drive.web devices.

Warning! Making a connection results in immediate execution of that connection. Dangerous Voltages and

rotating machinery may result!

Under the File menu, choose New Viewer… and then,File > Open Device Directory.

With two viewer windows, click a parameter, drag and drop onto a parameter in the other viewer.

Parameter Contextual Menu – Most parameter data is 16- bit. Data is formatted, limited, and scaled depending

on the parameter. Use Get Info or Re-Scale… to verify or change.

Click parameters for the Setter Box – Increment, decrement, default, last state, or keyboard entry.

Click blue connection block or arrow to jump to other end.



Upgrade savvy and speedy

Upgrade savvy with SFD Signal Flow Diagram.

Upgrade speedy with software options.

Process credit cards or Vouchers online or Coupons offline.

To upgrade savvy go to the Commerce menu, select Upgrade savvy, check desired options, click OK.

To upgrade speedy, choose Upgrade Device… in its contextual menu, check desired options, click OK.

To process Vouchers, choose Pay>Online Via Vouchers in the Shopping Cart. Enter codes on separate lines.

To process Coupons, use Commerce menu > Coupon Manager. Enter codes in the top box, click the Add

button, and the coupon is recognized. Click Apply.

 Signal Flow Diagram Upgrade

With savvy-SFD, build systems graphically. The live drawings are stored in your speedy.

Set drawing borders and annotate multi-page drawings.
A filterable list of function blocks and connections is at the left of the Signal Flow Diagram showing program
execution order from top down. Change execution order by dragging function blocks up or down the list. In this
picture, ENC1 Speed function block is moved so that it is processed after ENC Phase Lock.

savvyPanel Operator Station

Computers, Apple® mobile digital devices; iPad®, iPhone®, and iPod Touch® are operator touch stations with



savvyPanel. Requires Windows(XP, Vista, 7), Mac OS X, Linux-based Ubuntu, or iOS®.
Configurations are stored in the drive.web devices. savvy-SFD upgrade is required to edit or build  savvyPanel
systems.
dwOption-26 savvyPanel, must be installed in drive.web devices to enable the full suite of tiles. A limited set is
available without the option.

Get savvyPanel free from the Apple App Store℠ When your iPad or iPhone is connected to the internet via WiFi,
demo mode connects to a live drive system in our plant in Maryland, USA.
Explore the demo with savvy. Select File menu> Demo Mode > Discover Internet Demo Devices.

savvyPanel Pages

Systems Page where multiple savvyPanel systems are present.

A savvyPanel system may contain tiles from many drive.web devices.

A drive.web device contributes to only one savvyPanel system.

Touch the systems button, or  , in the window bar to access the systems page from home page.

Lock this button with home password.

Home Page is the first operator page in a savvyPanel system.

Access home page from any operator page with the home button, . Lock with the home password.

Operator Pages show graphic, page-link, and parameter tiles.

Pages can be renamed. Page name appears in window title bar.



Panel Tiles

Parameter Tiles – Touch a settable parameter to set. Setter includes slider, keypad, 1x and 10x increment and

decrement, return-to-default, and revert.

Graphic Tiles – Create diagrams with process elements.

Page-Link Tiles – A graphic tile that is also a page-link.

Touch to change the view to that page.

Device Tiles – Link to device’s signal flow diagram in Javabased savvyPanel. Appears as graphic tile in iOS.

Function blocks enable savvyPanel actions

Alarm Annunciator – Provides a system-wide alarm annunciation when active. Touch to view page 255.

Presence Monitor – Indicates the presence of a tagged savvyPanel application viewing a particular page.

Latch and SR Latch – For lighted start-stop pushbuttons.

Setpoint & Monitor – Adjust meter and setter range. Dual blocks enable dual-display meters.

Enumerated Parameter – In Utility group. Only custom enumerations appear in the setter and multi-position

switch.

Panel Launch, Setup, and Important Notes

See the savvy user manual for detailed instructions.



Launch savvyPanel via command line or batch file.

Limit operators to savvyPanel only. Specify start system and page.

Discover devices automatically, specifically by discovery file, or filtered by group and/or savvyPanel name.

Operator’s note: If communication with a drive.web device is interrupted, affected tiles indicate a yellow bar

with a warning symbol. The tile is not updated.

Important Design Note – An over-range enumeration is required if an out-of-range value could cause a hazard.

Comms Interfaces-Modbus & EIP/PCCC 
Warning! Use of speedy comms interfaces, ModbusTCP,ModbusRTU, and EIP/PCCC, may cause motors and
machinery to energize with high Voltages, or start, or operate in an unexpected, dangerous, or lethal way.
Find Modbus specifications – http://modbus.org/specs.phpspeedy Comms Server dwOption-04, -25

Note! You cannot write or force parameters that are readonly or have incoming drive.web connections.
Click the Comms Server icon in the FBE or SFD view. dwOption-04 ModbusTCP/IP slave/server
Supported Modbus Function Codes; 1 thru 6, 15, and 16.
Supports up to five simultaneous clients/masters. dwOption-25 EIP/PCCC Server
Supports PLC5 Typed-Write and Typed-Read commands.
See Appendix B of the savvy User Manual for information and drive.web parameter IDs mapping to PLC5.

Supports up to two simultaneous clients.

CANopen Master
Find the CANopen Setup function block and click on the Program parameter to begin setting up the interface.
Setup baud rate, the node ID of the single CANopen server and other important details under the Configuration
tab.
The PDO addresses in the server are setup in the Setup Actions tab. drive.web Training Courses Free online
interactive training seminars take about one hour.
Specialized online and factory training sessions are also available.
To register email training@driveweb.com or call.

HG50385d5rIisvs1e..1w eb 40 L wogw Cwa.dnoreiv Cewirceleb,. cSotemvensvill e , M D 21666 U S A .

Ph. 410-604-3400, Fax 410-604-3500, www.driveweb.com
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