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Product Specifications

Model: DXMR90

Application: VIBE-IQ Application Guide

Features: Continuous Vibration Monitoring, Self-Learning Baseline and Threshold, Acute and Chronic Alarms,

Temperature Alarms, Advanced Data Monitoring

Connectivity: RS-485 communication

Mounting Options: Flat magnet sensor bracket, Curved surface magnet bracket

Product Usage Instructions

Installation of Sensors
Follow the Banner’s Vibration Monitoring Sensor Installation Guide for proper sensor installation. Choose the
appropriate mounting option based on the surface type and size.

Connection to Controller
Connect the Banner Vibration and Temperature Sensors to the DXMR90 industrial controller using the provided
RS-485 communication.

Loading Configuration File
Load the preconfigured XML file and script onto the controller for up to 40 vibration sensors. Make minor
modifications to the XML file to customize it for your specific site.

Monitoring and Alerts
Monitor vibration data on the assets sensing X and Z axis RMS Velocity and high-frequency RMS Acceleration.
Keep an eye on the alarms and warnings generated for acute and chronic conditions for each motor.

Cloud Monitoring
If using Banner Cloud Data Services, set up SMS text and email alerts for individual warnings and alarms. Push
data to a Cloud Webserver or PLC via LAN for remote viewing, alerting, and logging.

Frequently Asked Questions (FAQ)



What is the purpose of VIBE-IQ Application Guide for the DXMR90?

The VIBE-IQ Application Guide helps in continuous vibration monitoring of critical rotating assets in industrial

facilities to prevent unexpected failures.

How many assets can be monitored using the DXMR90?

The DXMR90 can monitor vibration data on up to 40 assets sensing X and Z axis RMS Velocity and high-

frequency RMS Acceleration.

What are the benefits of using the Self-Learning Baseline feature?

The Self-Learning Baseline feature eliminates the need for users to generate baselines or alarms by using

machine learning algorithms to create initial baseline readings and warning/alarm thresholds for each motor

individually.

Background and Value

Industrial facilities have hundreds of critical rotating assets such as motors, pumps, gearboxes, and compressors.
Unexpected failures result in costly downtime.
An equipment health monitoring (EHM) preventative maintenance solution uses machine learning to identify when
assets exceed pre-defined parameters, resulting in:

Increased Uptime—Eliminate unplanned shutdowns by continuously monitoring  up to 40 assets with a single

system

Reduced Maintenance Cost—Repair prior to failure or extensive collateral  damage

Effective Maintenance/Parts Scheduling—Plan for labor and spare parts

Ease of Use—Reduce installation costs and eliminate complexity of traditional  data analysis

Improved Asset Selection—Use data to analyze root cause and reliability

IIOT—Review real-time alerts for better decision-making and remote asset management

VIBE-IQ® By Banner Engineering Corp:

Monitors each motor using a machine learning algorithm to baseline values and set control limits for alerts with

limited end-user interaction

Continually monitors RMS Velocity (10-1000Hz), RMS high-frequency Acceleration (1000-4000Hz), and

temperature on rotating equipment using Banner’s Wireless vibration/temperature sensor

Determines if motors are running or not and only uses the running data for baselining and alerting

Collects data for trending and analysis; script defines acute versus chronic issues

Sends data and alerts to the host controller or to the cloud for IIoT connectivity

This Banner solution monitors vibration levels on rotating assets that are the result of:

Imbalanced/misaligned assets

Loose or worn components

Improperly driven or mounted components

Over-temperature conditions

Early bearing failure



Application Features and Benefits

Continuous Vibratio
n Monitoring

Monitor vibration data on up to 40 assets sensing X and Z axis RMS Velocity and high-
frequency RMS Acceleration. RMS Velocity is indicative of general rotating machine he
alth (unbalance, misalignment, looseness) and high-frequency RMS Acceleration is ind
icative of early bearing wear.

Self-Learning Baseli
ne and Threshold

Prevent users from having to generate baselines or alarms by using machine learning a
lgorithms to create an initial baseline reading and warning/alarm thresholds for each m
otor individually.

 

Acute and Chronic A
larms

Alarms and Warnings are generated for both acute and chronic conditions for each mot
or. Acute thresholds indicate a short-term condition such as a motor jam or stall that cr
osses the threshold rapidly. Chronic thresholds use a multi-hour moving average of the
vibration signals to indicate a long-term condition such as a wearing/failing bearing or 
motor.

Temperature Alarms Each vibration sensor will also monitor the temperature and send an alarm when the th
reshold is exceeded.

 

Advanced Data
Additional advanced diagnostic data is available such as Spectral Band Velocity data, P
eak Velocity, Kurtosis, Crest factor, Peak Acceleration, etc.

SMS Text and Email 
Alerts

Generates email alerts based on individual warnings and/or alarms when used with Ba
nner Cloud Data Services.

Cloud Monitoring Push data to a Cloud Webserver or PLC via LAN for remote viewing, alerting, and loggi
ng.

Solution Components



Model Description

QM30VT2 Banner Vibration and Temperature Sensor with RS-485 communication

DXMR90-X1 Industrial controller with four Modbus ports

This guide demonstrates how to install the sensors, connect them to your controller, and load a preconfigured
XML file and script for up to 40 vibration sensors. The XML file only requires some minor modifications to be
customized for any site.

Mounting Options
The following mounting options are listed from least effective to most effective. In all mounting options, ensure
there is no sensor movement because this results in inaccurate information or changes to the time-trended data.
Follow Banner’s Vibration Monitoring Sensor Installation Guide  (p/n b_4471486) for proper sensor installation
help.

Configuration Instructions

Follow these basic steps to configure your system.

1. Load the configuration files (see “Load the Configuration Files”).

2. Set the sensor’s ID (see “Set the Sensor ID” ).

3. Install the vibration sensor (see “Install the Vibration Sensor”).

4. Customize the XML file (see “Customize the XML File”). This is an optional step that depends upon your

https://info.bannerengineering.com/cs/groups/public/documents/literature/b_4471486.pdf


specific network requirements.

5. Set up the Ethernet connection (see “Set Up the Ethernet Connection”). Verify that your Cloud Push Interval

has been set to None.

6. Turn on the sensors in the local registers (see “Turn on Sensors in Local Registers”).

7. Save and upload the configuration file (see “Save and Upload the Configuration File”).

8. Configure the BannerCDS account (see “Push Information to BannerCDS”).

Load the Configuration Files

To customize the system to an actual application, make some basic modifications to the template files. There

are two files uploaded to the DXM:

The XML file sets the DXM’s initial configuration

The ScriptBasic file reads vibration data, sets the thresholds for warnings and alarms, and organizes the

information in logical and easy-to-find registers in the DXM

To upload and modify these files, use Banner’s DXM Configuration Software (version 4 or newer) and the

Vibration Monitoring files available via in the links below.

1. Verify you have bound the radios, conducted a site survey, and set up the sensor IDs. Install the sensors.

2. The sensors automatically begin baselining after they are installed and connected to the DXM. Avoid

unrelated vibrations from installation after you have uploaded the configuration file.

3. Download the pre-configured files from either the DXMR90 series page or QM30VT sensor series page

on www.bannerengineering.com.

4. Extract the ZIP files into a folder on your computer. Note the location where the files were saved.

5. Connect the DXM, via the USB cable supplied with the DXM or ethernet cable, to a computer containing

the DXM Configuration

Software or download the software and install it on a computer.

6. Launch the software and select the correct DXM model.

7. On the DXM Configuration Software: Go to File › Open and select R90 VIBE-IQ XML file.

8. Connect the software to the DXM.

Go to Device › Connection Settings.

Select TCP/IP.

Enter the correct IP address of the DXM.

Click Connect.

9. Go to the Settings › Scripting screen and click Upload file. Select the DXMR90 VIBE-IQ script file (.sb).

10. Go to File › Save to save the XML file. Save the XML file any time the XML has been changed. The DXM

Configuration Software DOES NOT autosave.

Set the Sensor ID

Before configuring the sensors, each sensor must have a Modbus ID assigned to it. Sensor Modbus IDs must

be between 1 and 40.

Each sensor ID corresponds to individual sensor numbers in the DXM registers. Sensor IDs don’t have to be

assigned in order but Banner recommends assigning your sensors in reverse order, starting with the last sensor

in your system.

To assign sensor IDs through the DXM Configuration Software, follow these steps.

http://www.bannerengineering.com


1. Apply power to the DXMR90 Controller and connect it to your Ethernet network.

2. Connect your QM30VT2 sensor to port 1 of the DXMR90 Controller.

3. On your computer, launch the DXM Configuration Software and select the DXMR90x from the model drop-

down list.

4. Scan your network for DXMs and identify your DXMR90’s IP address. Click Connect.

If you are installing a factory preset DXMR90, the DXM should have a fixed IP address of 192.168.0.1.

You may need to directly connect your computer to the DXMR90 to configure DHCP before continuing.

5. After connecting to the DXMR90, go to the Tools › Register View screen.

6. In the Read/Write Source and Format section, select the following:

Register Source: Remote Device

Port: 1 (or the port your sensor is connected to)

Server ID: 1

Modbus ID 1 is the factory default ID for the QM30VT2. If your sensor has already been re-

addressed in the past, please enter the new address under Server ID. If you don’t know the ID and

can’t find it under 1, use the Sensor configuration software directly with the sensor.

7. Use the Read Registers section to read Register 6103 of the sensor. Register 6103 should contain a 1 by

default.

8. Use the Write Registers section to change the Sensor ID. Banner recommends you start with the last

sensor in your system and work your way back to 1.

To assign the sensor’s slave ID using the Sensor Configuration Software: Use the Sensor Configuration

Software and the BWA-UCT-900 cable accessory to connect the VT2 sensor to the computer. Follow the

instructions in the Sensor Configuration Software Instruction Manual  (p/n 170002) to assign the

Sensor Modbus ID to a value between 1 through 40.

Install the Vibration Sensor

Correctly mounting the vibration sensor on a motor is important to collect the most accurate readings. There

are some considerations when it comes to installing the sensor.

1. Align the vibration sensor’s x- and z-axes. The vibration sensors have an x- and z-axis indication on the

face of the sensor. The z-axis goes in a plane through the sensor while the xaxis goes horizontally. The

sensor can be installed flat or vertically.

Flat installation—Align the x-axis in line with the motor shaft or axially and the z-axis is going

into/through the motor.

https://info.bannerengineering.com/cs/groups/public/documents/literature/170002.pdf


Vertical installation—Align the z-axis so it is parallel with the motor shaft and x-axis is orthogonally

vertical to the shaft.

2. Install the sensor as close to the bearing of the motor as possible.

Using a cover shroud or location far from the bearing may result in reduced accuracy or ability to detect

certain vibration characteristics.

The mounting type can affect the results of the sensor.

Directly screwing or epoxying a bracket to a motor provides a permanent installation of the bracket to which the

sensor can be attached. This more rigid mounting solution ensures some of the best sensor accuracy and

frequency response, but is not flexible for future adjustments.

Magnets are slightly less effective but provide more flexibility for future adjustments and faster installation.

Magnet mounts are susceptible to accidental rotation or change in the sensor location if an outside force bumps

or moves the sensor. This can lead to a change in the sensor information that differs from the time-trended data

from the precious location.

Customize the XML File
This is an optional configuration step.

1. Within the configuration software, go to the Local Registers › Local Registers in Use screen.

2. Rename the registers for the monitored asset.

On the Local Registers › Local Registers in Use screen, to go the Edit Register section near the bottom of

the screen.

In the Name field, enter the register name of your monitored asset.

Because there are five registers per monitored asset, copy and paste names for efficiency. (N1 = Sensor

ID 11, N2 = Sensor ID 12, … N40 = Sensor ID 50).

3. To display the motor vibration data, warnings, and alarms on the Banner CDS website, change the Cloud

settings to Read for each monitored asset’s information (velocity, acceleration, alert mask, etc.) that you would

like to appear on the website.



4. The most common registers to be sent to the cloud already have their cloud permissions set. To send additional

registers or reduce the number of registers being sent if you are using less than 40 sensors, change the cloud

permissions.

On the Modify Multiple Registers screen, select Set in the drop-down list next to Cloud settings.

In the Cloud settings drop-down, select Read or None to turn the register off.

Set the Starting Register and the Ending Register for the group of registers that need to be changed.

Click Modify Registers to complete the modification.

Standard register cloud permissions are shown in the Local Registers table at the end of this document.

Set Up the Ethernet Connection
The DXMR90 is designed to push data to a webserver via an Ethernet push. Follow these steps to set up the
Ethernet connection to the cloud services.

1. On the Local Registers in Use screen, set the Value Type of register 844 to Constant and a value of 1 to enable

the data push.

2. If the DXM will push to the cloud webserver, set up the push interface.

Go to the Settings › Cloud Services screen.

From the Network Interface drop-down list, select Ethernet.

3. Set the Cloud Push Interval to None.

The script associated with this file defines the five-minute push interval internally so that it occurs immediately

after the sample of the sensors. If you define the Cloud Push Interval here as well, you will be pushing too much

information to your account.

Turn on Sensors in Local Registers

To turn on the sensors, set the NodeSelect registers (7881–7920) to the DXMR90 Port Number of the sensor.

By default, only Sensor 1 (ID 1) is set to a 1 to avoid long timeouts of other systems not on the system. Setting

the register back to 0 tells the system the sensor is OFF and data won’t be collected.

For example, if you have five sensors connected to port 1 of the DXMR90 and five sensors connected to port 2



of the DXMR90, set registers 7881–7885 to 1 and registers 7886–7890 to 2. Set all other registers to 0 to

indicate those sensors are not used in the system.

These registers also indicate to the Vibe-IQ application which sensor data should be pushed to the BannerCDS

cloud. The application uses group pushing to optimize bandwidth and avoid pushing blank registers for unused

sensors in the system. Because of register constraints, sensors 31–35 and 36–40 are grouped. If you have 36

sensors, you will push registers for all 40. The Banner CDS application automatically hides empty registers.

The registers can be written to from a PLC.

Repeat these steps any time a sensor is added or removed from the system.

1. After the DXM reboot, wait one to two minutes.

2. From the DXM Configuration Software: Go to the Tools › Register View screen.

3. In the Write Registers section, set the starting register to a value between 7881 and 7920 to turn on the

sensors used in the system.

Set the Number of Registers to 40 to see them all at once.

4. Enter a 0 to turn a sensor off and enter the DXMR90 port number of the sensor (1, 2, 3, or 4) to turn it on.

5. Click Write registers to write your changes to the DXM.

Save and Upload the Configuration File

After making any changes to the configuration, you must save the configuration files to your computer, then

upload it to the device.

Changes to the XML file are not automatically saved. Save your configuration file before exiting the tool and

before sending the XML file to the device to avoid losing data. If you select DXM › Send XML Configuration to

DXM before saving the configuration file, the software will prompt you to choose between saving the file or

continuing without saving the file.

1. Save the XML configuration file to your hard drive by going to the File › Save As menu.

2. Go to the DXM › Send XML Configuration to DXM menu.

If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and

re-plug in the cable and reconnect the DXM to the software.

If the Application Status indicator is green, the file upload is complete.

If the Application Status indicator is gray and the green status bar is in motion, the file transfer is in

progress.

After the file transfer is complete, the device reboots and begins running the new configuration.

Push Information to BannerCDS

The DXMR90 can connect to the Web via Ethernet or an internal cell module. The controller pushes data from

the DXMR90 to be stored and displayed on a website.

The Banner platform for storing and monitoring the system’s data is https://bannercds.com. The Banner

Cloud Data Services website automatically generates dashboard content for the application that is populated

onto the Dashboard. Email alerts can be configured using the Alarms screen.

https://bannercds.com


To push data to the cloud, change register 844 to one (1).

For more information on creating accounts on and using the Banner Cloud Data Services (CDS) system, please

refer to the Banner CDS Quick Start Guide (p/n 201126).

Create a New Gateway
After you log into the Banner Cloud Data Services website, the Overview screen displays. Follow these steps to
create a new monitoring site.

1. Click on New Gateway (top right corner of the Overview screen).

Create a new Gateway for each DXM Controller that sends data to the web server.

A New Gateway prompt appears.

2. Verify Traditional is selected for the Gateway Type.

3. Enter a Gateway Name.

4. Select the Company from the drop-down list.

5. Copy the Gateway ID number located within the prompt window to your computer’s clipboard.

The Gateway ID number created by the web server is a required parameter in the configuration of the DXM.

The Gateway ID is the address the webserver uses to store the data pushed from the DXM.

6. Click Submit to close the prompt window.

Configure the DXM to Push Information to the Cloud
IMPORTANT: Do not adjust the Cloud Push Interval. The push frequency is controlled by the script. Adjusting the
cloud push interval through this configuration may result in excessive amounts of data being pushed to Banner
CDS.

1. Within the DXM Configuration Software, go to the Local Registers in Use screen.

2. Set the Value Type of register 844 to Constant and a value of 1 to enable the data push.

3. Go to the Settings › Cloud Services screen.

4. Set the Server name/IP to push.bannercds.com.

5. In the Web Server section, paste the Gateway ID copied from the BannerCDS configuration screen into the

appropriate field.

6. Use the File › Save menu to save the XML file to your hard drive.

7. Send the updated XML to the DXM Controller using the DXM › Send XML Configuration to DXM menu.

Upload the XML Configuration File to the Website
To upload an XML configuration file to the website, follow these instructions.

1. On the BannerCDS website, select Gateways on the Overview screen.

2. On the row displaying your Gateway, click the Details under View.

3. Select Edit Gateway.

The Edit Gateway prompt appears.

4. Click Select File under Update XML.

5. Select the file that was just updated to the DXM and click Open.

After the XML file is loaded into the webserver, the webserver uses the register names and configurations

defined in the configuration file. The same XML configuration file is now loaded on both the DXM and the

Website. After some time, the data should be seen on the website.

6. To view the data from the Gateway’s screen, click on the Details link for each Gateway.



The Gateway Details screen lists the Sensor objects and default Alarms for that gateway. You may view the

individual register information by selecting Registers.

Additional Information

Baselining a Motor

The script included with this guide uses the first 300 running data points (user adjustable by changing register

852) of a motor to generate a baseline and the statistics for determining warning and alarm threshold levels.

Create a new baseline when significant changes are made to the motor or vibration sensor, including

performing heavy maintenance, moving the sensor, installing a new motor, etc. This ensures that the system is

running as accurately as possible. Re-baselining a motor can be done from the DXM Configuration Software,

from the Banner CDS website, or from a connected host system.

Baseline a Motor Using the DXM Configuration Software

1. Go to the Local Registers › Local Registers in Use screen.

2. Use the arrows to select Registers.

The registers are labeled NX_Baseline (where X is the sensor number you want to baseline).

3. Select the appropriate register to reset and click Enter.

4. Change the value to 1 ,then click Enter three times.

The reset register value automatically returns to zero after the baseline is complete.

Baseline a Motor from the Banner CDS Website

1. On the Dashboard screen, select the appropriate Dashboard that was automatically created for your gateway

2. Within the Dashboard, click on the appropriate motor icon for the asset you would like to baseline.

3. Click View Item within the prompt that appears.

4. Scroll down within the tray that appears at the bottom of the screen, then click the Baseline switch to ON.

This automatically turns off after the baseline is complete.

5. Repeat these steps for each sensor that needs to be baselined.

Baseline a Motor from a Connected Host System
Example host systems may be a PLC or HMI.

1. Determine the sensor number X, where X is the sensor number 1–40 (sensor ID 11-50) to be re-baselined.

2. Write a value of 1 to register 320 + X.

Sensor Connection Status

The system tracks the connection status of a sensor. If a sensor times out, the sensor is put into a “status error”

state and is only checked once every four hours until after the system receives a good reading during one of

the four-hour intervals.

A sensor may have a status error if the radio signal has diminished and needs to be corrected or if the radio’s



power source has failed (such as needing a new battery). After the issue has been corrected, send a 1 to the

Sensor Discovery Local Register to force the system to check all sensors that are in the system. The system

immediately checks all sensors without having to wait for the next four-hour interval. The registers for status

and sensor discovery are:

Sensor Connection Status—Local Registers 281 through 320

Sensor Discovery—Local Register 832 (changes to 0 when complete, but can take 10 to 20 seconds)

Viewing Run Flags

The vibration monitoring solution also tracks when a motor is running. This feature can use additional action

rules to track on/off count or approximate motor run time. To view this information on the web, change the cloud

reporting and permissions.

The following registers are used to show if a sample has determined that the motor was running or not.

Motor Run Flag On/Off (0/1)—Local Registers 241 through 280

Adjusting the Sample Rate

The DXMR90 is a wired solution that can support more rapid sampling rates than a wireless solution. The

default sample rate for the R90 solution is 300 seconds (5 minutes). The sample rate is controlled by register

857. For the best performance:

Do not set a sample rate for less than 5 seconds, no matter how few sensors are in your network.

Set your sample rate for two seconds for each sensor in your system, up to 35 seconds or 15 sensors.

For more than 15 sensors, use a 35-second minimum sample rate.

Advanced Diagnostic Vibration Data

The MultiHop Vibration monitoring system includes access to additional advanced diagnostic data is available

that is not available with the Performance radio system. The added characteristics are based in the two large

frequency bands from 10 Hz to 1000 Hz and 1000 Hz to 4000 Hz and include Peak Acceleration (1000–4000

Hz), Peak Velocity Frequency Component(10–1000 Hz), RMS Low Frequency Acceleration(10–1000 Hz),

Kurtosis (1000–4000 Hz) and Crest Factor (1000–4000 Hz).

There are five additional characteristics from each axis for a total of 10 total registers per sensor. This data is

available in registers 6141– 6540 as shown in “Local Registers” on page 10.

In addition to the additional large band registers above, the system may collect Spectral Band data: RMS

Velocity, Peak Velocity, and Velocity Peak Frequency components from each of three bands that are generated

from Speed Inputs. The three bands center around the 1x, 2x, and 3x-10x running speeds entered in Hz into

the DXM Local Registers 6581–6620 (one register for each sensor). NOTE: Speed cannot be entered any faster

than once per hour to these registers.

To view the Spectral Band data, enable register 857 (change the value from 0 to 1) then view floating-point

registers 1001–2440 (36 registers per sensor). For more information, see “Local Registers” on page 10. For

more information about the Spectral Band information, refer to the VT2 Vibration Spectral Band Configuration

technical note (p/n b_4510565).

Adjusting Warning and Alarm Thresholds



These values are stored in non-volatile local registers so they remain through a power outage.

Temperature— The default temperature settings are 158 °F (70 °C) for warnings and 176 °F (80 °C) for

alarms. Temperature thresholds may be changed from the DXM Configuration Software, from the Banner CDS

website, or from a connected host system.

Vibration— After baselining is complete, warning and alarm thresholds are set for each vibration characteristic

on each axis automatically. To view those values, check registers 5181–5660 (12 registers per sensor). To

adjust those thresholds, use registers 7001–7320 (8 registers per sensor). Triggering a new baseline returns

these user-defined registers to zero.

Adjust the Thresholds Using the Configuration Software

1. Using the DXM Configuration Software, connect to the DXM Controller running the Vibration Application Guide.

2. Go to the Tools › Register View screen.

Temperature—The temperature warning and alarm thresholds are in registers 7681–7760 and are

labeled NX_TempW or NX_TempA, where X is the Sensor ID.

Vibration—The vibration warning and alarm thresholds are in registers 7001–7320 and are labeled

User_NX_XVel_Warning or User_NX_XVel_Alarm, etc., where X is the Sensor ID.

3. Use the right column and enter the starting register to change and the value to write to the register.

4. Click Write Registers.

5. Repeat steps 3 and 4 for any additional thresholds to change.

6. To modify up to 40 thresholds at a time, adjust the Number of registers underneath the starting register. Enter a

value for each register and click Write Registers when you are finished.

7. To return to using an original baseline value for a particular sensor:

Vibration— Set the user-defined register (7001–7320) back to 0.

Adjust the Threshold from the Banner CDS Website

1. On the Dashboard screen, select the appropriate Dashboard that was automatically created for your gateway.

2. Within the Dashboard, click on the appropriate motor icon for the asset you would like to adjust thresholds.

3. Click View Item within the prompt that appears.

4. Below the graphs, enter the values for the thresholds and click Update.

5. The Banner CDS updates the system’s settings the next time the Controller pushes to the cloud.

Scroll down within the tray that appears at the bottom of the screen and enter your desired values for the

thresholds into the respective numeric fields.

6. Click Update.Banner CDS updates the system settings the next time the gateway controller pushes to the

cloud.

7. Repeat these steps for each sensor threshold.

8. For the vibration thresholds, set the threshold back to 0 to return to using the original baseline values for a

particular sensor.

Adjust the Thresholds from a Connected Host System
Example host systems may be a PLC or HMI.



1. Write the appropriate value into the register where x is the Sensor ID.

Temperature—Value in °F or °C to registers 7680 + x for the temperature warning or 7720 + x for the

temperature alarm.

Vibration—Write to the following registers.

Register Description Register Description

7000 + (x – 

1) × 8
X-Axis Velocity Warning

7004 + (x – 

1) × 8
X-Axis Acceleration Warning

7001 + (x – 

1) × 8
X-Axis Velocity Alarm

7005 + (x – 

1) × 8
X-Axis Acceleration Alarm

7002 + (x – 

1) × 8
Z-Axis Velocity Warning

7006 + (x – 

1) × 8
Z-Axis Acceleration Warning

7003 + (x – 

1) × 8
Z-Axis Velocity Alarm

7007 + (x – 

1) × 8
Z-Axis Acceleration Alarm

2. For the Vibration values, to return to using an original baseline value for a sensor, set the user-defined register

(7001–7320) back to 0.

Alarm Masks

Warnings and alarms within the system are contained in a register for each sensor (up to 40 sensors) in local

registers 201–240.

These alarm masks are automatically recognized by Banner CDS, making it straightforward to create alerts

based on the alarm mask. However, a complete breakdown is provided here for using this data in a PLC or

other cloud system. The registers are labeled NXX VibMask where XX is the sensor number. The register value

is a decimal form of an 18-bit binary number with a value of 0 or 1 because each sensor could have up to 18

warnings or alarms.

Velocity alerts—Indicate low-frequency motor issues such as unbalance, misalignment, soft foot,

looseness, etc.

High-Frequency Acceleration alerts—Indicate early bearing failure, cavitation, and high-side gear

mesh, etc.

Acute alerts—Indicate quickly happening issues that occur after five consecutive (adjustable in register

853) running samples above the thresholds.

Chronic alerts—Indicate a long-term failure based on a 100-point moving average of running samples

above the thresholds.

The 18-bit binary masks are broken out as follows:



Bit Description Binary Mask

0 Warning – X-Axis – Acute Velocity (0/1) × 20

1
Warning – X-Axis – Acute Acceleration (Hi

Freq)
(0/1) × 21

2 Warning – Z-Axis – Acute Velocity (0/1) × 22

3
Warning – Z-Axis – Acute Acceleration (Hi 

Freq)
(0/1) × 23

4 Alarm – X-Axis – Acute Velocity (0/1) × 24

5
Alarm – X-Axis – Acute Acceleration (Hi Fr

eq)
(0/1) × 25

6 Alarm – Z-Axis – Acute Velocity (0/1) × 26

7
Alarm – Z-Axis – Acute Acceleration (Hi Fr

eq)
(0/1) × 27

8 Warning – X-Axis – Chronic Velocity (0/1) × 28

9
Warning – X-Axis – Chronic Acceleration (

Hi Freq)
(0/1) × 29

10 Warning – Z-Axis – Chronic Velocity (0/1) × 210

11
Warning – Z-Axis – Chronic Acceleration (

Hi Freq)
(0/1) × 211

12 Alarm – X-Axis – Chronic Velocity (0/1) × 212

13
Alarm – X-Axis – Chronic Acceleration (Hi 

Freq)
(0/1) × 213

14 Alarm – Z-Axis – Chronic Velocity (0/1) × 214

15
Alarm – Z-Axis – Chronic Acceleration (Hi 

Freq)
(0/1) × 215

16 Warning Temperature ( > 158°F or 70°C ) (0/1) × 216

17 Alarm Temperature ( > 176°F or 80°C ) (0/1) × 217

18-bit register binary mask
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0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

The Vibe Mask Registers display in decimal form and are the sum of the calculations shown in the right column

for each Sensor’s mask register. Note that any value greater than zero in registers 201 through 240 indicates a

warning or alarm for that particular sensor.

To know the exact warning or alarm, calculate the binary value from the decimal value, which can be done on

the Banner CDS site or can be done with a PLC or HMI. Multiple warnings and alarms may trigger on an event

depending on severity.

Local Registers
The Applications Guide files are shared by Banner Solutions Kits. Some registers described as Solutions Kit
functionality are only relevant for systems using the Banner Solutions Kits that use an HMI screen. The variable N
represents the sensor ID 1–40.

Name Register Range Description Cloud Push 
Default

 

 

 

 

Vibration Data

1 + (N – 1) × 
5

 

 

 

 

1–200

Z-axis velocity ✔

2 + (N – 1) × 
5 Z-axis high-frequency acceleration ✔

3 + (N – 1) × 
5 X-axis velocity ✔

4 + (N – 1) × 
5 X-axis high-frequency acceleration ✔

5 + (N – 1) × 
5 Temperature ✔

Vibration Mask 201 + (N – 1) 201–240 Bit-packed alarm message ✔

Run Flag 241 + (N – 1) 241–280 Motor running flag (0/1)  



Sensor Status 281 + (N – 1) 281–320 Connection status of sensor (128 = Conn
ected) ✔

Baseline 321 + (N – 1) 321–360 Trigger to re-baseline a sensor (0/1) Read/Write

 

 

 

 

Raw Register Data

1 + (N – 1) × 
5

 

 

 

 

361–560

 

 

 

 

Placeholder registers for script

 

2 + (N – 1) × 
5  

3 + (N – 1) × 
5  

4 + (N – 1) × 
5  

5 + (N – 1) × 
5  

Warning/Alarm Mas
ks  561–574

 

 

OR’d Alarm registers

 

Temp OR  575–576  

Status Radio OR  577–578  

Temperature Warnin
g 581 + (N – 1) 581–620 Individual temperature warning registers (

0/1)  

Temperature Alarm 621 + (N – 1) 621–660 Individual temperature alarm registers (0/
1)  

 

 

 

Run Thresholds Co
nstants

661 + (N – 1) 661–700

 

 

 

Threshold constant for motor run determi
nation

 

701 + (N – 1) 701–740  

741 + (N – 1) 741–780  

781 + (N – 1) 781–820  

Alert Warning Lights  825–830  



Sample Count  831
 

 

 

Solutions Kit functionality

 

Sensor Discovery  832  

Network Reformatio
n  833  

Sample Time  834

 

 

Push Count  835  

Sensors 1-10
Status  836  

Sensors 11-20 Stat
us  837  

Sensors 21-30 Stat
us  838  

Sensors 31-40 Stat
us  839  

Fast Sample Trigger  843  

Cloud Push Enable  844 Enable or disable cloud pushing  

First Run  851 Solutions Kit functionality (0/1, set to 0 to 
reinitialize settings)  

Baseline samples  852 Set number of samples for a baseline (de
fault 300)  

Acute Sample  853 Number of samples in a row for acute fau
lt (default 5)  

N/A  854 N/A  

Server Starting
Number  855 Server address starting number (default 1

1)  



 

Status Wait Time for
Dropout

 
 

856
Samples before re-checking a server that
dropped out of the system (default 48)  

Sample Rate  857 Rate, in seconds, for system to sample e
ach sensor (default 300)  

Spectral Banding O
n/Off  858 Enable or disable spectral banding  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1001 + (N – 
1) × 36

 

 

 

 

 

 

 

 

 

 

 

 

 

Z-axis velocity 1x band  

1003 + (N – 
1) × 36 Z-axis peak velocity 1x band  

1005 + (N – 
1) × 36 Z-axis velocity peak frequency 1x band  

1007 + (N – 
1) × 36 Z-axis velocity 2x band  

1009 + (N – 
1) × 36 Z-axis peak velocity 2x band  

1011 + (N – 
1) × 36 Z-axis velocity peak frequency 2x band  

1013 + (N – 
1) × 36 Z-axis velocity 3x-10x band  

1015 + (N – 
1) × 36 Z-axis peak velocity 3x-10x band  

1017 + (N – 
1) × 36

Z-axis velocity peak frequency 3x-10x ban
d  

1019 + (N – 
1) × 36 X-axis velocity 1x band  

1021 + (N – 
1) × 36 X-axis peak velocity 1x band  



 

Spectral Band Infor
mation (Floating Poi
nt Registers)

1023 + (N – 
1) × 36

 

 

1001–2440

X-axis velocity peak frequency 1x band  

1025 + (N – 
1) × 36 X-axis velocity 2x band  

1027 + (N – 
1) × 36 X-axis peak velocity 2x band  

1029 + (N – 
1) × 36 X-axis velocity peak frequency 2x band  

1031 + (N – 
1) × 36 X-axis velocity 3x-10x band  

1033 + (N – 
1) × 36 X-axis peak velocity 3x-10x band  

1035 + (N – 
1) × 36

X-axis velocity peak frequency 3x-10x ba
nd  

Site Survey  5001–5005 Solutions Kit registers for site survey  

Binding  5006–5007 Solutions Kit registers for binding  

 

 

Chronic Fault Trend
s 100 Point Moving 
Average

5021 + (N – 
1) × 4

 

 

 

5021–5180

Z velocity trend  

5022 + (N – 
1) × 4 Z acceleration trend  

5023 + (N – 
1) × 4 X velocity trend  

5024 + (N – 
1) × 4 X acceleration trend  

 

Visible Baseline and
Alarms

 

5181 + (N – 
1) × 12

 

5181–5660
Thresholds being used for alarms (Select
ed from learned or user- defined)

Push once a 
day at UTC 0
0:00



 

Learned Thresholds

 

5661 + (N – 
1) × 8

 

5661–5980

Thresholds from algorithm (used in 5181-
5660 if equivalent user thresholds in 7001
-7320 are set to 0)

 

Scaled Temp Readi
ng

5981 + (N – 
1) 5981–6020 Placeholder registers for script  

Additional Vibration 
Registers

6141 + (N – 
1) × 10 6141–6540 Z-axis peak acceleration  



 

6142 + (N – 
1) × 10

 

X-axis peak acceleration  

6143 + (N – 
1) × 10

Z-axis peak velocity frequency
component  

6144 + (N – 
1) × 10

X-axis peak velocity frequency componen
t  

6145 + (N – 
1) × 10 Z-axis RMS low acceleration  

6146 + (N – 
1) × 10 X-axis RMS low acceleration  

6147 + (N – 
1) × 10 Z-axis kurtosis  

6148 + (N – 
1) × 10 X-axis kurtosis  

6149 + (N – 
1) × 10 Z-axis crest factor  

6150 + (N – 
1) × 10 X-axis crest factor  

Speed Input (Hz) 6581 + (N – 
1) 6581–6620 Speed input in Hz for spectral banding re

gisters  

 

User Defined Thres
holds

 

7001 + (N – 
1) × 8

 

7001–7320
User-defined vibration thresholds (will ov
erride learned thresholds)  

Saved Count/Mean/
StdDev

7321 + (N – 
1) × 9 7321–7680 Solutions Kit functionality  

Temp Warn Thresho
lds

7681 + (N – 
1) 7681–7720 User-defined temperature warning thresh

olds
 

Push once a 
day at UTC 0
0:00 / Write

Temp Alarm Thresh
olds

7721 + (N – 
1) 7721–7760 User-defined temperature alarm

thresholds

 

DXMR90 Port
Numbering

 

7881 + (N – 
1)

 

7881–7920

Default to zero, meaning no sensor. Set t
o 1–4 to indicate the port number of the s
ensor attached. Used to keep timeouts lo
w, reducing server IDs talked to by the sy
stem.
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