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Model: LT12

1. INTRODUCTION

This manual provides comprehensive instructions for the safe and efficient operation of your EazeID
LT12 Label Maker. Please read this manual thoroughly before using the device and retain it for future
reference.

2. CONTENTS CHECKLIST

Verify that all items listed below are included in your package:

1 × EazeID LT12 Handheld Labeler

1 × PZ Label Tape (12mm × 4M)

1 × Type-C Cable

1 × User Manual

1 × Quick Start Guide

1 × Colorful Packaging Box
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Figure 2.1: Package Contents of the EazeID LT12 Label Maker.

Your browser does not support the video tag.

Video 2.1: Unboxing the EazeID LT12 Label Maker. This video demonstrates the contents of the package and initial
handling of the device.

3. PARTS DESCRIPTION

Familiarize yourself with the components of your EazeID LT12 Label Maker:



Figure 3.1: Front view of the EazeID LT12 Label Maker.

LCD Screen: Displays text, settings, and preview of labels. Features a backlight for visibility in
low-light conditions.

QWERTY Keyboard: For efficient text input.

Power Button: Turns the device on or off.

Print Button: Initiates the label printing process.

Clear Button: Clears text or settings.

Delete Button: Deletes characters one by one.

Esc Button: Exits current menu or operation.

OK Button: Confirms selections.

Navigation Buttons: Used to move the cursor and navigate menus.

Settings Button: Accesses device settings.

Insert Button: Inserts symbols, units, or date.

Format Button: Changes label size, style, borders, alignment, and vertical printing.

File Button: Saves or opens labels.



Shift Key: Used in combination with other keys for uppercase letters, numbers, and symbols.

Caps Lock: Toggles uppercase/lowercase input.

A/a Button: Switches between uppercase and lowercase characters.

Accented Characters Button: Accesses accented characters.

Space Bar: Inserts a space.

Type-C Port: For charging the device.

Flashing Indicator: Shows charging status and other notifications.

Reset Button: Resets the device (use a pin to press).

Cutter: Manually cuts the printed label.

Label Exit: Where the printed label emerges.

Tape Cassette Compartment Cover: Protects the tape cassette.

Your browser does not support the video tag.

Video 3.1: EazeID LT12 Label Maker - Exterior Details and Tips. This video highlights the various physical features
and components of the label maker.

4. SETUP

4.1 Charging the Device

The EazeID LT12 Label Maker is powered by a robust 1200mAh lithium battery. Use the provided
Type-C cable to charge the device. The power indicator light will go out once fully charged.



Figure 4.1: Rechargeable feature of the LT12 with Type-C port.

Your browser does not support the video tag.

Video 4.1: Quick Label Maker Comparison LT12 vs LT100H. This video demonstrates the Type-C charging of the
LT12, highlighting its convenience compared to battery-operated models (0:36-0:56).

4.2 Installing the Tape Cassette

1. Open the tape cassette compartment cover.

2. Ensure that the end of the tape passes through the tape guide.

3. Install the tape cassette firmly into the compartment.

4. Pull out a section of the label about 1 inch (3cm) from the paper outlet.

5. Close the tape cassette compartment cover.



Figure 4.2: Proper installation of the tape cassette.

4.3 Initial Settings

Before first use, or if you need to adjust settings, follow these steps:

Language: Press Settings → [Language] → OK → Select a language → OK. By default, the
language is set to English. The machine comes with 23 built-in languages.

Feed: Press Settings → [Feed] → OK. This feeds a small amount of tape.

Bluetooth: Press Settings → [Bluetooth] → OK → [ON] → OK. By default, Bluetooth is off.

Label Length: Press Settings → [Label Length] → OK → Select a value → OK. Auto adjusts
label length to text. You can also manually set the length.

Your browser does not support the video tag.

Video 4.2: EazeID LT12 Label Maker - Detailed User Guide. This video demonstrates initial settings including
language, feed, Bluetooth, and label length (0:00-0:56).

5. OPERATING INSTRUCTIONS

5.1 Text Entry



Use the QWERTY keyboard for efficient text input. The backlit LCD screen ensures clear visibility.

Figure 5.1: Backlit LCD screen and QWERTY keyboard for easy text entry.

Your browser does not support the video tag.

Video 5.1: Quick Label Maker Comparison LT12 vs LT100H. This video demonstrates the typing speed and clarity
of the LT12's QWERTY keyboard and backlit screen compared to an older model (1:00-1:29 for keyboard, 2:17-2:33

for backlight).

5.2 Inserting Symbols and Date

To enhance your labels, you can insert various symbols and the current date:

Symbols: Press Insert → [Symbols] → OK → Select a category → OK → Select a symbol →
OK.

Date: Press Insert → [Date] → OK → Choose a date format → OK.

Your browser does not support the video tag.

Video 5.2: EazeID LT12 Label Maker - Detailed User Guide. This video demonstrates how to insert symbols and
dates into your labels (0:57-1:51).

5.3 Formatting Labels

Customize the appearance of your labels using the Format menu:

Press Format to access options.

Size: Adjust the length of the label (Auto, Small, Medium, Large).

Style: Adjust the style of the font (Normal, Bold, Italic, Bold&Italic).

Borders: Select a decorative frame to add to your label.

Alignment: Adjust text format (Align Left, Align Center, Align Right).

Vertical: Set up vertical printing (ON/OFF).

Your browser does not support the video tag.

Video 5.3: EazeID LT12 Label Maker - Detailed User Guide. This video demonstrates how to format labels,
including size, style, borders, alignment, and vertical printing (1:52-3:26).

5.4 Saving and Opening Labels

You can save your labels for future use and access them later to edit and print them.

Save: Press File → [Save] → OK → Select a save destination → OK. You can save up to 9
files, each with a maximum of 100 characters.



Open: Press File → [Open] → OK → Select a saved file → OK.

Your browser does not support the video tag.

Video 5.4: EazeID LT12 Label Maker - Detailed User Guide. This video demonstrates how to save and open labels
(3:27-4:22).

5.5 Text Editing

Edit your text efficiently with these functions:

New Line: Press A/a to start a new line. The maximum number of lines for 0.47" (12 mm) tape
width is three lines.

Delete Text and Format:

1. Delete one by one: Use the Delete button.

2. Delete one character at a time: Use the Delete button.

3. Delete all characters: Press Clear → [Text Only] → OK.

Upper-Case & Lower-Case: Press A/a to switch between uppercase and lowercase
characters.

Accented Characters: Select text you wish to convert to accented characters, then press A&N
→ Select a value → OK.

Your browser does not support the video tag.

Video 5.5: EazeID LT12 Label Maker - Detailed User Guide. This video demonstrates various text editing functions
(4:23-5:47).

5.6 Shift Key Operations

By using the Shift key combination, the following operations can be performed:

1. Insert numbers and symbols: Press and hold Shift when pressing a letter or number key to
type an uppercase letter or the symbol marked on the number key.

2. Multiple Editing: Allows editing multiple labels sequentially.

3. Multiple Printing: Select 1-9 print copies.

4. Quickly locate the initial and final positions of text: Use Shift + Navigation buttons.

Your browser does not support the video tag.

Video 5.6: EazeID LT12 Label Maker - Detailed User Guide. This video demonstrates operations using the Shift
key, including inserting numbers/symbols, multiple editing, multiple printing, and quick text navigation (5:48-7:44).

5.7 App Connection and Features

Connect your LT12 Label Maker to the "Print Master" app via Bluetooth for extended customization
options.

1. Download the "Print Master" app from your device's app store.

2. Ensure Bluetooth is enabled on your label maker and smartphone.

3. Open the app and connect to the LT12 printer.

4. Utilize the app to access 1600+ icons, 163 fonts, and 287 border styles.

5. Generate and print barcodes or QR codes directly through the app for inventory management
or tracking.



Figure 5.2: Bluetooth connection and app usage for the LT12 Label Maker.

Your browser does not support the video tag.

Video 5.7: Quick Label Maker Comparison LT12 vs LT100H. This video demonstrates the app connection process
and basic label creation using the app (2:34-3:13).

6. MAINTENANCE

Proper maintenance ensures the longevity and optimal performance of your label maker.

6.1 Cleaning the Print Head

If print quality degrades (e.g., faint lines, missing dots), clean the print head:

1. Turn off the label maker.

2. Open the tape cassette compartment cover.

3. Gently wipe the print head with a cotton swab lightly moistened with isopropyl alcohol.

4. Allow the print head to dry completely before closing the cover and resuming use.

6.2 Cleaning the Cutter



If labels are not cut cleanly, the cutter blade may have adhesive residue:

1. Turn off the label maker.

2. Open the tape cassette compartment cover.

3. Carefully use a dry cotton swab to remove any visible adhesive or debris from the cutter blade.
Avoid touching the blade directly with your fingers.

4. Close the cover.

6.3 Storage

Store the label maker in a cool, dry place away from direct sunlight and extreme temperatures.
Remove the tape cassette if the device will not be used for an extended period.

7. TROUBLESHOOTING

If you encounter issues with your EazeID LT12 Label Maker, refer to the following common problems
and solutions:

Problem Possible Cause Solution

Device does
not power
on.

Low battery or no
charge.

Connect the label maker to a power source using the
Type-C cable and charge it.

Faint or
incomplete
print.

Print head is dirty or
tape is incorrectly
installed.

Clean the print head (see Section 6.1). Reinstall the tape
cassette, ensuring it is properly seated and tape is fed
correctly.

Labels are
not cutting
cleanly.

Cutter blade is dirty or
dull.

Clean the cutter blade (see Section 6.2). If the issue
persists, the blade may need replacement.

Bluetooth
connection
fails.

Bluetooth is off on the
device or phone, or
interference.

Ensure Bluetooth is enabled on both the label maker and
your smartphone. Move closer to the device. Restart
both devices.

Label tape
gets
jammed.

Tape is not installed
correctly or is damaged.

Open the tape compartment, remove the cassette, clear
any jammed tape, and reinstall the cassette correctly.

8. SPECIFICATIONS

Feature Description

Product Dimensions 2"D x 1"W x 1"H



Item Weight 10.1 ounces (0.63 Pounds)

Model Number LT12

Brand EazeID

Connectivity
Technology

Bluetooth

Printing Technology Thermal

Maximum Media Size 0.47 inch (12mm)

Printer Output Monochrome

Max Print Speed
(Monochrome)

10 mm/s

Special Features
Backlit LCD Screen, Bluetooth Connectivity, Portable Handheld, QWERTY
Keyboard, Rechargeable Battery

Battery 1 Lithium Ion battery required (included)

Control Method App, Keyboard

Ink Color Black (Thermal printing requires no ink)

Warranty Type Limited

Feature Description

9. WARRANTY AND SUPPORT

Your EazeID LT12 Label Maker comes with a limited warranty. For specific warranty details, please
refer to the documentation included in your product packaging or contact EazeID customer support.
Product support is included with your purchase. If you have any questions, require assistance, or
need to report an issue, please contact the seller directly through the Amazon platform. The seller,
Eazeid, aims to provide quick responses and support within 24 hours.
To contact the seller on Amazon:

1. Go to the product page on Amazon.

2. Click on the seller's name (Eazeid).

3. Click the "Ask a question" button to send a message.



Figure 9.1: How to contact the seller on Amazon for support.

© 2024 EazeID. All rights reserved.
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Quin LT12 Portable Label Maker Quick Start Guide
This guide provides instructions for the Quin LT12 Portable Label Maker, covering printing from the
device, mobile app connectivity via Bluetooth, charging, and replacing the label cassette. Includes
steps in English.

Cudy Router Quick Installation Guide
A guide to installing and setting up your Cudy router, including SIM card insertion, LED status
checks, connection methods (Wi-Fi and wired), and initial configuration steps.

Snow Joe 24V-LT12-LTE Cordless Trimmer + Edger Operator's Manual
This manual provides essential safety instructions, operating guidelines, and maintenance tips for
the Snow Joe 24V-LT12-LTE Cordless Trimmer + Edger. Learn how to safely assemble, use, and
care for your trimmer and edger for optimal performance and longevity.

Cudy 4G/5G Router Quick Installation Guide
Step-by-step instructions for installing and configuring your Cudy 4G/5G router, including SIM card
setup, network connection, and initial setup via web interface.
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Cudy 4G/5G Router Quick Installation Guide
Comprehensive guide for setting up Cudy 4G/5G routers, covering antenna installation, SIM card
insertion, power connection, LED status, network configuration via Wi-Fi or Ethernet, and SIM PIN
entry. Includes EU Declaration of Conformity and support information.

Cudy Networking Product Guide: Routers, Mesh, 5G, Wi-Fi 6, Switches & More
Explore the comprehensive Cudy Networking Product Guide featuring a wide range of Wi-Fi
routers, mesh systems, 5G/4G devices, access points, switches, adapters, and accessories.
Discover advanced networking solutions for home and business.
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Innovative Labeling Solutions LT Label Maker User Manual Thank you for choosing
our label maker here in after referred to as the Label Maker . The label maker
produces professional, high-quality, durable labels. In addition, the variety of tape
cartridges available allows you to print label...
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