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What is BlackBerry Edit?

BlackBerry Edit is a mobile document management app for smartphones and tablets. With BlackBerry Edit you
can easily view, edit, create, present and share Microsoft Office quality documents using your mobile device.

Getting started with BlackBerry Edit

In the BlackBerry Edit app, you can create Microsoft Word documents, Microsoft Excel spreadsheets, and
Microsoft PowerPoint presentations.

Install BlackBerry Edit and activate using an access key, activation password, or QR code

Complete this task if you have not installed the BlackBerry UEM Client on your device and your administrator

has not allowed the BlackBerry UEM Client to manage the activation of BlackBerry Dynamics apps, you do not

have another BlackBerry Dynamics app already activated on your device, or you choose to activate the app

using an access key, activation password, or QR code.

To get the activation credentials, choose one of the following options:



Request an access key, activation password, or QR code from your administrator. Your administrator will send

you an email with the activation details.

Generate an access key, activation password, and QR code from your organization’s self-service portal. If you

do not know how to access your self-service portal, contact your administrator.

Note: If allowed by your organization, you can activate BlackBerry Edit using Easy Activation. An Easy Activation
key, when permitted, is supplied by another BlackBerry Dynamics app, like BlackBerry Work or BlackBerry
Connect, as long as these apps are already installed and activated on your device. If available, you can
activate BlackBerry Edit using the container password for the activation app.

1. Request the activation credentials from your administrator or generate your own from your organization’s self-

service portal.

2. After you receive the email message with the activation credentials or have generated your own in the self-

service portal, download and install BlackBerry Edit from the App Store.

3. Tap BlackBerry Edit.

4. Tap Client End User License Agreement to read the license agreement and, if you accept the terms, tap I

Agree.

5. Complete one of the following tasks:

Activation method                           Steps

Access key                                        a. In the Email Address field, type the email address located in the acti

vation email message that you received from your administrator or type your work email address if you gener

ated your own access key.

b. In the Activation password field, enter the access key, without hyphens, that is in your activation email 

message that you received from your administrator or enter the access key that you generated in the BlackB

erry UEM Self-Service. The access key is not case sensitive.

c. Tap Enter on the device.

*



Activation method                           Steps

Activation password                           a. In the Email Address field, type the email address that is in the

activation email message that you received from your administrator or type your work email address if you g

enerated your own activation password.

b. In the Activation password field, enter the activation password that is in your activation email message t

hat you received from your administrator or enter the activation password that you generated in the BlackBer

ry UEM Self-Service.

c. Tap Enter on the device.

QR code                                           a. Tap Use QR code.

b. Tap OK to give BlackBerry Edit access to the camera.

c. Scan the QR code in the activation email that you received in the activation email from your administrator 

or that you generated in the BlackBerry UEM Self-Service.

Optionally, you can tap Advanced Settings and enter your email address, access key or activation password,

and the BlackBerry UEM address.

6. If prompted, create and confirm a password for BlackBerry Edit. If your device is equipped with Touch ID, you

can turn on this option to use instead of the password, except on initial startup.

7. If prompted, allow BlackBerry Edit to use your location history to establish trusted locations.

8. Tap the BlackBerry Dynamics Launcher in the lower-right of the screen to start using BlackBerry Edit.

Install and activate BlackBerry Edit when the BlackBerry UEM Client or another BlackBerry Dynamics app
is already activated

If you have installed and activated the BlackBerry UEM Client app on your device and your administrator has
allowed the BlackBerry UEM Client to manage the activation of BlackBerry Dynamics apps or you have an
existing BlackBerry Dynamics app already activated on your device, you do not have to use access keys or QR
code to activate BlackBerry Edit or any other BlackBerry Dynamics app that you want to install.

1. If the app was not automatically pushed to your device by your administrator, open your Work Apps app and

install the BlackBerry Work app. If you do not see the BlackBerry Work app in your Work Apps app, contact

your administrator to make the app available to you.

Note: If your administrator did not make the app available to you, you can download and install the BlackBerry

Edit app from the App Store. However, the application will not activate.

2. Tap Edit.

3. Tap Client End User License Agreement to read the license agreement and, if you accept the terms, tap I

Agree.

4. Tap Allow to allow BlackBerry Edit to send notifications.

5. Tap Set up using <BlackBerry UEM Client or BlackBerry Dynamics app that is installed and activated on the

device>.

*



6. Enter your password for the BlackBerry UEM Client or BlackBerry Dynamics app that is installed and activated

on the device and tap Enter.

Create a file

In the BlackBerry Edit app, you can create Microsoft Word documents, Microsoft Excel spreadsheets,
and Microsoft PowerPoint presentations.

1. Tap  .

2. Tap Create New.

3. Do one of the following

Task                                               Steps

Create a new file using a blank             Tap one of the existing options: template                                           • 

   .docx

•        .doc

•        .pptx

•        .ppt

•        .xlsx

•        .xls

Create a new file using an                     a. Tap Templates.

existing template                                b. Tap one of the existing templates.

Open a file

1. Tap My Documents.

2. Tap the file that you want to open.

Delete a file

1. Tap My Documents.

2. Tap the file that you want to delete.

3. Tap the delete icon.

4. Tap Delete.

Copy a file

1. Tap My Documents.



2. Tap the file that you want to copy.

3. Tap the copy icon.

4. Tap the location where you want to store the copied version of the file.

5. Type a name for the file.

6. Tap Copy.

Rename a file

1. Tap My Documents.

2. Tap the file that you want to rename.

3. Tap the rename icon.

4. Type a new name for the file.

5. Navigate to the location where you want to store the file.

6. Tap Rename.

Change the font or formatting in a file

1. Open the file that you want to edit.

2. Tap inside the file.

3. Click File > Edit.

4. Double-tap on the text or cell that you want to format. If necessary, move the selection pins to adjust the

selection.

5. Do any of the following:

1. Tap on the font field and select a new font type.

2. Tap the + or – icons to make the text larger or smaller.

3. Tap one of the formatting icons, such as bold or italic.

6. Click Edit > File > Save

Cut, copy, and paste text in a file

1. Open the file that you want to edit.

2. Click File > Edit.

3. Double-tap on the text or cell that you want to cut, or copy. If necessary, move the selection pins to adjust the

selection.

4. Select an action for the highlighted text.

5. 5. When you are done, click Edit > File > Save.

6. 

             Option     Action

Cut          Tap the cut icon.

Copy       Tap the copy icon.

Paste         Tap and hold where you want to paste the text that you copied or cut, and tap the paste icon.



Insert an image, photo, or shape

1. Open the presentation that you want to add an image, photo or shape to.

2. Tap inside the presentation.

3. Tap  File > Insert.

4. Navigate to the page or slide that you want to insert an image, photo, or shape into.

5. Do one of the following:

1. To insert an image, tap the image icon, and browse to the image.

2. To insert a photo, tap the photo icon. When the camera app opens, take a picture of the image that you

want to insert. The BlackBerry Edit app adds the picture to your document.

3. To insert a shape, tap the shape icon and tap the shape that you want to insert.

6. When you are done, click Insert > File > Save.

Find text in a file

1. Open the file that you want to find the text in.

2. Tap inside the file.

3. Click Edit > Find.

4. Type the word that you want to find in the search field.

5. Click Next or Previous.

Save a file
When you are done working on your file, click File > Save.

Working with files that are stored in BlackBerry Edit

You can access files that you have stored in BlackBerry Share.

Before you begin: You must have BlackBerry Share installed on your device.

1. Open BlackBerry Share.

2. Do one of the following:

1. Tap Set up using BlackBerry Edit. Enter your password for BlackBerry Edit and press OK. Enter and

confirm a new password and press OK. On the End user license agreement, if you agree to the terms,

tap I Agree

2. Tap Set up using your Access Key. Enter your email address and access key and press OK.

3. Tap  .

4. Tap BlackBerry Share.

5. Navigate to and tap the file that you want to work on.

Using gestures
You can use the following gestures to help you edit the documents.



Gesture Description

Drag Pan around a page, or adjust the caret position

Pinch Zoom in or out on a page

Single tap Place the insertion caret

Double tap Select a word

Press and hold Temporarily zooms the page in

Editing documents in BlackBerry Edit

BlackBerry Edit makes it easy to edit and format documents. You can change the font, cut, copy and paste text
and markup changes.

View pages in a document

You can use the pages features to move through your document quickly.

1. Open the document that you want to edit.

2. Tap inside the document.

3. Click File > Pages.

4. Do any of the following:

1. To view the last page, tap the last page icon.

2. To view the first page, tap the first page icon.

3. To fit a page to the screen, tap the reflow icon.

4. To scroll through the pages in the document, use the thumbnails on the right-hand side.

Review a document

1. Open the document that you want to review.

2. Tap inside the document.

3. Click File > Review.

4. Do any of the following:

1. To track changes in the document, turn on Track changes.

2. To show changes in the document, turn on Show changes.

3. To add a comment to the document, tap Comment.

4. To accept a change to a document, tap the change and tap Accept.

5. To reject a change to a document, tap the change and tap Reject.

6. To skip to the next comment, tap Next.

7. To skip to the previous comment, tap Previous.

5. When you are done, click Review > File > Save.

Edit an Azure-IP RMS or AD-RMS protected file in BlackBerry Edit – iOS



BlackBerry Work Docs and BlackBerry Edit can work together to enable you to edit Azure-IP RMS protected files
in a secure enterprise File Share and from enterprise SharePoint, Box, and CMIS repository sites. The following
RMS protected file types are supported: .doc, .docx, .ppt, .pptx, .xls, and .xlsx.

Before you begin:

You must have the BlackBerry Work app 3.1 or later installed.

You must have the appropriate permissions to the Azure-IP RMS or AD-RMS protected file to complete tasks

such as edit, print, save, and cut-and-paste content in the file.

If the task requires four or more prerequisites, create a separate Prerequisites topic.

1. Open BlackBerry Work Docs and navigate to the protected file that you want to edit.

2. Tap   > Edit. The BlackBerry Edit app opens.

3. Edit the file.

4. Tap Save back to app and complete one of the following actions:

1. Tap Replace. The file is saved back to its original location with its original protection.

2. Change the file name and tap Save. The file is saved with the new name in the original location with the

original protection.

3. Tap Back. Navigate to a secure enterprise location to save the file with the original protection, tap Save.

Edit an Azure-IP RMS or AD-RMS protected file in BlackBerry Edit – Android

BlackBerry Work Docs and BlackBerry Edit can work together to enable you to edit Azure-IP RMS protected files
in a secure enterprise File Share and from enterprise SharePoint, Box, and CMIS repository sites. The following
RMS protected file types are supported: .doc, .docx, .ppt, .pptx, .xls, and .xlsx.

Before you begin:

You must have the BlackBerry Work app 3.1 or later installed.

You must have the appropriate permissions to the Azure-IP RMS or AD-RMS protected file to complete tasks

such as edit, print, save, and cut-and-paste content in the file.

1. Open BlackBerry Work Docs and navigate to the protected file that you want to edit.

2. Tap   > Edit. The BlackBerry Edit app opens.

3. Edit the file.

4. Tap Save To and complete one of the following actions:

1. Tap Save. If you are prompted that the file exists, complete one of the following actions:

2. Tap Yes. The file is saved back to its original location with its original protection.

3. Tap No. Rename the file and save or save the edited file to another enterprise location.

4. Tap Save as New Document. Save the file to a new secure enterprise location with the original

protection.

Editing spreadsheets in BlackBerry Edit

BlackBerry Edit makes it easy to edit and format spreadsheets. You can add or delete sheets, change the font or



formatting, and cut, copy and paste cells, rows, and columns.

Add or delete a sheet

Open the spreadsheet that you want to edit.

Tap inside the spreadsheet.

Do any of the following:

To add a sheet, at the bottom of the screen, tap +.

To delete a sheet, at the bottom of the screen, tap the sheet that you want to delete, tap X.

When you are done, click Save.

Use a formula

1. Open the spreadsheet that you want to use the formula in.

2. Tap inside the spreadsheet.

3. Click File > Formulas.

4. Tap on the cell that you want to add the formula to. If necessary, move the selection pins to adjust the

selection.

5. Select one of the formulas such as Date/Time or Engineering.

6. When you are done, click Formulas > File > Save.

Editing presentations in BlackBerry Edit

BlackBerry Edit makes it easy to edit and format presentations. You can add or delete slides, change the font or
formatting, and insert images, photos, or shapes.

Add or remove a slide

1. Open the presentation that you want to edit.

2. Tap inside the presentation.

3. Click File > Slides.

4. Use the thumbnails on the right-hand side to navigate to the slide that you want to delete or duplicate.

5. Long tap on the slide that you want to delete or duplicate.

6. Do one of the following:

1. Tap Delete to remove a slide from the presentation.

2. Tap Duplicate to add a slide from the presentation. After you have duplicated the slide, you can edit it to

include the appropriate information.

7. When you are done, click Slides > File > Save.

Edit a slide

1. Open the presentation that you want to edit.

2. Tap inside the presentation.

3. Click File > Edit.

4. Navigate to the slide that you want to edit.



5. Tap inside the slide to place the cursor where you want to edit the text.

6. When you are done editing, click Edit > File > Save.

Formatting shapes
Using the Format menu allows you to adjust a selected shape’s properties such as fill color, line color and width.
You can also move the item forward or backward on a slide

1. Open the presentation that you want to edit.

2. Tap inside the presentation.

3. Click Edit > Format.

4. Navigate to the slide that you want to format.

5. Tap the shape that you want to format.

6. Do one of the following:

1. In the Shape and line section, tap one of the options to change the fill color, line color, line weight, or line

style of the shape.

2. In the Arrange section, tap one of the options to change the position of the shape: send backward, send

to back, bring to front, bring forward.

7. When you are done editing, click Edit > File > Save.

Arranging slides

1. Open the presentation that you want to edit.

2. Tap inside the presentation.

3. Click File > Slides.

4. In the list of slides on the right-hand side of the page, tap, hold and drag the slide that you want to move to the

correct position in the presentation.

5. Release the slide.

6. When you are done, click Slides > File > Save.

View a slideshow

1. Open the presentation that you want to edit.

2. Tap inside the presentation.

3. Click File > Slides.

4. Tap the slideshow icon.

5. Swipe left or right to navigate through the slideshow.

6. To exit the slideshow, long press on the presentation.

Save a file as PDF

1. Open the file that you want to convert to a PDF.

2. Tap inside the file.

3. Tap Save PDF.

4. Select a place to store the file.

5. Tap Save.



Redact information from PDF files
Users can redact sensitive, confidential, or privileged information including text, images, and links from PDF files.

1. Open the PDF that you want to redact information from.

2. Tap  File > Redact and select the text that you want to redact.

3. Tap Mark text or Mark area.

1. The selected text or area is marked in red.

4. Tap Apply.

5. In the confirmation dialog, tap Yes.

1. Depending on whether your device is using light or dark mode, a black or white box appears over the

text.

6. Tap Save.

Printing files using a BlackBerry Dynamics printing app

Before you begin:

You must have your device configured to use a printer with a secure printing app that is compatible with

BlackBerry Dynamics products. A list of compatible printing apps can be found here.

Your administrator must have your organization’s policies configured to allow printing.

1. Open the file that you want to print.

2. Tap the print icon.

3. Tap the down arrow.

4. Select your options such as Copies, Paper size, and Orientation.

5. Tap the up arrow.

6. Tap Select a printer.

7. In the Add printer page, select an option.

Change your theme – iOS
On devices that are running iOS 13, you can change the theme for BlackBerry Dynamics apps using the iPhone
device settings. For instructions, see the iOS 13 documentation. For more information about supported operating
systems, see the Mobile/Desktop OS and Enterprise Applications compatibility matrix.

Change your theme – Android
If you switch to a dark theme, it changes the background that appears when you sign in to the app. By default, the
theme is Light.

1. In the app, open the BlackBerry Dynamics Launcher.

2. Tap Settings.

3. Tap Change application theme.

4. Tap a theme (for example, Light or Dark).

Legal notice



©2021 BlackBerry Limited. Trademarks, including but not limited to BLACKBERRY, BBM, BES, EMBLEM Design,
ATHOC, CYLANCE and SECUSMART are the trademarks or registered trademarks of BlackBerry Limited, its
subsidiaries and/or affiliates, used under license, and the exclusive rights to such trademarks are expressly
reserved. All other trademarks are the property of their respective owners.
Apple and App Store are trademarks of Apple Inc. Google Play is a trademark of Google Inc. Microsoft, Excel,
and PowerPoint are either registered trademarks or trademarks of Microsoft Corporation in the United States
and/or other countries. All other trademarks are the property of their respective owners.

This documentation including all documentation incorporated by reference herein such as documentation
provided or made available on the BlackBerry website provided or made accessible “AS IS” and “AS AVAILABLE”
and without condition, endorsement, guarantee, representation, or warranty of any kind by BlackBerry Limited
and its affiliated companies (“BlackBerry”) and BlackBerry assumes no responsibility for any typographical,
technical, or other inaccuracies, errors, or omissions in this documentation. In order to protect BlackBerry
proprietary and confidential information and/or trade secrets, this documentation may describe some aspects of
BlackBerry technology in generalized terms. BlackBerry reserves the right to periodically change information that
is contained in this documentation; however, BlackBerry makes no commitment to provide any such changes,
updates, enhancements, or other additions to this documentation to you in a timely manner or at all.

This documentation might contain references to third-party sources of information, hardware or software, products
or services including components and content such as content protected by copyright and/or third-party websites
(collectively the “Third Party Products and Services”). BlackBerry does not control, and is not responsible for, any
Third Party Products and Services including, without limitation the content, accuracy, copyright compliance,
compatibility, performance, trustworthiness, legality, decency, links, or any other aspect of Third Party Products
and Services. The inclusion of a reference to Third Party Products and Services in this documentation does not
imply endorsement by BlackBerry of the Third Party Products and Services or the third party in any way.

EXCEPT TO THE EXTENT SPECIFICALLY PROHIBITED BY APPLICABLE LAW IN YOUR JURISDICTION, ALL
CONDITIONS, ENDORSEMENTS, GUARANTEES, REPRESENTATIONS, OR WARRANTIES OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION, ANY CONDITIONS, ENDORSEMENTS,
GUARANTEES, REPRESENTATIONS OR WARRANTIES OF DURABILITY, FITNESS FOR A PARTICULAR
PURPOSE OR USE, MERCHANTABILITY, MERCHANTABLE QUALITY, NON-INFRINGEMENT, SATISFACTORY
QUALITY, OR TITLE, OR ARISING FROM A STATUTE OR CUSTOM OR A COURSE OF DEALING OR USAGE
OF TRADE, OR RELATED TO THE DOCUMENTATION OR ITS USE, OR PERFORMANCE OR NON-
PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD PARTY PRODUCTS AND
SERVICES REFERENCED HEREIN, ARE HEREBY EXCLUDED. YOU MAY ALSO HAVE OTHER RIGHTS THAT
VARY BY STATE OR PROVINCE. SOME JURISDICTIONS MAY NOT ALLOW THE EXCLUSION OR LIMITATION
OF IMPLIED WARRANTIES AND CONDITIONS. TO THE EXTENT PERMITTED BY LAW, ANY IMPLIED
WARRANTIES OR CONDITIONS RELATING TO THE DOCUMENTATION TO THE EXTENT THEY CANNOT BE
EXCLUDED AS SET OUT ABOVE, BUT CAN BE LIMITED, ARE HEREBY LIMITED TO NINETY (90) DAYS
FROM THE DATE YOU FIRST ACQUIRED THE DOCUMENTATION OR THE ITEM THAT IS THE SUBJECT OF
THE CLAIM.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, IN NO EVENT
SHALL BLACKBERRY BE LIABLE FOR ANY TYPE OF DAMAGES RELATED TO THIS DOCUMENTATION OR
ITS USE, OR PERFORMANCE OR NON-PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR
ANY THIRD PARTY PRODUCTS AND SERVICES REFERENCED HEREIN INCLUDING WITHOUT LIMITATION
ANY OF THE FOLLOWING DAMAGES: DIRECT, CONSEQUENTIAL, EXEMPLARY, INCIDENTAL, INDIRECT,
SPECIAL, PUNITIVE, OR AGGRAVATED DAMAGES, DAMAGES FOR LOSS OF PROFITS OR REVENUES,
FAILURE TO REALIZE ANY EXPECTED SAVINGS, BUSINESS INTERRUPTION, LOSS OF BUSINESS
INFORMATION, LOSS OF BUSINESS OPPORTUNITY, OR CORRUPTION OR LOSS OF DATA, FAILURES TO
TRANSMIT OR RECEIVE ANY DATA, PROBLEMS ASSOCIATED WITH ANY APPLICATIONS USED IN
CONJUNCTION WITH BLACKBERRY PRODUCTS OR SERVICES, DOWNTIME COSTS, LOSS OF THE USE
OF BLACKBERRY PRODUCTS OR SERVICES OR ANY PORTION THEREOF OR OF ANY AIRTIME
SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF COVER, FACILITIES OR SERVICES, COST OF
CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT SUCH DAMAGES WERE
FORESEEN OR UNFORESEEN, AND EVEN IF BLACKBERRY HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.



TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, BLACKBERRY
SHALL HAVE NO OTHER OBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR
OTHERWISE TO YOU INCLUDING ANY LIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.

THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE
NATURE OF THE CAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO
BREACH OF CONTRACT, NEGLIGENCE, TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND
SHALL SURVIVE A FUNDAMENTAL BREACH OR BREACHES OR THE FAILURE OF THE ESSENTIAL
PURPOSE OF THIS AGREEMENT OR OF ANY REMEDY CONTAINED HEREIN; AND (B) TO BLACKBERRY
AND ITS AFFILIATED COMPANIES, THEIR SUCCESSORS, ASSIGNS, AGENTS, SUPPLIERS (INCLUDING
AIRTIME SERVICE PROVIDERS), AUTHORIZED BLACKBERRY DISTRIBUTORS (ALSO INCLUDING AIRTIME
SERVICE PROVIDERS) AND THEIR RESPECTIVE DIRECTORS, EMPLOYEES, AND INDEPENDENT
CONTRACTORS.

IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY
DIRECTOR, EMPLOYEE, AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF
BLACKBERRY OR ANY AFFILIATES OF BLACKBERRY HAVE ANY LIABILITY ARISING FROM OR RELATED
TO THE DOCUMENTATION.

Prior to subscribing for, installing, or using any Third Party Products and Services, it is your responsibility to
ensure that your airtime service provider has agreed to support all of their features. Some airtime service
providers might not offer Internet browsing functionality with a subscription to the BlackBerry® Internet Service.
Check with your service provider for availability, roaming arrangements, service plans and features. Installation or
use of Third Party Products and Services with BlackBerry’s products and services may require one or more
patents, trademarks, copyright, or other licenses in order to avoid infringement or violation of third-party rights.
You are solely responsible for determining whether to use Third Party Products and Services and if any third-party
licenses are required to do so. If required you are responsible for acquiring them. You should not install or use
Third Party Products and Services until all necessary licenses have been acquired. Any Third Party Products and
Services that are provided with BlackBerry’s products and services are provided as a convenience to you and are
provided “AS IS” with no express or implied conditions, endorsements, guarantees, representations, or warranties
of any kind by BlackBerry and BlackBerry assumes no liability whatsoever, in relation thereto. Your use of Third
Party Products and Services shall be governed by and subject to you agreeing to the terms of separate licenses
and other agreements applicable thereto with third parties, except to the extent expressly covered by a license or
other agreement with BlackBerry.

The terms of use of any BlackBerry product or service are set out in a separate license or other agreement with
BlackBerry applicable thereto. NOTHING IN THIS DOCUMENTATION IS INTENDED TO SUPERSEDE ANY
EXPRESS WRITTEN AGREEMENTS OR WARRANTIES PROVIDED BY BLACKBERRY FOR PORTIONS OF
ANY BLACKBERRY PRODUCT OR SERVICE OTHER THAN THIS DOCUMENTATION.
BlackBerry Enterprise Software incorporates certain third-party software. The license and copyright information
associated with this software is available at .https://www.blackberry.com/us/en/legal/third-party-software
BlackBerry Limited 2200 University Avenue East Waterloo, Ontario Canada N2K 0A7 BlackBerry UK Limited
Ground Floor, The Pearce Building, West Street, Maidenhead, Berkshire SL6 1RL United Kingdom
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