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ACOM 2020S Amplifier

Specifications:

Model: ACOM 2020S

Power Output: Outstanding HF Power Products

Latest Firmware Version: 1.9 (Released on 23.02.2024)

Compatibility: Compatible with all ACOM 2020S amplifiers produced

Software: ACOM Terminal S (for MS Windows only)

Product Usage Instructions

Firmware Update Procedure for ACOM 2020S Amplifiers
This instruction describes the firmware update procedure for the ACOM 2020S amplifier CPU module firmware.

Firmware Versions
The ACOM 2020S firmware versions history is detailed below:

1.3 – Base firmware version (25.11.2021)

1.4B – Improvements (12.10.2022)

1.9 – New functions and improvements (23.02.2024)

Prerequisites

Before updating the firmware, ensure compatibility with your hardware and boot loader revisions. Check

compatibility in Menu SERVICE -> ABOUT on the RCU of the amplifier. Consult your dealer if unsure.

We recommend updating to firmware version 1.9, which is compatible with all ACOM 2020S amplifiers

produced.

Uploading Firmware

To upload firmware, use the ACOM Terminal S software available for free download from www.acom-bg.com

for MS Windows systems.

The ACOM Terminal S software communicates with the amplifier via a special cable connected to the RCU

connector on the rear panel of the amplifier.

FAQ:

Q: Can I revert to an earlier firmware version?

A: Yes, when compatibility is confirmed, you can return to an earlier version of the firmware.

Q: Where can I find the latest firmware versions?

A: The latest firmware versions are available for free download at www.acom-bg.com.

Firmware Update Procedure for ACOM 2020S amplifiers
Technical Information
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OUTSTANDING HF POWER PRODUCTS

FIRMWARE UPDATE PROCEDURE FOR ACOM 2020S AMPLIFIERS

This instruction describes the firmware update procedure for ACOM 2020S amplifier (CPU module firmware).

1. Firmware

1.1. Firmware Versions
The history of available ACOM 2020S firmware versions is shown in Table 1-1 | ACOM 2020S firmware versions
history.

Table 1-1 | ACOM 2020S firmware versions history



Version Release Date Amplifier CPU Module firmware / Notes

1.3 25.11.2021 Base firmware version;

1.4B 12.10.2022 Improvements;

1.9 23.02.2024

–  NEW function: “Active automatic protection”

–  Improve input power calculation

–  CAT interface: properly set power before tune

–  Increase threshold for 5V max

–  YAESU CAT interface: restore MIC gain after tune

–  Improve code readability and add HW division (These changes are purely in
ternal and have no effect on end user experience)

–  Disable Auto-Operate after Hard Fault Error

–  Fix: selection of polling time and byte spacing

Version Release Date RCU model R05 firmware / Notes

1.0 25.11.2021 Backend / Base firmware version;

1.1.1 06.2023 Backend / Firmware version with added tuner support;

1.0 25.11.2021 Interface / Base firmware version;

1.1.1 06.2023 Interface / Firmware version with added tuner support;

Table 1-1 | ACOM 2020S firmware versions history

The new firmware is issued as a file, for example, ACOM_2020S_CPU_H1.2_FW V1.9 – 23.02.2024.DAT.
The latest firmware versions for our products are available at www.acom-bg.com free of charge.

Requirements

Before you change the firmware version, check the new version compatibility with the revisions of the hardware

and of the boot loader in your amplifier (see Menu SERVICE -> ABOUT on the RCU of the amplifier). If you

have any doubts about the versions, please,  consult your dealer before you undertake any action.

When ACOM issues a new firmware version, the user can upload it in the amplifier after he checks the

compatibility. When compatibility is confirmed a return to an earlier version is also possible.

We highly recommend updating your ACOM 2020S amplifier with firmware version 1.9. The ACOM 2020S

firmware version 1.9 is compatible with all ACOM 2020S amplifiers  produced.

For uploading (or backup) a firmware to ACOM 2020S you have to use the ACOM Terminal S software,

distributed by ACOM free of charge. You can download it from www.acom-bg.com.

The ACOM Terminal S is available for MS Windows operation systems only. ACOM Technical Support Team

can advise you om Terminal S use in the Windows  environment.

The ACOM Terminal S software (installed on your PC) communicates with the amplifier via a special cable (see

Figure 1-2 | Special cable for ACOM 2020S firmware update) connected to the RCU connector (see Figure 1-1 |

Amplifier rear panel – Connections).

http://www.acom-bg.com
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Figure 1-1 | Amplifier rear panel – Connections

In fact, the above special cable consists of 2 separate parts:

“USB to RS-232” converter cable;

The ACOM recommends using “USB to RS-232” converters produced by FTDI (www.ftdichip.com) or based

on an FTDI chip.

ACOM RS-232 interface cable with POWER ON button (cable made by ACOM).

For all owners of ACOM 2020S with firmware versions earlier than V1.9 (in-factory installed), ACOM company

will provide the special cable (as shown on Figure 1-2) for  firmware updates free of charge.  Please, contact

your dealer for cable availability and delivery.

Firmware Update Procedure 

http://www.ftdichip.com


The firmware update procedure below is based on a PC with Windows 11 operating system.

STEP 1 – RS-232 Interface Settings on your PC

Switch On your PC. Connect the special cable (see Figure 1-2 | Special cable for ACOM 2020S firmware

update) to any USB port on your computer, and do not connect the cable to the amplifier.

Go to Device Manager on your PC (right mouse click over Windows Start button -> Device Manager). The

converter’s driver should be installed automatically, and you can see a situation similar to Figure 1-3 | PC

Device Manager (if driver installation is OK).

Make sure that the correct (newest) driver for your hardware is installed.

Remember the serial (RS-232) port number.

Go to Serial port Properties (right mouse click over Device Manager -> Ports -> USB Serial Port -> Properties).

You can see a situation similar to this:



Go to Port Settings tab -> Advanced tab and change Latency Timer parameter to 1 msec.

Restart your PC



STEP 2 – Amplifier Settings

When the amplifier is turned on, check the menu USER PREFERENCES -> AUTO OPERATE. The status must be
OFF. This is a necessary condition for a successful start of Firmware Update Procedure.

When the amplifier is turned on, push the POWER button on the RCU rear panel to turn off the amplifier (back

to low-energy STANDBY mode);

Switch off the amplifier via Main Power Switch (see Figure 1-8 | Rear panel);

Make sure the Main Power Switch is in OFF position;

Pull the amplifier’s line (mains) plug out of the outlet;

Do not disconnect GND connection;

Disconnect all cables (except GND connection) from the rear panel of the amplifier – RCU, transceiver,

antenna, etc.

The amplifier’s RCU is unnecessary for the firmware update procedure and should be disconnected.



Connect the special cable’s connector (D-sub, 15-pin, male) to the amplifier’s RCU connector (see Figure 1-8 |

Rear panel);

Check whether the amplifier rear panel Main Power Switch (marked ON/OFF) is turned off (must be). Insert the

amplifier’s mains plug into the wall outlet;

Switch on the amplifier via Main Power Switch (see Figure 1-8 | Rear panel);

Push and hold for 1-2 seconds the POWER ON button on the special cable (see Figure 1-9 |Special cable for

ACOM 2020S firmware update) to start the amplifier in the STANDBY mode.

If the amplifier starts normally there will be a couple of beeps from the amplifier.

STEP 3 – Using Terminal S software for Firmware Update

Exit all programs running on your computer and DISABLE/DEACTIVATE any antivirus software;

Start ACOM Terminal S software (We assume that you downloaded Terminal S software from www.acom-

bg.com and installed it on your PC);

http://www.acom-bg.com


Open the Settings window by clicking on the Settings icon (two gears) or use Tools -> Settings from the menu

bar. In the Settings window -> tab General, configure the settings as shown in Figure 1-11 | Terminal S – Tools -

> Setting -> General menu: – Command timeout (ms) 10000;

• In the Settings window -> tab Serial port, configure the settings as shown in Figure 1-12 |Terminal S – Tools ->

Setting -> Serial port menu. For actual serial port number see STEP 1 – RS-232 Interface Settings on your PC:

– Serial port settings 9600, 8, None, 1;



Connect ACOM Terminal S to the amplifier by clicking on the Connect icon (two connected plugs) or use Device

-> Connect from the menu bar;

When connected click on the Firmware Upload/Download icon (two arrows in opposite directions) or use

Device -> Firmware upload/download from the menu bar to activate the Bootloader;



When the bootloader has been activated there will be two beeps from the amplifier.

Click on the Disconnect icon (two separated plugs) or use Device -> Disconnect from the menu bar to

disconnect from the amplifier.

Open the Settings window by clicking on the Settings icon (two gears) or use Tools -> Settings from the menu

bar. In the Settings window -> tab Serial port, configure the settings as shown in Figure 1-16 | Terminal S –

Change Bits per Second:

– Serial port settings 34800, 8, None, 1  (change “Bits per second” parameter only); 



Re-connect to the amplifier by clicking on the Connect icon (two connected plugs) or use Device -> Connect

from the menu bar;

When connected click on the Firmware Upload/Download icon (two arrows in opposite directions) or use

Device -> Firmware upload/download from the menu bar to activate the bootloader. A Bootloader menu will

appear in the text box as shown below;



Press the U letter from your keyboard to activate the Firmware Upload process. Press the Y letter from your

keyboard to answer the question that appears:

CURRENT FIRMWARE WILL BE ERASED! ARE YOU SURE (N/N)?

A new dialog box will open asking for the new firmware file name and location. Open the folder that contains

the new firmware file (*.dat), select the file, and press the Upload button (We assume that you downloaded the

newest firmware from www.acom-bg.com and unzipped it on your PC);

The Upload firmware process may take approx. 3-6 minutes.

Press the B letter from your keyboard to activate the Firmware Backup process.

A new dialog box will open prompting you to enter a name and location for the new backup file. Press the

Download button to start the process;

http://www.acom-bg.com


The Backup firmware process may take approx. 3-6 minutes.

It is not obligatory to back up your current firmware because all firmware versions are available for download

from www.acom-bg.com.

Press the E letter from your keyboard to exit from the process. Click on the Disconnect icon (two separated

plugs) or use Device -> Disconnect from the menu bar to disconnect from the amplifier. Click on the File -> Quit

from the menu bar to close Terminal S;

Switch off the amplifier via Main Power Switch. Make sure the Main Power Switch is in OFF position;

http://www.acom-bg.com


Pull the line (mains) plug out of the outlet;

Disconnect the ACOM special cable;

Follow the instructions in Section Connections in ACOM 2020S User’s Manual to re-connect the amplifier to

your station;

You can check the current firmware version in the amplifier’s MENU SELECTION -> SERVICE -> ABOUT.

Troubleshooting

Sometimes the procedure for Firmware Update/Backup is unsuccessful.

A. Error Timeout when using Terminal S software

If you see an error message related to Timeout, please check:

Command timeout parameter as describer in Section 1.3 Firmware Update Procedure (STEP 3 –Using Terminal

S software for Firmware Update).

The other possible reasons for Timeout error could be, for example: 

Windows Device Manager -> USB Serial Converter Properties -> Advanced Below are shown the

recommended settings (VCP = Virtual Com Port):



Windows Device Manager -> USB Serial Converter Properties -> Power Management Below are shown the

recommended settings:

Windows Power plan

Below are shown the recommended settings:



B. If, for some reason (mostly human error), the Firmware Update/Backup process is interrupted, the
following scenarios are possible:

The amplifier is in STB mode but nothing happens when you press the Terminal S buttons. Solution:

Click on the Disconnect icon (two separated plugs) to disconnect from the amplifier;

Click on the File -> Quit from the menu bar to close Terminal S;

Switch off the amplifier via Main Power Switch on the rear panel and wait 10-15 seconds;

Switch on the amplifier again via Main Power Switch on the rear panel;

Push and hold for 1-2 seconds the POWER ON button on the special cable to start the amplifier;

Start Terminal S;

Start the Firmware Update procedure from the beginning.

The amplifier is in BOOTLOADER mode but nothing happens when you press the Terminal S buttons. Solution:

Click on the Disconnect icon (two separated plugs) to disconnect from the amplifier;

Click on the File -> Quit from the menu bar to close Terminal S;

Switch off the amplifier via Main Power Switch on the rear panel and wait 10-15 seconds;

Switch on the amplifier again via Main Power Switch on the rear panel;

Push and hold for 1-2 seconds the POWER ON button on the special cable to start the amplifier;

If the amplifier starts normal and goes to STB mode, then:

Start the Terminal S and continue with the Firmware Update procedure from the beginning;

If above step is unsuccessful this means that amplifier is in BOOTLOADER mode. Then re-start the

Terminal S and change Serial port settings to 38400, 8, None, 1;

Connect to the amplifier by clicking on the Connect icon (two connected plugs);

Click on the Firmware Upload/Download icon (two arrows in opposite directions) to activate the bootloader. A

bootloader menu should now appear in the text box;

Continue with the Firmware Update procedure as usual.

If the problem persists, contact your dealer (see Section Owner Assistance in ACOM 2020S User’s Manual). 



ACOM Ltd.
Bulgaria | Bozhurishte 2227
Sofia-Bozhurishte Industrial Park | 6 Valeri Petrov Str.
GPS coordinates: 42.748616о | 23.209801о
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