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Purpose of the Document
The purpose of this document is to explain the technical specifications and manual for using the USB dongle board
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Package contents

STM32 USB Dongle Package

« STM32F072C8T6 USB dongle.

Download

« Install STM32CubeProgrammer for Windows. https:/www.st.com/en/development-

tools/stm32cubeprog.html
« Arduino software can be downloaded from the following website: https://github.com/5ghub/stm32

« To use the board with Arduino IDE and start running Arduino projects and sketches, install the following
software: Install Arduino IDE for Windows from the following website
https://www.arduino.cc/en/Main/Software

« Download and Install LTE&GNSS modem driver for Windows OS: https://github.com/5ghub/5G-NB-
loT/tree/master/Driver

« Download and Install QNavigator and QCOM tools for Quectel BG95 here: https://github.com/5ghub/5G-NB-
loT/tree/master/Tools

General Description

Overview

This is a USB dongle powered by STM32 MCU. The USB is designed as a compact and complete development
platform for STMicroelectronics ARM cortex-MO core-based STM32F072C8T6 microcontroller with 12C, SPI,
USART, CAN, 12-bit ADC, 12-bit DAC, GP comparators, internal 16KB SRAM and 128KB Flash, USB FS, Touch
sensing, SWD debugging support. The USB is used as a standalone board or as a motherboard where other
daughter boards can be stacked on it. Daughter boards can be GNSS, Cellular, CAN transceiver, and other
modules. The USB leverages and utilizes all hardware features of STM32F072C8T6. The USB is designed for the
evaluation of all the peripherals and the development of user-specific applications. Extension headers are used to
easily connect a daughter board to it. The USB board is a rich hardware board that can be used for the 4G LTE
and GNSS wireless technology and enables a variety of smart applications for devices. It enables a large number
of applications such as wireless POS, smart metering, tracking, smart transportation, smart buildings, smart city,
and smart homes, CAN scanners, and On-Board vehicle Diagnostics (OBD). The board is also compatible with
Arduino and Arduino software (IDE). Arduino sketches and examples are provided with the kit and additional
sketches can be developed and uploaded to the board.

Key Features
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« STM32F072C8T6 MCU

« USB full-speed connector

« 5V USB power supply

« 12C, SPI, and UART interface

« CAN2.0A/B compliant interface

« SWD debug support

« Motherboard and daughter board switch button

« Extension connector for daughter board or wrapping board

« Analogue and Digital GPIOs

« Two user-programmable LEDs

« Compact board size of 59 mm x 25mm

« Arduino IDE Compatible

o Works with Windows or Linux

« Ready for smart applications and development (smart home, smart city, smart transportation, smart metering,
smart farming, smart waste management, asset tracking, location, navigation, mapping, and timing
applications). Applications such as Gas Detectors, Soil PH Testers, Optical Sensors, Machinery Alarm
Systems, Irrigation Controllers, Elevators, Asset Tracking Electronics, Person/Pet Tracking, Water/Gas

Metering, Smart Parking Systems, Fire Hydrants, Smoke Alarms, Trash Bins, Street Lighting

Overview Diagrams
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Figure 2. USB Modem Overview Diagram - Bottom View

Physical Characteristics
The width and length of the USB modem is 25 mm (width) by 59 mm (length). The board have two screw holes in
each corner that allows the board to be attached to a surface or case.
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Figure 3. Physical Characteristics.

Peripherals — Key Components
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Hardware Specification
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Figure 4. USB Modem Top Side — Key Components

Technical Specification

Microcontroller (MCU)

STM32F072C8T6, 32-Bit ARM Cortex MO+

Clock Speed 48 MHz

Flash Memory 128 KB

SRAM 16 KB

NB-loT Module Quectel BG95-M2 or BG95-M2
Dimension 25 mm (width) by 60 mm (length)
Weight 20 grams

Power Supply USB (5V)

LED Power LED, LED1, LED2




Interfacing Logic Voltage Level

(Operating Voltage)

3.3V

Voltage output

5V, 3.3V

RESET buttons

Not Mounted

USB Switch

1 switch to connect to MCU directly or BG95 directly

General-purpose digital 1/0

32 (PAO-PA15, PBO-PB15)

Pins
uUSB 1
1°C 1
SPI 1
1 (with 1ISO7816 interface, LIN, IrDA, auto baud rate detection and
UART wakeup feature)
CAN 1
ADC pins 1 (12-bit ADC)
DAC pin 1 (12-bit DAC)

External interrupts

14 (All general-purpose PINs)

PWM pin

DC Current per 1/0O Pin

10 mA

JTAG Debug

Cortex Debug Connector (Single Wire Debug)

PIN Description

PIN DIRECTION

Description

USB Connector |

The USB modem is powered from the USB port (3.8V-5V)

LED1 (USER) o)

LED which can be controlled from MCU (D25). When the pin is

HIGH value, the LED is on, when the pin is LOW, it is off




LED which can be controlled from MCU (D26). When the pin is

LED2 (USER) © HIGH value, the LED is on, when the pin is LOW, it is off
USB Switch | 1 switch to connect to MCU directly or BG95 directly
3.3V generated by the on-board regulator. Maximum current drawn is 3A. T
he regulator also provides power to the MCU and
3.3V @) BGY5
5V generated from the board. The board is supplied with power
SV © from USB connector (typical 5V)
GND Ground
PA5_AIN5 10
PAG6_AIN5 10
PA7_AIN5 10
Six analog inputs which can provide up to 12 bits of resolution (i.e. 4096 diff
PBO_AINO 10 erent values). By default, each input measures from ground to 3.3 volts.
PB1_AIN9 10
SCL 10
SDA 10 12C. The SCL (clock line). Can be used as GPIO
SCK 10 I2C. The SDA (data line). Can be used as GPIO
MISO 10 SPI Interface. Can be used as GPIO
MOSI 10 SPI Interface. Can be used as GPIO
SS 10 SPI Interface. Can be used as GPIO
CAN Tx/Rx 10 CAN Interface. Can be used as GPIO
PA8/ PA9/ PA10 10 GPIO




Cortex Debug
10 GPIO. Can be used as GPIO

Connector
Using Single Wire Debug to burn bootloader and debug the

BOOQOTO I board
Connected to BG95. Force the BG95 to enter an emergency download
mode

Precaution

The USB modem runs at 3.3V. The maximum voltage that the I/O pins can tolerate is 3.3V. Applying voltages
higher than 3.3V to any I/O pin could damage the board

Using the Board with Arduino IDE

Installing the Software
To use the board with Arduino IDE and starts running Arduino projects and sketches, install the following software:

Setting Up the Board
Gently move the switch S1 left or right to make the USB port either connect to the Motherboard (STM32) or
daughter board.
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Setting Up STM32 Bootloader
Make sure to install STM32CubeProgammer. Do the following:

1. Connect a shunt into PIN4 and PIN3 on J4
2. Insert the USB dongle into USB port on a PC.

3. Launch Windows device manager, and you shall see the STM32 bootloader.



% Device Manager - a X
File Action View Help

s MEEmM B EXE

» i Batteries ~
> |@ Biometric devices
> ) Bluetooth
> Q Cameras
> B8 Computer
> ma Disk drives
@ Display adapters
B Firmware
> g Human Interface Devices
<= Imaging devices
I Jungo Connectivity
= Keyboards
£ 1 Memory technology devices
. Mice and other pointing devices
> [ Monitors
» 3 Network adapters
> @ Ports (COM & LPT)
» = Print queues
» = Printers
[ Processors
B Security devices
[3 Sensors
[ Software components
B Software devices
q' Sound, video and game controllers
G Storage controllers
Em System devices
> i Universal Serial Bus controllers
v § Universal Serial Bus devices
§ Billboard Device
§ Camera DFU Device
§ STM3Z BOOTLOADER o
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4. Launch the STM32CubeProgammer, select SUB, and click Connect. You shall see the STM32F072 connected.



STMEZCubeP rogrammar — [m] x |

Address OxDE000000 | =  Size 0400 Cata width  32-bit =  Find Data ox

Address L] 4 8 c
D Q8000000 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
D OB000010 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYWY VYWY
Q08000020 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYWYV Y Y Y Y YYY
D Q8000030 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF Y Y Y Y YY
Do OB000040 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYWY Y VYV Y
O 0B000050 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VY Y Yy
D OE0D00G0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYWY Y VYWY Y
OeDE0D00T0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
O 0B000080 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF W
Ox0E000090 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VWYYV Yy
O 0B000040 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VY Y Y Y Y Y YY
D OE0D00B0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VY Y Y Y YWY
eDE0D00CD FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYWY Y YV Y
O 0B0000D0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VY YYY Y Y Y YYYYYYY

Verbosity level @ 1

08:18:37 ¢ Size
01837 : Address

0E-18:37

Flead progress

08:18:37 : Time elapsed during the read cperation is 00:00:00.024

Setting Up Arduino IDE

1. Launch Arduino IDE and choose File->Preferences. In the Additional Boards Manager URLs, insert the

following URL:




STM32F0T2CETE -

5Ghub_bmeBBlasync ino
22 #include <STM32_board.h> |
23
24  #define SEALEVELPRESSURE_MPA (1013.25)
25
26 ff Using I2C Interface
27 _SGHUB_BMEGE@ bme;
28
28 wvoid setup()
! {
31 Wire.setSDA(PB11); ings
32 Wire.setSCL(PB18); )
33 Sketchbook _
3 serial.begin(115208); ¥ v m
s while (Serial.read() >= @ I8 Show files inside Sketche
36 Serial.println(F(“BMEGS8 | o fond cize i
37
3s if (lbme.Begin()) ey
30 { T e
48 Serial.println(F("BMEGSI e English =)
a1 while (1); % 7
a2 } I
43 N ~
44 figure B Ve e
45 bme.SetTemperatu W
46 bme . SetHumidityOv 8 Editor Quick Suggestions
a7 bme. SetPressureOversanplil R B e e Holt niem32duir - awimainic imicroe
as bme.SetTIRFi1tersize (BMES! ) o S i S ol i, s e o
ag bme.SetGasHeater(320, 158
58}
51
52 wvoid loop(} |
Output :)U‘N“‘ m =6

2. In Arduino IDE, choose Tools->Board->Boards Manager, select and install “STM32F072C8T6 Board”.
3. Choose “STM32F072C8T6”

Lnd, Col 1 STM3ZFOTZCETE oot connected] O B3
4. In the Arduino IDE, Choose Sketch->Include Library->Add .Zip Library and select the file STM32_Arduino.zip
5. You are ready now to use the Arduino IDE and write the first sketch. You can start compiling Arduino sketches
and upload the sketch to the USB dongle.
6. When uploading an Arduino sketch, make sure the following setting are selected:



Board: "STM32F072C8T6" b
Port: "COM5" b
Get Board Info

Debug symbols and core logs: "None” 4
Optimize: "Smallest (-Os default)” 4
Board part number: "STM32F072C8T6" »
C Runtime Library: "Newlib Nano (default)” L4
Upload method: "5STM32CubeProgrammer (DFU)" L4
USB support (if available): "CDC (generic ‘Serial’ supersede U(S)ART)" »

Burn Bootloader

7. After uploading an Arduino sketch, unplug the shunt, and re-insert the USB dongle again into the USB port.
Windows will recognize the USB dongle as a new COM port as show here:

% Device Manager - O X

File Action View Help

s @mE HEHEB EX®

v & LAPTOP-HOSSAMNEW ~
> | Audio inputs and outputs
> 4 Batteries
> & Biometric devices
v a Bluetooth
ﬁ Intel(R) Wireless Bluetooth(R)
® Cameras
8 Computer

== Disk drives

B Display adapters

i Firmware

Human Interface Devices

=% Imaging devices

& Jungo Connectivity

Keyboards

L 1 Memory technology devices

i Mice and other pointing devices

[ Monitors

¥ Network adapters

@ Ports (COM & LPT)
i Intel(R) Active Management Technology
i USB Serial Device (COM5)

» [ Print queues

y = Printers v

(V\-"VVVVVVVVVVV

8. In Arduino IDE, choose Port->COMS5.



User LED | Arduine IDE 2.1.1
Edit Sketch Tools Help

File

Now, you can enable the Arduino IDE Serial Monitor and see the Arduino sketch running on the board.

« NOTE: When uploading the Arduino sketch to the USB dongle, a shunt must be connected between PIN4 and

User LEL

B = 3 B ow R

S e e e
£ W K e D90

15

Auto Format

Archive Sketch

Manage Libranes... Cirl+5Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter

WIiFI101 / WiFiNINA Firmware Updater

Upload 551 Root Certificates

Board: "STM32F072C8TE"
Port: “COM3"

Get Board Info

Debug symbols and core logs: “None®

Optimize: "Smallest [-Os default)”

Board part number “STM32F0T2C8TE*

C Runtime Library: "Newlib Nana (default)”
Upload method: *5TM32CubeProgrammer {DFU)"

USB support (if available): "CDC (generic "Senal’ supersede U(SJART)"

Burn Bootloader

ITOUE PO LY, UOTPOT

pinMode(PB14,0UTPUT);

void loop()

I
L

PIN3 of J4 (i.e, the STM32 MCU must be in BOOT mode)

« NOTE: To run the Arduino sketch, unplug the shunt and re-insert the USB dongle into a USB port again.
« Copyright © 5GHUB.US

Documents / Resources

)
&Hle 5G HUB STM32F072C8T6 USB Mother Board [pdf] User Manual
SE STM32F072C8T6, STM32F072C8T6 USB Mother Board, STM32F072C8T6, USB Mother
Board, Mother Board, Board
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